summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'mail-client/mail-notification')
-rw-r--r--mail-client/mail-notification/mail-notification-5.4-r10.ebuild23
1 files changed, 11 insertions, 12 deletions
diff --git a/mail-client/mail-notification/mail-notification-5.4-r10.ebuild b/mail-client/mail-notification/mail-notification-5.4-r10.ebuild
index 6a021824142e..4c0b026eefaf 100644
--- a/mail-client/mail-notification/mail-notification-5.4-r10.ebuild
+++ b/mail-client/mail-notification/mail-notification-5.4-r10.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -17,9 +17,6 @@ LICENSE="GPL-3"
IUSE="+gnome-keyring libressl sasl ssl sylpheed"
LANGS="bg ca cs de es fr ja nl pl pt pt_BR ru sr sr@Latn sv"
-for lang in ${LANGS}; do
- IUSE+=" linguas_${lang}"
-done
# gmime is actually optional, but it's used by so much of the package
# it's pointless making it optional. gnome-keyring is required for
@@ -100,12 +97,14 @@ src_install() {
einstalldocs
rm -rf "${ED}/var/lib/scrollkeeper"
- einfo "Cleaning up locales..."
- for lang in ${LANGS}; do
- use "linguas_${lang}" && {
- einfo "- keeping ${lang}"
- continue
- }
- rm -Rf "${D}"/usr/share/locale/"${lang}" || die
- done
+ if [[ -n ${LINGUAS+set} ]]; then
+ einfo "Cleaning up locales..."
+ for lang in ${LANGS}; do
+ if has ${lang} ${LINGUAS}; then
+ einfo "- keeping ${lang}"
+ else
+ rm -Rf "${D}"/usr/share/locale/"${lang}" || die
+ fi
+ done
+ fi
}