summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'mail-client/sylpheed')
-rw-r--r--mail-client/sylpheed/Manifest1
-rw-r--r--mail-client/sylpheed/sylpheed-3.5.1.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/mail-client/sylpheed/Manifest b/mail-client/sylpheed/Manifest
index 6f240c6c2ba3..3c77a24908c9 100644
--- a/mail-client/sylpheed/Manifest
+++ b/mail-client/sylpheed/Manifest
@@ -1,2 +1,3 @@
DIST sylpheed-3.4.2.tar.bz2 3474176 SHA256 198de08d01a5c150adae6b6612da80674bbc7ed59b58bbd7508124b869322ba3 SHA512 1bfaf5636facb6ca55173e914904be7f9fb9ca98eb440f5b548fbbbe03f5dfb5428801e878f3275d3683e715d0b4bd33f63f69f5f98578ce1a25cef695406b5e WHIRLPOOL a7dda342adb598027765c5ab6d14ae3e850bf39ff63d90a79927fa2aec1bf539454357cb6dea8664d21f68deeccf78fada264d04b0a14ff311ff5827717c4aa8
DIST sylpheed-3.5.0.tar.bz2 3519735 SHA256 4a0b62d17bca6f1a96ab951ef55a9a67813d87bc1dc3ee55d8ec2c045366a05c SHA512 fa2803c41a935089989d93cd78ef0dd04d5c0117283f37b82f3d5e76eb753d38960ce3cc122936883cb3057e834acaa03b1a565cd31202331527d07a24e8d5b0 WHIRLPOOL 6f7b6df00a75cab868fdaae0856d7a7080d45ee361cd1f41c5f356199f3ac630926b1b22e549e5e0ce6d78b8a4553c440460f2882fa28e5bbdb2af9dfb8df6a5
+DIST sylpheed-3.5.1.tar.bz2 3561816 SHA256 3a5a04a13a0e2f32cdbc6e09d92b5143ca96df5fef23425cd81d96b8bd5b1087 SHA512 264aafb40eaa163405074480b2deb7eefe0d2158a107d9b26bc35d5506dcf5a52cf5712b81bd4c06b4c76e48c6e372c74473e5371bbdc80f230267f3b211c7f5 WHIRLPOOL 500978315913b99148d83df1f46991144ec467625837d422ed5ec9f4ce8a344f48e4ca6da7c25ca8ae5ed950c1464551de5e7da90ab27a9a7f2b1998ee4846b7
diff --git a/mail-client/sylpheed/sylpheed-3.5.1.ebuild b/mail-client/sylpheed/sylpheed-3.5.1.ebuild
new file mode 100644
index 000000000000..70b9ce63583a
--- /dev/null
+++ b/mail-client/sylpheed/sylpheed-3.5.1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="6"
+
+inherit eutils
+
+DESCRIPTION="A lightweight email client and newsreader"
+HOMEPAGE="http://sylpheed.sraoss.jp/"
+SRC_URI="http://${PN}.sraoss.jp/${PN}/v${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="crypt ipv6 ldap libressl nls oniguruma pda spell ssl xface"
+
+CDEPEND="x11-libs/gtk+:2
+ crypt? ( app-crypt/gpgme )
+ ldap? ( net-nds/openldap )
+ nls? ( sys-devel/gettext )
+ oniguruma? ( dev-libs/oniguruma )
+ pda? ( app-pda/jpilot )
+ spell? ( app-text/gtkspell:2 )
+ ssl? (
+ !libressl? ( dev-libs/openssl:0 )
+ libressl? ( dev-libs/libressl )
+ )"
+RDEPEND="${CDEPEND}
+ app-misc/mime-types
+ net-misc/curl"
+DEPEND="${CDEPEND}
+ virtual/pkgconfig
+ xface? ( media-libs/compface )"
+
+src_configure() {
+ local htmldir=/usr/share/doc/${PF}/html
+ econf \
+ $(use_enable crypt gpgme) \
+ $(use_enable ipv6) \
+ $(use_enable ldap) \
+ $(use_enable oniguruma) \
+ $(use_enable pda jpilot) \
+ $(use_enable spell gtkspell) \
+ $(use_enable ssl) \
+ $(use_enable xface compface) \
+ --with-plugindir=/usr/$(get_libdir)/${PN}/plugins \
+ --with-manualdir=${htmldir}/manual \
+ --with-faqdir=${htmldir}/faq \
+ --disable-updatecheck
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc AUTHORS ChangeLog* NEWS* PLUGIN* README* TODO*
+
+ doicon *.png
+ domenu *.desktop
+
+ cd plugin/attachment_tool
+ emake DESTDIR="${D}" install-plugin
+ docinto plugin/attachment_tool
+ dodoc README
+}