summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'mail-client')
-rw-r--r--mail-client/evolution/Manifest1
-rw-r--r--mail-client/evolution/evolution-3.22.6.ebuild138
-rw-r--r--mail-client/evolution/metadata.xml2
3 files changed, 141 insertions, 0 deletions
diff --git a/mail-client/evolution/Manifest b/mail-client/evolution/Manifest
index 4bdff198f02b..f1d5f080b33b 100644
--- a/mail-client/evolution/Manifest
+++ b/mail-client/evolution/Manifest
@@ -1,3 +1,4 @@
DIST evolution-3.20.5.tar.xz 12133872 SHA256 2e13551ce0996963506f0bdde5e01c3b8aa0622849a272ff12877cd595baeb6e SHA512 4b974ac5d8f3918a8012192634e8d131b1f6af0ed40a32181eb9500bc43b8bf4cf29a6fc7e49620638ada8f2456117e263e6162f21c0e1deef81861789a97906 WHIRLPOOL 1ed38bd2b9de97ad50bb832e03b76bf94131e65f0cf05c555d9e62d0e908467382b7e879d8eeb9513a6a09396da77eb2b2ac3a0dd3b97c6f2cde373dd65222ae
DIST evolution-3.22.3.tar.xz 12269980 SHA256 a7328b0f225e41654643514eefafb02e6819660fd989ec1e8feab4f17e93dc00 SHA512 33d31d8c7dff30e026280fddc599085c1f9d0624e9c3ed95d9815787a48aebefc198b1bb2cb4bab75d283120c72275144ba4f158e8d82a6055c60dcd02b6addc WHIRLPOOL 2e89b65d40f97597e7554fffe235b9477b6529b5eba73fbcb61b53bfd72515ca32c52f55585431ad4b122d14d5be29ea863536ba045dcbbfeb72a181e88301ac
DIST evolution-3.22.4.tar.xz 12272488 SHA256 522209f022a468c9031fd393fe4ba6c655dedfa06dd6ae59d2d693d1485c690a SHA512 dd73a11d4d7903be6a99bf0d937f5a217a26f0dffb9dc0cea2ca81142d5783c42f889a8b913d565678e9f55b7f2f2a1d42f06c30e3cb004926c19f44dae3b70f WHIRLPOOL 6aadef7a735cd351abbcdaacd086641b656ac7d94d78ab278ef0270725f487a5cd0eb6b859530611f41049024e12945368e6616fe2a3afd4481cce6654ee6279
+DIST evolution-3.22.6.tar.xz 12288232 SHA256 9f4be4a1d5ee4d5eb9b132cf751ba3afc833025aa6dc7baa1f9483489d8a943e SHA512 c699adae640d05558b583b05eda5c5ad3de99aa1d1bbfa24af6110be41251f715ff4b16ff0efb96c8de7faa8c895d82460b504c2704974d4c9731f1bc3e7739f WHIRLPOOL df9fde3db1b6ebf11551d81694a99e07822ab184cc4d14e7d54777eab348de60c5180bd73e0795a3c190509b97f0d948b4e0f4b6d32816e46d967a555746ae98
diff --git a/mail-client/evolution/evolution-3.22.6.ebuild b/mail-client/evolution/evolution-3.22.6.ebuild
new file mode 100644
index 000000000000..5630cad99189
--- /dev/null
+++ b/mail-client/evolution/evolution-3.22.6.ebuild
@@ -0,0 +1,138 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2 flag-o-matic readme.gentoo-r1
+
+DESCRIPTION="Integrated mail, addressbook and calendaring functionality"
+HOMEPAGE="https://wiki.gnome.org/Apps/Evolution"
+
+# Note: explicitly "|| ( LGPL-2 LGPL-3 )", not "LGPL-2+".
+LICENSE="|| ( LGPL-2 LGPL-3 ) CC-BY-SA-3.0 FDL-1.3+ OPENLDAP"
+SLOT="2.0"
+
+IUSE="archive +bogofilter crypt geolocation highlight ldap spamassassin spell ssl +weather"
+
+KEYWORDS="~alpha ~amd64 ~x86"
+
+# We need a graphical pinentry frontend to be able to ask for the GPG
+# password from inside evolution, bug 160302
+PINENTRY_DEPEND="|| ( app-crypt/pinentry[gnome-keyring] app-crypt/pinentry[gtk] app-crypt/pinentry[qt4] app-crypt/pinentry[qt5] )"
+
+# glade-3 support is for maintainers only per configure.ac
+# pst is not mature enough and changes API/ABI frequently
+# dconf explicitely needed for backup plugin
+# gnome-desktop support is optional with --enable-gnome-desktop
+COMMON_DEPEND="
+ >=app-crypt/gcr-3.4:=
+ >=app-text/enchant-1.1.7
+ >=dev-libs/glib-2.46:2[dbus]
+ >=dev-libs/libxml2-2.7.3:2
+ >=gnome-base/gnome-desktop-2.91.3:3=
+ >=gnome-base/gsettings-desktop-schemas-2.91.92
+ >=gnome-extra/evolution-data-server-${PV}:=[gtk,weather?]
+ >=media-libs/libcanberra-0.25[gtk3]
+ >=net-libs/libsoup-2.42:2.4
+ >=net-libs/webkit-gtk-2.13.90:4
+ >=x11-libs/cairo-1.9.15:=[glib]
+ >=x11-libs/gdk-pixbuf-2.24:2
+ >=x11-libs/gtk+-3.10:3
+ >=x11-libs/libnotify-0.7:=
+ >=x11-misc/shared-mime-info-0.22
+
+ >=app-text/iso-codes-0.49
+ dev-libs/atk
+ gnome-base/dconf
+ dev-libs/libical:=
+ x11-libs/libSM
+ x11-libs/libICE
+
+ archive? ( >=app-arch/gnome-autoar-0.1.1[gtk] )
+ crypt? (
+ >=app-crypt/gnupg-1.4
+ ${PINENTRY_DEPEND}
+ x11-libs/libcryptui )
+ geolocation? (
+ >=media-libs/libchamplain-0.12:0.12[gtk]
+ >=media-libs/clutter-1.0.0:1.0
+ >=media-libs/clutter-gtk-0.90:1.0
+ >=sci-geosciences/geocode-glib-3.10.0
+ x11-libs/mx:1.0 )
+ ldap? ( >=net-nds/openldap-2:= )
+ spell? ( app-text/gtkspell:3 )
+ ssl? (
+ >=dev-libs/nspr-4.6.1:=
+ >=dev-libs/nss-3.11:= )
+ weather? ( >=dev-libs/libgweather-3.10:2= )
+"
+DEPEND="${COMMON_DEPEND}
+ app-text/docbook-xml-dtd:4.1.2
+ app-text/yelp-tools
+ >=dev-util/gtk-doc-am-1.14
+ >=dev-util/intltool-0.40.0
+ >=gnome-base/gnome-common-2.12
+ virtual/pkgconfig
+"
+RDEPEND="${COMMON_DEPEND}
+ bogofilter? ( mail-filter/bogofilter )
+ highlight? ( app-text/highlight )
+ spamassassin? ( mail-filter/spamassassin )
+ !gnome-extra/evolution-exchange
+"
+
+DISABLE_AUTOFORMATTING="yes"
+DOC_CONTENTS="To change the default browser if you are not using GNOME, edit
+~/.local/share/applications/mimeapps.list so it includes the
+following content:
+
+[Default Applications]
+x-scheme-handler/http=firefox.desktop
+x-scheme-handler/https=firefox.desktop
+
+(replace firefox.desktop with the name of the appropriate .desktop
+file from /usr/share/applications if you use a different browser)."
+
+src_configure() {
+ # Use NSS/NSPR only if 'ssl' is enabled.
+ gnome2_src_configure \
+ --without-glade-catalog \
+ --disable-code-coverage \
+ --disable-installed-tests \
+ --disable-pst-import \
+ --enable-canberra \
+ $(use_enable archive autoar) \
+ $(use_enable crypt libcryptui) \
+ $(use_enable highlight text-highlight) \
+ $(use_enable geolocation contact-maps) \
+ $(use_enable spell gtkspell) \
+ $(use_enable ssl nss) \
+ $(use_enable ssl smime) \
+ $(use_with bogofilter) \
+ $(use_with ldap openldap) \
+ $(use_with spamassassin) \
+ $(usex ssl --enable-nss=yes "--without-nspr-libs
+ --without-nspr-includes
+ --without-nss-libs
+ --without-nss-includes") \
+ $(use_enable weather)
+}
+
+src_install() {
+ gnome2_src_install
+
+ # Problems with prelink:
+ # https://bugzilla.gnome.org/show_bug.cgi?id=731680
+ # https://bugzilla.gnome.org/show_bug.cgi?id=732148
+ # https://bugzilla.redhat.com/show_bug.cgi?id=1114538
+ echo PRELINK_PATH_MASK=/usr/bin/evolution > ${T}/99${PN}
+ doenvd "${T}"/99${PN}
+
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ readme.gentoo_print_elog
+}
diff --git a/mail-client/evolution/metadata.xml b/mail-client/evolution/metadata.xml
index ab10917ad0f1..da11033a3497 100644
--- a/mail-client/evolution/metadata.xml
+++ b/mail-client/evolution/metadata.xml
@@ -6,6 +6,8 @@
<name>Gentoo GNOME Desktop</name>
</maintainer>
<use>
+ <flag name="archive">Enable archives support in attachments via
+ <pkg>app-arch/gnome-autoar</pkg></flag>
<flag name="bogofilter">Build <pkg>mail-filter/bogofilter</pkg> plugin</flag>
<flag name="crypt">Enable GPG encryption support using
<pkg>app-crypt/gnupg</pkg> and <pkg>app-crypt/pinentry</pkg></flag>