summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'mate-base/mate-menus')
-rw-r--r--mate-base/mate-menus/Manifest1
-rw-r--r--mate-base/mate-menus/mate-menus-1.10.1.ebuild82
2 files changed, 0 insertions, 83 deletions
diff --git a/mate-base/mate-menus/Manifest b/mate-base/mate-menus/Manifest
index d675a020cf34..9d79742069b6 100644
--- a/mate-base/mate-menus/Manifest
+++ b/mate-base/mate-menus/Manifest
@@ -1,3 +1,2 @@
-DIST mate-menus-1.10.1.tar.xz 342516 SHA256 bd46d676bd4780f815d8343f8a8c3e67645c85fb812a943a0a69e664d3dcddbc SHA512 f0a96334c71052060d2f40b309b91a0a6464f8bd8135e43b29b3e9c67332b01205ffe1a3e2b262b910bbd0a679acd4ebd67b6de604c1e5cfb2bc42bf54028a86 WHIRLPOOL ae24e8bb2b99966e7676f535f6c9d0bfd32223d0dd9e9c5a371c40b15ce9b788cf9b0a7af7df1a2f5880b2fa03aa12fe45e43caaaba48450164c8bc23e47aa4a
DIST mate-menus-1.12.0.tar.xz 342488 SHA256 b0b735be91cca632d7c63f254a9442201608b24f1d5588a1ff05b50da41b95c4 SHA512 12788d5b88c1dba7b561a3119e311a9724629d1f9ae7d54a9e4443946b331c532310c79b7b39bcacc791697ac52d4b55338051da66c4d747c371575a03183ba6 WHIRLPOOL ec1137ea30f36537dda4aa6d6432f6712a644fa942b618f83a069c8dcdf357b3106e2db6aea86a3dce19f66c053b4fb6e780143e4eab0f42e4eb246bdda29981
DIST mate-menus-1.14.0.tar.xz 362136 SHA256 26585cafa82496e22851fd7c767260797eb029d24698ca8059ddfe3f70226cc5 SHA512 9d82737669b37e85ab76e94e84a464d7cafb837b71d6af90cf08b4286480de901e1a37d279ba7f0af25e655c3c9c67481b1394587b6aad902a284a8ac58559c6 WHIRLPOOL ac0a45e91ab619c40ba946624de68f71a6df8dec7c83562fa471018f7be113aa2ac9cbb9e74d44929923c3595bb0f4756d4f9458cb5f2572864ecc5e90a5fab6
diff --git a/mate-base/mate-menus/mate-menus-1.10.1.ebuild b/mate-base/mate-menus/mate-menus-1.10.1.ebuild
deleted file mode 100644
index 0754d5bbc9fa..000000000000
--- a/mate-base/mate-menus/mate-menus-1.10.1.ebuild
+++ /dev/null
@@ -1,82 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="5"
-
-GCONF_DEBUG="no"
-GNOME2_LA_PUNT="yes"
-PYTHON_COMPAT=( python2_7 )
-
-inherit gnome2 python-r1
-
-MATE_BRANCH="$(get_version_component_range 1-2)"
-
-SRC_URI="http://pub.mate-desktop.org/releases/${MATE_BRANCH}/${P}.tar.xz"
-DESCRIPTION="MATE menu system, implementing the F.D.O cross-desktop spec"
-HOMEPAGE="http://mate-desktop.org"
-
-LICENSE="GPL-2 LGPL-2"
-SLOT="0"
-KEYWORDS="amd64 ~arm x86"
-
-IUSE="debug +introspection python"
-
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-
-RDEPEND=">=dev-libs/glib-2.36.0:2
- virtual/libintl:0
- introspection? ( >=dev-libs/gobject-introspection-0.6.7:0 )
- python? (
- dev-python/pygtk:2[${PYTHON_USEDEP}]
- ${PYTHON_DEPS}
- )"
-
-DEPEND="${RDEPEND}
- >=dev-util/intltool-0.40:*
- >=mate-base/mate-common-1.10:0
- sys-devel/gettext:*
- virtual/pkgconfig:*"
-
-my_command() {
- if use python ; then
- python_foreach_impl run_in_build_dir $@
- else
- $@
- fi
-}
-
-src_configure() {
- G2CONF="${G2CONF} \
- $(use_enable python) \
- $(use_enable introspection)"
-
- # Do NOT compile with --disable-debug/--enable-debug=no as it disables API
- # usage checks.
- if ! use debug ; then
- G2CONF="${G2CONF} --enable-debug=minimum"
- fi
-
- if use python ; then
- python_copy_sources
- fi
-
- my_command gnome2_src_configure
-}
-
-src_compile() {
- my_command gnome2_src_compile
-}
-
-src_test() {
- my_command emake check
-}
-
-DOCS="AUTHORS ChangeLog NEWS README"
-
-src_install() {
- my_command gnome2_src_install
-
- exeinto /etc/X11/xinit/xinitrc.d/
- doexe "${FILESDIR}/10-xdg-menu-mate"
-}