summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/chafa/chafa-1.0.1.ebuild')
-rw-r--r--media-gfx/chafa/chafa-1.0.1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/media-gfx/chafa/chafa-1.0.1.ebuild b/media-gfx/chafa/chafa-1.0.1.ebuild
new file mode 100644
index 000000000000..53d1b3126f45
--- /dev/null
+++ b/media-gfx/chafa/chafa-1.0.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="versatile and fast Unicode/ASCII/ANSI graphics renderer"
+HOMEPAGE="https://hpjansson.org/chafa/ https://github.com/hpjansson/chafa"
+SRC_URI="https://hpjansson.org/chafa/releases/${P}.tar.xz"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="static-libs +tools"
+
+RDEPEND="
+ dev-libs/glib:2
+ media-gfx/imagemagick:0=
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_configure() {
+ local econfargs=(
+ $(use_enable static-libs static)
+ # install manpage manually
+ --disable-man
+ $(use_with tools)
+ )
+
+ econf "${econfargs[@]}"
+}
+
+src_install() {
+ local DOCS=( AUTHORS NEWS README TODO )
+ default
+
+ use tools && doman docs/chafa.1
+
+ find "${ED}"/usr/lib* -name '*.la' -delete || die
+}