summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/gifsicle/gifsicle-1.87.ebuild')
-rw-r--r--media-gfx/gifsicle/gifsicle-1.87.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/media-gfx/gifsicle/gifsicle-1.87.ebuild b/media-gfx/gifsicle/gifsicle-1.87.ebuild
new file mode 100644
index 000000000000..4075fa397a62
--- /dev/null
+++ b/media-gfx/gifsicle/gifsicle-1.87.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="A command-line tool for creating, editing, and getting information about GIF images and animations"
+HOMEPAGE="http://www.lcdf.org/~eddietwo/gifsicle/"
+SRC_URI="http://www.lcdf.org/~eddietwo/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2 MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="X"
+
+RDEPEND="X? ( x11-libs/libX11 x11-libs/libXt )"
+DEPEND="${RDEPEND}
+ X? ( x11-proto/xproto )"
+
+src_configure() {
+ local myconf
+ use X || myconf='--disable-gifview'
+
+ econf ${myconf}
+}