summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/jhead/jhead-2.96.ebuild')
-rw-r--r--media-gfx/jhead/jhead-2.96.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/media-gfx/jhead/jhead-2.96.ebuild b/media-gfx/jhead/jhead-2.96.ebuild
new file mode 100644
index 000000000000..b8a89770d5d8
--- /dev/null
+++ b/media-gfx/jhead/jhead-2.96.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Exif Jpeg camera setting parser and thumbnail remover"
+HOMEPAGE="http://www.sentex.net/~mwandel/jhead"
+SRC_URI="http://www.sentex.net/~mwandel/${PN}/${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="alpha amd64 hppa ia64 ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE=""
+
+src_prepare() {
+ # bug 275200 - respect flags and use mktemp instead of mkstemp
+ epatch "${FILESDIR}"/${PN}-2.90-mkstemp_respect_flags.patch
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}"
+}
+
+src_install() {
+ dobin ${PN}
+ dodoc *.txt
+ dohtml *.html
+ doman ${PN}.1
+}