summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/mandelbulber/mandelbulber-1.12.1.ebuild')
-rw-r--r--media-gfx/mandelbulber/mandelbulber-1.12.1.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/media-gfx/mandelbulber/mandelbulber-1.12.1.ebuild b/media-gfx/mandelbulber/mandelbulber-1.12.1.ebuild
new file mode 100644
index 000000000000..68a78d357101
--- /dev/null
+++ b/media-gfx/mandelbulber/mandelbulber-1.12.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils toolchain-funcs versionator
+
+MY_P=${PN}$(replace_version_separator 2 '-' )
+
+DESCRIPTION="Tool to render 3D fractals"
+HOMEPAGE="http://sites.google.com/site/mandelbulber/home"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/gtk+:2
+ >=media-libs/libsndfile-1
+ >=media-libs/libpng-1.4:0=
+ virtual/jpeg"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${PN}-1.11-qa.patch \
+ "${FILESDIR}"/${P}-memcpy_and_memset.patch
+}
+
+src_compile() {
+ emake CXX="$(tc-getCXX)" -C makefiles all
+}
+
+src_install() {
+ dobin makefiles/${PN}
+ dodoc README NEWS
+ insinto /usr/share/${PN}
+ doins -r usr/share/*
+}
+
+pkg_postinst() {
+ elog "Before you run ${PN} please copy /usr/share/${PN}/* to \${HOME}/.${PN}"
+}