summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/pdf2svg/pdf2svg-0.2.2.ebuild')
-rw-r--r--media-gfx/pdf2svg/pdf2svg-0.2.2.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/media-gfx/pdf2svg/pdf2svg-0.2.2.ebuild b/media-gfx/pdf2svg/pdf2svg-0.2.2.ebuild
new file mode 100644
index 000000000000..6a470094ae97
--- /dev/null
+++ b/media-gfx/pdf2svg/pdf2svg-0.2.2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils
+
+DESCRIPTION="pdf2svg is based on poppler and cairo and can convert pdf to svg files"
+HOMEPAGE="http://www.cityinthesky.co.uk/opensource/pdf2svg/"
+SRC_URI="http://www.cityinthesky.co.uk/wp-content/uploads/2013/10/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=app-text/poppler-0.12.3-r3:=[cairo]
+ >=x11-libs/cairo-1.2.6:=[svg]
+ x11-libs/gtk+:2="
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS="AUTHORS" # ChangeLog is only for <=0.2.1 and README.md doesn't have anything useful for usage
+
+src_prepare() {
+ sed -i \
+ -e 's:#include <stdio.h>:#include <stdio.h>\n#include <stdlib.h>:' \
+ ${PN}.c || die
+}