summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/sxiv/sxiv-1.1.1.ebuild')
-rw-r--r--media-gfx/sxiv/sxiv-1.1.1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/media-gfx/sxiv/sxiv-1.1.1.ebuild b/media-gfx/sxiv/sxiv-1.1.1.ebuild
new file mode 100644
index 000000000000..c26d605394bb
--- /dev/null
+++ b/media-gfx/sxiv/sxiv-1.1.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils savedconfig toolchain-funcs
+
+DESCRIPTION="Simple (or small or suckless) X Image Viewer"
+HOMEPAGE="https://github.com/muennich/sxiv/"
+SRC_URI="https://github.com/muennich/sxiv/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+RDEPEND="media-libs/giflib
+ media-libs/imlib2[X]
+ x11-libs/libX11"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.1-makefile.patch
+ tc-export CC
+
+ restore_config config.h
+}
+
+src_install() {
+ emake DESTDIR="${ED}" PREFIX=/usr install
+ dodoc README.md
+
+ save_config config.h
+}