summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/ufraw/files/ufraw-0.22-exiv2-0.27.patch25
-rw-r--r--media-gfx/ufraw/ufraw-0.22-r2.ebuild3
2 files changed, 27 insertions, 1 deletions
diff --git a/media-gfx/ufraw/files/ufraw-0.22-exiv2-0.27.patch b/media-gfx/ufraw/files/ufraw-0.22-exiv2-0.27.patch
new file mode 100644
index 000000000000..b5b4140fff8e
--- /dev/null
+++ b/media-gfx/ufraw/files/ufraw-0.22-exiv2-0.27.patch
@@ -0,0 +1,25 @@
+--- a/ufraw_exiv2.cc 2015-06-16 05:58:38.000000000 +0200
++++ b/ufraw_exiv2.cc 2018-12-29 22:51:23.291894430 +0100
+@@ -15,9 +15,7 @@
+ #include "ufraw.h"
+
+ #ifdef HAVE_EXIV2
+-#include <exiv2/image.hpp>
+-#include <exiv2/easyaccess.hpp>
+-#include <exiv2/exif.hpp>
++#include <exiv2/exiv2.hpp>
+ #include <sstream>
+ #include <cassert>
+
+@@ -67,7 +65,11 @@
+ if (exifData.empty()) {
+ std::string error(uf->filename);
+ error += ": No Exif data found in the file";
++#if EXIV2_TEST_VERSION(0,27,0)
++ throw Exiv2::Error(Exiv2::kerErrorMessage, error);
++#else
+ throw Exiv2::Error(1, error);
++#endif
+ }
+
+ /* List of tag names taken from exiv2's printSummary() in actions.cpp */
diff --git a/media-gfx/ufraw/ufraw-0.22-r2.ebuild b/media-gfx/ufraw/ufraw-0.22-r2.ebuild
index 53994be42a82..9bbc7e771218 100644
--- a/media-gfx/ufraw/ufraw-0.22-r2.ebuild
+++ b/media-gfx/ufraw/ufraw-0.22-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -44,6 +44,7 @@ PATCHES=(
"${FILESDIR}"/${P}-drop_superfluous_abs.patch
"${FILESDIR}"/${P}-fix-unsigned-char.patch
"${FILESDIR}"/${P}-jpeg9.patch
+ "${FILESDIR}"/${P}-exiv2-0.27.patch
)
src_prepare() {