summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/chromaprint/files')
-rw-r--r--media-libs/chromaprint/files/chromaprint-0.7-boost.patch8
-rw-r--r--media-libs/chromaprint/files/chromaprint-0.7-ffmpeg.patch43
-rw-r--r--media-libs/chromaprint/files/chromaprint-0.7-libav9.patch44
-rw-r--r--media-libs/chromaprint/files/chromaprint-1.0-libav9.patch11
-rw-r--r--media-libs/chromaprint/files/chromaprint-1.1-ffmpeg2.patch13
-rw-r--r--media-libs/chromaprint/files/chromaprint-1.1-libav_build_fix_for_tools.patch59
6 files changed, 0 insertions, 178 deletions
diff --git a/media-libs/chromaprint/files/chromaprint-0.7-boost.patch b/media-libs/chromaprint/files/chromaprint-0.7-boost.patch
deleted file mode 100644
index 46df857689de..000000000000
--- a/media-libs/chromaprint/files/chromaprint-0.7-boost.patch
+++ /dev/null
@@ -1,8 +0,0 @@
---- chromaprint-0.7/tests/CMakeLists.txt
-+++ chromaprint-0.7/tests/CMakeLists.txt
-@@ -1,4 +1,5 @@
- include_directories(
-+ ${Boost_INCLUDE_DIRS}
- ${GTEST_INCLUDE_DIRS}
- ${CMAKE_CURRENT_SOURCE_DIR}/../src
- )
diff --git a/media-libs/chromaprint/files/chromaprint-0.7-ffmpeg.patch b/media-libs/chromaprint/files/chromaprint-0.7-ffmpeg.patch
deleted file mode 100644
index f51e7794b6d8..000000000000
--- a/media-libs/chromaprint/files/chromaprint-0.7-ffmpeg.patch
+++ /dev/null
@@ -1,43 +0,0 @@
-https://bugs.gentoo.org/show_bug.cgi?id=435856
-https://raw.github.com/pld-linux/chromaprint/master/chromaprint-ffmpeg.patch
-
---- chromaprint-0.7/src/ext/ffmpeg_decoder.h.orig 2012-09-05 20:05:36.000000000 +0200
-+++ chromaprint-0.7/src/ext/ffmpeg_decoder.h 2012-10-10 17:59:58.632685943 +0200
-@@ -80,7 +80,7 @@
- avcodec_close(m_codec_ctx);
- }
- if (m_format_ctx) {
-- av_close_input_file(m_format_ctx);
-+ avformat_close_input(&m_format_ctx);
- }
- //av_audio_convert_free(m_convert_ctx);
- av_free(m_buffer2);
-@@ -89,12 +89,12 @@
-
- inline bool Decoder::Open()
- {
-- if (av_open_input_file(&m_format_ctx, m_file_name.c_str(), NULL, 0, NULL) != 0) {
-+ if (avformat_open_input(&m_format_ctx, m_file_name.c_str(), NULL, NULL) != 0) {
- m_error = "Couldn't open the file." + m_file_name;
- return false;
- }
-
-- if (av_find_stream_info(m_format_ctx) < 0) {
-+ if (avformat_find_stream_info(m_format_ctx, NULL) < 0) {
- m_error = "Couldn't find stream information in the file.";
- return false;
- }
-@@ -129,11 +129,11 @@
- return false;
- }
-
-- if (m_codec_ctx->sample_fmt != SAMPLE_FMT_S16) {
-+ if (m_codec_ctx->sample_fmt != AV_SAMPLE_FMT_S16) {
- m_error = "Unsupported sample format.\n";
- return false;
- }
-- /*m_convert_ctx = av_audio_convert_alloc(SAMPLE_FMT_S16, 1,
-+ /*m_convert_ctx = av_audio_convert_alloc(AV_SAMPLE_FMT_S16, 1,
- m_codec_ctx->sample_fmt, 1,
- NULL, 0);
- if (!m_convert_ctx) {
diff --git a/media-libs/chromaprint/files/chromaprint-0.7-libav9.patch b/media-libs/chromaprint/files/chromaprint-0.7-libav9.patch
deleted file mode 100644
index c52097056377..000000000000
--- a/media-libs/chromaprint/files/chromaprint-0.7-libav9.patch
+++ /dev/null
@@ -1,44 +0,0 @@
-diff -burN chromaprint-0.7.orig//src/fft_lib_avfft.h chromaprint-0.7/src/fft_lib_avfft.h
---- chromaprint-0.7.orig//src/fft_lib_avfft.h 2012-09-05 20:05:36.000000000 +0200
-+++ chromaprint-0.7/src/fft_lib_avfft.h 2013-02-16 17:34:08.682624779 +0100
-@@ -25,6 +25,7 @@
- extern "C" {
- #include <libavcodec/avcodec.h>
- #include <libavcodec/avfft.h>
-+#include <libavutil/mem.h>
- }
- #include "combined_buffer.h"
-
-diff -burN chromaprint-0.7.orig/examples/fpcalc.c chromaprint-0.7/work/chromaprint-0.7/examples/fpcalc.c
---- chromaprint-0.7.orig/examples/fpcalc.c 2012-09-05 20:05:36.000000000 +0200
-+++ chromaprint-0.7/examples/fpcalc.c 2013-02-16 17:40:09.947611629 +0100
-@@ -42,7 +42,7 @@
- goto done;
- }
-
-- if (av_find_stream_info(format_ctx) < 0) {
-+ if (avformat_find_stream_info(format_ctx, NULL) < 0) {
- fprintf(stderr, "ERROR: couldn't find stream information in the file\n");
- goto done;
- }
-@@ -65,7 +65,7 @@
- goto done;
- }
-
-- if (avcodec_open(codec_ctx, codec) < 0) {
-+ if (avcodec_open2(codec_ctx, codec, NULL) < 0) {
- fprintf(stderr, "ERROR: couldn't open the codec\n");
- goto done;
- }
-diff -burN chromaprint-0.7.orig/src/ext/ffmpeg_decoder.h chromaprint-0.7/src/ext/ffmpeg_decoder.h
---- chromaprint-0.7.orig/src/ext/ffmpeg_decoder.h 2013-02-16 17:49:06.799592088 +0100
-+++ chromaprint-0.7/src/ext/ffmpeg_decoder.h 2013-02-16 17:49:54.037590369 +0100
-@@ -124,7 +124,7 @@
- return false;
- }
-
-- if (avcodec_open(m_codec_ctx, codec) < 0) {
-+ if (avcodec_open2(m_codec_ctx, codec, NULL) < 0) {
- m_error = "Couldn't open the codec.";
- return false;
- }
diff --git a/media-libs/chromaprint/files/chromaprint-1.0-libav9.patch b/media-libs/chromaprint/files/chromaprint-1.0-libav9.patch
deleted file mode 100644
index e8167903471f..000000000000
--- a/media-libs/chromaprint/files/chromaprint-1.0-libav9.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- chromaprint-1.0.orig/src/ext/ffmpeg_decoder.h 2013-11-03 17:32:04.347686878 +0800
-+++ chromaprint-1.0/src/ext/ffmpeg_decoder.h 2013-11-03 17:32:41.082686494 +0800
-@@ -124,7 +124,7 @@
- return false;
- }
-
-- if (avcodec_open(m_codec_ctx, codec) < 0) {
-+ if (avcodec_open2(m_codec_ctx, codec, NULL) < 0) {
- m_error = "Couldn't open the codec.";
- return false;
- }
diff --git a/media-libs/chromaprint/files/chromaprint-1.1-ffmpeg2.patch b/media-libs/chromaprint/files/chromaprint-1.1-ffmpeg2.patch
deleted file mode 100644
index 2a68de3105dc..000000000000
--- a/media-libs/chromaprint/files/chromaprint-1.1-ffmpeg2.patch
+++ /dev/null
@@ -1,13 +0,0 @@
---- chromaprint-1.1/src/ext/ffmpeg_decoder.h
-+++ chromaprint-1.1/src/ext/ffmpeg_decoder.h
-@@ -28,6 +28,10 @@
- }
- #include "audio_consumer.h"
-
-+#ifndef AVCODEC_MAX_AUDIO_FRAME_SIZE
-+# define AVCODEC_MAX_AUDIO_FRAME_SIZE 192000
-+#endif
-+
- class Decoder
- {
- public:
diff --git a/media-libs/chromaprint/files/chromaprint-1.1-libav_build_fix_for_tools.patch b/media-libs/chromaprint/files/chromaprint-1.1-libav_build_fix_for_tools.patch
deleted file mode 100644
index b53f79838091..000000000000
--- a/media-libs/chromaprint/files/chromaprint-1.1-libav_build_fix_for_tools.patch
+++ /dev/null
@@ -1,59 +0,0 @@
-http://bugs.gentoo.org/498194
-http://bitbucket.org/acoustid/chromaprint/commits/90822f6eee64da2941c9cbd9cd41a9664fead1d4
-
-From 90822f6eee64da2941c9cbd9cd41a9664fead1d4 Mon Sep 17 00:00:00 2001
-From: Urs Fleisch <ufleisch@users.sourceforge.net>
-Date: Sat, 28 Dec 2013 09:47:31 +0100
-Subject: [PATCH] Build fpcalc if neither HAVE_SWRESAMPLE nor HAVE_AVRESAMPLE
- defined, issue #11.
-
----
- examples/fpcalc.c | 9 +++++++--
- 1 file changed, 7 insertions(+), 2 deletions(-)
-
-diff --git a/examples/fpcalc.c b/examples/fpcalc.c
-index a4b0ff9..e73e358 100644
---- a/examples/fpcalc.c
-+++ b/examples/fpcalc.c
-@@ -33,6 +33,8 @@ int decode_audio_file(ChromaprintContext *chromaprint_ctx, const char *file_name
- SwrContext *convert_ctx = NULL;
- #elif defined(HAVE_AVRESAMPLE)
- AVAudioResampleContext *convert_ctx = NULL;
-+#else
-+ void *convert_ctx = NULL;
- #endif
- int max_dst_nb_samples = 0, dst_linsize = 0;
- uint8_t *dst_data[1] = { NULL };
-@@ -75,6 +77,7 @@ int decode_audio_file(ChromaprintContext *chromaprint_ctx, const char *file_name
- goto done;
- }
-
-+#if defined(HAVE_SWRESAMPLE) || defined(HAVE_AVRESAMPLE)
- if (codec_ctx->sample_fmt != AV_SAMPLE_FMT_S16) {
- int64_t channel_layout = codec_ctx->channel_layout;
- if (!channel_layout) {
-@@ -111,6 +114,7 @@ int decode_audio_file(ChromaprintContext *chromaprint_ctx, const char *file_name
- }
- #endif
- }
-+#endif
-
- if (stream->duration != AV_NOPTS_VALUE) {
- *duration = stream->time_base.num * stream->duration / stream->time_base.den;
-@@ -155,10 +159,11 @@ int decode_audio_file(ChromaprintContext *chromaprint_ctx, const char *file_name
- max_dst_nb_samples = frame->nb_samples;
- }
- #if defined(HAVE_SWRESAMPLE)
-- if (swr_convert(convert_ctx, dst_data, frame->nb_samples, (const uint8_t **)frame->data, frame->nb_samples) < 0) {
-+ if (swr_convert(convert_ctx, dst_data, frame->nb_samples, (const uint8_t **)frame->data, frame->nb_samples) < 0)
- #elif defined(HAVE_AVRESAMPLE)
-- if (avresample_convert(convert_ctx, dst_data, 0, frame->nb_samples, (uint8_t **)frame->data, 0, frame->nb_samples) < 0) {
-+ if (avresample_convert(convert_ctx, dst_data, 0, frame->nb_samples, (uint8_t **)frame->data, 0, frame->nb_samples) < 0)
- #endif
-+ {
- fprintf(stderr, "ERROR: couldn't convert the audio\n");
- goto done;
- }
---
-1.9.rc2.211.gd198f5d
-