summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/grilo')
-rw-r--r--media-libs/grilo/Manifest1
-rw-r--r--media-libs/grilo/grilo-0.2.15.ebuild86
2 files changed, 0 insertions, 87 deletions
diff --git a/media-libs/grilo/Manifest b/media-libs/grilo/Manifest
index c83f9fe1c4c2..72c3a6a04633 100644
--- a/media-libs/grilo/Manifest
+++ b/media-libs/grilo/Manifest
@@ -1,2 +1 @@
-DIST grilo-0.2.15.tar.xz 627196 BLAKE2B 3277f2588413e364835954f971c986451837b6992858d48273280d511a4d1ef4a8075924aaa3d4426818952e9f4d65c1b2dff7d3e255b2cbf30a8f73f740f91a SHA512 ac0a76d9075e5383fe1a56277b23986a8ec8e86f01f3f782ac7dc79539904712c22295c679243604b619f24088a1210622e0699b5601678264bd7651012ded3e
DIST grilo-0.3.6.tar.xz 653864 BLAKE2B 58570975b2c4623b2a43b441c60d88146080327a86018bfd1a37967d35b6389e5102915296ceba1a8ebf23d27a3e4f8d23eeb59555a6c5cd0ca596b5ab674878 SHA512 175cf61a43aea8456a41f4dce7694fac50e854cf6340ed0671f233e6188fa34347c1e7308aac99bc49d081c36747776b9a8c1c5cc7c0be00a1df2c9d015d8849
diff --git a/media-libs/grilo/grilo-0.2.15.ebuild b/media-libs/grilo/grilo-0.2.15.ebuild
deleted file mode 100644
index 46a92486b6db..000000000000
--- a/media-libs/grilo/grilo-0.2.15.ebuild
+++ /dev/null
@@ -1,86 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="5"
-GCONF_DEBUG="no" # --enable-debug only changes CFLAGS
-GNOME2_LA_PUNT="yes"
-PYTHON_COMPAT=( python2_7 )
-VALA_MIN_API_VERSION="0.28"
-VALA_USE_DEPEND="vapigen"
-
-inherit gnome2 python-any-r1 vala
-
-DESCRIPTION="A framework for easy media discovery and browsing"
-HOMEPAGE="https://wiki.gnome.org/Projects/Grilo"
-
-LICENSE="LGPL-2.1+"
-SLOT="0.2/1" # subslot is libgrilo-0.2 soname suffix
-KEYWORDS="~alpha amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc x86"
-
-IUSE="gtk examples +introspection +network playlist test vala"
-REQUIRED_USE="test? ( introspection )"
-
-RDEPEND="
- >=dev-libs/glib-2.44:2
- dev-libs/libxml2:2
- net-libs/liboauth
- gtk? ( >=x11-libs/gtk+-3:3 )
- introspection? ( >=dev-libs/gobject-introspection-0.9:= )
- network? ( >=net-libs/libsoup-2.41.3:2.4 )
- playlist? ( >=dev-libs/totem-pl-parser-3.4.1 )
-"
-DEPEND="${RDEPEND}
- >=dev-util/gtk-doc-am-1.10
- >=dev-util/intltool-0.40
- virtual/pkgconfig
- vala? ( $(vala_depend) )
- test? (
- $(python_gen_any_dep '
- dev-python/pygobject:2[${PYTHON_USEDEP}]
- dev-python/pygobject:3[${PYTHON_USEDEP}]')
- media-plugins/grilo-plugins:0.2 )
-"
-# eautoreconf requires gnome-common
-
-python_check_deps() {
- has_version "dev-python/pygobject:2[${PYTHON_USEDEP}]" && \
- has_version "dev-python/pygobject:3[${PYTHON_USEDEP}]"
-}
-
-pkg_setup() {
- use test && python-any-r1_pkg_setup
-}
-
-src_prepare() {
- # Don't build examples
- sed -e '/SUBDIRS/s/examples//' \
- -i Makefile.am -i Makefile.in || die
-
- use vala && vala_src_prepare
- gnome2_src_prepare
-}
-
-src_configure() {
- # --enable-debug only changes CFLAGS, useless for us
- gnome2_src_configure \
- --disable-static \
- --disable-debug \
- $(use_enable gtk test-ui) \
- $(use_enable introspection) \
- $(use_enable network grl-net) \
- $(use_enable playlist grl-pls) \
- $(use_enable test tests) \
- $(use_enable vala)
-}
-
-src_install() {
- gnome2_src_install
- # Upstream made this conditional on gtk-doc build...
- emake -C doc install DESTDIR="${ED}"
-
- if use examples; then
- # Install example code
- insinto /usr/share/doc/${PF}/examples
- doins "${S}"/examples/*.c
- fi
-}