summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/kvazaar/kvazaar-9999.ebuild')
-rw-r--r--media-libs/kvazaar/kvazaar-9999.ebuild11
1 files changed, 10 insertions, 1 deletions
diff --git a/media-libs/kvazaar/kvazaar-9999.ebuild b/media-libs/kvazaar/kvazaar-9999.ebuild
index 48ce175d0487..b8685352e221 100644
--- a/media-libs/kvazaar/kvazaar-9999.ebuild
+++ b/media-libs/kvazaar/kvazaar-9999.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
GREATEST_PV="1.2.1"
@@ -24,9 +24,13 @@ SLOT="0/4"
IUSE="static-libs test"
REQUIRED_USE="test? ( static-libs )"
+RESTRICT="!test? ( test )"
ASM_DEP=">=dev-lang/yasm-1.2.0"
RDEPEND=""
DEPEND="${RDEPEND}
+ test? (
+ media-video/ffmpeg
+ )
abi_x86_32? ( ${ASM_DEP} )
abi_x86_64? ( ${ASM_DEP} )
"
@@ -42,6 +46,11 @@ src_prepare() {
fi
# Some m4 macros append Werror, we do not want that.
append-flags "-Wno-error"
+
+ # valgrind isn't available on all archs
+ # also, the valgrind tests fail with new ffmpeg (upstream only tests again ffmpeg 2.6.3)
+ # see https://github.com/ultravideo/kvazaar/issues/216
+ find "${S}/tests/" -type f -exec grep -q 'valgrind_test' '{}' \; -delete || die
}
multilib_src_configure() {