summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/libbdplus/libbdplus-9999.ebuild')
-rw-r--r--media-libs/libbdplus/libbdplus-9999.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/media-libs/libbdplus/libbdplus-9999.ebuild b/media-libs/libbdplus/libbdplus-9999.ebuild
new file mode 100644
index 000000000000..e5c04bcf0f49
--- /dev/null
+++ b/media-libs/libbdplus/libbdplus-9999.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools-multilib
+
+if [[ ${PV} == 9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="git://git.videolan.org/${PN}.git"
+else
+ SRC_URI="http://ftp.videolan.org/pub/videolan/${PN}/${PV}/${P}.tar.bz2"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Blu-ray library for BD+ decryption"
+HOMEPAGE="http://www.videolan.org/developers/libbdplus.html"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+IUSE="aacs static-libs"
+
+RDEPEND="dev-libs/libgcrypt:0=[${MULTILIB_USEDEP}]
+ dev-libs/libgpg-error[${MULTILIB_USEDEP}]
+ aacs? ( >=media-libs/libaacs-0.7.0[${MULTILIB_USEDEP}] )"
+DEPEND="${RDEPEND}"
+
+DOCS="ChangeLog README.txt"
+
+src_configure() {
+ local myeconfargs=(
+ --disable-optimizations
+ $(use_with aacs libaacs)
+ )
+ autotools-multilib_src_configure
+}