summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/rubberband')
-rw-r--r--media-libs/rubberband/Manifest1
-rw-r--r--media-libs/rubberband/rubberband-1.8.2.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/media-libs/rubberband/Manifest b/media-libs/rubberband/Manifest
index 6d6fc0353137..bfeba18d2f2b 100644
--- a/media-libs/rubberband/Manifest
+++ b/media-libs/rubberband/Manifest
@@ -1 +1,2 @@
DIST rubberband-1.8.1.tar.bz2 177501 BLAKE2B 57ca56abc7db2f2a25ff7c900daf24f32a892a1ef27099d34ab8ad290344ea8c5884cbace9206bfdf75262ee0c30bec8d736ae5398d5aaf92f73d0d5980e6932 SHA512 9721eaa36b80574f90b8ae5cfae388159a239e4257b8c85b9e55e7cf0dbbb9a996b857213a6a172a4ada5ff712e6936a16adbe08396e2ab1df3fd8d5a02a3620
+DIST rubberband-1.8.2.tar.bz2 182232 BLAKE2B 991debac51e0a5516a35e1d063d5ea2c51b9d193b6a183200b0869a6743e184fe4296168d6caaea7b811a4022d25c08ca7909f05491a0e91cfe7dda532ed29cb SHA512 da677f9a843711c44c52c0153faa62e587ac7c010569523ef4fef7ce941b9d292e566f46147700e496f6cfff4c9f22f9901dcc93f2d701fdb9de152ddac0c3a6
diff --git a/media-libs/rubberband/rubberband-1.8.2.ebuild b/media-libs/rubberband/rubberband-1.8.2.ebuild
new file mode 100644
index 000000000000..ae950d2a9928
--- /dev/null
+++ b/media-libs/rubberband/rubberband-1.8.2.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit multilib-minimal
+
+DESCRIPTION="An audio time-stretching and pitch-shifting library and utility program"
+HOMEPAGE="https://www.breakfastquay.com/rubberband/"
+SRC_URI="https://breakfastquay.com/files/releases/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="static-libs"
+
+RDEPEND="
+ media-libs/ladspa-sdk
+ media-libs/libsamplerate[${MULTILIB_USEDEP}]
+ media-libs/libsndfile
+ media-libs/vamp-plugin-sdk[${MULTILIB_USEDEP}]
+ sci-libs/fftw:3.0[${MULTILIB_USEDEP}]"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ default
+ if ! use static-libs ; then
+ sed -e '/^all:/s/$(STATIC_TARGET)//' \
+ -e '/^\tcp $(STATIC_TARGET)/d' \
+ -i Makefile.in || die
+ fi
+
+ sed -e '/cp -f.*JNI_TARGET/d' -i Makefile.in || die
+
+ multilib_copy_sources
+}
+
+multilib_src_install() {
+ emake INSTALL_BINDIR="${ED}/usr/bin" \
+ INSTALL_INCDIR="${ED}/usr/include/rubberband" \
+ INSTALL_LIBDIR="${ED}/usr/$(get_libdir)" \
+ INSTALL_VAMPDIR="${ED}/usr/$(get_libdir)/vamp" \
+ INSTALL_LADSPADIR="${ED}/usr/$(get_libdir)/ladspa" \
+ INSTALL_LRDFDIR="${ED}/usr/share/ladspa/rdf" \
+ INSTALL_PKGDIR="${ED}/usr/$(get_libdir)/pkgconfig" \
+ install
+}
+
+multilib_src_install_all() {
+ einstalldocs
+}