summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/vigra')
-rw-r--r--media-libs/vigra/vigra-1.11.1-r3.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/media-libs/vigra/vigra-1.11.1-r3.ebuild b/media-libs/vigra/vigra-1.11.1-r3.ebuild
index c9dfc49eed8e..f3b56a52e27c 100644
--- a/media-libs/vigra/vigra-1.11.1-r3.ebuild
+++ b/media-libs/vigra/vigra-1.11.1-r3.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{6,7,8} )
+PYTHON_COMPAT=( python3_{6,7,8,9} )
PYTHON_REQ_USE="threads(+),xml"
inherit cmake python-r1
@@ -97,7 +97,7 @@ src_prepare() {
if ! use test; then
cmake_comment_add_subdirectory test
- sed -e "/ADD_SUBDIRECTORY.*test/s/^/#DONT /" -i vigranumpy/CMakeLists.txt || die
+ cmake_run_in vigranumpy cmake_comment_add_subdirectory test
fi
}