summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/alsa-lib/alsa-lib-1.2.8-r1.ebuild (renamed from media-libs/alsa-lib/alsa-lib-1.2.8.ebuild)1
-rw-r--r--media-libs/alsa-lib/files/alsa-lib-1.2.8-clang16-macro.patch31
2 files changed, 32 insertions, 0 deletions
diff --git a/media-libs/alsa-lib/alsa-lib-1.2.8.ebuild b/media-libs/alsa-lib/alsa-lib-1.2.8-r1.ebuild
index ea97e535b5f7..60c8f343db4e 100644
--- a/media-libs/alsa-lib/alsa-lib-1.2.8.ebuild
+++ b/media-libs/alsa-lib/alsa-lib-1.2.8-r1.ebuild
@@ -34,6 +34,7 @@ BDEPEND="doc? ( >=app-doc/doxygen-1.2.6 )"
PATCHES=(
"${FILESDIR}/${PN}-1.1.6-missing_files.patch" # bug #652422
+ "${FILESDIR}/${PN}-1.2.8-clang16-macro.patch"
)
pkg_setup() {
diff --git a/media-libs/alsa-lib/files/alsa-lib-1.2.8-clang16-macro.patch b/media-libs/alsa-lib/files/alsa-lib-1.2.8-clang16-macro.patch
new file mode 100644
index 000000000000..c74a7cc73e26
--- /dev/null
+++ b/media-libs/alsa-lib/files/alsa-lib-1.2.8-clang16-macro.patch
@@ -0,0 +1,31 @@
+https://github.com/alsa-project/alsa-lib/pull/278
+
+From 68a233404279366f7c7e34afb6197bcc70f4b7d7 Mon Sep 17 00:00:00 2001
+From: Sam James <sam@gentoo.org>
+Date: Sun, 30 Oct 2022 18:06:37 +0000
+Subject: [PATCH] utils/alsa.m4: include <stdlib.h> for exit()
+
+Clang 16 makes -Wimplicit-function-declaration an error by default
+and it's easier to just explicitly include <stdlib.h> rather
+than hope the ALSA headers always have it.
+
+Signed-off-by: Sam James <sam@gentoo.org>
+--- a/utils/alsa.m4
++++ b/utils/alsa.m4
+@@ -85,6 +85,7 @@ AC_LANG_PUSH([C])
+ AC_MSG_CHECKING([for libasound headers version >= $alsa_min_major_version.$alsa_min_minor_version.$alsa_min_micro_version ($min_alsa_version)])
+ AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
+ #include <alsa/asoundlib.h>
++#include <stdlib.h>
+ ]], [[
+ /* ensure backward compatibility */
+ #if !defined(SND_LIB_MAJOR) && defined(SOUNDLIB_VERSION_MAJOR)
+@@ -130,6 +131,7 @@ AC_MSG_CHECKING([for libatopology (sound headers version > 1.1.9)])
+ AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
+ #include <alsa/asoundlib.h>
+ #include <alsa/topology.h>
++#include <stdlib.h>
+ ]], [[
+ /* ensure backward compatibility */
+ #if !defined(SND_LIB_VERSION)
+