summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-radio')
-rw-r--r--media-radio/svxlink/files/svxlink-15.11-gcc72.patch12
-rw-r--r--media-radio/svxlink/svxlink-15.11.ebuild5
2 files changed, 16 insertions, 1 deletions
diff --git a/media-radio/svxlink/files/svxlink-15.11-gcc72.patch b/media-radio/svxlink/files/svxlink-15.11-gcc72.patch
new file mode 100644
index 000000000000..a55894c62f34
--- /dev/null
+++ b/media-radio/svxlink/files/svxlink-15.11-gcc72.patch
@@ -0,0 +1,12 @@
+# backported fix for newer compilers
+--- src/async/audio/AsyncAudioDeviceAlsa.cpp.orig 2017-12-27 16:32:27.185098621 +0000
++++ src/async/audio/AsyncAudioDeviceAlsa.cpp 2017-12-27 16:33:33.468067578 +0000
+@@ -548,7 +548,7 @@
+ return false;
+ }
+
+- if (::abs(real_rate - sample_rate) > 100)
++ if (::abs(static_cast<int>(real_rate) - sample_rate) > 100)
+ {
+ cerr << "*** ERROR: The sample rate could not be set to "
+ << sample_rate << "Hz for ALSA device \"" << dev_name << "\". "
diff --git a/media-radio/svxlink/svxlink-15.11.ebuild b/media-radio/svxlink/svxlink-15.11.ebuild
index de0def111eaa..0eac5fc40fef 100644
--- a/media-radio/svxlink/svxlink-15.11.ebuild
+++ b/media-radio/svxlink/svxlink-15.11.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=5
-inherit cmake-utils qt4-r2 user
+inherit cmake-utils eutils qt4-r2 user
CMAKE_USE_DIR="${S}/src"
@@ -34,6 +34,9 @@ pkg_setup() {
}
src_prepare() {
+ # fix compilation problem with newer gcc bug #639592
+ epatch "${FILESDIR}"/${P}-gcc72.patch
+
cmake-utils_src_prepare
# drop deprecated desktop category (bug #475730)
sed -i -e "s:Categories=Application;:Categories=:g" src/qtel/qtel.desktop || die