summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-radio')
-rw-r--r--media-radio/direwolf/Manifest1
-rw-r--r--media-radio/direwolf/direwolf-1.4.ebuild39
-rw-r--r--media-radio/direwolf/files/1.4-makefile.patch89
-rw-r--r--media-radio/direwolf/files/direwolf-kiss.service10
-rw-r--r--media-radio/direwolf/files/direwolf.service10
-rw-r--r--media-radio/direwolf/metadata.xml8
6 files changed, 157 insertions, 0 deletions
diff --git a/media-radio/direwolf/Manifest b/media-radio/direwolf/Manifest
new file mode 100644
index 000000000000..531918335474
--- /dev/null
+++ b/media-radio/direwolf/Manifest
@@ -0,0 +1 @@
+DIST direwolf-1.4.tar.gz 17554878 BLAKE2B a8eea6777df93d66d67c993c23eba86f37ff1e23d95df842b17be1a9a0b83c4bb0b7b14b97f43a1756512d060e50136712d1d9d499b2567eabbe1092a2f5edf0 SHA512 597b0652e910642d5a3c538297e4306f9317c29b3629e7fd96cc33b92b2f09d743cea8b8a0cc6451347dc0877fcf1f3933a420ae58e33ad7be7d899f80036eb3
diff --git a/media-radio/direwolf/direwolf-1.4.ebuild b/media-radio/direwolf/direwolf-1.4.ebuild
new file mode 100644
index 000000000000..04a0995bbf20
--- /dev/null
+++ b/media-radio/direwolf/direwolf-1.4.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils systemd
+
+DESCRIPTION="Decoded Information from Radio Emissions for Windows Or Linux Fans"
+HOMEPAGE="https://github.com/wb2osz/direwolf/blob/master/README.md"
+SRC_URI="https://github.com/wb2osz/direwolf/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2 BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="media-libs/alsa-lib:="
+DEPEND="${RDEPEND}"
+
+DOCS=( CHANGES.md README.md doc/2400-4800-PSK-for-APRS-Packet-Radio.pdf doc/A-Better-APRS-Packet-Demodulator-Part-1-1200-baud.pdf doc/A-Better-APRS-Packet-Demodulator-Part-2-9600-baud.pdf doc/A-Closer-Look-at-the-WA8LMF-TNC-Test-CD.pdf doc/APRS-Telemetry-Toolkit.pdf doc/APRStt-Implementation-Notes.pdf doc/APRStt-interface-for-SARTrack.pdf doc/APRStt-Listening-Example.pdf doc/Going-beyond-9600-baud.pdf doc/Raspberry-Pi-APRS.pdf doc/Raspberry-Pi-APRS-Tracker.pdf doc/Raspberry-Pi-SDR-IGate.pdf doc/README.md doc/Successful-APRS-IGate-Operation.pdf doc/User-Guide.pdf doc/WA8LMF-TNC-Test-CD-Results.pdf direwolf.conf dw-start.sh sdr.conf telemetry-toolkit/telem-m0xer-3.txt telemetry-toolkit/telem-balloon.conf telemetry-toolkit/telem-volts.conf )
+
+INSTALLDIR="${D}"
+
+src_prepare() {
+ eapply_user
+ epatch "${FILESDIR}/${PV}-makefile.patch"
+}
+
+src_install() {
+ dodir /usr
+ dodir /usr/bin
+ dodir /var/log/direwolf
+ emake DESTDIR="${D}" install
+ insinto /etc/direwolf/
+ doins direwolf.conf
+ einstalldocs
+ systemd_dounit "${FILESDIR}"/direwolf.service
+ systemd_dounit "${FILESDIR}"/direwolf-kiss.service
+}
diff --git a/media-radio/direwolf/files/1.4-makefile.patch b/media-radio/direwolf/files/1.4-makefile.patch
new file mode 100644
index 000000000000..6424d8a72cc3
--- /dev/null
+++ b/media-radio/direwolf/files/1.4-makefile.patch
@@ -0,0 +1,89 @@
+--- direwolf-1.4-orig/Makefile.linux
++++ direwolf-1.4/Makefile.linux
+@@ -484,11 +484,12 @@ direwolf.conf : generic.conf
+ # This is a step in the right direction but not sufficient to use /usr instead.
+ # Eventually I'd like to have targets here to build the .DEB and .RPM packages.
+
+-INSTALLDIR := /usr/local
++DESTDIR ?= /usr/local
++INSTALLDIR ?= $(DESTDIR)usr/
+
+ # Command to "install" to system directories. Use "ginstall" for Mac.
+
+-INSTALL=install
++INSTALL=install
+
+ # direwolf.desktop was previously handcrafted for the Raspberry Pi.
+ # It was hardcoded with lxterminal, /home/pi, and so on.
+@@ -554,56 +555,37 @@ install : $(APPS) direwolf.conf tocalls.txt symbols-new.txt symbolsX.txt dw-icon
+ #
+ # Misc. data such as "tocall" to system mapping.
+ #
+- $(INSTALL) -D --mode=644 tocalls.txt /usr/share/direwolf/tocalls.txt
+- $(INSTALL) -D --mode=644 symbols-new.txt /usr/share/direwolf/symbols-new.txt
+- $(INSTALL) -D --mode=644 symbolsX.txt /usr/share/direwolf/symbolsX.txt
+- $(INSTALL) -D --mode=644 dw-icon.png /usr/share/direwolf/dw-icon.png
+- $(INSTALL) -D --mode=644 direwolf.desktop /usr/share/applications/direwolf.desktop
++ $(INSTALL) -D --mode=644 tocalls.txt $(INSTALLDIR)/share/direwolf/tocalls.txt
++ $(INSTALL) -D --mode=644 symbols-new.txt $(INSTALLDIR)/share/direwolf/symbols-new.txt
++ $(INSTALL) -D --mode=644 symbolsX.txt $(INSTALLDIR)/share/direwolf/symbolsX.txt
++ $(INSTALL) -D --mode=644 dw-icon.png $(INSTALLDIR)/share/direwolf/dw-icon.png
++ $(INSTALL) -D --mode=644 direwolf.desktop $(INSTALLDIR)/share/applications/direwolf.desktop
+ #
+ # Documentation. Various plain text files and PDF.
+ #
+- $(INSTALL) -D --mode=644 CHANGES.md $(INSTALLDIR)/share/doc/direwolf/CHANGES.md
+- $(INSTALL) -D --mode=644 LICENSE-dire-wolf.txt $(INSTALLDIR)/share/doc/direwolf/LICENSE-dire-wolf.txt
+- $(INSTALL) -D --mode=644 LICENSE-other.txt $(INSTALLDIR)/share/doc/direwolf/LICENSE-other.txt
+ #
+ # ./README.md is an overview for the project main page.
+ # doc/README.md contains an overview of the PDF file contents and is more useful here.
+ #
+- $(INSTALL) -D --mode=644 doc/README.md $(INSTALLDIR)/share/doc/direwolf/README.md
+- $(INSTALL) -D --mode=644 doc/User-Guide.pdf $(INSTALLDIR)/share/doc/direwolf/User-Guide.pdf
+- $(INSTALL) -D --mode=644 doc/Raspberry-Pi-APRS.pdf $(INSTALLDIR)/share/doc/direwolf/Raspberry-Pi-APRS.pdf
+- $(INSTALL) -D --mode=644 doc/Raspberry-Pi-APRS-Tracker.pdf $(INSTALLDIR)/share/doc/direwolf/Raspberry-Pi-APRS-Tracker.pdf
+- $(INSTALL) -D --mode=644 doc/Raspberry-Pi-SDR-IGate.pdf $(INSTALLDIR)/share/doc/direwolf/Raspberry-Pi-SDR-IGate.pdf
+- $(INSTALL) -D --mode=644 doc/APRStt-Implementation-Notes.pdf $(INSTALLDIR)/share/doc/direwolf/APRStt-Implementation-Notes.pdf
+- $(INSTALL) -D --mode=644 doc/APRStt-interface-for-SARTrack.pdf $(INSTALLDIR)/share/doc/direwolf/APRStt-interface-for-SARTrack.pdf
+- $(INSTALL) -D --mode=644 doc/APRS-Telemetry-Toolkit.pdf $(INSTALLDIR)/share/doc/direwolf/APRS-Telemetry-Toolkit.pdf
+- $(INSTALL) -D --mode=644 doc/A-Better-APRS-Packet-Demodulator-Part-1-1200-baud.pdf $(INSTALLDIR)/share/doc/direwolf/A-Better-APRS-Packet-Demodulator-Part-1-1200-baud.pdf
+- $(INSTALL) -D --mode=644 doc/A-Better-APRS-Packet-Demodulator-Part-2-9600-baud.pdf $(INSTALLDIR)/share/doc/direwolf/A-Better-APRS-Packet-Demodulator-Part-2-9600-baud.pdf
+ #
+ # Various sample config and other files go into examples under the doc directory.
+ # When building from source, these can be put in home directory with "make install-conf".
+ # When installed from .DEB or .RPM package, the user will need to copy these to
+ # the home directory or other desired location.
+ #
+- $(INSTALL) -D --mode=644 direwolf.conf $(INSTALLDIR)/share/doc/direwolf/examples/direwolf.conf
+- $(INSTALL) -D --mode=755 dw-start.sh $(INSTALLDIR)/share/doc/direwolf/examples/dw-start.sh
+- $(INSTALL) -D --mode=644 sdr.conf $(INSTALLDIR)/share/doc/direwolf/examples/sdr.conf
+- $(INSTALL) -D --mode=644 telemetry-toolkit/telem-m0xer-3.txt $(INSTALLDIR)/share/doc/direwolf/examples/telem-m0xer-3.txt
+- $(INSTALL) -D --mode=644 telemetry-toolkit/telem-balloon.conf $(INSTALLDIR)/share/doc/direwolf/examples/telem-balloon.conf
+- $(INSTALL) -D --mode=644 telemetry-toolkit/telem-volts.conf $(INSTALLDIR)/share/doc/direwolf/examples/telem-volts.conf
+ #
+ # "man" pages
+ #
+- $(INSTALL) -D --mode=644 man1/aclients.1 $(INSTALLDIR)/man/man1/aclients.1
+- $(INSTALL) -D --mode=644 man1/atest.1 $(INSTALLDIR)/man/man1/atest.1
+- $(INSTALL) -D --mode=644 man1/decode_aprs.1 $(INSTALLDIR)/man/man1/decode_aprs.1
+- $(INSTALL) -D --mode=644 man1/direwolf.1 $(INSTALLDIR)/man/man1/direwolf.1
+- $(INSTALL) -D --mode=644 man1/gen_packets.1 $(INSTALLDIR)/man/man1/gen_packets.1
+- $(INSTALL) -D --mode=644 man1/ll2utm.1 $(INSTALLDIR)/man/man1/ll2utm.1
+- $(INSTALL) -D --mode=644 man1/log2gpx.1 $(INSTALLDIR)/man/man1/log2gpx.1
+- $(INSTALL) -D --mode=644 man1/text2tt.1 $(INSTALLDIR)/man/man1/text2tt.1
+- $(INSTALL) -D --mode=644 man1/tt2text.1 $(INSTALLDIR)/man/man1/tt2text.1
+- $(INSTALL) -D --mode=644 man1/utm2ll.1 $(INSTALLDIR)/man/man1/utm2ll.1
++ $(INSTALL) -D --mode=644 man1/aclients.1 $(INSTALLDIR)/share/man/man1/aclients.1
++ $(INSTALL) -D --mode=644 man1/atest.1 $(INSTALLDIR)/share/man/man1/atest.1
++ $(INSTALL) -D --mode=644 man1/decode_aprs.1 $(INSTALLDIR)/share/man/man1/decode_aprs.1
++ $(INSTALL) -D --mode=644 man1/direwolf.1 $(INSTALLDIR)/share/man/man1/direwolf.1
++ $(INSTALL) -D --mode=644 man1/gen_packets.1 $(INSTALLDIR)/share/man/man1/gen_packets.1
++ $(INSTALL) -D --mode=644 man1/ll2utm.1 $(INSTALLDIR)/share/man/man1/ll2utm.1
++ $(INSTALL) -D --mode=644 man1/log2gpx.1 $(INSTALLDIR)/share/man/man1/log2gpx.1
++ $(INSTALL) -D --mode=644 man1/text2tt.1 $(INSTALLDIR)/share/man/man1/text2tt.1
++ $(INSTALL) -D --mode=644 man1/tt2text.1 $(INSTALLDIR)/share/man/man1/tt2text.1
++ $(INSTALL) -D --mode=644 man1/utm2ll.1 $(INSTALLDIR)/share/man/man1/utm2ll.1
+ #
+ @echo " "
+ @echo "If this is your first install, not an upgrade, type this to put a copy"
diff --git a/media-radio/direwolf/files/direwolf-kiss.service b/media-radio/direwolf/files/direwolf-kiss.service
new file mode 100644
index 000000000000..473feb246c31
--- /dev/null
+++ b/media-radio/direwolf/files/direwolf-kiss.service
@@ -0,0 +1,10 @@
+[Unit]
+Description=Dire Wolf
+
+[Service]
+Type=simple
+ExecStart=/usr/bin/direwolf -l /var/log/direwolf -p
+Restart=always
+
+[Install]
+WantedBy=multi-user.target
diff --git a/media-radio/direwolf/files/direwolf.service b/media-radio/direwolf/files/direwolf.service
new file mode 100644
index 000000000000..47eb3e7871bb
--- /dev/null
+++ b/media-radio/direwolf/files/direwolf.service
@@ -0,0 +1,10 @@
+[Unit]
+Description=Dire Wolf
+
+[Service]
+Type=simple
+ExecStart=/usr/bin/direwolf -l /var/log/direwolf
+Restart=always
+
+[Install]
+WantedBy=multi-user.target
diff --git a/media-radio/direwolf/metadata.xml b/media-radio/direwolf/metadata.xml
new file mode 100644
index 000000000000..12bc90833845
--- /dev/null
+++ b/media-radio/direwolf/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="person">
+ <email>rich0@gentoo.org</email>
+ <description>Primary maintainer</description>
+</maintainer>
+</pkgmetadata>