summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/adplay')
-rw-r--r--media-sound/adplay/Manifest1
-rw-r--r--media-sound/adplay/adplay-1.8.ebuild30
-rw-r--r--media-sound/adplay/metadata.xml1
3 files changed, 32 insertions, 0 deletions
diff --git a/media-sound/adplay/Manifest b/media-sound/adplay/Manifest
index 0bb775e5a859..95a5684f778a 100644
--- a/media-sound/adplay/Manifest
+++ b/media-sound/adplay/Manifest
@@ -1 +1,2 @@
DIST adplay-1.7.tar.bz2 264340 BLAKE2B ea9231c66a8233ee1d026bccd073440cbbc0e8868469aee33ec0e18c7d893fa24dd20bb4fe960f908db0666e7ee5c6a4afd14051b851b011418796cc0cc2c939 SHA512 854a9bee1057d3a42308d9149e74a8abae0b6bdfda5e1466086df9d6aeed4bbc92a045bca02917fc699b43195572b39c6316ddf56ee3441add1a01d6cbbdfcbe
+DIST adplay-1.8.tar.bz2 333582 BLAKE2B e5d0e3baf3f37adb1a2f42eee368fbbcb3947b0c651415b60d5f1d648d004789eae0ef75b7e6ac8ad9f90ac9941332e713e36555167648a40a871659083d1b59 SHA512 6a82b10fa73ad9317303da03d2fcb1fa97772d850f3f78f53c554b9daaa9ae5d04bc2f0a1b1d25fd5d3a1eab073641d6fa0589070721612987d57762f03363c7
diff --git a/media-sound/adplay/adplay-1.8.ebuild b/media-sound/adplay/adplay-1.8.ebuild
new file mode 100644
index 000000000000..76afd8fa9a6c
--- /dev/null
+++ b/media-sound/adplay/adplay-1.8.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="A console player for AdLib music"
+HOMEPAGE="https://adplug.github.io/"
+SRC_URI="https://github.com/adplug/adplay-unix/releases/download/v${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="alsa ao oss sdl"
+
+RDEPEND=">=media-libs/adplug-2.2.1
+ dev-cpp/libbinio
+ alsa? ( media-libs/alsa-lib )
+ ao? ( media-libs/libao )
+ sdl? ( media-libs/libsdl )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_configure() {
+ econf \
+ --disable-output-esound \
+ $(use_enable alsa output-alsa) \
+ $(use_enable ao output-ao) \
+ $(use_enable oss output-oss) \
+ $(use_enable sdl output-sdl)
+}
diff --git a/media-sound/adplay/metadata.xml b/media-sound/adplay/metadata.xml
index 3be2784242d4..dc329baaf1bf 100644
--- a/media-sound/adplay/metadata.xml
+++ b/media-sound/adplay/metadata.xml
@@ -7,5 +7,6 @@
</maintainer>
<upstream>
<remote-id type="sourceforge">adplug</remote-id>
+ <remote-id type="github">adplug/adplay-unix</remote-id>
</upstream>
</pkgmetadata>