summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/fapg/fapg-0.42.ebuild')
-rw-r--r--media-sound/fapg/fapg-0.42.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/media-sound/fapg/fapg-0.42.ebuild b/media-sound/fapg/fapg-0.42.ebuild
new file mode 100644
index 000000000000..52761727688a
--- /dev/null
+++ b/media-sound/fapg/fapg-0.42.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+DESCRIPTION="Fast Audio Playlist Generator"
+HOMEPAGE="http://royale.zerezo.com/fapg/"
+SRC_URI="http://royale.zerezo.com/fapg/${P}.tar.gz"
+IUSE="xspf"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+RDEPEND="xspf? ( >=dev-libs/uriparser-0.6.3 )"
+DEPEND="${RDEPEND}"
+
+src_compile() {
+ local myconf=""
+ use xspf || myconf="${myconf} --disable-xspf"
+ econf ${myconf}
+ emake || die "make failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS ChangeLog README
+}