summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/gramofile/files/gramofile-1.6-strlen_and_exit.patch')
-rw-r--r--media-sound/gramofile/files/gramofile-1.6-strlen_and_exit.patch56
1 files changed, 56 insertions, 0 deletions
diff --git a/media-sound/gramofile/files/gramofile-1.6-strlen_and_exit.patch b/media-sound/gramofile/files/gramofile-1.6-strlen_and_exit.patch
new file mode 100644
index 000000000000..4c35dd3eb2ff
--- /dev/null
+++ b/media-sound/gramofile/files/gramofile-1.6-strlen_and_exit.patch
@@ -0,0 +1,56 @@
+--- a/bplaysrc/Makefile
++++ b/bplaysrc/Makefile
+@@ -6,13 +6,12 @@
+ ../clrscr.o ../secshms.o
+ #SRCS = bplay.c sndfunc.o shmbuf.c
+
+-CC = gcc
+-LDFLAGS =
++CC ?= gcc
+
+ ########## CHOOSE YOUR ARCHITECTURE: (NOTE: also see ../Makefile!)
+
+ # For Linux (and maybe others), use these:
+-CFLAGS = -Wall -O2 -DUSEBUFFLOCK -DLP2CD -DVUMETER # -DDEBUG
++CFLAGS += -Wall -DUSEBUFFLOCK -DLP2CD -DVUMETER
+ LIBS = -lncurses
+
+ # For FreeBSD (and maybe others), use these:
+--- a/gramofile.c
++++ b/gramofile.c
+@@ -11,6 +11,7 @@
+ #include "splashscr.h"
+ #include <signal.h>
+ #include <unistd.h>
++#include <stdlib.h>
+ #include <string.h>
+ #ifndef OLD_CURSES
+ #include <ncurses.h>
+--- a/Makefile
++++ b/Makefile
+@@ -14,13 +14,12 @@
+ OBJS = $(SRCS:.c=.o)
+ SHELL = /bin/sh
+
+-CC = gcc
+-LDFLAGS =
++CC ?= gcc
+
+ ########## CHOOSE YOUR ARCHITECTURE: (NOTE: also see bplaysrc/Makefile!)
+
+ # For Linux (and maybe others), use these:
+-CFLAGS = -Wall -O2 -funroll-loops -DTURBO_MEDIAN -DTURBO_BUFFER
++CFLAGS += -Wall -DTURBO_MEDIAN -DTURBO_BUFFER
+ DEPS = $(OBJS) makebplay
+ LIBS = -lncurses -lrfftw -lfftw -lm
+ COPY_A = -a
+--- a/signpr_cmf3.c
++++ b/signpr_cmf3.c
+@@ -34,6 +34,7 @@
+ #include <stdlib.h>
+ #include <stdio.h>
+ #include <math.h>
++#include <string.h>
+ #ifndef OLD_CURSES
+ #include <ncurses.h>
+ #else