summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/lilypond')
-rw-r--r--media-sound/lilypond/Manifest1
-rw-r--r--media-sound/lilypond/lilypond-2.19.46.ebuild142
-rw-r--r--media-sound/lilypond/lilypond-9999.ebuild23
3 files changed, 157 insertions, 9 deletions
diff --git a/media-sound/lilypond/Manifest b/media-sound/lilypond/Manifest
index dd9b0f940b54..11113ee77269 100644
--- a/media-sound/lilypond/Manifest
+++ b/media-sound/lilypond/Manifest
@@ -1,2 +1,3 @@
DIST lilypond-2.18.2.tar.gz 16027977 SHA256 329d733765b0ba7be1878ae3f457dbbb875cc2840d2b75af4afc48c9454fba07 SHA512 0692f6eb41733076ba7f610cd1e65762f4dfd67307e2ab9e222b140d58ae3a1bb1c6b3be3bcff778d57f161868cf6d57e99bf43bf20f2663d042a07493942ec6 WHIRLPOOL 95db264992a1e425fd1ee53d980941eef554c1784a1adfc105750d82d11664f61207c2b1897b6e99448790131c0715f08401f45b663c420553925596c6fd4b1c
DIST lilypond-2.19.42.tar.gz 16870150 SHA256 f925284e994a67712c9d57437f2ff4329a987793e071d6944bdf32d762b81c8c SHA512 2f94656f20bae50797985657c0e557aca793044c8b9ae137ee6bbdee60cb4aa72cca0988d8ae19bf24cc4948d2ba73cb87ce9530a746daeb93632e0092ea5acf WHIRLPOOL 887f4fa188f999474ab3b3240dafb1130861b38768bfbae18dd2096488bfb645b189ab47563f5d6de0dee81279d6fe84f5d2c9af690db0c0e767cf26dfb1fa72
+DIST lilypond-2.19.46.tar.gz 16899476 SHA256 f609051e2128c40da17698c0432fe8a96858583d197a8264fc4bceeab0378674 SHA512 594921b784f6604bfb2210569fac03911cb5c4c11e2e9241f62153d7c012b5e10cd2cacd3ac3d69c1719c9b6fddc550d381a9fa9b96f22ada63019b38ef95de1 WHIRLPOOL b77b1bc76ccdf6e17179fd9b1497beac96da2bd1ce83b7944a2a8f4a5d6274581c8e7f4c9e2de44b53912df702731456cd2658d96cccb186347f1a4577146a4d
diff --git a/media-sound/lilypond/lilypond-2.19.46.ebuild b/media-sound/lilypond/lilypond-2.19.46.ebuild
new file mode 100644
index 000000000000..2a3aaafdadd4
--- /dev/null
+++ b/media-sound/lilypond/lilypond-2.19.46.ebuild
@@ -0,0 +1,142 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+
+[[ "${PV}" = "9999" ]] && inherit git-r3
+inherit elisp-common autotools python-single-r1
+
+if [[ "${PV}" = "9999" ]]; then
+ EGIT_REPO_URI="git://git.sv.gnu.org/lilypond.git"
+else
+ SRC_URI="http://download.linuxaudio.org/lilypond/sources/v${PV:0:4}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~hppa ~x86"
+fi
+
+DESCRIPTION="GNU Music Typesetter"
+HOMEPAGE="http://lilypond.org/"
+
+LICENSE="GPL-3 FDL-1.3"
+SLOT="0"
+LANGS=" ca cs da de el eo es fi fr it ja nl ru sv tr uk vi zh_TW"
+IUSE="debug emacs profile vim-syntax ${LANGS// / linguas_}"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND=">=app-text/ghostscript-gpl-8.15
+ >=dev-scheme/guile-1.8.2:12[deprecated,regex]
+ media-fonts/tex-gyre
+ media-libs/fontconfig
+ media-libs/freetype:2
+ >=x11-libs/pango-1.12.3
+ emacs? ( virtual/emacs )
+ ${PYTHON_DEPS}"
+DEPEND="${RDEPEND}
+ app-text/t1utils
+ dev-lang/perl
+ dev-libs/kpathsea
+ >=dev-texlive/texlive-metapost-2013
+ || (
+ >=app-text/texlive-core-2013
+ >=dev-tex/metapost-1.803
+ )
+ virtual/pkgconfig
+ media-gfx/fontforge[png]
+ >=sys-apps/texinfo-4.11
+ >=sys-devel/bison-2.0
+ sys-devel/flex
+ sys-devel/gettext
+ sys-devel/make"
+
+# Correct output data for tests isn't bundled with releases
+RESTRICT="test"
+
+DOCS=( DEDICATION HACKING README.txt ROADMAP )
+
+pkg_setup() {
+ # make sure >=metapost-1.803 is selected if it's installed, bug 498704
+ if [[ ${MERGE_TYPE} != binary ]] && has_version ">=dev-tex/metapost-1.803" ; then
+ if [[ $(readlink "${EROOT}"/usr/bin/mpost) =~ mpost-texlive-* ]] ; then
+ einfo "Updating metapost symlink"
+ eselect mpost update || die
+ fi
+ fi
+
+ python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+
+ if ! use vim-syntax ; then
+ sed -i 's/vim//' GNUmakefile.in || die
+ fi
+
+ # respect CFLAGS
+ sed -i 's/OPTIMIZE -g/OPTIMIZE/' aclocal.m4 || die
+
+ for lang in ${LANGS}; do
+ use linguas_${lang} || rm po/${lang}.po || die
+ done
+
+ # respect AR
+ sed -i "s/^AR=ar/AR=$(tc-getAR)/" stepmake/stepmake/library-vars.make || die
+
+ # remove bundled texinfo file (fixes bug #448560)
+ rm tex/texinfo.tex || die
+
+ eautoreconf
+}
+
+src_configure() {
+ # documentation generation currently not supported since it requires a newer
+ # version of texi2html than is currently in the tree
+
+ local myeconfargs+=(
+ --with-texgyre-dir=/usr/share/fonts/tex-gyre
+ --disable-documentation
+ --disable-optimising
+ --disable-pipe
+ $(use_enable debug debugging)
+ $(use_enable profile profiling)
+ )
+
+ has_version ">=dev-scheme/guile-2" && myeconfargs+=( --enable-guile2 )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_compile() {
+ default
+
+ if use emacs ; then
+ elisp-compile elisp/lilypond-{font-lock,indent,mode,what-beat}.el \
+ || die "elisp-compile failed"
+ fi
+}
+
+src_install () {
+ emake DESTDIR="${D}" vimdir=/usr/share/vim/vimfiles install
+
+ # remove elisp files since they are in the wrong directory
+ rm -r "${ED}"/usr/share/emacs || die
+
+ if use emacs ; then
+ elisp-install ${PN} elisp/*.{el,elc} elisp/out/*.el \
+ || die "elisp-install failed"
+ elisp-site-file-install "${FILESDIR}"/50${PN}-gentoo.el
+ fi
+
+ python_fix_shebang "${ED}"
+
+ einstalldocs
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}
diff --git a/media-sound/lilypond/lilypond-9999.ebuild b/media-sound/lilypond/lilypond-9999.ebuild
index f27ba3673fd5..2a3aaafdadd4 100644
--- a/media-sound/lilypond/lilypond-9999.ebuild
+++ b/media-sound/lilypond/lilypond-9999.ebuild
@@ -52,7 +52,7 @@ DEPEND="${RDEPEND}
# Correct output data for tests isn't bundled with releases
RESTRICT="test"
-DOCS=( README.txt )
+DOCS=( DEDICATION HACKING README.txt ROADMAP )
pkg_setup() {
# make sure >=metapost-1.803 is selected if it's installed, bug 498704
@@ -67,6 +67,8 @@ pkg_setup() {
}
src_prepare() {
+ default
+
if ! use vim-syntax ; then
sed -i 's/vim//' GNUmakefile.in || die
fi
@@ -84,8 +86,6 @@ src_prepare() {
# remove bundled texinfo file (fixes bug #448560)
rm tex/texinfo.tex || die
- eapply_user
-
eautoreconf
}
@@ -93,13 +93,18 @@ src_configure() {
# documentation generation currently not supported since it requires a newer
# version of texi2html than is currently in the tree
- econf \
- --with-texgyre-dir=/usr/share/fonts/tex-gyre \
- --disable-documentation \
- --disable-optimising \
- --disable-pipe \
- $(use_enable debug debugging) \
+ local myeconfargs+=(
+ --with-texgyre-dir=/usr/share/fonts/tex-gyre
+ --disable-documentation
+ --disable-optimising
+ --disable-pipe
+ $(use_enable debug debugging)
$(use_enable profile profiling)
+ )
+
+ has_version ">=dev-scheme/guile-2" && myeconfargs+=( --enable-guile2 )
+
+ econf "${myeconfargs[@]}"
}
src_compile() {