summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/mpdas/mpdas-0.3.0-r1.ebuild')
-rw-r--r--media-sound/mpdas/mpdas-0.3.0-r1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/media-sound/mpdas/mpdas-0.3.0-r1.ebuild b/media-sound/mpdas/mpdas-0.3.0-r1.ebuild
new file mode 100644
index 000000000000..4d2c873a6f85
--- /dev/null
+++ b/media-sound/mpdas/mpdas-0.3.0-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit toolchain-funcs
+
+DESCRIPTION="An AudioScrobbler client for MPD written in C++"
+HOMEPAGE="http://50hz.ws/mpdas/"
+SRC_URI="http://50hz.ws/${PN}/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="media-libs/libmpd
+ net-misc/curl"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_compile() {
+ tc-export CXX
+ emake CONFIG="/etc"
+}
+
+src_install() {
+ dobin ${PN}
+ doman ${PN}.1
+ newinitd "${FILESDIR}/${PN}.init" ${PN}
+ dodoc ChangeLog mpdasrc.example README
+}
+
+pkg_postinst() {
+ elog "For further configuration help consult the README in"
+ elog "${EPREFIX}/usr/share/doc/${PF}"
+}