summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/mt-daapd/mt-daapd-0.2.4.2.ebuild')
-rw-r--r--media-sound/mt-daapd/mt-daapd-0.2.4.2.ebuild69
1 files changed, 38 insertions, 31 deletions
diff --git a/media-sound/mt-daapd/mt-daapd-0.2.4.2.ebuild b/media-sound/mt-daapd/mt-daapd-0.2.4.2.ebuild
index a36e59993f8e..572b7c217878 100644
--- a/media-sound/mt-daapd/mt-daapd-0.2.4.2.ebuild
+++ b/media-sound/mt-daapd/mt-daapd-0.2.4.2.ebuild
@@ -1,11 +1,12 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=2
-inherit autotools eutils
+EAPI=7
+
+inherit autotools
DESCRIPTION="A multi-threaded implementation of Apple's DAAP server"
-HOMEPAGE="http://www.mt-daapd.org"
+HOMEPAGE="https://sourceforge.net/projects/mt-daapd/"
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
@@ -13,63 +14,69 @@ SLOT="0"
KEYWORDS="amd64 arm ~hppa ~mips ppc sh sparc x86 ~amd64-linux ~x86-linux"
IUSE="vorbis"
-RDEPEND="media-libs/libid3tag
- sys-libs/gdbm
- net-dns/avahi[dbus]
- vorbis? ( media-libs/libvorbis )"
+RDEPEND="
+ media-libs/libid3tag:=
+ net-dns/avahi:=[dbus]
+ sys-libs/gdbm:=
+ sys-libs/zlib:=
+ vorbis? (
+ media-libs/libvorbis:=
+ media-libs/libogg:=
+ )"
DEPEND="${RDEPEND}
virtual/pkgconfig"
-src_prepare() {
- cp "${FILESDIR}"/${PN}.init.2 initd
-
- sed -i -e 's:#USEHOWL need mDNSResponderPosix:need avahi-daemon:' initd
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.2.3-sparc.patch
+ "${FILESDIR}"/${PN}-0.2.4.1-libsorder.patch
+ "${FILESDIR}"/${PN}-0.2.4.1-pidfile.patch
+ "${FILESDIR}"/${P}-maintainer-mode.patch
+ "${FILESDIR}"/${P}-oggvorbis.patch
+)
- epatch "${FILESDIR}"/${PN}-0.2.3-sparc.patch \
- "${FILESDIR}"/${PN}-0.2.4.1-libsorder.patch \
- "${FILESDIR}"/${PN}-0.2.4.1-pidfile.patch \
- "${FILESDIR}"/${P}-maintainer-mode.patch \
- "${FILESDIR}"/${P}-oggvorbis.patch
+src_prepare() {
+ default
+ mv configure.{in,ac} || die
eautoreconf
}
src_configure() {
- econf $(use_enable vorbis oggvorbis) \
+ econf \
+ $(use_enable vorbis oggvorbis) \
--disable-maintainer-mode \
--enable-avahi \
--disable-mdns
}
src_install() {
- emake DESTDIR="${D}" install || die "emake install failed."
+ default
insinto /etc
newins contrib/mt-daapd.conf mt-daapd.conf.example
doins contrib/mt-daapd.playlist
- newinitd initd ${PN}
+ newinitd "${FILESDIR}"/${PN}.init.2 ${PN}
keepdir /var/cache/mt-daapd /etc/mt-daapd.d
- dodoc AUTHORS ChangeLog CREDITS NEWS README TODO
}
pkg_postinst() {
- einfo
+ elog
elog "You have to configure your mt-daapd.conf following"
- elog "/etc/mt-daapd.conf.example file."
- einfo
+ elog "${EROOT}/etc/mt-daapd.conf.example file."
+ elog
if use vorbis; then
- einfo
- elog "You need to edit you extensions list in /etc/mt-daapd.conf"
+ elog
+ elog "You need to edit you extensions list in ${EROOT}/etc/mt-daapd.conf"
elog "if you want your mt-daapd to serve ogg files."
- einfo
+ elog
fi
- einfo
+ elog
elog "If you want to start more than one ${PN} service, symlink"
- elog "/etc/init.d/${PN} to /etc/init.d/${PN}.<name>, and it will"
- elog "load the data from /etc/${PN}.d/<name>.conf."
+ elog "${EROOT}/etc/init.d/${PN} to ${EROOT}/etc/init.d/${PN}.<name>, and it will"
+ elog "load the data from ${EROOT}/etc/${PN}.d/<name>.conf."
elog "Make sure that you have different cache directories for them."
- einfo
+ elog
}