summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/teamspeak-client-bin/teamspeak-client-bin-3.0.19.4-r1.ebuild')
-rw-r--r--media-sound/teamspeak-client-bin/teamspeak-client-bin-3.0.19.4-r1.ebuild78
1 files changed, 0 insertions, 78 deletions
diff --git a/media-sound/teamspeak-client-bin/teamspeak-client-bin-3.0.19.4-r1.ebuild b/media-sound/teamspeak-client-bin/teamspeak-client-bin-3.0.19.4-r1.ebuild
deleted file mode 100644
index 9a0493fb0ba1..000000000000
--- a/media-sound/teamspeak-client-bin/teamspeak-client-bin-3.0.19.4-r1.ebuild
+++ /dev/null
@@ -1,78 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit desktop unpacker
-
-DESCRIPTION="TeamSpeak Client - Voice Communication Software"
-HOMEPAGE="https://www.teamspeak.com/"
-SRC_URI="
- amd64? ( http://ftp.4players.de/pub/hosted/ts3/releases/${PV}/TeamSpeak3-Client-linux_amd64-${PV/_/-}.run )
- x86? ( http://ftp.4players.de/pub/hosted/ts3/releases/${PV}/TeamSpeak3-Client-linux_x86-${PV/_/-}.run )"
-
-LICENSE="teamspeak3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="alsa pulseaudio"
-
-REQUIRED_USE="|| ( alsa pulseaudio )"
-
-RDEPEND="
- >=dev-libs/quazip-0.7.3[-qt4(-),qt5(+)]
- dev-qt/qtcore:5
- dev-qt/qtgui:5[accessibility]
- dev-qt/qtnetwork:5
- dev-qt/qtsql:5[sqlite]
- dev-qt/qtwidgets:5
- sys-libs/glibc
- sys-libs/zlib
- alsa? ( media-libs/alsa-lib )
- pulseaudio? ( media-sound/pulseaudio )"
-
-RESTRICT="mirror strip"
-
-S="${WORKDIR}"
-
-pkg_nofetch() {
- elog "Please download ${A}"
- elog "from ${HOMEPAGE}?page=downloads and place this"
- elog "file in ${DISTDIR}"
-}
-
-src_prepare() {
- default
-
- # Remove the qt-libraries as they just cause trouble with the system's Qt, see bug #328807.
- rm libQt* || die "Couldn't remove bundled Qt libraries."
-
- rm -r platforms sqldrivers qt.conf || die "Couldn't remove bundle Qt files."
-
- # Remove unwanted soundbackends.
- if ! use alsa ; then
- rm soundbackends/libalsa* || die
- fi
-
- if ! use pulseaudio ; then
- rm soundbackends/libpulseaudio* || die
- fi
-
- # Remove quazip
- rm libquazip.so || die
-
- # Rename the tsclient to its shorter version, required by the teamspeak3 script we install.
- mv ts3client_linux_* ts3client || die "Couldn't rename ts3client to its shorter version."
-}
-
-src_install() {
- insinto /opt/teamspeak3-client
- doins -r *
-
- fperms +x /opt/teamspeak3-client/ts3client
-
- dobin "${FILESDIR}/teamspeak3"
-
- make_desktop_entry teamspeak3 TeamSpeak3 \
- "/opt/teamspeak3-client/pluginsdk/docs/client_html/images/logo.png" \
- Network
-}