summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/abcmidi/Manifest6
-rw-r--r--media-sound/abcmidi/abcmidi-2022.05.05.ebuild35
-rw-r--r--media-sound/abcmidi/abcmidi-2022.05.20.ebuild35
-rw-r--r--media-sound/abcmidi/abcmidi-2022.06.14.ebuild (renamed from media-sound/abcmidi/abcmidi-2022.04.06.ebuild)0
-rw-r--r--media-sound/abcmidi/abcmidi-2022.08.01.ebuild (renamed from media-sound/abcmidi/abcmidi-2022.04.28.ebuild)0
-rw-r--r--media-sound/aeolus/Manifest1
-rw-r--r--media-sound/aeolus/aeolus-0.10.4.ebuild2
-rw-r--r--media-sound/aeolus/aeolus-0.9.9.ebuild59
-rw-r--r--media-sound/alsa-tools/Manifest1
-rw-r--r--media-sound/alsa-tools/alsa-tools-1.2.2-r1.ebuild152
-rw-r--r--media-sound/alsa-tools/metadata.xml9
-rw-r--r--media-sound/alsa-utils/Manifest3
-rw-r--r--media-sound/alsa-utils/alsa-utils-1.2.7-r1.ebuild (renamed from media-sound/alsa-utils/alsa-utils-1.2.5.1.ebuild)17
-rw-r--r--media-sound/alsa-utils/alsa-utils-1.2.7.ebuild (renamed from media-sound/alsa-utils/alsa-utils-1.2.4.ebuild)12
-rw-r--r--media-sound/alsa-utils/metadata.xml19
-rw-r--r--media-sound/alsaplayer/alsaplayer-0.99.81-r3.ebuild (renamed from media-sound/alsaplayer/alsaplayer-0.99.81-r2.ebuild)31
-rw-r--r--media-sound/alsaplayer/files/alsaplayer-0.99.81-autotools.patch37
-rw-r--r--media-sound/amsynth/Manifest1
-rw-r--r--media-sound/amsynth/amsynth-1.13.0.ebuild64
-rw-r--r--media-sound/apetag/apetag-1.12-r3.ebuild4
-rw-r--r--media-sound/ardour/ardour-6.9-r1.ebuild4
-rw-r--r--media-sound/ardour/ardour-9999.ebuild4
-rw-r--r--media-sound/audacious/Manifest3
-rw-r--r--media-sound/audacious/audacious-4.0.5.ebuild81
-rw-r--r--media-sound/audacious/audacious-4.2.ebuild (renamed from media-sound/audacious/audacious-4.1.ebuild)2
-rw-r--r--media-sound/audiotools/audiotools-3.1.1-r1.ebuild (renamed from media-sound/audiotools/audiotools-3.1.1.ebuild)8
-rw-r--r--media-sound/baudline/baudline-1.08-r2.ebuild (renamed from media-sound/baudline/baudline-1.08-r1.ebuild)13
-rw-r--r--media-sound/beets/beets-1.6.0.ebuild5
-rw-r--r--media-sound/beets/beets-9999.ebuild8
-rw-r--r--media-sound/bluez-alsa/Manifest2
-rw-r--r--media-sound/bluez-alsa/bluez-alsa-4.0.0.ebuild (renamed from media-sound/bluez-alsa/bluez-alsa-3.0.0.ebuild)26
-rw-r--r--media-sound/bluez-alsa/bluez-alsa-9999.ebuild19
-rw-r--r--media-sound/bluez-alsa/metadata.xml5
-rw-r--r--media-sound/cadence/Manifest2
-rw-r--r--media-sound/cadence/cadence-0.9.2-r1.ebuild (renamed from media-sound/cadence/cadence-0.9.1-r2.ebuild)16
-rw-r--r--media-sound/cadence/cadence-9999.ebuild13
-rw-r--r--media-sound/cadence/files/cadence-0.9.1-fix-qt5.15.patch34
-rw-r--r--media-sound/cantata/cantata-2.5.0.ebuild2
-rw-r--r--media-sound/cava/Manifest1
-rw-r--r--media-sound/cava/cava-0.8.1.ebuild75
-rw-r--r--media-sound/chuck/Manifest1
-rw-r--r--media-sound/chuck/chuck-1.4.1.0.ebuild70
-rw-r--r--media-sound/chuck/chuck-1.4.1.1.ebuild6
-rw-r--r--media-sound/chuck/files/chuck-1.4.0.0-makefile.patch27
-rw-r--r--media-sound/chuck/files/chuck-1.4.1.1-makefile.patch50
-rw-r--r--media-sound/cmus/Manifest2
-rw-r--r--media-sound/cmus/cmus-2.10.0.ebuild (renamed from media-sound/cmus/cmus-2.9.1-r1.ebuild)18
-rw-r--r--media-sound/cmus/cmus-9999.ebuild22
-rw-r--r--media-sound/combine_wave/combine_wave-0.3.1-r2.ebuild (renamed from media-sound/combine_wave/combine_wave-0.3.1-r1.ebuild)22
-rw-r--r--media-sound/combine_wave/files/combine_wave-0.3.1-makefile.patch22
-rw-r--r--media-sound/combine_wave/files/combine_wave-0.3.1-missing-includes.patch14
-rw-r--r--media-sound/csound/Manifest7
-rw-r--r--media-sound/csound/csound-6.16.2.ebuild262
-rw-r--r--media-sound/csound/csound-6.17.0.ebuild (renamed from media-sound/csound/csound-6.16.1.ebuild)84
-rw-r--r--media-sound/csound/csound-9999.ebuild5
-rw-r--r--media-sound/csound/files/csound-6.15.0-lame.patch26
-rw-r--r--media-sound/csound/metadata.xml6
-rw-r--r--media-sound/deadbeef/Manifest1
-rw-r--r--media-sound/deadbeef/deadbeef-1.9.1-r1.ebuild191
-rw-r--r--media-sound/denemo/denemo-2.6.0.ebuild2
-rw-r--r--media-sound/denonavr-cli/Manifest2
-rw-r--r--media-sound/denonavr-cli/denonavr-cli-2.ebuild27
-rw-r--r--media-sound/denonavr-cli/denonavr-cli-3.ebuild34
-rw-r--r--media-sound/denonavr-cli/metadata.xml12
-rw-r--r--media-sound/din/Manifest1
-rw-r--r--media-sound/din/din-53.1.ebuild57
-rw-r--r--media-sound/din/din-54.ebuild2
-rw-r--r--media-sound/dir2ogg/dir2ogg-0.13-r1.ebuild5
-rw-r--r--media-sound/drumstick/Manifest1
-rw-r--r--media-sound/drumstick/drumstick-2.6.0.ebuild65
-rw-r--r--media-sound/drumstick/drumstick-2.6.1.ebuild2
-rw-r--r--media-sound/easyeffects/Manifest2
-rw-r--r--media-sound/easyeffects/easyeffects-6.2.4.ebuild2
-rw-r--r--media-sound/easyeffects/easyeffects-6.2.6.ebuild79
-rw-r--r--media-sound/easyeffects/easyeffects-6.2.8.ebuild79
-rw-r--r--media-sound/easytag/easytag-2.4.3-r3.ebuild (renamed from media-sound/easytag/easytag-2.4.3-r2.ebuild)20
-rw-r--r--media-sound/ecasound/ecasound-2.9.3-r1.ebuild97
-rw-r--r--media-sound/elisa/Manifest3
-rw-r--r--media-sound/elisa/elisa-22.04.1.ebuild63
-rw-r--r--media-sound/elisa/elisa-22.04.3.ebuild (renamed from media-sound/elisa/elisa-21.12.3.ebuild)6
-rw-r--r--media-sound/exaile/Manifest1
-rw-r--r--media-sound/exaile/exaile-4.1.1-r1.ebuild (renamed from media-sound/exaile/exaile-4.1.1.ebuild)20
-rw-r--r--media-sound/exaile/exaile-4.1.2.ebuild68
-rw-r--r--media-sound/exaile/exaile-9999.ebuild22
-rw-r--r--media-sound/ezstream/ezstream-0.6.0-r2.ebuild (renamed from media-sound/ezstream/ezstream-0.6.0-r1.ebuild)17
-rw-r--r--media-sound/flac-image/flac-image-1.00-r1.ebuild (renamed from media-sound/flac-image/flac-image-1.00.ebuild)14
-rw-r--r--media-sound/flacon/Manifest2
-rw-r--r--media-sound/flacon/files/flacon-9.0.0-no-man-compress.patch21
-rw-r--r--media-sound/flacon/flacon-8.2.0.ebuild2
-rw-r--r--media-sound/flacon/flacon-9.0.0.ebuild88
-rw-r--r--media-sound/flacon/flacon-9.1.0.ebuild88
-rw-r--r--media-sound/flacon/metadata.xml9
-rw-r--r--media-sound/fluidsynth/Manifest3
-rw-r--r--media-sound/fluidsynth/fluidsynth-2.2.7.ebuild120
-rw-r--r--media-sound/fluidsynth/fluidsynth-2.2.8.ebuild (renamed from media-sound/fluidsynth/fluidsynth-2.2.6.ebuild)0
-rw-r--r--media-sound/fmit/fmit-1.0.15-r3.ebuild24
-rw-r--r--media-sound/frescobaldi/Manifest1
-rw-r--r--media-sound/frescobaldi/frescobaldi-3.2-r1.ebuild (renamed from media-sound/frescobaldi/frescobaldi-3.1.3.ebuild)9
-rw-r--r--media-sound/frescobaldi/frescobaldi-3.2.ebuild4
-rw-r--r--media-sound/gmorgan/files/gmorgan-0.79-remove-gettext-version-check.patch18
-rw-r--r--media-sound/gmorgan/gmorgan-0.79-r2.ebuild (renamed from media-sound/gmorgan/gmorgan-0.79-r1.ebuild)16
-rw-r--r--media-sound/gmusicbrowser/metadata.xml4
-rw-r--r--media-sound/gnome-music/Manifest2
-rw-r--r--media-sound/gnome-music/files/40.1.1-fix-build-with-meson-0.61.1.patch24
-rw-r--r--media-sound/gnome-music/gnome-music-41.0.ebuild81
-rw-r--r--media-sound/gnome-music/gnome-music-42.0.ebuild74
-rw-r--r--media-sound/gnome-music/gnome-music-42.1.ebuild2
-rw-r--r--media-sound/gnome-sound-recorder/Manifest1
-rw-r--r--media-sound/gnome-sound-recorder/files/40.0-fix-build-with-meson-0.61.1.patch43
-rw-r--r--media-sound/gnome-sound-recorder/gnome-sound-recorder-40.0.ebuild54
-rw-r--r--media-sound/gnome-sound-recorder/gnome-sound-recorder-42.0.ebuild2
-rw-r--r--media-sound/gpodder/Manifest3
-rw-r--r--media-sound/gpodder/gpodder-3.10.16-r1.ebuild66
-rw-r--r--media-sound/gpodder/gpodder-3.10.21-r1.ebuild (renamed from media-sound/gpodder/gpodder-3.10.20.ebuild)24
-rw-r--r--media-sound/gpodder/gpodder-3.11.0.ebuild (renamed from media-sound/gpodder/gpodder-3.10.21.ebuild)44
-rw-r--r--media-sound/gsm/gsm-1.0.13-r1.ebuild4
-rw-r--r--media-sound/guitarix/guitarix-0.44.1.ebuild2
-rw-r--r--media-sound/jack-audio-connection-kit/jack-audio-connection-kit-0.125.0-r1.ebuild4
-rw-r--r--media-sound/jack/metadata.xml3
-rw-r--r--media-sound/jack2/jack2-9999.ebuild6
-rw-r--r--media-sound/jalv/jalv-1.6.6.ebuild6
-rw-r--r--media-sound/kid3/Manifest1
-rw-r--r--media-sound/kid3/kid3-3.9.2.ebuild100
-rw-r--r--media-sound/klick/klick-0.12.2-r3.ebuild54
-rw-r--r--media-sound/kmidimon/Manifest1
-rw-r--r--media-sound/kmidimon/kmidimon-1.2.0.ebuild39
-rw-r--r--media-sound/kmidimon/kmidimon-1.3.0.ebuild2
-rw-r--r--media-sound/lash/lash-0.5.4-r5.ebuild (renamed from media-sound/lash/lash-0.5.4-r4.ebuild)4
-rw-r--r--media-sound/lilypond/lilypond-9999.ebuild4
-rw-r--r--media-sound/lmms/metadata.xml4
-rw-r--r--media-sound/mixxx/Manifest2
-rw-r--r--media-sound/mixxx/mixxx-2.3.3.ebuild (renamed from media-sound/mixxx/mixxx-2.3.2.ebuild)14
-rw-r--r--media-sound/mixxx/mixxx-2.3.9999.ebuild14
-rw-r--r--media-sound/mixxx/mixxx-9999.ebuild14
-rw-r--r--media-sound/mp32ogg/mp32ogg-0.11-r7.ebuild (renamed from media-sound/mp32ogg/mp32ogg-0.11-r6.ebuild)20
-rw-r--r--media-sound/mp3blaster/mp3blaster-3.2.6-r1.ebuild (renamed from media-sound/mp3blaster/mp3blaster-3.2.6.ebuild)17
-rw-r--r--media-sound/mp3val/files/mp3val-0.1.8-makefile.patch12
-rw-r--r--media-sound/mp3val/files/mp3val-0.1.8-open.patch20
-rw-r--r--media-sound/mp3val/mp3val-0.1.8-r1.ebuild (renamed from media-sound/mp3val/mp3val-0.1.8.ebuild)27
-rw-r--r--media-sound/mpc/Manifest1
-rw-r--r--media-sound/mpc/mpc-0.33.ebuild54
-rw-r--r--media-sound/mpc/mpc-0.34.ebuild4
-rw-r--r--media-sound/mpd/Manifest1
-rw-r--r--media-sound/mpd/mpd-0.23.7.ebuild2
-rw-r--r--media-sound/mpd/mpd-0.23.8.ebuild293
-rw-r--r--media-sound/mpdscribble/Manifest2
-rw-r--r--media-sound/mpdscribble/files/mpdscribble-0.23-gcc12-time.patch37
-rw-r--r--media-sound/mpdscribble/mpdscribble-0.22.ebuild31
-rw-r--r--media-sound/mpdscribble/mpdscribble-0.23.ebuild42
-rw-r--r--media-sound/mpdscribble/mpdscribble-0.24.ebuild3
-rw-r--r--media-sound/mpg123/Manifest4
-rw-r--r--media-sound/mpg123/mpg123-1.30.0.ebuild (renamed from media-sound/mpg123/mpg123-1.29.3.ebuild)0
-rw-r--r--media-sound/mpg123/mpg123-1.30.1.ebuild108
-rw-r--r--media-sound/mpg123/mpg123-1.30.2.ebuild108
-rw-r--r--media-sound/mps-youtube/mps-youtube-0.2.8-r3.ebuild (renamed from media-sound/mps-youtube/mps-youtube-0.2.8-r2.ebuild)8
-rw-r--r--media-sound/mps-youtube/mps-youtube-9999.ebuild6
-rw-r--r--media-sound/mumble/Manifest3
-rw-r--r--media-sound/mumble/files/mumble-1.4.230-gcc12-include-memory.patch28
-rw-r--r--media-sound/mumble/files/mumble-1.4.230-poco-link-cmake.patch24
-rw-r--r--media-sound/mumble/metadata.xml17
-rw-r--r--media-sound/mumble/mumble-1.3.4.ebuild160
-rw-r--r--media-sound/mumble/mumble-1.4.230-r1.ebuild135
-rw-r--r--media-sound/mumble/mumble-9999.ebuild132
-rw-r--r--media-sound/mup/Manifest2
-rw-r--r--media-sound/mup/files/mup-6.6-makefile.patch69
-rw-r--r--media-sound/mup/files/mup-6.9-build-system.patch125
-rw-r--r--media-sound/mup/mup-6.6.ebuild44
-rw-r--r--media-sound/mup/mup-6.9.ebuild54
-rw-r--r--media-sound/murmur/Manifest4
-rw-r--r--media-sound/murmur/files/murmur.confd9
-rw-r--r--media-sound/murmur/files/murmur.initd-r125
-rw-r--r--media-sound/murmur/files/murmur.initd-r224
-rw-r--r--media-sound/murmur/files/murmur.logrotate8
-rw-r--r--media-sound/murmur/files/murmurd-dbus.tmpfiles1
-rw-r--r--media-sound/murmur/metadata.xml15
-rw-r--r--media-sound/murmur/murmur-1.3.3.ebuild162
-rw-r--r--media-sound/murmur/murmur-1.3.4.ebuild162
-rw-r--r--media-sound/murmur/murmur-1.4.230-r2.ebuild176
-rw-r--r--media-sound/murmur/murmur-9999.ebuild170
-rw-r--r--media-sound/musescore/musescore-3.6.2-r1.ebuild (renamed from media-sound/musescore/musescore-3.6.2.ebuild)9
-rw-r--r--media-sound/musescore/musescore-9999.ebuild10
-rw-r--r--media-sound/ncmpc/Manifest2
-rw-r--r--media-sound/ncmpc/ncmpc-0.47.ebuild (renamed from media-sound/ncmpc/ncmpc-0.46.ebuild)2
-rw-r--r--media-sound/openmpt123/Manifest2
-rw-r--r--media-sound/openmpt123/openmpt123-0.6.4.ebuild (renamed from media-sound/openmpt123/openmpt123-0.6.3.ebuild)0
-rw-r--r--media-sound/pamix/metadata.xml5
-rw-r--r--media-sound/paprefs/paprefs-1.2-r2.ebuild (renamed from media-sound/paprefs/paprefs-1.2-r1.ebuild)3
-rw-r--r--media-sound/pasystray/pasystray-0.8.0-r1.ebuild2
-rw-r--r--media-sound/patchage/Manifest2
-rw-r--r--media-sound/patchage/files/patchage-1.0.4-fix-compilation.patch48
-rw-r--r--media-sound/patchage/metadata.xml17
-rw-r--r--media-sound/patchage/patchage-1.0.6.ebuild (renamed from media-sound/patchage/patchage-1.0.4.ebuild)18
-rw-r--r--media-sound/pianobar/Manifest1
-rw-r--r--media-sound/pianobar/metadata.xml3
-rw-r--r--media-sound/pianobar/pianobar-2022.04.01.ebuild47
-rw-r--r--media-sound/pianobar/pianobar-9999.ebuild13
-rw-r--r--media-sound/picard/Manifest2
-rw-r--r--media-sound/picard/picard-2.8.2.ebuild (renamed from media-sound/picard/picard-2.7.3.ebuild)1
-rw-r--r--media-sound/picard/picard-9999.ebuild3
-rw-r--r--media-sound/pithos/pithos-1.5.1-r1.ebuild (renamed from media-sound/pithos/pithos-1.5.1.ebuild)16
-rw-r--r--media-sound/pms/files/pms-0.42_p20170508-gcc12-time.patch11
-rw-r--r--media-sound/pms/pms-0.42_p20170508-r1.ebuild6
-rw-r--r--media-sound/pms/pms-9999.ebuild36
-rw-r--r--media-sound/podracer/podracer-1.4-r2.ebuild37
-rw-r--r--media-sound/podracer/podracer-1.4-r3.ebuild42
-rw-r--r--media-sound/puddletag/Manifest1
-rw-r--r--media-sound/puddletag/puddletag-2.2.0.ebuild31
-rw-r--r--media-sound/pulseaudio-ctl/Manifest3
-rw-r--r--media-sound/pulseaudio-ctl/pulseaudio-ctl-1.67.ebuild23
-rw-r--r--media-sound/pulseaudio-ctl/pulseaudio-ctl-1.68.ebuild21
-rw-r--r--media-sound/pulseaudio-ctl/pulseaudio-ctl-1.69.ebuild21
-rw-r--r--media-sound/pulseaudio-daemon/Manifest3
-rw-r--r--media-sound/pulseaudio-daemon/files/pulseaudio-16.0-optional-module-console-kit.patch76
-rw-r--r--media-sound/pulseaudio-daemon/metadata.xml28
-rw-r--r--media-sound/pulseaudio-daemon/pulseaudio-daemon-16.0-r1.ebuild (renamed from media-sound/pulseaudio-daemon/pulseaudio-daemon-15.99.1-r2.ebuild)78
-rw-r--r--media-sound/pulseaudio-daemon/pulseaudio-daemon-16.1.ebuild (renamed from media-sound/pulseaudio/pulseaudio-15.0-r3.ebuild)325
-rw-r--r--media-sound/pulseaudio-modules-bt/Manifest1
-rw-r--r--media-sound/pulseaudio-modules-bt/pulseaudio-modules-bt-1.4.ebuild81
-rw-r--r--media-sound/pulseaudio/Manifest2
-rw-r--r--media-sound/pulseaudio/files/pulseaudio-11.1-disable-flat-volumes.patch48
-rw-r--r--media-sound/pulseaudio/files/pulseaudio-13.0-clang.patch25
-rw-r--r--media-sound/pulseaudio/files/pulseaudio-14.99.2-require-GIO-for-RTP-GStreamer.patch51
-rw-r--r--media-sound/pulseaudio/files/pulseaudio-14.99.2-require-bluez-dependency.patch89
-rw-r--r--media-sound/pulseaudio/files/pulseaudio-15.0-xice-xsm-xtst-daemon-only.patch25
-rw-r--r--media-sound/pulseaudio/files/pulseaudio.conf.d6
-rw-r--r--media-sound/pulseaudio/files/pulseaudio.init.d-580
-rw-r--r--media-sound/pulseaudio/files/pulseaudio.service10
-rw-r--r--media-sound/pulseaudio/files/pulseaudio.tmpfiles1
-rw-r--r--media-sound/pulseaudio/metadata.xml83
-rw-r--r--media-sound/pulseaudio/pulseaudio-13.0-r1.ebuild355
-rw-r--r--media-sound/pulseaudio/pulseaudio-15.0-r2.ebuild375
-rw-r--r--media-sound/pulseaudio/pulseaudio-16.0.ebuild (renamed from media-sound/pulseaudio/pulseaudio-15.99.1-r1.ebuild)10
-rw-r--r--media-sound/pulseaudio/pulseaudio-16.1.ebuild29
-rw-r--r--media-sound/pulseeffects/Manifest3
-rw-r--r--media-sound/pulseeffects/files/pulseeffects-4.8.5-meson_no_automagic.patch55
-rw-r--r--media-sound/pulseeffects/files/pulseeffects-4.8.6-boost_1.79.patch25
-rw-r--r--media-sound/pulseeffects/files/pulseeffects-4.8.7-meson_no_automagic.patch (renamed from media-sound/pulseeffects/files/pulseeffects-4.8.6-meson_no_automagic.patch)2
-rw-r--r--media-sound/pulseeffects/pulseeffects-4.8.6.ebuild87
-rw-r--r--media-sound/pulseeffects/pulseeffects-4.8.7.ebuild (renamed from media-sound/pulseeffects/pulseeffects-4.8.5-r1.ebuild)18
-rw-r--r--media-sound/qmmp/Manifest3
-rw-r--r--media-sound/qmmp/qmmp-1.5.4.ebuild159
-rw-r--r--media-sound/qmmp/qmmp-1.6.1-r1.ebuild (renamed from media-sound/qmmp/qmmp-1.6.0.ebuild)14
-rw-r--r--media-sound/qmmp/qmmp-9999.ebuild8
-rw-r--r--media-sound/qtractor/Manifest1
-rw-r--r--media-sound/qtractor/qtractor-0.9.27.ebuild103
-rw-r--r--media-sound/rexima/files/rexima-1.4-makefile.patch24
-rw-r--r--media-sound/rexima/rexima-1.4-r2.ebuild (renamed from media-sound/rexima/rexima-1.4-r1.ebuild)20
-rw-r--r--media-sound/rhythmbox/Manifest2
-rw-r--r--media-sound/rhythmbox/files/3.4.5-relax-meson-version-check.patch42
-rw-r--r--media-sound/rhythmbox/rhythmbox-3.4.6.ebuild (renamed from media-sound/rhythmbox/rhythmbox-3.4.5.ebuild)10
-rw-r--r--media-sound/rosegarden/Manifest2
-rw-r--r--media-sound/rosegarden/rosegarden-22.06.ebuild (renamed from media-sound/rosegarden/rosegarden-21.12.ebuild)0
-rw-r--r--media-sound/schismtracker/Manifest2
-rw-r--r--media-sound/schismtracker/schismtracker-20220506.ebuild2
-rw-r--r--media-sound/schismtracker/schismtracker-20220807.ebuild (renamed from media-sound/schismtracker/schismtracker-20220125.ebuild)8
-rw-r--r--media-sound/snapcast/snapcast-0.26.0.ebuild2
-rw-r--r--media-sound/sndfile-tools/metadata.xml3
-rw-r--r--media-sound/sndio/files/sndio-1.8.0-fix-hardcoded-pkgconfdir.patch12
-rw-r--r--media-sound/sndio/sndio-1.8.0-r1.ebuild55
-rw-r--r--media-sound/sonata/sonata-1.7.0-r1.ebuild (renamed from media-sound/sonata/sonata-1.7.0.ebuild)13
-rw-r--r--media-sound/sooperlooper/metadata.xml11
-rw-r--r--media-sound/soundconverter/Manifest2
-rw-r--r--media-sound/soundconverter/metadata.xml1
-rw-r--r--media-sound/soundconverter/soundconverter-3.0.2-r1.ebuild65
-rw-r--r--media-sound/soundconverter/soundconverter-4.0.3.ebuild99
-rw-r--r--media-sound/sox/sox-14.4.2_p20210509.ebuild4
-rw-r--r--media-sound/spek/Manifest1
-rw-r--r--media-sound/spek/files/spek-0.8.4-disable-updates.patch11
-rw-r--r--media-sound/spek/spek-0.8.4.ebuild33
-rw-r--r--media-sound/spotify/metadata.xml20
-rw-r--r--media-sound/strawberry/Manifest4
-rw-r--r--media-sound/strawberry/metadata.xml4
-rw-r--r--media-sound/strawberry/strawberry-1.0.5.ebuild (renamed from media-sound/strawberry/strawberry-1.0.4.ebuild)0
-rw-r--r--media-sound/strawberry/strawberry-1.0.6.ebuild120
-rw-r--r--media-sound/strawberry/strawberry-1.0.7.ebuild120
-rw-r--r--media-sound/tagtool/files/tagtool-0.12.3-QA-desktop.patch10
-rw-r--r--media-sound/tagtool/files/tagtool-0.12.3-autotools.patch (renamed from media-sound/tagtool/files/tagtool-0.12.3-underlinking.patch)24
-rw-r--r--media-sound/tagtool/tagtool-0.12.3-r2.ebuild (renamed from media-sound/tagtool/tagtool-0.12.3-r1.ebuild)26
-rw-r--r--media-sound/teamspeak-client/Manifest2
-rw-r--r--media-sound/teamspeak-client/teamspeak-client-5.0.0_beta70.ebuild (renamed from media-sound/teamspeak-client/teamspeak-client-5.0.0_beta68.ebuild)4
-rw-r--r--media-sound/teamspeak-server/Manifest4
-rw-r--r--media-sound/teamspeak-server/teamspeak-server-3.13.7.ebuild (renamed from media-sound/teamspeak-server/teamspeak-server-3.13.6-r1.ebuild)0
-rw-r--r--media-sound/umurmur/Manifest3
-rw-r--r--media-sound/umurmur/files/umurmur-0.2.20-openssl3.patch11
-rw-r--r--media-sound/umurmur/files/umurmur.conf58
-rw-r--r--media-sound/umurmur/files/umurmurd.confd3
-rw-r--r--media-sound/umurmur/files/umurmurd.initd18
-rw-r--r--media-sound/umurmur/files/umurmurd.service15
-rw-r--r--media-sound/umurmur/metadata.xml29
-rw-r--r--media-sound/umurmur/umurmur-0.2.17-r4.ebuild111
-rw-r--r--media-sound/umurmur/umurmur-0.2.19.ebuild110
-rw-r--r--media-sound/umurmur/umurmur-0.2.20.ebuild114
-rw-r--r--media-sound/umurmur/umurmur-9999.ebuild110
-rw-r--r--media-sound/upmpdcli/Manifest2
-rw-r--r--media-sound/upmpdcli/upmpdcli-1.5.17.ebuild17
-rw-r--r--media-sound/upmpdcli/upmpdcli-1.5.19.ebuild (renamed from media-sound/upmpdcli/upmpdcli-1.5.13.ebuild)19
-rw-r--r--media-sound/vorbisgain/files/vorbisgain-0.37-wformat-security.patch13
-rw-r--r--media-sound/vorbisgain/vorbisgain-0.37-r4.ebuild (renamed from media-sound/vorbisgain/vorbisgain-0.37-r3.ebuild)2
-rw-r--r--media-sound/wavpack/Manifest2
-rw-r--r--media-sound/wavpack/wavpack-5.5.0.ebuild (renamed from media-sound/wavpack/wavpack-5.4.0.ebuild)14
-rw-r--r--media-sound/whipper/whipper-0.10.0.ebuild4
-rw-r--r--media-sound/xmms2/Manifest3
-rw-r--r--media-sound/xmms2/files/xmms2-0.8-rtvg.patch31
-rw-r--r--media-sound/xmms2/files/xmms2-0.8_p20161122-cpp-client.patch16
-rw-r--r--media-sound/xmms2/files/xmms2-0.8_p20161122-faad.patch16
-rw-r--r--media-sound/xmms2/files/xmms2-0.8_p20161122-mac-4.patch38
-rw-r--r--media-sound/xmms2/files/xmms2-0.8_p20201016-ffmpeg5.patch127
-rw-r--r--media-sound/xmms2/xmms2-0.8_p20201016-r2.ebuild237
-rw-r--r--media-sound/xmms2/xmms2-0.9.1.ebuild4
-rw-r--r--media-sound/yarock/yarock-1.4.0-r3.ebuild (renamed from media-sound/yarock/yarock-1.4.0-r2.ebuild)6
-rw-r--r--media-sound/yoshimi/Manifest2
-rw-r--r--media-sound/yoshimi/yoshimi-2.2.0.ebuild2
-rw-r--r--media-sound/yoshimi/yoshimi-2.2.1.ebuild (renamed from media-sound/yoshimi/yoshimi-2.1.2.2.ebuild)2
313 files changed, 3642 insertions, 6762 deletions
diff --git a/media-sound/abcmidi/Manifest b/media-sound/abcmidi/Manifest
index 367808f9cfb..6b297b186d6 100644
--- a/media-sound/abcmidi/Manifest
+++ b/media-sound/abcmidi/Manifest
@@ -1,4 +1,2 @@
-DIST abcMIDI-2022.04.06.zip 609956 BLAKE2B c140bcacc94d8e6193ba6220c1747861a11d79e5b394ff5826edfdb3029e57b3a6d9443a557baf6279d4a7c9e6488dcb2c8d0e6a05858046be53fc52be2640bd SHA512 06d4ddfc4f7bbc1906604629e3b2ca7ebf8d2f89edb478d2068b2ba4efab6ff1d96aeebd6344ea2ebc7a92c23cf49d08b40bc97c47458e526d505313fb52a527
-DIST abcMIDI-2022.04.28.zip 610114 BLAKE2B 73ef4569bf58cf45c5b8972150d7e81d84c88b4ca05d616a06df9585c5fca1ca73d635699db323583402113c1b783979d1d34719ae107700843cfc42ee209268 SHA512 1e17d493597bb2d22b491587c0bbb86e04aed8ea2af2f426e48c68871ec0fcd1180e78f0ccc44d9bd63c5d98cbb22db5a9aa8b66a15bfcc35aa7e9770c813350
-DIST abcMIDI-2022.05.05.zip 610217 BLAKE2B 241d9ae42defef6345b143c59140f1cee844c19608b6a897b020f0a54c915d45edaf09ef75e1e01b1a932a6e82934aaa82d1e82c74c61d23e1c372418726bff8 SHA512 7f8141792e67e5ed22e84d35f0f9894c5ecba74817ac9c23323d5e7777bad0a3fc477daf43bf515e243aad46476c3a9597d8e9b4e0e865210b5baad0a1ebc6d3
-DIST abcMIDI-2022.05.20.zip 611325 BLAKE2B 1fd9c786ec0a7b3558f71502ceda261419b6883dffe524de6f5203188f5ee618d52ad1cba0662d28a3ba4c252702abf4d5a2e4271b951916e9164c9d573b28ff SHA512 f6e8212c4bc96fc62f95c868f65bfd40208f2aeb5d4913fe1b4d85331dae69a763cfc3db9f446018dd0b43afaec496b6572ea0c46ebeac563902899b71f24645
+DIST abcMIDI-2022.06.14.zip 612729 BLAKE2B f9644ea59bb43d50a39f60f31f440e9d4e425701c71877fb812adeaa0757da37d2aabab5c2b3593f38a5a135adc0925545337860452317e558cbfb037c95d4af SHA512 4e8a9a770925e166dabdbf459227b26373c33ed0ec356d093d8f4de457cc9034cd9237d445f31883e7c3974c3fd4b69a6f6fb156b26e03483bcd70793e7457ec
+DIST abcMIDI-2022.08.01.zip 613060 BLAKE2B 9d488dcfd427e45ea73322e78af46772a090a6319622b826c45fdebe6f4e34a0ed83aa0086366854c3fd921c9e016a39dfa73c6827861321e44e2062491a2ed5 SHA512 6fe63ad1829de9c46b792ec6f6dc7edfa8717cc93a2f93d5e91b70af2595b44ed9117d072f4d0505fc0f0971a82f94d709a937a0643936dbb8f7d79d102409fe
diff --git a/media-sound/abcmidi/abcmidi-2022.05.05.ebuild b/media-sound/abcmidi/abcmidi-2022.05.05.ebuild
deleted file mode 100644
index 11f547f4cb8..00000000000
--- a/media-sound/abcmidi/abcmidi-2022.05.05.ebuild
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit autotools
-
-MY_P="abcMIDI-${PV}"
-DESCRIPTION="Programs for processing ABC music notation files"
-HOMEPAGE="https://ifdo.ca/~seymour/runabc/top.html"
-SRC_URI="https://ifdo.ca/~seymour/runabc/${MY_P}.zip"
-S="${WORKDIR}"/${PN}
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="examples"
-
-BDEPEND="app-arch/unzip"
-
-src_prepare() {
- default
- sed -i "s:-O2::" configure.ac || die
- sed -i "s:@datarootdir@/doc/abcmidi:@docdir@:" Makefile.in || die
- eautoreconf
-}
-
-src_install() {
- default
-
- if use examples ; then
- docinto examples
- dodoc samples/*.abc
- fi
-}
diff --git a/media-sound/abcmidi/abcmidi-2022.05.20.ebuild b/media-sound/abcmidi/abcmidi-2022.05.20.ebuild
deleted file mode 100644
index 11f547f4cb8..00000000000
--- a/media-sound/abcmidi/abcmidi-2022.05.20.ebuild
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit autotools
-
-MY_P="abcMIDI-${PV}"
-DESCRIPTION="Programs for processing ABC music notation files"
-HOMEPAGE="https://ifdo.ca/~seymour/runabc/top.html"
-SRC_URI="https://ifdo.ca/~seymour/runabc/${MY_P}.zip"
-S="${WORKDIR}"/${PN}
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="examples"
-
-BDEPEND="app-arch/unzip"
-
-src_prepare() {
- default
- sed -i "s:-O2::" configure.ac || die
- sed -i "s:@datarootdir@/doc/abcmidi:@docdir@:" Makefile.in || die
- eautoreconf
-}
-
-src_install() {
- default
-
- if use examples ; then
- docinto examples
- dodoc samples/*.abc
- fi
-}
diff --git a/media-sound/abcmidi/abcmidi-2022.04.06.ebuild b/media-sound/abcmidi/abcmidi-2022.06.14.ebuild
index 3b11050a4f4..3b11050a4f4 100644
--- a/media-sound/abcmidi/abcmidi-2022.04.06.ebuild
+++ b/media-sound/abcmidi/abcmidi-2022.06.14.ebuild
diff --git a/media-sound/abcmidi/abcmidi-2022.04.28.ebuild b/media-sound/abcmidi/abcmidi-2022.08.01.ebuild
index 11f547f4cb8..11f547f4cb8 100644
--- a/media-sound/abcmidi/abcmidi-2022.04.28.ebuild
+++ b/media-sound/abcmidi/abcmidi-2022.08.01.ebuild
diff --git a/media-sound/aeolus/Manifest b/media-sound/aeolus/Manifest
index 3c5fcedb508..59c4a5a40bb 100644
--- a/media-sound/aeolus/Manifest
+++ b/media-sound/aeolus/Manifest
@@ -1,2 +1 @@
DIST aeolus-0.10.4.tar.bz2 66492 BLAKE2B 7a0861cacb1c8cb4c02f081883c0f61de3cfbea1da8716dba394b63cac325795d51cdf935c3f6cc242ed68d0ccc474d7c424eaf93d7084fe8e8af20fe4b16355 SHA512 4ef84ce7ca28c109ebc1327d3ecd18b1757617eca87313f4ed03a63a65c874de76bebf8dca780587a64e92dc881706c7fe888147475a30134648f02b570bad5a
-DIST aeolus-0.9.9.tar.bz2 66552 BLAKE2B 3e3aafd29477f660cfada1e7bf68e0143c32bebbde26abb653411041741273b7617f580b5c71a5315528d089e9dd9a18c9e56922ffe2a069afd35844b2dd9277 SHA512 423278564e83b00e90b91a408a098de8feb3c03809b2b96cf0b320522206ca1afea1d7f3f5cccad80fc4f03e0f31bb2d19f7256e30e6fbd25d25eb777c669ea2
diff --git a/media-sound/aeolus/aeolus-0.10.4.ebuild b/media-sound/aeolus/aeolus-0.10.4.ebuild
index 7df6c099cec..81f44ef16f3 100644
--- a/media-sound/aeolus/aeolus-0.10.4.ebuild
+++ b/media-sound/aeolus/aeolus-0.10.4.ebuild
@@ -11,7 +11,7 @@ SRC_URI="http://kokkinizita.linuxaudio.org/linuxaudio/downloads/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="amd64 x86"
IUSE=""
BDEPEND="
diff --git a/media-sound/aeolus/aeolus-0.9.9.ebuild b/media-sound/aeolus/aeolus-0.9.9.ebuild
deleted file mode 100644
index 9d6558e3be4..00000000000
--- a/media-sound/aeolus/aeolus-0.9.9.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit toolchain-funcs flag-o-matic desktop xdg
-
-DESCRIPTION="A synthesised pipe organ emulator"
-HOMEPAGE="http://kokkinizita.linuxaudio.org/linuxaudio/aeolus/index.html"
-SRC_URI="http://kokkinizita.linuxaudio.org/linuxaudio/downloads/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE=""
-
-BDEPEND="
- virtual/pkgconfig
-"
-CDEPEND="
- dev-libs/libclthreads
- media-libs/alsa-lib
- >=media-libs/zita-alsa-pcmi-0.3
- sys-libs/readline:0
- virtual/jack
- x11-libs/libclxclient
- x11-libs/libX11
- x11-libs/libXft
-"
-DEPEND="${CDEPEND}"
-RDEPEND="
- ${CDEPEND}
- media-libs/stops
-"
-
-DOCS=( README COPYING AUTHORS )
-
-PATCHES=(
- "${FILESDIR}"/${P}-fix-Makefile.patch
-)
-
-src_compile() {
- cd "${S}"/source || die "Failed to cd to source dir"
- tc-export CXX
- append-cppflags $($(tc-getPKG_CONFIG) --cflags xft)
- emake PREFIX="${EPREFIX}/usr" LIBDIR="${EXPREFIX}/usr/$(get_libdir)"
-}
-
-src_install() {
- default
-
- cd "${S}"/source || die "Failed to cd to source dir"
- emake PREFIX="${D}/usr" install
- echo "-S ${EPREFIX}/usr/share/stops" > "${T}/aeolus.conf"
- insinto /etc
- doins "${T}/aeolus.conf"
-
- make_desktop_entry aeolus Aeolus "" "AudioVideo"
-}
diff --git a/media-sound/alsa-tools/Manifest b/media-sound/alsa-tools/Manifest
index 96ea1a83771..bea713b13d3 100644
--- a/media-sound/alsa-tools/Manifest
+++ b/media-sound/alsa-tools/Manifest
@@ -1,2 +1 @@
-DIST alsa-tools-1.2.2.tar.bz2 1876266 BLAKE2B 2bfe4464869927f73b1059de9d972231b90af3be930e0e63048fcc40dadace0c842396e339874595f917b632fe407e16977a8b774240ffaf758004d42f46a27c SHA512 935d46ee3cc843566ccea183bcf7ea36439a4a6aa22964ebf6fd2722b78ec634d3be4e6a30b04c608abe6c5a132dd633f8343fff19f9d90a756d6699fc849a16
DIST alsa-tools-1.2.5.tar.bz2 1880907 BLAKE2B 1ecd7d24771e3f5899a7084a69196c9301b549dd331cbbbc55b6f0c694566147a9d5642cf94f0ad5ca5fcedb77daa1cb4615ce0ec0be157b32c9d756611a7cca SHA512 1c4ff947d9f2424056a6748e04a1250fb73443a3f470f61d0b563c91be082bc42d56e550d6cc27eaed3edcea2066a107e20455c959b053b5deafa2d811b7e498
diff --git a/media-sound/alsa-tools/alsa-tools-1.2.2-r1.ebuild b/media-sound/alsa-tools/alsa-tools-1.2.2-r1.ebuild
deleted file mode 100644
index 90f3ebe6770..00000000000
--- a/media-sound/alsa-tools/alsa-tools-1.2.2-r1.ebuild
+++ /dev/null
@@ -1,152 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit autotools flag-o-matic xdg
-
-DESCRIPTION="Advanced Linux Sound Architecture tools"
-HOMEPAGE="https://alsa-project.org/wiki/Main_Page"
-SRC_URI="https://www.alsa-project.org/files/pub/tools/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0.9"
-KEYWORDS="~alpha amd64 ~arm64 ~hppa ~ia64 ~mips ppc ppc64 sparc x86"
-
-IUSE="fltk gtk alsa_cards_hdsp alsa_cards_hdspm alsa_cards_mixart
-alsa_cards_vx222 alsa_cards_usb-usx2y alsa_cards_sb16 alsa_cards_sbawe
-alsa_cards_emu10k1 alsa_cards_emu10k1x alsa_cards_ice1712
-alsa_cards_rme32 alsa_cards_rme96 alsa_cards_sscape alsa_cards_pcxhr"
-
-DEPEND=">=media-libs/alsa-lib-${PV}
- >=dev-python/pyalsa-1.0.26
- fltk? ( >=x11-libs/fltk-1.3.0:1 )
- gtk? (
- dev-libs/gobject-introspection
- x11-libs/gtk+:2
- x11-libs/gtk+:3
- )" #468294
-RDEPEND="${DEPEND}
- gtk? ( media-fonts/font-misc-misc )" #456114
-BDEPEND="
- virtual/pkgconfig
-"
-
-PATCHES=(
- "${FILESDIR}"/envy24control-config-dir.patch
-)
-
-pkg_setup() {
- ALSA_TOOLS=(
- seq/sbiload
- us428control
- hwmixvolume
- hda-verb
- $(usex alsa_cards_mixart mixartloader '')
- $(usex alsa_cards_vx222 vxloader '')
- $(usex alsa_cards_usb-usx2y usx2yloader '')
- $(usex alsa_cards_pcxhr pcxhrloader '')
- $(usex alsa_cards_sscape sscape_ctl '')
- )
-
- if use gtk; then
- ALSA_TOOLS+=(
- echomixer
- hdajackretask
- $(usex alsa_cards_ice1712 envy24control '')
- )
- # Perhaps a typo the following && logic?
- if use alsa_cards_rme32 && use alsa_cards_rme96 ; then
- ALSA_TOOLS+=( rmedigicontrol )
- fi
- fi
-
- if use alsa_cards_hdsp || use alsa_cards_hdspm ; then
- ALSA_TOOLS+=(
- hdsploader
- $(usex fltk 'hdspconf hdspmixer' '')
- )
- fi
-
- if use alsa_cards_sb16 || use alsa_cards_sbawe ; then
- ALSA_TOOLS+=( sb16_csp )
- fi
-
- if use alsa_cards_emu10k1 || use alsa_cards_emu10k1x; then
- ALSA_TOOLS+=( as10k1 ld10k1 )
- fi
-}
-
-src_prepare() {
- default
-
- # This block only deals with the tools that still use GTK and the
- # AM_PATH_GTK macro.
- for dir in echomixer envy24control rmedigicontrol; do
- has "${dir}" "${ALSA_TOOLS[*]}" || continue
- pushd "${dir}" &> /dev/null
- eautoreconf
- popd &> /dev/null
- done
-
- # This block deals with the tools that are being patched
- for dir in hdspconf; do
- has "${dir}" "${ALSA_TOOLS[*]}" || continue
- pushd "${dir}" &> /dev/null
- eautoreconf
- popd &> /dev/null
- done
-
- elibtoolize
-}
-
-src_configure() {
- if use fltk; then
- # hdspmixer requires fltk
- append-ldflags "-L$(dirname $(fltk-config --libs))"
- append-flags "-I$(fltk-config --includedir)"
- fi
-
- local f
- for f in ${ALSA_TOOLS[@]} ; do
- cd "${S}/${f}" || die
- case "${f}" in
- echomixer,envy24control,rmedigicontrol )
- econf --with-gtk2
- ;;
- * )
- econf
- ;;
- esac
- done
-}
-
-src_compile() {
- local f
- for f in ${ALSA_TOOLS[@]} ; do
- cd "${S}/${f}" || die
- emake
- done
-}
-
-src_install() {
- local f
- for f in ${ALSA_TOOLS[@]} ; do
- # Install the main stuff
- cd "${S}/${f}" || die
- # hotplugdir is for usx2yloader/Makefile.am
- emake DESTDIR="${D}" hotplugdir=/lib/firmware install
-
- # Install the text documentation
- local doc
- for doc in README TODO ChangeLog AUTHORS; do
- if [[ -f "${doc}" ]]; then
- mv "${doc}" "${doc}.$(basename ${f})" || die
- dodoc "${doc}.$(basename ${f})"
- fi
- done
- done
-
- # Punt at least /usr/lib/liblo10k1.la (last checked, 1.0.27)
- find "${ED}" -type f -name '*.la' -delete || die
-}
diff --git a/media-sound/alsa-tools/metadata.xml b/media-sound/alsa-tools/metadata.xml
index 44cf5aa052a..d2e8313dec3 100644
--- a/media-sound/alsa-tools/metadata.xml
+++ b/media-sound/alsa-tools/metadata.xml
@@ -1,7 +1,10 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer type="project">
- <email>alsa-bugs@gentoo.org</email>
- </maintainer>
+ <maintainer type="project">
+ <email>alsa-bugs@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">alsa-project/alsa-tools</remote-id>
+ </upstream>
</pkgmetadata>
diff --git a/media-sound/alsa-utils/Manifest b/media-sound/alsa-utils/Manifest
index d47eefde538..39571a16c4a 100644
--- a/media-sound/alsa-utils/Manifest
+++ b/media-sound/alsa-utils/Manifest
@@ -1,3 +1,2 @@
-DIST alsa-utils-1.2.4.tar.bz2 1286259 BLAKE2B 41eb0b8186c1956c19d8f8b28863ab54c66ff531b9ec5c48cc6c5ed8ca249d135614112ce412d6adb6f21982235e06a4148591777cce00d17ea537aacbd664ad SHA512 13080abda55269513b3751044dac292d695e273073a62d74ed4a32c68f448a2b015fe16604650821a6398b6ef6a7b6008cb9f0b7fb7f4ee1fa2b4eb2dcf29770
-DIST alsa-utils-1.2.5.1.tar.bz2 1326965 BLAKE2B 79f96fd3ba1d92e72dc634dc01439acd3ccd02555c39cc1714c52bbd1e4bc8b68ec7bf5d219a704533e4a61587c3528504ef9cd7c652924d74daafa90f74e42a SHA512 bbafeb9189ec5802965c4e69cf6e7cd4c132ffb77b57f164d6585649890f96edd052c72697171fd629b39e12f78648fea634468df34c1a80255227ca397907bf
DIST alsa-utils-1.2.6.tar.bz2 1334063 BLAKE2B 3b81cccc836e0de9f6d98f311dc3a316a02179ec1fc7520da9658192f27e7701c6dc41b04a82639d6269d6943afd8a89cb6477406cbc36ac450e57919cff46f2 SHA512 6842f0f4c2f7cc5ac3ba94736ee259d9988b5d3e0d2b522f858d712e16938d2845fa9ef64f4aa60222b8ef6738e053f9113a5ea24a197f2c0d6c4dbd70030f5e
+DIST alsa-utils-1.2.7.tar.bz2 1562595 BLAKE2B dd8821c510a98d76e2986d59c01516013f01c632fb6311e6ffd2b10eabbdd68312537d977b1bf2ab48e0f181751ecf58ec1c1da3f8d4f7ee84d8f2623893a091 SHA512 1be8f617315193e6033653ac96a14bd1c3272cd9d8f3776cdb1357f35f5353652acd5975cfc5bd16278cd496f5bf409bb60432818a526282edad9a4c718a97c9
diff --git a/media-sound/alsa-utils/alsa-utils-1.2.5.1.ebuild b/media-sound/alsa-utils/alsa-utils-1.2.7-r1.ebuild
index 19b3f1451fb..753daf229f9 100644
--- a/media-sound/alsa-utils/alsa-utils-1.2.5.1.ebuild
+++ b/media-sound/alsa-utils/alsa-utils-1.2.7-r1.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit systemd udev
DESCRIPTION="Advanced Linux Sound Architecture Utils (alsactl, alsamixer, etc.)"
@@ -10,11 +10,12 @@ SRC_URI="https://www.alsa-project.org/files/pub/utils/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0.9"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"
-IUSE="bat doc +libsamplerate +ncurses nls selinux"
+KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~loong ~mips ppc ppc64 ~riscv sparc x86"
+IUSE="bat doc +libsamplerate ieee1394 +ncurses nls selinux"
CDEPEND=">=media-libs/alsa-lib-${PV}
libsamplerate? ( media-libs/libsamplerate )
+ ieee1394? ( media-libs/libffado )
ncurses? ( >=sys-libs/ncurses-5.7-r7:0= )
bat? ( sci-libs/fftw:= )"
DEPEND="${CDEPEND}
@@ -28,6 +29,8 @@ PATCHES=(
)
src_configure() {
+ export ac_cv_lib_ffado_ffado_streaming_init=$(usex ieee1394)
+
local myeconfargs=(
# --disable-alsaconf because it doesn't work with sys-apps/kmod wrt #456214
--disable-alsaconf
@@ -63,6 +66,8 @@ src_install() {
}
pkg_postinst() {
+ udev_reload
+
if [[ -z ${REPLACING_VERSIONS} ]]; then
elog
elog "To take advantage of the init script, and automate the process of"
@@ -75,3 +80,7 @@ pkg_postinst() {
ewarn "means. There is no longer any modular auto(un)loading in alsa-utils."
fi
}
+
+pkg_postrm() {
+ udev_reload
+}
diff --git a/media-sound/alsa-utils/alsa-utils-1.2.4.ebuild b/media-sound/alsa-utils/alsa-utils-1.2.7.ebuild
index 777934934c4..46afae5d343 100644
--- a/media-sound/alsa-utils/alsa-utils-1.2.4.ebuild
+++ b/media-sound/alsa-utils/alsa-utils-1.2.7.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit systemd udev
DESCRIPTION="Advanced Linux Sound Architecture Utils (alsactl, alsamixer, etc.)"
@@ -10,7 +10,7 @@ SRC_URI="https://www.alsa-project.org/files/pub/utils/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0.9"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 sparc x86"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"
IUSE="bat doc +libsamplerate +ncurses nls selinux"
CDEPEND=">=media-libs/alsa-lib-${PV}
@@ -63,6 +63,8 @@ src_install() {
}
pkg_postinst() {
+ udev_reload
+
if [[ -z ${REPLACING_VERSIONS} ]]; then
elog
elog "To take advantage of the init script, and automate the process of"
@@ -75,3 +77,7 @@ pkg_postinst() {
ewarn "means. There is no longer any modular auto(un)loading in alsa-utils."
fi
}
+
+pkg_postrm() {
+ udev_reload
+}
diff --git a/media-sound/alsa-utils/metadata.xml b/media-sound/alsa-utils/metadata.xml
index b7cfbe16f12..cd20e90459c 100644
--- a/media-sound/alsa-utils/metadata.xml
+++ b/media-sound/alsa-utils/metadata.xml
@@ -1,12 +1,15 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer type="project">
- <email>alsa-bugs@gentoo.org</email>
- </maintainer>
- <use>
- <flag name="bat">install basic audio tester (BAT) util</flag>
- <flag name="libsamplerate">install utils that use libsamplerate (e.g. alsaloop)</flag>
- <flag name="ncurses">install utils that use ncurses (e.g. alsamixer)</flag>
- </use>
+ <maintainer type="project">
+ <email>alsa-bugs@gentoo.org</email>
+ </maintainer>
+ <use>
+ <flag name="bat">install basic audio tester (BAT) util</flag>
+ <flag name="libsamplerate">install utils that use libsamplerate (e.g. alsaloop)</flag>
+ <flag name="ncurses">install utils that use ncurses (e.g. alsamixer)</flag>
+ </use>
+ <upstream>
+ <remote-id type="github">alsa-project/alsa-utils</remote-id>
+ </upstream>
</pkgmetadata>
diff --git a/media-sound/alsaplayer/alsaplayer-0.99.81-r2.ebuild b/media-sound/alsaplayer/alsaplayer-0.99.81-r3.ebuild
index 098fdbbe333..32fb30aa29d 100644
--- a/media-sound/alsaplayer/alsaplayer-0.99.81-r2.ebuild
+++ b/media-sound/alsaplayer/alsaplayer-0.99.81-r3.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
inherit autotools desktop xdg
@@ -13,6 +13,7 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ~mips ~ppc ~riscv ~sparc x86"
IUSE="+alsa audiofile doc flac gtk id3tag jack mad mikmod nas nls ogg opengl oss vorbis xosd"
+REQUIRED_USE="|| ( alsa jack nas oss )"
RDEPEND="
media-libs/libsndfile:=
@@ -31,27 +32,17 @@ RDEPEND="
vorbis? ( media-libs/libvorbis )
xosd? ( x11-libs/xosd )"
DEPEND="${RDEPEND}
- virtual/pkgconfig
- doc? ( app-doc/doxygen )
- nls? ( sys-devel/gettext )
oss? ( virtual/os-headers )"
-REQUIRED_USE="|| ( alsa jack nas oss )"
+BDEPEND="
+ sys-devel/gettext
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )"
+
+PATCHES=( "${FILESDIR}"/${P}-autotools.patch )
src_prepare() {
default
-
- sed -i \
- -e 's:AM_CFLAGS = $(AM_CXXFLAGS)::' \
- output/jack/Makefile.am || die
-
- sed -i \
- -e 's:-O2 -funroll-loops -finline-functions -ffast-math::' \
- configure.ac || die
-
- sed -i \
- -e "s:/usr/lib:/usr/$(get_libdir):" \
- configure.ac config.rpath || die
-
+ cp "${BROOT}"/usr/share/gettext/config.rpath . || die
eautoreconf
}
@@ -83,5 +74,5 @@ src_install() {
newicon interface/gtk2/pixmaps/logo.xpm ${PN}.xpm
- find "${D}" -name '*.la' -delete || die
+ find "${ED}" -name '*.la' -delete || die
}
diff --git a/media-sound/alsaplayer/files/alsaplayer-0.99.81-autotools.patch b/media-sound/alsaplayer/files/alsaplayer-0.99.81-autotools.patch
new file mode 100644
index 00000000000..b51277317e0
--- /dev/null
+++ b/media-sound/alsaplayer/files/alsaplayer-0.99.81-autotools.patch
@@ -0,0 +1,37 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -82,11 +82,6 @@
+ dnl PKGCONFIG preparations
+ dnl ======================
+
+-if test -z $PKG_CONFIG_PATH; then
+- PKG_CONFIG_PATH=/usr/local/lib/pkgconfig:/usr/lib/pkgconfig
+-fi
+-
+-export PKG_CONFIG_PATH
+
+
+ dnl ===============
+@@ -639,10 +634,10 @@
+
+ AC_MSG_CHECKING(for gcc optimization flags)
+ old_cflags=$CFLAGS
+-CFLAGS="$CFLAGS -O2 -funroll-loops -finline-functions -ffast-math -Wall"
++CFLAGS="$CFLAGS -Wall"
+ AC_TRY_COMPILE([#include <stdio.h>],
+ [ printf ("hello, world"); ],
+-[ EXTRA_OPT_CFLAGS="$CFLAGS -O2 -funroll-loops -finline-functions -ffast-math -Wall"],[ EXTRA_OPT_CFLAGS=""])
++[ EXTRA_OPT_CFLAGS="$CFLAGS -Wall"],[ EXTRA_OPT_CFLAGS=""])
+ CFLAGS=$old_cflags
+ AC_MSG_RESULT([$EXTRA_OPT_CFLAGS])
+
+--- a/output/jack/Makefile.am
++++ b/output/jack/Makefile.am
+@@ -24,7 +24,6 @@
+
+ AM_CXXFLAGS = $(COMMON_FLAGS) $(JACK_CFLAGS)
+
+-AM_CFLAGS = $(AM_CXXFLAGS)
+
+ libdir = $(ADDON_DIR)/output
+
diff --git a/media-sound/amsynth/Manifest b/media-sound/amsynth/Manifest
index 9cd27b40845..187f196a445 100644
--- a/media-sound/amsynth/Manifest
+++ b/media-sound/amsynth/Manifest
@@ -1 +1,2 @@
DIST amsynth-1.12.4.tar.gz 1624416 BLAKE2B 1dcd2454d94200b76097d4215ed419123a3b8427064c8f674a1e7cb27620fb5b2977470ea7feb8114c429ed904511ec73c73461b7f38e1388e4cfeabc4e68ec3 SHA512 502fdd1d6c4e54a57482d266977d78008efa26717c173be0bf98e907a111366fd80b65d667b9448e751085901dc5f2a61ac0bf5b1d02e35c695ecd99c9d1df00
+DIST amsynth-1.13.0.tar.gz 1626209 BLAKE2B 29b79f18ca0ddbba77aaf1bde738f235698f0debe2ddea3b9f2bce2eeaaa399ba125f72b97c83157b87bb28bdb4a259ae2e535c87def16a9e1af3d3093bf0270 SHA512 29698be7d690c76a46a0c8306d6c3b94630b25ed9a3524d7e27d22e244f5c144b74b8473f09eecdb1368443f503ba7024d1c71ead6794f11a2d1cb2114c84bd5
diff --git a/media-sound/amsynth/amsynth-1.13.0.ebuild b/media-sound/amsynth/amsynth-1.13.0.ebuild
new file mode 100644
index 00000000000..e42fb11b9d1
--- /dev/null
+++ b/media-sound/amsynth/amsynth-1.13.0.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg
+
+DESCRIPTION="Virtual analogue synthesizer"
+HOMEPAGE="https://github.com/amsynth/amsynth"
+SRC_URI="https://github.com/${PN}/${PN}/releases/download/release-${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="alsa dssi gtk jack lash lv2 nsm oss vst"
+
+REQUIRED_USE="dssi? ( gtk ) lv2? ( gtk )"
+
+BDEPEND="
+ dev-util/intltool
+ virtual/pkgconfig
+"
+RDEPEND="
+ alsa? (
+ media-libs/alsa-lib:=
+ media-sound/alsa-utils
+ )
+ dssi? (
+ media-libs/dssi:=
+ media-libs/liblo:=
+ )
+ gtk? (
+ x11-libs/gtk+:2
+ x11-libs/libX11
+ )
+ jack? ( virtual/jack )
+ lash? ( media-sound/lash )
+ lv2? ( media-libs/lv2 )
+"
+DEPEND="${RDEPEND}
+ oss? ( virtual/os-headers )
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.12.2-metadata.patch"
+)
+
+src_prepare() {
+ default
+ ! use gtk && eapply "${FILESDIR}/${PN}-1.12.2-x11.patch"
+}
+
+src_configure() {
+ econf \
+ $(use_with alsa) \
+ $(use_with dssi) \
+ $(use_with gtk gui) \
+ $(use_with jack) \
+ $(use_with lash) \
+ $(use_with lv2) \
+ $(use_with nsm) \
+ $(use_with oss) \
+ $(use_with vst)
+}
diff --git a/media-sound/apetag/apetag-1.12-r3.ebuild b/media-sound/apetag/apetag-1.12-r3.ebuild
index d34b04e2b1a..3b2b3d33e1d 100644
--- a/media-sound/apetag/apetag-1.12-r3.ebuild
+++ b/media-sound/apetag/apetag-1.12-r3.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{8,9} )
+PYTHON_COMPAT=( python3_{8..10} )
inherit python-single-r1 toolchain-funcs
diff --git a/media-sound/ardour/ardour-6.9-r1.ebuild b/media-sound/ardour/ardour-6.9-r1.ebuild
index 95a824b4d2d..e258a114466 100644
--- a/media-sound/ardour/ardour-6.9-r1.ebuild
+++ b/media-sound/ardour/ardour-6.9-r1.ebuild
@@ -21,7 +21,7 @@ fi
LICENSE="GPL-2"
SLOT="6"
-IUSE="altivec doc jack nls phonehome pulseaudio cpu_flags_x86_sse cpu_flags_x86_mmx cpu_flags_x86_3dnow"
+IUSE="doc jack nls phonehome pulseaudio cpu_flags_ppc_altivec cpu_flags_x86_sse cpu_flags_x86_mmx cpu_flags_x86_3dnow"
RDEPEND="
dev-cpp/glibmm:2
@@ -136,7 +136,7 @@ src_configure() {
--noconfirm
--optimize
--with-backends=${backends}
- $({ use altivec || use cpu_flags_x86_sse; } && echo "--fpu-optimization" || echo "--no-fpu-optimization")
+ $({ use cpu_flags_ppc_altivec || use cpu_flags_x86_sse; } && echo "--fpu-optimization" || echo "--no-fpu-optimization")
$(usex doc "--docs" '')
$(usex nls "--nls" "--no-nls")
$(usex phonehome "--phone-home" "--no-phone-home")
diff --git a/media-sound/ardour/ardour-9999.ebuild b/media-sound/ardour/ardour-9999.ebuild
index 4b3a74958f6..9309627c651 100644
--- a/media-sound/ardour/ardour-9999.ebuild
+++ b/media-sound/ardour/ardour-9999.ebuild
@@ -21,7 +21,7 @@ fi
LICENSE="GPL-2"
SLOT="7"
-IUSE="altivec doc jack nls phonehome pulseaudio cpu_flags_x86_sse cpu_flags_x86_mmx cpu_flags_x86_3dnow"
+IUSE="doc jack nls phonehome pulseaudio cpu_flags_ppc_altivec cpu_flags_x86_sse cpu_flags_x86_mmx cpu_flags_x86_3dnow"
RDEPEND="
dev-cpp/glibmm:2
@@ -136,7 +136,7 @@ src_configure() {
--noconfirm
--optimize
--with-backends=${backends}
- $({ use altivec || use cpu_flags_x86_sse; } && echo "--fpu-optimization" || echo "--no-fpu-optimization")
+ $({ use cpu_flags_ppc_altivec || use cpu_flags_x86_sse; } && echo "--fpu-optimization" || echo "--no-fpu-optimization")
$(usex doc "--docs" '')
$(usex nls "--nls" "--no-nls")
$(usex phonehome "--phone-home" "--no-phone-home")
diff --git a/media-sound/audacious/Manifest b/media-sound/audacious/Manifest
index ea1f38dbd78..04525a44fca 100644
--- a/media-sound/audacious/Manifest
+++ b/media-sound/audacious/Manifest
@@ -1,3 +1,2 @@
-DIST audacious-4.0.5.tar.bz2 577422 BLAKE2B a65810baf0f733327a3e37e6efd2af3d35245b1e99936a4cd39d8068e0df06779ab3c08e839e4b3586f70bec2d16a605c62328f863f747247181851ac7c151c2 SHA512 4be7ebeee937f9b29931a28e1d80782b9df8beec70eab3917f5adccd0bf02aa6003a5b8361359b792edac2d2f31a257b853db43d59dd0674e5a3fbec7e7c1e46
-DIST audacious-4.1.tar.bz2 586472 BLAKE2B baed9f47ddca9b6a4668da542483e8ead049126383e8d1b090b29153b698cc83042ce0620bc5c3e78e59c599cb9f1be72b9c8d2e8c3c87f36fae45554a743b24 SHA512 6e603108c245a146c3bb360e99d85e949b25a50a4d97eca6a0519cb457a93e8d73131504ae10f86c34c0e9d98fb5fdf6660accc0bb3bb480332cb674ac27ac9f
+DIST audacious-4.2.tar.bz2 612155 BLAKE2B 04a910288278fa27cb4848663ab74f9e523f3cbea7851e28f5e197035c4ad17281e9b0d5756602efb531a65aeb8e6b7abd7b11274af3353f6ac1d21a0bd4c47c SHA512 814bd865e87cf9bc39df07c9f9898eca1dd94d8b8299b2709f77046669ce12e9c31067d55084371f6797724e79872f7571b575cc766093ee2124b38b0409a853
DIST gentoo_ice-xmms-0.2.tar.bz2 51839 BLAKE2B d3bf8dbfee675dd588bc0258f1015c76877b6b0a3835813d8e9621d149b924aaa33544d07f7ad44a01c058d41d7480b3908b0773c124af33b6e020c376b13d54 SHA512 e863a8f86073007c47ce8c20739aae4bff22e22a7ddc11556b12ae6ebb68654cec7310fdc9d05f2c47f81cf2591fe601b2eb12a2fd911c0a6118c9f3cc524f05
diff --git a/media-sound/audacious/audacious-4.0.5.ebuild b/media-sound/audacious/audacious-4.0.5.ebuild
deleted file mode 100644
index 560b050d80c..00000000000
--- a/media-sound/audacious/audacious-4.0.5.ebuild
+++ /dev/null
@@ -1,81 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-MY_P="${P/_/-}"
-
-if [[ ${PV} == *9999 ]]; then
- inherit autotools git-r3
- EGIT_REPO_URI="https://github.com/audacious-media-player/audacious.git"
-else
- SRC_URI="https://distfiles.audacious-media-player.org/${MY_P}.tar.bz2"
- KEYWORDS="amd64 ~riscv x86"
-fi
-inherit xdg
-
-DESCRIPTION="Lightweight and versatile audio player"
-HOMEPAGE="https://audacious-media-player.org/"
-SRC_URI+=" mirror://gentoo/gentoo_ice-xmms-0.2.tar.bz2"
-
-LICENSE="BSD-2"
-SLOT="0"
-IUSE="nls"
-
-BDEPEND="
- virtual/pkgconfig
- nls? ( dev-util/intltool )
-"
-DEPEND="
- >=dev-libs/dbus-glib-0.60
- >=dev-libs/glib-2.28
- dev-qt/qtcore:5
- dev-qt/qtgui:5
- dev-qt/qtwidgets:5
- >=x11-libs/cairo-1.2.6
- >=x11-libs/pango-1.8.0
- virtual/freedesktop-icon-theme
-"
-RDEPEND="${DEPEND}"
-PDEPEND="~media-plugins/audacious-plugins-${PV}"
-
-S="${WORKDIR}/${MY_P}"
-
-src_unpack() {
- default
- [[ ${PV} == *9999 ]] && git-r3_src_unpack
-}
-
-src_prepare() {
- default
- if ! use nls; then
- sed -e "/SUBDIRS/s/ po//" -i Makefile || die # bug #512698
- fi
- [[ ${PV} == *9999 ]] && eautoreconf
-}
-
-src_configure() {
- # D-Bus is a mandatory dependency, remote control,
- # session management and some plugins depend on this.
- # Building without D-Bus is *unsupported* and a USE-flag
- # will not be added due to the bug reports that will result.
- # Bugs #197894, #199069, #207330, #208606
- local myeconfargs=(
- --disable-valgrind
- --disable-gtk
- --enable-dbus
- --enable-qt
- $(use_enable nls)
- )
- econf "${myeconfargs[@]}"
-}
-
-src_install() {
- default
-
- # Gentoo_ice skin installation; bug #109772
- insinto /usr/share/audacious/Skins/gentoo_ice
- doins -r "${WORKDIR}"/gentoo_ice/.
- docinto gentoo_ice
- dodoc "${WORKDIR}"/README
-}
diff --git a/media-sound/audacious/audacious-4.1.ebuild b/media-sound/audacious/audacious-4.2.ebuild
index b2ca1ac2f2d..70f5385f84f 100644
--- a/media-sound/audacious/audacious-4.1.ebuild
+++ b/media-sound/audacious/audacious-4.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
diff --git a/media-sound/audiotools/audiotools-3.1.1.ebuild b/media-sound/audiotools/audiotools-3.1.1-r1.ebuild
index b63f0e4b37a..82bedd95682 100644
--- a/media-sound/audiotools/audiotools-3.1.1.ebuild
+++ b/media-sound/audiotools/audiotools-3.1.1-r1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
-PYTHON_COMPAT=( python3_{7,8,9} )
+EAPI=8
+PYTHON_COMPAT=( python3_{8..10} )
PYTHON_REQ_USE="xml(+)"
inherit distutils-r1
@@ -13,7 +13,7 @@ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="amd64 ~x86"
IUSE="aac alsa cdda cdr cue dvda flac gui twolame mp3 opus pulseaudio vorbis wavpack"
BDEPEND="virtual/pkgconfig"
diff --git a/media-sound/baudline/baudline-1.08-r1.ebuild b/media-sound/baudline/baudline-1.08-r2.ebuild
index 6c4a606f37e..b1acd9cd0f9 100644
--- a/media-sound/baudline/baudline-1.08-r1.ebuild
+++ b/media-sound/baudline/baudline-1.08-r2.ebuild
@@ -1,31 +1,34 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
inherit desktop xdg
DESCRIPTION="A time-frequency browser designed for visualization of spectral domains"
HOMEPAGE="https://www.baudline.com/"
-SRC_URI="amd64? ( https://www.baudline.com/${PN}_${PV}_linux_x86_64.tar.gz )
+SRC_URI="
+ amd64? ( https://www.baudline.com/${PN}_${PV}_linux_x86_64.tar.gz )
x86? ( https://www.baudline.com/${PN}_${PV}_linux_i686.tar.gz )"
LICENSE="baudline"
SLOT="0"
KEYWORDS="amd64 ~x86"
IUSE="jack"
-
RESTRICT="mirror bindist"
-QA_PREBUILT="opt/baudline/baudline*"
-RDEPEND="media-fonts/font-adobe-75dpi
+RDEPEND="
+ media-fonts/font-adobe-75dpi
media-fonts/font-misc-misc
+ sys-libs/glibc
x11-libs/libX11
x11-libs/libXext
x11-libs/libXmu
x11-libs/libXt
x11-libs/libXxf86vm"
+QA_PREBUILT="opt/baudline/baudline*"
+
src_unpack() {
default
# strip arch names from S
diff --git a/media-sound/beets/beets-1.6.0.ebuild b/media-sound/beets/beets-1.6.0.ebuild
index 37b074a8899..4550e6da0e1 100644
--- a/media-sound/beets/beets-1.6.0.ebuild
+++ b/media-sound/beets/beets-1.6.0.ebuild
@@ -4,7 +4,7 @@
EAPI=7
DISTUTILS_SINGLE_IMPL=1
-PYTHON_COMPAT=( python3_{8..9} )
+PYTHON_COMPAT=( python3_{8..10} )
PYTHON_REQ_USE="sqlite"
inherit distutils-r1 bash-completion-r1 optfeature
@@ -16,7 +16,7 @@ else
MY_PV=${PV/_beta/-beta.}
MY_P=${PN}-${MY_PV}
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
- KEYWORDS="~amd64 ~x86"
+ KEYWORDS="amd64 ~x86"
S="${WORKDIR}/${MY_P}"
fi
@@ -62,6 +62,7 @@ BDEPEND="
dev-python/pygobject:3[${PYTHON_USEDEP}]
dev-python/python-mpd[${PYTHON_USEDEP}]
dev-python/pyxdg[${PYTHON_USEDEP}]
+ dev-python/reflink[${PYTHON_USEDEP}]
|| (
dev-python/pillow[${PYTHON_USEDEP}]
media-gfx/imagemagick
diff --git a/media-sound/beets/beets-9999.ebuild b/media-sound/beets/beets-9999.ebuild
index d7df175f13f..870844e4cb0 100644
--- a/media-sound/beets/beets-9999.ebuild
+++ b/media-sound/beets/beets-9999.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
DISTUTILS_SINGLE_IMPL=1
-PYTHON_COMPAT=( python3_{8..9} )
+PYTHON_COMPAT=( python3_{8..10} )
PYTHON_REQ_USE="sqlite"
inherit distutils-r1 bash-completion-r1 optfeature
@@ -16,7 +16,7 @@ else
MY_PV=${PV/_beta/-beta.}
MY_P=${PN}-${MY_PV}
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
- KEYWORDS="~amd64"
+ KEYWORDS="~amd64 ~x86"
S="${WORKDIR}/${MY_P}"
fi
@@ -37,7 +37,6 @@ RDEPEND="
dev-python/pyyaml[${PYTHON_USEDEP}]
dev-python/requests-oauthlib[${PYTHON_USEDEP}]
dev-python/requests[${PYTHON_USEDEP}]
- >=dev-python/six-1.9[${PYTHON_USEDEP}]
dev-python/unidecode[${PYTHON_USEDEP}]
dev-python/reflink[${PYTHON_USEDEP}]
dev-python/confuse[${PYTHON_USEDEP}]
@@ -63,6 +62,7 @@ BDEPEND="
dev-python/pygobject:3[${PYTHON_USEDEP}]
dev-python/python-mpd[${PYTHON_USEDEP}]
dev-python/pyxdg[${PYTHON_USEDEP}]
+ dev-python/reflink[${PYTHON_USEDEP}]
|| (
dev-python/pillow[${PYTHON_USEDEP}]
media-gfx/imagemagick
diff --git a/media-sound/bluez-alsa/Manifest b/media-sound/bluez-alsa/Manifest
index c294ef4f454..ee1b8979d79 100644
--- a/media-sound/bluez-alsa/Manifest
+++ b/media-sound/bluez-alsa/Manifest
@@ -1,2 +1,2 @@
-DIST bluez-alsa-3.0.0.tar.gz 157776 BLAKE2B 68cc67dcfd303e624333d7dafa53a3ce0f91f55e58a9a1a51f17153eadfdca5acc1b12b2e41a11c4780909fe8283e0a9c859a7d755e38dd9aeebbf4ae9e0daf2 SHA512 094c91636c3f1803b3eb88e295683acc604be9f86d00022c196784b4ec88aa4a6cc20bdff0fdab2a7e5af3efe95ed8bd8c5486a8cd7896ec572bfa9e8e0f13d0
DIST bluez-alsa-3.1.0.tar.gz 179984 BLAKE2B b0bd5008d1bcc972577d8626970834934cc9424b4dff5c9ede1b1bfb0ac6c62c50dd8a7b94bdaa8884354379fb4fe06d758f620b2f42207d85f68da5064b3499 SHA512 8b2644cb2114569cc896869f22352386a9362eeacae823423a63d9b21198f561d4af796700fcd3267556bb69ff2575569474a1da8e3a645b5a2e779882c27cbf
+DIST bluez-alsa-4.0.0.tar.gz 230879 BLAKE2B 998127cb4e03afc019679b80fc1ac7d56351aeb8274efe76a74d6c5600c4b8527d5463e864cc8f68c1fa82c1729ef38d8168e90e7092dfe5eaf5a7cf25ba4bfa SHA512 8a79e5a1189db2d39b2d772cb8f8cd51ebb96b9bd91489556195e83dfd16f40a581dce68c5ad9e886b66cec8a03ae7f959e8288bb4c5c87ea5a2bbd6aee9c5f0
diff --git a/media-sound/bluez-alsa/bluez-alsa-3.0.0.ebuild b/media-sound/bluez-alsa/bluez-alsa-4.0.0.ebuild
index e7b9c1c647a..1343401528a 100644
--- a/media-sound/bluez-alsa/bluez-alsa-3.0.0.ebuild
+++ b/media-sound/bluez-alsa/bluez-alsa-4.0.0.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
-inherit autotools multilib-minimal systemd
+EAPI=8
+inherit autotools bash-completion-r1 multilib-minimal systemd
DESCRIPTION="Bluetooth Audio ALSA Backend"
HOMEPAGE="https://github.com/Arkq/bluez-alsa"
@@ -17,19 +17,20 @@ fi
LICENSE="MIT"
SLOT="0"
-IUSE="aac debug hcitop lame ldac man mpg123 ofono static-libs test unwind upower"
+IUSE="aac aptx debug hcitop lame ldac man mpg123 ofono static-libs systemd test unwind upower"
RESTRICT="!test? ( test )"
# bluez-alsa does not directly link to upower but
# is using the upower interface via dbus calls.
RDEPEND="
- >=dev-libs/glib-2.26[${MULTILIB_USEDEP}]
+ >=dev-libs/glib-2.32[${MULTILIB_USEDEP}]
>=media-libs/alsa-lib-1.1.2[${MULTILIB_USEDEP}]
>=media-libs/sbc-1.2[${MULTILIB_USEDEP}]
>=net-wireless/bluez-5.0[${MULTILIB_USEDEP}]
sys-apps/dbus[${MULTILIB_USEDEP}]
sys-libs/readline:0=
aac? ( >=media-libs/fdk-aac-0.1.1:=[${MULTILIB_USEDEP}] )
+ aptx? ( media-libs/libopenaptx )
lame? ( media-sound/lame[${MULTILIB_USEDEP}] )
mpg123? ( media-sound/mpg123[${MULTILIB_USEDEP}] )
hcitop? (
@@ -38,11 +39,15 @@ RDEPEND="
)
ldac? ( >=media-libs/libldac-2.0.0 )
ofono? ( net-misc/ofono )
+ systemd? ( sys-apps/systemd )
unwind? ( sys-libs/libunwind[${MULTILIB_USEDEP}] )
upower? ( sys-power/upower )
"
DEPEND="${RDEPEND}
- test? ( dev-libs/check )"
+ test? (
+ dev-libs/check
+ media-libs/libsndfile
+ )"
BDEPEND="
virtual/pkgconfig
man? ( app-text/pandoc )
@@ -55,18 +60,25 @@ src_prepare() {
multilib_src_configure() {
local myeconfargs=(
+ --enable-cli
+ --enable-faststream
--enable-rfcomm
+ --with-bash-completion="$(get_bashcompdir)"
$(use_enable aac)
$(use_enable debug)
$(use_enable lame mp3lame)
$(use_enable man manpages)
$(use_enable mpg123)
$(use_enable static-libs static)
+ $(use_enable systemd)
$(use_enable test)
+ $(use_with systemd systemdsystemunitdir $(systemd_get_systemunitdir))
+ $(multilib_native_use_enable aptx)
$(multilib_native_use_enable hcitop)
$(multilib_native_use_enable ldac)
$(multilib_native_use_enable ofono)
$(multilib_native_use_enable upower)
+ $(multilib_native_use_with aptx libopenaptx)
$(use_with unwind libunwind)
)
ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
@@ -78,7 +90,7 @@ multilib_src_install_all() {
newinitd "${FILESDIR}"/bluealsa-init.d bluealsa
newconfd "${FILESDIR}"/bluealsa-conf.d-2 bluealsa
- systemd_dounit "${FILESDIR}"/bluealsa.service
+ #systemd_dounit "${FILESDIR}"/bluealsa.service
# Add config file to alsa datadir as well to preserve changes in /etc
insinto "/usr/share/alsa/alsa.conf.d/"
diff --git a/media-sound/bluez-alsa/bluez-alsa-9999.ebuild b/media-sound/bluez-alsa/bluez-alsa-9999.ebuild
index 80ea97b69db..1343401528a 100644
--- a/media-sound/bluez-alsa/bluez-alsa-9999.ebuild
+++ b/media-sound/bluez-alsa/bluez-alsa-9999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit autotools bash-completion-r1 multilib-minimal systemd
DESCRIPTION="Bluetooth Audio ALSA Backend"
@@ -17,13 +17,13 @@ fi
LICENSE="MIT"
SLOT="0"
-IUSE="aac aptx debug hcitop lame ldac man mpg123 ofono static-libs test unwind upower"
+IUSE="aac aptx debug hcitop lame ldac man mpg123 ofono static-libs systemd test unwind upower"
RESTRICT="!test? ( test )"
# bluez-alsa does not directly link to upower but
# is using the upower interface via dbus calls.
RDEPEND="
- >=dev-libs/glib-2.26[${MULTILIB_USEDEP}]
+ >=dev-libs/glib-2.32[${MULTILIB_USEDEP}]
>=media-libs/alsa-lib-1.1.2[${MULTILIB_USEDEP}]
>=media-libs/sbc-1.2[${MULTILIB_USEDEP}]
>=net-wireless/bluez-5.0[${MULTILIB_USEDEP}]
@@ -39,11 +39,15 @@ RDEPEND="
)
ldac? ( >=media-libs/libldac-2.0.0 )
ofono? ( net-misc/ofono )
+ systemd? ( sys-apps/systemd )
unwind? ( sys-libs/libunwind[${MULTILIB_USEDEP}] )
upower? ( sys-power/upower )
"
DEPEND="${RDEPEND}
- test? ( dev-libs/check )"
+ test? (
+ dev-libs/check
+ media-libs/libsndfile
+ )"
BDEPEND="
virtual/pkgconfig
man? ( app-text/pandoc )
@@ -57,6 +61,7 @@ src_prepare() {
multilib_src_configure() {
local myeconfargs=(
--enable-cli
+ --enable-faststream
--enable-rfcomm
--with-bash-completion="$(get_bashcompdir)"
$(use_enable aac)
@@ -65,7 +70,9 @@ multilib_src_configure() {
$(use_enable man manpages)
$(use_enable mpg123)
$(use_enable static-libs static)
+ $(use_enable systemd)
$(use_enable test)
+ $(use_with systemd systemdsystemunitdir $(systemd_get_systemunitdir))
$(multilib_native_use_enable aptx)
$(multilib_native_use_enable hcitop)
$(multilib_native_use_enable ldac)
@@ -83,7 +90,7 @@ multilib_src_install_all() {
newinitd "${FILESDIR}"/bluealsa-init.d bluealsa
newconfd "${FILESDIR}"/bluealsa-conf.d-2 bluealsa
- systemd_dounit "${FILESDIR}"/bluealsa.service
+ #systemd_dounit "${FILESDIR}"/bluealsa.service
# Add config file to alsa datadir as well to preserve changes in /etc
insinto "/usr/share/alsa/alsa.conf.d/"
diff --git a/media-sound/bluez-alsa/metadata.xml b/media-sound/bluez-alsa/metadata.xml
index 8da3eff6604..5533720929d 100644
--- a/media-sound/bluez-alsa/metadata.xml
+++ b/media-sound/bluez-alsa/metadata.xml
@@ -1,10 +1,7 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer type="person">
- <email>polynomial-c@gentoo.org</email>
- <name>Lars Wendler</name>
- </maintainer>
+ <!-- maintainer-needed -->
<upstream>
<remote-id type="github">Arkq/bluez-alsa</remote-id>
</upstream>
diff --git a/media-sound/cadence/Manifest b/media-sound/cadence/Manifest
index 4b62b9742a8..924b685f62f 100644
--- a/media-sound/cadence/Manifest
+++ b/media-sound/cadence/Manifest
@@ -1 +1 @@
-DIST cadence-0.9.1.tar.gz 2202272 BLAKE2B 0f96a3eadc90540ef455e3b9c9abe1b8dc0d912936642c77e52a3704367f06e870b4cbe0bee78482436b9b099063c66b0b04007e8905b7eaf213d6b2f9aa08d1 SHA512 daa9df947f0198522172451ec3d2a0e138de5245d4fa849c89ae17fc141388467bdb2e5b1ed191d1db372f4d1c02a8f1c32458c20b893d413af8fdce72ee9219
+DIST cadence-0.9.2.tar.gz 2202164 BLAKE2B a5422e4d74618e2e45d9c6f275393a6e918783fc37d60a54142725aa54e691435c41f76dd0346fae7684c452988b07a18d817902abd917dbceaff5fb4aaa6c47 SHA512 d8a1b52c361e3e18a193d1c283bb69abe18ce667b554fc53cb9b752d92747269145144ae512895ffbb5df76efe8671cfc0782f29e59d0d7cd3d97c97240bdecf
diff --git a/media-sound/cadence/cadence-0.9.1-r2.ebuild b/media-sound/cadence/cadence-0.9.2-r1.ebuild
index a6a6a44e2de..f67d9bb389f 100644
--- a/media-sound/cadence/cadence-0.9.1-r2.ebuild
+++ b/media-sound/cadence/cadence-0.9.2-r1.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_{8,9} )
+PYTHON_COMPAT=( python3_{8..11} )
inherit python-single-r1 xdg desktop
DESCRIPTION="Collection of tools useful for audio production"
@@ -34,14 +34,18 @@ CDEPEND="
media-sound/jack_capture
virtual/jack
a2jmidid? ( media-sound/a2jmidid[dbus] )
- pulseaudio? ( || ( media-sound/pulseaudio-daemon[jack] <media-sound/pulseaudio-15.99.1[daemon(+),jack] ) )
-"
+ pulseaudio? (
+ || (
+ media-sound/pulseaudio-daemon[jack]
+ media-video/pipewire[jack-sdk]
+ <media-sound/pulseaudio-15.99.1[daemon(+),jack]
+ )
+ )"
RDEPEND="${CDEPEND}"
DEPEND="${CDEPEND}"
PATCHES=(
- "${FILESDIR}"/${P}-fix-clang.patch
- "${FILESDIR}"/${P}-fix-qt5.15.patch
+ "${FILESDIR}"/${PN}-0.9.1-fix-clang.patch
)
src_prepare() {
diff --git a/media-sound/cadence/cadence-9999.ebuild b/media-sound/cadence/cadence-9999.ebuild
index 0100e16f1a3..98dadcb280c 100644
--- a/media-sound/cadence/cadence-9999.ebuild
+++ b/media-sound/cadence/cadence-9999.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_{8,9} )
+PYTHON_COMPAT=( python3_{8..11} )
inherit python-single-r1 xdg desktop
DESCRIPTION="Collection of tools useful for audio production"
@@ -34,8 +34,13 @@ CDEPEND="
media-sound/jack_capture
virtual/jack
a2jmidid? ( media-sound/a2jmidid[dbus] )
- pulseaudio? ( || ( media-sound/pulseaudio-daemon[jack] <media-sound/pulseaudio-15.99.1[daemon(+),jack] ) )
-"
+ pulseaudio? (
+ || (
+ media-sound/pulseaudio-daemon[jack]
+ media-video/pipewire[jack-sdk]
+ <media-sound/pulseaudio-15.99.1[daemon(+),jack]
+ )
+ )"
RDEPEND="${CDEPEND}"
DEPEND="${CDEPEND}"
diff --git a/media-sound/cadence/files/cadence-0.9.1-fix-qt5.15.patch b/media-sound/cadence/files/cadence-0.9.1-fix-qt5.15.patch
deleted file mode 100644
index b9c52167e37..00000000000
--- a/media-sound/cadence/files/cadence-0.9.1-fix-qt5.15.patch
+++ /dev/null
@@ -1,34 +0,0 @@
-From c167f35fbb76c4246c730b29262a59da73010412 Mon Sep 17 00:00:00 2001
-From: Alex Tsitsimpis <alex.tsitsimpis@gmail.com>
-Date: Thu, 4 Jun 2020 12:49:40 +0300
-Subject: [PATCH] Fix build with Qt 5.15+
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
-Building with Qt 5.15 failed with the following error:
-
-../widgets/pixmapdial.cpp:231:26: error: aggregate ‘QPainterPath ballPath’ has incomplete type and cannot be defined
- 231 | QPainterPath ballPath;
- | ^~~~~~~~
-../widgets/pixmapdial.cpp:278:26: error: aggregate ‘QPainterPath ballPath’ has incomplete type and cannot be defined
- 278 | QPainterPath ballPath;
- | ^~~~~~~~
-
-Signed-off-by: Alex Tsitsimpis <alex.tsitsimpis@gmail.com>
----
- c++/widgets/pixmapdial.cpp | 1 +
- 1 file changed, 1 insertion(+)
-
-diff --git a/c++/widgets/pixmapdial.cpp b/c++/widgets/pixmapdial.cpp
-index 37dcffd..0b5e0f5 100644
---- a/c++/widgets/pixmapdial.cpp
-+++ b/c++/widgets/pixmapdial.cpp
-@@ -22,6 +22,7 @@
- #include <QtCore/QTimer>
- #include <QtGui/QPainter>
- #include <QtGui/QPaintEvent>
-+#include <QtGui/QPainterPath>
-
- PixmapDial::PixmapDial(QWidget* parent)
- : QDial(parent),
diff --git a/media-sound/cantata/cantata-2.5.0.ebuild b/media-sound/cantata/cantata-2.5.0.ebuild
index c080848b821..b913e18ae0c 100644
--- a/media-sound/cantata/cantata-2.5.0.ebuild
+++ b/media-sound/cantata/cantata-2.5.0.ebuild
@@ -4,7 +4,7 @@
EAPI=8
PLOCALES="cs da de en_GB es fi fr hu it ja ko nl pl pt_BR ru zh_CN"
-inherit cmake plocale qmake-utils xdg
+inherit cmake plocale xdg
DESCRIPTION="Featureful and configurable Qt client for the music player daemon (MPD)"
HOMEPAGE="https://github.com/CDrummond/cantata"
diff --git a/media-sound/cava/Manifest b/media-sound/cava/Manifest
index 7a932b4766f..2a24285f08f 100644
--- a/media-sound/cava/Manifest
+++ b/media-sound/cava/Manifest
@@ -1,2 +1 @@
-DIST cava-0.8.1.tar.gz 99310 BLAKE2B e7d85a6241fee0a4e45f5c50d068b2300ee2d41a019738dc87317986525571eca5f56831e937580fecf949cc85e11512340678b5842ee6f2f3a99f9d06812c3a SHA512 fad4e4fefe98300cc2774a168322056e4181cd2a0cc77a8622471d86512bab9eea6c09559a75518785fbcafee5a958e6d95c8fe5ce1816253e4dec99a23fae1c
DIST cava-0.8.2.tar.gz 103930 BLAKE2B feeb8313bd9b74029d101acaecfeed02e449cc29dceb2c119d7deef65befae418526274e6bad14dc0df7eaed90850ecae4a4064a414d94950ab3c24943281017 SHA512 8ab146987324fad97dea5e9fd893de6c12b00cbb074d835c1e334d75c0d32cb4cbbc13cf72f7899191ebd5d346505b2639dcad5312e5ab00975b29a006ba41b3
diff --git a/media-sound/cava/cava-0.8.1.ebuild b/media-sound/cava/cava-0.8.1.ebuild
deleted file mode 100644
index b96197a19e0..00000000000
--- a/media-sound/cava/cava-0.8.1.ebuild
+++ /dev/null
@@ -1,75 +0,0 @@
-# Copyright 2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit autotools
-
-DESCRIPTION="Console-based Audio Visualizer for Alsa"
-HOMEPAGE="https://github.com/karlstav/cava/"
-SRC_URI="https://github.com/karlstav/cava/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="alsa +ncurses portaudio pulseaudio sdl sndio"
-
-RDEPEND="
- dev-libs/iniparser:4
- sci-libs/fftw:=
- alsa? ( media-libs/alsa-lib )
- ncurses? ( sys-libs/ncurses:= )
- portaudio? ( media-libs/portaudio )
- pulseaudio? ( media-sound/pulseaudio )
- sdl? ( media-libs/libsdl2[opengl,video] )
- sndio? ( media-sound/sndio:= )"
-DEPEND="${RDEPEND}"
-BDEPEND="app-editors/vim-core"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-0.8.0-gentoo-iniparser4.patch
-)
-
-src_prepare() {
- default
-
- # see autogen.sh
- echo ${PV} > version || die
- xxd -i example_files/config config_file.h || die
-
- # https://github.com/karlstav/cava/issues/450
- sed -i 's/-Werror //' Makefile.am || die
-
- eautoreconf
-}
-
-src_configure() {
- local econfargs=(
- $(use_enable alsa input-alsa)
- $(use_enable portaudio input-portaudio)
- $(use_enable pulseaudio input-pulse)
- $(use_enable sndio input-sndio)
-
- $(use_enable ncurses output-ncurses)
- $(use_enable sdl output-sdl)
-
- GENTOO_SYSROOT="${ESYSROOT}" # see iniparser4.patch
- )
-
- econf "${econfargs[@]}"
-}
-
-pkg_postinst() {
- if [[ ! ${REPLACING_VERSIONS} ]]; then
- elog "A default ~/.config/cava/config will be created after initial"
- elog "use of ${PN}, see it and ${EROOT}/usr/share/doc/${PF}/README*"
- elog "for configuring audio input and more."
- fi
-
- if use !alsa && use !portaudio && use !pulseaudio && use !sndio; then
- # give a warning given greets with a segfault without proper configuration
- ewarn "All audio backends are disabled, ${PN} will only function if first"
- ewarn "configured to use 'method = fifo' or 'shmem'."
- ewarn "Tip: fifo is versatile, e.g. mkfifo fifo && jack_capture --daemon -ws > fifo"
- fi
-}
diff --git a/media-sound/chuck/Manifest b/media-sound/chuck/Manifest
index 362205da2e8..9b7723431de 100644
--- a/media-sound/chuck/Manifest
+++ b/media-sound/chuck/Manifest
@@ -1,2 +1 @@
-DIST chuck-1.4.1.0.tgz 14902696 BLAKE2B df324c793236fccc26f6604d1120dc1777cb2ffd8c95a8eff42e8963b9e7011aa88fb094145b4845821c39be781d77ac163cb02025db4fd6db7972f3c390fe65 SHA512 8967c1279959b6a41759519eace468fa4384cd0511c365cef91f8c03e8d720407637c2f9f33df6abd246b7c2155005e82d206113c90a4f23fb22b02f6f426704
DIST chuck-1.4.1.1.tgz 14940362 BLAKE2B 21cd9d30d471c87e35e479dabede5a8ec5c9c8952a24636768aaabddd2bbd6fb00f45bf1394fc218a3fddd9c771473a7b52da779a9e89690cf0eb0ed2801c604 SHA512 8202c9275c6341f35f87fb5140b507936183f3365839f5ba240cd758b6e9b12138e4669ab37f84e218010b49cfcbed777352ba7b69e02b5efc3b800e1977a360
diff --git a/media-sound/chuck/chuck-1.4.1.0.ebuild b/media-sound/chuck/chuck-1.4.1.0.ebuild
deleted file mode 100644
index 21730ecc4a1..00000000000
--- a/media-sound/chuck/chuck-1.4.1.0.ebuild
+++ /dev/null
@@ -1,70 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit flag-o-matic toolchain-funcs
-
-DESCRIPTION="Strongly-timed, concurrent, and on-the-fly audio programming language"
-HOMEPAGE="http://chuck.cs.princeton.edu/"
-SRC_URI="http://chuck.cs.princeton.edu/release/files/${P}.tgz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="+alsa jack examples"
-REQUIRED_USE="|| ( alsa jack )"
-
-RDEPEND="app-eselect/eselect-chuck
- media-libs/libsndfile
- alsa? ( media-libs/alsa-lib )
- jack? ( virtual/jack )"
-DEPEND="${RDEPEND}
- sys-devel/bison
- sys-devel/flex"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-1.4.0.0-hid-smc.patch
- "${FILESDIR}"/${PN}-1.4.0.0-makefile.patch
-)
-
-compile_backend() {
- backend=$1
- pushd "${S}/src" &>/dev/null || die
- einfo "Compiling against ${backend}"
- emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" linux-${backend}
- mv chuck{,-${backend}} || die
- emake clean
- popd &>/dev/null || die
-}
-
-src_compile() {
- # when compile with athlon or athlon-xp flags
- # chuck crashes on removing a shred with a double free or corruption
- # it happens in Chuck_VM_Stack::shutdown() on the line
- # SAFE_DELETE_ARRAY( stack );
- replace-cpu-flags athlon athlon-xp i686
-
- use jack && compile_backend jack
- use alsa && compile_backend alsa
-}
-
-src_install() {
- use jack && dobin src/chuck-jack
- use alsa && dobin src/chuck-alsa
-
- dodoc AUTHORS DEVELOPER PROGRAMMER QUICKSTART README THANKS TODO VERSIONS
- if use examples; then
- dodoc -r examples
- docompress -x /usr/share/doc/${PF}/examples
- fi
-}
-
-pkg_postinst() {
- if [[ -z ${REPLACING_VERSIONS} ]]; then
- elog "Chuck now can use multiple audio engines, so you can specify"
- elog "the preferred audio engine with chuck-{jack,alsa}"
- elog "Or you can use 'eselect chuck' to set the audio engine"
- fi
- eselect chuck update --if-unset
-}
diff --git a/media-sound/chuck/chuck-1.4.1.1.ebuild b/media-sound/chuck/chuck-1.4.1.1.ebuild
index 67ca0bc1a18..45ff5363c15 100644
--- a/media-sound/chuck/chuck-1.4.1.1.ebuild
+++ b/media-sound/chuck/chuck-1.4.1.1.ebuild
@@ -11,7 +11,7 @@ SRC_URI="http://chuck.cs.princeton.edu/release/files/${P}.tgz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="amd64 x86"
IUSE="+alsa jack examples"
REQUIRED_USE="|| ( alsa jack )"
@@ -25,14 +25,14 @@ DEPEND="${RDEPEND}
PATCHES=(
"${FILESDIR}"/${PN}-1.4.0.0-hid-smc.patch
- "${FILESDIR}"/${PN}-1.4.0.0-makefile.patch
+ "${FILESDIR}"/${P}-makefile.patch
)
compile_backend() {
backend=$1
pushd "${S}/src" &>/dev/null || die
einfo "Compiling against ${backend}"
- emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" linux-${backend}
+ emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" LD="$(tc-getCXX)" linux-${backend}
mv chuck{,-${backend}} || die
emake clean
popd &>/dev/null || die
diff --git a/media-sound/chuck/files/chuck-1.4.0.0-makefile.patch b/media-sound/chuck/files/chuck-1.4.0.0-makefile.patch
deleted file mode 100644
index f8c6561a814..00000000000
--- a/media-sound/chuck/files/chuck-1.4.0.0-makefile.patch
+++ /dev/null
@@ -1,27 +0,0 @@
---- chuck-1.4.0.0/src/makefile
-+++ chuck-1.4.0.0/src/makefile
-@@ -40,8 +40,6 @@
-
- ifneq ($(CHUCK_DEBUG),)
- CFLAGS+= -g
--else
--CFLAGS+= -O3
- endif
-
- ifneq ($(USE_64_BIT_SAMPLE),)
---- chuck-1.4.0.0/src/core/makefile.x/makefile.alsa
-+++ chuck-1.4.0.0/src/core/makefile.x/makefile.alsa
-@@ -1,4 +1,4 @@
-
--CFLAGS+= -D__LINUX_ALSA__ -D__PLATFORM_LINUX__ -O3 -fno-strict-aliasing -D__CK_SNDFILE_NATIVE__
-+CFLAGS+= -D__LINUX_ALSA__ -D__PLATFORM_LINUX__ -fno-strict-aliasing -D__CK_SNDFILE_NATIVE__ -fPIC
- LDFLAGS+= -lasound -lstdc++ -ldl -lm -lsndfile -lpthread
-
---- chuck-1.4.0.0/src/core/makefile.x/makefile.jack
-+++ chuck-1.4.0.0/src/core/makefile.x/makefile.jack
-@@ -1,4 +1,4 @@
-
--CFLAGS+= -D__UNIX_JACK__ -D__PLATFORM_LINUX__ -O3 -fno-strict-aliasing -D__CK_SNDFILE_NATIVE__
-+CFLAGS+= -D__UNIX_JACK__ -D__PLATFORM_LINUX__ -fno-strict-aliasing -D__CK_SNDFILE_NATIVE__ -fPIC
- LDFLAGS+= -lasound -ljack -lstdc++ -ldl -lm -lsndfile -lpthread
-
diff --git a/media-sound/chuck/files/chuck-1.4.1.1-makefile.patch b/media-sound/chuck/files/chuck-1.4.1.1-makefile.patch
new file mode 100644
index 00000000000..98147cf9a81
--- /dev/null
+++ b/media-sound/chuck/files/chuck-1.4.1.1-makefile.patch
@@ -0,0 +1,50 @@
+diff --git a/src/core/makefile.x/makefile.alsa b/src/core/makefile.x/makefile.alsa
+index 5694257..577dd91 100644
+--- a/src/core/makefile.x/makefile.alsa
++++ b/src/core/makefile.x/makefile.alsa
+@@ -1,4 +1,4 @@
+
+-CFLAGS+= -D__LINUX_ALSA__ -D__PLATFORM_LINUX__ -O3 -fno-strict-aliasing -D__CK_SNDFILE_NATIVE__
++CFLAGS+= -D__LINUX_ALSA__ -D__PLATFORM_LINUX__ -fno-strict-aliasing -D__CK_SNDFILE_NATIVE__ -fPIC
+ LDFLAGS+= -lasound -lstdc++ -ldl -lm -lsndfile -lpthread
+
+diff --git a/src/core/makefile.x/makefile.jack b/src/core/makefile.x/makefile.jack
+index 86b2511..442708b 100644
+--- a/src/core/makefile.x/makefile.jack
++++ b/src/core/makefile.x/makefile.jack
+@@ -1,4 +1,4 @@
+
+-CFLAGS+= -D__UNIX_JACK__ -D__PLATFORM_LINUX__ -O3 -fno-strict-aliasing -D__CK_SNDFILE_NATIVE__
++CFLAGS+= -D__UNIX_JACK__ -D__PLATFORM_LINUX__ -fno-strict-aliasing -D__CK_SNDFILE_NATIVE__ -fPIC
+ LDFLAGS+= -lasound -ljack -lstdc++ -ldl -lm -lsndfile -lpthread
+
+diff --git a/src/makefile b/src/makefile
+index f52f0c2..310991a 100644
+--- a/src/makefile
++++ b/src/makefile
+@@ -76,11 +76,11 @@ CK_VERSION=1.4.1.1
+
+
+ ########################### COMPILATION TOOLS ##################################
+-LEX=flex
+-YACC=bison
+-CC=gcc
+-CXX=g++
+-LD=g++
++LEX?=flex
++YACC?=bison
++CC?=gcc
++CXX?=g++
++LD?=g++
+
+
+ ############################# COMPILER FLAGS ###################################
+@@ -92,8 +92,6 @@ endif
+
+ ifneq ($(CHUCK_DEBUG),)
+ CFLAGS+= -g
+-else
+-CFLAGS+= -O3
+ endif
+
+ ifneq ($(USE_64_BIT_SAMPLE),)
diff --git a/media-sound/cmus/Manifest b/media-sound/cmus/Manifest
index c5a79155862..41275517b7b 100644
--- a/media-sound/cmus/Manifest
+++ b/media-sound/cmus/Manifest
@@ -1 +1 @@
-DIST cmus-2.9.1.tar.gz 321004 BLAKE2B 1531d9ca8c1fd54ca487eb2b9ce8602f2d448dd80567a04bfc18449d60fbcd5286cd9f0d19983a885b2a532793c44d7dab8c1993ac8d7f5ada4f01ce670404d9 SHA512 b417e58a68c54e97db92b8760a49a3071e81f1594f2144911eed3ccceb68499dedf0699ae313babcb822d71b37add8880dfb2018686cb572e89f8627446d5e05
+DIST cmus-2.10.0.tar.gz 324121 BLAKE2B 7a9b17b04f9461b5375f51584f1dce35dcb6863d57eb9b28391cbfb6abb4eae1f541ee6f10cbbf4c7048c08fd77307647700fd08e41eb56bbad89b67657dd876 SHA512 c055dc974a88f32c7f19fb2e4260ede37fbddc3f23707a98e7f669032c1b4fd9a1032eb5c808cf5ee635617d3abf176e78d1e8596cbe669bbad95cd5c50dde7c
diff --git a/media-sound/cmus/cmus-2.9.1-r1.ebuild b/media-sound/cmus/cmus-2.10.0.ebuild
index a95bb0bdf06..583dd99c76b 100644
--- a/media-sound/cmus/cmus-2.9.1-r1.ebuild
+++ b/media-sound/cmus/cmus-2.10.0.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit bash-completion-r1 toolchain-funcs
@@ -30,7 +30,7 @@ BDEPEND="
DEPEND="
sys-libs/ncurses:=[unicode(+)?]
aac? ( media-libs/faad2 )
- alsa? ( >=media-libs/alsa-lib-1.0.11 )
+ alsa? ( media-libs/alsa-lib )
ao? ( media-libs/libao )
cddb? ( media-libs/libcddb )
cdio? ( dev-libs/libcdio-paranoia )
@@ -40,16 +40,16 @@ DEPEND="
flac? ( media-libs/flac )
jack? ( virtual/jack )
libsamplerate? ( media-libs/libsamplerate )
- mad? ( >=media-libs/libmad-0.14 )
+ mad? ( media-libs/libmad )
mikmod? ( media-libs/libmikmod:0 )
- modplug? ( >=media-libs/libmodplug-0.7 )
- mp4? ( >=media-libs/libmp4v2-1.9:0 )
- musepack? ( >=media-sound/musepack-tools-444 )
+ modplug? ( media-libs/libmodplug )
+ mp4? ( media-libs/libmp4v2:0 )
+ musepack? ( media-sound/musepack-tools )
opus? ( media-libs/opusfile )
pulseaudio? ( media-sound/pulseaudio )
systemd? ( sys-apps/systemd )
tremor? ( media-libs/tremor )
- !tremor? ( vorbis? ( >=media-libs/libvorbis-1.0 ) )
+ !tremor? ( vorbis? ( media-libs/libvorbis ) )
wavpack? ( media-sound/wavpack )
"
RDEPEND="${DEPEND}
@@ -68,7 +68,7 @@ DOCS=( AUTHORS README.md )
S="${WORKDIR}/${P/_/-}"
PATCHES=(
- "${FILESDIR}/${P}-atomic.patch"
+ "${FILESDIR}/${PN}-2.9.1-atomic.patch"
)
src_configure() {
diff --git a/media-sound/cmus/cmus-9999.ebuild b/media-sound/cmus/cmus-9999.ebuild
index 3a73e7ed9e7..7a06ebbe809 100644
--- a/media-sound/cmus/cmus-9999.ebuild
+++ b/media-sound/cmus/cmus-9999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit bash-completion-r1 toolchain-funcs
@@ -10,7 +10,7 @@ if [[ ${PV} == "9999" ]] ; then
inherit git-r3
else
SRC_URI="https://github.com/cmus/cmus/archive/v${PV/_/-}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+ KEYWORDS="~amd64 ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
fi
DESCRIPTION="Ncurses based music player with plugin support for many formats"
@@ -30,7 +30,7 @@ BDEPEND="
DEPEND="
sys-libs/ncurses:=[unicode(+)?]
aac? ( media-libs/faad2 )
- alsa? ( >=media-libs/alsa-lib-1.0.11 )
+ alsa? ( media-libs/alsa-lib )
ao? ( media-libs/libao )
cddb? ( media-libs/libcddb )
cdio? ( dev-libs/libcdio-paranoia )
@@ -40,16 +40,16 @@ DEPEND="
flac? ( media-libs/flac )
jack? ( virtual/jack )
libsamplerate? ( media-libs/libsamplerate )
- mad? ( >=media-libs/libmad-0.14 )
+ mad? ( media-libs/libmad )
mikmod? ( media-libs/libmikmod:0 )
- modplug? ( >=media-libs/libmodplug-0.7 )
- mp4? ( >=media-libs/libmp4v2-1.9:0 )
- musepack? ( >=media-sound/musepack-tools-444 )
+ modplug? ( media-libs/libmodplug )
+ mp4? ( media-libs/libmp4v2:0 )
+ musepack? ( media-sound/musepack-tools )
opus? ( media-libs/opusfile )
pulseaudio? ( media-sound/pulseaudio )
systemd? ( sys-apps/systemd )
tremor? ( media-libs/tremor )
- !tremor? ( vorbis? ( >=media-libs/libvorbis-1.0 ) )
+ !tremor? ( vorbis? ( media-libs/libvorbis ) )
wavpack? ( media-sound/wavpack )
"
RDEPEND="${DEPEND}
@@ -67,6 +67,10 @@ DOCS=( AUTHORS README.md )
S="${WORKDIR}/${P/_/-}"
+PATCHES=(
+ "${FILESDIR}/${PN}-2.9.1-atomic.patch"
+)
+
src_configure() {
my_config() {
local value
diff --git a/media-sound/combine_wave/combine_wave-0.3.1-r1.ebuild b/media-sound/combine_wave/combine_wave-0.3.1-r2.ebuild
index 6974e43cf26..ff73a2b87cd 100644
--- a/media-sound/combine_wave/combine_wave-0.3.1-r1.ebuild
+++ b/media-sound/combine_wave/combine_wave-0.3.1-r2.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
inherit toolchain-funcs
@@ -12,18 +12,12 @@ SRC_URI="http://panteltje.com/panteltje/dvd/${P}.tgz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
-DOCS=( CHANGES README combine_wave.man )
-
-PATCHES=( "${FILESDIR}/${P}-overflow.patch" )
-
-src_prepare() {
- default
- # fix makefile
- sed -i -e "s:gcc:\$(CC):g" -e "s:= -O2:+=:g" \
- -e "s:\( -o \): \$(LDFLAGS)\1:g" Makefile || die "sed Makefile failed"
-}
+PATCHES=(
+ "${FILESDIR}"/${P}-makefile.patch
+ "${FILESDIR}"/${P}-overflow.patch
+ "${FILESDIR}"/${P}-missing-includes.patch
+)
src_configure() {
tc-export CC
@@ -31,5 +25,7 @@ src_configure() {
src_install() {
dobin combine_wave
+
einstalldocs
+ dodoc combine_wave.man
}
diff --git a/media-sound/combine_wave/files/combine_wave-0.3.1-makefile.patch b/media-sound/combine_wave/files/combine_wave-0.3.1-makefile.patch
new file mode 100644
index 00000000000..591d56ad186
--- /dev/null
+++ b/media-sound/combine_wave/files/combine_wave-0.3.1-makefile.patch
@@ -0,0 +1,22 @@
+--- a/Makefile
++++ b/Makefile
+@@ -3,16 +3,13 @@
+ #CC = /usr/local/bin/g++
+ #CC = /usr/bin/g++
+
+-CFLAGS = -O2 -Wall -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64
+-
+-.c.o:
+- gcc $(CFLAGS) -c $<
++CFLAGS += -Wall
++CPPFLAGS += -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64
+
+ OBJECT =\
+ combine_wave.o
+
+-a.out : $(OBJECT)
+- gcc -o combine_wave $(OBJECT)
++all: combine_wave
+
+ # DEPENDENCIES
+ combine_wave.o : combine_wave.c combine_wave.h wave_header.h
diff --git a/media-sound/combine_wave/files/combine_wave-0.3.1-missing-includes.patch b/media-sound/combine_wave/files/combine_wave-0.3.1-missing-includes.patch
new file mode 100644
index 00000000000..3d6a3c938ba
--- /dev/null
+++ b/media-sound/combine_wave/files/combine_wave-0.3.1-missing-includes.patch
@@ -0,0 +1,14 @@
+--- a/combine_wave.h
++++ b/combine_wave.h
+@@ -12,9 +12,10 @@
+ #include <float.h>
+ #include <math.h>
+ #include <linux/soundcard.h>
+-#include <sys/poll.h>
++#include <poll.h>
+ #include "stdint.h"
+ #include <sys/ioctl.h>
++#include <sys/select.h>
+ #include <string.h>
+
+
diff --git a/media-sound/csound/Manifest b/media-sound/csound/Manifest
index 1a1dcce1b7d..9eb23bde8e3 100644
--- a/media-sound/csound/Manifest
+++ b/media-sound/csound/Manifest
@@ -1,4 +1,3 @@
-DIST Csound6.16.0_manual_html.zip 24765630 BLAKE2B 3bf6e2202a42dfa826d39ef41282e1942f26cc3f6a3358e0de3a006f102b686342b4e1824a1c3a48ac37ffed31d9353e6946d948751dcc059819da649d63d9cb SHA512 e550a832e365ab186533045d110259699039d08a85ec2f53d4fe36aa31004725b1dc6732f71d9895fa19b3df5f4ec720af1b4f80856a14b0ffbd844c4ab2dbe3
-DIST Csound6.16.0_manual_pdf.zip 9640644 BLAKE2B 7bb35f806568a80abbd84a4f4988217bea09f3174881d802f6d61505f044c8a26b59036dcb61ead5315e756a4512eb1fb56b2824f27f09899a8fe1664a386754 SHA512 18347ce7080ca7997e98f8addffcc492c7ec5d8e037e71a33bb46fdbc5b58ec26ee42f370689fc228d4150bd9dedc31c7824ec4c19f3243d512977f4380f9490
-DIST csound-6.16.1-distributable.tar.xz 25142436 BLAKE2B fe29208afe2cfc9740e68da213f269ca909facd452ffdd595e14a6dc14526bd497e8a2bc1832da28b0bbd6c8b9ac8891f79d819abf64cba0a9e1002c42f8e5dd SHA512 2535f16dab6a682e38b8352cb7bb87a65aedf0550c1705cde8a64b3c0112d7fd97e6c366dad18ef9ef5e1baaf7123f2c0032d9a2ab6979c202692c3a4069117e
-DIST csound-6.16.2-distributable.tar.xz 25169396 BLAKE2B f51c27606f53571d998a62667c55c60a831c076ced993c4eaa8fa24a7e0a8d4872055dc59455b70124f51e2c419018345e2d0e9a33b95d4362f8c6bdecb8310d SHA512 b72c89b2935d92840f5cb7f6d5696e74a3528f5d37858218691f0f6331a69f63b261937a8a8d346d6e182cf8f4a40af85167a4e42fd005cfcf5b4c9daa822f75
+DIST Csound6.17.0_manual_html.zip 25897263 BLAKE2B 3148a60a398d49d6932864d84b2ee37ddf86d5389b91c99443b2c64f7c3b270d040b83ac88b80ebc772c198223682452da1618391fcc8963fe63151b7837037e SHA512 ff2098828e51e78aa80b10736ea162d90c0b1bef3265e469951a5df63250d283e852490cb2a6599dcb1b8a5c185cf4f0b9534f501e4cb755b9da67ecfb1f4ba6
+DIST Csound6.17.0_manual_pdf.zip 9930889 BLAKE2B c0210f2fb97a6707ae6cd0a0cf38cd374f4d4c973b188ee8d418a7efd5c98dc1d4e61867de021ed2859bd8264cc0876b46deb565c358b6efea42f471d39671a9 SHA512 bf664bab1dec073b48853ccf7519086c55ad74af33db86ac7f95746231c18fb10d46a485047788050094e412d27bbd0df65e238d31b01b435989f2fd734189a6
+DIST csound-6.17.0-distributable.tar.xz 25231984 BLAKE2B 9767aae3368f33340d80abb84c573e6ceb91bb16448e961f62c679742377e62f611b36341ce7dfb32a2daafc9440c3dff84fe031c9d52b7d86491c383cf79d61 SHA512 b7c5b2f70e82d9dc37074cb217bc146d66293cfea2d69ffd3b0eab9aca302e431eb82b906c8d6494969374988edd6a9c7d04d7676efd085a2dce235988400caa
diff --git a/media-sound/csound/csound-6.16.2.ebuild b/media-sound/csound/csound-6.16.2.ebuild
deleted file mode 100644
index 58046967e8a..00000000000
--- a/media-sound/csound/csound-6.16.2.ebuild
+++ /dev/null
@@ -1,262 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-# As upstream (and we aswell) are not allowed to redistribute scansyn,
-# we have to repackage the tarball. For that purpose use `bash files/repackage.sh version`
-# Reference: https://github.com/csound/csound/issues/1148
-
-EAPI=7
-
-LUA_COMPAT=( lua5-1 luajit )
-PYTHON_COMPAT=( python3_{7,8,9} )
-
-inherit cmake lua-single python-single-r1 toolchain-funcs
-
-if [[ ${PV} == "9999" ]]; then
- EGIT_REPO_URI="https://github.com/csound/csound.git"
- inherit git-r3
-else
- DOC_P="Csound$(ver_cut 1-2).0"
- SRC_URI="https://dev.gentoo.org/~fordfrog/distfiles/${P}-distributable.tar.xz
- doc? (
- https://github.com/csound/csound/releases/download/${PV}/${DOC_P}_manual_pdf.zip
- https://github.com/csound/csound/releases/download/${PV}/${DOC_P}_manual_html.zip
- )"
- KEYWORDS="amd64 x86"
-fi
-
-DESCRIPTION="Sound design and signal processing system for composition and performance"
-HOMEPAGE="https://csound.github.io/"
-
-LICENSE="LGPL-2.1 doc? ( FDL-1.2+ )"
-SLOT="0"
-IUSE="+alsa beats chua curl +cxx debug doc double-precision dssi examples
-fltk +fluidsynth hdf5 jack java keyboard linear lua mp3 nls osc portaudio
-portaudio portmidi pulseaudio python samples static-libs stk test +threads +utils
-vim-syntax websocket"
-
-REQUIRED_USE="
- alsa? ( threads )
- java? ( cxx )
- linear? ( double-precision )
- lua? ( ${LUA_REQUIRED_USE} cxx )
- python? ( ${PYTHON_REQUIRED_USE} cxx )
-"
-
-BDEPEND="
- sys-devel/flex
- virtual/yacc
- chua? ( dev-libs/boost )
- lua? ( dev-lang/swig )
- python? ( dev-lang/swig )
- nls? ( sys-devel/gettext )
- test? (
- dev-util/cunit
- ${PYTHON_DEPS}
- )
-"
-# linear currently works only with sci-mathematics-gmm-5.1
-# https://github.com/csound/csound/issues/920
-CDEPEND="
- dev-cpp/eigen:3
- >=media-libs/libsndfile-1.0.16
- media-libs/libsamplerate
- sys-libs/zlib
- alsa? ( media-libs/alsa-lib )
- curl? ( net-misc/curl )
- dssi? (
- media-libs/dssi
- media-libs/ladspa-sdk
- )
- fluidsynth? ( media-sound/fluidsynth:= )
- fltk? ( x11-libs/fltk:1[threads?] )
- hdf5? ( sci-libs/hdf5 )
- jack? ( virtual/jack )
- java? ( >=virtual/jdk-1.8:* )
- keyboard? ( x11-libs/fltk:1[threads?] )
- linear? ( =sci-mathematics/gmm-5.1* )
- lua? ( ${LUA_DEPS} )
- mp3? ( >=media-sound/lame-3.100-r3 )
- osc? ( media-libs/liblo )
- portaudio? ( media-libs/portaudio )
- portmidi? ( media-libs/portmidi )
- pulseaudio? ( media-sound/pulseaudio )
- python? ( ${PYTHON_DEPS} )
- stk? ( media-libs/stk )
- utils? ( !media-sound/snd )
- websocket? ( net-libs/libwebsockets:= )
-"
-RDEPEND="${CDEPEND}"
-DEPEND="
- ${CDEPEND}
- dev-libs/boost
-"
-
-if [[ ${PV} != "9999" ]]; then
- DEPEND+="doc? ( app-arch/unzip )"
-fi
-
-# requires specific alsa settings
-RESTRICT="test"
-
-PATCHES=(
- "${FILESDIR}/${PN}-6.13.0-xdg-open.patch"
- "${FILESDIR}/${PN}-6.15.0-lame.patch"
-)
-
-pkg_setup() {
- use lua && lua-single_pkg_setup
-
- if use python || use test ; then
- python-single-r1_pkg_setup
- fi
-}
-
-src_prepare() {
- cmake_src_prepare
-
- sed -e '/set(PLUGIN_INSTALL_DIR/s/-${APIVERSION}//' \
- -e '/-O3/d' \
- -i CMakeLists.txt || die
-
- if use doc; then
- local png="${WORKDIR}/html/images/delayk.png"
- pngfix -q --out=${png/.png/fixed.png} ${png} # see pngfix help for exit codes
- [[ $? -gt 15 ]] && die "Failed to fix ${png}"
- mv -f ${png/.png/fixed.png} ${png} || die
- fi
-}
-
-src_configure() {
- local mycmakeargs=(
- -DBUILD_BELA=OFF
- -DBUILD_BUCHLA_OPCODES=ON
- -DBUILD_CHUA_OPCODES=$(usex chua)
- -DBUILD_COUNTER_OPCODES=ON
- -DBUILD_CSBEATS=$(usex beats)
- -DBUILD_CUDA_OPCODES=OFF
- -DBUILD_CXX_INTERFACE=$(usex cxx)
- -DBUILD_DSSI_OPCODES=$(usex dssi)
- -DBUILD_EMUGENS_OPCODES=ON
- -DBUILD_EXCITER_OPCODES=ON
- -DBUILD_FLUID_OPCODES=$(usex fluidsynth)
- -DBUILD_FRAMEBUFFER_OPCODES=ON
- -DBUILD_HDF5_OPCODES=$(usex hdf5)
- -DBUILD_INSTALLER=OFF
- -DBUILD_JACK_OPCODES=$(usex jack)
- -DBUILD_JAVA_INTERFACE=$(usex java)
- -DBUILD_LINEAR_ALGEBRA_OPCODES=$(usex linear)
- -DBUILD_LUA_INTERFACE=$(usex lua)
- -DBUILD_MP3OUT_OPCODE=$(usex mp3)
- -DBUILD_MULTI_CORE=$(usex threads)
- -DBUILD_OPENCL_OPCODES=OFF
- -DBUILD_OSC_OPCODES=$(usex osc)
- -DBUILD_P5GLOVE_OPCODES=OFF
- -DBUILD_PADSYNTH_OPCODES=ON
- -DBUILD_PLATEREV_OPCODES=ON
- -DBUILD_PVSGENDY_OPCODE=OFF
- -DBUILD_PYTHON_INTERFACE=$(usex python)
- -DBUILD_RELEASE=ON
- -DBUILD_SCANSYN_OPCODES=OFF # this is not allowed to be redistributed: https://github.com/csound/csound/issues/1148
- -DBUILD_SELECT_OPCODE=ON
- -DBUILD_SERIAL_OPCODES=ON
- -DBUILD_SHARED_LIBS=ON
- -DBUILD_STACK_OPCODES=ON
- -DBUILD_STATIC_LIBRARY=$(usex static-libs "ON" $(usex test))
- -DBUILD_STK_OPCODES=$(usex stk)
- -DBUILD_TESTS=$(usex test)
- -DBUILD_UTILITIES=$(usex utils)
- -DBUILD_VIRTUAL_KEYBOARD=$(usex keyboard)
- -DBUILD_VST4CS_OPCODES=OFF
- -DBUILD_WEBSOCKET_OPCODE=$(usex websocket)
- -DBUILD_WIIMOTE_OPCODES=OFF
- -DBUILD_WINSOUND=OFF
-
- -DFAIL_MISSING=ON
- -DNEW_PARSER_DEBUG=$(usex debug)
- -DREQUIRE_PTHREADS=$(usex threads)
-
- -DUSE_ALSA=$(usex alsa)
- -DUSE_ATOMIC_BUILTIN=ON
- -DUSE_AUDIOUNIT=OFF # Apple specific
- -DUSE_COMPILER_OPTIMIZATIONS=ON
- -DUSE_COREMIDI=OFF # Apple specific
- -DUSE_CURL=$(usex curl)
- -DUSE_DOUBLE=$(usex double-precision)
- -DUSE_FLTK=$(usex fltk)
- -DUSE_GETTEXT=$(usex nls)
- -DUSE_GIT_COMMIT=ON
- -DUSE_IPMIDI=ON
- -DUSE_JACK=$(usex jack)
- -DUSE_LIB64=$([[ $(get_libdir) == "lib64" ]] && echo "ON" || echo "OFF")
- -DUSE_LRINT=ON
- -DUSE_PORTAUDIO=$(usex portaudio)
- -DUSE_PORTMIDI=$(usex portmidi)
- -DUSE_PULSEAUDIO=$(usex pulseaudio)
-
- )
-
- use java && mycmakeargs+=(
- -DJAVA_HOME="$(java-config -g JAVA_HOME)"
- )
-
- use lua && mycmakeargs+=(
- -DLUA_H_PATH="$(lua_get_include_dir)"
- -DLUA_LIBRARY="$(lua_get_shared_lib)"
- # LUA_MODULE_INSTALL_DIR omitted on purpose, csound Lua module links against liblua
- # so it must NOT be installed into cmod_dir.
- )
-
- cmake_src_configure
-}
-
-src_install() {
- cmake_src_install
- dodoc -r Release_Notes/.
-
- # generate env.d file
- cat > "${T}"/62${PN} <<-_EOF_ || die
- OPCODEDIR$(usex double-precision 64 '')="${EPREFIX}/usr/$(get_libdir)/${PN}/plugins$(usex double-precision 64 '')"
- CSSTRNGS="${EPREFIX}/usr/share/locale"
- _EOF_
- if use stk ; then
- echo RAWWAVE_PATH=\"${EPREFIX}/usr/share/csound/rawwaves\" >> "${T}"/62${PN} || die
- fi
- doenvd "${T}"/62${PN}
-
- if use examples ; then
- dodoc -r examples
- docompress -x /usr/share/doc/${PF}/examples
- fi
-
- use samples && dodoc -r samples
-
- if use vim-syntax ; then
- insinto /usr/share/vim/vimfiles/syntax
- doins installer/misc/vim/csound_{csd,orc,sco}.vim
- insinto /usr/share/vim/vimfiles/plugin
- doins installer/misc/vim/csound.vim
- fi
-
- # rename extract to csound_extract (bug #247394)
- mv "${ED}"/usr/bin/{,csound_}extract || die
-
- use python && python_optimize
-
- use java && (dosym lib_jcsound6.so usr/lib64/lib_jcsound.so.1 || die "Failed to create java lib symlink")
-
- # install docs
- if [[ ${PV} != "9999" ]] && use doc ; then
- dodoc "${WORKDIR}"/*.pdf
- dodoc -r "${WORKDIR}"/html
- fi
-}
-
-pkg_postinst() {
- if [[ -z ${REPLACING_VERSIONS} ]] ; then
- elog
- elog "The extract tool is now installed as csound_extract"
- elog "due to collisions with many other packages (bug #247394)."
- elog
- fi
-}
diff --git a/media-sound/csound/csound-6.16.1.ebuild b/media-sound/csound/csound-6.17.0.ebuild
index 58046967e8a..cc3c316eca9 100644
--- a/media-sound/csound/csound-6.16.1.ebuild
+++ b/media-sound/csound/csound-6.17.0.ebuild
@@ -1,22 +1,22 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
# As upstream (and we aswell) are not allowed to redistribute scansyn,
# we have to repackage the tarball. For that purpose use `bash files/repackage.sh version`
# Reference: https://github.com/csound/csound/issues/1148
-EAPI=7
+EAPI=8
LUA_COMPAT=( lua5-1 luajit )
-PYTHON_COMPAT=( python3_{7,8,9} )
+PYTHON_COMPAT=( python3_{8..11} )
-inherit cmake lua-single python-single-r1 toolchain-funcs
+inherit cmake lua-single python-single-r1
if [[ ${PV} == "9999" ]]; then
EGIT_REPO_URI="https://github.com/csound/csound.git"
inherit git-r3
else
- DOC_P="Csound$(ver_cut 1-2).0"
+ DOC_P="Csound${PV}"
SRC_URI="https://dev.gentoo.org/~fordfrog/distfiles/${P}-distributable.tar.xz
doc? (
https://github.com/csound/csound/releases/download/${PV}/${DOC_P}_manual_pdf.zip
@@ -30,36 +30,31 @@ HOMEPAGE="https://csound.github.io/"
LICENSE="LGPL-2.1 doc? ( FDL-1.2+ )"
SLOT="0"
-IUSE="+alsa beats chua curl +cxx debug doc double-precision dssi examples
-fltk +fluidsynth hdf5 jack java keyboard linear lua mp3 nls osc portaudio
-portaudio portmidi pulseaudio python samples static-libs stk test +threads +utils
-vim-syntax websocket"
+IUSE="+alsa beats curl +cxx debug doc double-precision dssi examples jack java lua nls osc portaudio
+portaudio portmidi pulseaudio samples static-libs test +threads +utils vim-syntax"
REQUIRED_USE="
+ ${PYTHON_REQUIRED_USE}
alsa? ( threads )
java? ( cxx )
- linear? ( double-precision )
lua? ( ${LUA_REQUIRED_USE} cxx )
- python? ( ${PYTHON_REQUIRED_USE} cxx )
"
BDEPEND="
+ sys-devel/bison
sys-devel/flex
virtual/yacc
- chua? ( dev-libs/boost )
+ doc? ( media-libs/libpng )
lua? ( dev-lang/swig )
- python? ( dev-lang/swig )
nls? ( sys-devel/gettext )
test? (
dev-util/cunit
${PYTHON_DEPS}
)
"
-# linear currently works only with sci-mathematics-gmm-5.1
-# https://github.com/csound/csound/issues/920
CDEPEND="
dev-cpp/eigen:3
- >=media-libs/libsndfile-1.0.16
+ media-libs/libsndfile
media-libs/libsamplerate
sys-libs/zlib
alsa? ( media-libs/alsa-lib )
@@ -68,25 +63,19 @@ CDEPEND="
media-libs/dssi
media-libs/ladspa-sdk
)
- fluidsynth? ( media-sound/fluidsynth:= )
- fltk? ( x11-libs/fltk:1[threads?] )
- hdf5? ( sci-libs/hdf5 )
jack? ( virtual/jack )
java? ( >=virtual/jdk-1.8:* )
- keyboard? ( x11-libs/fltk:1[threads?] )
- linear? ( =sci-mathematics/gmm-5.1* )
lua? ( ${LUA_DEPS} )
- mp3? ( >=media-sound/lame-3.100-r3 )
osc? ( media-libs/liblo )
portaudio? ( media-libs/portaudio )
portmidi? ( media-libs/portmidi )
pulseaudio? ( media-sound/pulseaudio )
- python? ( ${PYTHON_DEPS} )
- stk? ( media-libs/stk )
utils? ( !media-sound/snd )
- websocket? ( net-libs/libwebsockets:= )
"
-RDEPEND="${CDEPEND}"
+RDEPEND="
+ ${CDEPEND}
+ ${PYTHON_DEPS}
+"
DEPEND="
${CDEPEND}
dev-libs/boost
@@ -101,15 +90,12 @@ RESTRICT="test"
PATCHES=(
"${FILESDIR}/${PN}-6.13.0-xdg-open.patch"
- "${FILESDIR}/${PN}-6.15.0-lame.patch"
)
pkg_setup() {
use lua && lua-single_pkg_setup
- if use python || use test ; then
- python-single-r1_pkg_setup
- fi
+ python-single-r1_pkg_setup
}
src_prepare() {
@@ -130,47 +116,21 @@ src_prepare() {
src_configure() {
local mycmakeargs=(
-DBUILD_BELA=OFF
- -DBUILD_BUCHLA_OPCODES=ON
- -DBUILD_CHUA_OPCODES=$(usex chua)
- -DBUILD_COUNTER_OPCODES=ON
-DBUILD_CSBEATS=$(usex beats)
- -DBUILD_CUDA_OPCODES=OFF
-DBUILD_CXX_INTERFACE=$(usex cxx)
+ -DBUILD_DEPRECATED_OPCODES=ON
-DBUILD_DSSI_OPCODES=$(usex dssi)
- -DBUILD_EMUGENS_OPCODES=ON
- -DBUILD_EXCITER_OPCODES=ON
- -DBUILD_FLUID_OPCODES=$(usex fluidsynth)
- -DBUILD_FRAMEBUFFER_OPCODES=ON
- -DBUILD_HDF5_OPCODES=$(usex hdf5)
-DBUILD_INSTALLER=OFF
- -DBUILD_JACK_OPCODES=$(usex jack)
-DBUILD_JAVA_INTERFACE=$(usex java)
- -DBUILD_LINEAR_ALGEBRA_OPCODES=$(usex linear)
-DBUILD_LUA_INTERFACE=$(usex lua)
- -DBUILD_MP3OUT_OPCODE=$(usex mp3)
-DBUILD_MULTI_CORE=$(usex threads)
- -DBUILD_OPENCL_OPCODES=OFF
-DBUILD_OSC_OPCODES=$(usex osc)
- -DBUILD_P5GLOVE_OPCODES=OFF
-DBUILD_PADSYNTH_OPCODES=ON
- -DBUILD_PLATEREV_OPCODES=ON
- -DBUILD_PVSGENDY_OPCODE=OFF
- -DBUILD_PYTHON_INTERFACE=$(usex python)
-DBUILD_RELEASE=ON
-DBUILD_SCANSYN_OPCODES=OFF # this is not allowed to be redistributed: https://github.com/csound/csound/issues/1148
- -DBUILD_SELECT_OPCODE=ON
- -DBUILD_SERIAL_OPCODES=ON
- -DBUILD_SHARED_LIBS=ON
- -DBUILD_STACK_OPCODES=ON
-DBUILD_STATIC_LIBRARY=$(usex static-libs "ON" $(usex test))
- -DBUILD_STK_OPCODES=$(usex stk)
-DBUILD_TESTS=$(usex test)
-DBUILD_UTILITIES=$(usex utils)
- -DBUILD_VIRTUAL_KEYBOARD=$(usex keyboard)
- -DBUILD_VST4CS_OPCODES=OFF
- -DBUILD_WEBSOCKET_OPCODE=$(usex websocket)
- -DBUILD_WIIMOTE_OPCODES=OFF
- -DBUILD_WINSOUND=OFF
-DFAIL_MISSING=ON
-DNEW_PARSER_DEBUG=$(usex debug)
@@ -178,12 +138,9 @@ src_configure() {
-DUSE_ALSA=$(usex alsa)
-DUSE_ATOMIC_BUILTIN=ON
- -DUSE_AUDIOUNIT=OFF # Apple specific
-DUSE_COMPILER_OPTIMIZATIONS=ON
- -DUSE_COREMIDI=OFF # Apple specific
-DUSE_CURL=$(usex curl)
-DUSE_DOUBLE=$(usex double-precision)
- -DUSE_FLTK=$(usex fltk)
-DUSE_GETTEXT=$(usex nls)
-DUSE_GIT_COMMIT=ON
-DUSE_IPMIDI=ON
@@ -193,7 +150,7 @@ src_configure() {
-DUSE_PORTAUDIO=$(usex portaudio)
-DUSE_PORTMIDI=$(usex portmidi)
-DUSE_PULSEAUDIO=$(usex pulseaudio)
-
+ -DUSE_VCPKG=OFF
)
use java && mycmakeargs+=(
@@ -219,9 +176,6 @@ src_install() {
OPCODEDIR$(usex double-precision 64 '')="${EPREFIX}/usr/$(get_libdir)/${PN}/plugins$(usex double-precision 64 '')"
CSSTRNGS="${EPREFIX}/usr/share/locale"
_EOF_
- if use stk ; then
- echo RAWWAVE_PATH=\"${EPREFIX}/usr/share/csound/rawwaves\" >> "${T}"/62${PN} || die
- fi
doenvd "${T}"/62${PN}
if use examples ; then
@@ -241,7 +195,7 @@ src_install() {
# rename extract to csound_extract (bug #247394)
mv "${ED}"/usr/bin/{,csound_}extract || die
- use python && python_optimize
+ python_optimize
use java && (dosym lib_jcsound6.so usr/lib64/lib_jcsound.so.1 || die "Failed to create java lib symlink")
diff --git a/media-sound/csound/csound-9999.ebuild b/media-sound/csound/csound-9999.ebuild
index 0486ace1f63..ae7b8aae361 100644
--- a/media-sound/csound/csound-9999.ebuild
+++ b/media-sound/csound/csound-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
# As upstream (and we aswell) are not allowed to redistribute scansyn,
@@ -8,7 +8,7 @@
EAPI=8
LUA_COMPAT=( lua5-1 luajit )
-PYTHON_COMPAT=( python3_{7,8,9,10} )
+PYTHON_COMPAT=( python3_{8..11} )
inherit cmake lua-single python-single-r1
@@ -44,6 +44,7 @@ BDEPEND="
sys-devel/bison
sys-devel/flex
virtual/yacc
+ doc? ( media-libs/libpng )
lua? ( dev-lang/swig )
nls? ( sys-devel/gettext )
test? (
diff --git a/media-sound/csound/files/csound-6.15.0-lame.patch b/media-sound/csound/files/csound-6.15.0-lame.patch
deleted file mode 100644
index 800ec4fd0f4..00000000000
--- a/media-sound/csound/files/csound-6.15.0-lame.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-diff --git a/Opcodes/CMakeLists.txt b/Opcodes/CMakeLists.txt
-index af39138..ec48294 100644
---- a/Opcodes/CMakeLists.txt
-+++ b/Opcodes/CMakeLists.txt
-@@ -41,7 +41,7 @@ check_include_file(wiiuse.h WIIUSE_H)
- find_library(WIIUSE_LIB wiiuse)
- check_include_file(p5glove.h P5GLOVE_H)
- find_library(P5GLOVE_LIB p5glove)
--check_include_file(lame.h LAME_HEADER)
-+check_include_file(lame/lame.h LAME_HEADER)
- find_library(LAME_LIB mp3lame)
-
- ## OPCODE LIBS WITH NO EXTERNAL DEPENDENCIES ##
-diff --git a/Opcodes/lame.c b/Opcodes/lame.c
-index a951f47..0c1c3e6 100644
---- a/Opcodes/lame.c
-+++ b/Opcodes/lame.c
-@@ -22,7 +22,7 @@
- */
-
- #include "csdl.h"
--#include "lame.h"
-+#include "lame/lame.h"
-
- typedef struct _mp3out {
- OPDS h;
diff --git a/media-sound/csound/metadata.xml b/media-sound/csound/metadata.xml
index cf179bf2427..1ef13208437 100644
--- a/media-sound/csound/metadata.xml
+++ b/media-sound/csound/metadata.xml
@@ -7,17 +7,11 @@
</maintainer>
<use>
<flag name="beats">Build the beats score frontend</flag>
- <flag name="chua">Build the chua opcodes</flag>
<flag name="double-precision">Use double-precision floating point for audio samples</flag>
<flag name="dssi">Build the DSSI opcodes</flag>
- <flag name="fluidsynth">Build the fluidsynth opcodes</flag>
- <flag name="keyboard">Build Virtual MIDI keyboard</flag>
- <flag name="linear">Build the linear algebra Opcodes</flag>
<flag name="portmidi">Build the PortMIDI I/O module</flag>
<flag name="samples">Install the HRTF datafiles for use with hrtfmove, hrtfmove2, hrtfstat, hrtfearly, and hrtfreverb</flag>
- <flag name="stk">Build the stk opcodes</flag>
<flag name="utils">Build stand-alone executables for utilities that can also be used via `csound -U`</flag>
- <flag name="websocket">Build the websocket opcode</flag>
</use>
<upstream>
<remote-id type="sourceforge">csound</remote-id>
diff --git a/media-sound/deadbeef/Manifest b/media-sound/deadbeef/Manifest
index 0ca8958aee2..315ce3f2e73 100644
--- a/media-sound/deadbeef/Manifest
+++ b/media-sound/deadbeef/Manifest
@@ -1 +1,2 @@
DIST deadbeef-1.8.8.tar.bz2 5083407 BLAKE2B 69fd2cbaf131b3e44b426163ce6a83479bb1aff0e088c4beea09d747750f6f20b1e297eab1dd1ae0446d2af0aaf28fe0cc7c9f9e3e73fe031d369ba2f5d809ca SHA512 399f0e70eca5e102a9e73ff03199c89c6f28f3e0da96e793316d1af83f00e71f09f6cc81a3fd0b0f0d52fe9e0195a3b9ffb0cf7e7708c3ea7085f33a5ec08b47
+DIST deadbeef-1.9.1.tar.bz2 5136384 BLAKE2B 6e8314728b824b182ecb356d9a9cb09364650f6ca6b5e5d2f7077fc048fe62284e4959910a4cf982fd79893c503044d02417633713d0dcf34e93128aff22692e SHA512 2f959fb139078bbde3c1183019545ed3979b3c5dfc051794ea7a5ccf166156acc8d5dface3169ec705059f487d47c9b314c5400770a7572c22fbd0b903eefc5a
diff --git a/media-sound/deadbeef/deadbeef-1.9.1-r1.ebuild b/media-sound/deadbeef/deadbeef-1.9.1-r1.ebuild
new file mode 100644
index 00000000000..d749eff41a5
--- /dev/null
+++ b/media-sound/deadbeef/deadbeef-1.9.1-r1.ebuild
@@ -0,0 +1,191 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools xdg flag-o-matic toolchain-funcs plocale
+
+DESCRIPTION="DeaDBeeF is a modular audio player similar to foobar2000"
+HOMEPAGE="https://deadbeef.sourceforge.io/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="
+ GPL-2
+ LGPL-2.1
+ wavpack? ( BSD )
+"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+IUSE="aac alsa cdda converter cover dts ffmpeg flac +hotkeys lastfm mp3 musepack nls notify +nullout opus oss pulseaudio sc68 shellexec +supereq threads vorbis wavpack"
+
+REQUIRED_USE="
+ || ( alsa oss pulseaudio nullout )
+"
+
+DEPEND="
+ x11-libs/gtk+:3
+ net-misc/curl:0=
+ dev-libs/jansson:=
+ aac? ( media-libs/faad2 )
+ alsa? ( media-libs/alsa-lib )
+ cdda? (
+ dev-libs/libcdio:0=
+ media-libs/libcddb
+ dev-libs/libcdio-paranoia:0=
+ )
+ cover? (
+ media-libs/imlib2[jpeg,png]
+ )
+ dts? ( media-libs/libdca )
+ ffmpeg? ( media-video/ffmpeg )
+ flac? (
+ media-libs/flac
+ media-libs/libogg
+ )
+ mp3? ( media-sound/mpg123 )
+ musepack? ( media-sound/musepack-tools )
+ nls? ( virtual/libintl )
+ notify? (
+ sys-apps/dbus
+ )
+ opus? ( media-libs/opusfile )
+ pulseaudio? ( media-sound/pulseaudio )
+ vorbis? ( media-libs/libvorbis )
+ wavpack? ( media-sound/wavpack )
+ dev-libs/libdispatch
+"
+
+RDEPEND="${DEPEND}"
+BDEPEND="
+ dev-util/intltool
+ sys-devel/gettext
+ sys-devel/clang
+ sys-devel/llvm
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ "${FILESDIR}/deadbeef-use-ffmpeg-plugin-for-ape-by-default.patch"
+)
+
+src_prepare() {
+ default
+
+ drop_from_linguas() {
+ sed "/${1}/d" -i "${S}/po/LINGUAS" || die
+ }
+
+ drop_and_stub() {
+ rm -rf "${1}"
+ mkdir "${1}"
+ cat > "${1}/Makefile.in" <<-EOF
+ all: nothing
+ install: nothing
+ nothing:
+ EOF
+ }
+
+ plocale_for_each_disabled_locale drop_from_linguas || die
+
+ eautopoint --force
+ eautoreconf
+
+ # Get rid of bundled gettext.
+ drop_and_stub "${S}/intl"
+
+ # Plugins that are undesired for whatever reason, candidates for unbundling and such.
+ for i in adplug alac dumb ffap mms gme mono2stereo psf shn sid soundtouch wma; do
+ drop_and_stub "${S}/plugins/${i}"
+ done
+
+ rm -rf "${S}/plugins/rg_scanner/ebur128"
+}
+
+src_configure () {
+ if ! tc-is-clang; then
+ AR=llvm-ar
+ CC=${CHOST}-clang
+ CXX=${CHOST}-clang++
+ NM=llvm-nm
+ RANLIB=llvm-ranlib
+
+ strip-unsupported-flags
+ fi
+
+ export HOST_CC="$(tc-getBUILD_CC)"
+ export HOST_CXX="$(tc-getBUILD_CXX)"
+ tc-export CC CXX LD AR NM OBJDUMP RANLIB PKG_CONFIG
+
+ local myconf=(
+ "--disable-static"
+ "--disable-staticlink"
+ "--disable-portable"
+ "--disable-rpath"
+
+ "--disable-libmad"
+ "--disable-gtk2"
+ "--disable-adplug"
+ "--disable-coreaudio"
+ "--disable-dumb"
+ "--disable-alac"
+ "--disable-ffap"
+ "--disable-gme"
+ "--disable-mms"
+ "--disable-mono2stereo"
+ "--disable-psf"
+ "--disable-rgscanner"
+ "--disable-shn"
+ "--disable-sid"
+ "--disable-sndfile"
+ "--disable-soundtouch"
+ "--disable-src"
+ "--disable-tta"
+ "--disable-vfs-zip"
+ "--disable-vtx"
+ "--disable-wildmidi"
+ "--disable-wma"
+
+ "$(use_enable alsa)"
+ "$(use_enable oss)"
+ "$(use_enable pulseaudio pulse)"
+ "$(use_enable mp3)"
+ "$(use_enable mp3 libmpg123)"
+ "$(use_enable nls)"
+ "$(use_enable vorbis)"
+ "$(use_enable threads)"
+ "$(use_enable flac)"
+ "$(use_enable supereq)"
+ "$(use_enable cdda)"
+ "$(use_enable cdda cdda-paranoia)"
+ "$(use_enable aac)"
+ "$(use_enable cover artwork)"
+ "$(use_enable cover artwork-network)"
+ "$(use_enable dts dca)"
+ "$(use_enable ffmpeg)"
+ "$(use_enable converter)"
+ "$(use_enable musepack)"
+ "$(use_enable notify)"
+ "$(use_enable nullout)"
+ "$(use_enable opus)"
+ "$(use_enable pulseaudio pulse)"
+ "$(use_enable sc68)"
+ "$(use_enable shellexec)"
+ "$(use_enable shellexec shellexecui)"
+ "$(use_enable lastfm lfm)"
+ "$(use_enable wavpack)"
+
+ "--enable-gtk3"
+ "--enable-vfs-curl"
+ "--enable-shared"
+ "--enable-m3u"
+ "--enable-pltbrowser"
+ )
+
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+
+ find "${ED}" -name '*.la' -delete || die
+}
diff --git a/media-sound/denemo/denemo-2.6.0.ebuild b/media-sound/denemo/denemo-2.6.0.ebuild
index aebe9141094..dbeb5f19d94 100644
--- a/media-sound/denemo/denemo-2.6.0.ebuild
+++ b/media-sound/denemo/denemo-2.6.0.ebuild
@@ -11,7 +11,7 @@ SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
LICENSE="GPL-3+ OFL-1.1"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="amd64 x86"
# configure options currently not used:
# --enable-mem(no) memory debugging: needs Electric fence (efence), which
diff --git a/media-sound/denonavr-cli/Manifest b/media-sound/denonavr-cli/Manifest
new file mode 100644
index 00000000000..67d63d547e3
--- /dev/null
+++ b/media-sound/denonavr-cli/Manifest
@@ -0,0 +1,2 @@
+DIST denonavr-cli-2.gh.tar.gz 4102 BLAKE2B 1f17a642cd546d3a9fb77ee9d24a6c7c1622e8c0d6fd6f4d04ac1daa4b491908e3bc18efce4e827fbf6936b91929e68d32efe0c91aec260069817d6c0708eb9f SHA512 04354f5fdf46e179a82df3d539329fd6f00312c3d87fc78ecc40c85223c468c6bfc93092e835351857a1ca4fa149c5f209aa6a2d96caf518332dd7dc4aba334d
+DIST denonavr-cli-3.gh.tar.gz 7508 BLAKE2B 4084cbc87363858cb0132847b88c486795332ae28d1c24efb46c22a8985711aa18dfe6b2634f6457ea3108789bb4812ffba17a50edb429fb64a29ca90bbeedaa SHA512 f2bdf442fd3bec788d9ac684d93314da6c7750d946fc563ceb71a52ef1663e1fe06c62653d4e5ff69625749f1eefacc41c92ebcfdf0f6ff7fdf7c7b703d7408d
diff --git a/media-sound/denonavr-cli/denonavr-cli-2.ebuild b/media-sound/denonavr-cli/denonavr-cli-2.ebuild
new file mode 100644
index 00000000000..32f23f00f48
--- /dev/null
+++ b/media-sound/denonavr-cli/denonavr-cli-2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="A simple CLI for Denon AV receivers"
+HOMEPAGE="
+ https://github.com/mgorny/denonavr-cli/
+ https://pypi.org/project/denonavr-cli/
+"
+SRC_URI="
+ https://github.com/mgorny/denonavr-cli/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/denonavr[${PYTHON_USEDEP}]
+"
diff --git a/media-sound/denonavr-cli/denonavr-cli-3.ebuild b/media-sound/denonavr-cli/denonavr-cli-3.ebuild
new file mode 100644
index 00000000000..a5e29f2af9b
--- /dev/null
+++ b/media-sound/denonavr-cli/denonavr-cli-3.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="A simple CLI for Denon AV receivers"
+HOMEPAGE="
+ https://github.com/mgorny/denonavr-cli/
+ https://pypi.org/project/denonavr-cli/
+"
+SRC_URI="
+ https://github.com/mgorny/denonavr-cli/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/denonavr[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
diff --git a/media-sound/denonavr-cli/metadata.xml b/media-sound/denonavr-cli/metadata.xml
new file mode 100644
index 00000000000..b3ab18a624f
--- /dev/null
+++ b/media-sound/denonavr-cli/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mgorny@gentoo.org</email>
+ <name>Michał Górny</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">mgorny/denonavr-cli</remote-id>
+ <remote-id type="pypi">denonavr-cli</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/media-sound/din/Manifest b/media-sound/din/Manifest
index ed7850d4c2a..63db87a93dd 100644
--- a/media-sound/din/Manifest
+++ b/media-sound/din/Manifest
@@ -1,2 +1 @@
-DIST din-53.1.tar.gz 3708022 BLAKE2B 882d4ae6cbe24c3d7fc326df3f3630d7ea7cd65b5d53c4751844dc3edcf9d533cd7cfe58fed4c46766fab6b4983e75f75145206b5362bceb27382d02705b9a36 SHA512 42058b00402e726869af8a5cb8eb9b34e7b1709185c972d3f3b633a980ad7de57a143ca0ce854ce681ec67b81cd6dd2b2b06023a15d3f1b1bd54c4ac643b6096
DIST din-54.tar.gz 3710611 BLAKE2B 2a7540d9a413c0f83b2cfc7373b1c0fdd40012ae725f162810e4d3165e3bc669661860fd653eaed8c7f2eeed7f015ff50ce6082ce8de04bd035bf395ca018d6a SHA512 8831e6d838ba06373b13574701929f96a508f2899618509b3e79f23cb0aa11c34b347fa00b4fa765a7668c7db54733be2c9146b8e783d3fe07e3ea4ce2707bd8
diff --git a/media-sound/din/din-53.1.ebuild b/media-sound/din/din-53.1.ebuild
deleted file mode 100644
index a12ad9ed2cc..00000000000
--- a/media-sound/din/din-53.1.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit autotools edos2unix xdg
-
-DESCRIPTION="a software musical instrument and audio synthesizer"
-HOMEPAGE="https://dinisnoise.org/"
-SRC_URI="https://archive.org/download/dinisnoise_source_code/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="+alsa jack"
-
-RDEPEND="
- dev-lang/tcl:0=
- media-libs/libsdl:=
- virtual/glu
- virtual/opengl
- alsa? ( media-libs/alsa-lib )
- jack? ( virtual/jack )
-"
-DEPEND="
- ${RDEPEND}
- dev-libs/boost
-"
-BDEPEND="
- virtual/pkgconfig
-"
-
-REQUIRED_USE="|| ( alsa jack )"
-
-PATCHES=(
- "${FILESDIR}/${PN}-52-makefile.patch"
- "${FILESDIR}/${PN}-48-fix-random-constants.patch"
-)
-
-src_prepare() {
- default
-
- edos2unix pixmaps/${PN}.desktop
-
- use jack && (sed -i "s/-lasound/-ljack/g" src/Makefile.am || die "Failed to fix jack linking")
-
- eautoreconf
-}
-
-src_configure() {
- # Jack takes over alsa.
- local sound_engine
-
- use jack && sound_engine="UNIX_JACK" || sound_engine="LINUX_ALSA"
-
- econf CXXFLAGS="${CXXFLAGS} -D__${sound_engine}__"
-}
diff --git a/media-sound/din/din-54.ebuild b/media-sound/din/din-54.ebuild
index 1ff40dd5f7d..a12ad9ed2cc 100644
--- a/media-sound/din/din-54.ebuild
+++ b/media-sound/din/din-54.ebuild
@@ -11,7 +11,7 @@ SRC_URI="https://archive.org/download/dinisnoise_source_code/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="amd64 x86"
IUSE="+alsa jack"
RDEPEND="
diff --git a/media-sound/dir2ogg/dir2ogg-0.13-r1.ebuild b/media-sound/dir2ogg/dir2ogg-0.13-r1.ebuild
index 0b4c50e8cdb..d6dc033a19f 100644
--- a/media-sound/dir2ogg/dir2ogg-0.13-r1.ebuild
+++ b/media-sound/dir2ogg/dir2ogg-0.13-r1.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{8..9} )
+
+PYTHON_COMPAT=( python3_{8..11} )
inherit python-single-r1
diff --git a/media-sound/drumstick/Manifest b/media-sound/drumstick/Manifest
index 84347e3f73d..f5a62012720 100644
--- a/media-sound/drumstick/Manifest
+++ b/media-sound/drumstick/Manifest
@@ -1,2 +1 @@
-DIST drumstick-2.6.0.tar.gz 1920439 BLAKE2B 755f252030626ec47359e48a4f8fdd007448dbd61ee41b9d09d3f5b83816bcb15f7555fe0855828c21623094a6845c974d62483bbaf2071dd8f21ed15a506d0b SHA512 68bf1875ce6622a6655c6bc3f768d3ea5b6754eff64b668235a24ab71a502204f34b0b5cf201d911929189a4dbcf1253c21e4388b5a71fdfd4fa5d83ad505326
DIST drumstick-2.6.1.tar.gz 1922869 BLAKE2B 5f1b9413c60d80ecb87f28f9a9eccd5cc418444664bdbd0fe9d47f698effc12956a3ddd2f45ae9e734486e94006883ed7264f8421a5989ce0b025ad85239e10b SHA512 ab858ee17aa957fe1c68935e2419798c50d4253b14dd0f31cafb46e087869986702c8a0d3ac1333d67b17618e7d5d75894aeb0e0f5bffb77762d0a56c242a811
diff --git a/media-sound/drumstick/drumstick-2.6.0.ebuild b/media-sound/drumstick/drumstick-2.6.0.ebuild
deleted file mode 100644
index 29329502f5d..00000000000
--- a/media-sound/drumstick/drumstick-2.6.0.ebuild
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit cmake xdg
-
-DESCRIPTION="Qt/C++ wrapper for ALSA sequencer"
-HOMEPAGE="https://drumstick.sourceforge.io/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-3+"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="doc fluidsynth network pulseaudio"
-
-RESTRICT="test"
-
-BDEPEND="
- dev-libs/libxslt
- dev-qt/linguist-tools:5
- virtual/pkgconfig
- x11-misc/shared-mime-info
- doc? (
- app-doc/doxygen[dot]
- app-text/docbook-xsl-stylesheets
- )
-"
-DEPEND="
- dev-qt/designer:5
- dev-qt/qtcore:5
- dev-qt/qtdbus:5
- dev-qt/qtgui:5
- dev-qt/qtsvg:5
- dev-qt/qtwidgets:5
- media-libs/alsa-lib
- fluidsynth? ( media-sound/fluidsynth )
- network? ( dev-qt/qtnetwork:5 )
- pulseaudio? ( media-sound/pulseaudio )
-"
-RDEPEND="${DEPEND}"
-
-DOCS=( AUTHORS ChangeLog NEWS readme.md TODO )
-
-src_configure() {
- local mycmakeargs=(
- -DBUILD_TESTING=OFF
- -DUSE_DBUS=ON
- -DUSE_FLUIDSYNTH=$(usex fluidsynth)
- -DUSE_NETWORK=$(usex network)
- -DUSE_PULSEAUDIO=$(usex pulseaudio)
- -DBUILD_DOCS=$(usex doc)
- )
- cmake_src_configure
-}
-
-src_compile() {
- cmake_src_compile
- use doc && cmake_src_compile doxygen
-}
-
-src_install() {
- use doc && local HTML_DOCS=( "${BUILD_DIR}"/doc/html/. )
- cmake_src_install
-}
diff --git a/media-sound/drumstick/drumstick-2.6.1.ebuild b/media-sound/drumstick/drumstick-2.6.1.ebuild
index ec49cc915a1..29329502f5d 100644
--- a/media-sound/drumstick/drumstick-2.6.1.ebuild
+++ b/media-sound/drumstick/drumstick-2.6.1.ebuild
@@ -11,7 +11,7 @@ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
LICENSE="GPL-3+"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="amd64 x86"
IUSE="doc fluidsynth network pulseaudio"
RESTRICT="test"
diff --git a/media-sound/easyeffects/Manifest b/media-sound/easyeffects/Manifest
index 365baa4f240..6ae12a111e4 100644
--- a/media-sound/easyeffects/Manifest
+++ b/media-sound/easyeffects/Manifest
@@ -1,2 +1,4 @@
DIST easyeffects-6.2.3.tar.gz 2621460 BLAKE2B fb73c635b10dec5808d046a4df63cdaaada1c3534f1e9275fdd4f28db52a9111a850367b564b5d008a1bdb7c7e55864e38cc1d50fc363b5614fb138bd0fe0cc1 SHA512 79babe59ef0c86d138b29a4c2dfaa1a937da9de8d7ae7cc40bee6ae5e011b6c43d6ff9554885ce116114943976d50c24c44c4e30775933b5ee8a2bf350d55525
DIST easyeffects-6.2.4.tar.gz 2648725 BLAKE2B 8d4f10f286ed4b3468ffa2e3b5331b9dfd9c266b0a6a35b373856be14c8465032c79ebad2826ff7ebb1a8db3d81a57fef398880fa7601282da672d5348dae817 SHA512 1c7a9fb95bab3fe039d96420d465d8dfa0d42bf3c04081c5b258f3f227923229f658d6e8152587bf38b26e0a3f3c73b5b89a1a8c9b42807b7e02b776f419e361
+DIST easyeffects-6.2.6.tar.gz 2743298 BLAKE2B 242faa7a819f7986a292bc587a841b130284e9770ff299af741a9f8df56807fd878a5c66a3323af09cd7672c403af725e8f6c3c5109f90a35868e09d37fce742 SHA512 0c93c6afdc337bd5fe60beab00475087eece250ac7014a8b5ac0e6cad9154b3ac22cfa61a44bbbaa99aff79d4706772e903a056c3719a58d9507772684d6f767
+DIST easyeffects-6.2.8.tar.gz 3063821 BLAKE2B d64952ff1e04f0013cb2548cc62d67f4013e9bd51dda2afe50170fc1ddbaabb967da5cb0b2cf6fde44cbdcf196b9656d19172595f6c527099a86b2dfc8ff34be SHA512 8a306308e783ed19fd5380a6b8d1e0ddba1400bca3447ddbf2954355f6d74229d0e750e5ce50b19c9ad1979ee88cda6ad4d1b2549eef7bb88cd29b6dc96dc33b
diff --git a/media-sound/easyeffects/easyeffects-6.2.4.ebuild b/media-sound/easyeffects/easyeffects-6.2.4.ebuild
index fe870ff42fa..cfdaafbd393 100644
--- a/media-sound/easyeffects/easyeffects-6.2.4.ebuild
+++ b/media-sound/easyeffects/easyeffects-6.2.4.ebuild
@@ -13,7 +13,7 @@ if [[ ${PV} == *9999 ]]; then
EGIT_REPO_URI="https://github.com/wwmm/easyeffects"
else
SRC_URI="https://github.com/wwmm/easyeffects/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+ KEYWORDS="amd64 ~arm ~arm64 ~ppc64 ~x86"
fi
LICENSE="GPL-3"
diff --git a/media-sound/easyeffects/easyeffects-6.2.6.ebuild b/media-sound/easyeffects/easyeffects-6.2.6.ebuild
new file mode 100644
index 00000000000..9250f1d82cc
--- /dev/null
+++ b/media-sound/easyeffects/easyeffects-6.2.6.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome2-utils flag-o-matic meson toolchain-funcs
+
+DESCRIPTION="Limiter, auto volume and many other plugins for PipeWire applications"
+HOMEPAGE="https://github.com/wwmm/easyeffects"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/wwmm/easyeffects"
+else
+ SRC_URI="https://github.com/wwmm/easyeffects/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="calf +doc mda-lv2 zamaudio"
+
+DEPEND="dev-cpp/nlohmann_json
+ dev-cpp/tbb
+ >=dev-libs/glib-2.56:2
+ dev-libs/libfmt
+ >=dev-libs/libsigc++-3.0.6:3
+ >=gui-libs/gtk-4.2.1:4
+ gui-libs/libadwaita:1
+ media-libs/libbs2b
+ >=media-libs/libebur128-1.2.0
+ media-libs/libsndfile
+ >=media-libs/lilv-0.22
+ >=media-libs/lv2-1.18.2
+ media-libs/rnnoise
+ media-libs/rubberband[ladspa]
+ media-libs/speexdsp
+ >=media-libs/zita-convolver-3.0.0
+ >=media-video/pipewire-0.3.41
+ sci-libs/fftw:3.0"
+RDEPEND="${DEPEND}
+ >=media-libs/lsp-plugins-1.1.24[lv2]
+ sys-apps/dbus
+ calf? ( >=media-plugins/calf-0.90.1[lv2] )
+ doc? ( gnome-extra/yelp )
+ mda-lv2? ( media-plugins/mda-lv2 )
+ zamaudio? ( media-plugins/zam-plugins )"
+# Only header files are used from libsamplerate so put it here rather than DEPEND
+# to avoid unnecessary cross-compilation.
+BDEPEND="dev-libs/appstream-glib
+ dev-util/desktop-file-utils
+ dev-util/itstool
+ media-libs/libsamplerate
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+pkg_pretend() {
+ if [[ ${MERGE_TYPE} != "binary" ]] ; then
+ if ! test-flag-CXX -std=c++20 ; then
+ die "${PN} requires degree of C++20 support only available since GCC 10 or Clang 10"
+ fi
+
+ if tc-is-gcc && [[ $(gcc-major-version) -lt 11 ]] ; then
+ die "Since version 6.2.5 ${PN} requires GCC 11 or newer to build (Bug #848072)"
+ fi
+ fi
+}
+
+pkg_postinst() {
+ gnome2_gconf_install
+ gnome2_schemas_update
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_gconf_uninstall
+ gnome2_schemas_update
+ xdg_icon_cache_update
+}
diff --git a/media-sound/easyeffects/easyeffects-6.2.8.ebuild b/media-sound/easyeffects/easyeffects-6.2.8.ebuild
new file mode 100644
index 00000000000..7df1501d43c
--- /dev/null
+++ b/media-sound/easyeffects/easyeffects-6.2.8.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome2-utils flag-o-matic meson toolchain-funcs
+
+DESCRIPTION="Limiter, auto volume and many other plugins for PipeWire applications"
+HOMEPAGE="https://github.com/wwmm/easyeffects"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/wwmm/easyeffects"
+else
+ SRC_URI="https://github.com/wwmm/easyeffects/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="calf +doc mda-lv2 zamaudio"
+
+COMMON="dev-cpp/nlohmann_json
+ dev-cpp/tbb
+ >=dev-libs/glib-2.56:2
+ dev-libs/libfmt
+ >=dev-libs/libsigc++-3.0.6:3
+ >=gui-libs/gtk-4.2.1:4
+ gui-libs/libadwaita:1
+ media-libs/libbs2b
+ >=media-libs/libebur128-1.2.0
+ media-libs/libsndfile
+ >=media-libs/lilv-0.22
+ >=media-libs/lv2-1.18.2
+ media-libs/rnnoise
+ media-libs/rubberband[ladspa]
+ media-libs/speexdsp
+ >=media-libs/zita-convolver-3.0.0
+ >=media-video/pipewire-0.3.41
+ sci-libs/fftw:3.0"
+# Only header files are used from libsamplerate
+DEPEND="${COMMON}
+ media-libs/libsamplerate"
+RDEPEND="${COMMON}
+ >=media-libs/lsp-plugins-1.1.24[lv2]
+ sys-apps/dbus
+ calf? ( >=media-plugins/calf-0.90.1[lv2] )
+ doc? ( gnome-extra/yelp )
+ mda-lv2? ( media-plugins/mda-lv2 )
+ zamaudio? ( media-plugins/zam-plugins )"
+BDEPEND="dev-libs/appstream-glib
+ dev-util/desktop-file-utils
+ dev-util/itstool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+pkg_pretend() {
+ if [[ ${MERGE_TYPE} != "binary" ]] ; then
+ if ! test-flag-CXX -std=c++20 ; then
+ die "${PN} requires degree of C++20 support only available since GCC 10 or Clang 10"
+ fi
+
+ if tc-is-gcc && [[ $(gcc-major-version) -lt 11 ]] ; then
+ die "Since version 6.2.5 ${PN} requires GCC 11 or newer to build (Bug #848072)"
+ fi
+ fi
+}
+
+pkg_postinst() {
+ gnome2_gconf_install
+ gnome2_schemas_update
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_gconf_uninstall
+ gnome2_schemas_update
+ xdg_icon_cache_update
+}
diff --git a/media-sound/easytag/easytag-2.4.3-r2.ebuild b/media-sound/easytag/easytag-2.4.3-r3.ebuild
index bfadc0488b1..98b5ca0d656 100644
--- a/media-sound/easytag/easytag-2.4.3-r2.ebuild
+++ b/media-sound/easytag/easytag-2.4.3-r3.ebuild
@@ -1,9 +1,8 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
-GNOME2_LA_PUNT="yes"
inherit gnome2
DESCRIPTION="GTK+ utility for editing MP2, MP3, MP4, FLAC, Ogg and other media tags"
@@ -12,13 +11,11 @@ HOMEPAGE="https://wiki.gnome.org/Apps/EasyTAG"
LICENSE="GPL-2 GPL-2+ LGPL-2 LGPL-2+ LGPL-2.1+"
SLOT="0"
KEYWORDS="~alpha amd64 ~arm ppc ppc64 ~riscv ~sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-solaris"
-
IUSE="flac mp3 mp4 nautilus opus speex test vorbis wavpack"
RESTRICT="!test? ( test )"
REQUIRED_USE="
opus? ( vorbis )
- speex? ( vorbis )
-"
+ speex? ( vorbis )"
RDEPEND="
>=dev-libs/glib-2.38:2
@@ -40,9 +37,9 @@ RDEPEND="
>=media-libs/libogg-1.3.1
>=media-libs/libvorbis-1.3.4
)
- wavpack? ( >=media-sound/wavpack-4.70 )
-"
-DEPEND="${RDEPEND}
+ wavpack? ( >=media-sound/wavpack-4.70 )"
+DEPEND="${RDEPEND}"
+BDEPEND="
app-text/docbook-xml-dtd:4.4
app-text/yelp-tools
dev-util/glib-utils
@@ -54,10 +51,9 @@ DEPEND="${RDEPEND}
test? (
dev-libs/appstream-glib
>=dev-util/desktop-file-utils-0.22
- )
-"
+ )"
-PATCHES=( "${FILESDIR}/${P}-ogg-corruption.patch" )
+PATCHES=( "${FILESDIR}"/${P}-ogg-corruption.patch )
src_configure() {
gnome2_src_configure \
diff --git a/media-sound/ecasound/ecasound-2.9.3-r1.ebuild b/media-sound/ecasound/ecasound-2.9.3-r1.ebuild
new file mode 100644
index 00000000000..42ec0f087a4
--- /dev/null
+++ b/media-sound/ecasound/ecasound-2.9.3-r1.ebuild
@@ -0,0 +1,97 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit autotools python-single-r1
+
+DESCRIPTION="a package for multitrack audio processing"
+HOMEPAGE="https://ecasound.seul.org/ecasound/"
+SRC_URI="https://ecasound.seul.org/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="1"
+KEYWORDS="~amd64 ~ppc x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="alsa audiofile debug doc jack libsamplerate lv2 mikmod ncurses oil osc oss
+python ruby sndfile static-libs test"
+RESTRICT="!test? ( test )"
+REQUIRED_USE="test? ( lv2 )
+ python? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="sys-libs/readline:0=
+ alsa? ( media-libs/alsa-lib:= )
+ audiofile? ( media-libs/audiofile:= )
+ jack? ( virtual/jack:= )
+ libsamplerate? ( media-libs/libsamplerate:= )
+ lv2? ( media-libs/lilv:= )
+ media-libs/ladspa-sdk
+ mikmod? ( media-libs/libmikmod:0= )
+ ncurses? ( sys-libs/ncurses:0= )
+ oil? ( dev-libs/liboil:= )
+ osc? ( media-libs/liblo:= )
+ python? ( ${PYTHON_DEPS} )
+ ruby? ( dev-lang/ruby:* )
+ sndfile? ( media-libs/libsndfile:= )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+BDEPEND="sys-apps/ed"
+PATCHES=(
+ "${FILESDIR}"/${P}-ldflags.patch
+ "${FILESDIR}"/${PN}-2.9.1-tinfo.patch
+)
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+
+ # https://bugs.gentoo.org/787620
+ printf '%s\n' H '/^EXTRACXXFLAGS="-std=c++98"$/s/98/11/' w q |
+ ed -s configure.ac || die "Couldn't patch EXTRACXXFLAGS in configure.ac"
+
+ eautoreconf
+}
+
+src_configure() {
+ local pyconf=()
+
+ if use python ; then
+ pyconf=( "--with-python-modules=${EPREFIX}/usr/$(get_libdir)/${EPYTHON}" )
+ fi
+
+ econf \
+ --disable-arts \
+ --enable-shared \
+ --enable-sys-readline \
+ --with-largefile \
+ $(use_enable alsa) \
+ $(use_enable audiofile) \
+ $(use_enable debug) \
+ $(use_enable jack) \
+ $(use_enable libsamplerate) \
+ $(use_enable lv2 liblilv) \
+ $(use_enable ncurses) \
+ $(use_enable oil liboil) \
+ $(use_enable osc liblo) \
+ $(use_enable oss) \
+ $(use_enable python pyecasound) \
+ $(use_enable ruby rubyecasound) \
+ $(use_enable sndfile) \
+ $(use_enable static-libs static) \
+ "${pyconf[@]}"
+}
+
+src_install() {
+ default
+ use python && python_optimize
+
+ if use doc ; then
+ dodoc Documentation/*.html
+ dodoc Documentation/programmers_guide/ecasound_programmers_guide.txt
+ fi
+
+ find "${ED}" -name "*.la" -delete
+}
diff --git a/media-sound/elisa/Manifest b/media-sound/elisa/Manifest
index 62d0af05736..8947e3cd98f 100644
--- a/media-sound/elisa/Manifest
+++ b/media-sound/elisa/Manifest
@@ -1,2 +1 @@
-DIST elisa-21.12.3.tar.xz 1748236 BLAKE2B 5e3ea6a5cd1f7bb9aa7a99e33ddfe97f7f239f3594d8e7684639861966b16e812ba9f46cbc5a6c9ceb5c19acd75c3bb56567875dacb01ebade88a59ec81cb865 SHA512 f2ef0c2669d171e42e55460d464f019751a4fdea174cf8224c90bf6002d7d181e101cac46c8fb3e8e13bfac0b0f79bd16fae3b55f02808a4172ba994f8ac667b
-DIST elisa-22.04.1.tar.xz 1747180 BLAKE2B 9d74ab4346126e615809dbddb81c9d69601674e3dac7fbd7cb5d53fa77b4577ad5182984189e1a7eb452474c24b4add6f71f47d807c681f994835c7ecef53ef2 SHA512 f31bd4540bc224bdb0225735d359e6415be5f5ec094a32c29120fd81bfbf1a887d22c3857635bb4bc709b130ca934756ea14d9bcfb63f01777118a84f5016a43
+DIST elisa-22.04.3.tar.xz 1747400 BLAKE2B c4f3a91f1f32e8735221961291c9a1fe998dadd648bced18f8f7c8e03f973397feda9d9d143901f26f28eb3e808468f1c780e646343858706be30609521f47e8 SHA512 ac1ba9b06eb263f409e798001093cb0ca0b56df565a38a69c78f61bd8820bdd0f3aa53510a0ef0efcab56bea001798ef4c028d48f425499942369e5d5b718040
diff --git a/media-sound/elisa/elisa-22.04.1.ebuild b/media-sound/elisa/elisa-22.04.1.ebuild
deleted file mode 100644
index ad63da6072e..00000000000
--- a/media-sound/elisa/elisa-22.04.1.ebuild
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-ECM_HANDBOOK="optional"
-ECM_TEST="forceoptional"
-KDE_GEAR="true"
-KFMIN=5.92.0
-QTMIN=5.15.3
-inherit ecm kde.org
-
-DESCRIPTION="Simple music player by KDE"
-HOMEPAGE="https://elisa.kde.org/ https://apps.kde.org/elisa/"
-
-LICENSE="LGPL-3+"
-SLOT="5"
-KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
-IUSE="mpris semantic-desktop +vlc"
-
-RESTRICT="test"
-
-BDEPEND="sys-devel/gettext"
-DEPEND="
- >=dev-qt/qtdeclarative-${QTMIN}:5[widgets]
- >=dev-qt/qtgui-${QTMIN}:5
- >=dev-qt/qtmultimedia-${QTMIN}:5
- >=dev-qt/qtsql-${QTMIN}:5
- >=dev-qt/qtwidgets-${QTMIN}:5
- >=kde-frameworks/kconfig-${KFMIN}:5
- >=kde-frameworks/kconfigwidgets-${KFMIN}:5
- >=kde-frameworks/kcoreaddons-${KFMIN}:5
- >=kde-frameworks/kcrash-${KFMIN}:5
- >=kde-frameworks/kdeclarative-${KFMIN}:5
- >=kde-frameworks/kfilemetadata-${KFMIN}:5[taglib]
- >=kde-frameworks/ki18n-${KFMIN}:5
- >=kde-frameworks/kio-${KFMIN}:5
- >=kde-frameworks/kirigami-${KFMIN}:5
- >=kde-frameworks/kitemviews-${KFMIN}:5
- >=kde-frameworks/kxmlgui-${KFMIN}:5
- mpris? (
- >=dev-qt/qtdbus-${QTMIN}:5
- >=kde-frameworks/kdbusaddons-${KFMIN}:5
- )
- semantic-desktop? ( >=kde-frameworks/baloo-${KFMIN}:5 )
- vlc? ( media-video/vlc:= )
- !vlc? ( >=dev-qt/qtmultimedia-${QTMIN}:5[gstreamer] )
-"
-RDEPEND="${DEPEND}
- >=dev-qt/qtgraphicaleffects-${QTMIN}:5
- >=dev-qt/qtquickcontrols-${QTMIN}:5
- >=dev-qt/qtquickcontrols2-${QTMIN}:5
-"
-
-src_configure() {
- local mycmakeargs=(
- $(cmake_use_find_package mpris KF5DBusAddons)
- $(cmake_use_find_package semantic-desktop KF5Baloo)
- $(cmake_use_find_package vlc LIBVLC)
- )
-
- ecm_src_configure
-}
diff --git a/media-sound/elisa/elisa-21.12.3.ebuild b/media-sound/elisa/elisa-22.04.3.ebuild
index 40bda819edd..edc59b55b2c 100644
--- a/media-sound/elisa/elisa-21.12.3.ebuild
+++ b/media-sound/elisa/elisa-22.04.3.ebuild
@@ -6,9 +6,9 @@ EAPI=8
ECM_HANDBOOK="optional"
ECM_TEST="forceoptional"
KDE_GEAR="true"
-KFMIN=5.88.0
-QTMIN=5.15.2
-inherit ecm kde.org
+KFMIN=5.92.0
+QTMIN=5.15.4
+inherit ecm gear.kde.org
DESCRIPTION="Simple music player by KDE"
HOMEPAGE="https://elisa.kde.org/ https://apps.kde.org/elisa/"
diff --git a/media-sound/exaile/Manifest b/media-sound/exaile/Manifest
index 27e78fd8afd..544d8b19db0 100644
--- a/media-sound/exaile/Manifest
+++ b/media-sound/exaile/Manifest
@@ -1 +1,2 @@
DIST exaile-4.1.1.tar.gz 3641073 BLAKE2B 34222ddba782dd51897c017d7a77da9a796e45dad69983f934e76cc559c2e52f2173ee418004943ca087fd894439bc42a6eff2a5d6146e6189ec1cd478f5d08b SHA512 babf37253054fbeb6dad33aedafe969201860d4f35222d577343256730be943682c1a5f2f7cec7c574695624cb2b7abbdff4e6eaada848d22fea073c2c44bd23
+DIST exaile-4.1.2.tar.gz 3708188 BLAKE2B 859d77bac62df0843291fdc0de4888079c8f103da3cdf3417d0cd5ba67cf5199a8a1e89d20403efbc6793dfcd7b8333708df74ff535e0912fb02502a13702a0a SHA512 7711f9e062088b02362bbd404f7c61a0f1c128e29e42ce657dc092cac351641f6000846c9da843866bf28ccbd68cf1b07731ba1c9854d52b33c0448e87d0e93b
diff --git a/media-sound/exaile/exaile-4.1.1.ebuild b/media-sound/exaile/exaile-4.1.1-r1.ebuild
index de0775df2e3..adfea4458e8 100644
--- a/media-sound/exaile/exaile-4.1.1.ebuild
+++ b/media-sound/exaile/exaile-4.1.1-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_{8..9} )
+PYTHON_COMPAT=( python3_{8..10} )
inherit python-single-r1 xdg
if [[ ${PV} == "9999" ]]; then
@@ -11,7 +11,7 @@ if [[ ${PV} == "9999" ]]; then
EGIT_REPO_URI="https://github.com/exaile/exaile.git"
else
SRC_URI="https://github.com/${PN}/${PN}/archive/${PV/_/-}/${PN}-${PV/_/}.tar.gz"
- KEYWORDS="~amd64 ~x86"
+ KEYWORDS="amd64 ~x86"
S="${WORKDIR}/${PN}-${PV/_/-}"
fi
@@ -30,18 +30,18 @@ BDEPEND="
)
"
RDEPEND="${PYTHON_DEPS}
- >=media-libs/gst-plugins-base-1.6:1.0
- >=media-libs/gst-plugins-good-1.4:1.0
+ media-libs/gst-plugins-base:1.0
+ media-libs/gst-plugins-good:1.0
media-plugins/gst-plugins-meta:1.0
- >=x11-libs/gtk+-3.10:3[introspection]
- libnotify? ( >=x11-libs/libnotify-0.7[introspection] )
+ x11-libs/gtk+:3[introspection]
+ libnotify? ( x11-libs/libnotify[introspection] )
$(python_gen_cond_dep '
dev-python/bsddb3[${PYTHON_USEDEP}]
dev-python/dbus-python[${PYTHON_USEDEP}]
dev-python/gst-python:1.0[${PYTHON_USEDEP}]
dev-python/pycairo[${PYTHON_USEDEP}]
- >=dev-python/pygobject-3.13.2:3[${PYTHON_USEDEP}]
- >=media-libs/mutagen-1.10[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ media-libs/mutagen[${PYTHON_USEDEP}]
scrobbler? ( dev-python/pylast[${PYTHON_USEDEP}] )
')
"
diff --git a/media-sound/exaile/exaile-4.1.2.ebuild b/media-sound/exaile/exaile-4.1.2.ebuild
new file mode 100644
index 00000000000..5fd5b6a75bc
--- /dev/null
+++ b/media-sound/exaile/exaile-4.1.2.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit python-single-r1 xdg
+
+if [[ ${PV} == "9999" ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/exaile/exaile.git"
+else
+ SRC_URI="https://github.com/${PN}/${PN}/archive/${PV/_/-}/${PN}-${PV/_/}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}/${PN}-${PV/_/-}"
+fi
+
+DESCRIPTION="GTK+ based media player aiming to be similar to Amarok"
+HOMEPAGE="https://www.exaile.org/"
+LICENSE="GPL-2 GPL-3"
+SLOT="0"
+# IUSE+=cddb if have dev-python/cddb-py
+IUSE="libnotify nls scrobbler"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+BDEPEND="
+ nls? (
+ dev-util/intltool
+ sys-devel/gettext
+ )
+"
+RDEPEND="${PYTHON_DEPS}
+ media-libs/gst-plugins-base:1.0
+ media-libs/gst-plugins-good:1.0
+ media-plugins/gst-plugins-meta:1.0
+ x11-libs/gtk+:3[introspection]
+ libnotify? ( x11-libs/libnotify[introspection] )
+ $(python_gen_cond_dep '
+ dev-python/bsddb3[${PYTHON_USEDEP}]
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/gst-python:1.0[${PYTHON_USEDEP}]
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ media-libs/mutagen[${PYTHON_USEDEP}]
+ scrobbler? ( dev-python/pylast[${PYTHON_USEDEP}] )
+ ')
+"
+
+RESTRICT="test" #315589
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+}
+
+src_compile() {
+ use nls && emake locale
+}
+
+src_install() {
+ emake \
+ PREFIX=/usr \
+ LIBINSTALLDIR=/usr/$(get_libdir) \
+ DESTDIR="${D}" \
+ install$(use nls || echo _no_locale)
+
+ python_optimize "${D}/usr/$(get_libdir)/${PN}"
+ python_optimize "${D}/usr/share/${PN}"
+}
diff --git a/media-sound/exaile/exaile-9999.ebuild b/media-sound/exaile/exaile-9999.ebuild
index 93bda21f7a3..5fd5b6a75bc 100644
--- a/media-sound/exaile/exaile-9999.ebuild
+++ b/media-sound/exaile/exaile-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_{8..9} )
+PYTHON_COMPAT=( python3_{8..10} )
inherit python-single-r1 xdg
if [[ ${PV} == "9999" ]]; then
@@ -30,28 +30,24 @@ BDEPEND="
)
"
RDEPEND="${PYTHON_DEPS}
- >=media-libs/gst-plugins-base-1.6:1.0
- >=media-libs/gst-plugins-good-1.4:1.0
+ media-libs/gst-plugins-base:1.0
+ media-libs/gst-plugins-good:1.0
media-plugins/gst-plugins-meta:1.0
- >=x11-libs/gtk+-3.10:3[introspection]
- libnotify? ( >=x11-libs/libnotify-0.7[introspection] )
+ x11-libs/gtk+:3[introspection]
+ libnotify? ( x11-libs/libnotify[introspection] )
$(python_gen_cond_dep '
dev-python/bsddb3[${PYTHON_USEDEP}]
dev-python/dbus-python[${PYTHON_USEDEP}]
dev-python/gst-python:1.0[${PYTHON_USEDEP}]
dev-python/pycairo[${PYTHON_USEDEP}]
- >=dev-python/pygobject-3.13.2:3[${PYTHON_USEDEP}]
- >=media-libs/mutagen-1.10[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ media-libs/mutagen[${PYTHON_USEDEP}]
scrobbler? ( dev-python/pylast[${PYTHON_USEDEP}] )
')
"
RESTRICT="test" #315589
-PATCHES=(
- "${FILESDIR}/${PN}-4.1.1-metainfo.patch"
-)
-
pkg_setup() {
python-single-r1_pkg_setup
}
diff --git a/media-sound/ezstream/ezstream-0.6.0-r1.ebuild b/media-sound/ezstream/ezstream-0.6.0-r2.ebuild
index 665c2a35883..d9cb6fb0988 100644
--- a/media-sound/ezstream/ezstream-0.6.0-r1.ebuild
+++ b/media-sound/ezstream/ezstream-0.6.0-r2.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
DESCRIPTION="A command line source client for Icecast media streaming servers"
HOMEPAGE="https://www.icecast.org/ezstream/"
@@ -12,19 +12,20 @@ SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
IUSE="taglib"
-COMMON_DEPEND="dev-libs/libxml2
+DEPEND="
+ dev-libs/libxml2
>=media-libs/libshout-2.2
!taglib? ( media-libs/libvorbis )
taglib? ( media-libs/taglib )"
-RDEPEND="${COMMON_DEPEND}
+RDEPEND="
+ ${DEPEND}
net-misc/icecast"
-DEPEND="${COMMON_DEPEND}
- virtual/pkgconfig"
+BDEPEND="virtual/pkgconfig"
src_configure() {
econf \
--enable-examplesdir='$(docdir)/examples' \
- $(use_with taglib taglib "/usr")
+ $(use_with taglib taglib "${ESYSROOT}"/usr)
}
src_install() {
@@ -33,5 +34,5 @@ src_install() {
newinitd "${FILESDIR}"/${PN}.initd ${PN}
newconfd "${FILESDIR}"/${PN}.confd ${PN}
- rm -f "${D%/}"/usr/share/doc/${PF}/COPYING
+ rm -f "${ED}"/usr/share/doc/${PF}/COPYING || die
}
diff --git a/media-sound/flac-image/flac-image-1.00.ebuild b/media-sound/flac-image/flac-image-1.00-r1.ebuild
index 78ea6acddc7..2d8b79560fd 100644
--- a/media-sound/flac-image/flac-image-1.00.ebuild
+++ b/media-sound/flac-image/flac-image-1.00-r1.ebuild
@@ -1,35 +1,33 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
inherit toolchain-funcs
DESCRIPTION="Utility for adding image files (e.g. album cover art) to metadata of FLAC files"
HOMEPAGE="http://www.singingtree.com/software/"
-SRC_URI="http://www.singingtree.com/software/${PN}.tar.gz -> ${P}.tar.gz"
# FIXME: no version in tarball, but also no updates for a long time. So it's ok.
+SRC_URI="http://www.singingtree.com/software/${PN}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
DEPEND="media-libs/flac"
RDEPEND="${DEPEND}"
-S=${WORKDIR}
-
PATCHES=(
"${FILESDIR}"/${PN}-1.00-add-missing-string-include.patch
"${FILESDIR}"/${PN}-1.00-fix-build-system.patch
)
src_configure() {
+ tc-export CC
+
# remove pre-compiled binary
rm -f "${PN}" || die
-
- tc-export CC
}
src_install() {
diff --git a/media-sound/flacon/Manifest b/media-sound/flacon/Manifest
index a862fd500a7..713855a106c 100644
--- a/media-sound/flacon/Manifest
+++ b/media-sound/flacon/Manifest
@@ -1,2 +1,4 @@
DIST flacon-5.5.1.tar.gz 2336502 BLAKE2B 524fe5fa28126f56452515ca1ce1572343dad8b06c28fc8e3a22a11e9ad8f3a51a25b3c19ddd29a7e3c658f1d7fb3316a2554a12a4ba3dd22370fc1394d38022 SHA512 36900b011135b61cf3cc1f05d94f852fc7e127972f3fed09e0fb7e66fec944ed1c3bfc61307494aff87c2fe24e16479605043a79e0634bc23940d01fc337c6c1
DIST flacon-8.2.0.tar.gz 3757221 BLAKE2B dff0dc849c326a53ad167efea3106ca2d057121081822a821f2daa4cc2140a858960f1b4cdc2935f3e569aac25c25ceece2d171056788b9f541355c540457550 SHA512 9799c1a27426a2f67d782f15a3a1d210c5dc61b00b30b9c4143047a243f2d46cb0eb651c18919fa1ac2a8fdc2f54c83ec2e0b46a00254c908230e7ffb34965bc
+DIST flacon-9.0.0.tar.gz 3762192 BLAKE2B abebc21e31fee43f4970b6e56724bfb0b6f2cc7d33e2539def102b329f1228886f7f0fcbb20a2e100a7ba77f6f45bf5ac032151ab0f830676dbf4ce24da0ce3f SHA512 3780f94a4c6c6812eb0a0efd4e677926d8cc53c15f692701cd20df0441f551d4639b632c08a36146873ad11cdb9cdaa4e726845eb05ae15ecc29a1dac250a928
+DIST flacon-9.1.0.tar.gz 3769110 BLAKE2B 9e0c4aaef3f6019a8c8196a204e8281ca4250df441ea14127d9347f26557091e87019388bd2942afc39e45a7864d653e2ae887f665ce190f18e646448c3f8e3e SHA512 be35c61e082be7d05bebee5f99192201f91e90f3a80827ac5808e6798f7ed0ada28ab7c2456702c443be51356ec192cd059408c2c3feb5b48b5bab048d0efb00
diff --git a/media-sound/flacon/files/flacon-9.0.0-no-man-compress.patch b/media-sound/flacon/files/flacon-9.0.0-no-man-compress.patch
new file mode 100644
index 00000000000..6ceff9bda27
--- /dev/null
+++ b/media-sound/flacon/files/flacon-9.0.0-no-man-compress.patch
@@ -0,0 +1,21 @@
+diff --git a/CMakeLists.txt.oirg b/CMakeLists.txt
+index f143d91..fd16a9b 100644
+--- a/CMakeLists.txt.oirg
++++ b/CMakeLists.txt
+@@ -302,14 +302,14 @@ if(${CMAKE_SYSTEM_NAME} STREQUAL "Darwin")
+ set_target_properties(${PROJECT_NAME} PROPERTIES OUTPUT_NAME "Flacon")
+ install(TARGETS ${PROJECT_NAME} RUNTIME DESTINATION Flacon.app/Contents/MacOS)
+ install(FILES ${QM_FILES} DESTINATION Flacon.app/Contents/translations)
+- install(FILES ${CMAKE_CURRENT_BINARY_DIR}/flacon.1.gz DESTINATION Flacon.app/Contents/Resources)
++ install(FILES ${CMAKE_CURRENT_BINARY_DIR}/flacon.1 DESTINATION Flacon.app/Contents/Resources)
+ install(FILES ${CMAKE_CURRENT_BINARY_DIR}/Info.plist DESTINATION Flacon.app/Contents)
+ install(FILES images/mainicon/Flacon.icns DESTINATION Flacon.app/Contents/Resources)
+
+ else()
+ install(TARGETS ${PROJECT_NAME} RUNTIME DESTINATION bin)
+ install(FILES ${QM_FILES} DESTINATION ${TRANSLATIONS_DIR})
+- install(FILES ${CMAKE_CURRENT_BINARY_DIR}/flacon.1.gz DESTINATION share/man/man1)
++ install(FILES ${CMAKE_CURRENT_BINARY_DIR}/flacon.1 DESTINATION share/man/man1)
+
+ install(FILES ${CMAKE_CURRENT_BINARY_DIR}/${PROJECT_NAME}.desktop DESTINATION "share/applications")
+ install(FILES ${CMAKE_CURRENT_BINARY_DIR}/com.github.Flacon.metainfo.xml DESTINATION "share/metainfo")
diff --git a/media-sound/flacon/flacon-8.2.0.ebuild b/media-sound/flacon/flacon-8.2.0.ebuild
index c0da6cdb1ab..2249a34996f 100644
--- a/media-sound/flacon/flacon-8.2.0.ebuild
+++ b/media-sound/flacon/flacon-8.2.0.ebuild
@@ -13,7 +13,7 @@ SRC_URI="https://github.com/flacon/flacon/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="LGPL-2.1+"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="amd64 x86"
IUSE="test"
BDEPEND="
diff --git a/media-sound/flacon/flacon-9.0.0.ebuild b/media-sound/flacon/flacon-9.0.0.ebuild
new file mode 100644
index 00000000000..6de27bcb88a
--- /dev/null
+++ b/media-sound/flacon/flacon-9.0.0.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# Tests require lots of disk space
+CHECKREQS_DISK_BUILD=10G
+inherit check-reqs cmake optfeature virtualx xdg-utils
+
+DESCRIPTION="Extracts audio tracks from an audio CD image to separate tracks"
+HOMEPAGE="https://flacon.github.io/"
+SRC_URI="https://github.com/flacon/flacon/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+BDEPEND="
+ dev-qt/linguist-tools:5
+ virtual/pkgconfig
+"
+RDEPEND="
+ app-i18n/uchardet
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtwidgets:5
+ media-libs/taglib
+"
+DEPEND="${RDEPEND}
+ dev-qt/qtconcurrent:5
+ test? (
+ dev-qt/qttest:5
+ media-libs/flac
+ media-sound/mac
+ media-sound/shntool
+ media-sound/ttaenc
+ media-sound/wavpack
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-9.0.0-no-man-compress.patch
+)
+
+RESTRICT="!test? ( test )"
+
+pkg_pretend() {
+ use test && check-reqs_pkg_pretend
+}
+
+pkg_setup() {
+ use test && check-reqs_pkg_setup
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TESTS="$(usex test)"
+ )
+ cmake_src_configure
+}
+
+src_test() {
+ virtx "${BUILD_DIR}/tests/${PN}_test" || die
+}
+
+pkg_postinst() {
+ optfeature_header "${PN} optionally supports formats listed below."
+ optfeature 'FLAC input and output support' media-libs/flac
+ optfeature 'WavPack input and output support' media-sound/wavpack
+ optfeature 'APE input support' media-sound/mac
+ optfeature 'ALAC output support' media-sound/alac_decoder
+ optfeature 'TTA input support' media-sound/ttaenc
+ optfeature 'AAC output support' media-libs/faac
+ optfeature 'MP3 output support' media-sound/lame
+ optfeature 'Vorbis output support' media-sound/vorbis-tools
+ optfeature 'MP3 Replay Gain support' media-sound/mp3gain
+ optfeature 'Vorbis Replay Gain support' media-sound/vorbisgain
+
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+}
diff --git a/media-sound/flacon/flacon-9.1.0.ebuild b/media-sound/flacon/flacon-9.1.0.ebuild
new file mode 100644
index 00000000000..6de27bcb88a
--- /dev/null
+++ b/media-sound/flacon/flacon-9.1.0.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# Tests require lots of disk space
+CHECKREQS_DISK_BUILD=10G
+inherit check-reqs cmake optfeature virtualx xdg-utils
+
+DESCRIPTION="Extracts audio tracks from an audio CD image to separate tracks"
+HOMEPAGE="https://flacon.github.io/"
+SRC_URI="https://github.com/flacon/flacon/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+BDEPEND="
+ dev-qt/linguist-tools:5
+ virtual/pkgconfig
+"
+RDEPEND="
+ app-i18n/uchardet
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtwidgets:5
+ media-libs/taglib
+"
+DEPEND="${RDEPEND}
+ dev-qt/qtconcurrent:5
+ test? (
+ dev-qt/qttest:5
+ media-libs/flac
+ media-sound/mac
+ media-sound/shntool
+ media-sound/ttaenc
+ media-sound/wavpack
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-9.0.0-no-man-compress.patch
+)
+
+RESTRICT="!test? ( test )"
+
+pkg_pretend() {
+ use test && check-reqs_pkg_pretend
+}
+
+pkg_setup() {
+ use test && check-reqs_pkg_setup
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TESTS="$(usex test)"
+ )
+ cmake_src_configure
+}
+
+src_test() {
+ virtx "${BUILD_DIR}/tests/${PN}_test" || die
+}
+
+pkg_postinst() {
+ optfeature_header "${PN} optionally supports formats listed below."
+ optfeature 'FLAC input and output support' media-libs/flac
+ optfeature 'WavPack input and output support' media-sound/wavpack
+ optfeature 'APE input support' media-sound/mac
+ optfeature 'ALAC output support' media-sound/alac_decoder
+ optfeature 'TTA input support' media-sound/ttaenc
+ optfeature 'AAC output support' media-libs/faac
+ optfeature 'MP3 output support' media-sound/lame
+ optfeature 'Vorbis output support' media-sound/vorbis-tools
+ optfeature 'MP3 Replay Gain support' media-sound/mp3gain
+ optfeature 'Vorbis Replay Gain support' media-sound/vorbisgain
+
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+}
diff --git a/media-sound/flacon/metadata.xml b/media-sound/flacon/metadata.xml
index 39b7db36d10..0c5a1c0fb13 100644
--- a/media-sound/flacon/metadata.xml
+++ b/media-sound/flacon/metadata.xml
@@ -1,7 +1,14 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <!-- maintainer-needed -->
+ <maintainer type="person" proxied="yes">
+ <email>rndxelement@protonmail.com</email>
+ <name>Philipp Rösner</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
<upstream>
<remote-id type="github">flacon/flacon</remote-id>
</upstream>
diff --git a/media-sound/fluidsynth/Manifest b/media-sound/fluidsynth/Manifest
index bde550059e4..b9e264166bb 100644
--- a/media-sound/fluidsynth/Manifest
+++ b/media-sound/fluidsynth/Manifest
@@ -1,2 +1 @@
-DIST fluidsynth-2.2.6.tar.gz 1749202 BLAKE2B 5296d48809a457770a968fb9ae20ae4091bbae11d6fbf8a11f75e44de1ca9fa1c121e925e61f25ab1016907ced73364ff632ffa3e7edfa9d15019bf3f3e0bb3c SHA512 e4958c409e057fe6e09a0aa86cc0d7c939aa883de479aa90c43f19faa4d0c3a0f6aca7242fad11ec7a7776cb7e2e602c953c6249fc94b9f04425101584ae3e6c
-DIST fluidsynth-2.2.7.tar.gz 1748897 BLAKE2B fd53603947ddf5a76676cfc3d77b1d904146ec7c30ab6e54a2c32cae0e76ec4b66397506072cac277febdd1b799801d5b13c7b37cc0ea4a545fae26077a1d881 SHA512 62709f96fa07bbafb9b907438da7376abdf1a4e679cd2b105c5bca257f1ff62c18bd4c646ef2ccba64ca5273604da996fb2caaf61eeee44686bf45fef1ed83a7
+DIST fluidsynth-2.2.8.tar.gz 1751615 BLAKE2B 7eaee4cc1c2f49e464cda2852890ec8e96bd86c258a39246ec5c84ea3e57c9869d1e88963daecc3fa8957df1d55ff6c6633a4900de3d6fc0a1adf830865adda0 SHA512 8173f2d368a214cf1eb7faae2f6326db43fb094ec9c83e652f953290c3f29c34ebd0b92cbb439bea8d814d3a7e4f9dc0c18c648df1d414989d5d8b4700c79535
diff --git a/media-sound/fluidsynth/fluidsynth-2.2.7.ebuild b/media-sound/fluidsynth/fluidsynth-2.2.7.ebuild
deleted file mode 100644
index 51908c54613..00000000000
--- a/media-sound/fluidsynth/fluidsynth-2.2.7.ebuild
+++ /dev/null
@@ -1,120 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-CMAKE_ECLASS=cmake
-inherit cmake-multilib systemd toolchain-funcs
-
-DESCRIPTION="Software real-time synthesizer based on the Soundfont 2 specifications"
-HOMEPAGE="https://www.fluidsynth.org"
-SRC_URI="https://github.com/FluidSynth/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="LGPL-2.1+"
-SLOT="0/3"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86"
-IUSE="alsa dbus debug examples ipv6 jack ladspa lash network oss portaudio pulseaudio +readline sdl +sndfile systemd threads"
-
-BDEPEND="
- virtual/pkgconfig
-"
-DEPEND="
- dev-libs/glib:2[${MULTILIB_USEDEP}]
- alsa? (
- media-libs/alsa-lib[${MULTILIB_USEDEP}]
- lash? ( media-sound/lash[${MULTILIB_USEDEP}] )
- )
- dbus? ( sys-apps/dbus[${MULTILIB_USEDEP}] )
- jack? ( virtual/jack[${MULTILIB_USEDEP}] )
- ladspa? (
- media-libs/ladspa-sdk[${MULTILIB_USEDEP}]
- media-plugins/cmt-plugins[${MULTILIB_USEDEP}]
- )
- portaudio? ( media-libs/portaudio[${MULTILIB_USEDEP}] )
- pulseaudio? ( media-sound/pulseaudio[${MULTILIB_USEDEP}] )
- readline? ( sys-libs/readline:0=[${MULTILIB_USEDEP}] )
- sdl? ( media-libs/libsdl2[${MULTILIB_USEDEP}] )
- sndfile? ( media-libs/libsndfile[${MULTILIB_USEDEP}] )
-"
-RDEPEND="${DEPEND}"
-
-DOCS=( AUTHORS ChangeLog README.md THANKS TODO doc/fluidsynth-v20-devdoc.txt )
-
-src_configure() {
- local mycmakeargs=(
- -DCMAKE_C_COMPILER="$(tc-getCC)"
- -Denable-alsa=$(usex alsa)
- -Denable-aufile=ON
- -Denable-dbus=$(usex dbus)
- -Denable-debug=$(usex debug)
- -Denable-dsound=OFF # Windows
- -Denable-floats=OFF # loat instead of double for DSP samples
- -Denable-fpe-check=$(usex debug)
- -Denable-ipv6=$(usex ipv6)
- -Denable-jack=$(usex jack)
- -Denable-ladspa=$(usex ladspa)
- -Denable-libinstpatch=ON # https://github.com/swami/libinstpatch
- -Denable-midishare=OFF # http://midishare.sourceforge.net/
- -Denable-network=$(usex network)
- -Denable-opensles=OFF
- -Denable-oboe=OFF # requires OpenSLES and/or AAudio
- -Denable-oss=$(usex oss)
- -Denable-libsndfile=$(usex sndfile)
- -Denable-pkgconfig=ON
- -Denable-portaudio=$(usex portaudio)
- -Denable-profiling=$(usex debug)
- -Denable-pulseaudio=$(usex pulseaudio)
- -Denable-readline=$(usex readline)
- -Denable-sdl2=$(usex sdl)
- -Denable-systemd=$(usex systemd)
- -Denable-threads=$(usex threads)
- -Denable-trap-on-fpe=$(usex debug)
- -Denable-ubsan=OFF # compile and link against UBSan (for debugging fluidsynth internals)
- -Denable-waveout=OFF # Windows
- -Denable-winmidi=OFF # Windows
- )
-
- if use alsa; then
- mycmakeargs+=( -Denable-lash=$(usex lash) )
- else
- mycmakeargs+=( -Denable-lash=OFF )
- fi
-
- if use systemd; then
- mycmakeargs+=( -DFLUID_DAEMON_ENV_FILE="/etc/fluidsynth.conf" )
- fi
-
- cmake-multilib_src_configure
-}
-
-install_systemd_files() {
- if multilib_is_native_abi; then
- systemd_dounit "${BUILD_DIR}/fluidsynth.service"
- insinto /etc
- doins "${BUILD_DIR}/fluidsynth.conf"
- fi
-}
-
-multilib_src_test() {
- eninja check
-}
-
-src_install() {
- cmake-multilib_src_install
-
- docinto pdf
- dodoc doc/*.pdf
-
- if use examples; then
- docinto examples
- dodoc doc/examples/*.c
- fi
-
- if use systemd; then
- multilib_foreach_abi install_systemd_files
-
- elog "When using fluidsynth as a systemd service, make sure"
- elog "to configure your fluidsynth settings globally in "
- elog "/etc/fluidsynth.conf or per-user in ~/.config/fluidsynth"
- fi
-}
diff --git a/media-sound/fluidsynth/fluidsynth-2.2.6.ebuild b/media-sound/fluidsynth/fluidsynth-2.2.8.ebuild
index 387ff481a6d..387ff481a6d 100644
--- a/media-sound/fluidsynth/fluidsynth-2.2.6.ebuild
+++ b/media-sound/fluidsynth/fluidsynth-2.2.8.ebuild
diff --git a/media-sound/fmit/fmit-1.0.15-r3.ebuild b/media-sound/fmit/fmit-1.0.15-r3.ebuild
index 1d322a86d48..5ca73642751 100644
--- a/media-sound/fmit/fmit-1.0.15-r3.ebuild
+++ b/media-sound/fmit/fmit-1.0.15-r3.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit qmake-utils
@@ -27,21 +27,20 @@ RDEPEND="
jack? ( virtual/jack )
portaudio? ( media-libs/portaudio )
"
-DEPEND="${RDEPEND}
- dev-qt/linguist-tools:5
-"
+DEPEND="${RDEPEND}"
+BDEPEND="dev-qt/linguist-tools:5"
src_prepare() {
# Fix the path to readme file to prevent errors on start up
sed -i "/QFile readmefile/c\QFile readmefile \
(\"/usr/share/doc/${PF}/README.txt\");" \
- src/main.cpp || die "README sed failed"
+ src/main.cpp || die
# Fix the PREFIX location, insert real path.
sed -i "/QString fmitprefix/c\QString fmitprefix(STR(/usr));" \
- src/main.cpp || die "PREFIX fix sed failed"
+ src/main.cpp || die
# Fix the PREFIX location, insert real path.
sed -i "/QString fmitprefix/c\QString fmitprefix(STR(/usr));" \
- src/modules/MicrotonalView.cpp || die "PREFIX fix sed failed"
+ src/modules/MicrotonalView.cpp || die
default
}
@@ -51,8 +50,11 @@ src_configure() {
use ${flag} && config+=" acs_${flag}"
done
- "$(qt5_get_bindir)"/lrelease fmit.pro || die "Running lrelease failed"
+ "$(qt5_get_bindir)"/lrelease fmit.pro || die
+
+ eqmake5 CONFIG+="${config}" PREFIX=/usr fmit.pro
+}
- eqmake5 CONFIG+="${config}" fmit.pro PREFIX="${D}"/usr \
- PREFIXSHORTCUT="${D}"/usr DISTDIR=/usr
+src_install() {
+ emake install INSTALL_ROOT="${D}"
}
diff --git a/media-sound/frescobaldi/Manifest b/media-sound/frescobaldi/Manifest
index f94e88e995e..9429bf75812 100644
--- a/media-sound/frescobaldi/Manifest
+++ b/media-sound/frescobaldi/Manifest
@@ -1,2 +1 @@
-DIST frescobaldi-3.1.3.tar.gz 6691789 BLAKE2B 88a08240997aad11d9bf31c57a844a42e341e7641649f5cfb52571beb63fa4c29382136eae7758e5fff1cc6a4f8eb2942ca9b09b8217d7243c699041c951081d SHA512 595c4628df1923dffa44987ba858827a50d5415e9a01b45c87def2a6625d22c8b9b2e988c49dec20bba750cfc1ff4512e6f67875c3a2b23e440ef7231856c159
DIST frescobaldi-3.2.tar.gz 6696111 BLAKE2B e74a8c3a59c6dc5187538785bc5971dd996cf897c6428ff510775bad58aa4c04dd69b91f3821b9c868a3e7f13b6cae6f76814188de2620542959039e768c9be0 SHA512 403ae6cfe145595fef0ffe06ce4fd595a0417201b19e5f2315944b45cdcec50592296424f2bf2c7e3eccbe3dbeb9ff5bfc4aa7813241d8168bc057e7bf5539b3
diff --git a/media-sound/frescobaldi/frescobaldi-3.1.3.ebuild b/media-sound/frescobaldi/frescobaldi-3.2-r1.ebuild
index bde7dad74da..884b2e9b8e4 100644
--- a/media-sound/frescobaldi/frescobaldi-3.1.3.ebuild
+++ b/media-sound/frescobaldi/frescobaldi-3.2-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1 xdg
DESCRIPTION="A LilyPond sheet music text editor"
@@ -12,7 +12,7 @@ SRC_URI="https://github.com/wbsoft/${PN}/releases/download/v${PV}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="amd64 x86"
+KEYWORDS="amd64 ~x86"
IUSE=""
DEPEND="
@@ -20,6 +20,7 @@ DEPEND="
dev-python/PyQtWebEngine[${PYTHON_USEDEP}]
dev-python/python-ly[${PYTHON_USEDEP}]
dev-python/python-poppler-qt5[${PYTHON_USEDEP}]
+ dev-python/qpageview[${PYTHON_USEDEP}]
media-sound/lilypond"
RDEPEND="${DEPEND}
x11-themes/tango-icon-theme
diff --git a/media-sound/frescobaldi/frescobaldi-3.2.ebuild b/media-sound/frescobaldi/frescobaldi-3.2.ebuild
index 1b7def16a0e..a71a77966f4 100644
--- a/media-sound/frescobaldi/frescobaldi-3.2.ebuild
+++ b/media-sound/frescobaldi/frescobaldi-3.2.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-PYTHON_COMPAT=( python3_{8..9} )
+PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1 xdg
DESCRIPTION="A LilyPond sheet music text editor"
@@ -12,7 +12,7 @@ SRC_URI="https://github.com/wbsoft/${PN}/releases/download/v${PV}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="amd64 x86"
IUSE=""
DEPEND="
diff --git a/media-sound/gmorgan/files/gmorgan-0.79-remove-gettext-version-check.patch b/media-sound/gmorgan/files/gmorgan-0.79-remove-gettext-version-check.patch
index 5a076a7ba2a..430159271b6 100644
--- a/media-sound/gmorgan/files/gmorgan-0.79-remove-gettext-version-check.patch
+++ b/media-sound/gmorgan/files/gmorgan-0.79-remove-gettext-version-check.patch
@@ -5,22 +5,18 @@ Subject: [PATCH 1/3] Remove useless gettext version check
Fixes following error:
autopoint: *** Missing version: please specify in configure.ac through a line 'AM_GNU_GETTEXT_VERSION(x.yy.zz)' the gettext version the package is using
----
- configure.ac | 1 -
- 1 file changed, 1 deletion(-)
-diff --git a/configure.ac b/configure.ac
-index ed48b6f..f6ba2af 100644
--- a/configure.ac
+++ b/configure.ac
-@@ -16,7 +16,6 @@ AC_HEADER_STDC
+@@ -16,9 +16,8 @@
AC_FUNC_SELECT_ARGTYPES
AC_CHECK_FUNCS([bzero memset select strdup])
AM_GNU_GETTEXT([external])
-AM_GNU_GETTEXT_VERSION
- LIBS="`fltk-config --use-images --ldflags` -lasound"
- CXXFLAGS="-g `fltk-config --use-images --cxxflags`"
+-LIBS="`fltk-config --use-images --ldflags` -lasound"
+-CXXFLAGS="-g `fltk-config --use-images --cxxflags`"
++LIBS="$(fltk-config --use-images --ldflags) -lasound ${LIBS}"
++CXXFLAGS="$(fltk-config --use-images --cxxflags) ${CXXFLAGS}"
AC_CHECK_HEADERS([unistd.h])
---
-2.12.0
-
+ AC_CHECK_HEADER(alsa/asoundlib.h, true, AC_MSG_ERROR([Alsa is required]))
+ AC_PATH_PROG(FLTK_CONFIG, fltk-config, no)
diff --git a/media-sound/gmorgan/gmorgan-0.79-r1.ebuild b/media-sound/gmorgan/gmorgan-0.79-r2.ebuild
index 54db2b24697..074f938d622 100644
--- a/media-sound/gmorgan/gmorgan-0.79-r1.ebuild
+++ b/media-sound/gmorgan/gmorgan-0.79-r2.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
inherit autotools
@@ -14,10 +14,11 @@ SLOT="0"
KEYWORDS="amd64 x86"
IUSE="nls"
-RDEPEND="media-libs/alsa-lib
+RDEPEND="
+ media-libs/alsa-lib
x11-libs/fltk:1"
-DEPEND="${RDEPEND}
- nls? ( sys-devel/gettext )"
+DEPEND="${RDEPEND}"
+BDEPEND="nls? ( sys-devel/gettext )"
PATCHES=(
"${FILESDIR}"/${P}-remove-gettext-version-check.patch
@@ -35,11 +36,10 @@ src_prepare() {
}
src_configure() {
- econf \
- $(use_enable nls)
+ econf $(use_enable nls)
}
src_install() {
default
- doman man/${PN}.1
+ doman man/gmorgan.1
}
diff --git a/media-sound/gmusicbrowser/metadata.xml b/media-sound/gmusicbrowser/metadata.xml
index 9311060ff29..af7bb91007d 100644
--- a/media-sound/gmusicbrowser/metadata.xml
+++ b/media-sound/gmusicbrowser/metadata.xml
@@ -1,10 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer type="person" proxied="yes">
- <email>Sergiy.Borodych@gmail.com</email>
- <name>Sergiy Borodych</name>
- </maintainer>
<maintainer type="project">
<email>sound@gentoo.org</email>
<name>Gentoo Sound project</name>
diff --git a/media-sound/gnome-music/Manifest b/media-sound/gnome-music/Manifest
index 6e4e65b661c..998e14c1c40 100644
--- a/media-sound/gnome-music/Manifest
+++ b/media-sound/gnome-music/Manifest
@@ -1,3 +1 @@
-DIST gnome-music-41.0.tar.xz 898652 BLAKE2B cc72eb7be553ccefe10620a85aa3ee75aa30c1809e810a8ebb30a2ffbccebb9dc173cc79859e098be97fea9c964f0f6969f55c7c84ea9540a93a920376746ac1 SHA512 883f8862d5216ab30c3208a316378c2ef016ba52861c9261b8fa9ceb44f935e4dc35608ea66b333c3bf61c9dcc950fa338adfadc2d5e7f67a7a84467228d28a2
-DIST gnome-music-42.0.tar.xz 1651960 BLAKE2B 43ecee648441dab0b562e5a307554e62b3aac5f55f798bbcdbf99c50fd034b5fe52f9fafcac95a0e12e910499618337e37042ca7482e313b3854ed708f4f4cde SHA512 2e104188681337d200fabdfb2a332e4c01c8c0357580fc6f8c53fa0e44ebc4785c33acf0b32f201cad0acdfc0cb4a6dcf21b15842d0aa0b480add5f91d2a46e7
DIST gnome-music-42.1.tar.xz 1652976 BLAKE2B 6a6f6249a0ae61895feeaf658e6d4b0b217ed198e2137edf2f8acdf03f8b9f0b35adf19c74d34d360f3a5d8f1e4b0c3a4004f4b14444c7ebe7b7327d94d86284 SHA512 4feb02459a010c83c66bde12d73be648e9e482117bda88ae2e44e93b59ac7c0b80522e8e4d7ccb38954465d7c012975521b0764f0a42dbecef737fe64d3c3bf1
diff --git a/media-sound/gnome-music/files/40.1.1-fix-build-with-meson-0.61.1.patch b/media-sound/gnome-music/files/40.1.1-fix-build-with-meson-0.61.1.patch
deleted file mode 100644
index 4ae460ac99d..00000000000
--- a/media-sound/gnome-music/files/40.1.1-fix-build-with-meson-0.61.1.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-https://gitlab.gnome.org/GNOME/gnome-music/-/commit/d9f35b542adbf6b0e1114c7c077df04212a98fc7
-https://bugs.gentoo.org/831936
-
-From: Jean Felder <jfelder@src.gnome.org>
-Date: Thu, 18 Nov 2021 12:09:26 +0100
-Subject: [PATCH] meson: Remove incorrect i18n.merge_file argument
-
-The positional argument was being silently ignored until meson 0.60.0
-where it returns a deprecation message:
-"DEPRECATION: i18n.merge_file does not take any positional
-arguments. This will become a hard error in the next Meson release."
-
-See: https://github.com/mesonbuild/meson/issues/9441
---- a/data/meson.build
-+++ b/data/meson.build
-@@ -47,7 +47,6 @@ appdata_conf.set('appid', APPLICATION_ID)
- appdata_conf.set('package_url', PACKAGE_URL)
- appdata_conf.set('package_url_bug', PACKAGE_URL_BUG)
- i18n.merge_file(
-- 'appdata',
- input: configure_file(
- output: PROJECT_RDNN_NAME + '.appdata.xml.in',
- input: PROJECT_RDNN_NAME + '.appdata.xml.in.in',
-GitLab
diff --git a/media-sound/gnome-music/gnome-music-41.0.ebuild b/media-sound/gnome-music/gnome-music-41.0.ebuild
deleted file mode 100644
index a60fd556fd2..00000000000
--- a/media-sound/gnome-music/gnome-music-41.0.ebuild
+++ /dev/null
@@ -1,81 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python3_{8..10} )
-
-inherit gnome.org gnome2-utils meson python-single-r1 xdg
-
-DESCRIPTION="Music management for Gnome"
-HOMEPAGE="https://wiki.gnome.org/Apps/Music"
-
-LICENSE="GPL-2+"
-SLOT="0"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-KEYWORDS="amd64 arm64 ~ppc64 ~riscv x86"
-
-DEPEND="${PYTHON_DEPS}
- >=dev-libs/glib-2.67.1:2
- >=net-libs/gnome-online-accounts-3.35.90[introspection]
- >=dev-libs/gobject-introspection-1.54:=
- >=x11-libs/gtk+-3.24.14:3[introspection]
- >=gui-libs/libhandy-1.2.0:1=[introspection]
- >=dev-libs/libdazzle-3.28.0[introspection]
- >=media-libs/libmediaart-1.9.1:2.0[introspection]
- net-libs/libsoup:2.4[introspection]
- app-misc/tracker:3=[introspection(+)]
- >=x11-libs/pango-1.44:=
- $(python_gen_cond_dep '
- >=dev-python/pygobject-3.36.1:3[cairo,${PYTHON_USEDEP}]
- >=dev-python/pycairo-1.14.0[${PYTHON_USEDEP}]
- ')
- >=media-libs/grilo-0.3.13:0.3[introspection]
- >=media-plugins/grilo-plugins-0.3.13:0.3
-"
-# xdg-user-dirs-update needs to be there to create needed dirs
-# https://bugzilla.gnome.org/show_bug.cgi?id=731613
-RDEPEND="${DEPEND}
- || (
- app-misc/tracker-miners:3[gstreamer]
- app-misc/tracker-miners:3[ffmpeg]
- )
- x11-libs/libnotify[introspection]
- media-libs/gstreamer:1.0[introspection]
- media-libs/gst-plugins-base:1.0[introspection]
- media-plugins/gst-plugins-meta:1.0
- media-plugins/grilo-plugins:0.3[tracker]
- x11-misc/xdg-user-dirs
-"
-BDEPEND="
- dev-libs/libxml2:2
- dev-util/itstool
- >=sys-devel/gettext-0.19.8
- virtual/pkgconfig
-"
-
-PATCHES=(
- "${FILESDIR}"/40.1.1-fix-build-with-meson-0.61.1.patch
-)
-
-RESTRICT="test" # only does desktop and appdata validation, and latter needs network to validate screenshot from https
-
-pkg_setup() {
- python_setup
-}
-
-src_install() {
- meson_src_install
- python_fix_shebang "${D}"/usr/bin/gnome-music
- python_optimize
-}
-
-pkg_postinst() {
- xdg_pkg_postinst
- gnome2_schemas_update
-}
-
-pkg_postrm() {
- xdg_pkg_postrm
- gnome2_schemas_update
-}
diff --git a/media-sound/gnome-music/gnome-music-42.0.ebuild b/media-sound/gnome-music/gnome-music-42.0.ebuild
deleted file mode 100644
index 1ca03facd94..00000000000
--- a/media-sound/gnome-music/gnome-music-42.0.ebuild
+++ /dev/null
@@ -1,74 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-PYTHON_COMPAT=( python3_{8..10} )
-
-inherit gnome.org gnome2-utils meson python-single-r1 xdg
-
-DESCRIPTION="Music management for Gnome"
-HOMEPAGE="https://wiki.gnome.org/Apps/Music https://gitlab.gnome.org/GNOME/gnome-music/"
-
-LICENSE="GPL-2+"
-SLOT="0"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
-
-DEPEND="${PYTHON_DEPS}
- >=dev-libs/glib-2.67.1:2
- >=net-libs/gnome-online-accounts-3.35.90[introspection]
- >=dev-libs/gobject-introspection-1.54:=
- >=gui-libs/gtk-4.5.0:4[introspection]
- >=gui-libs/libadwaita-1.0:1=[introspection]
- >=media-libs/libmediaart-1.9.1:2.0[introspection]
- net-libs/libsoup:2.4[introspection]
- app-misc/tracker:3=[introspection(+)]
- >=x11-libs/pango-1.44:=
- $(python_gen_cond_dep '
- >=dev-python/pygobject-3.36.1:3[cairo,${PYTHON_USEDEP}]
- >=dev-python/pycairo-1.14.0[${PYTHON_USEDEP}]
- ')
- >=media-libs/grilo-0.3.13:0.3[introspection]
- >=media-plugins/grilo-plugins-0.3.13:0.3
-"
-# xdg-user-dirs-update needs to be there to create needed dirs
-# https://bugzilla.gnome.org/show_bug.cgi?id=731613
-RDEPEND="${DEPEND}
- || (
- app-misc/tracker-miners:3[gstreamer]
- app-misc/tracker-miners:3[ffmpeg]
- )
- x11-libs/libnotify[introspection]
- media-libs/gstreamer:1.0[introspection]
- media-libs/gst-plugins-base:1.0[introspection]
- media-plugins/gst-plugins-meta:1.0
- media-plugins/grilo-plugins:0.3[tracker]
- x11-misc/xdg-user-dirs
-"
-BDEPEND="
- dev-libs/libxml2:2
- dev-util/itstool
- >=sys-devel/gettext-0.19.8
- virtual/pkgconfig
-"
-
-pkg_setup() {
- python_setup
-}
-
-src_install() {
- meson_src_install
- python_fix_shebang "${D}"/usr/bin/gnome-music
- python_optimize
-}
-
-pkg_postinst() {
- xdg_pkg_postinst
- gnome2_schemas_update
-}
-
-pkg_postrm() {
- xdg_pkg_postrm
- gnome2_schemas_update
-}
diff --git a/media-sound/gnome-music/gnome-music-42.1.ebuild b/media-sound/gnome-music/gnome-music-42.1.ebuild
index 1ca03facd94..61bf800171d 100644
--- a/media-sound/gnome-music/gnome-music-42.1.ebuild
+++ b/media-sound/gnome-music/gnome-music-42.1.ebuild
@@ -13,7 +13,7 @@ LICENSE="GPL-2+"
SLOT="0"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+KEYWORDS="amd64 arm64 ~ppc64 ~riscv x86"
DEPEND="${PYTHON_DEPS}
>=dev-libs/glib-2.67.1:2
diff --git a/media-sound/gnome-sound-recorder/Manifest b/media-sound/gnome-sound-recorder/Manifest
index d86cb48908d..6fd5e46155a 100644
--- a/media-sound/gnome-sound-recorder/Manifest
+++ b/media-sound/gnome-sound-recorder/Manifest
@@ -1,2 +1 @@
-DIST gnome-sound-recorder-40.0.tar.xz 199056 BLAKE2B e830b746ccf9e038a6f425dee9a6ef8eb88cd849659570c11364b833b0be8c7e7302c0b20e8c853d7228a589d6e3953fecf2fddb31304a1905678aa99b461248 SHA512 28de1dbb9251c834513be55c3f4107cd014d74e634e383e6feb3b9430ff562e19d29e9abcd566b0fc0ed1ec3841add0f694b47c51fe91a3b4ba33b9f43a0d617
DIST gnome-sound-recorder-42.0.tar.xz 162208 BLAKE2B 6f4f17ad5cb2cd893626defb3b91e62c0dfbfdae4c815df934a2d35a7b0e315f689f3ea222d9adef960935828095c337e00076aba60b4c1b3d243c274063aed3 SHA512 53fe2fe0646c5055cedc1c62cf87176dca52bf3d9452d83bcc849d9946179afbef826f08ff65a97ede7a0d14ade4da0755b2ef3780460d5a80f8f9e6c85fcfbd
diff --git a/media-sound/gnome-sound-recorder/files/40.0-fix-build-with-meson-0.61.1.patch b/media-sound/gnome-sound-recorder/files/40.0-fix-build-with-meson-0.61.1.patch
deleted file mode 100644
index 0eea5fe096e..00000000000
--- a/media-sound/gnome-sound-recorder/files/40.0-fix-build-with-meson-0.61.1.patch
+++ /dev/null
@@ -1,43 +0,0 @@
-https://gitlab.gnome.org/GNOME/gnome-sound-recorder/-/commit/1335b1b1aff61167f8648f7cb3c569764031960d.patch
-https://bugs.gentoo.org/831924
-
-From: Jan Beich <jbeich@FreeBSD.org>
-Date: Mon, 24 Jan 2022 11:37:06 +0000
-Subject: [PATCH] meson: drop unused argument for i18n.merge_file()
-
-Ignored in Meson < 0.60.0, deprecated since 0.60.1 and fatal since 0.61.0.
-
-data/appdata/meson.build:5:0: ERROR: Function does not take positional arguments.
-data/meson.build:16:0: ERROR: Function does not take positional arguments.
----
- data/appdata/meson.build | 1 -
- data/meson.build | 1 -
- 2 files changed, 2 deletions(-)
-
-diff --git a/data/appdata/meson.build b/data/appdata/meson.build
-index 1f5744e..d2c2c3a 100644
---- a/data/appdata/meson.build
-+++ b/data/appdata/meson.build
-@@ -3,7 +3,6 @@ metainfo_conf.set('app-id', application_id)
- metainfo_conf.set('gettext-package', gettext_package)
-
- metainfo_file = i18n.merge_file(
-- 'metainfo-file',
- input: configure_file(
- input: 'org.gnome.SoundRecorder.metainfo.xml.in.in',
- output: '@BASENAME@',
-diff --git a/data/meson.build b/data/meson.build
-index 44117ad..0ff8fa5 100644
---- a/data/meson.build
-+++ b/data/meson.build
-@@ -14,7 +14,6 @@ install_data(
- desktop_conf = configuration_data()
- desktop_conf.set('app-id', application_id)
- desktop_file = i18n.merge_file(
-- 'desktop',
- input: configure_file(
- input: 'org.gnome.SoundRecorder.desktop.in.in',
- output: '@BASENAME@',
---
-GitLab
-
diff --git a/media-sound/gnome-sound-recorder/gnome-sound-recorder-40.0.ebuild b/media-sound/gnome-sound-recorder/gnome-sound-recorder-40.0.ebuild
deleted file mode 100644
index 06371a51087..00000000000
--- a/media-sound/gnome-sound-recorder/gnome-sound-recorder-40.0.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python3_{7..9} )
-
-inherit gnome.org gnome2-utils meson python-any-r1 xdg
-
-DESCRIPTION="Simple sound recorder"
-HOMEPAGE="https://wiki.gnome.org/Design/Apps/SoundRecorder"
-
-LICENSE="GPL-2+"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 x86"
-
-DEPEND="
- >=dev-libs/gjs-1.54.0
- >=dev-libs/glib-2.46:2
- >=x11-libs/gtk+-3.12:3[introspection]
- media-libs/gst-plugins-bad:1.0
- >=gui-libs/libhandy-1.1.90:1=
- >=dev-libs/gobject-introspection-1.31.6
- x11-libs/gdk-pixbuf:2[introspection]
-"
-RDEPEND="${DEPEND}
- media-libs/gstreamer:1.0[introspection]
- media-libs/gst-plugins-base:1.0[introspection,ogg]
- media-libs/gst-plugins-good:1.0
- media-plugins/gst-plugins-flac:1.0
- media-plugins/gst-plugins-pulse:1.0
-"
-BDEPEND="
- ${PYTHON_DEPS}
- >=sys-devel/gettext-0.19.8
- virtual/pkgconfig
-"
-
-PATCHES=(
- "${FILESDIR}/${PV}"-fix-build-with-meson-0.61.1.patch
-)
-
-pkg_setup() {
- python-any-r1_pkg_setup
-}
-
-pkg_postinst() {
- xdg_pkg_postinst
- gnome2_schemas_update
-}
-
-pkg_postrm() {
- xdg_pkg_postrm
- gnome2_schemas_update
-}
diff --git a/media-sound/gnome-sound-recorder/gnome-sound-recorder-42.0.ebuild b/media-sound/gnome-sound-recorder/gnome-sound-recorder-42.0.ebuild
index e125245f009..417b22aa286 100644
--- a/media-sound/gnome-sound-recorder/gnome-sound-recorder-42.0.ebuild
+++ b/media-sound/gnome-sound-recorder/gnome-sound-recorder-42.0.ebuild
@@ -11,7 +11,7 @@ HOMEPAGE="https://wiki.gnome.org/Design/Apps/SoundRecorder https://gitlab.gnome.
LICENSE="GPL-2+"
SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~x86"
+KEYWORDS="amd64 ~arm64 x86"
DEPEND="
>=dev-libs/gjs-1.54.0
diff --git a/media-sound/gpodder/Manifest b/media-sound/gpodder/Manifest
index ae5ec5bf562..39dfc8eab3a 100644
--- a/media-sound/gpodder/Manifest
+++ b/media-sound/gpodder/Manifest
@@ -1,3 +1,2 @@
-DIST gpodder-3.10.16.tar.gz 1058386 BLAKE2B d73bc8a9d9d2cfe642a6c1e7ae3e7811e05db8c1ebf566904e669a5f9d029c6bce73599da737d25f42c4740d23537b1c414e7a23cf15076394fb714a2f33c79c SHA512 ce9525864e5a640dd82fb535021d63e1d1ddeb7785774b00c668ff86a279a45e075ab7488120ec93d1a07a0a943daa0abb786f822d74866e0fd8c6713d7f8531
-DIST gpodder-3.10.20.tar.gz 1081171 BLAKE2B b2a07a3d5ce02cc46d7dd5999287b6e0bb96149f2fbf613b0d70b8d3b04d4cd29dcd1b78b4584709d1613c9a5478d39c3cb9be35a274358d56aa593f0196e6b2 SHA512 93cae9cc6d7f3a7754e24f7e962d195788f5f344992a4a3f3be9fd9acf419728b94ce009e1a2e14faa64803ebba098e8199a8d43ed33f5f3e02eabde1fe5c3be
DIST gpodder-3.10.21.tar.gz 1105520 BLAKE2B c17905951c14a718e48d1bbded3abc41d62088bb517cda053e9fa71e3a952bb97ac57077d428cd58c3a048ae0cc18ef9385af97dcf8b460f3860674ecdb85c1c SHA512 5311a92469f605e489553e91586b788a8d07812e41c20d1ad0717c09ab6db6da22c356d5c1942293d1e27e25afe24caf3c14c15720250d8f230f2d7738206fec
+DIST gpodder-3.11.0.tar.gz 1155120 BLAKE2B b2e46a5ea5ceec7df632f888b00e9c25a0ec1c4597540228b50cb75bd4bd6acfc7566cfffe5c9d133e8ec29e1ffc2f4551e2fd289237d1b93d2e80f6b49db0c1 SHA512 90e33e04a8afcdafa0899f25714417ce61699c641ce3df93b3a3728224bdb0be5205c064e7263d1be1f4641e61932b945741e9848726b602633a94eb754fa937
diff --git a/media-sound/gpodder/gpodder-3.10.16-r1.ebuild b/media-sound/gpodder/gpodder-3.10.16-r1.ebuild
deleted file mode 100644
index 9e32490864d..00000000000
--- a/media-sound/gpodder/gpodder-3.10.16-r1.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python3_{8,9} )
-PYTHON_REQ_USE="sqlite"
-DISTUTILS_SINGLE_IMPL=1
-DISTUTILS_USE_SETUPTOOLS=no
-
-inherit distutils-r1 xdg
-
-DESCRIPTION="A free cross-platform podcast aggregator"
-HOMEPAGE="https://gpodder.github.io/"
-SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux ~x86-solaris"
-IUSE="+dbus bluetooth mtp test"
-RESTRICT="!test? ( test )"
-
-# As in Fedora: re-enable >=dev-python/eyeD3-0.7[${PYTHON_USEDEP}] and
-# ipod? ( media-libs/libgpod[python,${PYTHON_USEDEP}] ) once they
-# support python3
-COMMON_DEPEND="
- $(python_gen_cond_dep '
- dev-python/html5lib[${PYTHON_USEDEP}]
- dev-python/pycairo[${PYTHON_USEDEP}]
- >=dev-python/pygobject-3.22.0:3[${PYTHON_USEDEP}]
- >=dev-python/podcastparser-0.6.0[${PYTHON_USEDEP}]
- >=dev-python/mygpoclient-1.8[${PYTHON_USEDEP}]
- dbus? ( dev-python/dbus-python[${PYTHON_USEDEP}] )
- ')
- bluetooth? ( net-wireless/bluez )
- mtp? ( >=media-libs/libmtp-1.0.0:= )
-"
-RDEPEND="${COMMON_DEPEND}
- kernel_linux? ( sys-apps/iproute2 )
-"
-DEPEND="${COMMON_DEPEND}
- dev-util/desktop-file-utils
- dev-util/intltool
- sys-apps/help2man
- test? (
- dev-python/minimock
- dev-python/coverage
- )
-"
-
-src_install() {
- emake PYTHON=python3 DESTDIR="${D}" install
- distutils-r1_src_install
-}
-
-src_test() {
- emake releasetest
-}
-
-pkg_postinst() {
- xdg_pkg_postinst
-
- elog
- elog "If you want to use Youtube-dl extension, you need"
- elog "to emerge net-misc/youtube-dl."
- elog
-}
diff --git a/media-sound/gpodder/gpodder-3.10.20.ebuild b/media-sound/gpodder/gpodder-3.10.21-r1.ebuild
index 5ac6cbc3daf..c1e0a35b24d 100644
--- a/media-sound/gpodder/gpodder-3.10.20.ebuild
+++ b/media-sound/gpodder/gpodder-3.10.21-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{8,9} )
+PYTHON_COMPAT=( python3_{8..10} )
PYTHON_REQ_USE="sqlite"
DISTUTILS_SINGLE_IMPL=1
DISTUTILS_USE_SETUPTOOLS=no
@@ -16,9 +16,8 @@ SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="GPL-3"
SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~x86-solaris"
-IUSE="+dbus bluetooth mtp test"
-RESTRICT="!test? ( test )"
+KEYWORDS="amd64 x86"
+IUSE="+dbus bluetooth mtp"
# As in Fedora: re-enable >=dev-python/eyeD3-0.7[${PYTHON_USEDEP}] and
# ipod? ( media-libs/libgpod[python,${PYTHON_USEDEP}] ) once they
@@ -46,24 +45,31 @@ DEPEND="${COMMON_DEPEND}
test? (
$(python_gen_cond_dep '
dev-python/minimock[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/pytest-localserver[${PYTHON_USEDEP}]
+ dev-python/pytest-httpserver[${PYTHON_USEDEP}]
')
)
"
+distutils_enable_tests pytest
+
src_prepare() {
default
sed -i -e 's:--cov=gpodder::' makefile || die
}
-src_test() {
- emake releasetest
+python_test() {
+ # These are pulled out from the Makefile to give us more control
+ # See bug #795165
+ # Previously, we used 'emake releasetest' in src_test
+ LC_ALL=C epytest --ignore=tests --ignore=src/gpodder/utilwin32ctypes.py --doctest-modules src/gpodder/util.py src/gpodder/jsonconfig.py \
+ -p no:localserver
+ LC_ALL=C epytest tests --ignore=src/gpodder/utilwin32ctypes.py --ignore=src/mygpoclient \
+ -p no:localserver
}
src_install() {
- emake PYTHON=${EPYTHON} DESTDIR="${D}" install
+ emake PYTHON="${EPYTHON}" DESTDIR="${D}" install
distutils-r1_src_install
}
diff --git a/media-sound/gpodder/gpodder-3.10.21.ebuild b/media-sound/gpodder/gpodder-3.11.0.ebuild
index 5ac6cbc3daf..f2ab5d507ec 100644
--- a/media-sound/gpodder/gpodder-3.10.21.ebuild
+++ b/media-sound/gpodder/gpodder-3.11.0.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_{8,9} )
-PYTHON_REQ_USE="sqlite"
DISTUTILS_SINGLE_IMPL=1
DISTUTILS_USE_SETUPTOOLS=no
+PYTHON_COMPAT=( python3_{8..11} )
+PYTHON_REQ_USE="sqlite"
inherit distutils-r1 optfeature xdg
@@ -16,14 +16,10 @@ SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="GPL-3"
SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~x86-solaris"
-IUSE="+dbus bluetooth mtp test"
-RESTRICT="!test? ( test )"
+KEYWORDS="~amd64 ~x86"
+IUSE="+dbus bluetooth mtp"
-# As in Fedora: re-enable >=dev-python/eyeD3-0.7[${PYTHON_USEDEP}] and
-# ipod? ( media-libs/libgpod[python,${PYTHON_USEDEP}] ) once they
-# support python3
-COMMON_DEPEND="
+RDEPEND="
$(python_gen_cond_dep '
dev-python/html5lib[${PYTHON_USEDEP}]
dev-python/pycairo[${PYTHON_USEDEP}]
@@ -35,40 +31,50 @@ COMMON_DEPEND="
')
bluetooth? ( net-wireless/bluez )
mtp? ( >=media-libs/libmtp-1.0.0:= )
-"
-RDEPEND="${COMMON_DEPEND}
kernel_linux? ( sys-apps/iproute2 )
"
-DEPEND="${COMMON_DEPEND}
+BDEPEND="
dev-util/desktop-file-utils
dev-util/intltool
sys-apps/help2man
test? (
$(python_gen_cond_dep '
dev-python/minimock[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/pytest-localserver[${PYTHON_USEDEP}]
+ dev-python/pytest-httpserver[${PYTHON_USEDEP}]
')
)
"
+distutils_enable_tests pytest
+
src_prepare() {
default
sed -i -e 's:--cov=gpodder::' makefile || die
}
-src_test() {
- emake releasetest
+python_test() {
+ # These are pulled out from the Makefile to give us more control
+ # See bug #795165
+ # Previously, we used 'emake releasetest' in src_test
+ LC_ALL=C epytest --ignore=tests --ignore=src/gpodder/utilwin32ctypes.py --doctest-modules src/gpodder/util.py src/gpodder/jsonconfig.py \
+ -p no:localserver
+ LC_ALL=C epytest tests --ignore=src/gpodder/utilwin32ctypes.py --ignore=src/mygpoclient \
+ -p no:localserver
}
src_install() {
- emake PYTHON=${EPYTHON} DESTDIR="${D}" install
+ emake PYTHON="${EPYTHON}" DESTDIR="${D}" install
+
distutils-r1_src_install
+
+ touch "${ED}"/usr/share/gpodder/no-update-check || die
}
pkg_postinst() {
xdg_pkg_postinst
- optfeature "for the youtube-dl extension" net-misc/youtube-dl
+ optfeature "track length detection for device sync (only one package is needed)" media-video/mplayer dev-python/eyeD3
+ optfeature "for the YouTube extension" net-misc/yt-dlp net-misc/youtube-dl
+ optfeature "iPod sync support" media-libs/libgpod
}
diff --git a/media-sound/gsm/gsm-1.0.13-r1.ebuild b/media-sound/gsm/gsm-1.0.13-r1.ebuild
index 694195884bb..6a0a5898782 100644
--- a/media-sound/gsm/gsm-1.0.13-r1.ebuild
+++ b/media-sound/gsm/gsm-1.0.13-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -11,7 +11,7 @@ SRC_URI="mirror://gentoo/${P}.tar.gz"
LICENSE="gsm"
SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~mips ppc ppc64 ~riscv ~s390 sparc x86"
+KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~loong ~mips ppc ppc64 ~riscv ~s390 sparc x86"
S="${WORKDIR}/${PN}-$(ver_rs 2 '-pl' )"
diff --git a/media-sound/guitarix/guitarix-0.44.1.ebuild b/media-sound/guitarix/guitarix-0.44.1.ebuild
index d85e289e2d5..cd2c72ecf68 100644
--- a/media-sound/guitarix/guitarix-0.44.1.ebuild
+++ b/media-sound/guitarix/guitarix-0.44.1.ebuild
@@ -16,7 +16,7 @@ SRC_URI="mirror://sourceforge/guitarix/guitarix/${MY_P}.tar.xz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~amd64"
+KEYWORDS="amd64"
IUSE="bluetooth debug lv2 nls nsm +standalone zeroconf"
REQUIRED_USE="|| ( lv2 standalone )"
diff --git a/media-sound/jack-audio-connection-kit/jack-audio-connection-kit-0.125.0-r1.ebuild b/media-sound/jack-audio-connection-kit/jack-audio-connection-kit-0.125.0-r1.ebuild
index a01b6111e1c..af01c2ca271 100644
--- a/media-sound/jack-audio-connection-kit/jack-audio-connection-kit-0.125.0-r1.ebuild
+++ b/media-sound/jack-audio-connection-kit/jack-audio-connection-kit-0.125.0-r1.ebuild
@@ -12,7 +12,7 @@ SRC_URI="https://github.com/jackaudio/jack1/archive/${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="GPL-2 LGPL-2.1"
SLOT="0"
KEYWORDS="amd64 arm arm64 ~ia64 ppc ppc64 ~riscv sparc x86"
-IUSE="cpu_flags_x86_3dnow altivec alsa coreaudio doc debug examples oss cpu_flags_x86_sse pam"
+IUSE="cpu_flags_ppc_altivec cpu_flags_x86_3dnow alsa coreaudio doc debug examples oss cpu_flags_x86_sse pam"
# readline: only used for jack_transport -> useless for non native ABIs
# libsndfile: ditto for jackrec
@@ -64,7 +64,7 @@ multilib_src_configure() {
use doc || export ac_cv_prog_HAVE_DOXYGEN=false
econf \
- $(use_enable altivec) \
+ $(use_enable cpu_flags_ppc_altivec altivec) \
$(use_enable alsa) \
$(use_enable coreaudio) \
$(use_enable debug) \
diff --git a/media-sound/jack/metadata.xml b/media-sound/jack/metadata.xml
index a2cc30d822e..d238502d54f 100644
--- a/media-sound/jack/metadata.xml
+++ b/media-sound/jack/metadata.xml
@@ -13,4 +13,7 @@
<email>sound@gentoo.org</email>
<name>Gentoo Sound project</name>
</maintainer>
+ <upstream>
+ <remote-id type="github">jack-cli-cd-ripper/jack</remote-id>
+ </upstream>
</pkgmetadata>
diff --git a/media-sound/jack2/jack2-9999.ebuild b/media-sound/jack2/jack2-9999.ebuild
index 06fe3cac36b..eb214ebbb40 100644
--- a/media-sound/jack2/jack2-9999.ebuild
+++ b/media-sound/jack2/jack2-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{8,9} )
+PYTHON_COMPAT=( python3_{8,9,10} )
PYTHON_REQ_USE="threads(+)"
inherit python-single-r1 waf-utils multilib-minimal
@@ -18,7 +18,7 @@ else
MY_P="${PN}-${MY_PV}"
S="${WORKDIR}/${MY_P}"
SRC_URI="https://github.com/jackaudio/jack2/archive/v${MY_PV}/v${MY_PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+ KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~x86"
fi
LICENSE="GPL-2"
diff --git a/media-sound/jalv/jalv-1.6.6.ebuild b/media-sound/jalv/jalv-1.6.6.ebuild
index 42870c71a5f..4e6f6c0e6aa 100644
--- a/media-sound/jalv/jalv-1.6.6.ebuild
+++ b/media-sound/jalv/jalv-1.6.6.ebuild
@@ -1,14 +1,14 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7,8,9} )
+PYTHON_COMPAT=( python3_{7..11} )
PYTHON_REQ_USE='threads(+)'
inherit python-any-r1 qmake-utils waf-utils
DESCRIPTION="Simple but fully featured LV2 host for Jack"
-HOMEPAGE="http://drobilla.net/software/jalv/"
+HOMEPAGE="https://drobilla.net/software/jalv.html"
SRC_URI="http://download.drobilla.net/${P}.tar.bz2"
LICENSE="ISC"
diff --git a/media-sound/kid3/Manifest b/media-sound/kid3/Manifest
index 817b4f59d87..5ac84b27b10 100644
--- a/media-sound/kid3/Manifest
+++ b/media-sound/kid3/Manifest
@@ -1 +1,2 @@
DIST kid3-3.9.1.tar.xz 1796320 BLAKE2B 3404c6016a7d5195cc2e9826ef8daf452f5419566ffa9b50b20dd21072c0e34159e39bb8eeec08b7e12fe7f14df96517e929163ae4c14e28509cc51a0e96de08 SHA512 865fc2abfffd9533347ecfee037dfa15c6cedfc33ed0378b6d8dfef3436c6ec78c2100a317edf0882b16d345ea14b564cfb4055f74317634b4863ec477a80669
+DIST kid3-3.9.2.tar.xz 1952344 BLAKE2B 5a44a05f614f97dc7ddab39694a1773e1e6c55af7a9dc4ac7b793a520e54a8892c2181903a58f150885b3b4e17ebf921db719863f7ac4fd540f711a444990df3 SHA512 fc0b9db33ea948a2345968ab5da65f959bea829130f4250604d68df778218173d49f92b015d9be4e43f57ba5ae3388b0e97f558774df590b5959aa6f6293acd3
diff --git a/media-sound/kid3/kid3-3.9.2.ebuild b/media-sound/kid3/kid3-3.9.2.ebuild
new file mode 100644
index 00000000000..5e27fe36edd
--- /dev/null
+++ b/media-sound/kid3/kid3-3.9.2.ebuild
@@ -0,0 +1,100 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+inherit cmake kde.org python-any-r1 xdg
+
+DESCRIPTION="Simple tag editor based on Qt"
+HOMEPAGE="https://kid3.kde.org/"
+
+if [[ ${KDE_BUILD_TYPE} != live ]]; then
+ SRC_URI="mirror://kde/stable/${PN}/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-2+"
+SLOT="5"
+IUSE="acoustid flac kde mp3 mp4 +mpris +taglib test vorbis"
+
+REQUIRED_USE="flac? ( vorbis )"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtdeclarative:5
+ dev-qt/qtgui:5
+ dev-qt/qtmultimedia:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtxml:5
+ sys-libs/readline:0=
+ acoustid? (
+ media-libs/chromaprint
+ media-video/ffmpeg
+ )
+ flac? (
+ media-libs/flac[cxx]
+ media-libs/libvorbis
+ )
+ kde? (
+ kde-frameworks/kconfig:5
+ kde-frameworks/kconfigwidgets:5
+ kde-frameworks/kcoreaddons:5
+ kde-frameworks/kio:5
+ kde-frameworks/kwidgetsaddons:5
+ kde-frameworks/kxmlgui:5
+ )
+ mp3? ( media-libs/id3lib )
+ mp4? ( media-libs/libmp4v2:0 )
+ mpris? ( dev-qt/qtdbus:5 )
+ taglib? ( >=media-libs/taglib-1.9.1 )
+ vorbis? (
+ media-libs/libogg
+ media-libs/libvorbis
+ )
+"
+DEPEND="${RDEPEND}
+ test? ( dev-qt/qttest:5 )
+"
+BDEPEND="${PYTHON_DEPS}
+ dev-qt/linguist-tools:5
+ kde? ( kde-frameworks/extra-cmake-modules:5 )
+"
+
+pkg_setup() {
+ use test && python-any-r1_pkg_setup
+}
+
+src_prepare() {
+ # overengineered upstream build system
+ cmake_src_prepare
+ # applies broken python hacks, bug #614950
+ cmake_comment_add_subdirectory doc
+
+ sed -e "/^find_package.*QT NAMES/s/Qt6 //" \
+ -i CMakeLists.txt || die # ensure Qt5 build
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DPython3_EXECUTABLE="${PYTHON}"
+ -DWITH_CHROMAPRINT=$(usex acoustid)
+ -DWITH_DBUS=$(usex mpris)
+ -DWITH_FLAC=$(usex flac)
+ -DWITH_ID3LIB=$(usex mp3)
+ -DWITH_MP4V2=$(usex mp4)
+ -DWITH_TAGLIB=$(usex taglib)
+ -DBUILD_TESTING=$(usex test)
+ -DWITH_VORBIS=$(usex vorbis)
+ )
+
+ if use kde ; then
+ mycmakeargs+=( "-DWITH_APPS=KDE;CLI" )
+ else
+ mycmakeargs+=( "-DWITH_APPS=Qt;CLI" )
+ fi
+
+ cmake_src_configure
+}
diff --git a/media-sound/klick/klick-0.12.2-r3.ebuild b/media-sound/klick/klick-0.12.2-r3.ebuild
new file mode 100644
index 00000000000..dc5e78d639f
--- /dev/null
+++ b/media-sound/klick/klick-0.12.2-r3.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit python-any-r1 scons-utils toolchain-funcs
+
+DESCRIPTION="An advanced command-line based metronome for JACK"
+HOMEPAGE="http://das.nasophon.de/klick"
+SRC_URI="http://das.nasophon.de/download/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="debug osc rubberband"
+
+RDEPEND="media-libs/libsamplerate
+ media-libs/libsndfile
+ virtual/jack
+ osc? ( media-libs/liblo )
+ rubberband? ( media-libs/rubberband )"
+DEPEND="${RDEPEND}
+ dev-libs/boost"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-sconstruct.patch
+ "${FILESDIR}"/${P}-gcc6.patch
+)
+
+HTML_DOCS=( doc/manual.html )
+
+src_configure() {
+ MYSCONS=(
+ CXX="$(tc-getCXX)"
+ CXXFLAGS="${CXXFLAGS}"
+ LINKFLAGS="${LDFLAGS}"
+ PREFIX="${EPREFIX}/usr"
+ DEBUG=$(usex debug)
+ OSC=$(usex osc)
+ RUBBERBAND=$(usex rubberband)
+ )
+}
+
+src_compile() {
+ escons "${MYSCONS[@]}"
+}
+
+src_install() {
+ escons "${MYSCONS[@]}" DESTDIR="${D}" install
+ einstalldocs
+}
diff --git a/media-sound/kmidimon/Manifest b/media-sound/kmidimon/Manifest
index 3b5a4792fec..9836e899448 100644
--- a/media-sound/kmidimon/Manifest
+++ b/media-sound/kmidimon/Manifest
@@ -1,2 +1 @@
-DIST kmidimon-1.2.0.tar.bz2 696057 BLAKE2B a0a3cc8ccd7d9f065c5b1b5594a6baeafd36e4a124207bd8b8f55a3d3c22f7bc7eb84771b51f71f07f3251da3d796a79980a8e22a545576220dce17b354a1403 SHA512 ea62240438111428b1b10e4df2179497495038a376b848cd3fc910ca5eb6126a63f1ebafe9eb1408a0037a9626ffab5bf43e7e3cc31608d878b329450ec17463
DIST kmidimon-1.3.0.tar.bz2 698412 BLAKE2B 185125fda809042a064b225f14ef5c04c69f07bda77d2291d2719256ccbee122bc181d9ea602cb43335f764ae9576daf79966a681637d080f5e3533bd856715d SHA512 02085e6d6768fe5d35649446ec5db2eadcf34b4c727fb250bdbc33d79c86a16d6dc3993ddd9fe08e93e08e1400fb3f56bb71913020ffa410f56ad7168bf08b97
diff --git a/media-sound/kmidimon/kmidimon-1.2.0.ebuild b/media-sound/kmidimon/kmidimon-1.2.0.ebuild
deleted file mode 100644
index 203ceb048fe..00000000000
--- a/media-sound/kmidimon/kmidimon-1.2.0.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit cmake xdg
-
-DESCRIPTION="MIDI monitor for ALSA sequencer"
-HOMEPAGE="https://kmidimon.sourceforge.io/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="debug"
-
-RDEPEND="
- dev-qt/qtcore:5
- dev-qt/qtgui:5
- dev-qt/qtwidgets:5
- media-libs/alsa-lib
- >=media-sound/drumstick-2.4.0
-"
-DEPEND="${RDEPEND}"
-BDEPEND="
- app-arch/unzip
- dev-qt/linguist-tools:5
-"
-
-PATCHES=( "${FILESDIR}/${P}-fix-cmake-pathvar.patch" )
-
-src_configure() {
- local mycmakeargs=(
- -DBUILD_DOCS=OFF
- -DCMAKE_INSTALL_DOCDIR="${EPREFIX}"/usr/share/doc/${PF}/html
- -DUSE_QT=5
- )
- cmake_src_configure
-}
diff --git a/media-sound/kmidimon/kmidimon-1.3.0.ebuild b/media-sound/kmidimon/kmidimon-1.3.0.ebuild
index 846c67c3cf4..a8a7c43aa1f 100644
--- a/media-sound/kmidimon/kmidimon-1.3.0.ebuild
+++ b/media-sound/kmidimon/kmidimon-1.3.0.ebuild
@@ -11,7 +11,7 @@ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="amd64 x86"
IUSE="debug"
RDEPEND="
diff --git a/media-sound/lash/lash-0.5.4-r4.ebuild b/media-sound/lash/lash-0.5.4-r5.ebuild
index 686eaf21289..8a2d81ff545 100644
--- a/media-sound/lash/lash-0.5.4-r4.ebuild
+++ b/media-sound/lash/lash-0.5.4-r5.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7,8,9} )
+PYTHON_COMPAT=( python3_{7..11} )
inherit autotools multilib-minimal python-single-r1
diff --git a/media-sound/lilypond/lilypond-9999.ebuild b/media-sound/lilypond/lilypond-9999.ebuild
index 267d1a8af4d..4690f0a0f45 100644
--- a/media-sound/lilypond/lilypond-9999.ebuild
+++ b/media-sound/lilypond/lilypond-9999.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_COMPAT=( python3_{8..11} )
inherit elisp-common autotools python-single-r1 toolchain-funcs xdg-utils
@@ -62,7 +62,7 @@ PATCHES=(
"${FILESDIR}"/${PN}-2.22.1-free_font.patch
)
-DOCS=( DEDICATION HACKING README.md ROADMAP )
+DOCS=( DEDICATION README.md ROADMAP )
src_prepare() {
default
diff --git a/media-sound/lmms/metadata.xml b/media-sound/lmms/metadata.xml
index 631d11db0a8..32965e9b9b5 100644
--- a/media-sound/lmms/metadata.xml
+++ b/media-sound/lmms/metadata.xml
@@ -5,10 +5,6 @@
<email>aballier@gentoo.org</email>
<name>Alexis Ballier</name>
</maintainer>
- <maintainer type="person">
- <email>polynomial-c@gentoo.org</email>
- <name>Lars Wendler</name>
- </maintainer>
<maintainer type="project">
<email>proaudio@gentoo.org</email>
<name>Gentoo ProAudio Project</name>
diff --git a/media-sound/mixxx/Manifest b/media-sound/mixxx/Manifest
index 857db23f0ae..8309d892da1 100644
--- a/media-sound/mixxx/Manifest
+++ b/media-sound/mixxx/Manifest
@@ -1,4 +1,4 @@
-DIST mixxx-2.3.2.tar.gz 40138947 BLAKE2B 9ec1d871d3051f081152f07fdafd6c5e2bb41224e723dc260afe27755fdcd87befd2cb5ecaa2d0fb6d7ee9fb1b97c12db4b8d0a29e695a3ff1a7fb51b94ebfa4 SHA512 81282d6c587914157b9ef4a7ca2f0e886cb97a847e215e2b0496671938d392e3fc8f941071577bc69db517e677dcd96b72e4b53d6fd42d2224c8a4e62d2acbcd
+DIST mixxx-2.3.3.tar.gz 41011867 BLAKE2B 1b3d863341afbdce86c61c4689494a334a689d02aaf5a700aa74d3291843f028d77ef7d62e545d05377ffb1f9a5077529c3a77a2b4a5e8ce20823728a8fe8d80 SHA512 6bd3809802f2f66af7d840db6ce006d7e46a824cf460ea9ae1bcff81f17483debd2ef47fd68d0da82671afaf01b6c3bc2522e02b41d992e08bc98f4d3d68120f
DIST mixxx-manual-2.3-ca.pdf 34083768 BLAKE2B 0572da067016d6fd1a0e955cfa9daad319e633357532bad1143333a277d3dee1876709447ecfb954b5294f5fd176af229884e11a8e2fd40d03c12a6cf80bf01c SHA512 965f2f344bfa57531974362de889a92bb8b3024e527158f6c1819e285f70078762e958f7805ff1f833e7310646925cb8120eb3010f8600aa2cd21b2266a9333b
DIST mixxx-manual-2.3-cs.pdf 8358958 BLAKE2B de00e08468fed15670751b0997759af0eca71b041d0366ad0e8cf2297fe27368eb6340a3f109b3f992a6f01a99f0d04ba7962c983756cdca2121bf9ca025aa76 SHA512 648eedde674155094b4fa9605422032e71427c95580ffe3f01c8d41a26495bd9bd2d8d7dff38e99bdfbba3a46aee9ca6a6e1c9327b8d1d503310e4c669755068
DIST mixxx-manual-2.3-de.pdf 34069018 BLAKE2B bdcc970d37e43c2f1244aa1f03bc07287581711e534419caada3aabbc585e3006ec489e752142b5b50e526646d3d5431e0ec5924b9d6b31a92de4e7cc7efcc86 SHA512 fbbf27c4b898f856e61301bd1f26a3523bb97c133d96c8d94f1267c15ef63aa03313c18ebec62d4380c423c3896067ed1cedccbc775e5abc6d14e1baf8b668fc
diff --git a/media-sound/mixxx/mixxx-2.3.2.ebuild b/media-sound/mixxx/mixxx-2.3.3.ebuild
index eda1855950b..ee90b814430 100644
--- a/media-sound/mixxx/mixxx-2.3.2.ebuild
+++ b/media-sound/mixxx/mixxx-2.3.3.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit cmake xdg udev
@@ -151,7 +151,17 @@ src_install() {
local locale
for locale in ${PLOCALES} ; do
if use l10n_${locale} ; then
- dodoc ${DISTDIR}/${PN}-manual-$(ver_cut 1-2)-${locale/ja/ja-JP}.pdf
+ dodoc "${DISTDIR}"/${PN}-manual-$(ver_cut 1-2)-${locale/ja/ja-JP}.pdf
fi
done
}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ udev_reload
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ udev_reload
+}
diff --git a/media-sound/mixxx/mixxx-2.3.9999.ebuild b/media-sound/mixxx/mixxx-2.3.9999.ebuild
index 73bd3177b91..ef33c268c4f 100644
--- a/media-sound/mixxx/mixxx-2.3.9999.ebuild
+++ b/media-sound/mixxx/mixxx-2.3.9999.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit cmake xdg udev
@@ -149,7 +149,17 @@ src_install() {
local locale
for locale in ${PLOCALES} ; do
if use l10n_${locale} ; then
- dodoc ${DISTDIR}/${PN}-manual-$(ver_cut 1-2)-${locale/ja/ja-JP}.pdf
+ dodoc "${DISTDIR}"/${PN}-manual-$(ver_cut 1-2)-${locale/ja/ja-JP}.pdf
fi
done
}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ udev_reload
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ udev_reload
+}
diff --git a/media-sound/mixxx/mixxx-9999.ebuild b/media-sound/mixxx/mixxx-9999.ebuild
index 8b5963df7ac..3b37660dc9e 100644
--- a/media-sound/mixxx/mixxx-9999.ebuild
+++ b/media-sound/mixxx/mixxx-9999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit cmake xdg udev
@@ -129,3 +129,13 @@ src_install() {
dodoc README Mixxx-Manual.pdf
fi
}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ udev_reload
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ udev_reload
+}
diff --git a/media-sound/mp32ogg/mp32ogg-0.11-r6.ebuild b/media-sound/mp32ogg/mp32ogg-0.11-r7.ebuild
index 92d9ea2f2c7..c6a304b7937 100644
--- a/media-sound/mp32ogg/mp32ogg-0.11-r6.ebuild
+++ b/media-sound/mp32ogg/mp32ogg-0.11-r7.ebuild
@@ -1,30 +1,28 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
DESCRIPTION="A perl script to convert MP3 files to Ogg Vorbis files"
HOMEPAGE="http://faceprint.com/code/"
SRC_URI="ftp://ftp.faceprint.com/pub/software/scripts/mp32ogg"
+S="${WORKDIR}"
LICENSE="Artistic"
SLOT="0"
KEYWORDS="amd64 x86"
-IUSE=""
-RDEPEND="media-sound/mpg123
+RDEPEND="
dev-perl/MP3-Info
dev-perl/String-ShellQuote
+ media-sound/mpg123
media-sound/vorbis-tools"
-DEPEND=""
-
-S=${WORKDIR}
PATCHES=(
- "${FILESDIR}/${P}-r4-mpg321.patch"
- "${FILESDIR}/${P}-r4-quality.patch"\
- "${FILESDIR}/${P}-r5-german_umlaut.patch"
- "${FILESDIR}/${P}-r6-force-filename-stringification.patch"
+ "${FILESDIR}"/${P}-r4-mpg321.patch
+ "${FILESDIR}"/${P}-r4-quality.patch
+ "${FILESDIR}"/${P}-r5-german_umlaut.patch
+ "${FILESDIR}"/${P}-r6-force-filename-stringification.patch
)
src_unpack() {
diff --git a/media-sound/mp3blaster/mp3blaster-3.2.6.ebuild b/media-sound/mp3blaster/mp3blaster-3.2.6-r1.ebuild
index 396b5720266..7f2f19ec018 100644
--- a/media-sound/mp3blaster/mp3blaster-3.2.6.ebuild
+++ b/media-sound/mp3blaster/mp3blaster-3.2.6-r1.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
inherit autotools
@@ -13,18 +13,19 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha amd64 arm ppc ppc64 ~riscv sparc x86"
IUSE="lirc oss +sdl sid vorbis"
+REQUIRED_USE="|| ( oss sdl )"
RDEPEND="
- sys-libs/ncurses:0=
+ sys-libs/ncurses:=
lirc? ( app-misc/lirc )
sdl? ( media-libs/libsdl )
sid? ( media-libs/libsidplay:1 )
vorbis? ( media-libs/libvorbis )"
-DEPEND="${RDEPEND}
- x11-misc/imake
+DEPEND="
+ ${RDEPEND}
oss? ( virtual/os-headers )"
+BDEPEND="x11-misc/imake"
-REQUIRED_USE="|| ( oss sdl )"
PATCHES=(
"${FILESDIR}"/${PN}-3.2.5-fix-c++14.patch
"${FILESDIR}"/${PN}-3.2.5-fix-build-system.patch
@@ -57,8 +58,8 @@ src_install() {
default
# relocate everything except commands.txt because it's used by src/main.cc
- mv -vf "${ED%/}"/usr/share/{${PN}/{charmap,sample.*},doc/${PF}} || die
+ mv -vf "${ED}"/usr/share/{${PN}/{charmap,sample.*},doc/${PF}} || die
# file collision with media-sound/splay
- mv -vf "${ED%/}"/usr/bin/splay{,_mp3blaster} || die
+ mv -vf "${ED}"/usr/bin/splay{,_mp3blaster} || die
}
diff --git a/media-sound/mp3val/files/mp3val-0.1.8-makefile.patch b/media-sound/mp3val/files/mp3val-0.1.8-makefile.patch
new file mode 100644
index 00000000000..8da20930602
--- /dev/null
+++ b/media-sound/mp3val/files/mp3val-0.1.8-makefile.patch
@@ -0,0 +1,12 @@
+--- a/Makefile.linux
++++ b/Makefile.linux
+@@ -1,7 +1,7 @@
+-CXXFLAGS=-Wall -O2
++CXXFLAGS += -Wall
+
+ mp3val: main.o mpegparse.o out.o report.o crossapi.o crc.o
+- $(CXX) $(CXXFLAGS) $^ -o $@
++ $(CXX) $(LDFLAGS) $(CXXFLAGS) $^ -o $@
+
+ clean:
+ rm -f mp3val
diff --git a/media-sound/mp3val/files/mp3val-0.1.8-open.patch b/media-sound/mp3val/files/mp3val-0.1.8-open.patch
index 2b844c1fac1..499e2327238 100644
--- a/media-sound/mp3val/files/mp3val-0.1.8-open.patch
+++ b/media-sound/mp3val/files/mp3val-0.1.8-open.patch
@@ -1,11 +1,11 @@
---- mp3val-0.1.8-src/crossapi.cpp.orig 2010-05-03 10:45:53.000000000 -0700
-+++ mp3val-0.1.8-src/crossapi.cpp 2017-02-19 23:38:21.000000000 -0000
+--- a/crossapi.cpp
++++ b/crossapi.cpp
@@ -241,7 +241,7 @@
- //Moving failed due to different logical drives of source and destination. Let's copy:
- id=open(szOldName,O_RDONLY);
- if(id==-1) return 0;
-- od=open(szNewName,O_WRONLY|O_CREAT|O_TRUNC);
-+ od=open(szNewName, O_WRONLY|O_CREAT|O_TRUNC, S_IRUSR|S_IWUSR|S_IRGRP|S_IROTH);
- if(od==-1) {
- close(id);
- return 0;
+ //Moving failed due to different logical drives of source and destination. Let's copy:
+ id=open(szOldName,O_RDONLY);
+ if(id==-1) return 0;
+- od=open(szNewName,O_WRONLY|O_CREAT|O_TRUNC);
++ od=open(szNewName, O_WRONLY|O_CREAT|O_TRUNC, S_IRUSR|S_IWUSR|S_IRGRP|S_IROTH);
+ if(od==-1) {
+ close(id);
+ return 0;
diff --git a/media-sound/mp3val/mp3val-0.1.8.ebuild b/media-sound/mp3val/mp3val-0.1.8-r1.ebuild
index f4b74ed3c03..6a51bfd27fd 100644
--- a/media-sound/mp3val/mp3val-0.1.8.ebuild
+++ b/media-sound/mp3val/mp3val-0.1.8-r1.ebuild
@@ -1,29 +1,26 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-inherit edos2unix
+EAPI=8
+
+inherit toolchain-funcs
DESCRIPTION="Validate and fix MPEG audio files"
HOMEPAGE="http://mp3val.sourceforge.net/"
SRC_URI="mirror://sourceforge/mp3val/${P}-src.tar.gz"
+S="${WORKDIR}/${P}-src"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-S="${WORKDIR}/${P}-src"
+KEYWORDS="amd64 ~x86"
PATCHES=(
- "${FILESDIR}/${P}-open.patch"
+ "${FILESDIR}"/${P}-open.patch
+ "${FILESDIR}"/${P}-makefile.patch
)
-src_prepare() {
- edos2unix "${S}"/{*.{cpp,h},Makefile*}
- chmod a-x "${S}"/*
- sed -i -e '/^C.*FLAGS.*=/d' "${S}"/Makefile.linux
- default
+src_configure() {
+ tc-export CXX
}
src_compile() {
@@ -32,6 +29,8 @@ src_compile() {
src_install() {
dobin mp3val
- dohtml manual.html
+
dodoc changelog.txt
+ docinto html
+ dodoc manual.html
}
diff --git a/media-sound/mpc/Manifest b/media-sound/mpc/Manifest
index a435c2b92a5..4fa3905b1b9 100644
--- a/media-sound/mpc/Manifest
+++ b/media-sound/mpc/Manifest
@@ -1,2 +1 @@
-DIST mpc-0.33.tar.xz 45044 BLAKE2B 220848e088964297fbaddeedf61d5ddc90386df360a6af81b2d3753517f7ee36ff3d9462242f38b17c991996927a7d1fc253e1006253f2f875023ddb75a800c2 SHA512 d3247dfb54ac3c95caf5666088968a952b33eb7e8f941bca4f3715603839cf5a1bc5300488c78fdce6e38f612b243f2252ea682b8d0fec9f230acd760bf3560c
DIST mpc-0.34.tar.xz 47940 BLAKE2B 709f54ceebd66f703e5b1bf6ff8deb890e484fdc29c0b2198922763e347caac89d6eec5f74101f9fa860436e7493e2b02cc6b1b26e800e783546fe5a0c6e0d8f SHA512 d43d5547134ffb24f2a2972882f6e264c1011a94d1033369d329487f59414d32d9842835afdd05da96fd8ed28f823d2ae2f46d8d8d24b68f3695badca2a9bbb2
diff --git a/media-sound/mpc/mpc-0.33.ebuild b/media-sound/mpc/mpc-0.33.ebuild
deleted file mode 100644
index e3d7fa17a19..00000000000
--- a/media-sound/mpc/mpc-0.33.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit bash-completion-r1 meson
-
-DESCRIPTION="Commandline client for Music Player Daemon (media-sound/mpd)"
-HOMEPAGE="https://www.musicpd.org https://github.com/MusicPlayerDaemon/mpc"
-SRC_URI="https://www.musicpd.org/download/${PN}/${PV%.*}/${P}.tar.xz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 arm ppc ppc64 ~riscv ~sparc x86"
-IUSE="doc iconv test"
-
-BDEPEND="
- virtual/pkgconfig
- doc? ( dev-python/sphinx )
- iconv? ( virtual/libiconv )
- test? ( dev-libs/check )
-"
-DEPEND="media-libs/libmpdclient"
-RDEPEND="${DEPEND}"
-
-RESTRICT="!test? ( test )"
-
-PATCHES=( "${FILESDIR}/${PN}-0.31-nodoc.patch" )
-
-src_prepare() {
- default
-
- # use correct docdir
- sed -e "/install_dir:.*contrib/s/meson.project_name()/'${PF}'/" \
- -i meson.build || die
-
- # use correct (html) docdir
- sed -e "/install_dir:.*doc/s/meson.project_name()/'${PF}'/" \
- -i doc/meson.build || die
-}
-
-src_configure() {
- local emesonargs=(
- -Ddocumentation=$(usex doc enabled disabled)
- -Diconv=$(usex iconv enabled disabled)
- -Dtest=$(usex test true false)
- )
- meson_src_configure
-}
-
-src_install() {
- meson_src_install
- newbashcomp contrib/mpc-completion.bash mpc
-}
diff --git a/media-sound/mpc/mpc-0.34.ebuild b/media-sound/mpc/mpc-0.34.ebuild
index d62d147ec18..1a68200c9ce 100644
--- a/media-sound/mpc/mpc-0.34.ebuild
+++ b/media-sound/mpc/mpc-0.34.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -11,7 +11,7 @@ SRC_URI="https://www.musicpd.org/download/${PN}/${PV%.*}/${P}.tar.xz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~riscv ~sparc ~x86"
+KEYWORDS="amd64 arm ~arm64 ppc ppc64 ~riscv ~sparc x86"
IUSE="doc iconv test"
BDEPEND="
diff --git a/media-sound/mpd/Manifest b/media-sound/mpd/Manifest
index f1ee6b55f7f..7eedc53184d 100644
--- a/media-sound/mpd/Manifest
+++ b/media-sound/mpd/Manifest
@@ -3,3 +3,4 @@ DIST mpd-0.22.3.tar.xz 726356 BLAKE2B a821e9fed56c3ad625d155057867747d2c883dd90d
DIST mpd-0.23.5.tar.xz 770700 BLAKE2B 91f0d37bca0632a414083f6ecf8838ba5dc4ef4965692b14e56587d3d145140f61bcc120fe4b2bf83eb41f2a7e085da4d999efc19ca9717d2552d92fc6359c65 SHA512 3a870e79bb82c9e8877958d271e933daa3dd970a4510aff4aeea91feab521d7927cd59c7f1ea16a36e84ff879e4f24e4347602ac449c5da31853acb5a3b46f34
DIST mpd-0.23.6.tar.xz 770812 BLAKE2B 5ccb4a7c06c4317e3285846a261438bdcc10db5eaf71fcba969bcae8321ca50bb26fe9317e23e38eca1c4a8785015596064d5bfc692bf66f8007d0d2a1b71cbb SHA512 1595fcc53a67f1a68b0c0516697d242da53b91626e37bc2f49095add78eb497a52c67c961a421f20b40f3c57a571557a76559a212838de2a3ec4aec6c7a3288d
DIST mpd-0.23.7.tar.xz 771992 BLAKE2B 2c75196c37eb8d075cca2881bb7ed10e434a071d3c64bb7cdb3bb96dfea74c30de2dce5bfdbc51da945df325d9f278cdf8dd03b7ba07c0ad51cea50971f4a143 SHA512 2a6b3eb2c8b61a22861ae75fe2f62c8ec6cd391f029438577127e309b910e99d7b735e40afae96d52ed4f161195a0ce7cb89cc51ad45df5a18e04736c16ce3a6
+DIST mpd-0.23.8.tar.xz 773280 BLAKE2B fd2dd32bc935cb78d9204bccea6ed52f5131ae4645efca91323db930373a5fa14115a767daa11d670aaf46e218c52578d155b9a463ed5aae007e1f55d0208d3a SHA512 62f7571de29a329b8ef1fc6f7c338125e70895e06fca134eb9ade19635498ec13da00511870bfadabc5a9ccb090c44543d3101361ffe109e4fadce66435b37ab
diff --git a/media-sound/mpd/mpd-0.23.7.ebuild b/media-sound/mpd/mpd-0.23.7.ebuild
index 003f74fa7c6..a0d2135688f 100644
--- a/media-sound/mpd/mpd-0.23.7.ebuild
+++ b/media-sound/mpd/mpd-0.23.7.ebuild
@@ -11,7 +11,7 @@ SRC_URI="https://www.musicpd.org/download/${PN}/${PV%.*}/${P}.tar.xz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~amd64 ~arm ~ppc ~riscv ~x86"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~riscv ~x86"
IUSE="+alsa ao +audiofile bzip2 cdio chromaprint +cue +curl doc +dbus
+eventfd expat faad +ffmpeg +fifo flac fluidsynth gme +icu +id3tag +inotify
+ipv6 jack lame libmpdclient libsamplerate libsoxr +mad mikmod mms
diff --git a/media-sound/mpd/mpd-0.23.8.ebuild b/media-sound/mpd/mpd-0.23.8.ebuild
new file mode 100644
index 00000000000..a0d2135688f
--- /dev/null
+++ b/media-sound/mpd/mpd-0.23.8.ebuild
@@ -0,0 +1,293 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit flag-o-matic linux-info meson systemd xdg
+
+DESCRIPTION="The Music Player Daemon (mpd)"
+HOMEPAGE="https://www.musicpd.org https://github.com/MusicPlayerDaemon/MPD"
+SRC_URI="https://www.musicpd.org/download/${PN}/${PV%.*}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~riscv ~x86"
+IUSE="+alsa ao +audiofile bzip2 cdio chromaprint +cue +curl doc +dbus
+ +eventfd expat faad +ffmpeg +fifo flac fluidsynth gme +icu +id3tag +inotify
+ +ipv6 jack lame libmpdclient libsamplerate libsoxr +mad mikmod mms
+ modplug mpg123 musepack +network nfs openal openmpt opus oss pipe pipewire pulseaudio qobuz
+ recorder samba selinux sid signalfd snapcast sndfile sndio soundcloud sqlite systemd
+ test twolame udisks unicode vorbis wavpack webdav wildmidi upnp
+ zeroconf zip zlib"
+
+OUTPUT_PLUGINS="alsa ao fifo jack network openal oss pipe pipewire pulseaudio snapcast sndio recorder"
+DECODER_PLUGINS="audiofile faad ffmpeg flac fluidsynth mad mikmod
+ modplug mpg123 musepack opus openmpt flac sid vorbis wavpack wildmidi"
+ENCODER_PLUGINS="audiofile flac lame twolame vorbis"
+
+REQUIRED_USE="
+ || ( ${OUTPUT_PLUGINS} )
+ || ( ${DECODER_PLUGINS} )
+ network? ( || ( ${ENCODER_PLUGINS} ) )
+ recorder? ( || ( ${ENCODER_PLUGINS} ) )
+ qobuz? ( curl soundcloud )
+ soundcloud? ( curl qobuz )
+ udisks? ( dbus )
+ upnp? ( curl expat )
+ webdav? ( curl expat )
+"
+
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ acct-user/mpd
+ dev-libs/libfmt:=
+ dev-libs/libpcre2
+ media-libs/libogg
+ sys-libs/liburing:=
+ alsa? (
+ media-libs/alsa-lib
+ media-sound/alsa-utils
+ )
+ ao? ( media-libs/libao:=[alsa?,pulseaudio?] )
+ audiofile? ( media-libs/audiofile:= )
+ bzip2? ( app-arch/bzip2 )
+ cdio? (
+ dev-libs/libcdio:=
+ dev-libs/libcdio-paranoia
+ )
+ chromaprint? ( media-libs/chromaprint )
+ curl? ( net-misc/curl )
+ dbus? ( sys-apps/dbus )
+ doc? ( dev-python/sphinx )
+ expat? ( dev-libs/expat )
+ faad? ( media-libs/faad2 )
+ ffmpeg? ( media-video/ffmpeg:0= )
+ flac? ( media-libs/flac )
+ fluidsynth? ( media-sound/fluidsynth )
+ gme? ( >=media-libs/game-music-emu-0.6.0_pre20120802 )
+ icu? (
+ dev-libs/icu:=
+ virtual/libiconv
+ )
+ id3tag? ( media-libs/libid3tag:= )
+ jack? ( virtual/jack )
+ lame? ( network? ( media-sound/lame ) )
+ libmpdclient? ( media-libs/libmpdclient )
+ libsamplerate? ( media-libs/libsamplerate )
+ libsoxr? ( media-libs/soxr )
+ mad? ( media-libs/libmad )
+ mikmod? ( media-libs/libmikmod )
+ mms? ( media-libs/libmms )
+ modplug? ( media-libs/libmodplug )
+ mpg123? ( media-sound/mpg123 )
+ musepack? ( media-sound/musepack-tools )
+ network? ( >=media-libs/libshout-2.4.0 )
+ nfs? ( net-fs/libnfs )
+ openal? ( media-libs/openal )
+ openmpt? ( media-libs/libopenmpt )
+ opus? ( media-libs/opus )
+ pulseaudio? ( media-sound/pulseaudio )
+ pipewire? ( media-video/pipewire:= )
+ qobuz? ( dev-libs/libgcrypt:0 )
+ samba? ( net-fs/samba )
+ selinux? ( sec-policy/selinux-mpd )
+ sid? ( || (
+ media-libs/libsidplay:2
+ media-libs/libsidplayfp
+ ) )
+ snapcast? ( media-sound/snapcast )
+ sndfile? ( media-libs/libsndfile )
+ sndio? ( media-sound/sndio )
+ soundcloud? ( >=dev-libs/yajl-2:= )
+ sqlite? ( dev-db/sqlite:3 )
+ systemd? ( sys-apps/systemd:= )
+ twolame? ( media-sound/twolame )
+ udisks? ( sys-fs/udisks:2 )
+ upnp? ( net-libs/libupnp:0 )
+ vorbis? ( media-libs/libvorbis )
+ wavpack? ( media-sound/wavpack )
+ wildmidi? ( media-sound/wildmidi )
+ zeroconf? ( net-dns/avahi[dbus] )
+ zip? ( dev-libs/zziplib:= )
+ zlib? ( sys-libs/zlib:= )"
+
+DEPEND="${RDEPEND}
+ >=dev-libs/boost-1.68:=
+ test? ( dev-cpp/gtest )"
+
+BDEPEND="virtual/pkgconfig"
+
+pkg_setup() {
+ if use eventfd; then
+ CONFIG_CHECK+=" ~EVENTFD"
+ ERROR_EVENTFD="${P} requires eventfd in-kernel support."
+ fi
+
+ if use signalfd; then
+ CONFIG_CHECK+=" ~SIGNALFD"
+ ERROR_SIGNALFD="${P} requires signalfd in-kernel support."
+ fi
+
+ if use inotify; then
+ CONFIG_CHECK+=" ~INOTIFY_USER"
+ ERROR_INOTIFY_USER="${P} requires inotify in-kernel support."
+ fi
+
+ if use eventfd || use signalfd || use inotify; then
+ linux-info_pkg_setup
+ fi
+
+ elog "If you will be starting mpd via /etc/init.d/mpd, please make sure that MPD's pid_file is _set_."
+}
+
+src_prepare() {
+ sed -i \
+ -e 's:^#filesystem_charset.*$:filesystem_charset "UTF-8":' \
+ -e 's:^#user.*$:user "mpd":' \
+ -e 's:^#bind_to_address.*any.*$:bind_to_address "localhost":' \
+ -e 's:^#bind_to_address.*$:bind_to_address "/var/lib/mpd/socket":' \
+ -e 's:^#music_directory.*$:music_directory "/var/lib/mpd/music":' \
+ -e 's:^#playlist_directory.*$:playlist_directory "/var/lib/mpd/playlists":' \
+ -e 's:^#db_file.*$:db_file "/var/lib/mpd/database":' \
+ -e 's:^#log_file.*$:log_file "/var/lib/mpd/log":' \
+ -e 's:^#pid_file.*$:pid_file "/var/lib/mpd/pid":' \
+ -e 's:^#state_file.*$:state_file "/var/lib/mpd/state":' \
+ doc/mpdconf.example || die
+ default
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_feature bzip2)
+ $(meson_feature cdio cdio_paranoia)
+ $(meson_feature chromaprint)
+ $(meson_use cue)
+ $(meson_feature curl)
+ $(meson_feature dbus)
+ $(meson_use eventfd)
+ $(meson_feature expat)
+ $(meson_feature icu)
+ $(meson_feature id3tag)
+ $(meson_use inotify)
+ $(meson_feature ipv6)
+ $(meson_feature cdio iso9660)
+ $(meson_feature libmpdclient)
+ $(meson_feature libsamplerate)
+ $(meson_feature mms)
+ $(meson_feature nfs)
+ $(meson_use signalfd)
+ $(meson_feature samba smbclient)
+ $(meson_feature libsoxr soxr)
+ $(meson_feature sqlite)
+ $(meson_feature systemd)
+ $(meson_use test)
+ $(meson_feature udisks)
+ -Dupnp=$(usex upnp pupnp disabled)
+ $(meson_feature webdav)
+ -Dzeroconf=$(usex zeroconf avahi disabled)
+ $(meson_feature zlib)
+ $(meson_feature zip zzip)
+ )
+
+ emesonargs+=(
+ $(meson_feature alsa)
+ $(meson_feature ao)
+ $(meson_use fifo)
+ $(meson_feature jack)
+ $(meson_feature openal)
+ $(meson_feature oss)
+ $(meson_use pipe)
+ $(meson_feature pipewire)
+ $(meson_feature pulseaudio pulse)
+ $(meson_use recorder)
+ $(meson_use snapcast)
+ $(meson_feature sndio)
+ )
+
+ if use samba || use upnp; then
+ emesonargs+=( -Dneighbor=true )
+ fi
+
+ append-lfs-flags
+ append-ldflags "-L${ESYSROOT}/usr/$(get_libdir)/sidplay/builders"
+
+ if use network; then
+ emesonargs+=(
+ -Dshine=disabled
+ -Dshout=enabled
+ $(meson_feature vorbis vorbisenc)
+ -Dhttpd=true
+ $(meson_feature lame)
+ $(meson_feature twolame)
+ $(meson_use audiofile wave_encoder)
+ )
+ fi
+
+ emesonargs+=(
+ # media-libs/adplug is not packaged anymore
+ -Dadplug=disabled
+ $(meson_feature audiofile)
+ $(meson_feature faad)
+ $(meson_feature ffmpeg)
+ $(meson_feature flac)
+ $(meson_feature fluidsynth)
+ $(meson_feature gme)
+ $(meson_feature mad)
+ $(meson_feature mikmod)
+ $(meson_feature modplug)
+ $(meson_feature musepack mpcdec)
+ $(meson_feature mpg123)
+ $(meson_feature openmpt)
+ $(meson_feature opus)
+ $(meson_feature sid sidplay)
+ $(meson_feature sndfile)
+ $(meson_feature vorbis)
+ $(meson_feature wavpack)
+ $(meson_feature wildmidi)
+ $(meson_feature qobuz)
+ $(meson_feature soundcloud)
+
+ --libdir="/usr/$(get_libdir)"
+ $(meson_feature doc documentation)
+ -Dsolaris_output=disabled
+
+ -Ddatabase=true
+ -Ddsd=true
+ -Dio_uring=enabled
+ -Dtcp=true
+
+ -Dsystemd_system_unit_dir="$(systemd_get_systemunitdir)"
+ -Dsystemd_user_unit_dir="$(systemd_get_userunitdir)"
+
+ $(meson_feature icu iconv)
+ )
+
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+
+ insinto /etc
+ newins doc/mpdconf.example mpd.conf
+
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}"/${PN}-0.21.1.logrotate ${PN}
+
+ newinitd "${FILESDIR}"/${PN}-0.21.4.init ${PN}
+
+ if use unicode; then
+ sed -i -e 's:^#filesystem_charset.*$:filesystem_charset "UTF-8":' \
+ "${ED}"/etc/mpd.conf || die "sed failed"
+ fi
+
+ keepdir /var/lib/mpd
+ keepdir /var/lib/mpd/music
+ keepdir /var/lib/mpd/playlists
+
+ rm -r "${ED}"/usr/share/doc/mpd || die
+
+ fowners mpd:audio -R /var/lib/mpd
+
+}
diff --git a/media-sound/mpdscribble/Manifest b/media-sound/mpdscribble/Manifest
index 48a09394238..69cedcded4d 100644
--- a/media-sound/mpdscribble/Manifest
+++ b/media-sound/mpdscribble/Manifest
@@ -1,3 +1 @@
-DIST mpdscribble-0.22.tar.bz2 116981 BLAKE2B 13b15ca9e49faa3e5d254bc2864de4a0c409d8767db586def3a7bee415c67f84ddffbd7fce6093afe4aba5d5e66db8182aed52d9a141bebf4094a400f2ababe3 SHA512 bedd93392a4d5a0609dcaf7aefeeff3851f3084da8c34a4fc1f8fde51c2ba10b8370ac52cc8d55f0c9a96fffed975827a0935087c2c51880b7bfef8d79182dc8
-DIST mpdscribble-0.23.tar.xz 46624 BLAKE2B 47c59a4b2936b7990bb2d8563422c553d1e08b39a09a873fae1ad0215bd1fcc0dbcaa69e62eab9332530717a200a52295018a578e3c615e83d68d84564060402 SHA512 f924076a8aa201f67ba81e72a44d3dd1c31618bd87e4f75f6b63f7b3814fa08f6ef4f7964b1d518c5f8b68a1f8ba88f867c08ed8b0387157eec8e9f97eb0b825
DIST mpdscribble-0.24.tar.xz 69856 BLAKE2B 84143ed7f6978aff32fa759bbe90c934ba5c58df294d375921ffb1cd45de13ecd867fb832940088228fdad4c09948cd82c8dfe9b7fe77d6652743d522bfde8b7 SHA512 cca57f54f69ec1c870805cc58057e6325b6f5897370c315dcd6a64c5dd28ac07fdbddaa8b56f8c1fd88e71d27505f1a87decd68fbdff1f3fe1eaadec8ae80dae
diff --git a/media-sound/mpdscribble/files/mpdscribble-0.23-gcc12-time.patch b/media-sound/mpdscribble/files/mpdscribble-0.23-gcc12-time.patch
new file mode 100644
index 00000000000..7a6a247d73d
--- /dev/null
+++ b/media-sound/mpdscribble/files/mpdscribble-0.23-gcc12-time.patch
@@ -0,0 +1,37 @@
+https://github.com/MusicPlayerDaemon/mpdscribble/pull/42
+
+From: Sam James <sam@gentoo.org>
+Date: Sun, 12 Jun 2022 11:11:08 +0100
+Subject: [PATCH] Fix build with GCC 12 (missing <time.h> include)
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+Fixes the following build failure with GCC 12:
+```
+FAILED: mpdscribble.p/src_Log.cxx.o
+[...]
+../mpdscribble-0.24/src/Log.cxx: In function ‘const char* log_date()’:
+../mpdscribble-0.24/src/Log.cxx:48:13: error: ‘time’ was not declared in this scope
+ 48 | t = time(nullptr);
+ | ^~~~
+../mpdscribble-0.24/src/Log.cxx:49:15: error: ‘localtime’ was not declared in this scope
+ 49 | tmp = localtime(&t);
+ | ^~~~~~~~~
+../mpdscribble-0.24/src/Log.cxx:55:14: error: ‘strftime’ was not declared in this scope
+ 55 | if (!strftime(buf, sizeof(buf), "%Y-%m-%dT%H:%M:%S%z", tmp)) {
+ | ^~~~~~~~
+```
+
+Bug: https://bugs.gentoo.org/851513
+--- a/src/Log.cxx
++++ b/src/Log.cxx
+@@ -29,6 +29,7 @@
+ #include <stdio.h>
+ #include <string.h>
+ #include <errno.h>
++#include <time.h>
+
+ #ifdef HAVE_SYSLOG
+ #include <syslog.h>
+
diff --git a/media-sound/mpdscribble/mpdscribble-0.22.ebuild b/media-sound/mpdscribble/mpdscribble-0.22.ebuild
deleted file mode 100644
index 29b2c66fd7d..00000000000
--- a/media-sound/mpdscribble/mpdscribble-0.22.ebuild
+++ /dev/null
@@ -1,31 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-DESCRIPTION="An MPD client that submits information to Audioscrobbler"
-HOMEPAGE="https://www.musicpd.org/clients/mpdscribble/"
-SRC_URI="https://www.musicpd.org/download/${PN}/${PV}/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ~ppc x86"
-IUSE="+curl"
-
-RDEPEND="dev-libs/glib:2
- media-libs/libmpdclient
- curl? ( net-misc/curl )
- !curl? ( net-libs/libsoup:2.4 )"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-
-src_configure() {
- econf \
- --with-http-client=$(usex curl curl soup)
-}
-
-src_install() {
- default
- newinitd "${FILESDIR}/mpdscribble.rc" mpdscribble
- keepdir /var/cache/mpdscribble
-}
diff --git a/media-sound/mpdscribble/mpdscribble-0.23.ebuild b/media-sound/mpdscribble/mpdscribble-0.23.ebuild
deleted file mode 100644
index 31a25f8e410..00000000000
--- a/media-sound/mpdscribble/mpdscribble-0.23.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit meson systemd
-
-DESCRIPTION="An MPD client that submits information to Audioscrobbler"
-HOMEPAGE="
- https://www.musicpd.org/clients/mpdscribble/
- https://github.com/MusicPlayerDaemon/mpdscribble
-"
-SRC_URI="https://www.musicpd.org/download/${PN}/${PV}/${P}.tar.xz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-
-RDEPEND="
- dev-libs/boost
- dev-libs/libgcrypt:=
- media-libs/libmpdclient
- net-misc/curl
-"
-
-DEPEND="${RDEPEND}"
-
-DOCS=( AUTHORS COPYING NEWS README.rst )
-
-PATCHES=(
- "${FILESDIR}"/${PN}-0.23-Unconditionally-generate-systemd-unit-files.patch
- "${FILESDIR}"/${PN}-0.23-Don-t-install-AUTHORS-COPYING-NEWS-README.rst.patch
-)
-
-src_install() {
- meson_src_install
- newinitd "${FILESDIR}/mpdscribble.rc" mpdscribble
- keepdir /var/cache/mpdscribble
-
- systemd_dounit "${BUILD_DIR}"/systemd/system/"${PN}".service
- systemd_douserunit "${BUILD_DIR}"/systemd/user/"${PN}".service
-}
diff --git a/media-sound/mpdscribble/mpdscribble-0.24.ebuild b/media-sound/mpdscribble/mpdscribble-0.24.ebuild
index 9265bd6c5a2..69429a0bcd5 100644
--- a/media-sound/mpdscribble/mpdscribble-0.24.ebuild
+++ b/media-sound/mpdscribble/mpdscribble-0.24.ebuild
@@ -14,7 +14,7 @@ SRC_URI="https://www.musicpd.org/download/${PN}/${PV}/${P}.tar.xz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
+KEYWORDS="amd64 ~ppc x86"
RDEPEND="
dev-libs/boost
@@ -30,6 +30,7 @@ DOCS=( AUTHORS COPYING NEWS README.rst )
PATCHES=(
"${FILESDIR}"/${PN}-0.23-Unconditionally-generate-systemd-unit-files.patch
"${FILESDIR}"/${PN}-0.23-Don-t-install-AUTHORS-COPYING-NEWS-README.rst.patch
+ "${FILESDIR}"/${PN}-0.23-gcc12-time.patch
)
src_install() {
diff --git a/media-sound/mpg123/Manifest b/media-sound/mpg123/Manifest
index 5e4d7b578df..c6a7b9bed3e 100644
--- a/media-sound/mpg123/Manifest
+++ b/media-sound/mpg123/Manifest
@@ -1 +1,3 @@
-DIST mpg123-1.29.3.tar.bz2 1069979 BLAKE2B d01a8d77ffb6c344592d1b90026ee25ae12eb2e063446e88370e0aa508705a843b987f1a400351b5ed87d211251057b7b31a2e653401b800fe9871ac2a5756fc SHA512 0d8db63f9bae1507887bc5241a56abccfeb767b7ba8362eb0fce9de2f63369e57fdd6f25a953f8ef5f9ead4f400237db51914816e278566fdf8e6f205ebca5d6
+DIST mpg123-1.30.0.tar.bz2 1091578 BLAKE2B 6acdbfcc1119507c63d9da95afc747c43698ef385368b417e1716eadde6b74fc0618c3aa03a495e4415b5f14aef26d85f98832b3ba5f5bd17083651808a7f53b SHA512 cf508bdff1f75320c7c4d77653ba8170cc0dd8c565390cfb6ba745ce3853816071c86becff3ce304b80481d220cac2113ad244930832ccc78d3d8da74112562f
+DIST mpg123-1.30.1.tar.bz2 1092735 BLAKE2B 8ce6b964acf307ce4358b33468b7560e53024df2551a17602032260ac799d6c1ff0512cfb5fa6a59e3983c054fa82b1520f8329502fa4c351b94f66f9ccdee13 SHA512 098fcecc6a570e32ccd164b62428417186265905d148d009ea592c948a02027d67fc43e015ece21cf900008f31bbe35b3ec770faba5ae0b914db0022cb6b37fd
+DIST mpg123-1.30.2.tar.bz2 1093138 BLAKE2B 03247431bf58886c7a942fb00f11d7e82cc12f95cb30c95fc01bb986e32d8245349dba6fd2a0ada33918542ce8944037f9899512cc6ffa013b884a009dbe8cef SHA512 e2e9279799f3917c9ecbcb2ccdc2c246bda50317dbfdd7ba3d56281b7b4f5b1928442fc8e712fbf90543159afc703d1ab8ceb7e3c1c038e1547b82d1616bdc82
diff --git a/media-sound/mpg123/mpg123-1.29.3.ebuild b/media-sound/mpg123/mpg123-1.30.0.ebuild
index e82d3a628fb..e82d3a628fb 100644
--- a/media-sound/mpg123/mpg123-1.29.3.ebuild
+++ b/media-sound/mpg123/mpg123-1.30.0.ebuild
diff --git a/media-sound/mpg123/mpg123-1.30.1.ebuild b/media-sound/mpg123/mpg123-1.30.1.ebuild
new file mode 100644
index 00000000000..1c6f82a04ca
--- /dev/null
+++ b/media-sound/mpg123/mpg123-1.30.1.ebuild
@@ -0,0 +1,108 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit flag-o-matic toolchain-funcs libtool multilib-minimal
+
+DESCRIPTION="a realtime MPEG 1.0/2.0/2.5 audio player for layers 1, 2 and 3"
+HOMEPAGE="https://www.mpg123.org/"
+SRC_URI="https://www.mpg123.org/download/${P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~loong ~mips ppc ppc64 ~riscv sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~x86-solaris"
+IUSE="cpu_flags_x86_3dnow cpu_flags_x86_3dnowext cpu_flags_ppc_altivec alsa coreaudio int-quality ipv6 jack cpu_flags_x86_mmx nas oss portaudio pulseaudio sdl cpu_flags_x86_sse"
+
+# No MULTILIB_USEDEP here since we only build libmpg123 for non native ABIs.
+# Note: build system prefers libsdl2 > libsdl. We could in theory add both
+# but it's tricky when it comes to handling switching between them properly.
+# We'd need a USE flag for both sdl1 and sdl2 and to make them clash.
+RDEPEND="
+ dev-libs/libltdl:0
+ alsa? ( media-libs/alsa-lib )
+ jack? ( virtual/jack )
+ nas? ( media-libs/nas )
+ portaudio? ( media-libs/portaudio )
+ pulseaudio? ( media-sound/pulseaudio )
+ sdl? ( media-libs/libsdl2 )"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ sys-devel/libtool
+ virtual/pkgconfig
+"
+IDEPEND="app-eselect/eselect-mpg123"
+
+DOCS=( AUTHORS ChangeLog NEWS NEWS.libmpg123 README )
+
+src_prepare() {
+ default
+ elibtoolize # for Darwin bundles
+}
+
+multilib_src_configure() {
+ local _audio=dummy
+ local _output=dummy
+ local _cpu=generic_fpu
+
+ # Build fails without -D_GNU_SOURCE like this:
+ # error: ‘struct hostent’ has no member named ‘h_addr’
+ append-cflags -D_GNU_SOURCE
+
+ if $(multilib_is_native_abi) ; then
+ local flag
+ for flag in nas portaudio sdl oss jack alsa pulseaudio coreaudio; do
+ if use ${flag}; then
+ _audio+=" ${flag/pulseaudio/pulse}"
+ _output=${flag/pulseaudio/pulse}
+ fi
+ done
+ fi
+
+ use cpu_flags_ppc_altivec && _cpu=altivec
+
+ if [[ $(tc-arch) == amd64 || ${ARCH} == x64-* ]]; then
+ use cpu_flags_x86_sse && _cpu=x86-64
+ elif use x86 && gcc-specs-pie ; then
+ # Don't use any mmx, 3dnow, sse and 3dnowext
+ # bug #164504
+ _cpu=generic_fpu
+ else
+ use cpu_flags_x86_mmx && _cpu=mmx
+ use cpu_flags_x86_3dnow && _cpu=3dnow
+ use cpu_flags_x86_sse && _cpu=x86
+ use cpu_flags_x86_3dnowext && _cpu=x86
+ fi
+
+ local myconf=(
+ --with-optimization=0
+ --with-audio="${_audio}"
+ --with-default-audio=${_output}
+ --with-cpu=${_cpu}
+ --enable-network
+ $(use_enable ipv6)
+ --enable-int-quality=$(usex int-quality)
+ )
+
+ multilib_is_native_abi || myconf+=( --disable-modules )
+
+ ECONF_SOURCE="${S}" econf "${myconf[@]}"
+
+ if ! $(multilib_is_native_abi) ; then
+ sed -i -e 's:src doc:src/libmpg123:' Makefile || die
+ fi
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ mv "${ED}"/usr/bin/mpg123{,-mpg123}
+ find "${ED}" -type f -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ eselect mpg123 update ifunset
+}
+
+pkg_postrm() {
+ eselect mpg123 update ifunset
+}
diff --git a/media-sound/mpg123/mpg123-1.30.2.ebuild b/media-sound/mpg123/mpg123-1.30.2.ebuild
new file mode 100644
index 00000000000..20182ab1425
--- /dev/null
+++ b/media-sound/mpg123/mpg123-1.30.2.ebuild
@@ -0,0 +1,108 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit flag-o-matic toolchain-funcs libtool multilib-minimal
+
+DESCRIPTION="a realtime MPEG 1.0/2.0/2.5 audio player for layers 1, 2 and 3"
+HOMEPAGE="https://www.mpg123.org/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~x86-solaris"
+IUSE="cpu_flags_x86_3dnow cpu_flags_x86_3dnowext cpu_flags_ppc_altivec alsa coreaudio int-quality ipv6 jack cpu_flags_x86_mmx nas oss portaudio pulseaudio sdl cpu_flags_x86_sse"
+
+# No MULTILIB_USEDEP here since we only build libmpg123 for non native ABIs.
+# Note: build system prefers libsdl2 > libsdl. We could in theory add both
+# but it's tricky when it comes to handling switching between them properly.
+# We'd need a USE flag for both sdl1 and sdl2 and to make them clash.
+RDEPEND="
+ dev-libs/libltdl:0
+ alsa? ( media-libs/alsa-lib )
+ jack? ( virtual/jack )
+ nas? ( media-libs/nas )
+ portaudio? ( media-libs/portaudio )
+ pulseaudio? ( media-sound/pulseaudio )
+ sdl? ( media-libs/libsdl2 )"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ sys-devel/libtool
+ virtual/pkgconfig
+"
+IDEPEND="app-eselect/eselect-mpg123"
+
+DOCS=( AUTHORS ChangeLog NEWS NEWS.libmpg123 README )
+
+src_prepare() {
+ default
+ elibtoolize # for Darwin bundles
+}
+
+multilib_src_configure() {
+ local _audio=dummy
+ local _output=dummy
+ local _cpu=generic_fpu
+
+ # Build fails without -D_GNU_SOURCE like this:
+ # error: ‘struct hostent’ has no member named ‘h_addr’
+ append-cflags -D_GNU_SOURCE
+
+ if $(multilib_is_native_abi) ; then
+ local flag
+ for flag in nas portaudio sdl oss jack alsa pulseaudio coreaudio; do
+ if use ${flag}; then
+ _audio+=" ${flag/pulseaudio/pulse}"
+ _output=${flag/pulseaudio/pulse}
+ fi
+ done
+ fi
+
+ use cpu_flags_ppc_altivec && _cpu=altivec
+
+ if [[ $(tc-arch) == amd64 || ${ARCH} == x64-* ]]; then
+ use cpu_flags_x86_sse && _cpu=x86-64
+ elif use x86 && gcc-specs-pie ; then
+ # Don't use any mmx, 3dnow, sse and 3dnowext
+ # bug #164504
+ _cpu=generic_fpu
+ else
+ use cpu_flags_x86_mmx && _cpu=mmx
+ use cpu_flags_x86_3dnow && _cpu=3dnow
+ use cpu_flags_x86_sse && _cpu=x86
+ use cpu_flags_x86_3dnowext && _cpu=x86
+ fi
+
+ local myconf=(
+ --with-optimization=0
+ --with-audio="${_audio}"
+ --with-default-audio=${_output}
+ --with-cpu=${_cpu}
+ --enable-network
+ $(use_enable ipv6)
+ --enable-int-quality=$(usex int-quality)
+ )
+
+ multilib_is_native_abi || myconf+=( --disable-modules )
+
+ ECONF_SOURCE="${S}" econf "${myconf[@]}"
+
+ if ! $(multilib_is_native_abi) ; then
+ sed -i -e 's:src doc:src/libmpg123:' Makefile || die
+ fi
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ mv "${ED}"/usr/bin/mpg123{,-mpg123}
+ find "${ED}" -type f -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ eselect mpg123 update ifunset
+}
+
+pkg_postrm() {
+ eselect mpg123 update ifunset
+}
diff --git a/media-sound/mps-youtube/mps-youtube-0.2.8-r2.ebuild b/media-sound/mps-youtube/mps-youtube-0.2.8-r3.ebuild
index 82b44f71fd6..d7881bc30c9 100644
--- a/media-sound/mps-youtube/mps-youtube-0.2.8-r2.ebuild
+++ b/media-sound/mps-youtube/mps-youtube-0.2.8-r3.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_{7,8,9} )
+PYTHON_COMPAT=( python3_{8..10} )
DISTUTILS_USE_SETUPTOOLS=rdepend
inherit distutils-r1
@@ -12,7 +12,7 @@ if [[ ${PV} == "9999" ]] ; then
inherit git-r3
else
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
- KEYWORDS="~amd64 ~x86"
+ KEYWORDS="amd64 ~x86"
fi
DESCRIPTION="Terminal-based YouTube player and downloader"
diff --git a/media-sound/mps-youtube/mps-youtube-9999.ebuild b/media-sound/mps-youtube/mps-youtube-9999.ebuild
index 82b44f71fd6..4c3f4d17ba0 100644
--- a/media-sound/mps-youtube/mps-youtube-9999.ebuild
+++ b/media-sound/mps-youtube/mps-youtube-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_{7,8,9} )
+PYTHON_COMPAT=( python3_{8..10} )
DISTUTILS_USE_SETUPTOOLS=rdepend
inherit distutils-r1
diff --git a/media-sound/mumble/Manifest b/media-sound/mumble/Manifest
deleted file mode 100644
index 0f2194f6c40..00000000000
--- a/media-sound/mumble/Manifest
+++ /dev/null
@@ -1,3 +0,0 @@
-DIST mumble-1.3.4.tar.gz 8592741 BLAKE2B bcde3fd859ec4faea06f996cd4c583af7c0b8409cca79cb05ef8ba7fcdeac9e49ed1d07a4131225dd582da7610190d4006abc731fd4276b2288e02e8c18effb6 SHA512 e2dde5aad30d1a931e7acd8d7db0b8c785d3a268d0b8cf5626fa03953a51bcadb719c6682c440d02524e83beee13d73d8f5bb3fdf98ab1c82d3ecf824cc25f68
-DIST mumble-1.4-openssl3.patch.xz 4172 BLAKE2B 5b68f023e218628a4d73b0991dcc7790ce5f92ce6a27c372c5e80b1f3a8beafa3ddd6416b884705b321aee31ea4f5e09dda6ceb240272dde64f420fbeb06845a SHA512 3a4e504f3365e93418cb85d0da4e6f2f54ab904283743907604bb39276560a4215d9bea1b225601789d1c3d84d270c04840ec57cd04e3df1204cc586ea42562a
-DIST mumble-1.4.230.tar.gz 9441667 BLAKE2B da433f3c15d7e45dfac0c8a78c9dbe86ba8d5cd078d2d87fd4d90718968fc9e5928c3c5c5ba2e40a8a54d02a646c5fc6a7ee2fff4b71dfa411d74f395b097c26 SHA512 6cffc7a95d88b33876f4093b99266468210f5c14f190fbd2fbe4991bef91a567e55296e7c8c6cc99e19c054853211085cc3cc08109e367e6776afb70766b3a53
diff --git a/media-sound/mumble/files/mumble-1.4.230-gcc12-include-memory.patch b/media-sound/mumble/files/mumble-1.4.230-gcc12-include-memory.patch
deleted file mode 100644
index 624a8594d99..00000000000
--- a/media-sound/mumble/files/mumble-1.4.230-gcc12-include-memory.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-https://github.com/mumble-voip/mumble/commit/36398fb3b293fc889bbc38df29665359f5c2a0ca
-
-From: Sergei Trofimovich <slyich@gmail.com>
-Date: Sun, 27 Feb 2022 10:59:57 +0000
-Subject: [PATCH] BUILD(positional-audio): Fix missing <memory> include
-
-Without the change the build fails on upcoming gcc-12 as:
-
- /build/mumble/plugins/gtav/gtav.cpp:13:13:
- error: 'unique_ptr' in namespace 'std' does not name a template type
- 13 | static std::unique_ptr< Game > game;
- | ^~~~~~~~~~
- /build/mumble/plugins/gtav/gtav.cpp:12:1:
- note: 'std::unique_ptr' is defined in header '<memory>';
- did you forget to '#include <memory>'?
- 11 | #include <cstring>
- +++ |+#include <memory>
- 12 |
---- a/plugins/gtav/gtav.cpp
-+++ b/plugins/gtav/gtav.cpp
-@@ -9,6 +9,7 @@
- #include "mumble_positional_audio_utils.h"
-
- #include <cstring>
-+#include <memory>
-
- static std::unique_ptr< Game > game;
-
diff --git a/media-sound/mumble/files/mumble-1.4.230-poco-link-cmake.patch b/media-sound/mumble/files/mumble-1.4.230-poco-link-cmake.patch
deleted file mode 100644
index d1b4dee11d5..00000000000
--- a/media-sound/mumble/files/mumble-1.4.230-poco-link-cmake.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-https://bugs.gentoo.org/842984
-https://github.com/mumble-voip/mumble/commit/fefdd79ebcd53a3035967789d004938ee39e2030
-
-Fix underlinking against Poco.
---- a/src/mumble/CMakeLists.txt
-+++ b/src/mumble/CMakeLists.txt
-@@ -383,11 +383,16 @@ target_include_directories(mumble
- "${PLUGINS_DIR}"
- )
-
--find_pkg(Poco COMPONENTS Zip)
-+find_pkg(Poco
-+ COMPONENTS
-+ XML
-+ Zip
-+)
-
- if(TARGET Poco::Zip)
- target_link_libraries(mumble
- PRIVATE
-+ Poco::XML
- Poco::Zip
- )
- else()
diff --git a/media-sound/mumble/metadata.xml b/media-sound/mumble/metadata.xml
deleted file mode 100644
index 8c16fbd1e7e..00000000000
--- a/media-sound/mumble/metadata.xml
+++ /dev/null
@@ -1,17 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="person">
- <email>polynomial-c@gentoo.org</email>
- <name>Lars Wendler</name>
- </maintainer>
- <use>
- <flag name="g15">Enable support for the Logitech G15 LCD (and compatible devices).</flag>
- <flag name="pipewire">Enable pipewire support for audio output.</flag>
- <flag name="rnnoise">Enable alternative noise suppression option based on RNNoise.</flag>
- <flag name="speech">Enable text-to-speech support in Mumble.</flag>
- </use>
- <upstream>
- <remote-id type="sourceforge">mumble</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/media-sound/mumble/mumble-1.3.4.ebuild b/media-sound/mumble/mumble-1.3.4.ebuild
deleted file mode 100644
index 5c1fc367dd3..00000000000
--- a/media-sound/mumble/mumble-1.3.4.ebuild
+++ /dev/null
@@ -1,160 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit desktop multilib-build qmake-utils xdg
-
-DESCRIPTION="Mumble is an open source, low-latency, high quality voice chat software"
-HOMEPAGE="https://wiki.mumble.info"
-if [[ "${PV}" == 9999 ]] ; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/mumble-voip/mumble.git"
- EGIT_SUBMODULES=( '-*' celt-0.7.0-src celt-0.11.0-src themes/Mumble 3rdparty/rnnoise-src )
-else
- if [[ "${PV}" == *_pre* ]] ; then
- SRC_URI="https://dev.gentoo.org/~polynomial-c/dist/${P}.tar.xz"
- else
- MY_PV="${PV/_/-}"
- MY_P="${PN}-${MY_PV}"
- SRC_URI="https://github.com/mumble-voip/mumble/releases/download/${MY_PV}/${MY_P}.tar.gz
- https://dl.mumble.info/${MY_P}.tar.gz"
- S="${WORKDIR}/${P/_*}"
- fi
- KEYWORDS="amd64 ~arm64 ~ppc64 x86"
-fi
-
-LICENSE="BSD MIT"
-SLOT="0"
-IUSE="+alsa +dbus debug g15 jack +opus oss pch portaudio pulseaudio +rnnoise speech zeroconf"
-
-RDEPEND="
- dev-qt/qtcore:5
- dev-qt/qtgui:5
- dev-qt/qtnetwork:5[ssl]
- dev-qt/qtsql:5[sqlite]
- dev-qt/qtsvg:5
- dev-qt/qtwidgets:5
- dev-qt/qtxml:5
- >=dev-libs/protobuf-2.2.0:=
- >=media-libs/libsndfile-1.0.20[-minimal]
- >=media-libs/speex-1.2.0
- media-libs/speexdsp
- sys-apps/lsb-release
- x11-libs/libX11
- x11-libs/libXi
- alsa? ( media-libs/alsa-lib )
- dbus? ( dev-qt/qtdbus:5 )
- g15? ( app-misc/g15daemon )
- jack? ( virtual/jack )
- >=dev-libs/openssl-1.0.0b:0=
- opus? ( >=media-libs/opus-1.0.1 )
- portaudio? ( media-libs/portaudio )
- pulseaudio? ( media-sound/pulseaudio )
- speech? ( >=app-accessibility/speech-dispatcher-0.8.0 )
- zeroconf? ( net-dns/avahi[mdnsresponder-compat] )
-"
-DEPEND="${RDEPEND}
- >=dev-libs/boost-1.41.0
- x11-base/xorg-proto
-"
-BDEPEND="
- dev-qt/linguist-tools:5
- virtual/pkgconfig
-"
-
-# NB: qmake does not support multilib but it's fine to configure
-# for the native ABI here
-src_configure() {
- myuse() {
- [[ -n "${1}" ]] || die "myuse: No use option given"
- use ${1} || echo no-${1}
- }
-
- local conf_add=(
- bundled-celt
- no-bundled-opus
- no-bundled-speex
- no-embed-qt-translations
- no-server
- no-update
- $(myuse alsa)
- $(myuse dbus)
- $(usex debug 'symbols debug' release)
- $(myuse g15)
- $(usex jack '' no-jackaudio)
- $(myuse opus)
- $(myuse oss)
- $(myuse portaudio)
- $(myuse pulseaudio)
- $(usex rnnoise bundled-rnnoise '')
- $(usex speech '' no-speechd)
- $(usex zeroconf '' no-bonjour)
- )
-
- use pch || conf_add+=( no-pch )
-
- eqmake5 "${S}/main.pro" -recursive \
- CONFIG+="${conf_add[*]}" \
- DEFINES+="PLUGIN_PATH=/usr/$(get_libdir)/mumble"
-}
-
-multilib_src_compile() {
- local emake_args=(
- # place libmumble* in a subdirectory
- DESTDIR_ADD="/${MULTILIB_ABI_FLAG}"
- {C,L}FLAGS_ADD="$(get_abi_CFLAGS)"
- )
- # build only overlay library for other ABIs
- multilib_is_native_abi || emake_args+=( -C overlay_gl )
- emake "${emake_args[@]}"
- emake clean
-}
-
-src_compile() {
- multilib_foreach_abi multilib_src_compile
-}
-
-multilib_src_install() {
- local dir=$(usex debug debug release)
- insinto /usr/$(get_libdir)/${PN}
- doins "${dir}/${MULTILIB_ABI_FLAG}"/libmumble.so*
- if multilib_is_native_abi; then
- dobin "${dir}"/mumble
- doins "${dir}"/libcelt0.so* "${dir}"/plugins/lib*.so*
- fi
-}
-
-src_install() {
- multilib_foreach_abi multilib_src_install
-
- newdoc README.Linux README
- dodoc CHANGES
- dobin scripts/mumble-overlay
-
- insinto /usr/share/services
- doins scripts/mumble.protocol
-
- domenu scripts/mumble.desktop
-
- doicon -s scalable icons/mumble.svg
-
- doman man/mumble-overlay.1
- doman man/mumble.1
-}
-
-pkg_preinst() {
- xdg_pkg_preinst
-}
-
-pkg_postinst() {
- xdg_pkg_postinst
- echo
- elog "Visit https://wiki.mumble.info/ for futher configuration instructions."
- elog "Run mumble-overlay to start the OpenGL overlay (after starting mumble)."
- echo
-}
-
-pkg_postrm() {
- xdg_pkg_postrm
-}
diff --git a/media-sound/mumble/mumble-1.4.230-r1.ebuild b/media-sound/mumble/mumble-1.4.230-r1.ebuild
deleted file mode 100644
index 690186d9725..00000000000
--- a/media-sound/mumble/mumble-1.4.230-r1.ebuild
+++ /dev/null
@@ -1,135 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit cmake xdg
-
-DESCRIPTION="Mumble is an open source, low-latency, high quality voice chat software"
-HOMEPAGE="https://wiki.mumble.info"
-if [[ "${PV}" == 9999 ]] ; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/mumble-voip/mumble.git"
- EGIT_SUBMODULES=( '-*' celt-0.7.0-src celt-0.11.0-src themes/Mumble 3rdparty/rnnoise-src 3rdparty/FindPythonInterpreter )
-else
- if [[ "${PV}" == *_pre* ]] ; then
- SRC_URI="https://dev.gentoo.org/~polynomial-c/dist/${P}.tar.xz"
- else
- MY_PV="${PV/_/-}"
- MY_P="${PN}-${MY_PV}"
- SRC_URI="https://github.com/mumble-voip/mumble/releases/download/v${MY_PV}/${MY_P}.tar.gz"
- S="${WORKDIR}/${P/_*}.src"
- fi
- KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
-fi
-
-SRC_URI+=" https://dev.gentoo.org/~polynomial-c/${PN}-1.4-openssl3.patch.xz"
-
-LICENSE="BSD MIT"
-SLOT="0"
-IUSE="+alsa +dbus debug g15 jack pipewire portaudio pulseaudio multilib nls +rnnoise speech test zeroconf"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- >=dev-libs/openssl-1.0.0b:0=
- dev-libs/poco[util,xml,zip]
- >=dev-libs/protobuf-2.2.0:=
- dev-qt/qtcore:5
- dev-qt/qtgui:5
- dev-qt/qtnetwork:5[ssl]
- dev-qt/qtsql:5[sqlite]
- dev-qt/qtsvg:5
- dev-qt/qtwidgets:5
- dev-qt/qtxml:5
- >=media-libs/libsndfile-1.0.20[-minimal]
- >=media-libs/opus-1.3.1
- >=media-libs/speex-1.2.0
- media-libs/speexdsp
- sys-apps/lsb-release
- x11-libs/libX11
- x11-libs/libXi
- alsa? ( media-libs/alsa-lib )
- dbus? ( dev-qt/qtdbus:5 )
- g15? ( app-misc/g15daemon:= )
- jack? ( virtual/jack )
- portaudio? ( media-libs/portaudio )
- pulseaudio? ( media-sound/pulseaudio )
- pipewire? ( media-video/pipewire )
- speech? ( >=app-accessibility/speech-dispatcher-0.8.0 )
- zeroconf? ( net-dns/avahi[mdnsresponder-compat] )
-"
-DEPEND="${RDEPEND}
- dev-qt/qtconcurrent:5
- dev-qt/qttest:5
- >=dev-libs/boost-1.41.0
- x11-base/xorg-proto
-"
-BDEPEND="
- dev-qt/linguist-tools:5
- virtual/pkgconfig
-"
-
-PATCHES=(
- "${WORKDIR}/${PN}-1.4-openssl3.patch"
- "${FILESDIR}/${PN}-1.4.230-gcc12-include-memory.patch"
- "${FILESDIR}/${PN}-1.4.230-poco-link-cmake.patch"
-)
-
-src_prepare() {
- # required because of xdg.eclass also providing src_prepare
- cmake_src_prepare
-}
-
-src_configure() {
-
- local mycmakeargs=(
- -Dalsa="$(usex alsa)"
- -Dtests="$(usex test)"
- -Dbundled-celt="ON"
- -Dbundled-opus="OFF"
- -Dbundled-speex="OFF"
- -Ddbus="$(usex dbus)"
- -Dg15="$(usex g15)"
- -Djackaudio="$(usex jack)"
- -Doverlay="ON"
- -Dportaudio="$(usex portaudio)"
- -Doverlay-xcompile="$(usex multilib)"
- -Dpipewire="$(usex pipewire)"
- -Dpulseaudio="$(usex pulseaudio)"
- -Drnnoise="$(usex rnnoise)"
- -Dserver="OFF"
- -Dspeechd="$(usex speech)"
- -Dtranslations="$(usex nls)"
- -Dupdate="OFF"
- -Dwarnings-as-errors="OFF"
- -Dzeroconf="$(usex zeroconf)"
- )
-
- if [[ "${PV}" != 9999 ]] ; then
- mycmakeargs+=( -DBUILD_NUMBER="$(ver_cut 3)" )
- fi
-
- cmake_src_configure
-}
-
-src_install() {
- cmake_src_install
-
- if use amd64 && use multilib ; then
- # The 32bit overlay library gets built when multilib is enabled.
- # Install it into the correct 32bit lib dir.
- local libdir_64="/usr/$(get_libdir)/mumble"
- local libdir_32="/usr/$(get_abi_var LIBDIR x86)/mumble"
- dodir ${libdir_32}
- mv "${ED}"/${libdir_64}/libmumbleoverlay.x86.so* \
- "${ED}"/${libdir_32}/ || die
- fi
-}
-
-pkg_postinst() {
- xdg_pkg_postinst
- echo
- elog "Visit https://wiki.mumble.info/ for futher configuration instructions."
- elog "Run 'mumble-overlay <program>' to start the OpenGL overlay (after starting mumble)."
- echo
-}
diff --git a/media-sound/mumble/mumble-9999.ebuild b/media-sound/mumble/mumble-9999.ebuild
deleted file mode 100644
index 009f89b1241..00000000000
--- a/media-sound/mumble/mumble-9999.ebuild
+++ /dev/null
@@ -1,132 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit cmake xdg
-
-DESCRIPTION="Mumble is an open source, low-latency, high quality voice chat software"
-HOMEPAGE="https://wiki.mumble.info"
-if [[ "${PV}" == 9999 ]] ; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/mumble-voip/mumble.git"
- EGIT_SUBMODULES=( '-*' celt-0.7.0-src celt-0.11.0-src themes/Mumble 3rdparty/rnnoise-src 3rdparty/FindPythonInterpreter 3rdparty/tracy )
-else
- if [[ "${PV}" == *_pre* ]] ; then
- SRC_URI="https://dev.gentoo.org/~polynomial-c/dist/${P}.tar.xz"
- else
- MY_PV="${PV/_/-}"
- MY_P="${PN}-${MY_PV}"
- SRC_URI="https://github.com/mumble-voip/mumble/releases/download/v${MY_PV}/${MY_P}.tar.gz"
- S="${WORKDIR}/${P/_*}.src"
- fi
- KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
-fi
-
-LICENSE="BSD MIT"
-SLOT="0"
-IUSE="+alsa +dbus debug g15 jack pipewire portaudio pulseaudio multilib nls +rnnoise speech test zeroconf"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- >=dev-libs/openssl-1.0.0b:0=
- dev-libs/poco[util,xml,zip]
- >=dev-libs/protobuf-2.2.0:=
- dev-qt/qtcore:5
- dev-qt/qtgui:5
- dev-qt/qtnetwork:5[ssl]
- dev-qt/qtsql:5[sqlite]
- dev-qt/qtsvg:5
- dev-qt/qtwidgets:5
- dev-qt/qtxml:5
- >=media-libs/libsndfile-1.0.20[-minimal]
- >=media-libs/opus-1.3.1
- >=media-libs/speex-1.2.0
- media-libs/speexdsp
- sys-apps/lsb-release
- x11-libs/libX11
- x11-libs/libXi
- alsa? ( media-libs/alsa-lib )
- dbus? ( dev-qt/qtdbus:5 )
- g15? ( app-misc/g15daemon:= )
- jack? ( virtual/jack )
- portaudio? ( media-libs/portaudio )
- pulseaudio? ( media-sound/pulseaudio )
- pipewire? ( media-video/pipewire )
- speech? ( >=app-accessibility/speech-dispatcher-0.8.0 )
- zeroconf? ( net-dns/avahi[mdnsresponder-compat] )
-"
-DEPEND="${RDEPEND}
- dev-cpp/nlohmann_json
- dev-qt/qtconcurrent:5
- dev-qt/qttest:5
- >=dev-libs/boost-1.41.0
- x11-base/xorg-proto
-"
-BDEPEND="
- dev-qt/linguist-tools:5
- virtual/pkgconfig
-"
-
-src_prepare() {
- sed '/TRACY_ON_DEMAND/s@ ON @ OFF @' -i src/CMakeLists.txt || die
-
- # required because of xdg.eclass also providing src_prepare
- cmake_src_prepare
-}
-
-src_configure() {
-
- local mycmakeargs=(
- -Dalsa="$(usex alsa)"
- -Dbundled-celt="ON"
- -Dbundled-json="OFF"
- -Dbundled-opus="OFF"
- -Dbundled-speex="OFF"
- -Ddbus="$(usex dbus)"
- -Dg15="$(usex g15)"
- -Djackaudio="$(usex jack)"
- -Doverlay="ON"
- -Dportaudio="$(usex portaudio)"
- -Doverlay-xcompile="$(usex multilib)"
- -Dpipewire="$(usex pipewire)"
- -Dpulseaudio="$(usex pulseaudio)"
- -Drnnoise="$(usex rnnoise)"
- -Dserver="OFF"
- -Dspeechd="$(usex speech)"
- -Dtests="$(usex test)"
- -Dtracy="OFF"
- -Dtranslations="$(usex nls)"
- -Dupdate="OFF"
- -Dwarnings-as-errors="OFF"
- -Dzeroconf="$(usex zeroconf)"
- )
-
- if [[ "${PV}" != 9999 ]] ; then
- mycmakeargs+=( -DBUILD_NUMBER="$(ver_cut 3)" )
- fi
-
- cmake_src_configure
-}
-
-src_install() {
- cmake_src_install
-
- if use amd64 && use multilib ; then
- # The 32bit overlay library gets built when multilib is enabled.
- # Install it into the correct 32bit lib dir.
- local libdir_64="/usr/$(get_libdir)/mumble"
- local libdir_32="/usr/$(get_abi_var LIBDIR x86)/mumble"
- dodir ${libdir_32}
- mv "${ED}"/${libdir_64}/libmumbleoverlay.x86.so* \
- "${ED}"/${libdir_32}/ || die
- fi
-}
-
-pkg_postinst() {
- xdg_pkg_postinst
- echo
- elog "Visit https://wiki.mumble.info/ for futher configuration instructions."
- elog "Run 'mumble-overlay <program>' to start the OpenGL overlay (after starting mumble)."
- echo
-}
diff --git a/media-sound/mup/Manifest b/media-sound/mup/Manifest
index 056b323faec..509c4061cb3 100644
--- a/media-sound/mup/Manifest
+++ b/media-sound/mup/Manifest
@@ -1 +1 @@
-DIST mup66src.tar.gz 2514430 BLAKE2B d2747a0fc46f055b370456305b1c56bd1e35827c10686650804801826a945d7a60a25095a3d789fbec0abf2a0aab6cb2e1a8b87eadd2858674f54cbfca377dfb SHA512 3239be85eb9e52adf941a3c927e200a3232d697ee081b359ee63d8aac7a8748af09cc66eef33b6145ccdfeb548a1f93130beb99960ed858d695fcc286c61bd35
+DIST mup69src.tar.gz 3062560 BLAKE2B cb7456fe52f85a122106675372a5ffabe9466086e730cbb15dbb590ea2485ecfc34e52d8b8c7c3a583d98e4e8e352be07a203e41da38cd145adf11cdf59bad92 SHA512 b3b49177e12b6a8dbd711e88a327826b60e4141a0720c1be4900af2124ac29592572d866d98f2a5b8318fb008fb035371ad83f152601bf22d98a3e7568ecfe95
diff --git a/media-sound/mup/files/mup-6.6-makefile.patch b/media-sound/mup/files/mup-6.6-makefile.patch
deleted file mode 100644
index 0350a6e8044..00000000000
--- a/media-sound/mup/files/mup-6.6-makefile.patch
+++ /dev/null
@@ -1,69 +0,0 @@
-Fix header/library locations for fltk, respect LDFLAGS, and allow the ebuild to
-handle docs install.
-
---- mup-6.6/makefile
-+++ mup-6.6/makefile
-@@ -80,12 +80,12 @@
-
- # You can change this if your X libraries and headers are somewhere else
- # (like /usr/X11R6).
--X_LOCATION = /usr/X11
-+X_LOCATION = /usr
-
- # If you installed fltk somewhere other than $(X_LOCATION)/lib
- # set this to find them, as in
- # FLTK_LIB_LOCATION = -L/usr/local/lib
--FLTK_LIB_LOCATION =
-+FLTK_LIB_LOCATION = -L/usr/lib/fltk
-
- # The X libraries to link with Mupmate.
- # Depending on how fltk was compiled, you may be able to omit
-@@ -99,7 +99,7 @@
- #FLTK_VERSION=FLTK_1_1
-
- # The FLTK header files are under $(FLTK_INCLUDE)/FL
--FLTK_INCLUDE = $(X_LOCATION)/include
-+FLTK_INCLUDE = $(X_LOCATION)/include/fltk
-
- # You can use fltk_jpeg or jpeg library, whichever you have
- # or depending on how fltk was compiled, you may not need it at all
-@@ -251,25 +251,25 @@
- flex -t extras/lex.l > mup/lex.c
-
- mup/mup: $(MUP_HDRS) $(MUP_SRC)
-- $(CCOMPILER) $(CFLAGS) -o $@ $(MUP_SRC) -lm
-+ $(CCOMPILER) $(CFLAGS) $(LDFLAGS) -o $@ $(MUP_SRC) -lm
-
- mupdisp/mupdisp: $(MUPDISP_HDRS) $(MUPDISP_BITMAPS) $(MUPDISP_SRC)
-- $(CCOMPILER) $(CFLAGS) -L$(X_LOCATION)/lib -o $@ -DNO_VGA_LIB $(MUPDISP_SRC) -lX11
-+ $(CCOMPILER) $(CFLAGS) $(LDFLAGS) -L$(X_LOCATION)/lib -o $@ -DNO_VGA_LIB $(MUPDISP_SRC) -lX11
- # For Linux console mode support, comment out the previous line
- # and uncomment the following line
- # $(CCOMPILER) $(CFLAGS) -L$(X_LOCATION)/lib -o $@ $(MUPDISP_SRC) -lvga -lX11 -lm
-
- mkmupfnt/mkmupfnt: $(MKMUPFNT_SRC)
-- $(CCOMPILER) $(CFLAGS) -o $@ $(MKMUPFNT_SRC)
-+ $(CCOMPILER) $(CFLAGS) $(LDFLAGS) -o $@ $(MKMUPFNT_SRC)
-
- mupmate/mupmate: $(MUPMATE_SRC) $(MUPMATE_HDRS) $(MUPMATE_OTHER_FILES)
-- $(CPPCOMPILER) $(CFLAGS) -o $@ $(MUPMATE_SRC) \
-+ $(CPPCOMPILER) $(CXXFLAGS) $(LDFLAGS) -o $@ $(MUPMATE_SRC) \
- $(FLTK_VERSION) -I$(FLTK_INCLUDE) -Imup -L$(X_LOCATION)/lib \
- $(FLTK_LIB_LOCATION) -lfltk -lfltk_images $(X_LIBS) \
- $(JPEGLIB) $(PNGLIB) $(ZLIB) -lm
-
- install: all
-- mkdir -p $(BINDIR) $(MANDIR) $(DOCDIR)/uguide $(ICONDIR) $(LIBDIR)
-+ mkdir -p $(BINDIR) $(MANDIR) $(ICONDIR) $(LIBDIR)
- cp mup/mup $(BINDIR)/mup
- cp mkmupfnt/mkmupfnt $(BINDIR)/mkmupfnt
- cp mupdisp/mupdisp $(BINDIR)/mupdisp
-@@ -278,8 +278,6 @@
- cp mupmate/mupmate $(BINDIR)/mupmate
- cp mupprnt $(BINDIR)/mupprnt
- cp docs/*.1 $(MANDIR)
-- cp docs/README* docs/*.txt docs/*.ps docs/*.mup $(DOCDIR)
-- cp docs/uguide/* $(DOCDIR)/uguide
- cp $(MUPMATE_OTHER_FILES) $(ICONDIR)
- cp $(MUP_LIB_FILES) $(LIBDIR)
-
diff --git a/media-sound/mup/files/mup-6.9-build-system.patch b/media-sound/mup/files/mup-6.9-build-system.patch
new file mode 100644
index 00000000000..07a7dba237b
--- /dev/null
+++ b/media-sound/mup/files/mup-6.9-build-system.patch
@@ -0,0 +1,125 @@
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -1,4 +1,2 @@
+ SUBDIRS = lib tools src doc mup-input packaging
+-EXTRA_DIST = LICENSE simple.makefile
+-mup_doc_dir = $(datadir)/doc/packages/$(PACKAGE)
+-mup_doc__DATA = LICENSE
++EXTRA_DIST = simple.makefile
+--- a/configure.ac
++++ b/configure.ac
+@@ -3,7 +3,7 @@
+
+ AC_PREREQ([2.69])
+ AC_INIT([mup], [6.9], [support@arkkra.com])
+-AM_INIT_AUTOMAKE([-Wall -Werror])
++AM_INIT_AUTOMAKE([-Wall])
+
+ # Checks for programs.
+ AC_PROG_CXX
+@@ -16,21 +16,21 @@ AC_PROG_SED
+ AC_PROG_MKDIR_P
+
+ AC_PATH_PROGS(GS, [gs gs386], [none])
+-test "$GS" == "none" && AC_MSG_ERROR([required ghostscript program 'gs' is missing])
++test "$GS" = "none" && AC_MSG_ERROR([required ghostscript program 'gs' is missing])
+ AC_PATH_PROG(GROFF, [groff], [none])
+-test "$GROFF" == "none" && AC_MSG_ERROR([required program 'groff' is missing])
++test "$GROFF" = "none" && AC_MSG_ERROR([required program 'groff' is missing])
+ AC_PATH_PROG(BISON, [bison], [none])
+-test "$BISON" == "none" && AC_MSG_ERROR([required program 'bison' is missing])
++test "$BISON" = "none" && AC_MSG_ERROR([required program 'bison' is missing])
+ AC_PATH_PROG(PPMTOGIF, [ppmtogif], [none])
+-test "$PPMTOGIF" == "none" && AC_MSG_ERROR([required program 'ppmtogif' is missing])
++test "$PPMTOGIF" = "none" && AC_MSG_ERROR([required program 'ppmtogif' is missing])
+ AC_PATH_PROG(EXPR, [expr], [none])
+-test "$EXPR" == "none" && AC_MSG_ERROR([required program 'expr' is missing])
++test "$EXPR" = "none" && AC_MSG_ERROR([required program 'expr' is missing])
+ AC_PATH_PROG(SORT, [sort], [none])
+-test "$SORT" == "none" && AC_MSG_ERROR([required program 'sort' is missing])
++test "$SORT" = "none" && AC_MSG_ERROR([required program 'sort' is missing])
+ AC_PATH_PROG(CAT, [cat], [none])
+-test "$CAT" == "none" && AC_MSG_ERROR([required program 'cat' is missing])
++test "$CAT" = "none" && AC_MSG_ERROR([required program 'cat' is missing])
+ AC_PATH_PROG(EGREP, [egrep], [none])
+-test "$EGREP" == "none" && AC_MSG_ERROR([required program 'egrep' is missing])
++test "$EGREP" = "none" && AC_MSG_ERROR([required program 'egrep' is missing])
+
+ # Need to know if on Windows to install mupprnt.bat rather than shell script
+ AC_CANONICAL_HOST
+@@ -70,7 +70,7 @@ AS_IF([test "x$enable_mupmate" != xno],
+ # Find fltk-config program
+ PATH="$fltk_prefix/bin:$PATH"
+ AC_PATH_PROG(FLTK_CONFIG, fltk-config, none, $PATH)
+- test "$FLTK_CONFIG" == "none" && AC_MSG_ERROR([required program 'fltk-config' is missing])
++ test "$FLTK_CONFIG" = "none" && AC_MSG_ERROR([required program 'fltk-config' is missing])
+ # Make sure it is the 1.x API, not 2.x
+ fltk_api_version="`$FLTK_CONFIG --api-version`"
+ fltk_api_major=`echo $fltk_api_version | sed -e 's/\..*//'`
+@@ -79,13 +79,13 @@ AS_IF([test "x$enable_mupmate" != xno],
+ AC_SUBST([FLTK_CXXFLAGS], [`$FLTK_CONFIG --cxxflags`])
+ # Red Hat/CentOS 7 version of fltk-config doesn't include -lfltk when using --use_image --ldflags, so fix that
+ fltk_ldflags="`$FLTK_CONFIG --use-images --ldflags`"
+- if test "$fltk_ldflags" == "-lfltk_images"
++ if test "$fltk_ldflags" = "-lfltk_images"
+ then
+ AC_SUBST([FLTK_LDFLAGS], ["-lfltk -lfltk_images"])
+ else
+ AC_SUBST([FLTK_LDFLAGS], [`$FLTK_CONFIG --use-images --ldflags`])
+ fi
+- test "$build_mac" == "yes" && AC_SUBST([EXTRA_CFLAGS], [-Dunix])
++ test "$build_mac" = "yes" && AC_SUBST([EXTRA_CFLAGS], [-Dunix])
+ # Check that libraries that Mupmate needs exist
+ AC_CHECK_LIB([fltk], [fl_alphasort], [ ])
+ AC_CHECK_LIB([fltk_images], [main], [ ])
+@@ -100,13 +100,13 @@ AS_IF([test "x$enable_mupmate" != xno],
+ AC_CHECK_LIB([z], [gzgets], [ ])
+
+ # Programs for Windows icons for Mupmate
+- test "$build_windows" == "yes" && test "$PAMTOWINICON" == "none" && test "$PPMWINICON" == "none" && AC_MSG_ERROR([Need either pamtowinicon or ppmtowinicon])
++ test "$build_windows" = "yes" && test "$PAMTOWINICON" = "none" && test "$PPMWINICON" = "none" && AC_MSG_ERROR([Need either pamtowinicon or ppmtowinicon])
+ AC_PATH_PROG(XPMTOPPM, xpmtoppm, none, $PATH)
+- test "$build_windows" == "yes" && test "$XPMTOPPM" == "none" && AC_MSG_ERROR([Need xpmtoppm])
++ test "$build_windows" = "yes" && test "$XPMTOPPM" = "none" && AC_MSG_ERROR([Need xpmtoppm])
+ AC_PATH_PROG(PPMTOPGM, ppmtopgm, none, $PATH)
+- test "$build_windows" == "yes" && test "$PPMTOPGM" == "none" && test "$PAMTOWINICON" == "none" && AC_MSG_ERROR([Need ppmtopgm])
++ test "$build_windows" = "yes" && test "$PPMTOPGM" = "none" && test "$PAMTOWINICON" = "none" && AC_MSG_ERROR([Need ppmtopgm])
+ AC_PATH_PROG(WINDRES, i386-mingw32msvc-windres, none, $PATH)
+- test "$build_windows" == "yes" && test "$WINDRES" == "none" && AC_MSG_ERROR([Need i386-mingw32msvc-windres])
++ test "$build_windows" = "yes" && test "$WINDRES" = "none" && AC_MSG_ERROR([Need i386-mingw32msvc-windres])
+ ]
+ )
+
+@@ -122,7 +122,7 @@ AC_FUNC_MALLOC
+ AC_FUNC_MMAP
+ AC_FUNC_REALLOC
+ AC_CHECK_FUNCS([access alarm atan cos getcwd isascii isspace memcmp memmove memset munmap pow putenv select setenv sin sqrt strcasecmp strchr strcmp strcpy strcspn strdup strerror strncasecmp strncpy strpbrk strrchr strspn strstr strtol tan unlink])
+-test "$build_linux" == "yes" && AC_CHECK_FUNCS([kill sleep waitpid])
++test "$build_linux" = "yes" && AC_CHECK_FUNCS([kill sleep waitpid])
+
+ AS_IF([test "x$enable_mupdisp" != xno],
+ [
+--- a/doc/Makefile.am
++++ b/doc/Makefile.am
+@@ -208,10 +208,9 @@ uguide_files = \
+
+ ps_files = quickref.ps uguide.ps
+ EXTRA_DIST = uguide.t quickref.t charlist $(uguide_files) $(ps_files)
+-mup_doc_dir = $(datadir)/doc/packages/$(PACKAGE)
+-mup_doc__DATA = $(ps_files)
+-mup_uguide_dir = $(mup_doc_dir)/uguide
+-mup_uguide__DATA = $(uguide_files)
++dist_doc_DATA = $(ps_files)
++mup_uguidedir = $(docdir)/uguide
++mup_uguide_DATA = $(uguide_files)
+
+ muschar.ps: ../src/include/muschar.h ../tools/doc/mkmuscharps.sh
+ ../tools/doc/mkmuscharps.sh < ../src/include/muschar.h
+--- a/doc/htmldocs/Makefile.am
++++ b/doc/htmldocs/Makefile.am
+@@ -1,4 +1,4 @@
+ mup_html_docs = blind.html faq.html Macinst.html mupfeat.html overview.html usercomm.html whatsnew.html winrun.html
+-mup_htmldoc_dir = $(datadir)/doc/packages/$(PACKAGE)
++mup_htmldoc_dir = $(htmldir)
+ mup_htmldoc__DATA = $(mup_html_docs)
+ EXTRA_DIST = $(mup_html_docs)
diff --git a/media-sound/mup/mup-6.6.ebuild b/media-sound/mup/mup-6.6.ebuild
deleted file mode 100644
index 2647e954d2c..00000000000
--- a/media-sound/mup/mup-6.6.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit toolchain-funcs
-
-DESCRIPTION="Program for printing music scores"
-HOMEPAGE="http://www.arkkra.com/"
-SRC_URI="ftp://ftp.arkkra.com/pub/unix/mup${PV//.}src.tar.gz"
-
-LICENSE="Arkkra"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~sparc ~x86"
-IUSE=""
-
-RDEPEND="x11-libs/libX11
- x11-libs/libXext
- >=x11-libs/fltk-1.3:1
- x11-libs/libXpm
- virtual/jpeg:0
- media-libs/libpng:0="
-DEPEND="${RDEPEND}
- x11-base/xorg-proto"
-
-PATCHES=( "${FILESDIR}"/${P}-makefile.patch )
-
-src_prepare() {
- default
- sed -i -e "s:/lib:/$(get_libdir):g" makefile || die
-}
-
-src_compile() {
- emake CCOMPILER="$(tc-getCC)" CPPCOMPILER="$(tc-getCXX)" CFLAGS="${CFLAGS}"
-}
-
-src_install() {
- emake DESTDIR="${D}" install
- dodoc docs/{*.txt,README0}
- docinto html
- dodoc docs/{*.html,uguide/*}
- docinto sample
- dodoc docs/{*.mup,*.ps}
-}
diff --git a/media-sound/mup/mup-6.9.ebuild b/media-sound/mup/mup-6.9.ebuild
new file mode 100644
index 00000000000..9284b6f8570
--- /dev/null
+++ b/media-sound/mup/mup-6.9.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools toolchain-funcs
+
+DESCRIPTION="Program for printing music scores"
+HOMEPAGE="http://www.arkkra.com/"
+SRC_URI="http://www.arkkra.com/ftp/pub/unix/mup${PV//.}src.tar.gz
+ ftp://ftp.arkkra.com/pub/unix/mup${PV//.}src.tar.gz"
+
+LICENSE="Arkkra"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+RDEPEND="
+ media-libs/libjpeg-turbo:=
+ media-libs/libpng:=
+ x11-libs/libX11
+ x11-libs/libXext
+ >=x11-libs/fltk-1.3:1
+ x11-libs/libXpm
+"
+DEPEND="
+ ${RDEPEND}
+ x11-base/xorg-proto
+"
+BDEPEND="
+ app-text/ghostscript-gpl
+ media-libs/netpbm
+ sys-apps/groff
+ sys-devel/bison
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-6.9-build-system.patch
+)
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_compile() {
+ emake -j1 CCOMPILER="$(tc-getCC)" CPPCOMPILER="$(tc-getCXX)" CFLAGS="${CFLAGS}"
+}
+
+src_install() {
+ emake -j1 DESTDIR="${D}" install
+
+ dodoc README
+}
diff --git a/media-sound/murmur/Manifest b/media-sound/murmur/Manifest
deleted file mode 100644
index 04a9a00d763..00000000000
--- a/media-sound/murmur/Manifest
+++ /dev/null
@@ -1,4 +0,0 @@
-DIST mumble-1.3.3.tar.gz 8591354 BLAKE2B e5bf4d0a21f3c9af761b0892c4a5a7d86244d3283070976fe7a779a10567ffd857e0c19dad750cdbae40d851ce1dcf17b66c63a2cb5142a13358af6f272445dd SHA512 be4c6d4de82a1059bf30d4c7e3c44e41e4bb50dc4a811b7d0def808c52059ff7bcccf65140db940f18cc1bb66d58ea4dab23ba5dcfae3b8b904866751f32edb3
-DIST mumble-1.3.4.tar.gz 8592741 BLAKE2B bcde3fd859ec4faea06f996cd4c583af7c0b8409cca79cb05ef8ba7fcdeac9e49ed1d07a4131225dd582da7610190d4006abc731fd4276b2288e02e8c18effb6 SHA512 e2dde5aad30d1a931e7acd8d7db0b8c785d3a268d0b8cf5626fa03953a51bcadb719c6682c440d02524e83beee13d73d8f5bb3fdf98ab1c82d3ecf824cc25f68
-DIST mumble-1.4-openssl3.patch.xz 4172 BLAKE2B 5b68f023e218628a4d73b0991dcc7790ce5f92ce6a27c372c5e80b1f3a8beafa3ddd6416b884705b321aee31ea4f5e09dda6ceb240272dde64f420fbeb06845a SHA512 3a4e504f3365e93418cb85d0da4e6f2f54ab904283743907604bb39276560a4215d9bea1b225601789d1c3d84d270c04840ec57cd04e3df1204cc586ea42562a
-DIST mumble-1.4.230.tar.gz 9441667 BLAKE2B da433f3c15d7e45dfac0c8a78c9dbe86ba8d5cd078d2d87fd4d90718968fc9e5928c3c5c5ba2e40a8a54d02a646c5fc6a7ee2fff4b71dfa411d74f395b097c26 SHA512 6cffc7a95d88b33876f4093b99266468210f5c14f190fbd2fbe4991bef91a567e55296e7c8c6cc99e19c054853211085cc3cc08109e367e6776afb70766b3a53
diff --git a/media-sound/murmur/files/murmur.confd b/media-sound/murmur/files/murmur.confd
deleted file mode 100644
index 36367c51136..00000000000
--- a/media-sound/murmur/files/murmur.confd
+++ /dev/null
@@ -1,9 +0,0 @@
-# where to look for the config file
-MURMUR_CONF=/etc/murmur/murmur.ini
-
-# run as this user
-MURMUR_USER=murmur
-
-# HOME directory of MURMUR_USER
-MURMUR_HOME=/var/lib/murmur
-
diff --git a/media-sound/murmur/files/murmur.initd-r1 b/media-sound/murmur/files/murmur.initd-r1
deleted file mode 100644
index fe49b32f141..00000000000
--- a/media-sound/murmur/files/murmur.initd-r1
+++ /dev/null
@@ -1,25 +0,0 @@
-#!/sbin/openrc-run
-
-pidfile="/run/murmur/murmur.pid"
-command="/usr/bin/murmurd"
-command_args="-ini \"${MURMUR_CONF}\""
-start_stop_daemon_args="-u \"${MURMUR_USER}\" --env HOME=\"${MURMUR_HOME}\" --wait 20"
-extra_started_commands="reload"
-
-depend() {
- need localmount net
- use dbus logger
- after bootmisc mysql
-}
-
-start_pre() {
- checkpath -q -d -o ${MURMUR_USER} ${pidfile%/*}
-}
-
-reload() {
- ebegin "Reloading Murmur"
- start-stop-daemon --signal HUP --pidfile "${pidfile}" \
- --exec ${command}
- eend $?
-}
-
diff --git a/media-sound/murmur/files/murmur.initd-r2 b/media-sound/murmur/files/murmur.initd-r2
deleted file mode 100644
index b754c242462..00000000000
--- a/media-sound/murmur/files/murmur.initd-r2
+++ /dev/null
@@ -1,24 +0,0 @@
-#!/sbin/openrc-run
-
-pidfile="/run/murmur/murmur.pid"
-command="/usr/bin/mumble-server"
-command_args="-ini \"${MURMUR_CONF}\""
-start_stop_daemon_args="-u \"${MURMUR_USER}\" --env HOME=\"${MURMUR_HOME}\" --wait 20"
-extra_started_commands="reload"
-
-depend() {
- need localmount net
- use dbus logger
- after bootmisc mysql
-}
-
-start_pre() {
- checkpath -q -d -o ${MURMUR_USER} ${pidfile%/*}
-}
-
-reload() {
- ebegin "Reloading Murmur"
- start-stop-daemon --signal HUP --pidfile "${pidfile}" \
- --exec ${command}
- eend $?
-}
diff --git a/media-sound/murmur/files/murmur.logrotate b/media-sound/murmur/files/murmur.logrotate
deleted file mode 100644
index a82cb1a336c..00000000000
--- a/media-sound/murmur/files/murmur.logrotate
+++ /dev/null
@@ -1,8 +0,0 @@
-/var/log/murmur/*.log {
- missingok
- notifempty
- sharedscripts
- postrotate
- test -r /run/murmur/murmur.pid && kill -HUP $(cat /run/murmur/murmur.pid) &>/dev/null
- endscript
-}
diff --git a/media-sound/murmur/files/murmurd-dbus.tmpfiles b/media-sound/murmur/files/murmurd-dbus.tmpfiles
deleted file mode 100644
index 70963d0a575..00000000000
--- a/media-sound/murmur/files/murmurd-dbus.tmpfiles
+++ /dev/null
@@ -1 +0,0 @@
-d /run/murmur 0755 murmur murmur
diff --git a/media-sound/murmur/metadata.xml b/media-sound/murmur/metadata.xml
deleted file mode 100644
index a45616b4db1..00000000000
--- a/media-sound/murmur/metadata.xml
+++ /dev/null
@@ -1,15 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="person">
- <email>polynomial-c@gentoo.org</email>
- <name>Lars Wendler</name>
- </maintainer>
- <use>
- <flag name="grpc">Use <pkg>net-libs/grpc</pkg> to enable remote control capabilities.</flag>
- <flag name="ice">Use <pkg>dev-libs/Ice</pkg> to enable remote control capabilities.</flag>
- </use>
- <upstream>
- <remote-id type="sourceforge">mumble</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/media-sound/murmur/murmur-1.3.3.ebuild b/media-sound/murmur/murmur-1.3.3.ebuild
deleted file mode 100644
index 9131ecb5514..00000000000
--- a/media-sound/murmur/murmur-1.3.3.ebuild
+++ /dev/null
@@ -1,162 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit qmake-utils systemd readme.gentoo-r1 tmpfiles
-
-DESCRIPTION="Mumble is an open source, low-latency, high quality voice chat software"
-HOMEPAGE="https://wiki.mumble.info"
-if [[ "${PV}" == 9999 ]] ; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/mumble-voip/mumble.git"
- EGIT_SUBMODULES=( '-*' )
-else
- MY_PN="mumble"
- if [[ "${PV}" == *_pre* ]] ; then
- MY_P="${MY_PN}-${PV}"
- SRC_URI="https://dev.gentoo.org/~polynomial-c/dist/${MY_P}.tar.xz"
- S="${WORKDIR}/${MY_P}"
- else
- MY_PV="${PV/_/-}"
- MY_P="${MY_PN}-${MY_PV}"
- SRC_URI="https://github.com/mumble-voip/mumble/releases/download/${MY_PV}/${MY_P}.tar.gz
- https://dl.mumble.info/${MY_P}.tar.gz"
- S="${WORKDIR}/${MY_PN}-${PV/_*}"
- fi
- KEYWORDS="amd64 ~arm x86"
-fi
-
-LICENSE="BSD"
-SLOT="0"
-IUSE="+dbus debug +ice pch zeroconf"
-
-RDEPEND="
- acct-group/murmur
- acct-user/murmur
- >=dev-libs/openssl-1.0.0b:0=
- >=dev-libs/protobuf-2.2.0:=
- dev-qt/qtcore:5
- dev-qt/qtnetwork:5
- || (
- dev-qt/qtsql:5[sqlite]
- dev-qt/qtsql:5[mysql]
- )
- dev-qt/qtxml:5
- sys-apps/lsb-release
- >=sys-libs/libcap-2.15
- dbus? ( dev-qt/qtdbus:5 )
- ice? ( dev-libs/Ice:= )
- zeroconf? ( net-dns/avahi[mdnsresponder-compat] )
-"
-
-DEPEND="${RDEPEND}
- >=dev-libs/boost-1.41.0
-"
-BDEPEND="
- acct-group/murmur
- acct-user/murmur
- virtual/pkgconfig
-"
-
-if [[ "${PV}" == *9999 ]] ; then
- # Required for the mkini.sh script which calls perl multiple times
- BDEPEND+="
- dev-lang/perl
- "
-fi
-
-DOC_CONTENTS="
- Useful scripts are located in /usr/share/doc/${PF}/scripts.\n
- Please execute:\n
- murmurd -ini /etc/murmur/murmur.ini -supw <pw>\n
- chown murmur:murmur /var/lib/murmur/murmur.sqlite\n
- to set the build-in 'SuperUser' password before starting murmur.
- Please restart dbus before starting murmur, or else dbus
- registration will fail.
-"
-
-src_prepare() {
- default
-
- if [[ "${PV}" == *9999 ]] ; then
- pushd scripts &>/dev/null || die
- ./mkini.sh || die
- popd &>/dev/null || die
- fi
-
- sed \
- -e 's:mumble-server:murmur:g' \
- -e 's:/var/run:/run:g' \
- -i "${S}"/scripts/murmur.{conf,ini.system} || die
-
- # Adjust systemd service file to our config location #689208
- sed "s@/etc/${PN}\.ini@/etc/${PN}/${PN}.ini@" \
- -i scripts/${PN}.service || die
-}
-
-src_configure() {
- myuse() {
- [[ -n "${1}" ]] || die "myconf: No use flag given."
- use ${1} || echo "no-${1}"
- }
- local conf_add=(
- no-client
- $(myuse dbus)
- $(usex debug 'symbols debug' release)
- $(myuse ice)
- $(myuse pch)
- $(usex zeroconf '' no-bonjour)
- )
-
- eqmake5 main.pro -recursive \
- CONFIG+="${conf_add[*]}"
-}
-
-src_install() {
- dodoc README CHANGES
-
- docinto scripts
- dodoc -r scripts/server
- docompress -x /usr/share/doc/${PF}/scripts
-
- local dir="$(usex debug debug release)"
- dobin "${dir}"/murmurd
-
- local etcdir="/etc/murmur"
- insinto ${etcdir}
- newins scripts/${PN}.ini.system ${PN}.ini
-
- insinto /etc/logrotate.d/
- newins "${FILESDIR}"/murmur.logrotate murmur
-
- insinto /etc/dbus-1/system.d/
- doins scripts/murmur.conf
-
- insinto /usr/share/murmur/
- doins src/murmur/Murmur.ice
-
- newinitd "${FILESDIR}"/murmur.initd-r1 murmur
- newconfd "${FILESDIR}"/murmur.confd murmur
-
- systemd_dounit scripts/${PN}.service
- newtmpfiles "${FILESDIR}"/murmurd-dbus.tmpfiles "${PN}".conf
-
- keepdir /var/lib/murmur /var/log/murmur
- fowners -R murmur /var/lib/murmur /var/log/murmur
- fperms 750 /var/lib/murmur /var/log/murmur
-
- # Fix permissions on config file as it might contain passwords.
- # (bug #559362)
- fowners root:murmur ${etcdir}/murmur.ini
- fperms 640 ${etcdir}/murmur.ini
-
- doman man/murmurd.1
-
- readme.gentoo_create_doc
-}
-
-pkg_postinst() {
- tmpfiles_process ${PN}.conf
- readme.gentoo_print_elog
-}
diff --git a/media-sound/murmur/murmur-1.3.4.ebuild b/media-sound/murmur/murmur-1.3.4.ebuild
deleted file mode 100644
index 6af71f6272f..00000000000
--- a/media-sound/murmur/murmur-1.3.4.ebuild
+++ /dev/null
@@ -1,162 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit qmake-utils systemd readme.gentoo-r1 tmpfiles
-
-DESCRIPTION="Mumble is an open source, low-latency, high quality voice chat software"
-HOMEPAGE="https://wiki.mumble.info"
-if [[ "${PV}" == 9999 ]] ; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/mumble-voip/mumble.git"
- EGIT_SUBMODULES=( '-*' )
-else
- MY_PN="mumble"
- if [[ "${PV}" == *_pre* ]] ; then
- MY_P="${MY_PN}-${PV}"
- SRC_URI="https://dev.gentoo.org/~polynomial-c/dist/${MY_P}.tar.xz"
- S="${WORKDIR}/${MY_P}"
- else
- MY_PV="${PV/_/-}"
- MY_P="${MY_PN}-${MY_PV}"
- SRC_URI="https://github.com/mumble-voip/mumble/releases/download/${MY_PV}/${MY_P}.tar.gz
- https://dl.mumble.info/${MY_P}.tar.gz"
- S="${WORKDIR}/${MY_PN}-${PV/_*}"
- fi
- KEYWORDS="~amd64 ~arm ~x86"
-fi
-
-LICENSE="BSD"
-SLOT="0"
-IUSE="+dbus debug +ice pch zeroconf"
-
-RDEPEND="
- acct-group/murmur
- acct-user/murmur
- >=dev-libs/openssl-1.0.0b:0=
- >=dev-libs/protobuf-2.2.0:=
- dev-qt/qtcore:5
- dev-qt/qtnetwork:5
- || (
- dev-qt/qtsql:5[sqlite]
- dev-qt/qtsql:5[mysql]
- )
- dev-qt/qtxml:5
- sys-apps/lsb-release
- >=sys-libs/libcap-2.15
- dbus? ( dev-qt/qtdbus:5 )
- ice? ( dev-libs/Ice:= )
- zeroconf? ( net-dns/avahi[mdnsresponder-compat] )
-"
-
-DEPEND="${RDEPEND}
- >=dev-libs/boost-1.41.0
-"
-BDEPEND="
- acct-group/murmur
- acct-user/murmur
- virtual/pkgconfig
-"
-
-if [[ "${PV}" == *9999 ]] ; then
- # Required for the mkini.sh script which calls perl multiple times
- BDEPEND+="
- dev-lang/perl
- "
-fi
-
-DOC_CONTENTS="
- Useful scripts are located in /usr/share/doc/${PF}/scripts.\n
- Please execute:\n
- murmurd -ini /etc/murmur/murmur.ini -supw <pw>\n
- chown murmur:murmur /var/lib/murmur/murmur.sqlite\n
- to set the build-in 'SuperUser' password before starting murmur.
- Please restart dbus before starting murmur, or else dbus
- registration will fail.
-"
-
-src_prepare() {
- default
-
- if [[ "${PV}" == *9999 ]] ; then
- pushd scripts &>/dev/null || die
- ./mkini.sh || die
- popd &>/dev/null || die
- fi
-
- sed \
- -e 's:mumble-server:murmur:g' \
- -e 's:/var/run:/run:g' \
- -i "${S}"/scripts/murmur.{conf,ini.system} || die
-
- # Adjust systemd service file to our config location #689208
- sed "s@/etc/${PN}\.ini@/etc/${PN}/${PN}.ini@" \
- -i scripts/${PN}.service || die
-}
-
-src_configure() {
- myuse() {
- [[ -n "${1}" ]] || die "myconf: No use flag given."
- use ${1} || echo "no-${1}"
- }
- local conf_add=(
- no-client
- $(myuse dbus)
- $(usex debug 'symbols debug' release)
- $(myuse ice)
- $(myuse pch)
- $(usex zeroconf '' no-bonjour)
- )
-
- eqmake5 main.pro -recursive \
- CONFIG+="${conf_add[*]}"
-}
-
-src_install() {
- dodoc README CHANGES
-
- docinto scripts
- dodoc -r scripts/server
- docompress -x /usr/share/doc/${PF}/scripts
-
- local dir="$(usex debug debug release)"
- dobin "${dir}"/murmurd
-
- local etcdir="/etc/murmur"
- insinto ${etcdir}
- newins scripts/${PN}.ini.system ${PN}.ini
-
- insinto /etc/logrotate.d/
- newins "${FILESDIR}"/murmur.logrotate murmur
-
- insinto /etc/dbus-1/system.d/
- doins scripts/murmur.conf
-
- insinto /usr/share/murmur/
- doins src/murmur/Murmur.ice
-
- newinitd "${FILESDIR}"/murmur.initd-r1 murmur
- newconfd "${FILESDIR}"/murmur.confd murmur
-
- systemd_dounit scripts/${PN}.service
- newtmpfiles "${FILESDIR}"/murmurd-dbus.tmpfiles "${PN}".conf
-
- keepdir /var/lib/murmur /var/log/murmur
- fowners -R murmur /var/lib/murmur /var/log/murmur
- fperms 750 /var/lib/murmur /var/log/murmur
-
- # Fix permissions on config file as it might contain passwords.
- # (bug #559362)
- fowners root:murmur ${etcdir}/murmur.ini
- fperms 640 ${etcdir}/murmur.ini
-
- doman man/murmurd.1
-
- readme.gentoo_create_doc
-}
-
-pkg_postinst() {
- tmpfiles_process ${PN}.conf
- readme.gentoo_print_elog
-}
diff --git a/media-sound/murmur/murmur-1.4.230-r2.ebuild b/media-sound/murmur/murmur-1.4.230-r2.ebuild
deleted file mode 100644
index d0e26545bd3..00000000000
--- a/media-sound/murmur/murmur-1.4.230-r2.ebuild
+++ /dev/null
@@ -1,176 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit cmake systemd readme.gentoo-r1 tmpfiles
-
-DESCRIPTION="Mumble is an open source, low-latency, high quality voice chat software"
-HOMEPAGE="https://wiki.mumble.info"
-if [[ "${PV}" == 9999 ]] ; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/mumble-voip/mumble.git"
- EGIT_SUBMODULES=( '-*' )
-else
- MY_PN="mumble"
- if [[ "${PV}" == *_pre* ]] ; then
- MY_P="${MY_PN}-${PV}"
- SRC_URI="https://dev.gentoo.org/~polynomial-c/dist/${MY_P}.tar.xz"
- S="${WORKDIR}/${MY_P}"
- else
- MY_PV="${PV/_/-}"
- MY_P="${MY_PN}-${MY_PV}"
- SRC_URI="https://github.com/mumble-voip/mumble/releases/download/${MY_PV}/${MY_P}.tar.gz
- https://dl.mumble.info/${MY_P}.tar.gz"
- S="${WORKDIR}/${MY_PN}-${PV/_*}.src"
- fi
- KEYWORDS="~amd64 ~x86"
-fi
-
-SRC_URI+=" https://dev.gentoo.org/~polynomial-c/mumble-1.4-openssl3.patch.xz"
-
-LICENSE="BSD"
-SLOT="0"
-IUSE="+dbus grpc +ice test zeroconf"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- acct-group/murmur
- acct-user/murmur
- >=dev-libs/openssl-1.0.0b:0=
- >=dev-libs/protobuf-2.2.0:=
- dev-qt/qtcore:5
- dev-qt/qtnetwork:5
- || (
- dev-qt/qtsql:5[sqlite]
- dev-qt/qtsql:5[mysql]
- )
- dev-qt/qtxml:5
- sys-apps/lsb-release
- >=sys-libs/libcap-2.15
- dbus? ( dev-qt/qtdbus:5 )
- grpc? ( net-libs/grpc )
- ice? ( dev-libs/Ice:= )
- zeroconf? ( net-dns/avahi[mdnsresponder-compat] )
-"
-
-DEPEND="${RDEPEND}
- >=dev-libs/boost-1.41.0
- dev-qt/qttest:5
-"
-BDEPEND="
- acct-group/murmur
- acct-user/murmur
- virtual/pkgconfig
-"
-
-if [[ "${PV}" == *9999 ]] ; then
- # Required for the mkini.sh script which calls perl multiple times
- BDEPEND+="
- dev-lang/perl
- "
-fi
-
-DOC_CONTENTS="
- Useful scripts are located in /usr/share/doc/${PF}/scripts.\n
- Please execute:\n
- murmurd -ini /etc/murmur/murmur.ini -supw <pw>\n
- chown murmur:murmur /var/lib/murmur/murmur.sqlite\n
- to set the build-in 'SuperUser' password before starting murmur.
- Please restart dbus before starting murmur, or else dbus
- registration will fail.
-"
-
-PATCHES=(
- "${WORKDIR}/mumble-1.4-openssl3.patch"
-)
-
-src_prepare() {
- if [[ "${PV}" == *9999 ]] ; then
- pushd scripts &>/dev/null || die
- ./mkini.sh || die
- popd &>/dev/null || die
- fi
-
- sed \
- -e 's:mumble-server:murmur:g' \
- -e 's:/var/run:/run:g' \
- -i "${S}"/scripts/murmur.{conf,ini} || die
-
- # Adjust systemd service file to our config location #689208
- sed \
- -e "s@/etc/${PN}\.ini@/etc/${PN}/${PN}.ini@" \
- -e "s@murmurd@mumble-server@" \
- -i scripts/${PN}.service || die
-
- cmake_src_prepare
-}
-
-src_configure() {
- myuse() {
- [[ -n "${1}" ]] || die "myconf: No use flag given."
- use ${1} || echo "no-${1}"
- }
- local mycmakeargs=(
- -DBUILD_TESTING="$(usex test)"
- -Dclient="OFF"
- -Ddbus="$(usex dbus)"
- -Dg15="OFF"
- -Dgrpc="$(usex grpc)"
- -Dice="$(usex ice)"
- -Doverlay="OFF"
- -Dserver="ON"
- -Dzeroconf="$(usex zeroconf)"
- )
- if [[ "${PV}" != 9999 ]] ; then
- mycmakeargs+=( -DBUILD_NUMBER="$(ver_cut 3)" )
- fi
- cmake_src_configure
-}
-
-src_install() {
- cmake_src_install
-
- dodoc README.md CHANGES
-
- docinto scripts
- dodoc -r scripts/server
- docompress -x /usr/share/doc/${PF}/scripts
-
- local etcdir="/etc/murmur"
- insinto ${etcdir}
- doins scripts/${PN}.ini
-
- insinto /etc/logrotate.d/
- newins "${FILESDIR}"/murmur.logrotate murmur
-
- insinto /etc/dbus-1/system.d/
- doins scripts/murmur.conf
-
- insinto /usr/share/murmur/
- doins src/murmur/Murmur.ice
-
- newinitd "${FILESDIR}"/murmur.initd-r2 murmur
- newconfd "${FILESDIR}"/murmur.confd murmur
-
- systemd_dounit scripts/${PN}.service
- newtmpfiles "${FILESDIR}"/murmurd-dbus.tmpfiles "${PN}".conf
-
- keepdir /var/lib/murmur /var/log/murmur
- fowners -R murmur /var/lib/murmur /var/log/murmur
- fperms 750 /var/lib/murmur /var/log/murmur
-
- # Fix permissions on config file as it might contain passwords.
- # (bug #559362)
- fowners root:murmur ${etcdir}/murmur.ini
- fperms 640 ${etcdir}/murmur.ini
-
- doman man/murmurd.1
-
- readme.gentoo_create_doc
-}
-
-pkg_postinst() {
- tmpfiles_process ${PN}.conf
- readme.gentoo_print_elog
-}
diff --git a/media-sound/murmur/murmur-9999.ebuild b/media-sound/murmur/murmur-9999.ebuild
deleted file mode 100644
index d5c37496cf5..00000000000
--- a/media-sound/murmur/murmur-9999.ebuild
+++ /dev/null
@@ -1,170 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit cmake systemd readme.gentoo-r1 tmpfiles
-
-DESCRIPTION="Mumble is an open source, low-latency, high quality voice chat software"
-HOMEPAGE="https://wiki.mumble.info"
-if [[ "${PV}" == 9999 ]] ; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/mumble-voip/mumble.git"
- EGIT_SUBMODULES=( '-*' )
-else
- MY_PN="mumble"
- if [[ "${PV}" == *_pre* ]] ; then
- MY_P="${MY_PN}-${PV}"
- SRC_URI="https://dev.gentoo.org/~polynomial-c/dist/${MY_P}.tar.xz"
- S="${WORKDIR}/${MY_P}"
- else
- MY_PV="${PV/_/-}"
- MY_P="${MY_PN}-${MY_PV}"
- SRC_URI="https://github.com/mumble-voip/mumble/releases/download/${MY_PV}/${MY_P}.tar.gz
- https://dl.mumble.info/${MY_P}.tar.gz"
- S="${WORKDIR}/${MY_PN}-${PV/_*}.src"
- fi
- KEYWORDS="~amd64 ~x86"
-fi
-
-LICENSE="BSD"
-SLOT="0"
-IUSE="+dbus grpc +ice test zeroconf"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- acct-group/murmur
- acct-user/murmur
- >=dev-libs/openssl-1.0.0b:0=
- >=dev-libs/protobuf-2.2.0:=
- dev-qt/qtcore:5
- dev-qt/qtnetwork:5
- || (
- dev-qt/qtsql:5[sqlite]
- dev-qt/qtsql:5[mysql]
- )
- dev-qt/qtxml:5
- sys-apps/lsb-release
- >=sys-libs/libcap-2.15
- dbus? ( dev-qt/qtdbus:5 )
- grpc? ( net-libs/grpc )
- ice? ( dev-libs/Ice:= )
- zeroconf? ( net-dns/avahi[mdnsresponder-compat] )
-"
-
-DEPEND="${RDEPEND}
- >=dev-libs/boost-1.41.0
- dev-qt/qttest:5
-"
-BDEPEND="
- acct-group/murmur
- acct-user/murmur
- virtual/pkgconfig
-"
-
-if [[ "${PV}" == *9999 ]] ; then
- # Required for the mkini.sh script which calls perl multiple times
- BDEPEND+="
- dev-lang/perl
- "
-fi
-
-DOC_CONTENTS="
- Useful scripts are located in /usr/share/doc/${PF}/scripts.\n
- Please execute:\n
- murmurd -ini /etc/murmur/murmur.ini -supw <pw>\n
- chown murmur:murmur /var/lib/murmur/murmur.sqlite\n
- to set the build-in 'SuperUser' password before starting murmur.
- Please restart dbus before starting murmur, or else dbus
- registration will fail.
-"
-
-src_prepare() {
- if [[ "${PV}" == *9999 ]] ; then
- pushd scripts &>/dev/null || die
- ./mkini.sh || die
- popd &>/dev/null || die
- fi
-
- sed \
- -e 's:mumble-server:murmur:g' \
- -e 's:/var/run:/run:g' \
- -i "${S}"/scripts/murmur.{conf,ini} || die
-
- # Adjust systemd service file to our config location #689208
- sed \
- -e "s@/etc/${PN}\.ini@/etc/${PN}/${PN}.ini@" \
- -e "s@murmurd@mumble-server@" \
- -i scripts/${PN}.service || die
-
- cmake_src_prepare
-}
-
-src_configure() {
- myuse() {
- [[ -n "${1}" ]] || die "myconf: No use flag given."
- use ${1} || echo "no-${1}"
- }
- local mycmakeargs=(
- -DBUILD_TESTING="$(usex test)"
- -Dclient="OFF"
- -Ddbus="$(usex dbus)"
- -Dg15="OFF"
- -Dgrpc="$(usex grpc)"
- -Dice="$(usex ice)"
- -Doverlay="OFF"
- -Dserver="ON"
- -Dzeroconf="$(usex zeroconf)"
- )
- if [[ "${PV}" != 9999 ]] ; then
- mycmakeargs+=( -DBUILD_NUMBER="$(ver_cut 3)" )
- fi
- cmake_src_configure
-}
-
-src_install() {
- cmake_src_install
-
- dodoc README.md CHANGES
-
- docinto scripts
- dodoc -r scripts/server
- docompress -x /usr/share/doc/${PF}/scripts
-
- local etcdir="/etc/murmur"
- insinto ${etcdir}
- doins scripts/${PN}.ini
-
- insinto /etc/logrotate.d/
- newins "${FILESDIR}"/murmur.logrotate murmur
-
- insinto /etc/dbus-1/system.d/
- doins scripts/murmur.conf
-
- insinto /usr/share/murmur/
- doins src/murmur/Murmur.ice
-
- newinitd "${FILESDIR}"/murmur.initd-r2 murmur
- newconfd "${FILESDIR}"/murmur.confd murmur
-
- systemd_dounit scripts/${PN}.service
- newtmpfiles "${FILESDIR}"/murmurd-dbus.tmpfiles "${PN}".conf
-
- keepdir /var/lib/murmur /var/log/murmur
- fowners -R murmur /var/lib/murmur /var/log/murmur
- fperms 750 /var/lib/murmur /var/log/murmur
-
- # Fix permissions on config file as it might contain passwords.
- # (bug #559362)
- fowners root:murmur ${etcdir}/murmur.ini
- fperms 640 ${etcdir}/murmur.ini
-
- doman man/murmurd.1
-
- readme.gentoo_create_doc
-}
-
-pkg_postinst() {
- tmpfiles_process ${PN}.conf
- readme.gentoo_print_elog
-}
diff --git a/media-sound/musescore/musescore-3.6.2.ebuild b/media-sound/musescore/musescore-3.6.2-r1.ebuild
index 96f936a41a6..c5afad3d5f4 100644
--- a/media-sound/musescore/musescore-3.6.2.ebuild
+++ b/media-sound/musescore/musescore-3.6.2-r1.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CMAKE_MAKEFILE_GENERATOR="emake"
CHECKREQS_DISK_BUILD=3500M
-inherit cmake xdg check-reqs
+inherit cmake qmake-utils xdg check-reqs
if [[ ${PV} == "9999" ]]; then
inherit git-r3
@@ -83,13 +83,16 @@ src_prepare() {
}
src_configure() {
+ # bug #766111
+ export PATH="$(qt5_get_bindir):${PATH}"
+
local mycmakeargs=(
-DAEOLUS=OFF # does not compile
-DBUILD_ALSA="$(usex alsa)"
-DBUILD_CRASH_REPORTER=OFF
-DBUILD_JACK="$(usex jack)"
-DBUILD_LAME="$(usex mp3)"
- -DBUILD_PCH=ON
+ -DBUILD_PCH=OFF
-DBUILD_PORTAUDIO="$(usex portaudio)"
-DBUILD_PORTMIDI="$(usex portmidi)"
-DBUILD_PULSEAUDIO="$(usex pulseaudio)"
diff --git a/media-sound/musescore/musescore-9999.ebuild b/media-sound/musescore/musescore-9999.ebuild
index 01dcab44b22..d2e8794771d 100644
--- a/media-sound/musescore/musescore-9999.ebuild
+++ b/media-sound/musescore/musescore-9999.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CMAKE_MAKEFILE_GENERATOR="emake"
CHECKREQS_DISK_BUILD=3500M
-inherit cmake xdg check-reqs
+inherit cmake qmake-utils xdg check-reqs
if [[ ${PV} == "9999" ]]; then
inherit git-r3
@@ -79,13 +79,16 @@ src_prepare() {
}
src_configure() {
+ # bug #766111
+ export PATH="$(qt5_get_bindir):${PATH}"
+
local mycmakeargs=(
-DAEOLUS=OFF # does not compile
-DBUILD_ALSA="$(usex alsa)"
-DBUILD_CRASH_REPORTER=OFF
-DBUILD_JACK="$(usex jack)"
-DBUILD_LAME="$(usex mp3)"
- -DBUILD_PCH=ON
+ -DBUILD_PCH=OFF
-DBUILD_PORTAUDIO="$(usex portaudio)"
-DBUILD_PORTMIDI="$(usex portmidi)"
-DBUILD_PULSEAUDIO="$(usex pulseaudio)"
@@ -98,6 +101,7 @@ src_configure() {
-DOCR=OFF
-DOMR="$(usex omr)"
-DSOUNDFONT3=ON
+ -DTRY_USE_CCACHE=OFF
-DZERBERUS="$(usex sfz)"
-DUSE_PATH_WITH_EXPLICIT_QT_VERSION=ON
-DUSE_SYSTEM_FREETYPE=ON
diff --git a/media-sound/ncmpc/Manifest b/media-sound/ncmpc/Manifest
index c6ec0154360..f9592927f60 100644
--- a/media-sound/ncmpc/Manifest
+++ b/media-sound/ncmpc/Manifest
@@ -1 +1 @@
-DIST ncmpc-0.46.tar.xz 289332 BLAKE2B e57a931f5a512c543d48a9b6e532c7944e655d28d02fe9ec2b5b41563e2e6a5806924a668ae592f3fee58a2bb04a681fee0903b8046a61ce39a453092dfd8623 SHA512 34cbb9ff527bfa4d849069694b6d1a1e54c932b64538e799c9ef9b9ccc42ed24932b6bcbf3552af6ce846af6b7399916e1aabc6c79ac564f1c9fe56a33b6332f
+DIST ncmpc-0.47.tar.xz 291400 BLAKE2B 4b9e5bcc435b6064c054ad84000986942a699993e78decb26b73b4f3ec8d261e4e752e11d40ed5bdcbaab260b37f1a59b99708be05ade44973fee3f2b1e6d9d1 SHA512 6c9990ca9a0781eef67fae8b20ceec5fc00177b1db2b08cfdf122dd1f61f87a92030baadcaac154d73ddee622c963481d4e37d46f76a4ef21e51d4f18a6f3e6a
diff --git a/media-sound/ncmpc/ncmpc-0.46.ebuild b/media-sound/ncmpc/ncmpc-0.47.ebuild
index a57957c157b..969bcddf685 100644
--- a/media-sound/ncmpc/ncmpc-0.46.ebuild
+++ b/media-sound/ncmpc/ncmpc-0.47.ebuild
@@ -19,7 +19,7 @@ BDEPEND="
doc? ( dev-python/sphinx )
"
RDEPEND="
- >=media-libs/libmpdclient-2.9
+ media-libs/libmpdclient
sys-libs/ncurses:=[unicode(+)]
lirc? ( app-misc/lirc )
pcre? ( dev-libs/libpcre2 )
diff --git a/media-sound/openmpt123/Manifest b/media-sound/openmpt123/Manifest
index d4172ecc55a..357a68a8db7 100644
--- a/media-sound/openmpt123/Manifest
+++ b/media-sound/openmpt123/Manifest
@@ -1 +1 @@
-DIST libopenmpt-0.6.3+release.autotools.tar.gz 1514410 BLAKE2B e61473b3dcb1c88450b72fdd29b7e22f794134ffdf23222a79bf715c6e1c1810e19a5fb48cd6e1536d1f892349cf90cfa34b90e0a67e1c208e993f2db51af082 SHA512 b9f9cce9ef7d87ad8f18d17603b613fd153d5effdf04de566daabe26afa08b84eb0aa089b94fcbf7cb724befd0a3d93ffdaf5b578f2a3afa31f7aa517f39c62f
+DIST libopenmpt-0.6.4+release.autotools.tar.gz 1547663 BLAKE2B f1c7254146437ce3ca646049c05fe4ae0575012724584a7b2cfce7dfdacf7987eb5403b0634d1961e1b7b176adfbbcbb23a9966d874e489ebcf01524a020750d SHA512 7306ddbe030b8e82ad24fc85083d13d7ca680870f4dbe7215399719cd63ee9ed9e5c4c6229e9f17fb5a2005e86b21ceed0dab158d3f0b73c606579654434421f
diff --git a/media-sound/openmpt123/openmpt123-0.6.3.ebuild b/media-sound/openmpt123/openmpt123-0.6.4.ebuild
index f9f538ff046..f9f538ff046 100644
--- a/media-sound/openmpt123/openmpt123-0.6.3.ebuild
+++ b/media-sound/openmpt123/openmpt123-0.6.4.ebuild
diff --git a/media-sound/pamix/metadata.xml b/media-sound/pamix/metadata.xml
index 010dd5c1f9f..b62d7c2c323 100644
--- a/media-sound/pamix/metadata.xml
+++ b/media-sound/pamix/metadata.xml
@@ -1,10 +1,7 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer type="person">
- <email>polynomial-c@gentoo.org</email>
- <name>Lars Wendler</name>
- </maintainer>
+ <!-- maintainer-needed -->
<upstream>
<remote-id type="github">patroclos/PAmix</remote-id>
</upstream>
diff --git a/media-sound/paprefs/paprefs-1.2-r1.ebuild b/media-sound/paprefs/paprefs-1.2-r2.ebuild
index 29908197114..10b075e5e05 100644
--- a/media-sound/paprefs/paprefs-1.2-r1.ebuild
+++ b/media-sound/paprefs/paprefs-1.2-r2.ebuild
@@ -31,7 +31,8 @@ BDEPEND="
src_configure() {
append-cxxflags -std=c++11 #568590
- local mymesonargs=(
+
+ local emesonargs=(
-Dlynx=false
)
meson_src_configure
diff --git a/media-sound/pasystray/pasystray-0.8.0-r1.ebuild b/media-sound/pasystray/pasystray-0.8.0-r1.ebuild
index a58c48834be..a91da372521 100644
--- a/media-sound/pasystray/pasystray-0.8.0-r1.ebuild
+++ b/media-sound/pasystray/pasystray-0.8.0-r1.ebuild
@@ -11,7 +11,7 @@ SRC_URI="https://github.com/christophgysin/${PN}/archive/refs/tags/${PV}.tar.gz
LICENSE="LGPL-2.1+"
SLOT="0"
-KEYWORDS="amd64 ~arm ~x86"
+KEYWORDS="amd64 ~arm ~arm64 ~x86"
IUSE="libnotify zeroconf"
RDEPEND="
diff --git a/media-sound/patchage/Manifest b/media-sound/patchage/Manifest
index 8d79df994c1..8fca8a19891 100644
--- a/media-sound/patchage/Manifest
+++ b/media-sound/patchage/Manifest
@@ -1 +1 @@
-DIST patchage-1.0.4.tar.bz2 661824 BLAKE2B 3e56b7513e19e0acb1ef524ba7d7754699abdb6a968547f7a545c8651f23a33c209b9728dae01d839022ec380185a1673ff58733c1553007a6a3b7c889aa7f03 SHA512 665d81ca16c1052f71c3037d2ad8f9a6120b09a323999468484dda1b4c4b567c36728ebe38c54152406b63a4107f04764d0dede52302bc7a7b124e82132749fb
+DIST patchage-1.0.6.tar.bz2 664841 BLAKE2B 72d0de6d12e07ec160f4c59c51f138e1220a1b8994bdab90f56dd715bf16b6f561836d184ec5d5077de3bc7bb5c6778ea2b7bcbf0b33230be662f2b729eac568 SHA512 b7aedcb07da0c81842929833ab93a0b20c08e465bf05ebb4e47670d295c0d4d0d50f0f74001d9264c2c23ef08d3881232e7622ecf101d1d53ffcae2f8c0f31d3
diff --git a/media-sound/patchage/files/patchage-1.0.4-fix-compilation.patch b/media-sound/patchage/files/patchage-1.0.4-fix-compilation.patch
deleted file mode 100644
index aace519e630..00000000000
--- a/media-sound/patchage/files/patchage-1.0.4-fix-compilation.patch
+++ /dev/null
@@ -1,48 +0,0 @@
-diff --git a/src/JackDbusDriver.cpp b/src/JackDbusDriver.cpp
-index 23c12f2..f49a522 100644
---- a/src/JackDbusDriver.cpp
-+++ b/src/JackDbusDriver.cpp
-@@ -24,6 +24,7 @@
- #include "SignalDirection.hpp"
- #include "make_jack_driver.hpp"
- #include "warnings.hpp"
-+#include "AudioDriver.hpp"
-
- PATCHAGE_DISABLE_FMT_WARNINGS
- #include <fmt/core.h>
-@@ -61,7 +62,7 @@ namespace {
- class JackDriver : public AudioDriver
- {
- public:
-- explicit JackDriver(ILog& log, EventSink emit_event);
-+ explicit JackDriver(ILog& log, Driver::EventSink emit_event);
-
- JackDriver(const JackDriver&) = delete;
- JackDriver& operator=(const JackDriver&) = delete;
-@@ -75,7 +76,7 @@ public:
- void attach(bool launch_daemon) override;
- void detach() override;
- bool is_attached() const override;
-- void refresh(const EventSink& sink) override;
-+ void refresh(const Driver::EventSink& sink) override;
- bool connect(const PortID& tail_id, const PortID& head_id) override;
- bool disconnect(const PortID& tail_id, const PortID& head_id) override;
-
-@@ -129,7 +130,7 @@ private:
- dbus_uint64_t _graph_version;
- };
-
--JackDriver::JackDriver(ILog& log, EventSink emit_event)
-+JackDriver::JackDriver(ILog& log, Driver::EventSink emit_event)
- : AudioDriver{std::move(emit_event)}
- , _log(log)
- , _dbus_error()
-@@ -584,7 +585,7 @@ JackDriver::is_attached() const
- }
-
- void
--JackDriver::refresh(const EventSink& sink)
-+JackDriver::refresh(const Driver::EventSink& sink)
- {
- DBusMessage* reply_ptr = nullptr;
- DBusMessageIter iter = {};
diff --git a/media-sound/patchage/metadata.xml b/media-sound/patchage/metadata.xml
index 31c35cf5131..4bae645001a 100644
--- a/media-sound/patchage/metadata.xml
+++ b/media-sound/patchage/metadata.xml
@@ -1,11 +1,14 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer type="project">
- <email>proaudio@gentoo.org</email>
- <name>Gentoo ProAudio Project</name>
- </maintainer>
- <use>
- <flag name="jack-dbus">Use Jack via D-Bus instead of libjack</flag>
- </use>
+ <maintainer type="project">
+ <email>proaudio@gentoo.org</email>
+ <name>Gentoo ProAudio Project</name>
+ </maintainer>
+ <use>
+ <flag name="jack-dbus">Use Jack via D-Bus instead of libjack</flag>
+ </use>
+ <upstream>
+ <remote-id type="gitlab">drobilla/patchage</remote-id>
+ </upstream>
</pkgmetadata>
diff --git a/media-sound/patchage/patchage-1.0.4.ebuild b/media-sound/patchage/patchage-1.0.6.ebuild
index b9a415d93c2..3427226b5b0 100644
--- a/media-sound/patchage/patchage-1.0.4.ebuild
+++ b/media-sound/patchage/patchage-1.0.6.ebuild
@@ -1,14 +1,15 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7,8,9} )
+
+PYTHON_COMPAT=( python3_{8..11} )
PYTHON_REQ_USE='threads(+)'
inherit waf-utils python-any-r1 xdg
DESCRIPTION="Modular patch bay for JACK-based audio and MIDI systems"
-HOMEPAGE="http://drobilla.net/software/patchage"
-SRC_URI="http://download.drobilla.net/${P}.tar.bz2"
+HOMEPAGE="https://drobilla.net/software/patchage"
+SRC_URI="https://download.drobilla.net/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
@@ -17,7 +18,6 @@ IUSE="alsa debug jack-dbus"
BDEPEND="
${PYTHON_DEPS}
- dev-libs/boost
virtual/pkgconfig
"
RDEPEND="dev-cpp/glibmm:2
@@ -29,14 +29,12 @@ RDEPEND="dev-cpp/glibmm:2
dev-libs/dbus-glib
sys-apps/dbus
)"
-DEPEND="${RDEPEND}"
+DEPEND="${RDEPEND}
+ dev-libs/boost
+ dev-libs/libfmt:="
DOCS=( AUTHORS NEWS README.md )
-PATCHES=(
- "${FILESDIR}/${P}-fix-compilation.patch"
-)
-
src_configure() {
waf-utils_src_configure \
$(use debug && echo "--debug") \
diff --git a/media-sound/pianobar/Manifest b/media-sound/pianobar/Manifest
index fcbb4c5410f..e3f41875f37 100644
--- a/media-sound/pianobar/Manifest
+++ b/media-sound/pianobar/Manifest
@@ -1 +1,2 @@
DIST pianobar-2020.04.05.tar.bz2 48823 BLAKE2B 91e9b96f0a635995ab08bd189b7b6b353f553b6c6cd405be2e95f9c0401b075158df4aa28633854747eced4ac60777724dd265dae62744c773d5f4b4c12aa90e SHA512 40d717693f128da3718c0e1be9c90c269712becf9ac2ffe0669a91ea9417d0fdb0476949df29c1da908e2d78678f26955149dbb8c5a0167161f95835ce76084e
+DIST pianobar-2022.04.01.tar.bz2 52262 BLAKE2B d6f28a893ad94aed2cb7cda55a2b00480bb1319e01561974d75a10559c5ccda45fa6fe216d0b1d130c33d6eb2d7b395a95942a8a62eec0c21912f208799cc8f3 SHA512 9ad60c0048b375d74ad2bab289d75deec6dba46c31bfc1799dabf18661ec0cdef494df72273e6c16989ead21dc034445595a3e2ace43f6b6ca61446449895aef
diff --git a/media-sound/pianobar/metadata.xml b/media-sound/pianobar/metadata.xml
index 93423219a5b..fcf0dd5274a 100644
--- a/media-sound/pianobar/metadata.xml
+++ b/media-sound/pianobar/metadata.xml
@@ -5,4 +5,7 @@
<email>sound@gentoo.org</email>
<name>Gentoo Sound project</name>
</maintainer>
+ <upstream>
+ <remote-id type="github">PromyLOPh/pianobar</remote-id>
+ </upstream>
</pkgmetadata>
diff --git a/media-sound/pianobar/pianobar-2022.04.01.ebuild b/media-sound/pianobar/pianobar-2022.04.01.ebuild
new file mode 100644
index 00000000000..2ad410129b2
--- /dev/null
+++ b/media-sound/pianobar/pianobar-2022.04.01.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs flag-o-matic
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/PromyLOPh/pianobar.git"
+else
+ SRC_URI="https://6xq.net/${PN}/${P}.tar.bz2"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="A console-based replacement for Pandora's flash player"
+HOMEPAGE="https://6xq.net/pianobar/"
+
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="
+ dev-libs/json-c:=
+ dev-libs/libgcrypt:=
+ media-libs/libao
+ >=media-video/ffmpeg-3.3:=
+ net-misc/curl
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_compile() {
+ append-cflags -std=c99
+ tc-export AR CC
+ emake V=1 DYNLINK=1
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX=/usr LIBDIR=/usr/$(get_libdir) DYNLINK=1 install
+ dodoc ChangeLog README.rst
+
+ rm "${D}"/usr/lib*/*.a || die
+
+ docinto contrib
+ dodoc -r contrib/{config-example,*.sh,eventcmd-examples}
+ docompress -x /usr/share/doc/${PF}/contrib
+}
diff --git a/media-sound/pianobar/pianobar-9999.ebuild b/media-sound/pianobar/pianobar-9999.ebuild
index a13e7069ac5..2ad410129b2 100644
--- a/media-sound/pianobar/pianobar-9999.ebuild
+++ b/media-sound/pianobar/pianobar-9999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit toolchain-funcs flag-o-matic
@@ -18,17 +18,16 @@ HOMEPAGE="https://6xq.net/pianobar/"
LICENSE="MIT"
SLOT="0"
-IUSE=""
-BDEPEND="virtual/pkgconfig"
RDEPEND="
dev-libs/json-c:=
- dev-libs/libgcrypt:0=
+ dev-libs/libgcrypt:=
media-libs/libao
- >=media-video/ffmpeg-3.3:0=
+ >=media-video/ffmpeg-3.3:=
net-misc/curl
"
DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
src_compile() {
append-cflags -std=c99
@@ -38,7 +37,7 @@ src_compile() {
src_install() {
emake DESTDIR="${D}" PREFIX=/usr LIBDIR=/usr/$(get_libdir) DYNLINK=1 install
- dodoc ChangeLog README.md
+ dodoc ChangeLog README.rst
rm "${D}"/usr/lib*/*.a || die
diff --git a/media-sound/picard/Manifest b/media-sound/picard/Manifest
index e2cc2ca1e35..63edcdf469f 100644
--- a/media-sound/picard/Manifest
+++ b/media-sound/picard/Manifest
@@ -1 +1 @@
-DIST picard-2.7.3.tar.gz 4887533 BLAKE2B 65a10be3dafcdd99e20d6c193d1238b0edfa66425a28c705bd6df0f57f75ddcf874f3bf09cef3c331e583a35f49ec780a63d2960081188081c8f0687f6a0b4d1 SHA512 33cd37ce19e261d14882b4400054c289bf921d3c74313db634f3876bc7f51ecca184aa29a9cb1d673fe799c53eda81de45d23c83caaf2f71b74fe341c258d2f7
+DIST picard-2.8.2.tar.gz 5095347 BLAKE2B ddaab9e7d09bd7848d55ac385cd901b5f7b3e2044811cd63b16027159586e01028f2885202c4d2bbfa20926305e110e075778f0b907ff8812c937fe0905a8fef SHA512 18b4ebc6e898f4e2910d4d022a12c0516030133318467c38a77325ce088a9dd632d3d8105944570f75b918d3f4dc32b1a501e93bc92a7315ec9ff35ed3e56699
diff --git a/media-sound/picard/picard-2.7.3.ebuild b/media-sound/picard/picard-2.8.2.ebuild
index c57f433dd76..e651b436e57 100644
--- a/media-sound/picard/picard-2.7.3.ebuild
+++ b/media-sound/picard/picard-2.8.2.ebuild
@@ -30,6 +30,7 @@ BDEPEND="
RDEPEND="
$(python_gen_cond_dep '
dev-python/fasteners[${PYTHON_USEDEP}]
+ dev-python/pyjwt[${PYTHON_USEDEP}]
dev-python/PyQt5[declarative,gui,network,widgets,${PYTHON_USEDEP}]
dev-python/python-dateutil[${PYTHON_USEDEP}]
dev-python/pyyaml[${PYTHON_USEDEP}]
diff --git a/media-sound/picard/picard-9999.ebuild b/media-sound/picard/picard-9999.ebuild
index a096198a73f..5e3533bb35f 100644
--- a/media-sound/picard/picard-9999.ebuild
+++ b/media-sound/picard/picard-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -30,6 +30,7 @@ BDEPEND="
RDEPEND="
$(python_gen_cond_dep '
dev-python/fasteners[${PYTHON_USEDEP}]
+ dev-python/pyjwt[${PYTHON_USEDEP}]
dev-python/PyQt5[declarative,gui,network,widgets,${PYTHON_USEDEP}]
dev-python/python-dateutil[${PYTHON_USEDEP}]
dev-python/pyyaml[${PYTHON_USEDEP}]
diff --git a/media-sound/pithos/pithos-1.5.1.ebuild b/media-sound/pithos/pithos-1.5.1-r1.ebuild
index 3ac4ffed7e6..3f062c66de6 100644
--- a/media-sound/pithos/pithos-1.5.1.ebuild
+++ b/media-sound/pithos/pithos-1.5.1-r1.ebuild
@@ -1,16 +1,11 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
-PYTHON_COMPAT=( python3_{7..9} )
+EAPI=8
+PYTHON_COMPAT=( python3_{8..11} )
inherit xdg meson gnome2-utils virtualx python-r1
-if [[ ${PV} =~ [9]{4,} ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/${PN}/${PN}.git"
-else
- SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-fi
+SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
DESCRIPTION="Pandora.com client for the GNOME desktop"
HOMEPAGE="https://pithos.github.io/"
@@ -21,7 +16,8 @@ KEYWORDS="~amd64"
IUSE="appindicator +keybinder libnotify test"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-RDEPEND="${PYTHON_DEPS}
+RDEPEND="
+ ${PYTHON_DEPS}
dev-python/pygobject[${PYTHON_USEDEP}]
app-crypt/libsecret[introspection]
dev-libs/appstream-glib[introspection]
diff --git a/media-sound/pms/files/pms-0.42_p20170508-gcc12-time.patch b/media-sound/pms/files/pms-0.42_p20170508-gcc12-time.patch
new file mode 100644
index 00000000000..b0d586eff2c
--- /dev/null
+++ b/media-sound/pms/files/pms-0.42_p20170508-gcc12-time.patch
@@ -0,0 +1,11 @@
+https://bugs.gentoo.org/851621
+--- a/src/message.cpp
++++ b/src/message.cpp
+@@ -23,6 +23,7 @@
+
+
+ #include <cstdarg>
++#include <ctime>
+ #include <stdio.h>
+ #include "message.h"
+
diff --git a/media-sound/pms/pms-0.42_p20170508-r1.ebuild b/media-sound/pms/pms-0.42_p20170508-r1.ebuild
index 9f0546f7b15..750e97d2c67 100644
--- a/media-sound/pms/pms-0.42_p20170508-r1.ebuild
+++ b/media-sound/pms/pms-0.42_p20170508-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -25,6 +25,10 @@ RDEPEND="
"
DEPEND="${RDEPEND}"
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.42_p20170508-gcc12-time.patch
+)
+
src_configure() {
local mycmakeargs=(
-DENABLE_DOC=$(usex doc)
diff --git a/media-sound/pms/pms-9999.ebuild b/media-sound/pms/pms-9999.ebuild
deleted file mode 100644
index c1e5c9adb45..00000000000
--- a/media-sound/pms/pms-9999.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit cmake git-r3
-
-DESCRIPTION="Practical Music Search: an open source ncurses client for mpd, written in C++"
-HOMEPAGE="https://ambientsound.github.io/pms"
-
-EGIT_REPO_URI="https://github.com/ambientsound/pms.git"
-EGIT_BRANCH="0.42.x" # todo: package the golang version
-
-LICENSE="GPL-3+"
-SLOT="0"
-KEYWORDS=""
-IUSE="+regex doc"
-
-BDEPEND="
- virtual/pkgconfig
- doc? ( app-text/pandoc )
-"
-RDEPEND="
- sys-libs/ncurses:=[unicode(+)]
- media-libs/libmpdclient
-"
-DEPEND="${RDEPEND}"
-
-src_configure() {
- local mycmakeargs=(
- -DENABLE_DOC=$(usex doc)
- -DENABLE_REGEX=$(usex regex)
- )
-
- cmake_src_configure
-}
diff --git a/media-sound/podracer/podracer-1.4-r2.ebuild b/media-sound/podracer/podracer-1.4-r2.ebuild
deleted file mode 100644
index 35df96ec5d5..00000000000
--- a/media-sound/podracer/podracer-1.4-r2.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-DESCRIPTION="A simple podcast aggregator, designed for cron"
-HOMEPAGE="http://podracer.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE=""
-
-DEPEND=""
-RDEPEND="app-shells/bash
- net-misc/curl"
-
-src_unpack() {
- default
-
- # Bug 619956. Change directories first to ensure that "unpack" outputs
- # to ${S} and not to ${WORKDIR}.
- cd "${S}" || die
- unpack "${S}/podracer.1.gz"
-}
-
-src_install() {
- dobin podracer
- sed -i -e "s:sample=/usr/share/doc/\$progname/sample.subscriptions:sample=/usr/share/doc/${PF}/sample.subscriptions:" "${D}"/usr/bin/podracer || die
- dodoc CREDITS README ChangeLog TODO
- doman podracer.1
- docompress -x "/usr/share/doc/${PF}/sample.subscriptions"
- dodoc sample.subscriptions
- insinto /etc/
- doins podracer.conf
-}
diff --git a/media-sound/podracer/podracer-1.4-r3.ebuild b/media-sound/podracer/podracer-1.4-r3.ebuild
new file mode 100644
index 00000000000..4a6f563736b
--- /dev/null
+++ b/media-sound/podracer/podracer-1.4-r3.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="A simple podcast aggregator, designed for cron"
+HOMEPAGE="http://podracer.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+RDEPEND="
+ app-shells/bash
+ net-misc/curl"
+
+src_unpack() {
+ default
+
+ # Bug 619956. Change directories first to ensure that
+ # "unpack" outputs to ${S} and not to ${WORKDIR}.
+ cd "${S}" || die
+ unpack "${S}"/podracer.1.gz
+}
+
+src_prepare() {
+ default
+ sed -e "s:sample=/usr/share/doc/\$progname/sample.subscriptions:sample=/usr/share/doc/${PF}/sample.subscriptions:" \
+ -i podracer || die
+}
+
+src_install() {
+ dobin podracer
+
+ dodoc CREDITS README ChangeLog TODO sample.subscriptions
+ docompress -x /usr/share/doc/${PF}/sample.subscriptions
+ doman podracer.1
+
+ insinto /etc
+ doins podracer.conf
+}
diff --git a/media-sound/puddletag/Manifest b/media-sound/puddletag/Manifest
index 7551fdaa1f3..b86e1c197c4 100644
--- a/media-sound/puddletag/Manifest
+++ b/media-sound/puddletag/Manifest
@@ -1 +1,2 @@
DIST puddletag-2.1.1.tar.gz 14628014 BLAKE2B 14343cc5731bd060dc836b14707948ef103c3e4c968974e7c578ac975a12d6d2b9d3dfa9750e6d0ac94e8a8466c85b82f409b93cc787a32d8950f5de1b60dd3e SHA512 b05ab8a09d5ad4d21f8384fa85beebe039b8ee7e775630a23981bfe88ac389fc34a6ac6eac6660a99f38e34157e6bd841ba12237f45e290fe96ded3ab6d44d77
+DIST puddletag-2.2.0.tar.gz 14355485 BLAKE2B 712b6c28adea9743476b9908e9c28a3988e88ca598cb7c65580f876a06770442852188fc727c411fc78fa972e68edbe9b1fa53542507b4a1edfd0285af776423 SHA512 92c430f54b49d2f193ffc4168f35bbadb069ca9b41b28250ee1c6dcb84853def20865d6df52940eebff8c5b812c0c8ab6b8971b66d398ff9ac94918e955322bb
diff --git a/media-sound/puddletag/puddletag-2.2.0.ebuild b/media-sound/puddletag/puddletag-2.2.0.ebuild
new file mode 100644
index 00000000000..67f332fe02d
--- /dev/null
+++ b/media-sound/puddletag/puddletag-2.2.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8,9,10} )
+
+inherit distutils-r1 xdg
+
+DESCRIPTION="Audio tag editor"
+HOMEPAGE="http://docs.puddletag.net/"
+SRC_URI="https://github.com/${PN}/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2 GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="acoustid quodlibet"
+
+DEPEND=""
+RDEPEND="
+ >=dev-python/configobj-5.0.6[${PYTHON_USEDEP}]
+ >=dev-python/pyparsing-3.0.9[${PYTHON_USEDEP}]
+ >=dev-python/PyQt5-5.15.6[${PYTHON_USEDEP},svg]
+ >=media-libs/mutagen-1.45.1[${PYTHON_USEDEP}]
+ acoustid? ( >=media-libs/chromaprint-1.5.0 )
+ quodlibet? ( >=media-sound/quodlibet-4.4.0[${PYTHON_USEDEP}] )
+ >=dev-python/sip-4.19.22:0[${PYTHON_USEDEP}]
+ >=dev-python/lxml-4.9.1[${PYTHON_USEDEP}]
+"
+DOCS=(changelog NEWS THANKS TODO)
diff --git a/media-sound/pulseaudio-ctl/Manifest b/media-sound/pulseaudio-ctl/Manifest
index d9e56df610b..6b48e403cc6 100644
--- a/media-sound/pulseaudio-ctl/Manifest
+++ b/media-sound/pulseaudio-ctl/Manifest
@@ -1,4 +1 @@
-DIST pulseaudio-ctl-1.67.tar.gz 6615 BLAKE2B fd760fc5475cdd9c6bbced9f4bbe0f62e793364d375f0bc24686986d42c9ddcfeddde501950c3572a4bf004cdfba36d3dc5aa1df3eed7a9730a437e74eb97b26 SHA512 5ea1cbfd87cf073de46b6fd9953a3c7b9c6969da46103dd5dfc56aa3f179b2ba36ade5db7ca47d204f0f60ac02020f1a4f2dd58bbaf010f9a99780702295418c
-DIST pulseaudio-ctl-1.68.tar.gz 6575 BLAKE2B a126730f53687b8456ed06f205e13d9380f7cadd4581430b4263dff65ebd33b22ad698cad4271402f873d9fa6c3499fd805ba02e9108723dcd60690016fcc196 SHA512 8ed4383d123d235bcde2e89a0a81fea96daa81dabb37cc9428eb3dd8e0c80fde3b9adf2b3ff911abaf6c4e5cb7cdbd74ce6817e080b3dba65d9206677ce10de5
-DIST pulseaudio-ctl-1.69.tar.gz 6577 BLAKE2B db55eec57e1204eef228ad331fd0b95bab2ee16625ca94fe4632ee713412b0686f1c1abc509f8c2ee0d1e6b08147f79ab961a4039fdadc351a88bcaedc13a9e0 SHA512 4cd80bb917b95ed96bee5005b54f50cbce6d3e341aee32c91daf301e3b4bc8fdd8b4c350b3a3951c6afa740df4565dfc5f0fdb7c858a3f2c7321c983f3fb36c2
DIST pulseaudio-ctl-1.70.tar.gz 6513 BLAKE2B bd752c42a6ec7c205112637a11e2abae1474b2bcb43f09fa46439b1509c816e8baadd547868821f495f79acf9606bc913ee8664286f181357e264ffa3cdf60f9 SHA512 59ec5f3da3021fd79ba33d9934c6dde9eebdfcc5e7651355b69c54e13cf6525d741a68780c6dc5c871ad108a261334657f7f25306e59fc6142912e2ff2278cb7
diff --git a/media-sound/pulseaudio-ctl/pulseaudio-ctl-1.67.ebuild b/media-sound/pulseaudio-ctl/pulseaudio-ctl-1.67.ebuild
deleted file mode 100644
index ad9ef3abe65..00000000000
--- a/media-sound/pulseaudio-ctl/pulseaudio-ctl-1.67.ebuild
+++ /dev/null
@@ -1,23 +0,0 @@
-# Copyright 2019-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-DESCRIPTION="CLI utility to control PulseAudio volume"
-HOMEPAGE="https://github.com/graysky2/pulseaudio-ctl"
-SRC_URI="https://github.com/graysky2/pulseaudio-ctl/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-# Optional runtime deps: dbus-send for KDE OSD, notify-send for libnotify
-# in both cases they should be already present if DE supports them
-RDEPEND="media-sound/pulseaudio"
-
-src_install() {
- # install-man target compresses manpage
- emake install-bin PREFIX="${EPREFIX}/usr" DESTDIR="${D}"
- doman doc/pulseaudio-ctl.1
-}
diff --git a/media-sound/pulseaudio-ctl/pulseaudio-ctl-1.68.ebuild b/media-sound/pulseaudio-ctl/pulseaudio-ctl-1.68.ebuild
deleted file mode 100644
index 71ae8973b85..00000000000
--- a/media-sound/pulseaudio-ctl/pulseaudio-ctl-1.68.ebuild
+++ /dev/null
@@ -1,21 +0,0 @@
-# Copyright 2019-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-DESCRIPTION="CLI utility to control PulseAudio volume"
-HOMEPAGE="https://github.com/graysky2/pulseaudio-ctl"
-SRC_URI="https://github.com/graysky2/pulseaudio-ctl/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-# Optional runtime deps: dbus-send for KDE OSD, notify-send for libnotify
-# in both cases they should be already present if DE supports them
-RDEPEND="media-sound/pulseaudio"
-
-src_install() {
- emake install PREFIX="${EPREFIX}/usr" DESTDIR="${D}"
-}
diff --git a/media-sound/pulseaudio-ctl/pulseaudio-ctl-1.69.ebuild b/media-sound/pulseaudio-ctl/pulseaudio-ctl-1.69.ebuild
deleted file mode 100644
index 64655c017f7..00000000000
--- a/media-sound/pulseaudio-ctl/pulseaudio-ctl-1.69.ebuild
+++ /dev/null
@@ -1,21 +0,0 @@
-# Copyright 2019-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-DESCRIPTION="CLI utility to control PulseAudio volume"
-HOMEPAGE="https://github.com/graysky2/pulseaudio-ctl"
-SRC_URI="https://github.com/graysky2/pulseaudio-ctl/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-# Optional runtime deps: dbus-send for KDE OSD, notify-send for libnotify
-# in both cases they should be already present if DE supports them
-RDEPEND="media-sound/pulseaudio"
-
-src_install() {
- emake install PREFIX="${EPREFIX}/usr" DESTDIR="${D}"
-}
diff --git a/media-sound/pulseaudio-daemon/Manifest b/media-sound/pulseaudio-daemon/Manifest
index fe4662eb346..7e2a36fffea 100644
--- a/media-sound/pulseaudio-daemon/Manifest
+++ b/media-sound/pulseaudio-daemon/Manifest
@@ -1 +1,2 @@
-DIST pulseaudio-15.99.1.tar.xz 1546536 BLAKE2B d77b7f9d05c1ffe1490b72dbf58b479962798d6e961d4efc935cbab0a6ad7fcd6ecb99de5efa5b85658b58e59024087cfd446ac4e7eeef1cd38fa7e579b5fb3c SHA512 3eb7cdc9795204513d43336836d12709e78ebb001a97e9bab81969a4981a10df2d68a5fad34aef2660f37b72d269cb01e4c6e76c42a5c5742ac56c0f575778d5
+DIST pulseaudio-16.0.tar.xz 1551276 BLAKE2B 54ba5d446bc02246bf842280f577851eb66ff9fed1e1b0d2d03e238796d9d04bc1fc27215b02fdded37441da1747be23d1e03d5a00b79ee3b91eb35c0f76a470 SHA512 42d4968c2dc88f5e39a5358d124e399e40a5abdf815eff387087141bc9dddd217012acb35649a8e0e24a44e8a402d90eb193ce2eef186f7d59550f757a6cc26d
+DIST pulseaudio-16.1.tar.xz 1545596 BLAKE2B 535706abcea2cae39834b23c8bdc37f71b0e633de2d8e43ea4425da97a850b57c2f980c318681cbc86cf1e746200609dad41f8b96ecf4568f86d94aa6831c9a1 SHA512 33b0b4292f05e0882f3ec822cf5720414bb34c523d80fe287b9740d6be219787c562e8024c9b0d9e2ee010771ca72c7ae4f27df1bbef9c9cb6bb6a23cbcc412f
diff --git a/media-sound/pulseaudio-daemon/files/pulseaudio-16.0-optional-module-console-kit.patch b/media-sound/pulseaudio-daemon/files/pulseaudio-16.0-optional-module-console-kit.patch
new file mode 100644
index 00000000000..4ffdb82f490
--- /dev/null
+++ b/media-sound/pulseaudio-daemon/files/pulseaudio-16.0-optional-module-console-kit.patch
@@ -0,0 +1,76 @@
+commit 823e46fba0742605f557b68cd591f61624b93966
+Author: Igor V. Kovalenko <igor.v.kovalenko@gmail.com>
+Date: Sun Jun 12 21:49:32 2022 +0300
+
+ build-sys: meson: Make module-console-kit optional
+
+ Default build configuration would fail to run on a system without systemd-logind
+ (or elogind) and without ConsoleKit daemon responding on dbus interface. Here,
+ module-console-kit would fail to initialize, preventing daemon from starting.
+
+ Make module-console-kit an optional build feature to allow opt-out.
+
+ Part-of: <https://gitlab.freedesktop.org/pulseaudio/pulseaudio/-/merge_requests/719>
+
+diff --git a/meson.build b/meson.build
+index d4cdbd6a5..c6db7e670 100644
+--- a/meson.build
++++ b/meson.build
+@@ -732,6 +732,10 @@ if get_option('daemon')
+ cdata.set('HAVE_SYSTEMD_LOGIN', 1)
+ endif
+
++ if get_option('consolekit').enabled()
++ assert(dbus_dep.found(), 'ConsoleKit requires D-Bus support')
++ endif
++
+ tcpwrap_dep = cc.find_library('wrap', required: get_option('tcpwrap'))
+ if cc.has_header('tcpd.h') and cc.has_function('hosts_access', dependencies : tcpwrap_dep)
+ cdata.set('HAVE_LIBWRAP', 1)
+@@ -1001,6 +1005,7 @@ summary += [
+ ' Enable HAL->udev compat: @0@'.format(get_option('hal-compat')),
+ 'Enable systemd units: @0@'.format(systemd_dep.found()),
+ 'Enable elogind: @0@'.format(libelogind_dep.found()),
++ 'Enable ConsoleKit: @0@'.format(not get_option('consolekit').disabled() and dbus_dep.found()),
+ 'Enable TCP Wrappers: @0@'.format(tcpwrap_dep.found()),
+ 'Enable OpenSSL (for Airtunes): @0@'.format(openssl_dep.found()),
+ 'Database: @0@'.format(get_option('database')),
+diff --git a/meson_options.txt b/meson_options.txt
+index b23210072..e7160a3a7 100644
+--- a/meson_options.txt
++++ b/meson_options.txt
+@@ -99,6 +99,9 @@ option('bluez5-native-headset',
+ option('bluez5-ofono-headset',
+ type : 'boolean',
+ description : 'Optional oFono headset backend support (BlueZ 5)')
++option('consolekit',
++ type : 'feature', value : 'auto',
++ description : 'Optional ConsoleKit support')
+ option('dbus',
+ type : 'feature', value : 'auto',
+ description : 'Optional D-Bus support')
+diff --git a/src/modules/meson.build b/src/modules/meson.build
+index cdf372c8e..1d8004300 100644
+--- a/src/modules/meson.build
++++ b/src/modules/meson.build
+@@ -130,7 +130,6 @@ endif
+
+ if dbus_dep.found()
+ all_modules += [
+- [ 'module-console-kit', 'module-console-kit.c', [], [], [dbus_dep] ],
+ [ 'module-dbus-protocol',
+ [ 'dbus/iface-card.c', 'dbus/iface-card.h',
+ 'dbus/iface-card-profile.c', 'dbus/iface-card-profile.h',
+@@ -147,6 +146,12 @@ if dbus_dep.found()
+ [], [], [dbus_dep] ],
+ [ 'module-rygel-media-server', 'module-rygel-media-server.c', [], [], [dbus_dep], libprotocol_http ],
+ ]
++
++ if not get_option('consolekit').disabled()
++ all_modules += [
++ [ 'module-console-kit', 'module-console-kit.c', [], [], [dbus_dep] ],
++ ]
++ endif
+ endif
+
+ if fftw_dep.found()
diff --git a/media-sound/pulseaudio-daemon/metadata.xml b/media-sound/pulseaudio-daemon/metadata.xml
index 0a4437e2351..5d81f917019 100644
--- a/media-sound/pulseaudio-daemon/metadata.xml
+++ b/media-sound/pulseaudio-daemon/metadata.xml
@@ -1,9 +1,17 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer type="project">
- <email>gnome@gentoo.org</email>
- <name>Gentoo GNOME Desktop</name>
+ <maintainer type="person" proxied="yes">
+ <email>igor.v.kovalenko@gmail.com</email>
+ <name>Igor V. Kovalenko</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>sam@gentoo.org</email>
+ <name>Sam James</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>leio@gentoo.org</email>
+ <name>Mart Raudsepp</name>
</maintainer>
<use>
<flag name="X">
@@ -36,7 +44,10 @@
</flag>
<flag name="asyncns">Use libasyncns for asynchronous name resolution.</flag>
<flag name="equalizer">
- Enable the equalizer module (requires <pkg>sci-libs/fftw</pkg>).
+ Enable the equalizer module (requires <pkg>sci-libs/fftw</pkg> and <pkg>sys-apps/dbus</pkg>).
+ </flag>
+ <flag name="fftw">
+ Enable the virtual surround sink module (requires <pkg>sci-libs/fftw</pkg>).
</flag>
<flag name="ssl">
Use <pkg>dev-libs/openssl</pkg> to provide support for RAOP
@@ -56,15 +67,12 @@
Build with <pkg>sys-apps/systemd</pkg> support to replace standalone
ConsoleKit.
</flag>
- <flag name="native-headset">
- Build with native HSP backend for bluez 5.
- </flag>
+ <flag name="valgrind">Compile in valgrind memory hints</flag>
<flag name="ofono-headset">
- Build with oFono HFP backend for bluez 5, requires <pkg>net-misc/ofono</pkg>.
+ Build with optional oFono HFP backend for bluez 5, requires <pkg>net-misc/ofono</pkg>.
</flag>
<flag name="gstreamer">
- Build with support for gstreamer including ability to use bluetooth codecs.
- For bluetooth codecs see USE ldac and aptx.
+ Build GStreamer-based RTP protocol module which supports more advanced RTP features like OPUS payload encoding.
</flag>
<flag name="aptx">
aptX (HD) over Bluetooth (many Android compatible headphones), requires <pkg>media-plugins/gst-plugins-openaptx</pkg>.
diff --git a/media-sound/pulseaudio-daemon/pulseaudio-daemon-15.99.1-r2.ebuild b/media-sound/pulseaudio-daemon/pulseaudio-daemon-16.0-r1.ebuild
index e1c72c7c113..1dc4c81cf6e 100644
--- a/media-sound/pulseaudio-daemon/pulseaudio-daemon-15.99.1-r2.ebuild
+++ b/media-sound/pulseaudio-daemon/pulseaudio-daemon-16.0-r1.ebuild
@@ -16,7 +16,7 @@ if [[ ${PV} = 9999 ]]; then
EGIT_REPO_URI="https://gitlab.freedesktop.org/pulseaudio/pulseaudio"
else
SRC_URI="https://freedesktop.org/software/pulseaudio/releases/${MY_P}.tar.xz"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+ KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~loong ppc ppc64 ~riscv sparc x86 ~amd64-linux ~x86-linux"
fi
S="${WORKDIR}/${MY_P}"
@@ -32,8 +32,8 @@ SLOT="0"
# +alsa-plugin as discussed in bug #519530
# TODO: Find out why webrtc-aec is + prefixed - there's already the always available speexdsp-aec
# NOTE: The current ebuild sets +X almost certainly just for the pulseaudio.desktop file
-IUSE="+alsa +alsa-plugin aptx +asyncns bluetooth dbus elogind equalizer +gdbm gstreamer +glib gtk ipv6 jack ldac lirc
-native-headset ofono-headset +orc oss selinux sox ssl systemd system-wide tcpd test +udev +webrtc-aec +X zeroconf"
+IUSE="+alsa +alsa-plugin aptx +asyncns bluetooth dbus elogind equalizer fftw +gdbm +glib gstreamer gtk ipv6 jack ldac lirc
+ofono-headset +orc oss selinux sox ssl systemd system-wide tcpd test +udev valgrind +webrtc-aec +X zeroconf"
RESTRICT="!test? ( test )"
@@ -41,11 +41,12 @@ RESTRICT="!test? ( test )"
# Basically all IUSE are either ${MULTILIB_USEDEP} for client libs or they belong under !daemon ()
# We duplicate alsa-plugin, {native,ofono}-headset under daemon to let users deal with them at once
REQUIRED_USE="
+ ?? ( elogind systemd )
alsa-plugin? ( alsa )
+ aptx? ( bluetooth )
bluetooth? ( dbus )
- ?? ( elogind systemd )
equalizer? ( dbus )
- native-headset? ( bluetooth )
+ ldac? ( bluetooth )
ofono-headset? ( bluetooth )
udev? ( || ( alsa oss ) )
zeroconf? ( dbus )
@@ -55,8 +56,12 @@ REQUIRED_USE="
# - libpcre needed in some cases, bug #472228
# - media-libs/speexdsp is providing echo canceller implementation and used in resampler
# TODO: libatomic_ops is only needed on some architectures and conditions, and then at runtime too
+gstreamer_deps="
+ media-libs/gst-plugins-base
+ >=media-libs/gstreamer-1.14
+"
COMMON_DEPEND="
- >=media-libs/libpulse-${PV}[dbus?,glib?,systemd?,tcpd?,X?]
+ ~media-libs/libpulse-${PV}[dbus?,glib?,systemd?,tcpd(+)?,valgrind?,X?]
dev-libs/libatomic_ops
>=media-libs/libsndfile-1.0.20
>=media-libs/speexdsp-1.2
@@ -65,6 +70,7 @@ COMMON_DEPEND="
dev-libs/libpcre:3
)
alsa? ( >=media-libs/alsa-lib-1.0.24 )
+ aptx? ( ${gstreamer_deps} )
asyncns? ( >=net-libs/libasyncns-0.1 )
bluetooth? (
>=net-wireless/bluez-5
@@ -76,16 +82,17 @@ COMMON_DEPEND="
dbus? ( >=sys-apps/dbus-1.4.12 )
elogind? ( sys-auth/elogind )
equalizer? (
- sci-libs/fftw:3.0
+ sci-libs/fftw:3.0=
+ )
+ fftw? (
+ sci-libs/fftw:3.0=
)
gdbm? ( sys-libs/gdbm:= )
glib? ( >=dev-libs/glib-2.28.0:2 )
- gstreamer? (
- media-libs/gst-plugins-base
- >=media-libs/gstreamer-1.14
- )
+ gstreamer? ( ${gstreamer_deps} )
gtk? ( x11-libs/gtk+:3 )
jack? ( virtual/jack )
+ ldac? ( ${gstreamer_deps} )
lirc? ( app-misc/lirc )
ofono-headset? ( >=net-misc/ofono-1.13 )
orc? ( >=dev-lang/orc-0.4.15 )
@@ -95,6 +102,7 @@ COMMON_DEPEND="
systemd? ( sys-apps/systemd:= )
tcpd? ( sys-apps/tcp-wrappers )
udev? ( >=virtual/udev-143[hwdb(+)] )
+ valgrind? ( dev-util/valgrind )
webrtc-aec? ( >=media-libs/webrtc-audio-processing-0.2:0 )
X? (
>=x11-libs/libxcb-1.6
@@ -125,12 +133,11 @@ RDEPEND="
acct-group/pulse-access
)
bluetooth? (
- gstreamer? (
- ldac? ( media-plugins/gst-plugins-ldac )
- aptx? ( media-plugins/gst-plugins-openaptx )
- )
+ ldac? ( media-plugins/gst-plugins-ldac )
+ aptx? ( media-plugins/gst-plugins-openaptx )
)
"
+unset gstreamer_deps
# This is a PDEPEND to avoid a circular dep
PDEPEND="
@@ -163,6 +170,16 @@ src_prepare() {
}
src_configure() {
+ local enable_bluez5_gstreamer="disabled"
+ if use aptx || use ldac ; then
+ enable_bluez5_gstreamer="enabled"
+ fi
+
+ local enable_fftw="disabled"
+ if use equalizer || use fftw ; then
+ enable_fftw="enabled"
+ fi
+
local emesonargs=(
--localstatedir="${EPREFIX}"/var
@@ -188,12 +205,12 @@ src_configure() {
$(meson_feature asyncns)
$(meson_feature zeroconf avahi)
$(meson_feature bluetooth bluez5)
- $(meson_feature gstreamer bluez5-gstreamer)
- $(meson_use native-headset bluez5-native-headset)
+ -Dbluez5-gstreamer=${enable_bluez5_gstreamer}
+ $(meson_use bluetooth bluez5-native-headset)
$(meson_use ofono-headset bluez5-ofono-headset)
$(meson_feature dbus)
$(meson_feature elogind)
- $(meson_feature equalizer fftw)
+ -Dfftw=${enable_fftw}
$(meson_feature glib) # WARNING: toggling this likely changes ABI
$(meson_feature glib gsettings) # Supposedly correct?
$(meson_feature gstreamer)
@@ -211,7 +228,7 @@ src_configure() {
$(meson_feature systemd)
$(meson_feature tcpd tcpwrap) # TODO: This should technically be enabled for 32bit too, but at runtime it probably is never used without daemon?
$(meson_feature udev)
- -Dvalgrind=auto
+ $(meson_feature valgrind)
$(meson_feature X x11)
# Echo cancellation
@@ -311,12 +328,32 @@ pkg_postinst() {
elog ""
fi
- if use native-headset && use ofono-headset; then
+ if use bluetooth; then
+ elog "You have enabled bluetooth USE flag for pulseaudio. Daemon will now handle"
+ elog "bluetooth Headset (HSP HS and HSP AG) and Handsfree (HFP HF) profiles using"
+ elog "native headset backend by default. This can be selectively disabled"
+ elog "via runtime configuration arguments to module-bluetooth-discover"
+ elog "in /etc/pulse/default.pa"
+ elog "To disable HFP HF append enable_native_hfp_hf=false"
+ elog "To disable HSP HS append enable_native_hsp_hs=false"
+ elog "To disable HSP AG append headset=auto or headset=ofono"
+ elog "(note this does NOT require enabling USE ofono)"
+ elog ""
+ fi
+
+ if use ofono-headset; then
elog "You have enabled both native and ofono headset profiles. The runtime decision"
elog "which to use is done via the 'headset' argument of module-bluetooth-discover."
elog ""
fi
+ if use gstreamer; then
+ elog "GStreamer-based RTP implementation modile enabled."
+ elog "To use OPUS payload install media-plugins/gst-plugins-opus"
+ elog "and add enable_opus=1 argument to module-rtp-send"
+ elog ""
+ fi
+
if use systemd; then
elog "Pulseaudio autospawn by client library is no longer enabled when systemd is available."
elog "It's recommended to start pulseaudio via its systemd user units:"
@@ -342,4 +379,5 @@ pkg_postinst() {
pkg_postrm() {
gnome2_schemas_update
+ use udev && udev_reload
}
diff --git a/media-sound/pulseaudio/pulseaudio-15.0-r3.ebuild b/media-sound/pulseaudio-daemon/pulseaudio-daemon-16.1.ebuild
index a3ea20eec26..706fa7f66af 100644
--- a/media-sound/pulseaudio/pulseaudio-15.0-r3.ebuild
+++ b/media-sound/pulseaudio-daemon/pulseaudio-daemon-16.1.ebuild
@@ -4,22 +4,23 @@
EAPI="7"
MY_PV="${PV/_pre*}"
-MY_P="${PN}-${MY_PV}"
+MY_P="pulseaudio-${MY_PV}"
+inherit bash-completion-r1 gnome2-utils meson optfeature systemd tmpfiles udev
-inherit bash-completion-r1 gnome2-utils meson-multilib optfeature systemd tmpfiles udev
-
-DESCRIPTION="A networked sound server with an advanced plugin system"
+DESCRIPTION="Daemon component of PulseAudio (networked sound server)"
HOMEPAGE="https://www.freedesktop.org/wiki/Software/PulseAudio/"
if [[ ${PV} = 9999 ]]; then
inherit git-r3
EGIT_BRANCH="master"
- EGIT_REPO_URI="https://gitlab.freedesktop.org/${PN}/${PN}"
+ EGIT_REPO_URI="https://gitlab.freedesktop.org/pulseaudio/pulseaudio"
else
- SRC_URI="https://freedesktop.org/software/${PN}/releases/${MY_P}.tar.xz"
- KEYWORDS="~alpha amd64 ~arm arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv sparc x86 ~amd64-linux ~x86-linux"
+ SRC_URI="https://freedesktop.org/software/pulseaudio/releases/${MY_P}.tar.xz"
+ KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~loong ppc ppc64 ~riscv sparc x86 ~amd64-linux ~x86-linux"
fi
+S="${WORKDIR}/${MY_P}"
+
# libpulse-simple and libpulse link to libpulse-core; this is daemon's
# library and can link to gdbm and other GPL-only libraries. In this
# cases, we have a fully GPL-2 package. Leaving the rest of the
@@ -31,9 +32,8 @@ SLOT="0"
# +alsa-plugin as discussed in bug #519530
# TODO: Find out why webrtc-aec is + prefixed - there's already the always available speexdsp-aec
# NOTE: The current ebuild sets +X almost certainly just for the pulseaudio.desktop file
-IUSE="+alsa +alsa-plugin aptx +asyncns bluetooth dbus +daemon doc elogind equalizer +gdbm
-gstreamer +glib gtk ipv6 jack ldac lirc native-headset ofono-headset +orc oss selinux sox ssl systemd
-system-wide tcpd test +udev +webrtc-aec +X zeroconf"
+IUSE="+alsa +alsa-plugin aptx +asyncns bluetooth dbus elogind equalizer fftw +gdbm +glib gstreamer jack ldac lirc
+ofono-headset +orc oss selinux sox ssl systemd system-wide tcpd test +udev valgrind +webrtc-aec +X zeroconf"
RESTRICT="!test? ( test )"
@@ -41,81 +41,60 @@ RESTRICT="!test? ( test )"
# Basically all IUSE are either ${MULTILIB_USEDEP} for client libs or they belong under !daemon ()
# We duplicate alsa-plugin, {native,ofono}-headset under daemon to let users deal with them at once
REQUIRED_USE="
+ ?? ( elogind systemd )
alsa-plugin? ( alsa )
+ aptx? ( bluetooth )
bluetooth? ( dbus )
- daemon? ( ?? ( elogind systemd ) )
- !daemon? (
- !alsa
- !alsa-plugin
- !bluetooth
- !equalizer
- !gdbm
- !gstreamer
- !gtk
- !jack
- !lirc
- !native-headset
- !ofono-headset
- !orc
- !oss
- !sox
- !ssl
- !system-wide
- !udev
- !webrtc-aec
- !zeroconf
- )
equalizer? ( dbus )
- native-headset? ( bluetooth )
+ ldac? ( bluetooth )
ofono-headset? ( bluetooth )
udev? ( || ( alsa oss ) )
zeroconf? ( dbus )
"
-BDEPEND="
- dev-lang/perl
- dev-perl/XML-Parser
- sys-devel/gettext
- sys-devel/m4
- virtual/libiconv
- virtual/libintl
- virtual/pkgconfig
- doc? ( app-doc/doxygen )
- orc? ( >=dev-lang/orc-0.4.15 )
- system-wide? ( dev-util/unifdef )
-"
-
# NOTE:
# - libpcre needed in some cases, bug #472228
-# - media-libs/speexdsp is providing echo canceller implementation
+# - media-libs/speexdsp is providing echo canceller implementation and used in resampler
+# TODO: libatomic_ops is only needed on some architectures and conditions, and then at runtime too
+gstreamer_deps="
+ media-libs/gst-plugins-base
+ >=media-libs/gstreamer-1.14
+"
COMMON_DEPEND="
- >=media-libs/libsndfile-1.0.20[${MULTILIB_USEDEP}]
- >=media-libs/speexdsp-1.2[${MULTILIB_USEDEP}]
- virtual/libc
+ ~media-libs/libpulse-${PV}[dbus?,glib?,systemd?,valgrind?,X?]
+ dev-libs/libatomic_ops
+ >=media-libs/libsndfile-1.0.20
+ >=media-libs/speexdsp-1.2
+ || (
+ elibc_glibc? ( virtual/libc )
+ dev-libs/libpcre:3
+ )
alsa? ( >=media-libs/alsa-lib-1.0.24 )
- asyncns? ( >=net-libs/libasyncns-0.1[${MULTILIB_USEDEP}] )
+ aptx? ( ${gstreamer_deps} )
+ asyncns? ( >=net-libs/libasyncns-0.1 )
bluetooth? (
>=net-wireless/bluez-5
media-libs/sbc
)
- daemon? (
- dev-libs/libltdl
- sys-kernel/linux-headers
- >=sys-libs/libcap-2.22-r2
- )
- dbus? ( >=sys-apps/dbus-1.4.12[${MULTILIB_USEDEP}] )
+ dev-libs/libltdl
+ sys-kernel/linux-headers
+ >=sys-libs/libcap-2.22-r2
+ dbus? ( >=sys-apps/dbus-1.4.12 )
elogind? ( sys-auth/elogind )
equalizer? (
- sci-libs/fftw:3.0
+ sci-libs/fftw:3.0=
+ )
+ fftw? (
+ sci-libs/fftw:3.0=
)
gdbm? ( sys-libs/gdbm:= )
- glib? ( >=dev-libs/glib-2.28.0:2[${MULTILIB_USEDEP}] )
+ glib? ( >=dev-libs/glib-2.28.0:2 )
gstreamer? (
- media-libs/gst-plugins-base
- >=media-libs/gstreamer-1.14
+ ${gstreamer_deps}
+ >=dev-libs/glib-2.26.0:2
)
- gtk? ( x11-libs/gtk+:3 )
jack? ( virtual/jack )
+ ldac? ( ${gstreamer_deps} )
lirc? ( app-misc/lirc )
ofono-headset? ( >=net-misc/ofono-1.13 )
orc? ( >=dev-lang/orc-0.4.15 )
@@ -125,25 +104,22 @@ COMMON_DEPEND="
systemd? ( sys-apps/systemd:= )
tcpd? ( sys-apps/tcp-wrappers )
udev? ( >=virtual/udev-143[hwdb(+)] )
+ valgrind? ( dev-util/valgrind )
webrtc-aec? ( >=media-libs/webrtc-audio-processing-0.2:0 )
X? (
- x11-libs/libX11[${MULTILIB_USEDEP}]
- >=x11-libs/libxcb-1.6[${MULTILIB_USEDEP}]
- daemon? (
- x11-libs/libICE
- x11-libs/libSM
- >=x11-libs/libX11-1.4.0
- >=x11-libs/libXtst-1.0.99.2
- )
+ >=x11-libs/libxcb-1.6
+ x11-libs/libICE
+ x11-libs/libSM
+ >=x11-libs/libX11-1.4.0
+ >=x11-libs/libXtst-1.0.99.2
)
zeroconf? ( >=net-dns/avahi-0.6.12[dbus] )
+ !<media-sound/pulseaudio-15.0-r100
"
# pulseaudio ships a bundle xmltoman, which uses XML::Parser
DEPEND="
${COMMON_DEPEND}
- dev-libs/libatomic_ops
- dev-libs/libpcre:*
test? ( >=dev-libs/check-0.9.10 )
X? ( x11-base/xorg-proto )
"
@@ -158,27 +134,37 @@ RDEPEND="
acct-group/audio
acct-group/pulse-access
)
- daemon? (
- bluetooth? (
- gstreamer? (
- ldac? ( media-plugins/gst-plugins-ldac )
- aptx? ( media-plugins/gst-plugins-openaptx )
- )
- )
+ bluetooth? (
+ ldac? ( media-plugins/gst-plugins-ldac )
+ aptx? ( media-plugins/gst-plugins-openaptx )
)
+ !media-video/pipewire[sound-server(+)]
"
+unset gstreamer_deps
# This is a PDEPEND to avoid a circular dep
PDEPEND="
- alsa? ( alsa-plugin? ( >=media-plugins/alsa-plugins-1.0.27-r1[pulseaudio,${MULTILIB_USEDEP}] ) )
+ alsa? ( alsa-plugin? ( >=media-plugins/alsa-plugins-1.0.27-r1[pulseaudio] ) )
+"
+
+BDEPEND="
+ dev-lang/perl
+ dev-perl/XML-Parser
+ sys-devel/gettext
+ virtual/libiconv
+ virtual/libintl
+ virtual/pkgconfig
+ orc? ( >=dev-lang/orc-0.4.15 )
+ system-wide? ( dev-util/unifdef )
"
DOCS=( NEWS README )
S="${WORKDIR}/${MY_P}"
+# patches merged upstream, to be removed with 16.2 or later bump
PATCHES=(
- "${FILESDIR}"/pulseaudio-15.0-xice-xsm-xtst-daemon-only.patch
+ "${FILESDIR}"/pulseaudio-16.0-optional-module-console-kit.patch
)
src_prepare() {
@@ -187,106 +173,93 @@ src_prepare() {
gnome2_environment_reset
}
-multilib_src_configure() {
+src_configure() {
+ local enable_bluez5_gstreamer="disabled"
+ if use aptx || use ldac ; then
+ enable_bluez5_gstreamer="enabled"
+ fi
+
+ local enable_fftw="disabled"
+ if use equalizer || use fftw ; then
+ enable_fftw="enabled"
+ fi
+
local emesonargs=(
--localstatedir="${EPREFIX}"/var
- $(meson_native_use_bool daemon)
- $(meson_native_use_bool doc doxygen)
+ -Ddaemon=true
+ -Dclient=false
+ -Ddoxygen=false
-Dgcov=false
+ -Dman=true
# tests involve random modules, so just do them for the native # TODO: tests should run always
- $(meson_native_use_bool test tests)
- -Ddatabase=$(multilib_native_usex gdbm gdbm simple) # tdb is also an option but no one cares about it
+ $(meson_use test tests)
+ -Ddatabase=$(usex gdbm gdbm simple) # tdb is also an option but no one cares about it
-Dstream-restore-clear-old-devices=true
-Drunning-from-build-tree=false
# Paths
- -Dmodlibexecdir="${EPREFIX}/usr/$(get_libdir)/${PN}/modules" # Was $(get_libdir)/${P}
+ -Dmodlibexecdir="${EPREFIX}/usr/$(get_libdir)/pulseaudio/modules" # Was $(get_libdir)/${P}
-Dsystemduserunitdir=$(systemd_get_userunitdir)
-Dudevrulesdir="${EPREFIX}$(get_udevdir)/rules.d"
-Dbashcompletiondir="$(get_bashcompdir)" # Alternatively DEPEND on app-shells/bash-completion for pkg-config to provide the value
# Optional features
- $(meson_native_use_feature alsa)
+ $(meson_feature alsa)
$(meson_feature asyncns)
- $(meson_native_use_feature zeroconf avahi)
- $(meson_native_use_feature bluetooth bluez5)
- $(meson_native_use_feature gstreamer bluez5-gstreamer)
- $(meson_native_use_bool native-headset bluez5-native-headset)
- $(meson_native_use_bool ofono-headset bluez5-ofono-headset)
+ $(meson_feature zeroconf avahi)
+ $(meson_feature bluetooth bluez5)
+ -Dbluez5-gstreamer=${enable_bluez5_gstreamer}
+ $(meson_use bluetooth bluez5-native-headset)
+ $(meson_use ofono-headset bluez5-ofono-headset)
+ -Dconsolekit=disabled
$(meson_feature dbus)
- $(meson_native_use_feature elogind)
- $(meson_native_use_feature equalizer fftw)
+ $(meson_feature elogind)
+ -Dfftw=${enable_fftw}
$(meson_feature glib) # WARNING: toggling this likely changes ABI
- $(meson_native_use_feature glib gsettings) # Supposedly correct?
- $(meson_native_use_feature gstreamer)
- $(meson_native_use_feature gtk)
- -Dhal-compat=true # Consider disabling on next revbump
- $(meson_use ipv6)
- $(meson_native_use_feature jack)
- $(meson_native_use_feature lirc)
- $(meson_native_use_feature ssl openssl)
- $(meson_native_use_feature orc)
- $(meson_native_use_feature oss oss-output)
+ $(meson_feature glib gsettings) # Supposedly correct?
+ $(meson_feature gstreamer)
+ -Dgtk=disabled
+ -Dhal-compat=false
+ -Dipv6=true
+ $(meson_feature jack)
+ $(meson_feature lirc)
+ $(meson_feature ssl openssl)
+ $(meson_feature orc)
+ $(meson_feature oss oss-output)
-Dsamplerate=disabled # Matches upstream
- $(meson_native_use_feature sox soxr)
+ $(meson_feature sox soxr)
-Dspeex=enabled
- $(meson_native_use_feature systemd)
- $(meson_native_use_feature tcpd tcpwrap) # TODO: This should technically be enabled for 32bit too, but at runtime it probably is never used without daemon?
- $(meson_native_use_feature udev)
- -Dvalgrind=auto
+ $(meson_feature systemd)
+ $(meson_feature tcpd tcpwrap)
+ $(meson_feature udev)
+ $(meson_feature valgrind)
$(meson_feature X x11)
# Echo cancellation
-Dadrian-aec=false # Not packaged?
- $(meson_native_use_feature webrtc-aec)
+ $(meson_feature webrtc-aec)
)
- if multilib_is_native_abi; then
- # Make padsp work for non-native ABI, supposedly only possible with glibc;
- # this is used by /usr/bin/padsp that comes from native build, thus we need
- # this argument for native build
- if use elibc_glibc; then
- emesonargs+=( -Dpulsedsp-location="${EPREFIX}"'/usr/\\$$LIB/pulseaudio' )
- fi
- else
- emesonargs+=( -Dman=false )
- if ! use elibc_glibc; then
- # Non-glibc multilib is probably non-existent but just in case:
- ewarn "padsp wrapper for OSS emulation will only work with native ABI applications!"
- fi
- fi
-
meson_src_configure
}
-multilib_src_compile() {
- meson_src_compile
+src_install() {
+ meson_src_install
- if multilib_is_native_abi; then
- if use doc; then
- einfo "Generating documentation ..."
- meson_src_compile doxygen
- fi
- fi
-}
+ # Upstream installs 'pactl' if client is built, with all symlinks except for
+ # 'pulseaudio', 'pacmd' and 'pasuspender' which are installed if server is built.
+ # This trips QA warning, workaround:
+ # - install missing aliases in media-libs/libpulse (client build)
+ # - remove corresponding symlinks in media-sound/pulseaudio-daemonclient (server build)
+ rm "${D}/$(get_bashcompdir)"/pulseaudio || die
+ rm "${D}/$(get_bashcompdir)"/pacmd || die
+ rm "${D}/$(get_bashcompdir)"/pasuspender || die
-multilib_src_install() {
- # The files referenced in the DOCS array do not exist in the multilib source directory,
- # therefore clear the variable when calling the function that will access it.
- DOCS= meson_src_install
-
- if multilib_is_native_abi; then
- if use doc; then
- einfo "Installing documentation ..."
- docinto html
- dodoc -r doxygen/html/.
- fi
- fi
-}
-
-multilib_src_install_all() {
- einstalldocs
+ # Daemon configuration scripts will try to load snippets from corresponding '.d' dirs.
+ # Install these dirs to silence a warning if they are missing.
+ keepdir /etc/pulse/default.pa.d
+ keepdir /etc/pulse/system.pa.d
if use system-wide; then
newconfd "${FILESDIR}"/pulseaudio.conf.d pulseaudio
@@ -308,13 +281,13 @@ multilib_src_install_all() {
doinitd "${T}"/pulseaudio
- systemd_dounit "${FILESDIR}"/${PN}.service
+ systemd_dounit "${FILESDIR}"/pulseaudio.service
# We need /var/run/pulse, bug 442852
- newtmpfiles "${FILESDIR}"/${PN}.tmpfiles ${PN}.conf
+ newtmpfiles "${FILESDIR}"/pulseaudio.tmpfiles pulseaudio.conf
else
# Prevent warnings when system-wide is not used, bug 447694
- if use dbus && use daemon; then
+ if use dbus; then
rm "${ED}"/etc/dbus-1/system.d/pulseaudio-system.conf || die
fi
fi
@@ -326,14 +299,22 @@ multilib_src_install_all() {
|| die
fi
+ # Only enable autospawning pulseaudio daemon on systems without systemd
+ if ! use systemd; then
+ insinto /etc/pulse/client.conf.d
+ newins "${FILESDIR}/enable-autospawn.conf" "enable-autospawn.conf"
+ fi
+
find "${ED}" \( -name '*.a' -o -name '*.la' \) -delete || die
}
pkg_postinst() {
gnome2_schemas_update
+ use udev && udev_reload
+
if use system-wide; then
- tmpfiles_process "${PN}.conf"
+ tmpfiles_process "pulseaudio.conf"
elog "You have enabled the 'system-wide' USE flag for pulseaudio."
elog "This mode should only be used on headless servers, embedded systems,"
@@ -357,17 +338,46 @@ pkg_postinst() {
elog ""
fi
- if use native-headset && use ofono-headset; then
+ if use bluetooth; then
+ elog "You have enabled bluetooth USE flag for pulseaudio. Daemon will now handle"
+ elog "bluetooth Headset (HSP HS and HSP AG) and Handsfree (HFP HF) profiles using"
+ elog "native headset backend by default. This can be selectively disabled"
+ elog "via runtime configuration arguments to module-bluetooth-discover"
+ elog "in /etc/pulse/default.pa"
+ elog "To disable HFP HF append enable_native_hfp_hf=false"
+ elog "To disable HSP HS append enable_native_hsp_hs=false"
+ elog "To disable HSP AG append headset=auto or headset=ofono"
+ elog "(note this does NOT require enabling USE ofono)"
+ elog ""
+ fi
+
+ if use ofono-headset; then
elog "You have enabled both native and ofono headset profiles. The runtime decision"
elog "which to use is done via the 'headset' argument of module-bluetooth-discover."
elog ""
fi
- if use systemd && use daemon; then
+ if use gstreamer; then
+ elog "GStreamer-based RTP implementation modile enabled."
+ elog "To use OPUS payload install media-plugins/gst-plugins-opus"
+ elog "and add enable_opus=1 argument to module-rtp-send"
+ elog ""
+ fi
+
+ if use systemd; then
+ elog "Pulseaudio autospawn by client library is no longer enabled when systemd is available."
elog "It's recommended to start pulseaudio via its systemd user units:"
elog ""
elog " systemctl --user enable pulseaudio.service pulseaudio.socket"
elog ""
+ elog "Root user can change system default configuration for all users:"
+ elog ""
+ elog " systemctl --global enable pulseaudio.service pulseaudio.socket"
+ elog ""
+ elog "If you would like to enable autospawn by client library, edit autospawn flag in /etc/pulse/client.conf like this:"
+ elog ""
+ elog " autospawn = yes"
+ elog ""
elog "The change from autospawn to user units will take effect after restarting."
elog ""
fi
@@ -379,4 +389,5 @@ pkg_postinst() {
pkg_postrm() {
gnome2_schemas_update
+ use udev && udev_reload
}
diff --git a/media-sound/pulseaudio-modules-bt/Manifest b/media-sound/pulseaudio-modules-bt/Manifest
index 5558a7f3df3..555774eddc0 100644
--- a/media-sound/pulseaudio-modules-bt/Manifest
+++ b/media-sound/pulseaudio-modules-bt/Manifest
@@ -1,3 +1,2 @@
-DIST pulseaudio-13.0.tar.xz 1901768 BLAKE2B 651a80f54525f196bcb036d893fedd4d9f34e10459918281397a45f498c31bff0d0c836f4e64aab5ac2612ffd5a0cab1a41ea710bbee5fd34dfc9ea1236deea9 SHA512 d445b8ccd43029a0ca0e456fc9291a79d3434d6496ead7eb329ab348d5249235e8bde6cf2be68765d8f761452dbe1486fb10c739e40b1e67ed75787bbd24ac0c
DIST pulseaudio-15.0.tar.xz 1521760 BLAKE2B a6f7b74fdcfe7f2a993eafb9f465946915a24b6801d3077971b9377290d6c70b3f8640a800abd09d5901db96a20349f31b1beedd9da2249f69b591fb8392f489 SHA512 352ef20384c76c631c0faa73b08e2318902a433712e0c086a5ac7a0ae58873c8d4be8f35879bdec71a93b19ae8e2ba073cacac4d56215bcf58375a0cd9d88833
DIST pulseaudio-modules-bt-1.4.tar.gz 87558 BLAKE2B 98b21d8fced5b88d59e45ca4fa2505d3606616a8a09dd95eb91e30b0d31c8a0ec7e52e4c2fd1b601130f69a997871064849fa0c8847ec0686fb42a2ccd7ac43b SHA512 390b6ad0931b464a546c6624bec38cc5b6da7084e4defe2045f4164b0c910a9dd6d4327466eb0e53fcfbc78c995cf2e3634a75b67ee2a14f38ed18e31b5d2bce
diff --git a/media-sound/pulseaudio-modules-bt/pulseaudio-modules-bt-1.4.ebuild b/media-sound/pulseaudio-modules-bt/pulseaudio-modules-bt-1.4.ebuild
deleted file mode 100644
index b1b9841188e..00000000000
--- a/media-sound/pulseaudio-modules-bt/pulseaudio-modules-bt-1.4.ebuild
+++ /dev/null
@@ -1,81 +0,0 @@
-# Copyright 2019-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-inherit cmake readme.gentoo-r1
-
-DESCRIPTION="PulseAudio modules for LDAC, aptX, aptX HD, and AAC for Bluetooth"
-HOMEPAGE="https://github.com/EHfive/pulseaudio-modules-bt"
-
-PULSE_VER="13.0"
-SRC_URI="
- https://github.com/EHfive/pulseaudio-modules-bt/archive/v${PV}.tar.gz -> ${P}.tar.gz
- https://freedesktop.org/software/pulseaudio/releases/pulseaudio-${PULSE_VER}.tar.xz
-"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="fdk +ffmpeg +ldac +native-headset ofono-headset"
-
-DEPEND="
- fdk? ( media-libs/fdk-aac:0= )
- ffmpeg? ( media-video/ffmpeg )
- media-libs/sbc
- ldac? ( media-libs/libldac )
- >=net-wireless/bluez-5
- >=sys-apps/dbus-1.0.0
- ofono-headset? ( >=net-misc/ofono-1.13 )
- ( >=media-sound/pulseaudio-${PULSE_VER}[-bluetooth(-)] <media-sound/pulseaudio-15.99.1 )
-"
-# Ordinarily media-libs/libldac should be in DEPEND too, but for now upstream repo is using a ldac submodule instead.
-RDEPEND="${DEPEND}"
-BDEPEND=""
-
-DISABLE_AUTOFORMATTING="no"
-DOC_CONTENTS="
-After getting media-sound/pulseaudio merged without its bluetooth
-support (to not collide with this) you may have removed the loading
-of bluetooth modules in default.pa config file, leading to failure
-to use your bluetooth device (see
-https://github.com/EHfive/pulseaudio-modules-bt/issues/33).
-Please ensure you have this lines present in your /etc/pulse/default.pa
-file:
-
-.ifexists module-bluetooth-policy.so
-load-module module-bluetooth-policy
-.endif
-
-.ifexists module-bluetooth-discover.so
-load-module module-bluetooth-discover
-.endif
-"
-
-src_prepare() {
- cmake_src_prepare
-
- # pulseaudio headers needed to build
- rmdir pa/ || die
- ln -s ../pulseaudio-${PULSE_VER}/ pa || die
-}
-
-src_configure() {
- local mycmakeargs=(
- -DCODEC_AAC_FDK=$(usex fdk "ON" "OFF")
- -DCODEC_APTX_FF=$(usex ffmpeg "ON" "OFF")
- -DCODEC_APTX_HD_FF=$(usex ffmpeg "ON" "OFF")
- -DCODEC_LDAC=$(usex ldac "ON" "OFF")
- -DNATIVE_HEADSET=$(usex native-headset "ON" "OFF")
- -DOFONO_HEADSET=$(usex ofono-headset "ON" "OFF")
- )
- cmake_src_configure
-}
-
-src_install() {
- cmake_src_install
- readme.gentoo_create_doc
-}
-
-pkg_postinst() {
- readme.gentoo_print_elog
-}
diff --git a/media-sound/pulseaudio/Manifest b/media-sound/pulseaudio/Manifest
deleted file mode 100644
index 39535c6a45a..00000000000
--- a/media-sound/pulseaudio/Manifest
+++ /dev/null
@@ -1,2 +0,0 @@
-DIST pulseaudio-13.0.tar.xz 1901768 BLAKE2B 651a80f54525f196bcb036d893fedd4d9f34e10459918281397a45f498c31bff0d0c836f4e64aab5ac2612ffd5a0cab1a41ea710bbee5fd34dfc9ea1236deea9 SHA512 d445b8ccd43029a0ca0e456fc9291a79d3434d6496ead7eb329ab348d5249235e8bde6cf2be68765d8f761452dbe1486fb10c739e40b1e67ed75787bbd24ac0c
-DIST pulseaudio-15.0.tar.xz 1521760 BLAKE2B a6f7b74fdcfe7f2a993eafb9f465946915a24b6801d3077971b9377290d6c70b3f8640a800abd09d5901db96a20349f31b1beedd9da2249f69b591fb8392f489 SHA512 352ef20384c76c631c0faa73b08e2318902a433712e0c086a5ac7a0ae58873c8d4be8f35879bdec71a93b19ae8e2ba073cacac4d56215bcf58375a0cd9d88833
diff --git a/media-sound/pulseaudio/files/pulseaudio-11.1-disable-flat-volumes.patch b/media-sound/pulseaudio/files/pulseaudio-11.1-disable-flat-volumes.patch
deleted file mode 100644
index 40b23ec05f2..00000000000
--- a/media-sound/pulseaudio/files/pulseaudio-11.1-disable-flat-volumes.patch
+++ /dev/null
@@ -1,48 +0,0 @@
-diff -up a/man/pulse-daemon.conf.5.xml.in b/man/pulse-daemon.conf.5.xml.in
---- a/man/pulse-daemon.conf.5.xml.in 2016-05-26 23:21:17.000000000 -0500
-+++ b/man/pulse-daemon.conf.5.xml.in 2016-05-31 10:01:55.679976730 -0500
-@@ -220,7 +220,7 @@ License along with PulseAudio; if not, s
- <p><opt>flat-volumes=</opt> Enable 'flat' volumes, i.e. where
- possible let the sink volume equal the maximum of the volumes of
- the inputs connected to it. Takes a boolean argument, defaults
-- to <opt>yes</opt>.</p>
-+ to <opt>no</opt>.</p>
- </option>
-
- </section>
-diff -up a/src/daemon/daemon-conf.c b/src/daemon/daemon-conf.c
---- a/src/daemon/daemon-conf.c 2016-05-26 23:21:17.000000000 -0500
-+++ b/src/daemon/daemon-conf.c 2016-05-31 10:01:55.680976735 -0500
-@@ -68,7 +68,7 @@ static const pa_daemon_conf default_conf
- .realtime_priority = 5, /* Half of JACK's default rtprio */
- .disallow_module_loading = false,
- .disallow_exit = false,
-- .flat_volumes = true,
-+ .flat_volumes = false,
- .exit_idle_time = 20,
- .scache_idle_time = 20,
- .script_commands = NULL,
-diff -up a/src/daemon/daemon.conf.in b/src/daemon/daemon.conf.in
---- a/src/daemon/daemon.conf.in 2016-05-31 10:01:55.680976735 -0500
-+++ b/src/daemon/daemon.conf.in 2016-05-31 10:02:28.048133267 -0500
-@@ -57,7 +57,7 @@ ifelse(@HAVE_DBUS@, 1, [dnl
- ; enable-lfe-remixing = no
- ; lfe-crossover-freq = 0
-
--; flat-volumes = yes
-+; flat-volumes = no
-
- ifelse(@HAVE_SYS_RESOURCE_H@, 1, [dnl
- ; rlimit-fsize = -1
-diff -up a/src/pulsecore/core.c b/src/pulsecore/core.c
---- a/src/pulsecore/core.c 2016-05-26 23:21:17.000000000 -0500
-+++ b/src/pulsecore/core.c 2016-05-31 10:01:55.681976740 -0500
-@@ -135,7 +135,7 @@ pa_core* pa_core_new(pa_mainloop_api *m,
- c->exit_idle_time = -1;
- c->scache_idle_time = 20;
-
-- c->flat_volumes = true;
-+ c->flat_volumes = false;
- c->disallow_module_loading = false;
- c->disallow_exit = false;
- c->running_as_daemon = false;
diff --git a/media-sound/pulseaudio/files/pulseaudio-13.0-clang.patch b/media-sound/pulseaudio/files/pulseaudio-13.0-clang.patch
deleted file mode 100644
index d7b81de0313..00000000000
--- a/media-sound/pulseaudio/files/pulseaudio-13.0-clang.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-From e4450d8b586103ec1414e2d6245ff34a9096d97a Mon Sep 17 00:00:00 2001
-From: Peter Levine <plevine457@gmail.com>
-Date: Thu, 26 Sep 2019 07:24:40 +0000
-Subject: [PATCH] atomic: Explicitly cast void* to unsigned long
-
----
- src/pulsecore/atomic.h | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/src/pulsecore/atomic.h b/src/pulsecore/atomic.h
-index a82ca83c5..e5c140109 100644
---- a/src/pulsecore/atomic.h
-+++ b/src/pulsecore/atomic.h
-@@ -117,7 +117,7 @@ static inline void* pa_atomic_ptr_load(const pa_atomic_ptr_t *a) {
- }
-
- static inline void pa_atomic_ptr_store(pa_atomic_ptr_t *a, void* p) {
-- __atomic_store_n(&a->value, p, __ATOMIC_SEQ_CST);
-+ __atomic_store_n(&a->value, (unsigned long) p, __ATOMIC_SEQ_CST);
- }
-
- #else
---
-GitLab
-
diff --git a/media-sound/pulseaudio/files/pulseaudio-14.99.2-require-GIO-for-RTP-GStreamer.patch b/media-sound/pulseaudio/files/pulseaudio-14.99.2-require-GIO-for-RTP-GStreamer.patch
deleted file mode 100644
index a6554178da6..00000000000
--- a/media-sound/pulseaudio/files/pulseaudio-14.99.2-require-GIO-for-RTP-GStreamer.patch
+++ /dev/null
@@ -1,51 +0,0 @@
-From 58052e0e04ee1b5fdb1027ebc19717e7766825ec Mon Sep 17 00:00:00 2001
-From: "Igor V. Kovalenko" <igor.v.kovalenko@gmail.com>
-Date: Mon, 21 Jun 2021 02:32:41 +0300
-Subject: [PATCH] build-sys: meson: require GIO dependency for RTP-GStreamer
-
-Part-of: <https://gitlab.freedesktop.org/pulseaudio/pulseaudio/-/merge_requests/584>
----
- meson.build | 6 ++++--
- src/modules/meson.build | 2 +-
- 2 files changed, 5 insertions(+), 3 deletions(-)
-
-diff --git a/meson.build b/meson.build
-index fdd8bf655..61660b981 100644
---- a/meson.build
-+++ b/meson.build
-@@ -614,8 +614,9 @@ if dbus_dep.found()
- cdata.set('HAVE_DBUS', 1)
- endif
-
--gio_dep = dependency('gio-2.0', version : '>= 2.26.0', required : get_option('gsettings'))
--if gio_dep.found()
-+gio_dep = dependency('gio-2.0', version : '>= 2.26.0')
-+if get_option('gsettings').enabled()
-+ assert(gio_dep.found(), 'GSettings support needs glib I/O library (GIO)')
- cdata.set('HAVE_GSETTINGS', 1)
- endif
-
-@@ -760,6 +761,7 @@ gstrtp_dep = dependency('gstreamer-rtp-1.0', required : get_option('gstreamer'))
-
- have_gstreamer = false
- if gst_dep.found() and gstapp_dep.found() and gstrtp_dep.found()
-+ assert(gio_dep.found(), 'GStreamer-based RTP needs glib I/O library (GIO)')
- have_gstreamer = true
- endif
-
-diff --git a/src/modules/meson.build b/src/modules/meson.build
-index 9c498a4e1..e7db573b6 100644
---- a/src/modules/meson.build
-+++ b/src/modules/meson.build
-@@ -161,7 +161,7 @@ if dbus_dep.found() and fftw_dep.found()
- ]
- endif
-
--if gio_dep.found()
-+if get_option('gsettings').enabled() and gio_dep.found()
- subdir('gsettings')
- all_modules += [
- [ 'module-gsettings',
---
-GitLab
-
diff --git a/media-sound/pulseaudio/files/pulseaudio-14.99.2-require-bluez-dependency.patch b/media-sound/pulseaudio/files/pulseaudio-14.99.2-require-bluez-dependency.patch
deleted file mode 100644
index 5983a05ea4a..00000000000
--- a/media-sound/pulseaudio/files/pulseaudio-14.99.2-require-bluez-dependency.patch
+++ /dev/null
@@ -1,89 +0,0 @@
-From c817dfb5a438055c98449a4a2f34eb4ec341ccde Mon Sep 17 00:00:00 2001
-From: "Igor V. Kovalenko" <igor.v.kovalenko@gmail.com>
-Date: Fri, 18 Jun 2021 20:48:12 +0300
-Subject: [PATCH] build-sys: meson: Require bluez dependency if bluez5 feature
- is enabled
-
-Build breaks if bluez5 and bluez5-native-headset are both enabled
-but bluez headers are not available.
-
-Fix this by changing `bluez5` to Meson feature requiring `bluez` dependency.
-
-Part-of: <https://gitlab.freedesktop.org/pulseaudio/pulseaudio/-/merge_requests/583>
----
- meson.build | 10 ++++++----
- meson_options.txt | 2 +-
- src/modules/bluetooth/meson.build | 2 +-
- src/modules/meson.build | 2 +-
- 4 files changed, 9 insertions(+), 7 deletions(-)
-
-diff --git a/meson.build b/meson.build
-index 61660b981..92ceef706 100644
---- a/meson.build
-+++ b/meson.build
-@@ -706,7 +706,9 @@ endif
-
- sbc_dep = dependency('sbc', version : '>= 1.0', required : false)
-
--if get_option('bluez5')
-+bluez_dep = dependency('bluez', required : get_option('bluez5'))
-+
-+if bluez_dep.found()
- assert(dbus_dep.found(), 'BlueZ requires D-Bus support')
- assert(sbc_dep.found(), 'BlueZ requires SBC support')
- cdata.set('HAVE_SBC', 1)
-@@ -914,9 +916,9 @@ summary = [
- 'Enable Async DNS: @0@'.format(asyncns_dep.found()),
- 'Enable LIRC: @0@'.format(lirc_dep.found()),
- 'Enable D-Bus: @0@'.format(dbus_dep.found()),
-- ' Enable BlueZ 5: @0@'.format(get_option('bluez5')),
-- ' Enable native headsets: @0@'.format(get_option('bluez5-native-headset')),
-- ' Enable ofono headsets: @0@'.format(get_option('bluez5-ofono-headset')),
-+ ' Enable BlueZ 5: @0@'.format(cdata.has('HAVE_BLUEZ_5')),
-+ ' Enable native headsets: @0@'.format(cdata.has('HAVE_BLUEZ_5_NATIVE_HEADSET')),
-+ ' Enable ofono headsets: @0@'.format(cdata.has('HAVE_BLUEZ_5_OFONO_HEADSET')),
- ' Enable GStreamer based codecs: @0@'.format(have_bluez5_gstreamer),
- 'Enable udev: @0@'.format(udev_dep.found()),
- ' Enable HAL->udev compat: @0@'.format(get_option('hal-compat')),
-diff --git a/meson_options.txt b/meson_options.txt
-index cdb3c6787..bb41a42a7 100644
---- a/meson_options.txt
-+++ b/meson_options.txt
-@@ -85,7 +85,7 @@ option('avahi',
- type : 'feature', value : 'auto',
- description : 'Optional Avahi support')
- option('bluez5',
-- type : 'boolean', value : 'true',
-+ type : 'feature', value : 'auto',
- description : 'Optional BlueZ 5 support')
- option('bluez5-gstreamer',
- type : 'feature', value: 'auto',
-diff --git a/src/modules/bluetooth/meson.build b/src/modules/bluetooth/meson.build
-index 99263bb5a..ca77ee6aa 100644
---- a/src/modules/bluetooth/meson.build
-+++ b/src/modules/bluetooth/meson.build
-@@ -35,7 +35,7 @@ libbluez5_util = shared_library('bluez5-util',
- c_args : [pa_c_args, server_c_args],
- link_args : [nodelete_link_args],
- include_directories : [configinc, topinc],
-- dependencies : [libpulse_dep, libpulsecommon_dep, libpulsecore_dep, dbus_dep, sbc_dep, libintl_dep, bluez5_gst_dep, bluez5_gstapp_dep],
-+ dependencies : [libpulse_dep, libpulsecommon_dep, libpulsecore_dep, bluez_dep, dbus_dep, sbc_dep, libintl_dep, bluez5_gst_dep, bluez5_gstapp_dep],
- install : true,
- install_rpath : privlibdir,
- install_dir : modlibexecdir,
-diff --git a/src/modules/meson.build b/src/modules/meson.build
-index e7db573b6..be72c3b9b 100644
---- a/src/modules/meson.build
-+++ b/src/modules/meson.build
-@@ -118,7 +118,7 @@ if avahi_dep.found()
- ]
- endif
-
--if get_option('bluez5')
-+if cdata.has('HAVE_BLUEZ_5')
- subdir('bluetooth')
- all_modules += [
- [ 'module-bluetooth-discover', 'bluetooth/module-bluetooth-discover.c' ],
---
-GitLab
-
diff --git a/media-sound/pulseaudio/files/pulseaudio-15.0-xice-xsm-xtst-daemon-only.patch b/media-sound/pulseaudio/files/pulseaudio-15.0-xice-xsm-xtst-daemon-only.patch
deleted file mode 100644
index f3df62031d3..00000000000
--- a/media-sound/pulseaudio/files/pulseaudio-15.0-xice-xsm-xtst-daemon-only.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-https://bugs.gentoo.org/806052
-
-commit 42af3ee08381faa5807fde68d4c8ec0d7ad5e9a5
-Author: Igor V. Kovalenko <igor.v.kovalenko@gmail.com>
-Date: Tue Aug 3 09:43:32 2021 +0300
-
- build-sys: meson: Require xice, xsm and xtst for daemon only
-
- Part-of: <https://gitlab.freedesktop.org/pulseaudio/pulseaudio/-/merge_requests/613>
-
---- a/meson.build
-+++ b/meson.build
-@@ -681,9 +681,9 @@ endif
- x11_dep = dependency('x11-xcb', required : get_option('x11'))
- if x11_dep.found()
- xcb_dep = dependency('xcb', required : true, version : '>= 1.6')
-- ice_dep = dependency('ice', required : true)
-- sm_dep = dependency('sm', required : true)
-- xtst_dep = dependency('xtst', required : true)
-+ ice_dep = dependency('ice', required : get_option('daemon'))
-+ sm_dep = dependency('sm', required : get_option('daemon'))
-+ xtst_dep = dependency('xtst', required : get_option('daemon'))
- cdata.set('HAVE_X11', 1)
- if cc.has_function('XSetIOErrorExitHandler', dependencies: x11_dep)
- cdata.set('HAVE_XSETIOERROREXITHANDLER', 1)
diff --git a/media-sound/pulseaudio/files/pulseaudio.conf.d b/media-sound/pulseaudio/files/pulseaudio.conf.d
deleted file mode 100644
index 9e7245344a5..00000000000
--- a/media-sound/pulseaudio/files/pulseaudio.conf.d
+++ /dev/null
@@ -1,6 +0,0 @@
-# Config file for /etc/init.d/pulseaudio
-
-# For more see "pulseaudio -h".
-
-# Startup options
-PA_OPTS="--log-target=syslog --disallow-module-loading=1"
diff --git a/media-sound/pulseaudio/files/pulseaudio.init.d-5 b/media-sound/pulseaudio/files/pulseaudio.init.d-5
deleted file mode 100644
index d5415d6987d..00000000000
--- a/media-sound/pulseaudio/files/pulseaudio.init.d-5
+++ /dev/null
@@ -1,80 +0,0 @@
-#!/sbin/openrc-run
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-depend() {
- need localmount
- use net
-
- local script="/etc/pulse/system.pa"
-
- for opt in ${PA_OPTS}; do
- case "$opt" in
- --file=*) script="${opt#*=}" ;;
- -F*) script="${opt#-F}" ;;
- esac
- done
-
- config "$script"
-
- local needs="$(get_options need)"
- if [ -n "${needs}" ]; then
- need ${needs}
- return
- fi
-
- if egrep -q '^[[:space:]]*load-module[[:space:]]+module-console-kit' "$script"; then
- needs="${needs} consolekit"
- fi
-
-#ifdef UDEV
- if egrep -q '^[[:space:]]*load-module[[:space:]]+module-udev-detect' "$script"; then
- needs="${needs} udev"
- fi
-#endif
-
-#ifdef AVAHI
- if egrep -q '^[[:space:]]*load-module[[:space:]]+module-zeroconf-publish' "$script"; then
- needs="${needs} avahi-daemon"
- fi
-#endif
-
-#ifdef BLUETOOTH
- if egrep -q '^[[:space:]]*load-module[[:space:]]+module-bt-proximity' "$script"; then
- needs="${needs} bluetooth"
- fi
-#endif
-
-#ifdef ALSA
- if egrep -q '^[[:space:]]*load-module[[:space:]]+module-alsa-(sink|source)' "$script" ||
- egrep -q '^[[:space:]]*load-module[[:space:]]+module-(udev-)?detect' "$script" ||
- egrep -q '^[[:space:]]*add-autoload-source[[:space:]]+(input|output)[[:space:]]+module-alsa-(sink|source)' "$script"; then
- needs="${needs} alsasound"
- fi
-#endif
-
- need "${needs}"
- save_options need "${needs}"
-}
-
-start() {
- if [ -z "${PULSEAUDIO_SHOULD_NOT_GO_SYSTEMWIDE}" ]; then
- eerror "Please don't use system wide PulseAudio unless you read the"
- eerror "documentation available at http://www.pulseaudio.org/wiki/WhatIsWrongWithSystemMode"
- eerror ""
- eerror "When you're done, please set the variable PULSEAUDIO_SHOULD_NOT_GO_SYSTEMWIDE in"
- eerror "/etc/conf.d/pulseaudio . Please remember that upstream does not support this mode"
- eerror "when used for standard desktop configurations."
- return 1
- fi
- ebegin "Starting pulseaudio"
- PA_ALL_OPTS="${PA_OPTS} --fail=1 --daemonize=1 --system"
- start-stop-daemon --start --exec /usr/bin/pulseaudio -- ${PA_ALL_OPTS}
- eend $?
-}
-
-stop() {
- ebegin "Stopping pulseaudio"
- start-stop-daemon --stop --quiet --exec /usr/bin/pulseaudio --pidfile /var/run/pulse/pid
- eend $?
-}
diff --git a/media-sound/pulseaudio/files/pulseaudio.service b/media-sound/pulseaudio/files/pulseaudio.service
deleted file mode 100644
index c5f0d579992..00000000000
--- a/media-sound/pulseaudio/files/pulseaudio.service
+++ /dev/null
@@ -1,10 +0,0 @@
-[Unit]
-Description=System wide PulseAudio instance
-After=syslog.target network.target alsasound.service
-
-[Service]
-Restart=always
-ExecStart=/usr/bin/pulseaudio --system --log-target=syslog
-
-[Install]
-WantedBy=multi-user.target
diff --git a/media-sound/pulseaudio/files/pulseaudio.tmpfiles b/media-sound/pulseaudio/files/pulseaudio.tmpfiles
deleted file mode 100644
index 88374e35574..00000000000
--- a/media-sound/pulseaudio/files/pulseaudio.tmpfiles
+++ /dev/null
@@ -1 +0,0 @@
-d /var/run/pulse 0755 pulse audio -
diff --git a/media-sound/pulseaudio/metadata.xml b/media-sound/pulseaudio/metadata.xml
index fff0ae344a5..9810b94f531 100644
--- a/media-sound/pulseaudio/metadata.xml
+++ b/media-sound/pulseaudio/metadata.xml
@@ -1,88 +1,27 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer type="project">
- <email>gnome@gentoo.org</email>
- <name>Gentoo GNOME Desktop</name>
+ <maintainer type="person" proxied="yes">
+ <email>igor.v.kovalenko@gmail.com</email>
+ <name>Igor V. Kovalenko</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>sam@gentoo.org</email>
+ <name>Sam James</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>leio@gentoo.org</email>
+ <name>Mart Raudsepp</name>
</maintainer>
<use>
- <flag name="X">
- Build the X11 publish module to export PulseAudio information
- through X11 protocol for clients to make use. Don't enable this
- flag if you want to use a system wide instance. If unsure, enable
- this flag.
- </flag>
- <flag name="alsa-plugin">
- Request installing <pkg>media-plugins/alsa-plugins</pkg> with
- PulseAudio plugin enabled. This ensures that clients supporting
- ALSA only will use PulseAudio.
- </flag>
<flag name="daemon">Build the pulseaudio binary (not-needed for pipewire-pulse)</flag>
- <flag name="elogind">Use <pkg>sys-auth/elogind</pkg> for giving each session a PA client</flag>
- <flag name="gconf">
- Ensure <pkg>gnome-base/gconf</pkg> is present for pulseaudio GConf
- to GSettings module automatic migration (keeping the user configuration)
- </flag>
- <flag name="oss">
- Enable OSS sink/source (output/input). Deprecated, upstream does
- not support this on systems where other sink/source systems are
- available (i.e.: Linux). The padsp wrapper is now always build
- if the system supports OSS at all.
- </flag>
<flag name="glib">
Add support to <pkg>dev-libs/glib</pkg>-based mainloop for the
libpulse client library, to allow using libpulse on glib-based
programs. Build the GSettings PA module.
</flag>
- <flag name="system-wide">
- Allow preparation and installation of the system-wide init
- script for PulseAudio. Since this support is only supported for
- embedded situations, do not enable without reading the upstream
- instructions at
- https://www.freedesktop.org/wiki/Software/PulseAudio/Documentation/User/WhatIsWrongWithSystemWide/ .
- </flag>
- <flag name="asyncns">Use libasyncns for asynchronous name resolution.</flag>
- <flag name="doc">Build the doxygen-described API documentation.</flag>
- <flag name="realtime">
- Makes PulseAudio use RealtimeKit (<pkg>sys-auth/rtkit</pkg>) to get
- real-time priority while running.
- </flag>
- <flag name="equalizer">
- Enable the equalizer module (requires <pkg>sci-libs/fftw</pkg>).
- </flag>
- <flag name="ssl">
- Use <pkg>dev-libs/openssl</pkg> to provide support for RAOP
- (AirPort) streaming.
- </flag>
- <flag name="gdbm">
- Use <pkg>sys-libs/gdbm</pkg> to store PulseAudio
- databases. Recommended for desktop usage. This flag causes the
- whole package to be licensed under GPL-2 or later.
- </flag>
- <flag name="webrtc-aec">
- Uses the webrtc.org AudioProcessing library for enhancing VoIP calls
- greatly in applications that support it by performing acoustic echo
- cancellation, analog gain control, noise suppression and other processing.
- </flag>
- <flag name="systemd">
- Build with <pkg>sys-apps/systemd</pkg> support to replace standalone
- ConsoleKit.
- </flag>
- <flag name="native-headset">
- Build with native HSP backend for bluez 5.
- </flag>
<flag name="ofono-headset">
Build with oFono HFP backend for bluez 5, requires <pkg>net-misc/ofono</pkg>.
</flag>
- <flag name="gstreamer">
- Build with support for gstreamer including ability to use bluetooth codecs.
- For bluetooth codecs see USE ldac and aptx.
- </flag>
- <flag name="aptx">
- aptX (HD) over Bluetooth (many Android compatible headphones), requires <pkg>media-plugins/gst-plugins-openaptx</pkg>.
- </flag>
- <flag name="ldac">
- LDAC over Bluetooth (primarily Sony headphones), requires <pkg>media-plugins/gst-plugins-ldac</pkg>.
- </flag>
</use>
</pkgmetadata>
diff --git a/media-sound/pulseaudio/pulseaudio-13.0-r1.ebuild b/media-sound/pulseaudio/pulseaudio-13.0-r1.ebuild
deleted file mode 100644
index 5c3f45966c1..00000000000
--- a/media-sound/pulseaudio/pulseaudio-13.0-r1.ebuild
+++ /dev/null
@@ -1,355 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-inherit autotools bash-completion-r1 flag-o-matic gnome2-utils linux-info systemd toolchain-funcs udev multilib-minimal tmpfiles
-
-DESCRIPTION="A networked sound server with an advanced plugin system"
-HOMEPAGE="https://www.freedesktop.org/wiki/Software/PulseAudio/"
-SRC_URI="https://freedesktop.org/software/pulseaudio/releases/${P}.tar.xz"
-
-# libpulse-simple and libpulse link to libpulse-core; this is daemon's
-# library and can link to gdbm and other GPL-only libraries. In this
-# cases, we have a fully GPL-2 package. Leaving the rest of the
-# GPL-forcing USE flags for those who use them.
-LICENSE="!gdbm? ( LGPL-2.1 ) gdbm? ( GPL-2 )"
-
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ppc ppc64 sparc x86 ~amd64-linux ~x86-linux"
-
-# +alsa-plugin as discussed in bug #519530
-IUSE="+alsa +alsa-plugin +asyncns bluetooth +caps dbus doc equalizer elogind gconf
-+gdbm +glib gtk ipv6 jack libsamplerate lirc native-headset cpu_flags_arm_neon
-ofono-headset +orc oss qt5 realtime selinux sox ssl systemd system-wide tcpd test
-+udev +webrtc-aec +X zeroconf"
-
-RESTRICT="!test? ( test )"
-# See "*** BLUEZ support not found (requires D-Bus)" in configure.ac
-REQUIRED_USE="
- ?? ( elogind systemd )
- bluetooth? ( dbus )
- equalizer? ( dbus )
- ofono-headset? ( bluetooth )
- native-headset? ( bluetooth )
- realtime? ( dbus )
- udev? ( || ( alsa oss ) )
-"
-
-# libpcre needed in some cases, bug #472228
-RDEPEND="
- || (
- elibc_glibc? ( virtual/libc )
- dev-libs/libpcre
- )
- >=media-libs/libsndfile-1.0.20[${MULTILIB_USEDEP}]
- X? (
- >=x11-libs/libX11-1.4.0[${MULTILIB_USEDEP}]
- >=x11-libs/libxcb-1.6[${MULTILIB_USEDEP}]
- x11-libs/libSM[${MULTILIB_USEDEP}]
- x11-libs/libICE[${MULTILIB_USEDEP}]
- x11-libs/libXtst[${MULTILIB_USEDEP}]
- )
- caps? ( >=sys-libs/libcap-2.22-r2[${MULTILIB_USEDEP}] )
- libsamplerate? ( >=media-libs/libsamplerate-0.1.1-r1 )
- alsa? ( >=media-libs/alsa-lib-1.0.19 )
- glib? ( >=dev-libs/glib-2.26.0:2[${MULTILIB_USEDEP}] )
- zeroconf? ( >=net-dns/avahi-0.6.12[dbus] )
- jack? ( virtual/jack )
- tcpd? ( sys-apps/tcp-wrappers[${MULTILIB_USEDEP}] )
- lirc? ( app-misc/lirc )
- dbus? ( >=sys-apps/dbus-1.0.0[${MULTILIB_USEDEP}] )
- gtk? ( x11-libs/gtk+:3 )
- bluetooth? (
- >=net-wireless/bluez-5
- >=sys-apps/dbus-1.0.0
- media-libs/sbc
- )
- asyncns? ( net-libs/libasyncns[${MULTILIB_USEDEP}] )
- udev? ( >=virtual/udev-143[hwdb(+)] )
- equalizer? ( sci-libs/fftw:3.0 )
- ofono-headset? ( >=net-misc/ofono-1.13 )
- orc? ( >=dev-lang/orc-0.4.15 )
- sox? ( >=media-libs/soxr-0.1.1 )
- ssl? ( dev-libs/openssl:0= )
- media-libs/speexdsp
- gdbm? ( sys-libs/gdbm:= )
- webrtc-aec? ( >=media-libs/webrtc-audio-processing-0.2:0 )
- elogind? ( sys-auth/elogind )
- systemd? ( sys-apps/systemd:0=[${MULTILIB_USEDEP}] )
- dev-libs/libltdl:0
- selinux? ( sec-policy/selinux-pulseaudio )
- realtime? ( sys-auth/rtkit )
- gconf? ( >=gnome-base/gconf-3.2.6 )
-" # libltdl is a valid RDEPEND, libltdl.so is used for native abi in pulsecore and daemon
-
-DEPEND="${RDEPEND}
- X? (
- x11-base/xorg-proto
- >=x11-libs/libXtst-1.0.99.2[${MULTILIB_USEDEP}]
- )
- dev-libs/libatomic_ops
-"
-# This is a PDEPEND to avoid a circular dep
-PDEPEND="
- alsa? ( alsa-plugin? ( >=media-plugins/alsa-plugins-1.0.27-r1[pulseaudio,${MULTILIB_USEDEP}] ) )
-"
-
-# alsa-utils dep is for the alsasound init.d script (see bug #155707)
-# bluez dep is for the bluetooth init.d script
-# PyQt5 dep is for the qpaeq script
-RDEPEND="${RDEPEND}
- equalizer? ( qt5? ( dev-python/PyQt5[dbus,widgets] ) )
- system-wide? (
- alsa? ( media-sound/alsa-utils )
- bluetooth? ( >=net-wireless/bluez-5 )
- acct-user/pulse
- acct-group/pulse-access
- )
- acct-group/audio
-"
-
-BDEPEND="
- doc? ( app-doc/doxygen )
- orc? ( >=dev-lang/orc-0.4.15 )
- system-wide? ( dev-util/unifdef )
- test? ( >=dev-libs/check-0.9.10 )
- sys-devel/gettext
- sys-devel/m4
- virtual/pkgconfig
-"
-
-PATCHES=(
- "${FILESDIR}"/pulseaudio-11.1-disable-flat-volumes.patch # bug 627894
- "${FILESDIR}"/${P}-clang.patch
-)
-
-pkg_pretend() {
- CONFIG_CHECK="~HIGH_RES_TIMERS"
- WARNING_HIGH_RES_TIMERS="CONFIG_HIGH_RES_TIMERS:\tis not set (required for enabling timer-based scheduling in pulseaudio)\n"
- check_extra_config
-
- if linux_config_exists; then
- local snd_hda_prealloc_size=$(linux_chkconfig_string SND_HDA_PREALLOC_SIZE)
- if [ -n "${snd_hda_prealloc_size}" ] && [ "${snd_hda_prealloc_size}" -lt 2048 ]; then
- ewarn "A preallocated buffer-size of 2048 (kB) or higher is recommended for the HD-audio driver!"
- ewarn "CONFIG_SND_HDA_PREALLOC_SIZE=${snd_hda_prealloc_size}"
- fi
- fi
-}
-
-pkg_setup() {
- linux-info_pkg_setup
- gnome2_environment_reset #543364
-}
-
-src_prepare() {
- default
-
- # Skip test that cannot work with sandbox, bug #501846
- sed -i -e '/lock-autospawn-test /d' src/Makefile.am || die
- sed -i -e 's/lock-autospawn-test$(EXEEXT) //' src/Makefile.in || die
-
- eautoreconf
-}
-
-multilib_src_configure() {
- local myconf=(
- --disable-adrian-aec
- --disable-esound
- --disable-gconf
- --disable-solaris
- --enable-largefile
- --localstatedir="${EPREFIX}"/var
- --with-systemduserunitdir=$(systemd_get_userunitdir)
- --with-udev-rules-dir="${EPREFIX}/$(get_udevdir)"/rules.d
- $(multilib_native_use_enable alsa)
- $(multilib_native_use_enable bluetooth bluez5)
- $(multilib_native_use_enable glib gsettings)
- $(multilib_native_use_enable gtk gtk3)
- $(multilib_native_use_enable jack)
- $(multilib_native_use_enable libsamplerate samplerate)
- $(multilib_native_use_enable lirc)
- $(multilib_native_use_enable orc)
- $(multilib_native_use_enable oss oss-output)
- $(multilib_native_use_enable ssl openssl)
- # tests involve random modules, so just do them for the native
- $(multilib_native_use_enable test default-build-tests)
- $(multilib_native_use_enable udev)
- $(multilib_native_use_enable webrtc-aec)
- $(multilib_native_use_enable zeroconf avahi)
- $(multilib_native_use_with equalizer fftw)
- $(multilib_native_use_with sox soxr)
- $(multilib_native_usex gdbm '--with-database=gdbm' '--with-database=simple')
- $(multilib_native_usex orc "ORCC=${BROOT}/usr/bin/orcc" '')
- $(use_enable glib glib2)
- $(use_enable asyncns)
- $(use_enable cpu_flags_arm_neon neon-opt)
- $(use_enable tcpd tcpwrap)
- $(use_enable dbus)
- $(use_enable X x11)
- $(use_enable systemd systemd-daemon)
- # systemd-login isn't necessary for non-native, but the rest of systemd are; not changing it at this point close to a meson port
- $(use_enable systemd systemd-login)
- $(use_enable systemd systemd-journal)
- $(use_enable ipv6)
- $(use_with caps)
- )
-
- if use elogind && multilib_is_native_abi; then
- local PKGCONFIG="$(tc-getPKG_CONFIG)"
- myconf+=(
- --enable-systemd-login
- SYSTEMDLOGIN_CFLAGS="$(${PKGCONFIG} --cflags "libelogind")"
- SYSTEMDLOGIN_LIBS="$(${PKGCONFIG} --libs "libelogind")"
- )
- fi
-
- if use bluetooth; then
- myconf+=(
- $(multilib_native_use_enable native-headset bluez5-native-headset)
- $(multilib_native_use_enable ofono-headset bluez5-ofono-headset)
- )
- fi
-
- if ! multilib_is_native_abi; then
- myconf+=(
- # hack around unnecessary checks
- # (results don't matter, we're not building anything using it)
- ac_cv_lib_ltdl_lt_dladvise_init=yes
- LIBSPEEX_CFLAGS=' '
- LIBSPEEX_LIBS=' '
- )
- else
- # Make padsp work for non-native ABI, supposedly only possible with glibc; this is used by /usr/bin/padsp that comes from native build, thus we need this argument for native build
- if use elibc_glibc ; then
- myconf+=( --with-pulsedsp-location="${EPREFIX}"'/usr/\\$$LIB/pulseaudio' )
- fi
- fi
-
- ECONF_SOURCE=${S} \
- econf "${myconf[@]}"
-}
-
-multilib_src_compile() {
- if multilib_is_native_abi; then
- emake
- use doc && emake doxygen
- else
- local targets=( libpulse.la libpulsedsp.la libpulse-simple.la )
- use glib && targets+=( libpulse-mainloop-glib.la )
- emake -C src ${targets[*]}
- fi
-}
-
-multilib_src_test() {
- # We avoid running the toplevel check target because that will run
- # po/'s tests too, and they are broken. Officially, it should work
- # with intltool 0.41, but that doesn't look like a stable release.
- if multilib_is_native_abi; then
- emake -C src check
- fi
-}
-
-multilib_src_install() {
- if multilib_is_native_abi; then
- emake -j1 DESTDIR="${D}" bashcompletiondir="$(get_bashcompdir)" install
- if use doc ; then
- docinto html
- dodoc -r doxygen/html/
- fi
- else
- local targets=( libpulse.la libpulse-simple.la )
- use glib && targets+=( libpulse-mainloop-glib.la )
- emake DESTDIR="${D}" install-pkgconfigDATA
- emake DESTDIR="${D}" -C src \
- install-libLTLIBRARIES \
- install-padsplibLTLIBRARIES \
- lib_LTLIBRARIES="${targets[*]}" \
- install-pulseincludeHEADERS
- fi
-}
-
-multilib_src_install_all() {
- if use system-wide; then
- newconfd "${FILESDIR}/pulseaudio.conf.d" pulseaudio
-
- use_define() {
- local define=${2:-$(echo $1 | tr '[:lower:]' '[:upper:]')}
-
- use "$1" && echo "-D$define" || echo "-U$define"
- }
-
- unifdef $(use_define zeroconf AVAHI) \
- $(use_define alsa) \
- $(use_define bluetooth) \
- $(use_define udev) \
- "${FILESDIR}/pulseaudio.init.d-5" \
- > "${T}/pulseaudio"
-
- doinitd "${T}/pulseaudio"
-
- systemd_dounit "${FILESDIR}/${PN}.service"
-
- # We need /var/run/pulse, bug #442852
- newtmpfiles "${FILESDIR}/${PN}.tmpfiles" "${PN}.conf"
- else
- # Prevent warnings when system-wide is not used, bug #447694
- if use dbus ; then
- rm "${ED}"/etc/dbus-1/system.d/pulseaudio-system.conf || die
- fi
- fi
-
- if use zeroconf ; then
- sed -e '/module-zeroconf-publish/s:^#::' \
- -i "${ED}/etc/pulse/default.pa" || die
- fi
-
- dodoc NEWS README todo
-
- find "${ED}" \( -name '*.a' -o -name '*.la' \) -delete || die
-}
-
-pkg_postinst() {
- gnome2_schemas_update
- if use system-wide; then
- tmpfiles_process "${PN}.conf"
-
- elog "You have enabled the 'system-wide' USE flag for pulseaudio."
- elog "This mode should only be used on headless servers, embedded systems,"
- elog "or thin clients. It will usually require manual configuration, and is"
- elog "incompatible with many expected pulseaudio features."
- elog "On normal desktop systems, system-wide mode is STRONGLY DISCOURAGED."
- elog "For more information, see"
- elog " https://www.freedesktop.org/wiki/Software/PulseAudio/Documentation/User/WhatIsWrongWithSystemWide/"
- elog " https://www.freedesktop.org/wiki/Software/PulseAudio/Documentation/User/SystemWide/"
- elog " https://wiki.gentoo.org/wiki/PulseAudio#Headless_server"
- fi
-
- if use equalizer && ! use qt5; then
- elog "You've enabled the 'equalizer' USE-flag but not the 'qt5' USE-flag."
- elog "This will build the equalizer module, but the 'qpaeq' tool"
- elog "which is required to set equalizer levels will not work."
- fi
-
- if use equalizer && use qt5; then
- elog "You will need to load some extra modules to make qpaeq work."
- elog "You can do that by adding the following two lines in"
- elog "/etc/pulse/default.pa and restarting pulseaudio:"
- elog "load-module module-equalizer-sink"
- elog "load-module module-dbus-protocol"
- fi
-
- if use native-headset && use ofono-headset; then
- elog "You have enabled both native and ofono headset profiles. The runtime decision"
- elog "which to use is done via the 'headset' argument of module-bluetooth-discover."
- fi
-
- if use libsamplerate; then
- elog "The libsamplerate based resamplers are now deprecated, because they offer no"
- elog "particular advantage over speex. Upstream suggests disabling them."
- fi
-}
-
-pkg_postrm() {
- gnome2_schemas_update
-}
diff --git a/media-sound/pulseaudio/pulseaudio-15.0-r2.ebuild b/media-sound/pulseaudio/pulseaudio-15.0-r2.ebuild
deleted file mode 100644
index 91cc01e8a06..00000000000
--- a/media-sound/pulseaudio/pulseaudio-15.0-r2.ebuild
+++ /dev/null
@@ -1,375 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="7"
-
-MY_PV="${PV/_pre*}"
-MY_P="${PN}-${MY_PV}"
-
-inherit bash-completion-r1 gnome2-utils meson-multilib optfeature systemd tmpfiles udev
-
-DESCRIPTION="A networked sound server with an advanced plugin system"
-HOMEPAGE="https://www.freedesktop.org/wiki/Software/PulseAudio/"
-
-if [[ ${PV} = 9999 ]]; then
- inherit git-r3
- EGIT_BRANCH="master"
- EGIT_REPO_URI="https://gitlab.freedesktop.org/${PN}/${PN}"
-else
- SRC_URI="https://freedesktop.org/software/${PN}/releases/${MY_P}.tar.xz"
- KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ppc ppc64 ~riscv sparc x86 ~amd64-linux ~x86-linux"
-fi
-
-# libpulse-simple and libpulse link to libpulse-core; this is daemon's
-# library and can link to gdbm and other GPL-only libraries. In this
-# cases, we have a fully GPL-2 package. Leaving the rest of the
-# GPL-forcing USE flags for those who use them.
-LICENSE="!gdbm? ( LGPL-2.1 ) gdbm? ( GPL-2 )"
-
-SLOT="0"
-
-# +alsa-plugin as discussed in bug #519530
-# TODO: Deal with bluez5-gstreamer - requires ldacenc and rtpldacpay gstreamer elements
-# TODO: Find out why webrtc-aec is + prefixed - there's already the always available speexdsp-aec
-# NOTE: The current ebuild sets +X almost certainly just for the pulseaudio.desktop file
-IUSE="+alsa +alsa-plugin +asyncns bluetooth dbus +daemon doc elogind equalizer +gdbm
-gstreamer +glib gtk ipv6 jack lirc native-headset ofono-headset +orc oss selinux sox ssl systemd
-system-wide tcpd test +udev +webrtc-aec +X zeroconf"
-
-RESTRICT="!test? ( test )"
-
-# See "*** BLUEZ support not found (requires D-Bus)" in configure.ac
-# Basically all IUSE are either ${MULTILIB_USEDEP} for client libs or they belong under !daemon ()
-# We duplicate alsa-plugin, {native,ofono}-headset under daemon to let users deal with them at once
-REQUIRED_USE="
- alsa-plugin? ( alsa )
- bluetooth? ( dbus )
- daemon? ( ?? ( elogind systemd ) )
- !daemon? (
- !alsa
- !alsa-plugin
- !bluetooth
- !equalizer
- !gdbm
- !gstreamer
- !gtk
- !jack
- !lirc
- !native-headset
- !ofono-headset
- !orc
- !oss
- !sox
- !ssl
- !system-wide
- !udev
- !webrtc-aec
- !zeroconf
- )
- equalizer? ( dbus )
- native-headset? ( bluetooth )
- ofono-headset? ( bluetooth )
- udev? ( || ( alsa oss ) )
- zeroconf? ( dbus )
-"
-
-BDEPEND="
- dev-lang/perl
- dev-perl/XML-Parser
- sys-devel/gettext
- sys-devel/m4
- virtual/libiconv
- virtual/libintl
- virtual/pkgconfig
- doc? ( app-doc/doxygen )
- orc? ( >=dev-lang/orc-0.4.15 )
- system-wide? ( dev-util/unifdef )
-"
-
-# NOTE:
-# - libpcre needed in some cases, bug #472228
-# - media-libs/speexdsp is providing echo canceller implementation
-COMMON_DEPEND="
- >=media-libs/libsndfile-1.0.20[${MULTILIB_USEDEP}]
- >=media-libs/speexdsp-1.2[${MULTILIB_USEDEP}]
- virtual/libc
- alsa? ( >=media-libs/alsa-lib-1.0.24 )
- asyncns? ( >=net-libs/libasyncns-0.1[${MULTILIB_USEDEP}] )
- bluetooth? (
- >=net-wireless/bluez-5
- media-libs/sbc
- )
- daemon? (
- dev-libs/libltdl
- sys-kernel/linux-headers
- >=sys-libs/libcap-2.22-r2
- )
- dbus? ( >=sys-apps/dbus-1.4.12[${MULTILIB_USEDEP}] )
- elogind? ( sys-auth/elogind )
- equalizer? (
- sci-libs/fftw:3.0
- )
- gdbm? ( sys-libs/gdbm:= )
- glib? ( >=dev-libs/glib-2.28.0:2[${MULTILIB_USEDEP}] )
- gstreamer? (
- media-libs/gst-plugins-base
- >=media-libs/gstreamer-1.14
- )
- gtk? ( x11-libs/gtk+:3 )
- jack? ( virtual/jack )
- lirc? ( app-misc/lirc )
- ofono-headset? ( >=net-misc/ofono-1.13 )
- orc? ( >=dev-lang/orc-0.4.15 )
- selinux? ( sec-policy/selinux-pulseaudio )
- sox? ( >=media-libs/soxr-0.1.1 )
- ssl? ( dev-libs/openssl:= )
- systemd? ( sys-apps/systemd:= )
- tcpd? ( sys-apps/tcp-wrappers )
- udev? ( >=virtual/udev-143[hwdb(+)] )
- webrtc-aec? ( >=media-libs/webrtc-audio-processing-0.2:0 )
- X? (
- x11-libs/libX11[${MULTILIB_USEDEP}]
- >=x11-libs/libxcb-1.6[${MULTILIB_USEDEP}]
- daemon? (
- x11-libs/libICE
- x11-libs/libSM
- >=x11-libs/libX11-1.4.0
- >=x11-libs/libXtst-1.0.99.2
- )
- )
- zeroconf? ( >=net-dns/avahi-0.6.12[dbus] )
-"
-
-# pulseaudio ships a bundle xmltoman, which uses XML::Parser
-DEPEND="
- ${COMMON_DEPEND}
- dev-libs/libatomic_ops
- dev-libs/libpcre:*
- test? ( >=dev-libs/check-0.9.10 )
- X? ( x11-base/xorg-proto )
-"
-
-# alsa-utils dep is for the alsasound init.d script (see bug 155707); TODO: read it
-# NOTE: Only system-wide needs acct-group/audio unless elogind/systemd is not used
-RDEPEND="
- ${COMMON_DEPEND}
- system-wide? (
- alsa? ( media-sound/alsa-utils )
- acct-user/pulse
- acct-group/audio
- acct-group/pulse-access
- )
-"
-
-# This is a PDEPEND to avoid a circular dep
-PDEPEND="
- alsa? ( alsa-plugin? ( >=media-plugins/alsa-plugins-1.0.27-r1[pulseaudio,${MULTILIB_USEDEP}] ) )
-"
-
-DOCS=( NEWS README )
-
-S="${WORKDIR}/${MY_P}"
-
-PATCHES=(
- "${FILESDIR}"/pulseaudio-15.0-xice-xsm-xtst-daemon-only.patch
-)
-
-src_prepare() {
- default
-
- gnome2_environment_reset
-}
-
-multilib_src_configure() {
- local emesonargs=(
- --localstatedir="${EPREFIX}"/var
-
- $(meson_native_use_bool daemon)
- $(meson_native_use_bool doc doxygen)
- -Dgcov=false
- # tests involve random modules, so just do them for the native # TODO: tests should run always
- $(meson_native_use_bool test tests)
- -Ddatabase=$(multilib_native_usex gdbm gdbm simple) # tdb is also an option but no one cares about it
- -Dstream-restore-clear-old-devices=true
- -Drunning-from-build-tree=false
-
- # Paths
- -Dmodlibexecdir="${EPREFIX}/usr/$(get_libdir)/${PN}/modules" # Was $(get_libdir)/${P}
- -Dsystemduserunitdir=$(systemd_get_userunitdir)
- -Dudevrulesdir="${EPREFIX}$(get_udevdir)/rules.d"
- -Dbashcompletiondir="$(get_bashcompdir)" # Alternatively DEPEND on app-shells/bash-completion for pkg-config to provide the value
-
- # Optional features
- $(meson_native_use_feature alsa)
- $(meson_feature asyncns)
- $(meson_native_use_feature zeroconf avahi)
- $(meson_native_use_feature bluetooth bluez5)
- -Dbluez5-gstreamer=disabled # no ldacenc/rtpldacpay gst elements packaged yet
- $(meson_native_use_bool native-headset bluez5-native-headset)
- $(meson_native_use_bool ofono-headset bluez5-ofono-headset)
- $(meson_feature dbus)
- $(meson_native_use_feature elogind)
- $(meson_native_use_feature equalizer fftw)
- $(meson_feature glib) # WARNING: toggling this likely changes ABI
- $(meson_native_use_feature glib gsettings) # Supposedly correct?
- $(meson_native_use_feature gstreamer)
- $(meson_native_use_feature gtk)
- -Dhal-compat=true # Consider disabling on next revbump
- $(meson_use ipv6)
- $(meson_native_use_feature jack)
- $(meson_native_use_feature lirc)
- $(meson_native_use_feature ssl openssl)
- $(meson_native_use_feature orc)
- $(meson_native_use_feature oss oss-output)
- -Dsamplerate=disabled # Matches upstream
- $(meson_native_use_feature sox soxr)
- -Dspeex=enabled
- $(meson_native_use_feature systemd)
- $(meson_native_use_feature tcpd tcpwrap) # TODO: This should technically be enabled for 32bit too, but at runtime it probably is never used without daemon?
- $(meson_native_use_feature udev)
- -Dvalgrind=auto
- $(meson_feature X x11)
-
- # Echo cancellation
- -Dadrian-aec=false # Not packaged?
- $(meson_native_use_feature webrtc-aec)
- )
-
- if multilib_is_native_abi; then
- # Make padsp work for non-native ABI, supposedly only possible with glibc;
- # this is used by /usr/bin/padsp that comes from native build, thus we need
- # this argument for native build
- if use elibc_glibc; then
- emesonargs+=( -Dpulsedsp-location="${EPREFIX}"'/usr/\\$$LIB/pulseaudio' )
- fi
- else
- emesonargs+=( -Dman=false )
- if ! use elibc_glibc; then
- # Non-glibc multilib is probably non-existent but just in case:
- ewarn "padsp wrapper for OSS emulation will only work with native ABI applications!"
- fi
- fi
-
- meson_src_configure
-}
-
-multilib_src_compile() {
- meson_src_compile
-
- if multilib_is_native_abi; then
- if use doc; then
- einfo "Generating documentation ..."
- meson_src_compile doxygen
- fi
- fi
-}
-
-multilib_src_install() {
- # The files referenced in the DOCS array do not exist in the multilib source directory,
- # therefore clear the variable when calling the function that will access it.
- DOCS= meson_src_install
-
- if multilib_is_native_abi; then
- if use doc; then
- einfo "Installing documentation ..."
- docinto html
- dodoc -r doxygen/html/.
- fi
- fi
-}
-
-multilib_src_install_all() {
- einstalldocs
-
- if use system-wide; then
- newconfd "${FILESDIR}"/pulseaudio.conf.d pulseaudio
-
- use_define() {
- local define=${2:-$(echo ${1} | tr '[:lower:]' '[:upper:]')}
-
- use "${1}" && echo "-D${define}" || echo "-U${define}"
- }
-
- unifdef -x 1 \
- $(use_define zeroconf AVAHI) \
- $(use_define alsa) \
- $(use_define bluetooth) \
- $(use_define udev) \
- "${FILESDIR}"/pulseaudio.init.d-5 \
- > "${T}"/pulseaudio \
- || die
-
- doinitd "${T}"/pulseaudio
-
- systemd_dounit "${FILESDIR}"/${PN}.service
-
- # We need /var/run/pulse, bug 442852
- newtmpfiles "${FILESDIR}"/${PN}.tmpfiles ${PN}.conf
- else
- # Prevent warnings when system-wide is not used, bug 447694
- if use dbus && use daemon; then
- rm "${ED}"/etc/dbus-1/system.d/pulseaudio-system.conf || die
- fi
- fi
-
- if use zeroconf; then
- sed -i \
- -e '/module-zeroconf-publish/s:^#::' \
- "${ED}/etc/pulse/default.pa" \
- || die
- fi
-
- find "${ED}" \( -name '*.a' -o -name '*.la' \) -delete || die
-}
-
-pkg_postinst() {
- gnome2_schemas_update
-
- if use system-wide; then
- tmpfiles_process "${PN}.conf"
-
- elog "You have enabled the 'system-wide' USE flag for pulseaudio."
- elog "This mode should only be used on headless servers, embedded systems,"
- elog "or thin clients. It will usually require manual configuration, and is"
- elog "incompatible with many expected pulseaudio features."
- elog "On normal desktop systems, system-wide mode is STRONGLY DISCOURAGED."
- elog ""
- elog "For more information, see"
- elog " https://www.freedesktop.org/wiki/Software/PulseAudio/Documentation/User/WhatIsWrongWithSystemWide/"
- elog " https://www.freedesktop.org/wiki/Software/PulseAudio/Documentation/User/SystemWide/"
- elog " https://wiki.gentoo.org/wiki/PulseAudio#Headless_server"
- elog ""
- fi
-
- if use equalizer; then
- elog "You will need to load some extra modules to make qpaeq work."
- elog "You can do that by adding the following two lines in"
- elog "/etc/pulse/default.pa and restarting pulseaudio:"
- elog "load-module module-equalizer-sink"
- elog "load-module module-dbus-protocol"
- elog ""
- fi
-
- if use native-headset && use ofono-headset; then
- elog "You have enabled both native and ofono headset profiles. The runtime decision"
- elog "which to use is done via the 'headset' argument of module-bluetooth-discover."
- elog ""
- fi
-
- if use systemd && use daemon; then
- elog "It's recommended to start pulseaudio via its systemd user units:"
- elog ""
- elog " systemctl --user enable pulseaudio.service pulseaudio.socket"
- elog ""
- elog "The change from autospawn to user units will take effect after restarting."
- elog ""
- fi
-
- optfeature_header "PulseAudio can be enhanced by installing the following:"
- use equalizer && optfeature "using the qpaeq script" dev-python/PyQt5[dbus,widgets]
- use dbus && optfeature "restricted realtime capabilities via D-Bus" sys-auth/rtkit
-}
-
-pkg_postrm() {
- gnome2_schemas_update
-}
diff --git a/media-sound/pulseaudio/pulseaudio-15.99.1-r1.ebuild b/media-sound/pulseaudio/pulseaudio-16.0.ebuild
index 8606be44c53..0e728819bd6 100644
--- a/media-sound/pulseaudio/pulseaudio-15.99.1-r1.ebuild
+++ b/media-sound/pulseaudio/pulseaudio-16.0.ebuild
@@ -5,24 +5,24 @@ EAPI="7"
inherit multilib-minimal
-DESCRIPTION="A networked sound server with an advanced plugin system"
+DESCRIPTION="A meta package for PulseAudio (networked sound server)"
HOMEPAGE="https://www.freedesktop.org/wiki/Software/PulseAudio/"
SRC_URI=""
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~loong ppc ppc64 ~riscv sparc x86 ~amd64-linux ~x86-linux"
LICENSE="metapackage"
SLOT="0"
-# NOTE: bluetooth, native-headset and ofono-headset are passed through to
+# NOTE: bluetooth and ofono-headset are passed through to
# pulseaudio-daemon dependency to make sure users who have bluetooth enabled
# just for pulseaudio package will also get these enabled via metapackage.
-IUSE="bluetooth +daemon +glib jack native-headset ofono-headset"
+IUSE="bluetooth +daemon +glib jack ofono-headset"
RDEPEND="
>=media-libs/libpulse-${PV}[glib?,${MULTILIB_USEDEP}]
- daemon? ( >=media-sound/pulseaudio-daemon-${PV}[bluetooth?,glib?,jack?,native-headset?,ofono-headset?] )
+ daemon? ( >=media-sound/pulseaudio-daemon-${PV}[bluetooth?,glib?,jack?,ofono-headset?] )
"
DEPEND="${RDEPEND}"
diff --git a/media-sound/pulseaudio/pulseaudio-16.1.ebuild b/media-sound/pulseaudio/pulseaudio-16.1.ebuild
new file mode 100644
index 00000000000..4dcb6be5ba3
--- /dev/null
+++ b/media-sound/pulseaudio/pulseaudio-16.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit multilib-minimal
+
+DESCRIPTION="A meta package for PulseAudio (networked sound server)"
+HOMEPAGE="https://www.freedesktop.org/wiki/Software/PulseAudio/"
+SRC_URI=""
+
+KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~loong ppc ppc64 ~riscv sparc x86 ~amd64-linux ~x86-linux"
+
+LICENSE="metapackage"
+
+SLOT="0"
+
+# NOTE: bluetooth and ofono-headset are passed through to
+# pulseaudio-daemon dependency to make sure users who have bluetooth enabled
+# just for pulseaudio package will also get these enabled via metapackage.
+IUSE="bluetooth daemon +glib jack ofono-headset"
+
+RDEPEND="
+ >=media-libs/libpulse-${PV}[glib?,${MULTILIB_USEDEP}]
+ daemon? ( >=media-sound/pulseaudio-daemon-${PV}[bluetooth?,glib?,jack?,ofono-headset?] )
+"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}"
diff --git a/media-sound/pulseeffects/Manifest b/media-sound/pulseeffects/Manifest
index bec4c1ae85c..d83abb7279f 100644
--- a/media-sound/pulseeffects/Manifest
+++ b/media-sound/pulseeffects/Manifest
@@ -1,2 +1 @@
-DIST pulseeffects-4.8.5.tar.gz 2028531 BLAKE2B 0ba68c90d4eb25e3b22c4f39f989bef428c970f0dcfa0b301c500928f835d76c31cd1d7692d1a853b3121d4e8fbee8102c1f538b06cb15933509719a6da5d8a0 SHA512 b72f4d5356af1308d997f01ac2efc5eefb569e9a1253f0a19918aec5f9c2d386ab5c293a5aa6a28e8d15200289f32d34c8f3d524bc50874c750afdee61bc0820
-DIST pulseeffects-4.8.6.tar.gz 2028485 BLAKE2B bf50c72773670ec9b8fd1f21b927b23f6656a2de6c86fc0b68a8fb199a2c949146d1c550f6ce291ca713edb5d0f2a034cf5cae6f3d266c4ef0f541c5f247e422 SHA512 37ad97e7234e9dae0f3be910b35b2dfed94f593c39e59b9977e31c95108e7edede4104cc5fe32292e617f119898c4bad4e9fd5afdfb9aaaa134f5cb78fc5fa0f
+DIST pulseeffects-4.8.7.tar.gz 2028489 BLAKE2B 705783104c7ce3f4ff1246cf05c1a31c09ef0507a720365b9a8914e6e076a209dcc56e240ae2de1981f3ab377f10947d08260fe8ae8b3cae5724db1235a0c01c SHA512 0fa679723ba76ab0a0cf3136dfa66fec09b16643f3f4f7bd1bb2826794d907c5c29a2fc7633e30d3542ddf755c842fdaa167528942fe459e3e697ac3524c0cb9
diff --git a/media-sound/pulseeffects/files/pulseeffects-4.8.5-meson_no_automagic.patch b/media-sound/pulseeffects/files/pulseeffects-4.8.5-meson_no_automagic.patch
deleted file mode 100644
index 2ad89e62977..00000000000
--- a/media-sound/pulseeffects/files/pulseeffects-4.8.5-meson_no_automagic.patch
+++ /dev/null
@@ -1,55 +0,0 @@
---- a/meson.build
-+++ b/meson.build
-@@ -4,7 +4,7 @@
- 'cpp',
- default_options : ['cpp_std=c++17','buildtype=debugoptimized'],
- version: '4.8.5',
-- meson_version: '>= 0.40.0'
-+ meson_version: '>= 0.47.0'
- )
-
- add_global_arguments('-DG_LOG_DOMAIN="pulseeffects"', language : 'c')
---- a/meson_options.txt
-+++ b/meson_options.txt
-@@ -0,0 +1,12 @@
-+option(
-+ 'bs2b',
-+ type: 'feature',
-+ value: 'auto',
-+ description: 'Enable bs2b-based Crossfeed plug-in for improving headphone listening of stereo audio records'
-+)
-+option(
-+ 'rnnoise',
-+ type: 'feature',
-+ value: 'auto',
-+ description: 'Enable rnnoise-based Noise Reduction plug-in'
-+)
---- a/src/meson.build
-+++ b/src/meson.build
-@@ -108,7 +108,7 @@
- dependency('gstreamer-plugins-bad-1.0', version: '>=1.12.5'),
- dependency('gstreamer-fft-1.0'),
- dependency('lilv-0', version: '>=0.22', required: false),
-- dependency('libbs2b', required: false),
-+ dependency('libbs2b', required: get_option('bs2b')),
- dependency('boost', version: '>=1.72', modules:['system','filesystem']),
- dependency('sndfile'),
- dependency('threads')
---- a/src/rnnoise/meson.build
-+++ b/src/rnnoise/meson.build
-@@ -1,4 +1,5 @@
--dep_rnnoise = dependency('rnnoise', required: false)
-+opt_rnnoise = get_option('rnnoise')
-+dep_rnnoise = dependency('rnnoise', required: opt_rnnoise)
-
- if dep_rnnoise.found()
-
-@@ -28,7 +29,7 @@
- cpp_args: plugins_cxx_args
- )
-
--else
-+elif opt_rnnoise.auto()
-
- message('could not find the RNNoise library')
-
diff --git a/media-sound/pulseeffects/files/pulseeffects-4.8.6-boost_1.79.patch b/media-sound/pulseeffects/files/pulseeffects-4.8.6-boost_1.79.patch
deleted file mode 100644
index 825aaca3282..00000000000
--- a/media-sound/pulseeffects/files/pulseeffects-4.8.6-boost_1.79.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-https://bugs.gentoo.org/844898
-https://github.com/wwmm/easyeffects/commit/1000de1c27f422fb2fd6106c554844e9d81925cf
-
-From: Sven Hesse <drmccoy@drmccoy.de>
-Date: Sun, 15 May 2022 19:04:32 +0200
-Subject: [PATCH] fix compilation with Boost 1.79.0
-
-Boost.Filesystem in Boost 1.79.0 changed the already-deprecated header
-of string_file.hpp to be not included by default anymore in its commit
-266e1ac892a6f54d807fb35bf639a9aa1c8b2db1.
-
-Boost.Filesystem's fstream.hpp was never included directly by default,
-but string_file.hpp did include it, so this code here in PulseEffects
-worked. With Boost 1.79.0, though, it explodes in lin 179.
---- a/src/general_settings_ui.cpp
-+++ b/src/general_settings_ui.cpp
-@@ -21,6 +21,7 @@
- #include <giomm/file.h>
- #include <glibmm.h>
- #include <boost/filesystem.hpp>
-+#include <boost/filesystem/fstream.hpp>
- #include "util.hpp"
-
- namespace {
-
diff --git a/media-sound/pulseeffects/files/pulseeffects-4.8.6-meson_no_automagic.patch b/media-sound/pulseeffects/files/pulseeffects-4.8.7-meson_no_automagic.patch
index 0288fab2987..7d29270ce54 100644
--- a/media-sound/pulseeffects/files/pulseeffects-4.8.6-meson_no_automagic.patch
+++ b/media-sound/pulseeffects/files/pulseeffects-4.8.7-meson_no_automagic.patch
@@ -3,7 +3,7 @@
@@ -4,7 +4,7 @@
'cpp',
default_options : ['cpp_std=c++17','buildtype=debugoptimized'],
- version: '4.8.6',
+ version: '4.8.7',
- meson_version: '>= 0.40.0'
+ meson_version: '>= 0.47.0'
)
diff --git a/media-sound/pulseeffects/pulseeffects-4.8.6.ebuild b/media-sound/pulseeffects/pulseeffects-4.8.6.ebuild
deleted file mode 100644
index cb43e035466..00000000000
--- a/media-sound/pulseeffects/pulseeffects-4.8.6.ebuild
+++ /dev/null
@@ -1,87 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit gnome2-utils meson
-
-DESCRIPTION="Limiter, compressor, reverberation, equalizer auto volume effects for Pulseaudio"
-HOMEPAGE="https://github.com/wwmm/easyeffects/tree/pulseaudio-legacy"
-
-if [[ ${PV} == *9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/wwmm/easyeffects"
- EGIT_BRANCH="pulseaudio-legacy"
-else
- SRC_URI="https://github.com/wwmm/easyeffects/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~x86"
-fi
-
-LICENSE="GPL-3"
-SLOT="0"
-IUSE="bs2b calf +doc rnnoise rubberband webrtc zamaudio"
-
-DEPEND=">=dev-libs/boost-1.72:=
- >=dev-cpp/glibmm-2.56.0:2
- >=dev-cpp/gtkmm-3.24:3.0
- >=dev-libs/glib-2.56:2
- >=dev-libs/libsigc++-2.10:2
- >=media-libs/gstreamer-1.12.5:1.0
- media-libs/gst-plugins-base
- >=media-libs/gst-plugins-bad-1.12.5:1.0
- media-libs/libebur128
- media-libs/libsndfile
- >=media-libs/lilv-0.24.2-r1
- >=media-libs/zita-convolver-3.0.0
- media-sound/pulseaudio
- >=x11-libs/gtk+-3.20:3
- bs2b? ( >=media-plugins/gst-plugins-bs2b-1.12.5:1.0 )
- rnnoise? ( media-libs/rnnoise )"
-RDEPEND="!media-sound/easyeffects
- ${DEPEND}
- >=media-libs/gst-plugins-good-1.12.5:1.0
- >=media-libs/lsp-plugins-1.1.24[lv2]
- >=media-plugins/gst-plugins-ladspa-1.12.5:1.0
- >=media-plugins/gst-plugins-lv2-1.12.5:1.0
- >=media-plugins/gst-plugins-pulse-1.12.5:1.0
- sys-apps/dbus
- calf? ( >=media-plugins/calf-0.90.1[lv2] )
- doc? ( gnome-extra/yelp )
- rubberband? ( media-libs/rubberband[ladspa] )
- webrtc? ( media-plugins/gst-plugins-webrtc )
- zamaudio? ( media-plugins/zam-plugins )"
-# Only header files are used from libsamplerate so put it here rather than DEPEND
-# to avoid unnecessary cross-compilation.
-BDEPEND="dev-libs/appstream-glib
- dev-util/desktop-file-utils
- dev-util/itstool
- media-libs/libsamplerate
- sys-devel/gettext
- virtual/pkgconfig"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-4.8.6-meson_no_automagic.patch
- "${FILESDIR}"/${P}-boost_1.79.patch
-)
-
-S="${WORKDIR}"/easyeffects-${PV}
-
-src_configure() {
- local emesonargs=(
- $(meson_feature bs2b)
- $(meson_feature rnnoise)
- )
- meson_src_configure
-}
-
-pkg_postinst() {
- gnome2_gconf_install
- gnome2_schemas_update
- xdg_icon_cache_update
-}
-
-pkg_postrm() {
- gnome2_gconf_uninstall
- gnome2_schemas_update
- xdg_icon_cache_update
-}
diff --git a/media-sound/pulseeffects/pulseeffects-4.8.5-r1.ebuild b/media-sound/pulseeffects/pulseeffects-4.8.7.ebuild
index 9ca5a1a0098..f1b55c4facc 100644
--- a/media-sound/pulseeffects/pulseeffects-4.8.5-r1.ebuild
+++ b/media-sound/pulseeffects/pulseeffects-4.8.7.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit gnome2-utils meson
@@ -21,7 +21,7 @@ LICENSE="GPL-3"
SLOT="0"
IUSE="bs2b calf +doc rnnoise rubberband webrtc zamaudio"
-DEPEND=">=dev-libs/boost-1.72:=
+COMMON=">=dev-libs/boost-1.72:=
>=dev-cpp/glibmm-2.56.0:2
>=dev-cpp/gtkmm-3.24:3.0
>=dev-libs/glib-2.56:2
@@ -37,8 +37,11 @@ DEPEND=">=dev-libs/boost-1.72:=
>=x11-libs/gtk+-3.20:3
bs2b? ( >=media-plugins/gst-plugins-bs2b-1.12.5:1.0 )
rnnoise? ( media-libs/rnnoise )"
+# Only header files are used from libsamplerate
+DEPEND="${COMMON}
+ media-libs/libsamplerate"
RDEPEND="!media-sound/easyeffects
- ${DEPEND}
+ ${COMMON}
>=media-libs/gst-plugins-good-1.12.5:1.0
>=media-libs/lsp-plugins-1.1.24[lv2]
>=media-plugins/gst-plugins-ladspa-1.12.5:1.0
@@ -50,19 +53,18 @@ RDEPEND="!media-sound/easyeffects
rubberband? ( media-libs/rubberband[ladspa] )
webrtc? ( media-plugins/gst-plugins-webrtc )
zamaudio? ( media-plugins/zam-plugins )"
-# Only header files are used from libsamplerate so put it here rather than DEPEND
-# to avoid unnecessary cross-compilation.
BDEPEND="dev-libs/appstream-glib
dev-util/desktop-file-utils
dev-util/itstool
- media-libs/libsamplerate
sys-devel/gettext
virtual/pkgconfig"
PATCHES=(
- "${FILESDIR}"/${PN}-4.8.5-meson_no_automagic.patch
+ "${FILESDIR}"/${PN}-4.8.7-meson_no_automagic.patch
)
+S="${WORKDIR}"/easyeffects-${PV}
+
src_configure() {
local emesonargs=(
$(meson_feature bs2b)
diff --git a/media-sound/qmmp/Manifest b/media-sound/qmmp/Manifest
index 9b6246e96ef..c6a238a8616 100644
--- a/media-sound/qmmp/Manifest
+++ b/media-sound/qmmp/Manifest
@@ -1,2 +1 @@
-DIST qmmp-1.5.4.tar.bz2 1388941 BLAKE2B e1a205b6315cd841c7d7a94ed85dca7fcbc74416dcc09458637ccadab96c3a2614039007cdbab404098d2818f4b5cdb7a0bc5cf27e1bfdd0f146d73e2834f230 SHA512 5dcc543f75f3baa6115c7c692acaca00b1ad6b62c773ac18ad97447fc17978f067d85b132d1fdb65467474417b7d7e8d8b43e0284196978ca63dd5d431a23bf5
-DIST qmmp-1.6.0.tar.bz2 1364512 BLAKE2B 3af905fa8af1a23f04d3df30856f881184a5150de571ffb82efc98179c2fe67a232207ad1233c57fde9000facc1df07317b10658e5f462f79083e99deeb7bb9f SHA512 a96242b4eb46fce84f7eefb1dd90cf4c51809c7f8471a405462d95cb3ba5c373e217c50ed48b4ad6b94e1a7e0948839433d4085c41a35991bffd08699a4826f1
+DIST qmmp-1.6.1.tar.bz2 1353769 BLAKE2B d12f91166cec051caf604ec27dc563d4cf2a52511eabfc0dee0b0679373e7c5fa0f0faac2b4d25420f33485caf90545c7f0098f1e3814f92d46d82b253410afd SHA512 efaf44002c21544514301b5ec1210507fe3cdeb4c6b8d14fb8a573d32db5bb73a9d6d36d00d9d61592261b69fa4260417e3c65183f13299234bd82dda43536c5
diff --git a/media-sound/qmmp/qmmp-1.5.4.ebuild b/media-sound/qmmp/qmmp-1.5.4.ebuild
deleted file mode 100644
index 14e58416acd..00000000000
--- a/media-sound/qmmp/qmmp-1.5.4.ebuild
+++ /dev/null
@@ -1,159 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit cmake xdg
-
-DESCRIPTION="Qt5-based audio player with winamp/xmms skins support"
-HOMEPAGE="http://qmmp.ylsoftware.com"
-if [[ ${PV} != 9999 ]]; then
- SRC_URI="http://qmmp.ylsoftware.com/files/${P}.tar.bz2
- mirror://sourceforge/${PN}-dev/files/${P}.tar.bz2"
- KEYWORDS="amd64 x86"
-else
- inherit subversion
- QMMP_DEV_BRANCH="1.3"
- ESVN_REPO_URI="svn://svn.code.sf.net/p/${PN}-dev/code/branches/${PN}-${QMMP_DEV_BRANCH}"
-fi
-
-LICENSE="GPL-2"
-SLOT="0"
-# KEYWORDS further up
-IUSE="aac +alsa analyzer archive bs2b cdda cover crossfade cue curl +dbus enca
-ffmpeg flac game gnome jack ladspa lyrics +mad midi mms modplug mplayer musepack
-notifier opus oss pipewire projectm pulseaudio qsui qtmedia scrobbler shout sid
-sndfile soxr stereo tray udisks +vorbis wavpack"
-
-REQUIRED_USE="
- gnome? ( dbus )
- shout? ( soxr vorbis )
- udisks? ( dbus )
-"
-
-RDEPEND="
- dev-qt/qtcore:5
- dev-qt/qtgui:5
- dev-qt/qtnetwork:5
- dev-qt/qtsql:5
- dev-qt/qtwidgets:5
- dev-qt/qtx11extras:5
- media-libs/taglib
- x11-libs/libX11
- aac? ( media-libs/faad2 )
- alsa? ( media-libs/alsa-lib )
- archive? ( app-arch/libarchive )
- bs2b? ( media-libs/libbs2b )
- cdda? (
- dev-libs/libcdio:=
- dev-libs/libcdio-paranoia
- )
- curl? ( net-misc/curl )
- dbus? ( dev-qt/qtdbus:5 )
- enca? ( app-i18n/enca )
- ffmpeg? ( media-video/ffmpeg:= )
- flac? ( media-libs/flac )
- game? ( media-libs/game-music-emu )
- jack? (
- media-libs/libsamplerate
- virtual/jack
- )
- ladspa? ( media-plugins/cmt-plugins )
- mad? (
- media-libs/libmad:=
- media-sound/mpg123:=
- )
- midi? ( media-sound/wildmidi )
- mms? ( media-libs/libmms )
- modplug? ( >=media-libs/libmodplug-0.8.4 )
- mplayer? ( media-video/mplayer )
- musepack? ( >=media-sound/musepack-tools-444 )
- opus? ( media-libs/opusfile )
- pipewire? ( media-video/pipewire )
- projectm? (
- dev-qt/qtgui:5[-gles2-only]
- dev-qt/qtopengl:5
- media-libs/libprojectm:=
- )
- pulseaudio? ( >=media-sound/pulseaudio-0.9.9 )
- qtmedia? ( dev-qt/qtmultimedia:5 )
- scrobbler? ( net-misc/curl )
- shout? ( media-libs/libshout )
- sid? ( >=media-libs/libsidplayfp-1.1.0 )
- sndfile? ( media-libs/libsndfile )
- soxr? ( media-libs/soxr )
- udisks? ( sys-fs/udisks:2 )
- vorbis? (
- media-libs/libogg
- media-libs/libvorbis
- )
- wavpack? ( media-sound/wavpack )
-"
-DEPEND="${RDEPEND}
- dev-qt/linguist-tools:5
-"
-
-DOCS=( AUTHORS ChangeLog README )
-
-src_prepare() {
- if has_version dev-libs/libcdio-paranoia ; then
- sed -i \
- -e 's:cdio/cdda.h:cdio/paranoia/cdda.h:' \
- src/plugins/Input/cdaudio/decoder_cdaudio.cpp || die
- fi
-
- cmake_src_prepare
-}
-
-src_configure() {
- local mycmakeargs=(
- -DUSE_AAC="$(usex aac)"
- -DUSE_ALSA="$(usex alsa)"
- -DUSE_ANALYZER="$(usex analyzer)"
- -DUSE_ARCHIVE="$(usex archive)"
- -DUSE_BS2B="$(usex bs2b)"
- -DUSE_CDA="$(usex cdda)"
- -DUSE_COVER="$(usex cover)"
- -DUSE_CROSSFADE="$(usex crossfade)"
- -DUSE_CUE="$(usex cue)"
- -DUSE_CURL="$(usex curl)"
- -DUSE_KDENOTIFY="$(usex dbus)"
- -DUSE_MPRIS="$(usex dbus)"
- -DUSE_ENCA="$(usex enca)"
- -DUSE_FFMPEG="$(usex ffmpeg)"
- -DUSE_FILEWRITER="$(usex vorbis)"
- -DUSE_FLAC="$(usex flac)"
- -DUSE_GME="$(usex game)"
- -DUSE_GNOMEHOTKEY="$(usex gnome)"
- -DUSE_HAL=OFF
- -DUSE_JACK="$(usex jack)"
- -DUSE_LADSPA="$(usex ladspa)"
- -DUSE_LYRICS="$(usex lyrics)"
- -DUSE_MAD="$(usex mad)"
- -DUSE_MIDI="$(usex midi)"
- -DUSE_MMS="$(usex mms)"
- -DUSE_MODPLUG="$(usex modplug)"
- -DUSE_MPLAYER="$(usex mplayer)"
- -DUSE_MPC="$(usex musepack)"
- -DUSE_NOTIFIER="$(usex notifier)"
- -DUSE_OPUS="$(usex opus)"
- -DUSE_OSS="$(usex oss)"
- -DUSE_PIPEWIRE="$(usex pipewire)"
- -DUSE_PROJECTM="$(usex projectm)"
- -DUSE_PULSE="$(usex pulseaudio)"
- -DUSE_QSUI="$(usex qsui)"
- -DUSE_QTMULTIMEDIA="$(usex qtmedia)"
- -DUSE_SCROBBLER="$(usex scrobbler)"
- -DUSE_SHOUT="$(usex shout)"
- -DUSE_SID="$(usex sid)"
- -DUSE_SNDFILE="$(usex sndfile)"
- -DUSE_SOXR="$(usex soxr)"
- -DUSE_STEREO="$(usex stereo)"
- -DUSE_STATICON="$(usex tray)"
- -DUSE_UDISKS2="$(usex udisks)"
- -DUSE_VORBIS="$(usex vorbis)"
- -DUSE_WAVPACK="$(usex wavpack)"
- )
-
- cmake_src_configure
-}
diff --git a/media-sound/qmmp/qmmp-1.6.0.ebuild b/media-sound/qmmp/qmmp-1.6.1-r1.ebuild
index 973fbd88a57..5a037fc63f5 100644
--- a/media-sound/qmmp/qmmp-1.6.0.ebuild
+++ b/media-sound/qmmp/qmmp-1.6.1-r1.ebuild
@@ -10,7 +10,7 @@ HOMEPAGE="http://qmmp.ylsoftware.com"
if [[ ${PV} != 9999 ]]; then
SRC_URI="http://qmmp.ylsoftware.com/files/${P}.tar.bz2
mirror://sourceforge/${PN}-dev/files/${P}.tar.bz2"
- KEYWORDS="~amd64 ~x86"
+ KEYWORDS="amd64 x86"
else
inherit subversion
QMMP_DEV_BRANCH="1.3"
@@ -89,16 +89,11 @@ RDEPEND="
wavpack? ( media-sound/wavpack )
xmp? ( media-libs/libxmp )
"
-DEPEND="${RDEPEND}
- dev-qt/linguist-tools:5
-"
+DEPEND="${RDEPEND}"
+BDEPEND="dev-qt/linguist-tools:5"
DOCS=( AUTHORS ChangeLog README )
-PATCHES=(
- "${FILESDIR}/${PN}-1.6.0-udisks_plugin.patch"
-)
-
src_prepare() {
if has_version dev-libs/libcdio-paranoia ; then
sed -i \
@@ -129,7 +124,6 @@ src_configure() {
-DUSE_FLAC="$(usex flac)"
-DUSE_GME="$(usex game)"
-DUSE_GNOMEHOTKEY="$(usex gnome)"
- -DUSE_HAL=OFF
-DUSE_JACK="$(usex jack)"
-DUSE_LADSPA="$(usex ladspa)"
-DUSE_LYRICS="$(usex lyrics)"
@@ -153,7 +147,7 @@ src_configure() {
-DUSE_SOXR="$(usex soxr)"
-DUSE_STEREO="$(usex stereo)"
-DUSE_STATICON="$(usex tray)"
- -DUSE_UDISKS2="$(usex udisks)"
+ -DUSE_UDISKS="$(usex udisks)"
-DUSE_VORBIS="$(usex vorbis)"
-DUSE_WAVPACK="$(usex wavpack)"
-DUSE_XMP="$(usex xmp)"
diff --git a/media-sound/qmmp/qmmp-9999.ebuild b/media-sound/qmmp/qmmp-9999.ebuild
index 973fbd88a57..4cb654a37cd 100644
--- a/media-sound/qmmp/qmmp-9999.ebuild
+++ b/media-sound/qmmp/qmmp-9999.ebuild
@@ -89,9 +89,8 @@ RDEPEND="
wavpack? ( media-sound/wavpack )
xmp? ( media-libs/libxmp )
"
-DEPEND="${RDEPEND}
- dev-qt/linguist-tools:5
-"
+DEPEND="${RDEPEND}"
+BDEPEND="dev-qt/linguist-tools:5"
DOCS=( AUTHORS ChangeLog README )
@@ -129,7 +128,6 @@ src_configure() {
-DUSE_FLAC="$(usex flac)"
-DUSE_GME="$(usex game)"
-DUSE_GNOMEHOTKEY="$(usex gnome)"
- -DUSE_HAL=OFF
-DUSE_JACK="$(usex jack)"
-DUSE_LADSPA="$(usex ladspa)"
-DUSE_LYRICS="$(usex lyrics)"
@@ -153,7 +151,7 @@ src_configure() {
-DUSE_SOXR="$(usex soxr)"
-DUSE_STEREO="$(usex stereo)"
-DUSE_STATICON="$(usex tray)"
- -DUSE_UDISKS2="$(usex udisks)"
+ -DUSE_UDISKS="$(usex udisks)"
-DUSE_VORBIS="$(usex vorbis)"
-DUSE_WAVPACK="$(usex wavpack)"
-DUSE_XMP="$(usex xmp)"
diff --git a/media-sound/qtractor/Manifest b/media-sound/qtractor/Manifest
index d49f3051a09..0bcf887ae5f 100644
--- a/media-sound/qtractor/Manifest
+++ b/media-sound/qtractor/Manifest
@@ -1 +1,2 @@
DIST qtractor-0.9.26.tar.gz 1868666 BLAKE2B 3e0febf185ad5818bec00c3b66cfdcf8e2ff89909f3934facf3e371283b840847111b3eb175bcc7f5e0a073f06b01554aa5f61a0add1c21588124858849a3cfa SHA512 ca1a1cfcd7083bae83d26b0710cb7b884658176c060858f5f9fbc40a885a498731a544390be2a61f4f986d113ca112271eaf5c6218f6e3051b152dcae836b8d0
+DIST qtractor-0.9.27.tar.gz 1995105 BLAKE2B 08b3a18d37eb700960e24741178079deb728f909f80fc00491abbe832c1d1966022ec6bd2c24469047b53b168a7e084a7d76da96e587afff78662f2f1c9b1d26 SHA512 2bcd4c5676fda58c7cf9ad9a9dcc139eda11c69b1c608812ff912ff63da56fbd0ba6b76828b326038365c9d84519bc752c54572e8edbf573e6cd0d068a17faf6
diff --git a/media-sound/qtractor/qtractor-0.9.27.ebuild b/media-sound/qtractor/qtractor-0.9.27.ebuild
new file mode 100644
index 00000000000..f9f6cb16552
--- /dev/null
+++ b/media-sound/qtractor/qtractor-0.9.27.ebuild
@@ -0,0 +1,103 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake xdg
+
+DESCRIPTION="Audio/MIDI multi-track sequencer written in C++ with the Qt framework"
+HOMEPAGE="https://qtractor.sourceforge.io"
+SRC_URI="mirror://sourceforge/qtractor/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="aubio cpu_flags_x86_sse debug dssi ladspa libsamplerate mad osc rubberband vorbis zlib"
+REQUIRED_USE="dssi? ( ladspa )"
+
+BDEPEND="
+ dev-qt/linguist-tools:5
+ virtual/pkgconfig
+"
+DEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtxml:5
+ dev-qt/qtx11extras:5
+ media-libs/alsa-lib
+ media-libs/libsndfile
+ media-libs/lilv
+ media-libs/lv2
+ media-libs/suil
+ virtual/jack
+ aubio? ( media-libs/aubio )
+ dssi? ( media-libs/dssi )
+ ladspa? ( media-libs/ladspa-sdk )
+ libsamplerate? ( media-libs/libsamplerate )
+ mad? ( media-libs/libmad )
+ osc? ( media-libs/liblo )
+ rubberband? ( media-libs/rubberband )
+ vorbis? ( media-libs/libvorbis )
+ zlib? ( sys-libs/zlib )
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ cmake_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DCONFIG_DSSI=$(usex dssi 1 0)
+ -DCONFIG_GRADIENT=1
+ -DCONFIG_JACK_LATENCY=1
+ -DCONFIG_JACK_METADATA=1
+ -DCONFIG_JACK_SESSION=1
+ -DCONFIG_LADSPA=$(usex ladspa 1 0)
+ -DCONFIG_LIBAUBIO=$(usex aubio 1 0)
+ -DCONFIG_LIBLILV=1
+ -DCONFIG_LIBLO=$(usex osc 1 0)
+ -DCONFIG_LIBMAD=$(usex mad 1 0)
+ -DCONFIG_LIBRUBBERBAND=$(usex rubberband 1 0)
+ -DCONFIG_LIBSAMPLERATE=$(usex libsamplerate 1 0)
+ -DCONFIG_LIBVORBIS=$(usex vorbis 1 0)
+ -DCONFIG_LIBZ=$(usex zlib 1 0)
+ -DCONFIG_LV2=1
+ -DCONFIG_LV2_UI_GTK2=0
+ -DCONFIG_NSM=0
+ -DCONFIG_SSE=$(usex cpu_flags_x86_sse 1 0)
+ -DCONFIG_STACKTRACE=$(usex debug 1 0)
+ -DCONFIG_VESTIGE=0
+ -DCONFIG_VST=0
+ -DCONFIG_VST3=0
+ -DCONFIG_XUNIQUE=0
+ )
+ # Following options are left to the default
+ # CONFIG_LV2_ATOM
+ # CONFIG_LV2_BUF_SIZE
+ # CONFIG_LV2_CVPORT
+ # CONFIG_LV2_EVENT
+ # CONFIG_LV2_EXTERNAL_UI
+ # CONFIG_LV2_MIDNAM
+ # CONFIG_LV2_OPTIONS
+ # CONFIG_LV2_PARAMETERS
+ # CONFIG_LV2_PATCH
+ # CONFIG_LV2_PORT_EVENT
+ # CONFIG_LV2_PRESETS
+ # CONFIG_LV2_PROGRAMS
+ # CONFIG_LV2_STATE
+ # CONFIG_LV2_STATE_FILES
+ # CONFIG_LV2_STATE_MAKE_PATH
+ # CONFIG_LV2_TIME
+ # CONFIG_LV2_TIME_POSITION
+ # CONFIG_LV2_UI
+ # CONFIG_LV2_UI_IDLE
+ # CONFIG_LV2_UI_REQ_VALUE
+ # CONFIG_LV2_UI_SHOW
+ # CONFIG_LV2_UI_TOUCH
+ # CONFIG_LV2_WORKER
+ # CONFIG_LV2_UI_X11
+ cmake_src_configure
+}
diff --git a/media-sound/rexima/files/rexima-1.4-makefile.patch b/media-sound/rexima/files/rexima-1.4-makefile.patch
new file mode 100644
index 00000000000..9c70493b4cd
--- /dev/null
+++ b/media-sound/rexima/files/rexima-1.4-makefile.patch
@@ -0,0 +1,24 @@
+--- a/Makefile
++++ b/Makefile
+@@ -1,7 +1,9 @@
+ # Makefile - makefile for rexima
+
+-CC=gcc
+-CFLAGS=-O -Wall
++PKG_CONFIG ?= pkg-config
++CFLAGS += -Wall
++CPPFLAGS += $(shell $(PKG_CONFIG) --cflags ncurses)
++LDLIBS = $(shell $(PKG_CONFIG) --libs ncurses)
+
+ # Set BINDIR to directory for binary,
+ # MANDIR to directory for man page.
+@@ -16,9 +18,6 @@
+
+ all: rexima
+
+-rexima: rexima.o
+- $(CC) $(CFLAGS) -o rexima rexima.o -lncurses
+-
+ installdirs:
+ /bin/sh ./mkinstalldirs $(BINDIR) $(MANDIR)
+
diff --git a/media-sound/rexima/rexima-1.4-r1.ebuild b/media-sound/rexima/rexima-1.4-r2.ebuild
index 60fcf194acd..72dfeb4e8a7 100644
--- a/media-sound/rexima/rexima-1.4-r1.ebuild
+++ b/media-sound/rexima/rexima-1.4-r2.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
inherit toolchain-funcs
@@ -12,19 +12,15 @@ SRC_URI="ftp://ftp.ibiblio.org/pub/Linux/apps/sound/mixers/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ppc sparc x86"
-IUSE=""
-RDEPEND="sys-libs/ncurses:0="
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
+RDEPEND="sys-libs/ncurses:="
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
-src_configure() {
- tc-export CC
+PATCHES=( "${FILESDIR}"/${P}-makefile.patch )
- cat > Makefile <<- _EOF_ || die
- LDLIBS=$($(tc-getPKG_CONFIG) --libs ncurses)
- all: rexima
- _EOF_
+src_configure() {
+ tc-export CC PKG_CONFIG
}
src_install() {
diff --git a/media-sound/rhythmbox/Manifest b/media-sound/rhythmbox/Manifest
index 8bfa12034e2..d8d889ce68c 100644
--- a/media-sound/rhythmbox/Manifest
+++ b/media-sound/rhythmbox/Manifest
@@ -1,2 +1,2 @@
DIST rhythmbox-3.4.4.tar.xz 3890320 BLAKE2B 69c89c0478d6c43e1c4a10d39f25c25c3dc81f9b93f870e0de8947395e0f49d3902cb8dcf74c945da744536090b7058616545ad706626047e0c8fb61b0b792d7 SHA512 1fcd41dd66ffe34852f8cedb80ade57d101118295d6fd6f0a8687000ab6500991d2e11482daedb30a7abaf63e54e33ee3c4eaab73b075ec5e5907182f9a8c865
-DIST rhythmbox-3.4.5.tar.xz 3537764 BLAKE2B fe710816d0c48f5eac6925d5d160f0db060a3369a98afb8b57bd746998e40d413e51e3f5d2631d28eccb5af9a5b71b511f2c42812fbfa88e2cfd46f16338cc78 SHA512 aa9451a5046a99ed4318a45de6e3df069e7646d83e27895608a1e66f664312d0c2b72c8bb9da902eeb1255ab3d2f15956f4891ff51c1ad28f572c9c020dcefb7
+DIST rhythmbox-3.4.6.tar.xz 3535224 BLAKE2B 5e24facd810e72296ea541f8131b2ac364de0b38b0fd08a1fe6223a333e619cd08a3959fbbc6fbbd36a39990c7cc871decaefc316ce4910460aa6b446b3cb4c0 SHA512 d48818a6f299b3da8ae78bf13e41d702244d83a473586008b53f9c4cc504495ac2570c520c65efaf9e75408363b0256121d12680940c673d2977c7d177ef1fb3
diff --git a/media-sound/rhythmbox/files/3.4.5-relax-meson-version-check.patch b/media-sound/rhythmbox/files/3.4.5-relax-meson-version-check.patch
deleted file mode 100644
index 2843a4c0cab..00000000000
--- a/media-sound/rhythmbox/files/3.4.5-relax-meson-version-check.patch
+++ /dev/null
@@ -1,42 +0,0 @@
-https://github.com/GNOME/rhythmbox/commit/29a1627f1683aac358103710ffc1a51791951edd
-https://bugs.gentoo.org/845006
---- a/meson.build
-+++ b/meson.build
-@@ -3,10 +3,6 @@ project('rhythmbox', 'c',
- meson_version: '>= 0.59.0',
- default_options: ['c_std=gnu89'])
-
--if meson.version().version_compare('> 0.62.0')
-- error('unsupported version of meson, please use 0.62')
--endif
--
- gnome = import('gnome')
- i18n = import('i18n')
- pkg = import('pkgconfig')
-GitLab
-From 0fe3a388fac73a5d4217aed510d65976850734c4 Mon Sep 17 00:00:00 2001
-From: Bastien Nocera <hadess@hadess.net>
-Date: Wed, 4 May 2022 10:23:16 +0200
-Subject: [PATCH 2/2] ci: Install latest meson
-
---- a/.gitlab-ci.yml
-+++ b/.gitlab-ci.yml
-@@ -4,8 +4,6 @@ stages:
- - test
-
- variables:
-- MESON_VER: 0.62.0
--
- UBUNTU_DEPS:
- build-essential
- desktop-file-utils
-@@ -64,7 +62,7 @@ before_script:
- - export DEBIAN_FRONTEND=noninteractive
- - apt-get update
- - apt-get install -y $UBUNTU_DEPS
-- - pip3 install meson==$MESON_VER
-+ - pip3 install meson
-
- test:
- stage: test
-GitLab
diff --git a/media-sound/rhythmbox/rhythmbox-3.4.5.ebuild b/media-sound/rhythmbox/rhythmbox-3.4.6.ebuild
index c4b440ad855..1a0dfd6e900 100644
--- a/media-sound/rhythmbox/rhythmbox-3.4.5.ebuild
+++ b/media-sound/rhythmbox/rhythmbox-3.4.6.ebuild
@@ -2,8 +2,8 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-PYTHON_COMPAT=( python3_{8..10} )
-PYTHON_REQ_USE="xml"
+PYTHON_COMPAT=( python3_{8..11} )
+PYTHON_REQ_USE="xml(+)"
inherit gnome.org gnome2-utils python-single-r1 meson virtualx xdg
@@ -22,7 +22,7 @@ REQUIRED_USE="
python? ( ${PYTHON_REQUIRED_USE} )
"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+KEYWORDS="~alpha amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~riscv ~sparc x86"
DEPEND="
x11-libs/cairo
@@ -93,8 +93,6 @@ BDEPEND="
test? ( dev-libs/check )
"
-PATCHES=( "${FILESDIR}/${PV}"-relax-meson-version-check.patch )
-
pkg_setup() {
use python && python-single-r1_pkg_setup
}
@@ -117,7 +115,7 @@ src_configure() {
-Dhelp=true
$(meson_use gtk-doc gtk_doc)
- $(meson_use test tests)
+ $(meson_feature test tests)
)
meson_src_configure
}
diff --git a/media-sound/rosegarden/Manifest b/media-sound/rosegarden/Manifest
index 9629555f108..51bfd5a3cdd 100644
--- a/media-sound/rosegarden/Manifest
+++ b/media-sound/rosegarden/Manifest
@@ -1 +1 @@
-DIST rosegarden-21.12.tar.bz2 6490931 BLAKE2B d1f3bbd173e1d082c5380be2fe0bd9818a741498add5edc9b24c47b9e37e24b928869c00734bf84dd9c2cb9a79fed15275de35a8e7cd4cbbd8ff6cdcb739c09d SHA512 d11756f57e4f364993af67e4aa10c25ef6a7f5fd4baddd127df50c84c29d31aa1e4a42485c8503e9fca31a8cf8e50c3c5b3bad2a08ac945a3fc8cd1a5874d4be
+DIST rosegarden-22.06.tar.bz2 6514502 BLAKE2B d4ba13ac6b4cba6d0b5bc555933737d696d380737e56a3e4e1dd782aff641dcbd49af50aade75550b8a0e22a45f491585ffb4166b21cb9889eca1a2e546c585a SHA512 42ce03a65f9c9401cb3f641c0ae80a827e18d6f47420add382f63273f4644eac5997befe70cac972380441a43d74153a4e37a276fc3dc8d9889eb8671759ab5a
diff --git a/media-sound/rosegarden/rosegarden-21.12.ebuild b/media-sound/rosegarden/rosegarden-22.06.ebuild
index be07439fa3c..be07439fa3c 100644
--- a/media-sound/rosegarden/rosegarden-21.12.ebuild
+++ b/media-sound/rosegarden/rosegarden-22.06.ebuild
diff --git a/media-sound/schismtracker/Manifest b/media-sound/schismtracker/Manifest
index 0c61e19d31c..99173246caf 100644
--- a/media-sound/schismtracker/Manifest
+++ b/media-sound/schismtracker/Manifest
@@ -1,2 +1,2 @@
-DIST schismtracker-20220125.tar.gz 1309919 BLAKE2B 54fedd4936e51db248b8b237d53b2338488c8332866a221bdd03bc1598aabca80f644052bdc48d8be2f95ad3b10bc6cfc9065a37b62f09df7c0ef4d304a8adde SHA512 c34979cf6cda75a4e5533631b8134b2994a5491f1182b69bfa6e1c97fd2f2e0dc90d883c6184fb24e68e60351e91ca1a2bcccb3708fc0099d0051452b5a44851
DIST schismtracker-20220506.tar.gz 1310121 BLAKE2B a9740c2a8909a533523de18c8cd4c4457bdaa8f6198598fb0e73089fdb2c7bac3211024d5d9cb695aa5758710d0fa16a407ce0e150d0a3ef0071522f2937eec1 SHA512 8dacd1fd719c20fdc8ef157d1487202a39d4f36a37560ad62680655addde0ceb78bbce51e4f640d3979c91f6a4dfe4bc006785aa35d45a00206773d41adf9f42
+DIST schismtracker-20220807.tar.gz 1278129 BLAKE2B 86cb727e4b797ffcf87b7a0dee93d364a93f2c73bd66856af5bdf0c8ef72157824d04141a11a884d3d286cecb5fcdf2a24f91fcb3421e6831b5fdde6681b5100 SHA512 36944581ef88ba256764d1acec0f6d38fb83027ebca7bfea7d313693d9e4062bd217ba6c4dee6a262753b186398b89035d371c5428b35c33eaf95e901bd7304d
diff --git a/media-sound/schismtracker/schismtracker-20220506.ebuild b/media-sound/schismtracker/schismtracker-20220506.ebuild
index c5e2f717127..3701e3cf3a6 100644
--- a/media-sound/schismtracker/schismtracker-20220506.ebuild
+++ b/media-sound/schismtracker/schismtracker-20220506.ebuild
@@ -11,7 +11,7 @@ SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="GPL-2 LGPL-2 public-domain"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="amd64 x86"
IUSE=""
RDEPEND="
diff --git a/media-sound/schismtracker/schismtracker-20220125.ebuild b/media-sound/schismtracker/schismtracker-20220807.ebuild
index 3701e3cf3a6..fdc90b6a2c2 100644
--- a/media-sound/schismtracker/schismtracker-20220125.ebuild
+++ b/media-sound/schismtracker/schismtracker-20220807.ebuild
@@ -11,14 +11,12 @@ SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="GPL-2 LGPL-2 public-domain"
SLOT="0"
-KEYWORDS="amd64 x86"
+KEYWORDS="~amd64 ~x86"
IUSE=""
RDEPEND="
- media-libs/alsa-lib
- media-libs/libsdl[X]
+ media-libs/libsdl2[X]
x11-libs/libX11
- x11-libs/libXext
x11-libs/libXv
"
DEPEND="${RDEPEND}
@@ -30,8 +28,6 @@ src_prepare() {
default
eautoreconf
- sed -e "/^Categories/ s/Audio/AudioVideo;Audio/" -i sys/fd.org/schism.desktop || die
-
# workaround for temporary files (missing directory). Fixes:
# sh ./scripts/build-font.sh . font/default-lower.fnt font/default-upper-alt.fnt font/default-upper-itf.fnt font/half-width.fnt >auto/default-font.c
# /bin/sh: auto/default-font.c: No such file or directory
diff --git a/media-sound/snapcast/snapcast-0.26.0.ebuild b/media-sound/snapcast/snapcast-0.26.0.ebuild
index 24c46c3d753..eb636b7a42e 100644
--- a/media-sound/snapcast/snapcast-0.26.0.ebuild
+++ b/media-sound/snapcast/snapcast-0.26.0.ebuild
@@ -11,7 +11,7 @@ SRC_URI="https://github.com/badaix/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="GPL-3+"
SLOT="0"
-KEYWORDS="~amd64 ~arm ~ppc ~riscv ~x86"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~riscv ~x86"
IUSE="+client +expat +flac +opus +server tremor +vorbis +zeroconf"
REQUIRED_USE="|| ( server client )"
diff --git a/media-sound/sndfile-tools/metadata.xml b/media-sound/sndfile-tools/metadata.xml
index caeebce575d..f9cfd2e4651 100644
--- a/media-sound/sndfile-tools/metadata.xml
+++ b/media-sound/sndfile-tools/metadata.xml
@@ -15,4 +15,7 @@
* sndfile-spectrogram
* sndfile-mix-to-mono
</longdescription>
+ <upstream>
+ <remote-id type="github">libsndfile/sndfile-tools</remote-id>
+ </upstream>
</pkgmetadata>
diff --git a/media-sound/sndio/files/sndio-1.8.0-fix-hardcoded-pkgconfdir.patch b/media-sound/sndio/files/sndio-1.8.0-fix-hardcoded-pkgconfdir.patch
new file mode 100644
index 00000000000..70c66157fab
--- /dev/null
+++ b/media-sound/sndio/files/sndio-1.8.0-fix-hardcoded-pkgconfdir.patch
@@ -0,0 +1,12 @@
+diff -Naur a/configure b/configure
+--- a/configure 2021-05-07 10:49:58.000000000 +0300
++++ b/configure 2022-06-07 14:49:07.623069325 +0300
+@@ -205,7 +205,7 @@
+ datadir="${datadir:-$prefix/share}"
+ includedir="${includedir:-$prefix/include}"
+ libdir="${libdir:-$exec_prefix/lib}"
+-pkgconfdir="${pkgconfdir:-$prefix/lib/pkgconfig}"
++pkgconfdir="${pkgconfdir:-$libdir/pkgconfig}"
+ mandir="${mandir:-$prefix/share/man}"
+
+ #
diff --git a/media-sound/sndio/sndio-1.8.0-r1.ebuild b/media-sound/sndio/sndio-1.8.0-r1.ebuild
new file mode 100644
index 00000000000..3a22a2e82ac
--- /dev/null
+++ b/media-sound/sndio/sndio-1.8.0-r1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 2020-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit multilib-minimal toolchain-funcs
+
+DESCRIPTION="small audio and MIDI framework part of the OpenBSD project"
+HOMEPAGE="http://www.sndio.org/"
+if [[ "${PV}" == "9999" ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://caoua.org/git/sndio"
+ EGIT_MIN_CLONE_TYPE="single+tags"
+else
+ SRC_URI="http://www.sndio.org/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~sparc ~x86"
+fi
+
+LICENSE="ISC"
+SLOT="0/7.1"
+IUSE="alsa"
+
+DEPEND="
+ dev-libs/libbsd[${MULTILIB_USEDEP}]
+ alsa? ( media-libs/alsa-lib[${MULTILIB_USEDEP}] )
+"
+RDEPEND="
+ ${DEPEND}
+ acct-user/sndiod
+"
+
+PATCHES=( "${FILESDIR}"/sndio-1.8.0-fix-hardcoded-pkgconfdir.patch )
+
+src_prepare() {
+ default
+ multilib_copy_sources
+}
+
+multilib_src_configure() {
+ tc-export CC
+
+ ./configure \
+ --prefix="${EPREFIX}"/usr \
+ --libdir="${EPREFIX}"/usr/$(get_libdir) \
+ --privsep-user=sndiod \
+ --with-libbsd \
+ $(use_enable alsa) \
+ || die "Configure failed"
+}
+
+src_install() {
+ multilib-minimal_src_install
+
+ doinitd "${FILESDIR}/sndiod"
+}
diff --git a/media-sound/sonata/sonata-1.7.0.ebuild b/media-sound/sonata/sonata-1.7.0-r1.ebuild
index c413149a5e0..a1207894398 100644
--- a/media-sound/sonata/sonata-1.7.0.ebuild
+++ b/media-sound/sonata/sonata-1.7.0-r1.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_{8..9} )
-DISTUTILS_SINGLE_IMPL="true"
-DISTUTILS_USE_SETUPTOOLS="rdepend"
+PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_PEP517=setuptools
inherit desktop distutils-r1 xdg
DESCRIPTION="Elegant GTK+ music client for the Music Player Daemon (MPD)"
@@ -17,8 +17,6 @@ SLOT="0"
KEYWORDS="amd64 ~ppc x86"
IUSE="dbus taglib"
-BDEPEND="
- virtual/pkgconfig"
RDEPEND="
$(python_gen_cond_dep '
dev-python/pygobject:3[${PYTHON_USEDEP}]
@@ -27,6 +25,7 @@ RDEPEND="
taglib? ( dev-python/tagpy[${PYTHON_USEDEP}] )
')
"
+BDEPEND="virtual/pkgconfig"
distutils_enable_tests unittest
diff --git a/media-sound/sooperlooper/metadata.xml b/media-sound/sooperlooper/metadata.xml
index b69a849fd57..180951d3dba 100644
--- a/media-sound/sooperlooper/metadata.xml
+++ b/media-sound/sooperlooper/metadata.xml
@@ -1,8 +1,11 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<maintainer type="project">
- <email>sound@gentoo.org</email>
- <name>Gentoo Sound project</name>
-</maintainer>
+ <maintainer type="project">
+ <email>sound@gentoo.org</email>
+ <name>Gentoo Sound project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">essej/sooperlooper</remote-id>
+ </upstream>
</pkgmetadata>
diff --git a/media-sound/soundconverter/Manifest b/media-sound/soundconverter/Manifest
index 65d94a9871b..a5fa1c2a5dc 100644
--- a/media-sound/soundconverter/Manifest
+++ b/media-sound/soundconverter/Manifest
@@ -1 +1 @@
-DIST soundconverter-3.0.2.tar.xz 208440 BLAKE2B e7817648fe27b2083629ea718b0479f7b9e2607a017868b1e1ce3fb0407a84a548bd007647e73a1d4163a7f51b162a89e3914419ccdbfd07586c2a94a23f4af2 SHA512 0746395de412a4d845e3df4d6cce0dbcba266c9efc8db71663dd1c751d2a5de5b0dc266f24bbfe6c00f69428801ce5f9558fc8e5e2f5d5e6be8562085cd7fe92
+DIST soundconverter-4.0.3.gh.tar.gz 632495 BLAKE2B 9a2847b5ebb998b9122ff4020e47dc5b84635a6e1ae0de9061bab18e813ab3918278e940df80bc370b071de77a82a3637c376d9ebdd84d2f7b00865dda94935a SHA512 0674eb430bb3cf267ceabee8e7dbdeb2ee81e537ca093fcf6e1adab21112690ed9e3eb349a994805ddfc51b3a4f875b87a5819a1f2cf020752eb8e742665a998
diff --git a/media-sound/soundconverter/metadata.xml b/media-sound/soundconverter/metadata.xml
index 1fd31681d37..e16be19bd1b 100644
--- a/media-sound/soundconverter/metadata.xml
+++ b/media-sound/soundconverter/metadata.xml
@@ -7,5 +7,6 @@
</maintainer>
<upstream>
<remote-id type="launchpad">soundconverter</remote-id>
+ <remote-id type="github">kassoulet/soundconverter</remote-id>
</upstream>
</pkgmetadata>
diff --git a/media-sound/soundconverter/soundconverter-3.0.2-r1.ebuild b/media-sound/soundconverter/soundconverter-3.0.2-r1.ebuild
deleted file mode 100644
index dceecba8d9c..00000000000
--- a/media-sound/soundconverter/soundconverter-3.0.2-r1.ebuild
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python3_{8,9} )
-
-inherit gnome2 python-single-r1
-
-DESCRIPTION="A simple audiofile converter application for the GNOME environment"
-HOMEPAGE="https://soundconverter.org/"
-MY_PV="${PV/_/-}"
-SRC_URI="https://launchpad.net/${PN}/trunk/${MY_PV}/+download/${PN}-${MY_PV}.tar.xz"
-S="${WORKDIR}/${PN}-${MY_PV}"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="amd64 x86"
-
-IUSE="aac flac libnotify mp3 ogg opus vorbis"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-COMMON_DEPEND="${PYTHON_DEPS}
- dev-libs/gobject-introspection:=
- x11-libs/gtk+:3[introspection]
- media-libs/gstreamer:1.0[introspection]
-"
-
-# gst-plugins-meta for any decoders, USE flags for specific encoders used by code
-# List in soundconverter/gstreamer.py
-# wavenc and mp4mux come from gst-plugins-good, which everyone having base should have, so unconditional
-RDEPEND="${COMMON_DEPEND}
- x11-libs/pango[introspection]
- $(python_gen_cond_dep '
- dev-python/gst-python:1.0[${PYTHON_USEDEP}]
- ')
- libnotify? ( x11-libs/libnotify[introspection] )
-
- media-libs/gst-plugins-base:1.0[vorbis?,ogg?]
- media-plugins/gst-plugins-meta:1.0
- flac? ( media-plugins/gst-plugins-flac:1.0 )
- media-libs/gst-plugins-good:1.0
- mp3? (
- media-libs/gst-plugins-bad:1.0
- media-libs/gst-plugins-ugly:1.0
- media-plugins/gst-plugins-lame:1.0
- )
- aac? ( media-plugins/gst-plugins-faac:1.0 )
- opus? ( media-plugins/gst-plugins-opus:1.0 )
-"
-DEPEND="${COMMON_DEPEND}
- dev-util/intltool
- sys-devel/gettext
-"
-
-RESTRICT="test" # broken pot files list in 3.0.0 release, making src_test fallback to "make test" which fails
-
-src_prepare() {
- python_fix_shebang .
- gnome2_src_prepare
-}
-
-src_install() {
- gnome2_src_install
- python_optimize "${ED%/}"/usr/$(get_libdir)/soundconverter/python
-}
diff --git a/media-sound/soundconverter/soundconverter-4.0.3.ebuild b/media-sound/soundconverter/soundconverter-4.0.3.ebuild
new file mode 100644
index 00000000000..5bec269e915
--- /dev/null
+++ b/media-sound/soundconverter/soundconverter-4.0.3.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_REQ_USE="xml(+)"
+inherit gnome2-utils distutils-r1 virtualx xdg
+
+MY_PV="${PV/_/-}"
+DESCRIPTION="A simple audiofile converter application for the GNOME environment"
+HOMEPAGE="https://soundconverter.org/"
+SRC_URI="https://github.com/kassoulet/${PN}/archive/${MY_PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="aac flac mp3 ogg opus vorbis"
+
+# gst-plugins-meta for any decoders, USE flags for specific encoders used by code
+# List in soundconverter/gstreamer.py
+# wavenc and mp4mux come from gst-plugins-good, which everyone having base should have, so unconditional
+RDEPEND="
+ x11-libs/gtk+:3[introspection]
+ x11-libs/libnotify[introspection]
+ x11-libs/pango[introspection]
+ $(python_gen_cond_dep '
+ dev-python/gst-python[${PYTHON_USEDEP}]
+ dev-python/pygobject[${PYTHON_USEDEP}]
+ ')
+ media-libs/gst-plugins-base:1.0[vorbis?,ogg?]
+ media-plugins/gst-plugins-meta:1.0
+ flac? ( media-plugins/gst-plugins-flac:1.0 )
+ media-libs/gst-plugins-good:1.0
+ mp3? (
+ media-libs/gst-plugins-bad:1.0
+ media-libs/gst-plugins-ugly:1.0
+ media-plugins/gst-plugins-lame:1.0
+ )
+ aac? ( media-plugins/gst-plugins-faac:1.0 )
+ opus? ( media-plugins/gst-plugins-opus:1.0 )
+"
+BDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/python-distutils-extra[${PYTHON_USEDEP}]
+ ')
+ test? (
+ media-plugins/gst-plugins-flac:1.0
+ media-libs/gst-plugins-bad:1.0
+ media-libs/gst-plugins-ugly:1.0
+ media-plugins/gst-plugins-lame:1.0
+ media-plugins/gst-plugins-faac:1.0
+ media-plugins/gst-plugins-opus:1.0
+ )
+"
+
+# Before PEP517: tests seem to hang and also fail to find fdkaacenc from gst?
+# After: need to trick it into finding the data (inc. glade files)
+RESTRICT="test"
+
+python_prepare_all() {
+ gnome2_environment_reset
+ distutils-r1_python_prepare_all
+
+ rm -v "${S}/CHANGELOG.old" || die
+
+ # workaround incorrect behavior when LINGUAS is set to an empty string
+ # https://bugs.launchpad.net/python-distutils-extra/+bug/1133594
+ ! [[ -v LINGUAS && -z ${LINGUAS} ]] || rm po/*.po || die
+}
+
+src_test() {
+ virtx distutils-r1_src_test
+}
+
+python_test() {
+ export GSETTINGS_SCHEMA_DIR="${S}/data"
+ "${BROOT}${GLIB_COMPILE_SCHEMAS}" --allow-any-name "${S}"/data || die
+
+ "${EPYTHON}" tests/test.py || die
+}
+
+python_install_all() {
+ rm -v "${ED}"/usr/share/glib-2.0/schemas/gschemas.compiled || die
+ mv -v "${ED}"/usr/share/doc/${PN} "${ED}"/usr/share/doc/${PF} || die
+ distutils-r1_python_install_all
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
diff --git a/media-sound/sox/sox-14.4.2_p20210509.ebuild b/media-sound/sox/sox-14.4.2_p20210509.ebuild
index bf31ee4ef9a..e122a0f1f08 100644
--- a/media-sound/sox/sox-14.4.2_p20210509.ebuild
+++ b/media-sound/sox/sox-14.4.2_p20210509.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -19,7 +19,7 @@ S="${WORKDIR}/${MY_P}"
LICENSE="LGPL-2.1"
SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~mips ppc ppc64 ~riscv sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-solaris"
+KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~loong ~mips ppc ppc64 ~riscv sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-solaris"
IUSE="alsa amr ao encode flac id3tag ladspa mad ogg openmp oss opus png pulseaudio sndfile sndio static-libs twolame wavpack"
BDEPEND="
diff --git a/media-sound/spek/Manifest b/media-sound/spek/Manifest
index 54f02a8e744..60f47392b50 100644
--- a/media-sound/spek/Manifest
+++ b/media-sound/spek/Manifest
@@ -1 +1,2 @@
DIST spek-0.8.3.tar.gz 1349573 BLAKE2B ce783c319741c43f27462caf9dcd27e71f4c8fbc9d3a3d2ac0b977189cca4cf8ed14f258958bbf59532c4cae97562fa20819222ae68567e9e607f243a2777000 SHA512 a4b54746316d295574bc963e650728b23b3730ee6bcc8d78b043a5678baac70a0e859870120de2b0e6a17059e9e3757075f4691e2abde98c083afc393e93e17c
+DIST spek-0.8.4.tar.xz 430096 BLAKE2B 4b3a512f0a8e74650161c9ed7ef0e054325d9f42743362180d970854fccc99cf20fcf329643ffbd0e84a5ee0aff746d2fc2750b91f300e29243ce1194b1b0d9d SHA512 08e39d4c0c7732feec159a8ff29550a62bab37a01325589787e027a027c50ee926f4cd9e0971061bf4e0b53a590b842c6586b4173e09cc9b27dd3b5668dc2d8b
diff --git a/media-sound/spek/files/spek-0.8.4-disable-updates.patch b/media-sound/spek/files/spek-0.8.4-disable-updates.patch
new file mode 100644
index 00000000000..8f498e7942e
--- /dev/null
+++ b/media-sound/spek/files/spek-0.8.4-disable-updates.patch
@@ -0,0 +1,11 @@
+--- a/src/spek-preferences.cc
++++ b/src/spek-preferences.cc
+@@ -44,7 +44,7 @@ SpekPreferences::SpekPreferences() : locale(NULL)
+
+ bool SpekPreferences::get_check_update()
+ {
+- bool result = true;
++ bool result = false;
+ this->config->Read("/update/check", &result);
+ return result;
+ }
diff --git a/media-sound/spek/spek-0.8.4.ebuild b/media-sound/spek/spek-0.8.4.ebuild
new file mode 100644
index 00000000000..dbfa6ab4d59
--- /dev/null
+++ b/media-sound/spek/spek-0.8.4.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+WX_GTK_VER="3.0-gtk3"
+
+inherit wxwidgets xdg
+
+DESCRIPTION="Analyse your audio files by showing their spectrogram"
+HOMEPAGE="http://www.spek-project.org/"
+SRC_URI="https://github.com/alexkay/spek/releases/download/v${PV}/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ media-video/ffmpeg:=
+ x11-libs/wxGTK:${WX_GTK_VER}[X]"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.8.4-disable-updates.patch
+)
+
+src_configure() {
+ setup-wxwidgets unicode
+ default
+}
diff --git a/media-sound/spotify/metadata.xml b/media-sound/spotify/metadata.xml
index a8c59b0ec70..64b7b60216e 100644
--- a/media-sound/spotify/metadata.xml
+++ b/media-sound/spotify/metadata.xml
@@ -1,14 +1,14 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <use>
- <flag name="local-playback">Allows playing local files with the Spotify client</flag>
- <flag name="pax-kernel">Triggers a paxmarking of the main Spotify binary</flag>
- <flag name="pulseaudio">Controls the dependency on pulseaudio or apulse</flag>
- <flag name="systray">Pulls in dependencies needed for systray support on some desktop environments</flag>
- </use>
-<maintainer type="person">
-<email>prometheanfire@gentoo.org</email>
-<name>Matthew Thode</name>
-</maintainer>
+ <maintainer type="person">
+ <email>prometheanfire@gentoo.org</email>
+ <name>Matthew Thode</name>
+ </maintainer>
+ <use>
+ <flag name="local-playback">Allows playing local files with the Spotify client</flag>
+ <flag name="pax-kernel">Triggers a paxmarking of the main Spotify binary</flag>
+ <flag name="pulseaudio">Controls the dependency on pulseaudio or apulse</flag>
+ <flag name="systray">Pulls in dependencies needed for systray support on some desktop environments</flag>
+ </use>
</pkgmetadata>
diff --git a/media-sound/strawberry/Manifest b/media-sound/strawberry/Manifest
index cd77d11cbc5..bfb83981785 100644
--- a/media-sound/strawberry/Manifest
+++ b/media-sound/strawberry/Manifest
@@ -1 +1,3 @@
-DIST strawberry-1.0.4.tar.xz 11208992 BLAKE2B f7a8b000672b55fb667fa4e0f32052adb138b4dbdf2149beec308555ed00417aac0734fe7ede1767bf648d5a10ab527b69f004ffe0b1f8834e65d6dbaf2c52a9 SHA512 e2a90911acd47735715266cb3745910a6e04a2ef4e98b0c9734230a5e2b382cf7d3681fc2e368a361e7a7c53bc0627a88a36e6df6c4f6941d54f65e2424d29ee
+DIST strawberry-1.0.5.tar.xz 11212028 BLAKE2B 2bb668bc9a4f66a9cdeaa28f47f21bf90f999d5524fa443bc7beaa1d0d7c6dc6727bf4df010fc06989e00fc34d62902add11186908fcf3f1b490c3bf745a9971 SHA512 4c625c75855f87952b274c85b4c5b021b27e75a74d46202ab3ea0aa3c86f510bccdece583483c4ba73e4733f151feb5eac5f5ef5d9a956995979fa307fd8d911
+DIST strawberry-1.0.6.tar.xz 11212568 BLAKE2B ed1e3727df27509dfa9513c6dd70912c4e0a6daa0163789775ebbb01f89bf0dfa8f413cdd0cf12d917cf85bf2c13f55f32c50ad0be055ae5d6131b5197827e26 SHA512 8b929ffaac15acd94f244b582a086388bf459131bb9be56b97fb74c954734d209a9928411954ccc445145f70a027763c60d1b111d89532ebd12e9ed0db19e760
+DIST strawberry-1.0.7.tar.xz 11216436 BLAKE2B f7bc53f33be53fb9d947ea4f4c29827cc4248b0249904f2e48cbd9e4440de1f7f866d83c9fddc92cfb6f56b050c4dc40f0ad5e67a58c2a75e47a9d666847e9b3 SHA512 9bf092c3990ae0c2ce63074c7f6076ccab896ae915c4ee255a7fbb6534d50467648f3e96bc029075acfd50515c45ade867e55518d9a68ec9c10a741e1976d64f
diff --git a/media-sound/strawberry/metadata.xml b/media-sound/strawberry/metadata.xml
index 1d06f286e25..aab0f751f90 100644
--- a/media-sound/strawberry/metadata.xml
+++ b/media-sound/strawberry/metadata.xml
@@ -1,10 +1,6 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer type="person">
- <email>polynomial-c@gentoo.org</email>
- <name>Lars Wendler</name>
- </maintainer>
<maintainer type="project">
<email>sound@gentoo.org</email>
<name>Gentoo Sound project</name>
diff --git a/media-sound/strawberry/strawberry-1.0.4.ebuild b/media-sound/strawberry/strawberry-1.0.5.ebuild
index 721ef2158d3..721ef2158d3 100644
--- a/media-sound/strawberry/strawberry-1.0.4.ebuild
+++ b/media-sound/strawberry/strawberry-1.0.5.ebuild
diff --git a/media-sound/strawberry/strawberry-1.0.6.ebuild b/media-sound/strawberry/strawberry-1.0.6.ebuild
new file mode 100644
index 00000000000..fac9c644eb3
--- /dev/null
+++ b/media-sound/strawberry/strawberry-1.0.6.ebuild
@@ -0,0 +1,120 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake flag-o-matic plocale xdg
+
+PLOCALES="ca cs de es es_AR es_ES es_MX fi fr hu id it ja ko nb nl pl pt_BR ru sv uk zh_CN"
+
+DESCRIPTION="Modern music player and library organizer based on Clementine and Qt"
+HOMEPAGE="https://www.strawberrymusicplayer.org/"
+if [[ ${PV} == *9999* ]]; then
+ EGIT_REPO_URI="https://github.com/strawberrymusicplayer/strawberry"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/strawberrymusicplayer/strawberry/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~ppc64 ~x86"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="cdda debug +gstreamer ipod moodbar mtp pulseaudio +udisks vlc"
+
+BDEPEND="
+ dev-qt/linguist-tools:5
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+COMMON_DEPEND="
+ dev-db/sqlite:=
+ dev-libs/glib:2
+ dev-libs/protobuf:=
+ dev-qt/qtconcurrent:5
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5[ssl]
+ dev-qt/qtsql:5[sqlite]
+ dev-qt/qtwidgets:5
+ dev-qt/qtx11extras:5
+ media-libs/alsa-lib
+ media-libs/taglib
+ x11-libs/libX11
+ cdda? ( dev-libs/libcdio:= )
+ gstreamer? (
+ media-libs/chromaprint:=
+ media-libs/gstreamer:1.0
+ media-libs/gst-plugins-base:1.0
+ )
+ ipod? ( media-libs/libgpod )
+ moodbar? ( sci-libs/fftw:3.0 )
+ mtp? ( media-libs/libmtp )
+ pulseaudio? ( media-sound/pulseaudio )
+ vlc? ( media-video/vlc )
+"
+# Note: sqlite driver of dev-qt/qtsql is bundled, so no sqlite use is required; check if this can be overcome someway;
+RDEPEND="${COMMON_DEPEND}
+ gstreamer? (
+ media-plugins/gst-plugins-meta:1.0
+ media-plugins/gst-plugins-soup:1.0
+ media-plugins/gst-plugins-taglib:1.0
+ )
+ mtp? ( gnome-base/gvfs[mtp] )
+ udisks? ( sys-fs/udisks:2 )
+"
+DEPEND="${COMMON_DEPEND}
+ dev-cpp/gtest
+ dev-libs/boost
+ dev-qt/qttest:5
+"
+
+DOCS=( Changelog README.md )
+
+REQUIRED_USE="
+ cdda? ( gstreamer )
+ || ( gstreamer vlc )
+"
+
+src_prepare() {
+ plocale_find_changes "src/translations" "" ".po"
+
+ cmake_src_prepare
+}
+
+src_configure() {
+ # spotify is not in portage
+ local mycmakeargs=(
+ -DBUILD_WERROR=OFF
+ # avoid automagically enabling of ccache (bug #611010)
+ -DCCACHE_EXECUTABLE=OFF
+ -DENABLE_GIO=ON
+ -DLINGUAS="$(plocale_get_locales)"
+ -DENABLE_AUDIOCD="$(usex cdda)"
+ -DENABLE_GSTREAMER="$(usex gstreamer)"
+ -DENABLE_LIBGPOD="$(usex ipod)"
+ -DENABLE_LIBMTP="$(usex mtp)"
+ -DENABLE_LIBPULSE="$(usex pulseaudio)"
+ -DENABLE_MOODBAR="$(usex moodbar)"
+ -DENABLE_MUSICBRAINZ="$(usex gstreamer)"
+ -DENABLE_SONGFINGERPRINTING="$(usex gstreamer)"
+ -DENABLE_UDISKS2="$(usex udisks)"
+ -DENABLE_VLC="$(usex vlc)"
+ # Disable until we have qt6 in the tree
+ -DWITH_QT6=OFF
+ )
+
+ use !debug && append-cppflags -DQT_NO_DEBUG_OUTPUT
+
+ cmake_src_configure
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ if use gstreamer ; then
+ elog "Note that list of supported formats is controlled by media-plugins/gst-plugins-meta "
+ elog "USE flags. You may be interested in setting aac, flac, mp3, ogg or wavpack USE flags "
+ elog "depending on your preferences"
+ fi
+}
diff --git a/media-sound/strawberry/strawberry-1.0.7.ebuild b/media-sound/strawberry/strawberry-1.0.7.ebuild
new file mode 100644
index 00000000000..fac9c644eb3
--- /dev/null
+++ b/media-sound/strawberry/strawberry-1.0.7.ebuild
@@ -0,0 +1,120 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake flag-o-matic plocale xdg
+
+PLOCALES="ca cs de es es_AR es_ES es_MX fi fr hu id it ja ko nb nl pl pt_BR ru sv uk zh_CN"
+
+DESCRIPTION="Modern music player and library organizer based on Clementine and Qt"
+HOMEPAGE="https://www.strawberrymusicplayer.org/"
+if [[ ${PV} == *9999* ]]; then
+ EGIT_REPO_URI="https://github.com/strawberrymusicplayer/strawberry"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/strawberrymusicplayer/strawberry/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~ppc64 ~x86"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="cdda debug +gstreamer ipod moodbar mtp pulseaudio +udisks vlc"
+
+BDEPEND="
+ dev-qt/linguist-tools:5
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+COMMON_DEPEND="
+ dev-db/sqlite:=
+ dev-libs/glib:2
+ dev-libs/protobuf:=
+ dev-qt/qtconcurrent:5
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5[ssl]
+ dev-qt/qtsql:5[sqlite]
+ dev-qt/qtwidgets:5
+ dev-qt/qtx11extras:5
+ media-libs/alsa-lib
+ media-libs/taglib
+ x11-libs/libX11
+ cdda? ( dev-libs/libcdio:= )
+ gstreamer? (
+ media-libs/chromaprint:=
+ media-libs/gstreamer:1.0
+ media-libs/gst-plugins-base:1.0
+ )
+ ipod? ( media-libs/libgpod )
+ moodbar? ( sci-libs/fftw:3.0 )
+ mtp? ( media-libs/libmtp )
+ pulseaudio? ( media-sound/pulseaudio )
+ vlc? ( media-video/vlc )
+"
+# Note: sqlite driver of dev-qt/qtsql is bundled, so no sqlite use is required; check if this can be overcome someway;
+RDEPEND="${COMMON_DEPEND}
+ gstreamer? (
+ media-plugins/gst-plugins-meta:1.0
+ media-plugins/gst-plugins-soup:1.0
+ media-plugins/gst-plugins-taglib:1.0
+ )
+ mtp? ( gnome-base/gvfs[mtp] )
+ udisks? ( sys-fs/udisks:2 )
+"
+DEPEND="${COMMON_DEPEND}
+ dev-cpp/gtest
+ dev-libs/boost
+ dev-qt/qttest:5
+"
+
+DOCS=( Changelog README.md )
+
+REQUIRED_USE="
+ cdda? ( gstreamer )
+ || ( gstreamer vlc )
+"
+
+src_prepare() {
+ plocale_find_changes "src/translations" "" ".po"
+
+ cmake_src_prepare
+}
+
+src_configure() {
+ # spotify is not in portage
+ local mycmakeargs=(
+ -DBUILD_WERROR=OFF
+ # avoid automagically enabling of ccache (bug #611010)
+ -DCCACHE_EXECUTABLE=OFF
+ -DENABLE_GIO=ON
+ -DLINGUAS="$(plocale_get_locales)"
+ -DENABLE_AUDIOCD="$(usex cdda)"
+ -DENABLE_GSTREAMER="$(usex gstreamer)"
+ -DENABLE_LIBGPOD="$(usex ipod)"
+ -DENABLE_LIBMTP="$(usex mtp)"
+ -DENABLE_LIBPULSE="$(usex pulseaudio)"
+ -DENABLE_MOODBAR="$(usex moodbar)"
+ -DENABLE_MUSICBRAINZ="$(usex gstreamer)"
+ -DENABLE_SONGFINGERPRINTING="$(usex gstreamer)"
+ -DENABLE_UDISKS2="$(usex udisks)"
+ -DENABLE_VLC="$(usex vlc)"
+ # Disable until we have qt6 in the tree
+ -DWITH_QT6=OFF
+ )
+
+ use !debug && append-cppflags -DQT_NO_DEBUG_OUTPUT
+
+ cmake_src_configure
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ if use gstreamer ; then
+ elog "Note that list of supported formats is controlled by media-plugins/gst-plugins-meta "
+ elog "USE flags. You may be interested in setting aac, flac, mp3, ogg or wavpack USE flags "
+ elog "depending on your preferences"
+ fi
+}
diff --git a/media-sound/tagtool/files/tagtool-0.12.3-QA-desktop.patch b/media-sound/tagtool/files/tagtool-0.12.3-QA-desktop.patch
new file mode 100644
index 00000000000..50c290d0ee1
--- /dev/null
+++ b/media-sound/tagtool/files/tagtool-0.12.3-QA-desktop.patch
@@ -0,0 +1,10 @@
+--- a/data/tagtool.desktop.in
++++ b/data/tagtool.desktop.in
+@@ -3,6 +3,6 @@
+ _Comment=MP3 and Ogg Vorbis tag editor
+ Exec=tagtool
+ Icon=TagTool
+-Terminal=False
++Terminal=false
+ Type=Application
+ Categories=Audio;AudioVideo;AudioVideoEditing;
diff --git a/media-sound/tagtool/files/tagtool-0.12.3-underlinking.patch b/media-sound/tagtool/files/tagtool-0.12.3-autotools.patch
index 9569ad2fbaf..40d1f5e8044 100644
--- a/media-sound/tagtool/files/tagtool-0.12.3-underlinking.patch
+++ b/media-sound/tagtool/files/tagtool-0.12.3-autotools.patch
@@ -1,10 +1,11 @@
-Fix underlinking issues caused by missing libm and libogg linking
-Gentoo Bug: https://bugs.gentoo.org/show_bug.cgi?id=513012
+* Fix underlinking issues caused by missing libm and libogg linking
+ https://bugs.gentoo.org/513012
+* Fix spurious test failure caused by incomplete POTFILES.in
+ https://bugs.gentoo.org/631236
+* In addition, fix nonidiomatic AC_ARG_ENABLE option handling.
-In addition, fix nonidiomatic AC_ARG_ENABLE option handling.
-
---- tagtool-0.12.3/configure.ac
-+++ tagtool-0.12.3/configure.ac
+--- a/configure.ac
++++ b/configure.ac
@@ -13,20 +13,16 @@
@@ -57,8 +58,15 @@ In addition, fix nonidiomatic AC_ARG_ENABLE option handling.
AM_CONDITIONAL(ENABLE_MP3, test "$enable_mp3" = "yes")
AM_CONDITIONAL(ENABLE_VORBIS, test "$enable_vorbis" = "yes")
---- tagtool-0.12.3/src/Makefile.am
-+++ tagtool-0.12.3/src/Makefile.am
+--- a/po/POTFILES.in
++++ b/po/POTFILES.in
+@@ -22,3 +22,4 @@
+ src/vorbis_edit.c
+ src/vorbis_edit_field.c
+ src/vorbis_file.c
++src/vcedit.c
+--- a/src/Makefile.am
++++ b/src/Makefile.am
@@ -28,7 +28,8 @@
vorbis_sources = vorbis_file.c vorbis_file.h vorbis_edit.c \
vorbis_edit.h vorbis_edit_field.c vorbis_edit_field.h vcedit.c \
diff --git a/media-sound/tagtool/tagtool-0.12.3-r1.ebuild b/media-sound/tagtool/tagtool-0.12.3-r2.ebuild
index be7039a613e..65eb348ceaf 100644
--- a/media-sound/tagtool/tagtool-0.12.3-r1.ebuild
+++ b/media-sound/tagtool/tagtool-0.12.3-r2.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
-inherit autotools
+inherit autotools xdg
DESCRIPTION="Audio Tag Tool Ogg/Mp3 Tagger"
HOMEPAGE="https://sourceforge.net/projects/tagtool/"
@@ -15,21 +15,20 @@ KEYWORDS="amd64 ppc ~sparc x86"
IUSE="mp3 +vorbis"
REQUIRED_USE="|| ( mp3 vorbis )"
-RDEPEND="x11-libs/gtk+:2
+RDEPEND="
+ x11-libs/gtk+:2
>=gnome-base/libglade-2.6
mp3? ( >=media-libs/id3lib-3.8.3-r6 )
vorbis? ( >=media-libs/libvorbis-1 )"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
PATCHES=(
- "${FILESDIR}"/${P}-underlinking.patch
+ "${FILESDIR}"/${P}-autotools.patch
+ "${FILESDIR}"/${P}-QA-desktop.patch
)
src_prepare() {
- # QA fix for wrong boolean value
- sed -i -e 's/Terminal=False/Terminal=false/' data/tagtool.desktop.in || die
-
default
eautoreconf
}
@@ -43,9 +42,8 @@ src_configure() {
src_install() {
emake \
DESTDIR="${D}" \
- GNOME_SYSCONFDIR="${D}/etc" \
- sysdir="${D}/usr/share/applets/Multimedia" \
+ GNOME_SYSCONFDIR="${ED}"/etc \
+ sysdir="${ED}"/usr/share/applets/Multimedia \
install
-
- dodoc ChangeLog NEWS README TODO THANKS
+ einstalldocs
}
diff --git a/media-sound/teamspeak-client/Manifest b/media-sound/teamspeak-client/Manifest
index b9992c97d14..1e36d6095c7 100644
--- a/media-sound/teamspeak-client/Manifest
+++ b/media-sound/teamspeak-client/Manifest
@@ -1,3 +1,3 @@
DIST TeamSpeak3-Client-linux_amd64-3.5.6.run 100152301 BLAKE2B 9fbaa32ac000c9e29e09dcb1c932acea45265d5cf464308d6f27063fb3095690f3cb96abb061ce947438a4b919dcbaf8f3f0189048b470b09bb2b8285e426e39 SHA512 fe1b41773d2b2de8198fdaf189c6665994eeaf6a0255485f7d342a3e77702f5515d5c5c685410a0b5844b4ad5c395d57b68e57c7b1f46bd1211ef813ce1e0030
DIST TeamSpeak3-Client-linux_x86-3.5.6.run 98637555 BLAKE2B 6f891e6846f8f899edb8ef107b7ea6518f413488525b7696863292d99d73614cae40631f5ed2341cce75ea62ffd94c60968ff6b5d587446d7469271835c01202 SHA512 dfc5ed3e2a92ed9f1cea2fdde5e40cf73e4a999ea782c434b26072ac0e7ac37d6305c06ae2d39c104eeee10639f325c7b96f538082e60224a68c0553fab0d12c
-DIST teamspeak-client-5.0.0_beta68.tar.gz 134468631 BLAKE2B ddc02ec9b5e9b8a3ea3fb629bd39ab4973b6e9cf610d90a37d1ebde08fc893ea087e18efa599eac497771ee31aa7f4e835d6e2b6a07fb536eee150d0747be9d7 SHA512 3c3061b1e42fa7a90ddcadde9d27d543529dea45e4da023bf0519588fc64ff5336f1fe0abdf4f9ab42f255959f766bc6fbfae9d6daa2e3d8b3ba1fc76b74b293
+DIST teamspeak-client-5.0.0_beta70.tar.gz 137244141 BLAKE2B f6b238de91773782e94158fba194d87a0229a058cef9d0065f1c6e32139c4e753772086d2186fc3522fbb6654daadaba77ac981abd643513a3586ebb35650443 SHA512 144ee2409a511ac46155db95a6f7b2d641052b34fb8cb2a26b0724a7b9aa7d718db392d2e32b460cf9ca0c379d56397759c2cb65c3ac74260fa45cfb27c5f740
diff --git a/media-sound/teamspeak-client/teamspeak-client-5.0.0_beta68.ebuild b/media-sound/teamspeak-client/teamspeak-client-5.0.0_beta70.ebuild
index 03442d21525..8d989b8a4bf 100644
--- a/media-sound/teamspeak-client/teamspeak-client-5.0.0_beta68.ebuild
+++ b/media-sound/teamspeak-client/teamspeak-client-5.0.0_beta70.ebuild
@@ -7,7 +7,7 @@ inherit desktop xdg-utils
DESCRIPTION="A client software for quality voice communication via the internet"
HOMEPAGE="https://www.teamspeak.com/"
-SRC_URI="https://files.teamspeak-services.com/teamspeak/teamspeak-client.tar.gz -> ${P}.tar.gz"
+SRC_URI="https://files.teamspeak-services.com/pre_releases/client/${PV/_/-}/teamspeak-client.tar.gz -> ${P}.tar.gz"
S="${WORKDIR}"
KEYWORDS=""
@@ -69,7 +69,7 @@ src_install() {
dodir /opt/bin
dosym ../teamspeak5-client/TeamSpeak /opt/bin/ts5client
- make_desktop_entry /opt/bin/ts5client "Teamspeak 5 Client" /opt/teamspeak5-client/html/client_ui/images/icons/teamspea "Audio;AudioVideo;Network"
+ make_desktop_entry /opt/bin/ts5client "Teamspeak 5 Client" /opt/teamspeak5-client/html/client_ui/images/icons/teamspeak_logo.svg "Audio;AudioVideo;Network"
}
pkg_postinst() {
diff --git a/media-sound/teamspeak-server/Manifest b/media-sound/teamspeak-server/Manifest
index 4855c0956d3..7e25eff98f3 100644
--- a/media-sound/teamspeak-server/Manifest
+++ b/media-sound/teamspeak-server/Manifest
@@ -1,2 +1,2 @@
-DIST teamspeak3-server_linux_amd64-3.13.6.tar.bz2 9948972 BLAKE2B 397e96751e6688b5579ff7828e4998e3b26183b0b10980e89748d51207428059e7d8cfa6f2f6fb961b77f735f61e1ba00ac13a077c76b5d22a7b2abb28d67e48 SHA512 dc007cdc924fd284da4a206cf615816b53c2f03ccb2573a29aa2bce6874e09ce5764a3953f8e84de8a3cc02aee306b1505d8c7edf8d48713bbf5f172c3be3422
-DIST teamspeak3-server_linux_x86-3.13.6.tar.bz2 9785491 BLAKE2B f0d196a72e9a4283006c4dfd9a1d86e96a3b435d8bf14dfca178ea0240e94b88bcf3b9e20b6c99638e04019065fa79d28ac2d9ad452e306c4c27966e32464c69 SHA512 ef124964590c106bacd3bc98847a5e8f64fbbf69ccb2a216f9af6548f5f2d200c0bd307d283f48cb08c254fddb92fe03f6cff2c3c87e7ca593edf3023b053bee
+DIST teamspeak3-server_linux_amd64-3.13.7.tar.bz2 9968877 BLAKE2B 7c2f200b1e3a3184005aab213acc681326e16a776f529dbdac900f5b9a6ee9d91883d1aabfe4526e52e9a706a4856366291f061efc6eff581216d7450746322d SHA512 cd026e0c51d8269bd6965f9f274ff6478d4e179d23ee1b00f93a887997985b97afcb7eda05e34150d6fe0610f2715a61989a7f3ca05994067e71b9d3171e2962
+DIST teamspeak3-server_linux_x86-3.13.7.tar.bz2 9820644 BLAKE2B 37789bfe4c544b8eeb28a34d1fae933e2d2a11b23e85a6de66ac4c9772a061860803a3a767227d787efd90f7aa031b3ca77b229acca554aebd69f1f78b28128c SHA512 04278359a03cb9f8bc6db48b54976020da6a44629f17b503378bf0ffe554da838193ba590ab895e97c96e026aa87d96a3e167a009710adc4b9b03193d496201d
diff --git a/media-sound/teamspeak-server/teamspeak-server-3.13.6-r1.ebuild b/media-sound/teamspeak-server/teamspeak-server-3.13.7.ebuild
index 689e764c78d..689e764c78d 100644
--- a/media-sound/teamspeak-server/teamspeak-server-3.13.6-r1.ebuild
+++ b/media-sound/teamspeak-server/teamspeak-server-3.13.7.ebuild
diff --git a/media-sound/umurmur/Manifest b/media-sound/umurmur/Manifest
deleted file mode 100644
index 88c77311084..00000000000
--- a/media-sound/umurmur/Manifest
+++ /dev/null
@@ -1,3 +0,0 @@
-DIST umurmur-0.2.17.tar.gz 93786 BLAKE2B 92fc7d63dc0eed228c3fbcb0d18861cd49967f44378d980e856f8fb24fe7abc3429a4ca8e811eda6096727b76780724c909c46c04975b5edef70d848b7511618 SHA512 a496a51fd7815ad117f5aee17bb78cbd319c584ad60ab8aebbfd8ddf7b1760f443f2337bc74be1e0d5af17d3c3df2ae6c9060eca576cf1e6ed4c6cb0825e9c15
-DIST umurmur-0.2.19.tar.gz 93117 BLAKE2B 54d6fe6e67f51f24d6c9f0125fa330292004cd5df71791c40ece6aa7c2938bce98ca981e873a1e2b43598f99ea57c687963fd7cd8708400f5f2ce00ab11386eb SHA512 4a10c41d8396d6bd2b195578ff6a29e69a105f8830daf85141217f768cc2c4ea6204a2b3b65599d07d76c841090750db4ad6264c4e9d7e5afa7f1b4cf27bc768
-DIST umurmur-0.2.20.tar.gz 93152 BLAKE2B 7850d0f3a5c35db1f5ed2b2eea7725d288901eb7e49b9bf2f715963a102c6c6345ed90fd066d80a2666137918c73a58dd2c954321b69d0ce59f686e1c6d01e5a SHA512 0913f5ba84b30fec4ae6a1521c442ff8c48121bbbca5de9082e04e41b36434fadb5f81cb2ea0bd0a8c63f6e541d15eeda3637667d8cc7113d38935ded320cef4
diff --git a/media-sound/umurmur/files/umurmur-0.2.20-openssl3.patch b/media-sound/umurmur/files/umurmur-0.2.20-openssl3.patch
deleted file mode 100644
index ad7cc117787..00000000000
--- a/media-sound/umurmur/files/umurmur-0.2.20-openssl3.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- umurmur-0.2.20/src/ssli_openssl.c
-+++ umurmur-0.2.20/src/ssli_openssl.c
-@@ -142,8 +142,6 @@
-
- Log_info("Generating new server certificate.");
-
-- CRYPTO_mem_ctrl(CRYPTO_MEM_CHECK_ON);
--
- x509 = X509_new();
- if (!x509)
- goto err_out;
diff --git a/media-sound/umurmur/files/umurmur.conf b/media-sound/umurmur/files/umurmur.conf
deleted file mode 100644
index cebcca28a58..00000000000
--- a/media-sound/umurmur/files/umurmur.conf
+++ /dev/null
@@ -1,58 +0,0 @@
-# This configuration is based on the official example configuration. More information can be found
-# at http://code.google.com/p/umurmur/wiki/Configuring02x
-
-max_bandwidth = 48000;
-welcometext = "Welcome to uMurmur!";
-certificate = "/etc/umurmur/cert.crt";
-private_key = "/etc/umurmur/key.key";
-password = "";
-max_users = 10;
-
-# Specify port and/or address to bind to. Typically not needed.
-# Default is '*' for address and 64738 for port.
-# Can also be specified on the command line, which takes precedence if
-# both are specified.
-# bindport = 64738;
-# bindaddr = "192.168.1.1";
-
-# Specify this for privilege dropping. If username is specified but not
-# the groupname, the user's login group is used.
-username = "murmur";
-groupname = "murmur";
-
-# Root channel must always be defined first.
-# If a channel has a parent, the parent must be defined before the child channel(s).
-channels = ( {
- name = "Root";
- parent = "";
- description = "The Root of all channels";
- noenter = true;
- },
- {
- name = "Lobby";
- parent = "Root";
- description = "Lobby channel";
- },
- {
- name = "Red team";
- parent = "Lobby";
- description = "The Red team channel";
- },
- {
- name = "Blue team";
- parent = "Lobby";
- description = "The Blue team channel";
- }
-);
-# Channel links configuration.
-channel_links = ( {
- source = "Lobby";
- destination = "Red team";
- },
- {
- source = "Lobby";
- destination = "Blue team";
- }
-);
-
-default_channel = "Lobby";
diff --git a/media-sound/umurmur/files/umurmurd.confd b/media-sound/umurmur/files/umurmurd.confd
deleted file mode 100644
index d83461ce725..00000000000
--- a/media-sound/umurmur/files/umurmurd.confd
+++ /dev/null
@@ -1,3 +0,0 @@
-# Additional flags to be passed to umurmurd
-UMURMURD_OPTS="-r"
-
diff --git a/media-sound/umurmur/files/umurmurd.initd b/media-sound/umurmur/files/umurmurd.initd
deleted file mode 100644
index d0dd5517d62..00000000000
--- a/media-sound/umurmur/files/umurmurd.initd
+++ /dev/null
@@ -1,18 +0,0 @@
-#!/sbin/openrc-run
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-description="umurmurd - A minimalistic mumble server"
-pidfile="/run/umurmurd/umurmurd.pid"
-command="/usr/bin/umurmurd"
-command_args="-c /etc/umurmur/umurmur.conf -p ${pidfile} ${UMURMURD_OPTS}"
-start_stop_daemon_args="-p ${pidfile} -w 100"
-
-depend() {
- need net
- use logger
-}
-
-start_pre() {
- checkpath -d -o murmur ${pidfile%/*}
-}
diff --git a/media-sound/umurmur/files/umurmurd.service b/media-sound/umurmur/files/umurmurd.service
deleted file mode 100644
index 12ad2aec645..00000000000
--- a/media-sound/umurmur/files/umurmurd.service
+++ /dev/null
@@ -1,15 +0,0 @@
-[Unit]
-Description=A minimalistic Mumble server
-After=network.target
-
-[Service]
-Type=simple
-User=murmur
-Group=murmur
-PIDFile=/run/umurmurd.pid
-ExecStartPre=/usr/bin/umurmurd -t -c /etc/umurmur/umurmur.conf
-ExecStart=/usr/bin/umurmurd -d -r -p /run/umurmurd.pid -c /etc/umurmur/umurmur.conf
-ExecReload=/bin/kill -HUP $MAINPID
-
-[Install]
-WantedBy=multi-user.target
diff --git a/media-sound/umurmur/metadata.xml b/media-sound/umurmur/metadata.xml
deleted file mode 100644
index e08ea71f643..00000000000
--- a/media-sound/umurmur/metadata.xml
+++ /dev/null
@@ -1,29 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="person">
- <email>polynomial-c@gentoo.org</email>
- <name>Lars Wendler</name>
- </maintainer>
- <longdescription lang="en">
- uMurmur is a minimalistic Mumble server primarily targeted to
- run on routers with an open OS like OpenWRT. The server part
- of Mumble is called Murmur, hence the name uMurmur.
- </longdescription>
- <use>
- <flag name="mbedtls">Use <pkg>net-libs/mbedtls</pkg> as TLS provider</flag>
- <flag name="shm">Enable shared memory support</flag>
- </use>
- <upstream>
- <maintainer status="active">
- <email>fatbob.snack@gmail.com</email>
- <name>Martin Johansson</name>
- </maintainer>
- <bugs-to>https://code.google.com/p/umurmur/issues/list</bugs-to>
- <changelog>
- https://code.google.com/p/umurmur/wiki/Changelog</changelog>
- <doc lang="en">https://code.google.com/p/umurmur/w/list</doc>
- <remote-id type="google-code">umurmur</remote-id>
- <remote-id type="github">umurmur/umurmur</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/media-sound/umurmur/umurmur-0.2.17-r4.ebuild b/media-sound/umurmur/umurmur-0.2.17-r4.ebuild
deleted file mode 100644
index a840c65de76..00000000000
--- a/media-sound/umurmur/umurmur-0.2.17-r4.ebuild
+++ /dev/null
@@ -1,111 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit autotools systemd readme.gentoo-r1
-
-DESCRIPTION="Minimalistic Murmur (Mumble server)"
-HOMEPAGE="https://github.com/umurmur/umurmur"
-if [[ "${PV}" == 9999 ]] ; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/umurmur/umurmur.git"
-else
- SRC_URI="https://github.com/${PN}/${PN}/archive/${PV/_}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="amd64 ~arm x86"
-fi
-LICENSE="BSD"
-SLOT="0"
-IUSE="gnutls mbedtls shm"
-
-# ssl-provider precendence: gnutls, mbedtls
-# and openssl if none specified
-DEPEND=">=dev-libs/protobuf-c-1.0.0_rc2:=
- dev-libs/libconfig:=
- gnutls? (
- dev-libs/nettle:=
- >=net-libs/gnutls-3.0.0:=
- )
- !gnutls? (
- mbedtls? ( net-libs/mbedtls:= )
- !mbedtls? ( dev-libs/openssl:0= )
- )
-"
-
-RDEPEND="${DEPEND}
- acct-group/murmur
- acct-user/murmur
-"
-
-DOC_CONTENTS="
- A configuration file has been installed at /etc/umurmur/umurmur.conf - you
- may want to review it. See also\n
- https://github.com/umurmur/umurmur/wiki/Configuration "
-
-S="${WORKDIR}/${P/_}"
-
-get_ssl_impl() {
- local ssl_provider=()
-
- use gnutls && ssl_provider+=( gnutls )
- use mbedtls && ssl_provider+=( mbedtls )
-
- if ! use gnutls && ! use mbedtls; then
- ssl_provider+=( openssl )
- fi
- echo ${ssl_provider[@]}
-}
-
-pkg_pretend() {
- local ssl_provider=( $(get_ssl_impl) )
-
- if [[ ${#ssl_provider[@]} -gt 1 ]] ; then
- ewarn "More than one ssl provider selected (${ssl_provider[@]})"
- ewarn "defaulting to ${ssl_provider[0]}."
- fi
-}
-
-src_prepare() {
- default
- eautoreconf
-}
-
-src_configure() {
- local ssl_provider=( $(get_ssl_impl) )
-
- local myeconfargs=(
- --with-ssl="${ssl_provider[@]}"
- $(use_enable shm shmapi)
- )
- econf "${myeconfargs[@]}"
-}
-
-src_install() {
- local confdir
-
- emake DESTDIR="${D}" install
-
- newinitd "${FILESDIR}"/umurmurd.initd umurmurd
- newconfd "${FILESDIR}"/umurmurd.confd umurmurd
- systemd_dounit "${FILESDIR}"/umurmurd.service
-
- dodoc AUTHORS ChangeLog
- newdoc README.md README
-
- confdir="/etc/umurmur"
- insinto "${confdir}"
- doins "${FILESDIR}"/umurmur.conf
-
- # Some permissions are adjusted as the config may contain a server
- # password, and /etc/umurmur will typically contain the cert and the
- # key used to sign it, which are read after priveleges are dropped.
- fperms 0750 "${confdir}"
- fowners -R root:murmur "${confdir}"
- fperms 0640 "${confdir}"/umurmur.conf
-
- readme.gentoo_create_doc
-}
-
-pkg_postinst() {
- readme.gentoo_print_elog
-}
diff --git a/media-sound/umurmur/umurmur-0.2.19.ebuild b/media-sound/umurmur/umurmur-0.2.19.ebuild
deleted file mode 100644
index ca21485b1db..00000000000
--- a/media-sound/umurmur/umurmur-0.2.19.ebuild
+++ /dev/null
@@ -1,110 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit autotools systemd readme.gentoo-r1
-
-DESCRIPTION="Minimalistic Murmur (Mumble server)"
-HOMEPAGE="https://github.com/umurmur/umurmur"
-if [[ "${PV}" == *9999 ]] ; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/umurmur/umurmur.git"
-else
- SRC_URI="https://github.com/${PN}/${PN}/archive/${PV/_}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~arm ~x86"
-fi
-LICENSE="BSD"
-SLOT="0"
-IUSE="gnutls mbedtls shm"
-
-# ssl-provider precendence: gnutls, mbedtls and openssl if none specified
-DEPEND=">=dev-libs/protobuf-c-1.0.0_rc2:=
- dev-libs/libconfig:=
- gnutls? (
- dev-libs/nettle:=
- >=net-libs/gnutls-3.0.0:=
- )
- !gnutls? (
- mbedtls? ( net-libs/mbedtls:= )
- !mbedtls? ( dev-libs/openssl:0= )
- )
-"
-
-RDEPEND="${DEPEND}
- acct-group/murmur
- acct-user/murmur
-"
-
-DOC_CONTENTS="
- A configuration file has been installed at /etc/umurmur/umurmur.conf - you
- may want to review it. See also\n
- https://github.com/umurmur/umurmur/wiki/Configuration "
-
-S="${WORKDIR}/${P/_}"
-
-get_ssl_impl() {
- local ssl_provider=()
-
- use gnutls && ssl_provider+=( gnutls )
- use mbedtls && ssl_provider+=( mbedtls )
-
- if ! use gnutls && ! use mbedtls ; then
- ssl_provider+=( openssl )
- fi
- echo ${ssl_provider[@]}
-}
-
-pkg_pretend() {
- local ssl_provider=( $(get_ssl_impl) )
-
- if [[ ${#ssl_provider[@]} -gt 1 ]] ; then
- ewarn "More than one ssl provider selected (${ssl_provider[@]})"
- ewarn "defaulting to ${ssl_provider[0]}."
- fi
-}
-
-src_prepare() {
- default
- eautoreconf
-}
-
-src_configure() {
- local ssl_provider=( $(get_ssl_impl) )
-
- local myeconfargs=(
- --with-ssl="${ssl_provider[0]}"
- $(use_enable shm shmapi)
- )
- econf "${myeconfargs[@]}"
-}
-
-src_install() {
- local confdir
-
- emake DESTDIR="${D}" install
-
- newinitd "${FILESDIR}"/umurmurd.initd umurmurd
- newconfd "${FILESDIR}"/umurmurd.confd umurmurd
- systemd_dounit "${FILESDIR}"/umurmurd.service
-
- dodoc AUTHORS ChangeLog
- newdoc README.md README
-
- confdir="/etc/umurmur"
- insinto "${confdir}"
- doins "${FILESDIR}"/umurmur.conf
-
- # Some permissions are adjusted as the config may contain a server
- # password, and /etc/umurmur will typically contain the cert and the
- # key used to sign it, which are read after priveleges are dropped.
- fperms 0750 "${confdir}"
- fowners -R root:murmur "${confdir}"
- fperms 0640 "${confdir}"/umurmur.conf
-
- readme.gentoo_create_doc
-}
-
-pkg_postinst() {
- readme.gentoo_print_elog
-}
diff --git a/media-sound/umurmur/umurmur-0.2.20.ebuild b/media-sound/umurmur/umurmur-0.2.20.ebuild
deleted file mode 100644
index 677e6fa4f97..00000000000
--- a/media-sound/umurmur/umurmur-0.2.20.ebuild
+++ /dev/null
@@ -1,114 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit autotools systemd readme.gentoo-r1
-
-DESCRIPTION="Minimalistic Murmur (Mumble server)"
-HOMEPAGE="https://github.com/umurmur/umurmur"
-if [[ "${PV}" == *9999 ]] ; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/umurmur/umurmur.git"
-else
- SRC_URI="https://github.com/${PN}/${PN}/archive/${PV/_}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~arm ~x86"
-fi
-LICENSE="BSD"
-SLOT="0"
-IUSE="gnutls mbedtls shm"
-
-# ssl-provider precendence: gnutls, mbedtls and openssl if none specified
-DEPEND=">=dev-libs/protobuf-c-1.0.0_rc2:=
- dev-libs/libconfig:=
- gnutls? (
- dev-libs/nettle:=
- >=net-libs/gnutls-3.0.0:=
- )
- !gnutls? (
- mbedtls? ( net-libs/mbedtls:= )
- !mbedtls? ( dev-libs/openssl:0= )
- )
-"
-
-RDEPEND="${DEPEND}
- acct-group/murmur
- acct-user/murmur
-"
-
-DOC_CONTENTS="
- A configuration file has been installed at /etc/umurmur/umurmur.conf - you
- may want to review it. See also\n
- https://github.com/umurmur/umurmur/wiki/Configuration "
-
-PATCHES=(
- "${FILESDIR}/${PN}-0.2.20-openssl3.patch" #806154
-)
-
-S="${WORKDIR}/${P/_}"
-
-get_ssl_impl() {
- local ssl_provider=()
-
- use gnutls && ssl_provider+=( gnutls )
- use mbedtls && ssl_provider+=( mbedtls )
-
- if ! use gnutls && ! use mbedtls ; then
- ssl_provider+=( openssl )
- fi
- echo ${ssl_provider[@]}
-}
-
-pkg_pretend() {
- local ssl_provider=( $(get_ssl_impl) )
-
- if [[ ${#ssl_provider[@]} -gt 1 ]] ; then
- ewarn "More than one ssl provider selected (${ssl_provider[@]})"
- ewarn "defaulting to ${ssl_provider[0]}."
- fi
-}
-
-src_prepare() {
- default
- eautoreconf
-}
-
-src_configure() {
- local ssl_provider=( $(get_ssl_impl) )
-
- local myeconfargs=(
- --with-ssl="${ssl_provider[0]}"
- $(use_enable shm shmapi)
- )
- econf "${myeconfargs[@]}"
-}
-
-src_install() {
- local confdir
-
- emake DESTDIR="${D}" install
-
- newinitd "${FILESDIR}"/umurmurd.initd umurmurd
- newconfd "${FILESDIR}"/umurmurd.confd umurmurd
- systemd_dounit "${FILESDIR}"/umurmurd.service
-
- dodoc AUTHORS ChangeLog
- newdoc README.md README
-
- confdir="/etc/umurmur"
- insinto "${confdir}"
- doins "${FILESDIR}"/umurmur.conf
-
- # Some permissions are adjusted as the config may contain a server
- # password, and /etc/umurmur will typically contain the cert and the
- # key used to sign it, which are read after priveleges are dropped.
- fperms 0750 "${confdir}"
- fowners -R root:murmur "${confdir}"
- fperms 0640 "${confdir}"/umurmur.conf
-
- readme.gentoo_create_doc
-}
-
-pkg_postinst() {
- readme.gentoo_print_elog
-}
diff --git a/media-sound/umurmur/umurmur-9999.ebuild b/media-sound/umurmur/umurmur-9999.ebuild
deleted file mode 100644
index ca21485b1db..00000000000
--- a/media-sound/umurmur/umurmur-9999.ebuild
+++ /dev/null
@@ -1,110 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit autotools systemd readme.gentoo-r1
-
-DESCRIPTION="Minimalistic Murmur (Mumble server)"
-HOMEPAGE="https://github.com/umurmur/umurmur"
-if [[ "${PV}" == *9999 ]] ; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/umurmur/umurmur.git"
-else
- SRC_URI="https://github.com/${PN}/${PN}/archive/${PV/_}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~arm ~x86"
-fi
-LICENSE="BSD"
-SLOT="0"
-IUSE="gnutls mbedtls shm"
-
-# ssl-provider precendence: gnutls, mbedtls and openssl if none specified
-DEPEND=">=dev-libs/protobuf-c-1.0.0_rc2:=
- dev-libs/libconfig:=
- gnutls? (
- dev-libs/nettle:=
- >=net-libs/gnutls-3.0.0:=
- )
- !gnutls? (
- mbedtls? ( net-libs/mbedtls:= )
- !mbedtls? ( dev-libs/openssl:0= )
- )
-"
-
-RDEPEND="${DEPEND}
- acct-group/murmur
- acct-user/murmur
-"
-
-DOC_CONTENTS="
- A configuration file has been installed at /etc/umurmur/umurmur.conf - you
- may want to review it. See also\n
- https://github.com/umurmur/umurmur/wiki/Configuration "
-
-S="${WORKDIR}/${P/_}"
-
-get_ssl_impl() {
- local ssl_provider=()
-
- use gnutls && ssl_provider+=( gnutls )
- use mbedtls && ssl_provider+=( mbedtls )
-
- if ! use gnutls && ! use mbedtls ; then
- ssl_provider+=( openssl )
- fi
- echo ${ssl_provider[@]}
-}
-
-pkg_pretend() {
- local ssl_provider=( $(get_ssl_impl) )
-
- if [[ ${#ssl_provider[@]} -gt 1 ]] ; then
- ewarn "More than one ssl provider selected (${ssl_provider[@]})"
- ewarn "defaulting to ${ssl_provider[0]}."
- fi
-}
-
-src_prepare() {
- default
- eautoreconf
-}
-
-src_configure() {
- local ssl_provider=( $(get_ssl_impl) )
-
- local myeconfargs=(
- --with-ssl="${ssl_provider[0]}"
- $(use_enable shm shmapi)
- )
- econf "${myeconfargs[@]}"
-}
-
-src_install() {
- local confdir
-
- emake DESTDIR="${D}" install
-
- newinitd "${FILESDIR}"/umurmurd.initd umurmurd
- newconfd "${FILESDIR}"/umurmurd.confd umurmurd
- systemd_dounit "${FILESDIR}"/umurmurd.service
-
- dodoc AUTHORS ChangeLog
- newdoc README.md README
-
- confdir="/etc/umurmur"
- insinto "${confdir}"
- doins "${FILESDIR}"/umurmur.conf
-
- # Some permissions are adjusted as the config may contain a server
- # password, and /etc/umurmur will typically contain the cert and the
- # key used to sign it, which are read after priveleges are dropped.
- fperms 0750 "${confdir}"
- fowners -R root:murmur "${confdir}"
- fperms 0640 "${confdir}"/umurmur.conf
-
- readme.gentoo_create_doc
-}
-
-pkg_postinst() {
- readme.gentoo_print_elog
-}
diff --git a/media-sound/upmpdcli/Manifest b/media-sound/upmpdcli/Manifest
index af9f90d165f..ecf738f256e 100644
--- a/media-sound/upmpdcli/Manifest
+++ b/media-sound/upmpdcli/Manifest
@@ -1,2 +1,2 @@
-DIST upmpdcli-1.5.13.tar.gz 579569 BLAKE2B 30af7f455c0564e46c627217853a230bdabd0209baaa62b247388814af8005ecd0125de242c98cc20bef28adc548b5e83fa61d797535daa00cf180cad0fe0217 SHA512 bf61f7befe5fd64cdeed94f7d82965991d95abf8f8f96b044934d64aa55c887b7f4cdbc48f72a4843a5b6a145d9ccae6166e38710ce2015ccba18ac13c365ac6
DIST upmpdcli-1.5.17.tar.gz 585821 BLAKE2B dfd47d710751540743f5df38975e2775ac99355781c7d7bf8b50543148bc22aa85f4f851a5628291f11474342caec99ecfa664cd701fbe13c46be1d56cc6b042 SHA512 caaba9d6ee8564e9464f19c9462e2fe4ed917270a9a66a9608895ddc8e060cefa339749ffc284d83a05be78571241e1c0ee74c4b0058bda8c5b1d8ebbaf248a1
+DIST upmpdcli-1.5.19.tar.gz 586888 BLAKE2B 1784d41dd09b8bee93e9bd8c650480f48cee8324a0cae85068bb628cb748b223f20a37608369b085c154327569203421d476ad5e6bc1a044fa5d5ad920e2a768 SHA512 517fae799e0d400268f968ea7983b1cb7e22759ad7a0b9fe194a5bbfbb2db16ea26a233cb1784fae6d7e3b8f28ff3443a8f8ab3e447719d05e48be36b49ded08
diff --git a/media-sound/upmpdcli/upmpdcli-1.5.17.ebuild b/media-sound/upmpdcli/upmpdcli-1.5.17.ebuild
index 61ec5aab1fe..c7e369caaab 100644
--- a/media-sound/upmpdcli/upmpdcli-1.5.17.ebuild
+++ b/media-sound/upmpdcli/upmpdcli-1.5.17.ebuild
@@ -11,7 +11,7 @@ LICENSE="GPL-2"
SRC_URI="https://www.lesbonscomptes.com/upmpdcli/downloads/${P}.tar.gz"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="amd64 x86"
IUSE="thirdparty"
DEPEND="
@@ -28,6 +28,21 @@ RDEPEND="
thirdparty? ( dev-python/requests )
"
+src_configure() {
+
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var/lib \
+ --disable-dependency-tracking \
+ --disable-silent-rules \
+ "--docdir=/usr/share/doc/${P}" \
+ "--htmldir=/usr/share/doc/${P}/html" \
+ --libdir=/usr/lib64 \
+ || die "Configure failed"
+
+}
+
src_install() {
default
newinitd "${FILESDIR}/${PN}.initd" "${PN}"
diff --git a/media-sound/upmpdcli/upmpdcli-1.5.13.ebuild b/media-sound/upmpdcli/upmpdcli-1.5.19.ebuild
index d5b5585b951..68874e5bd6e 100644
--- a/media-sound/upmpdcli/upmpdcli-1.5.13.ebuild
+++ b/media-sound/upmpdcli/upmpdcli-1.5.19.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -11,7 +11,7 @@ LICENSE="GPL-2"
SRC_URI="https://www.lesbonscomptes.com/upmpdcli/downloads/${P}.tar.gz"
SLOT="0"
-KEYWORDS="amd64 x86"
+KEYWORDS="~amd64 ~x86"
IUSE="thirdparty"
DEPEND="
@@ -28,6 +28,21 @@ RDEPEND="
thirdparty? ( dev-python/requests )
"
+src_configure() {
+
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var/lib \
+ --disable-dependency-tracking \
+ --disable-silent-rules \
+ "--docdir=/usr/share/doc/${P}" \
+ "--htmldir=/usr/share/doc/${P}/html" \
+ --libdir=/usr/lib64 \
+ || die "Configure failed"
+
+}
+
src_install() {
default
newinitd "${FILESDIR}/${PN}.initd" "${PN}"
diff --git a/media-sound/vorbisgain/files/vorbisgain-0.37-wformat-security.patch b/media-sound/vorbisgain/files/vorbisgain-0.37-wformat-security.patch
new file mode 100644
index 00000000000..eecf45675fa
--- /dev/null
+++ b/media-sound/vorbisgain/files/vorbisgain-0.37-wformat-security.patch
@@ -0,0 +1,13 @@
+https://bugs.gentoo.org/634994
+--- a/misc.c
++++ b/misc.c
+@@ -57,8 +57,7 @@
+ vfprintf(stderr, message, args);
+ va_end(args);
+
+- fprintf(stderr, strerror(err_num));
+- fprintf(stderr, "\n");
++ fprintf(stderr, "%s\n", strerror(err_num));
+ }
+
+
diff --git a/media-sound/vorbisgain/vorbisgain-0.37-r3.ebuild b/media-sound/vorbisgain/vorbisgain-0.37-r4.ebuild
index 0757e73f9d6..885e785ad58 100644
--- a/media-sound/vorbisgain/vorbisgain-0.37-r3.ebuild
+++ b/media-sound/vorbisgain/vorbisgain-0.37-r4.ebuild
@@ -19,6 +19,8 @@ DEPEND="${RDEPEND}"
PATCHES=(
# bug 200931
"${FILESDIR}"/${P}-fix-errno-and-warnings.patch
+ # bug 634994
+ "${FILESDIR}"/${P}-wformat-security.patch
)
src_configure() {
diff --git a/media-sound/wavpack/Manifest b/media-sound/wavpack/Manifest
index 8b255329468..5f64c0b6e3e 100644
--- a/media-sound/wavpack/Manifest
+++ b/media-sound/wavpack/Manifest
@@ -1 +1 @@
-DIST wavpack-5.4.0.tar.xz 769764 BLAKE2B d35eefccf3402388d88d370daae41dc0e4f21808474e668f92a9dcee978ae71b96ae167de098a0924fcbaaa75f9b07270280e7c3b16cc8699ffaa7d2eddd0de5 SHA512 de4e75539c9b949d22f39ab73721c8a4ee7c38ff08835aa28b1d56bea08c332bcb601a54998efe520f3653a2e29c73dcfd716ad19707bb2815403786d9ed9c11
+DIST wavpack-5.5.0.tar.xz 797996 BLAKE2B e2a00052ce887c4ac4e767a1852f0b94c7d23071f5974cb15f33700acaf5b6ae9e5e08a7dee8c66520d2178a4f9e3cc2139da78f040803d55d504b949000c8c9 SHA512 9758e8079618e45e585330cd472f8ddae6e0ffd9a79032e7ec60251fff331390a619855dcdcf92942f5192d6ae12e05b6feca36394d30f0fe7e65222ee2696fc
diff --git a/media-sound/wavpack/wavpack-5.4.0.ebuild b/media-sound/wavpack/wavpack-5.5.0.ebuild
index 7734a214570..ce7f2196be2 100644
--- a/media-sound/wavpack/wavpack-5.4.0.ebuild
+++ b/media-sound/wavpack/wavpack-5.5.0.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit multilib-minimal
@@ -12,22 +12,12 @@ SRC_URI="https://github.com/dbry/WavPack/releases/download/${PV}/${P}.tar.xz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~mips ppc ppc64 ~riscv sparc x86 ~amd64-linux ~x86-linux ~x86-solaris"
-IUSE="test"
-RESTRICT="!test? ( test )"
RDEPEND=">=virtual/libiconv-0-r1"
DEPEND="${RDEPEND}"
multilib_src_configure() {
- ECONF_SOURCE="${S}" econf \
- --disable-static \
- $(use_enable test tests) \
- $(multilib_native_enable apps)
-}
-
-multilib_src_test() {
- emake -C cli wvtest
- cli/wvtest --default || die
+ ECONF_SOURCE="${S}" econf $(multilib_native_enable apps)
}
multilib_src_install_all() {
diff --git a/media-sound/whipper/whipper-0.10.0.ebuild b/media-sound/whipper/whipper-0.10.0.ebuild
index 4ec1758f78e..1049adc8eaa 100644
--- a/media-sound/whipper/whipper-0.10.0.ebuild
+++ b/media-sound/whipper/whipper-0.10.0.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7,8,9} )
+PYTHON_COMPAT=( python3_{8,9,10} )
inherit distutils-r1
diff --git a/media-sound/xmms2/Manifest b/media-sound/xmms2/Manifest
index e49b5778f52..39e87419b57 100644
--- a/media-sound/xmms2/Manifest
+++ b/media-sound/xmms2/Manifest
@@ -1,4 +1 @@
-DIST waf-2.0.22.tar.bz2 687244 BLAKE2B feea82e7e6aaba1187f368aa00025f206a7217196de9be7a97ca6aa8882823decd79db38dda4f1f25e81541eaa44edf029eea8d57e28f7d31b94d9ee93201ea9 SHA512 a3a275fd4c81c7b7385c2da001f3924d272105b8f33839265ebbb38708051b7cb13b9b9019e84325707d04513de0c13b032b1ad21458aec6586d10df4ed8d5f5
-DIST xmms2-0.8_p20201016.tar.gz 1720185 BLAKE2B e1cad8ed2ece9d8ce905ffe86de53bb4010639d83fd15700eefccf190034577ff8666f3557bfb23741ed8400eba1e6246ef28ff21c4dbbe499239da945befc74 SHA512 0e73771f56c341e5dea15451457426958217de3ac19cad1924c11740f96feb69e385242a27a9cf9258841ed4e6538c12e135492f715bfae6976b31fb358508bf
DIST xmms2-0.9.1.tar.bz2 1940773 BLAKE2B 4044499c2ffc55e66d5836e2e36360486b970ff05f0dc17b62e65111c06cfcc84f58c74427b1afa4455b4e0bdb7784dc8840cc84411bc57cb7b9f0cac4e46359 SHA512 a7d42202571d7eb5d9da4c9f5d55d2f6e072df52892080d6cc4349f66a55f5fece510c9872be9814dd5b258d0c59e2704ea8497c2d3be515c510d602c17b703a
-DIST xmms2-s4-0.8_p20201016.tar.gz 184231 BLAKE2B 0676f89b743e265af01593c215c609ae48ea368d861fd28b022b4124a00852182686a46ebf90ac44a10343f86ba5c398c47fd85e2688971b2b4445f3c3843af5 SHA512 f510141ca792893feba2c00d9bc437f492fdce7c29b12c9a8432792ca5a1703cc7068e1a9f4641abd50b320fefb5867fb5bc58a58b0b0272cf75828c764f94ed
diff --git a/media-sound/xmms2/files/xmms2-0.8-rtvg.patch b/media-sound/xmms2/files/xmms2-0.8-rtvg.patch
deleted file mode 100644
index e0a970c9186..00000000000
--- a/media-sound/xmms2/files/xmms2-0.8-rtvg.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-Add knob to disable valgrind at test runtime.
-
-When valgrind is installed in system but is not
-working we should still be able to run tests.
-
-Bug: https://bugs.gentoo.org/424377
---- a/waftools/unittest.py
-+++ b/waftools/unittest.py
-@@ -64,7 +64,8 @@ def generate_coverage(bld):
-
- def configure(conf):
- conf.load("waf_unit_test")
-- conf.find_program("valgrind", var="VALGRIND", mandatory=False)
-+ if conf.options.enable_valgrind is True:
-+ conf.find_program("valgrind", var="VALGRIND", mandatory=False)
- conf.find_program("lcov", var="LCOV", mandatory=False)
- conf.find_program("genhtml", var="GENHTML", mandatory=False)
-
---- a/wscript
-+++ b/wscript
-@@ -501,6 +501,10 @@ def options(opt):
- dest='ldconfig', help="Run ldconfig after install even if not root")
- opt.add_option('--without-ldconfig', action='store_false',
- dest='ldconfig', help="Don't run ldconfig after install")
-+ opt.add_option('--with-valgrind', action='store_true', default=None,
-+ dest='enable_valgrind', help="Run testsuite under valgrind (if present).")
-+ opt.add_option('--without-valgrind', action='store_false', default=None,
-+ dest='enable_valgrind', help="Don't run testsuite under valgrind.")
-
- opt.sub_options("src/xmms")
- for o in optional_subdirs + subdirs:
diff --git a/media-sound/xmms2/files/xmms2-0.8_p20161122-cpp-client.patch b/media-sound/xmms2/files/xmms2-0.8_p20161122-cpp-client.patch
deleted file mode 100644
index df1d1c61657..00000000000
--- a/media-sound/xmms2/files/xmms2-0.8_p20161122-cpp-client.patch
+++ /dev/null
@@ -1,16 +0,0 @@
-https://github.com/xmms2/xmms2-devel/pull/5
-
-From: Sergei Trofimovich <slyfox@gentoo.org>
-Date: Thu, 6 Dec 2018 07:19:08 +0000
-Subject: [PATCH] OTHER: fix c++ client dangling reference
---- a/src/include/xmmsclient/xmmsclient++/mainloop.h
-+++ b/src/include/xmmsclient/xmmsclient++/mainloop.h
-@@ -41,7 +41,7 @@ namespace Xmms
- * @note The constructor should only initialize the
- * mainloop, not start it!
- */
-- MainloopInterface( xmmsc_connection_t* conn ) :
-+ MainloopInterface( xmmsc_connection_t*& conn ) :
- running_( false ), conn_( conn ) { }
-
- /** Destructor. Should also stop the loop.
diff --git a/media-sound/xmms2/files/xmms2-0.8_p20161122-faad.patch b/media-sound/xmms2/files/xmms2-0.8_p20161122-faad.patch
deleted file mode 100644
index 2a206b913fe..00000000000
--- a/media-sound/xmms2/files/xmms2-0.8_p20161122-faad.patch
+++ /dev/null
@@ -1,16 +0,0 @@
-This line has stopped working since security fixes in the faad 2.9.0
-release. XMMS2 upstream were informed via IRC but have yet to act on
-it. I've run XMMS2 with this patch for months without issue.
-
--- Chewi
-
---- a/src/plugins/faad/faad.c
-+++ b/src/plugins/faad/faad.c
-@@ -242,7 +242,6 @@ xmms_faad_init (xmms_xform_t *xform)
- * and durations calculations... So we cheat and tell libfaad2 we're feeding
- * it frame 1.
- */
-- NeAACDecPostSeekReset (data->decoder, 1);
-
- /* FIXME: Because for HE AAC files some versions of libfaad return the wrong
- * samplerate in init, we have to do one read and let it decide the real
diff --git a/media-sound/xmms2/files/xmms2-0.8_p20161122-mac-4.patch b/media-sound/xmms2/files/xmms2-0.8_p20161122-mac-4.patch
deleted file mode 100644
index 9785b4198d5..00000000000
--- a/media-sound/xmms2/files/xmms2-0.8_p20161122-mac-4.patch
+++ /dev/null
@@ -1,38 +0,0 @@
-https://github.com/xmms2/xmms2-devel/pull/2
-
-From: Jérôme Carretero <cJ@zougloub.eu>
-Date: Tue, 24 Oct 2017 18:43:26 -0400
-Subject: [PATCH] plugins: mac: support newer mac API version
---- a/src/plugins/mac/mac.cpp
-+++ b/src/plugins/mac/mac.cpp
-@@ -210,8 +210,12 @@ xmms_mac_get_media_info (xmms_xform_t *xform)
- gchar *name;
-
- field_name = pTagField->GetFieldName ();
-- name = (gchar *)GetUTF8FromUTF16 (field_name);
-
-+#if MAC_DLL_INTERFACE_VERSION_NUMBER >= 1000
-+ name = (gchar *)CAPECharacterHelper::GetUTF8FromUTF16 (field_name);
-+#else
-+ name = (gchar *)GetUTF8FromUTF16 (field_name);
-+#endif
- memset (field_value, 0, 255);
- int size = 255;
- p_ape_tag->GetFieldString (field_name, (char *)field_value, &size, TRUE);
---- a/src/plugins/mac/source_adapter.h
-+++ b/src/plugins/mac/source_adapter.h
-@@ -38,7 +38,13 @@ public:
- ~CSourceAdapter () {};
-
- // open / close
-- int Open (const wchar_t * pName) { return ERROR_SUCCESS; }
-+#if MAC_DLL_INTERFACE_VERSION_NUMBER >= 1000
-+ int Open (const wchar_t * pName, BOOL bOpenReadOnly = FALSE)
-+#else
-+ int Open (const wchar_t * pName)
-+#endif
-+ { return ERROR_SUCCESS; }
-+
- int Close () { return ERROR_SUCCESS; }
-
- // read / write
diff --git a/media-sound/xmms2/files/xmms2-0.8_p20201016-ffmpeg5.patch b/media-sound/xmms2/files/xmms2-0.8_p20201016-ffmpeg5.patch
deleted file mode 100644
index b338e57cdfc..00000000000
--- a/media-sound/xmms2/files/xmms2-0.8_p20201016-ffmpeg5.patch
+++ /dev/null
@@ -1,127 +0,0 @@
-Lazy migration from audio4 that's missing in ffmpeg5, may not be
-entirely right but tested to play at least .tta/.wma properly.
-
-https://github.com/xmms2/xmms2-devel/pull/11
-
-Bug: https://bugs.gentoo.org/834398
-Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
---- a/src/plugins/avcodec/avcodec.c
-+++ b/src/plugins/avcodec/avcodec.c
-@@ -32,4 +32,5 @@
- typedef struct {
- AVCodecContext *codecctx;
-+ AVPacket packet;
-
- guchar *buffer;
-@@ -150,4 +151,5 @@
- data->buffer_size = AVCODEC_BUFFER_SIZE;
- data->codecctx = NULL;
-+ data->packet.size = 0;
-
- data->read_out_frame = av_frame_alloc ();
-@@ -155,6 +157,4 @@
- xmms_xform_private_data_set (xform, data);
-
-- avcodec_register_all ();
--
- mimetype = xmms_xform_indata_get_str (xform,
- XMMS_STREAM_TYPE_MIMETYPE);
-@@ -467,43 +467,35 @@
- xmms_avcodec_internal_decode_some (xmms_avcodec_data_t *data)
- {
-- int got_frame = 0;
-- gint bytes_read = 0;
-- AVPacket packet;
-+ int rc = 0;
-
-- av_init_packet (&packet);
-- packet.data = data->buffer;
-- packet.size = data->buffer_length;
--
-- /* clear buffers and reset fields to defaults */
-- av_frame_unref (data->read_out_frame);
--
-- bytes_read = avcodec_decode_audio4 (
-- data->codecctx, data->read_out_frame, &got_frame, &packet);
--
-- /* The DTS decoder of ffmpeg is buggy and always returns
-- * the input buffer length, get frame length from header */
-- /* FIXME: Is ^^^^ still true? */
-- if (!strcmp (data->codec_id, "dca") && bytes_read > 0) {
-- bytes_read = ((int)data->buffer[5] << 12) |
-- ((int)data->buffer[6] << 4) |
-- ((int)data->buffer[7] >> 4);
-- bytes_read = (bytes_read & 0x3fff) + 1;
-+ if (data->packet.size == 0) {
-+ av_init_packet (&data->packet);
-+ data->packet.data = data->buffer;
-+ data->packet.size = data->buffer_length;
-+
-+ rc = avcodec_send_packet(data->codecctx, &data->packet);
-+ if (rc == AVERROR_EOF)
-+ rc = 0;
-+ }
-+
-+ if (rc == 0) {
-+ rc = avcodec_receive_frame(data->codecctx, data->read_out_frame);
-+ if (rc < 0) {
-+ data->packet.size = 0;
-+ data->buffer_length = 0;
-+ if (rc == AVERROR(EAGAIN)) rc = 0;
-+ else if (rc == AVERROR_EOF) rc = 1;
-+ }
-+ else
-+ rc = 1;
- }
-
-- if (bytes_read < 0 || bytes_read > data->buffer_length) {
-+ if (rc < 0) {
-+ data->packet.size = 0;
- XMMS_DBG ("Error decoding data!");
- return -1;
- }
-
-- if (bytes_read < data->buffer_length) {
-- data->buffer_length -= bytes_read;
-- g_memmove (data->buffer,
-- data->buffer + bytes_read,
-- data->buffer_length);
-- } else {
-- data->buffer_length = 0;
-- }
--
-- return got_frame ? 1 : 0;
-+ return rc;
- }
-
---- a/src/plugins/avcodec/wscript
-+++ b/src/plugins/avcodec/wscript
-@@ -2,5 +2,5 @@
-
- ## Code fragments for configuration
--avcodec_decode_audio4_fragment = """
-+avcodec_send_packet_fragment = """
- #ifdef HAVE_LIBAVCODEC_AVCODEC_H
- # include "libavcodec/avcodec.h"
-@@ -10,9 +10,7 @@
- int main(void) {
- AVCodecContext *ctx;
-- AVFrame *frame;
-- int got_frame;
- AVPacket *pkt;
-
-- avcodec_decode_audio4 (ctx, frame, &got_frame, pkt);
-+ avcodec_send_packet (ctx, pkt);
-
- return 0;
-@@ -44,7 +42,7 @@
- # * ffmpeg: commit e4de716, lavc 53.40.0, release 0.9
- # * libav: commit 0eea212, lavc 53.25.0, release 0.8
-- conf.check_cc(fragment=avcodec_decode_audio4_fragment, uselib="avcodec",
-- uselib_store="avcodec_decode_audio4",
-- msg="Checking for function avcodec_decode_audio4", mandatory=True)
-+ conf.check_cc(fragment=avcodec_send_packet_fragment, uselib="avcodec",
-+ uselib_store="avcodec_send_packet",
-+ msg="Checking for function avcodec_send_packet", mandatory=True)
-
- # non-mandatory function avcodec_free_frame since
diff --git a/media-sound/xmms2/xmms2-0.8_p20201016-r2.ebuild b/media-sound/xmms2/xmms2-0.8_p20201016-r2.ebuild
deleted file mode 100644
index 0edb6f31cd7..00000000000
--- a/media-sound/xmms2/xmms2-0.8_p20201016-r2.ebuild
+++ /dev/null
@@ -1,237 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} )
-inherit multiprocessing optfeature perl-functions python-single-r1 toolchain-funcs
-
-XMMS2_COMMIT="46da10f0e20c53fd2b40843617ed182c0cba4ebb"
-S4_COMMIT="652ac581df7a0bca04334da397f8bb4f86eb7b59"
-WAF_VER="2.0.22"
-
-DESCRIPTION="X(cross)platform Music Multiplexing System, next generation of the XMMS player"
-HOMEPAGE="https://github.com/XMMS2"
-SRC_URI="
- https://github.com/xmms2/xmms2-devel/archive/${XMMS2_COMMIT}.tar.gz -> ${P}.tar.gz
- https://github.com/xmms2/s4/archive/${S4_COMMIT}.tar.gz -> ${PN}-s4-${PV}.tar.gz
- https://waf.io/waf-${WAF_VER}.tar.bz2"
-S="${WORKDIR}/${PN}-devel-${XMMS2_COMMIT}"
-
-LICENSE="GPL-2+ LGPL-2.1+"
-SLOT="0"
-KEYWORDS="~alpha amd64 ~arm ppc ~riscv x86"
-
-# IUSE static map to be passed to --with-{optionals,plugins}=opt1,opt2,...
-# flag:opt = `usev flag opt`, opt = `usev opt`, :opt = `echo opt`
-XMMS2_OPTIONALS=(
- cxx:xmmsclient++,xmmsclient++-glib :launcher mlib-update:medialib-updater
- :nycli perl :pixmaps python server:s4 test:tests
- # disabled: et,mdns,migrate-collections,ruby,sqlite2s4,vistest,xmmsclient-cf,xmmsclient-ecore
-)
-XMMS2_PLUGINS=(
- aac:faad airplay alsa ao :asx cdda :cue curl :diskwrite :equalizer
- ffmpeg:apefile,asf,avcodec,flv,tta :file flac fluidsynth:fluidsynth,mid1,midsquash
- gme :html ices :icymetaint :id3v2 jack :karaoke :m3u mac +mad mms modplug
- mp3:mpg123 :mp4 musepack :normalize :null :nulstripper ofa opus oss :pls
- pulseaudio:pulse :replaygain samba sid sndfile speex tremor vocoder +vorbis
- :wave wavpack :xml xml:rss,xspf zeroconf:daap
- # disabled: coreaudio,gvfs,nms,sc68,sun,waveout
-)
-
-IUSE="
- ${XMMS2_OPTIONALS[@]%:*}
- ${XMMS2_PLUGINS[@]%:*}
- +server valgrind"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-RESTRICT="!test? ( test ) !server? ( test )"
-
-COMMON_DEPEND="
- dev-libs/glib:2
- sys-libs/readline:=
- server? (
- aac? ( media-libs/faad2 )
- airplay? ( dev-libs/openssl:= )
- alsa? ( media-libs/alsa-lib )
- ao? ( media-libs/libao )
- cdda? (
- dev-libs/libcdio-paranoia:=
- dev-libs/libcdio:=
- media-libs/libdiscid
- )
- curl? ( net-misc/curl )
- ffmpeg? ( media-video/ffmpeg:= )
- flac? ( media-libs/flac )
- fluidsynth? ( media-sound/fluidsynth:= )
- gme? ( media-libs/game-music-emu )
- ices? (
- media-libs/libogg
- media-libs/libshout
- media-libs/libvorbis
- )
- jack? ( virtual/jack )
- mac? ( media-sound/mac )
- mad? ( media-libs/libmad )
- mms? (
- media-libs/libmms
- media-video/ffmpeg:=
- )
- modplug? ( media-libs/libmodplug )
- mp3? ( media-sound/mpg123 )
- musepack? ( media-sound/musepack-tools )
- ofa? (
- dev-libs/expat
- media-libs/libofa
- sci-libs/fftw:3.0=
- )
- opus? (
- media-libs/libogg
- media-libs/opus
- media-libs/opusfile
- )
- pulseaudio? ( media-sound/pulseaudio )
- samba? ( net-fs/samba )
- sid? ( media-libs/libsidplay:2 )
- sndfile? ( media-libs/libsndfile )
- speex? (
- media-libs/libogg
- media-libs/speex
- )
- tremor? ( media-libs/tremor )
- vocoder? (
- media-libs/libsamplerate
- sci-libs/fftw:3.0=
- )
- vorbis? ( media-libs/libvorbis )
- wavpack? ( media-sound/wavpack )
- xml? ( dev-libs/libxml2 )
- zeroconf? (
- net-dns/avahi[mdnsresponder-compat]
- net-misc/curl
- )
- )
- python? ( virtual/libcrypt:= )"
-RDEPEND="
- ${COMMON_DEPEND}
- perl? (
- dev-lang/perl
- dev-perl/glib-perl
- virtual/perl-Carp
- virtual/perl-IO
- virtual/perl-Scalar-List-Utils
- )
- python? (
- ${PYTHON_DEPS}
- $(python_gen_cond_dep 'dev-python/pygobject[${PYTHON_USEDEP}]')
- )"
-DEPEND="
- ${COMMON_DEPEND}
- cxx? ( dev-libs/boost )
- test? ( dev-util/cunit )"
-BDEPEND="
- ${PYTHON_DEPS}
- virtual/pkgconfig
- perl? ( dev-perl/Pod-Parser )
- python? ( $(python_gen_cond_dep 'dev-python/cython[${PYTHON_USEDEP}]') )
- test? ( valgrind? ( dev-util/valgrind ) )"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-0.8-rtvg.patch
- "${FILESDIR}"/${PN}-0.8_p20161122-mac-4.patch
- "${FILESDIR}"/${PN}-0.8_p20161122-cpp-client.patch
- "${FILESDIR}"/${PN}-0.8_p20161122-faad.patch
- "${FILESDIR}"/${P}-ffmpeg5.patch
-)
-
-src_prepare() {
- rmdir src/lib/s4 && mv ../s4-${S4_COMMIT} src/lib/s4 || die
- mv ../waf-${WAF_VER}/waf{,lib} . || die
-
- default
-
- sed -e "s|/path/to/.*sf2|${EPREFIX}/usr/share/sounds/sf2/FluidR3_GM.sf2|" \
- -i src/plugins/fluidsynth/fluidsynth.c || die
-}
-
-src_configure() {
- local waf=(
- ./waf configure
- --prefix="${EPREFIX}"/usr
- --libdir="${EPREFIX}"/usr/$(get_libdir)
- --boost-includes="${ESYSROOT}"/usr/include # needed for prefix
- --with-custom-version="%(version)s (git commit: ${XMMS2_COMMIT:0:8})"
- --with-target-platform="${CHOST}"
- )
-
- xmms2_flag() {
- local IFS=:
- set -- ${1#+}
-
- if [[ ${1} ]]; then
- usev ${1} ,${2:-${1}}
- else
- echo ,${2}
- fi
- }
-
- local flag optionals plugins
-
- if use server; then
- for flag in "${XMMS2_PLUGINS[@]}"; do
- plugins+=$(xmms2_flag ${flag})
- done
- else
- waf+=( --without-xmms2d )
- fi
-
- for flag in "${XMMS2_OPTIONALS[@]}"; do
- optionals+=$(xmms2_flag ${flag})
- done
-
- waf+=(
- # pass even if empty to avoid automagic
- --with-optionals=${optionals:1}
- --with-plugins=${plugins:1}
- )
-
- if use perl; then
- perl_set_version
- waf+=( --with-perl-archdir="${ARCH_LIB}" )
- fi
-
- if use valgrind; then
- if valgrind true &>/dev/null; then
- waf+=( --with-valgrind )
- else
- ewarn "valgrind was disabled due to failing a basic sanity check" #807271
- fi
- fi
-
- tc-export AR CC CXX
-
- echo "${waf[*]}"
- "${waf[@]}" || die
-}
-
-src_compile() {
- ./waf build -j$(makeopts_jobs) --verbose --notests || die
-}
-
-src_test() {
- ./waf --alltests || die
-}
-
-src_install() {
- ./waf install --destdir="${D}" --without-ldconfig --notests || die
-
- einstalldocs
-
- use python && python_optimize
-
- # to avoid editing waftools/man.py (use find given not always installed)
- find "${ED}" -name '*.gz' -exec gzip -d {} + || die
-}
-
-pkg_postinst() {
- use fluidsynth && optfeature "the default MIDI soundfont" media-sound/fluid-soundfont
-}
diff --git a/media-sound/xmms2/xmms2-0.9.1.ebuild b/media-sound/xmms2/xmms2-0.9.1.ebuild
index 3352a282436..64355359cdb 100644
--- a/media-sound/xmms2/xmms2-0.9.1.ebuild
+++ b/media-sound/xmms2/xmms2-0.9.1.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_COMPAT=( python3_{8..11} )
inherit multiprocessing optfeature perl-functions python-single-r1 toolchain-funcs
DESCRIPTION="X(cross)platform Music Multiplexing System, next generation of the XMMS player"
@@ -12,7 +12,7 @@ SRC_URI="https://github.com/xmms2/xmms2-devel/releases/download/${PV}/${P}.tar.b
LICENSE="GPL-2+ LGPL-2.1+"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~ppc ~riscv ~x86"
+KEYWORDS="~alpha amd64 ~arm ppc ~riscv x86"
# IUSE static map to be passed to --with-{optionals,plugins}=opt1,opt2,...
# flag:opt = `usev flag opt`, opt = `usev opt`, :opt = `echo opt`
diff --git a/media-sound/yarock/yarock-1.4.0-r2.ebuild b/media-sound/yarock/yarock-1.4.0-r3.ebuild
index c7f4cd5e45b..27aac662b7d 100644
--- a/media-sound/yarock/yarock-1.4.0-r2.ebuild
+++ b/media-sound/yarock/yarock-1.4.0-r3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -7,7 +7,7 @@ MY_P="Yarock_${PV}_Sources"
inherit cmake
DESCRIPTION="Qt-based music player"
-HOMEPAGE="https://seb-apps.github.io/yarock/"
+HOMEPAGE="https://code.launchpad.net/yarock"
SRC_URI="https://launchpad.net/${PN}/1.x/${PV}/+download/${MY_P}.tar.gz"
S="${WORKDIR}/${MY_P}"
@@ -27,7 +27,7 @@ RDEPEND="
dev-qt/qtxml:5
media-libs/taglib
x11-libs/libX11
- mpv? ( media-video/mpv:= )
+ mpv? ( media-video/mpv:=[libmpv] )
phonon? ( >=media-libs/phonon-4.11.0 )
vlc? ( media-video/vlc:= )
"
diff --git a/media-sound/yoshimi/Manifest b/media-sound/yoshimi/Manifest
index c6b5c2d0342..4f2b2443d64 100644
--- a/media-sound/yoshimi/Manifest
+++ b/media-sound/yoshimi/Manifest
@@ -1,2 +1,2 @@
-DIST yoshimi-2.1.2.2.tar.gz 7641720 BLAKE2B 45da49df7bea0919d08f66fa37ddf21483ac3074aa7fcb57f1a55137ab9f29545dc2121041b7c0fb33d86cffa0608a5fda5a963a79ce54c33cc4fc90ab5e38ba SHA512 14e9dc19e9654d4178004adfc930ca74522ab9db6711aaf2780e57930d6426cb28fd51f3d8d9b7478864e6a3e17d737512dd42cb9cdceeefe168ba803e71edaf
DIST yoshimi-2.2.0.tar.gz 8021191 BLAKE2B 9ed0976f70c1eea6a17be12e55bc3e01bb304614d0cf91d26f90ad676306baf46967406f7adf576e9758ae7ff103fee4d02584141d3afe99e4b67ff71ef01b18 SHA512 b2d21732d1dd476b0217c10012d654f038250a822517fd4cd4abd85d931c62f3a416cc39438c119bbd1b11b5f40a55735ff8316cc513204abb380b33fbc37231
+DIST yoshimi-2.2.1.tar.gz 8039881 BLAKE2B 8ef8851b6e0808190f8bf97fc6502448d703cd910726f44c8c1f839299badcd858872291f54d4d219d12e11acc31ec1d342f5df5009d71b0fc1d8eae2f6cb7d1 SHA512 9f1895273b8e6ecedf503d59f351f568c189a03d5111d3bc7de8cc0c025f89f48383540f462184b9fad9487ea3cc18c0cc6cb6b1ba7ccd2619ddb2c28c4c66f0
diff --git a/media-sound/yoshimi/yoshimi-2.2.0.ebuild b/media-sound/yoshimi/yoshimi-2.2.0.ebuild
index 07ae2d6616d..d37c7559c8d 100644
--- a/media-sound/yoshimi/yoshimi-2.2.0.ebuild
+++ b/media-sound/yoshimi/yoshimi-2.2.0.ebuild
@@ -11,7 +11,7 @@ SRC_URI="https://github.com/${PN^}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="amd64 x86"
IUSE="+lv2"
BDEPEND="virtual/pkgconfig"
diff --git a/media-sound/yoshimi/yoshimi-2.1.2.2.ebuild b/media-sound/yoshimi/yoshimi-2.2.1.ebuild
index d37c7559c8d..07ae2d6616d 100644
--- a/media-sound/yoshimi/yoshimi-2.1.2.2.ebuild
+++ b/media-sound/yoshimi/yoshimi-2.2.1.ebuild
@@ -11,7 +11,7 @@ SRC_URI="https://github.com/${PN^}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="amd64 x86"
+KEYWORDS="~amd64 ~x86"
IUSE="+lv2"
BDEPEND="virtual/pkgconfig"