summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/lilycomp/lilycomp-1.0.2-r2.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/media-sound/lilycomp/lilycomp-1.0.2-r2.ebuild b/media-sound/lilycomp/lilycomp-1.0.2-r2.ebuild
new file mode 100644
index 000000000000..57af1c754917
--- /dev/null
+++ b/media-sound/lilycomp/lilycomp-1.0.2-r2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="tk"
+
+inherit python-single-r1
+
+MY_P="${P/-/.}"
+
+DESCRIPTION="graphical note entry program for use with LilyPond"
+HOMEPAGE="http://lilycomp.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND="${PYTHON_DEPS}"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+HTML_DOCS=( "${S}/lilycomp.html" )
+
+src_prepare() {
+ default
+ python_fix_shebang lilycomp.py
+}
+
+src_install() {
+ default
+ newbin lilycomp.py lilycomp
+}