summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/lilypond/Manifest1
-rw-r--r--media-sound/lilypond/lilypond-2.19.80-r1.ebuild147
2 files changed, 0 insertions, 148 deletions
diff --git a/media-sound/lilypond/Manifest b/media-sound/lilypond/Manifest
index 1133e497bbc8..dfbd54447466 100644
--- a/media-sound/lilypond/Manifest
+++ b/media-sound/lilypond/Manifest
@@ -1,3 +1,2 @@
DIST lilypond-2.18.2.tar.gz 16027977 BLAKE2B b19b608891e22403efe8e18dd9e86c8d0c85ba516f34242f2a8bcb53c8849a3aa0fe83726036d168f26ee1a7d868a24cc54bd86016b016d634218956e8faf0d4 SHA512 0692f6eb41733076ba7f610cd1e65762f4dfd67307e2ab9e222b140d58ae3a1bb1c6b3be3bcff778d57f161868cf6d57e99bf43bf20f2663d042a07493942ec6
-DIST lilypond-2.19.80.tar.gz 17244725 BLAKE2B f0883d59b1a14634d5d32e6a6f02c0a224643d6d28a3da623d5163396b74ebd15c3307c33c4d96778254fb6486a74c3324d26e3015d51fa163e3765f2c3767aa SHA512 13a7f258bac8ff77ad6d3879f128e86dd5bf45c7780c9738e6976915574d2dfc5404e6f49ca61dcaf8bb15eb266e65fedec4131a50ded7ab305d1856bbd7a3d6
DIST lilypond-2.19.83.tar.gz 17996428 BLAKE2B d6048bfa0dbfbb08c25c5c11287f971936e82d30d88d80deb7fca8fe8d7c8d3d517c37a24b1d52e592c15e166e04eb79d99b4c64ddd4b7f392ec69bff0259d89 SHA512 c8a6acbff055196aba015ecd4786bed25934f04f3718ae9dd9a0dc49d2954f348806874cfe350903cd8bb2b25a0d05700ef5947cac180b20a8a355033ff98604
diff --git a/media-sound/lilypond/lilypond-2.19.80-r1.ebuild b/media-sound/lilypond/lilypond-2.19.80-r1.ebuild
deleted file mode 100644
index 3e23b2dfe640..000000000000
--- a/media-sound/lilypond/lilypond-2.19.80-r1.ebuild
+++ /dev/null
@@ -1,147 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python2_7 )
-
-[[ "${PV}" = "9999" ]] && inherit git-r3
-inherit elisp-common autotools python-single-r1 xdg-utils
-
-if [[ "${PV}" = "9999" ]]; then
- EGIT_REPO_URI="git://git.sv.gnu.org/lilypond.git"
-else
- SRC_URI="http://download.linuxaudio.org/lilypond/sources/v${PV:0:4}/${P}.tar.gz"
- KEYWORDS="amd64 ~arm arm64 ~hppa x86"
-fi
-
-DESCRIPTION="GNU Music Typesetter"
-HOMEPAGE="http://lilypond.org/"
-
-LICENSE="GPL-3 FDL-1.3"
-SLOT="0"
-IUSE="debug emacs guile2 profile vim-syntax"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-RDEPEND=">=app-text/ghostscript-gpl-8.15
- >=dev-scheme/guile-1.8.2:12=[deprecated,regex]
- media-fonts/tex-gyre
- media-libs/fontconfig
- media-libs/freetype:2
- >=x11-libs/pango-1.12.3
- emacs? ( virtual/emacs )
- guile2? ( >=dev-scheme/guile-2:12 )
- !guile2? (
- >=dev-scheme/guile-1.8.2:12=[deprecated,regex]
- <dev-scheme/guile-2.0:12
- )
- ${PYTHON_DEPS}"
-DEPEND="${RDEPEND}
- app-text/t1utils
- dev-lang/perl
- dev-libs/kpathsea
- >=dev-texlive/texlive-metapost-2013
- || (
- >=app-text/texlive-core-2013
- >=dev-tex/metapost-1.803
- )
- virtual/pkgconfig
- media-gfx/fontforge[png]
- >=sys-apps/texinfo-4.11
- >=sys-devel/bison-2.0
- sys-devel/flex
- sys-devel/gettext
- sys-devel/make"
-
-# Correct output data for tests isn't bundled with releases
-RESTRICT="test"
-
-PATCHES=(
- "${FILESDIR}"/${P}-remove-ly-protect.patch
- "${FILESDIR}"/${P}-fontforge-version.patch
-)
-
-DOCS=( DEDICATION HACKING README.txt ROADMAP )
-
-pkg_setup() {
- # make sure >=metapost-1.803 is selected if it's installed, bug 498704
- if [[ ${MERGE_TYPE} != binary ]] && has_version ">=dev-tex/metapost-1.803" ; then
- if [[ $(readlink "${EROOT}"/usr/bin/mpost) =~ mpost-texlive-* ]] ; then
- einfo "Updating metapost symlink"
- eselect mpost update || die
- fi
- fi
-
- python-single-r1_pkg_setup
-}
-
-src_prepare() {
- default
-
- if ! use vim-syntax ; then
- sed -i 's/vim//' GNUmakefile.in || die
- fi
-
- # respect CFLAGS
- sed -i 's/OPTIMIZE -g/OPTIMIZE/' aclocal.m4 || die
-
- # respect AR
- sed -i "s:^AR=ar:AR=$(tc-getAR):" stepmake/stepmake/library-vars.make || die
-
- # remove bundled texinfo file (fixes bug #448560)
- rm tex/texinfo.tex || die
-
- eautoreconf
-
- xdg_environment_reset #586592
-}
-
-src_configure() {
- # documentation generation currently not supported since it requires a newer
- # version of texi2html than is currently in the tree
-
- local myeconfargs=(
- --with-texgyre-dir=/usr/share/fonts/tex-gyre
- --disable-documentation
- --disable-optimising
- --disable-pipe
- $(use_enable debug debugging)
- $(use_enable guile2)
- $(use_enable profile profiling)
- )
-
- econf "${myeconfargs[@]}"
-}
-
-src_compile() {
- default
-
- if use emacs ; then
- elisp-compile elisp/lilypond-{font-lock,indent,mode,what-beat}.el \
- || die "elisp-compile failed"
- fi
-}
-
-src_install () {
- emake DESTDIR="${D}" vimdir=/usr/share/vim/vimfiles install
-
- # remove elisp files since they are in the wrong directory
- rm -r "${ED}"/usr/share/emacs || die
-
- if use emacs ; then
- elisp-install ${PN} elisp/*.{el,elc} elisp/out/*.el \
- || die "elisp-install failed"
- elisp-site-file-install "${FILESDIR}"/50${PN}-gentoo.el
- fi
-
- python_fix_shebang "${ED}"
-
- einstalldocs
-}
-
-pkg_postinst() {
- use emacs && elisp-site-regen
-}
-
-pkg_postrm() {
- use emacs && elisp-site-regen
-}