summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/lilypond/Manifest1
-rw-r--r--media-sound/lilypond/lilypond-2.19.53.ebuild148
2 files changed, 149 insertions, 0 deletions
diff --git a/media-sound/lilypond/Manifest b/media-sound/lilypond/Manifest
index 336ad5d49c09..0fa18979219c 100644
--- a/media-sound/lilypond/Manifest
+++ b/media-sound/lilypond/Manifest
@@ -1,3 +1,4 @@
DIST lilypond-2.18.2.tar.gz 16027977 SHA256 329d733765b0ba7be1878ae3f457dbbb875cc2840d2b75af4afc48c9454fba07 SHA512 0692f6eb41733076ba7f610cd1e65762f4dfd67307e2ab9e222b140d58ae3a1bb1c6b3be3bcff778d57f161868cf6d57e99bf43bf20f2663d042a07493942ec6 WHIRLPOOL 95db264992a1e425fd1ee53d980941eef554c1784a1adfc105750d82d11664f61207c2b1897b6e99448790131c0715f08401f45b663c420553925596c6fd4b1c
DIST lilypond-2.19.50.tar.gz 17059560 SHA256 169ad09fac39512c780d917f5b164dc6a1570f19f5516f812df9eb2157224eb3 SHA512 14267d7e0b578b8b32913042438e4087904023860d3ad607faa3a702741176f2cecc019e0b6c5c88132a93696b087f59ede58e96972c877c911d20b89de1ecd2 WHIRLPOOL 1b8f31728541a9fcd1c34f22c544b464dc89c0591938a882097af1f0581e76dfa8ddb7c4f09f31ad4d5df413615f99bc774bd08a0a668879f9449ef9cd8ff8e4
DIST lilypond-2.19.52.tar.gz 17064855 SHA256 77f4a62b2872f7d6813c7e58b9f8680fc4c3434b86f695117d135b5402e90409 SHA512 afdfa6f277235911b8cfb85985df110d740a580d7d8cb3899e682077674e71faaa050dab16d156d78c0e99243ddb59fb20282a3557309f8679ed457563364020 WHIRLPOOL 54882a8d43ce371ad3a27a955cd464a2296a630b7f274235e24373e08eca746535b0f62b8fca62e82ebed8425d8347a310405ee6134a248dc2e29ff9fd686e73
+DIST lilypond-2.19.53.tar.gz 17066384 SHA256 ef2e50d064911127e4dfdf0acea85a33bbb5cc0a1db68a90fc4d73f8f2932e17 SHA512 f09f15e80a8339ba71d68239f3a2b1a0df6407ffc89c4ec622c15cff4ea9686eb1f73ff540d89ad14278327002b22e98b2caa3b5f946dca3ae2bdd2705d78a9b WHIRLPOOL 285fe7da99eefef24a12ff52baba06e56ed0193c4a236e880812f5cb21f03a3a2d5c4f213265c5b70cf1722979416fca2633fea9dac0efb4dea0882be4336476
diff --git a/media-sound/lilypond/lilypond-2.19.53.ebuild b/media-sound/lilypond/lilypond-2.19.53.ebuild
new file mode 100644
index 000000000000..4326beff0071
--- /dev/null
+++ b/media-sound/lilypond/lilypond-2.19.53.ebuild
@@ -0,0 +1,148 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+
+[[ "${PV}" = "9999" ]] && inherit git-r3
+inherit elisp-common autotools python-single-r1 xdg-utils
+
+if [[ "${PV}" = "9999" ]]; then
+ EGIT_REPO_URI="git://git.sv.gnu.org/lilypond.git"
+else
+ SRC_URI="http://download.linuxaudio.org/lilypond/sources/v${PV:0:4}/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~x86"
+fi
+
+DESCRIPTION="GNU Music Typesetter"
+HOMEPAGE="http://lilypond.org/"
+
+LICENSE="GPL-3 FDL-1.3"
+SLOT="0"
+LANGS=" ca cs da de el eo es fi fr it ja nl ru sv tr uk vi zh_TW"
+IUSE="debug emacs guile2 profile vim-syntax ${LANGS// / linguas_}"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND=">=app-text/ghostscript-gpl-8.15
+ >=dev-scheme/guile-1.8.2:12[deprecated,regex]
+ media-fonts/tex-gyre
+ media-libs/fontconfig
+ media-libs/freetype:2
+ >=x11-libs/pango-1.12.3
+ emacs? ( virtual/emacs )
+ guile2? ( >=dev-scheme/guile-2:12 )
+ !guile2? (
+ >=dev-scheme/guile-1.8.2:12[deprecated,regex]
+ <dev-scheme/guile-2.0:12
+ )
+ ${PYTHON_DEPS}"
+DEPEND="${RDEPEND}
+ app-text/t1utils
+ dev-lang/perl
+ dev-libs/kpathsea
+ >=dev-texlive/texlive-metapost-2013
+ || (
+ >=app-text/texlive-core-2013
+ >=dev-tex/metapost-1.803
+ )
+ virtual/pkgconfig
+ media-gfx/fontforge[png]
+ >=sys-apps/texinfo-4.11
+ >=sys-devel/bison-2.0
+ sys-devel/flex
+ sys-devel/gettext
+ sys-devel/make"
+
+# Correct output data for tests isn't bundled with releases
+RESTRICT="test"
+
+DOCS=( DEDICATION HACKING README.txt ROADMAP )
+
+pkg_setup() {
+ # make sure >=metapost-1.803 is selected if it's installed, bug 498704
+ if [[ ${MERGE_TYPE} != binary ]] && has_version ">=dev-tex/metapost-1.803" ; then
+ if [[ $(readlink "${EROOT}"/usr/bin/mpost) =~ mpost-texlive-* ]] ; then
+ einfo "Updating metapost symlink"
+ eselect mpost update || die
+ fi
+ fi
+
+ python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+
+ if ! use vim-syntax ; then
+ sed -i 's/vim//' GNUmakefile.in || die
+ fi
+
+ # respect CFLAGS
+ sed -i 's/OPTIMIZE -g/OPTIMIZE/' aclocal.m4 || die
+
+ for lang in ${LANGS}; do
+ use linguas_${lang} || rm po/${lang}.po || die
+ done
+
+ # respect AR
+ sed -i "s/^AR=ar/AR=$(tc-getAR)/" stepmake/stepmake/library-vars.make || die
+
+ # remove bundled texinfo file (fixes bug #448560)
+ rm tex/texinfo.tex || die
+
+ eautoreconf
+
+ xdg_environment_reset #586592
+}
+
+src_configure() {
+ # documentation generation currently not supported since it requires a newer
+ # version of texi2html than is currently in the tree
+
+ local myeconfargs+=(
+ --with-texgyre-dir=/usr/share/fonts/tex-gyre
+ --disable-documentation
+ --disable-optimising
+ --disable-pipe
+ $(use_enable debug debugging)
+ $(use_enable guile2)
+ $(use_enable profile profiling)
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_compile() {
+ default
+
+ if use emacs ; then
+ elisp-compile elisp/lilypond-{font-lock,indent,mode,what-beat}.el \
+ || die "elisp-compile failed"
+ fi
+}
+
+src_install () {
+ emake DESTDIR="${D}" vimdir=/usr/share/vim/vimfiles install
+
+ # remove elisp files since they are in the wrong directory
+ rm -r "${ED}"/usr/share/emacs || die
+
+ if use emacs ; then
+ elisp-install ${PN} elisp/*.{el,elc} elisp/out/*.el \
+ || die "elisp-install failed"
+ elisp-site-file-install "${FILESDIR}"/50${PN}-gentoo.el
+ fi
+
+ python_fix_shebang "${ED}"
+
+ einstalldocs
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}