summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/lilypond/Manifest1
-rw-r--r--media-sound/lilypond/lilypond-2.19.50.ebuild142
2 files changed, 143 insertions, 0 deletions
diff --git a/media-sound/lilypond/Manifest b/media-sound/lilypond/Manifest
index 432e084232aa..3fd175475506 100644
--- a/media-sound/lilypond/Manifest
+++ b/media-sound/lilypond/Manifest
@@ -3,3 +3,4 @@ DIST lilypond-2.19.46.tar.gz 16899476 SHA256 f609051e2128c40da17698c0432fe8a9685
DIST lilypond-2.19.47.tar.gz 16926783 SHA256 842312813a9144b6b54a33f13fb19addbfc779d7bbfe3b2075be1235287de08c SHA512 8720a11f0410bd462db1bf11508a7181953b099918b01fc3707a52a2269a840473fc22065b82fad59d98fdd84e54d3810c2c6a4302754d36f1bd6d847e7f72bd WHIRLPOOL ccd8eee71067b0811a32a0ad6572031f936e95637266909534a5212783f0c0fe99eac7406aadae21b17e632c3fb1f1c50b945d4d0e9b64b32ec1c976bf8406c1
DIST lilypond-2.19.48.tar.gz 16928689 SHA256 84b586cfe933a330e964b1c3e95c41525499eca6a5625089044d943e9cc768c8 SHA512 aa128a651af69579ef7fead0a88b57697c2a4a2604f9e81232b48d6b355a0f6e1f372b12454f7154126c78516341a7123bba8aa2dcd4eb17c819030e51a893f9 WHIRLPOOL 5f8d31a93355ec9c0871bec73d0e9ed8ac57989a3e0d8d40df3953c1439ad986529a1f7665025c4e68473f4d87805f17c1a42ef8fa8bb604c8ff21871e65f14a
DIST lilypond-2.19.49.tar.gz 17037279 SHA256 cd190de273cfef61a76c7dec74700b1e8a5d0b44cc98d8a11b58325706c6a3ee SHA512 1b1cd356f332994855f67a1dd8d0aef02f0b133d3aa9c91ddba0950b78b1cb4dc243b0926f7ce0ac46677c8b3cd267cd03db965cb26f74928a645c9d358c6ba2 WHIRLPOOL e0ffd3cde364d234b2bc1f75a453cf40412accab69852befe5d6cc81e5e8dbf91afbb1f5bb3c05b43ff0444b7854621edf1a95dfad5dc46c869530b086685242
+DIST lilypond-2.19.50.tar.gz 17059560 SHA256 169ad09fac39512c780d917f5b164dc6a1570f19f5516f812df9eb2157224eb3 SHA512 14267d7e0b578b8b32913042438e4087904023860d3ad607faa3a702741176f2cecc019e0b6c5c88132a93696b087f59ede58e96972c877c911d20b89de1ecd2 WHIRLPOOL 1b8f31728541a9fcd1c34f22c544b464dc89c0591938a882097af1f0581e76dfa8ddb7c4f09f31ad4d5df413615f99bc774bd08a0a668879f9449ef9cd8ff8e4
diff --git a/media-sound/lilypond/lilypond-2.19.50.ebuild b/media-sound/lilypond/lilypond-2.19.50.ebuild
new file mode 100644
index 000000000000..63535e73399f
--- /dev/null
+++ b/media-sound/lilypond/lilypond-2.19.50.ebuild
@@ -0,0 +1,142 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+
+[[ "${PV}" = "9999" ]] && inherit git-r3
+inherit elisp-common autotools python-single-r1
+
+if [[ "${PV}" = "9999" ]]; then
+ EGIT_REPO_URI="git://git.sv.gnu.org/lilypond.git"
+else
+ SRC_URI="http://download.linuxaudio.org/lilypond/sources/v${PV:0:4}/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~x86"
+fi
+
+DESCRIPTION="GNU Music Typesetter"
+HOMEPAGE="http://lilypond.org/"
+
+LICENSE="GPL-3 FDL-1.3"
+SLOT="0"
+LANGS=" ca cs da de el eo es fi fr it ja nl ru sv tr uk vi zh_TW"
+IUSE="debug emacs profile vim-syntax ${LANGS// / linguas_}"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND=">=app-text/ghostscript-gpl-8.15
+ >=dev-scheme/guile-1.8.2:12[deprecated,regex]
+ media-fonts/tex-gyre
+ media-libs/fontconfig
+ media-libs/freetype:2
+ >=x11-libs/pango-1.12.3
+ emacs? ( virtual/emacs )
+ ${PYTHON_DEPS}"
+DEPEND="${RDEPEND}
+ app-text/t1utils
+ dev-lang/perl
+ dev-libs/kpathsea
+ >=dev-texlive/texlive-metapost-2013
+ || (
+ >=app-text/texlive-core-2013
+ >=dev-tex/metapost-1.803
+ )
+ virtual/pkgconfig
+ media-gfx/fontforge[png]
+ >=sys-apps/texinfo-4.11
+ >=sys-devel/bison-2.0
+ sys-devel/flex
+ sys-devel/gettext
+ sys-devel/make"
+
+# Correct output data for tests isn't bundled with releases
+RESTRICT="test"
+
+DOCS=( DEDICATION HACKING README.txt ROADMAP )
+
+pkg_setup() {
+ # make sure >=metapost-1.803 is selected if it's installed, bug 498704
+ if [[ ${MERGE_TYPE} != binary ]] && has_version ">=dev-tex/metapost-1.803" ; then
+ if [[ $(readlink "${EROOT}"/usr/bin/mpost) =~ mpost-texlive-* ]] ; then
+ einfo "Updating metapost symlink"
+ eselect mpost update || die
+ fi
+ fi
+
+ python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+
+ if ! use vim-syntax ; then
+ sed -i 's/vim//' GNUmakefile.in || die
+ fi
+
+ # respect CFLAGS
+ sed -i 's/OPTIMIZE -g/OPTIMIZE/' aclocal.m4 || die
+
+ for lang in ${LANGS}; do
+ use linguas_${lang} || rm po/${lang}.po || die
+ done
+
+ # respect AR
+ sed -i "s/^AR=ar/AR=$(tc-getAR)/" stepmake/stepmake/library-vars.make || die
+
+ # remove bundled texinfo file (fixes bug #448560)
+ rm tex/texinfo.tex || die
+
+ eautoreconf
+}
+
+src_configure() {
+ # documentation generation currently not supported since it requires a newer
+ # version of texi2html than is currently in the tree
+
+ local myeconfargs+=(
+ --with-texgyre-dir=/usr/share/fonts/tex-gyre
+ --disable-documentation
+ --disable-optimising
+ --disable-pipe
+ $(use_enable debug debugging)
+ $(use_enable profile profiling)
+ )
+
+ has_version ">=dev-scheme/guile-2" && myeconfargs+=( --enable-guile2 )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_compile() {
+ default
+
+ if use emacs ; then
+ elisp-compile elisp/lilypond-{font-lock,indent,mode,what-beat}.el \
+ || die "elisp-compile failed"
+ fi
+}
+
+src_install () {
+ emake DESTDIR="${D}" vimdir=/usr/share/vim/vimfiles install
+
+ # remove elisp files since they are in the wrong directory
+ rm -r "${ED}"/usr/share/emacs || die
+
+ if use emacs ; then
+ elisp-install ${PN} elisp/*.{el,elc} elisp/out/*.el \
+ || die "elisp-install failed"
+ elisp-site-file-install "${FILESDIR}"/50${PN}-gentoo.el
+ fi
+
+ python_fix_shebang "${ED}"
+
+ einstalldocs
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}