summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-video/obs-studio/obs-studio-9999.ebuild')
-rw-r--r--media-video/obs-studio/obs-studio-9999.ebuild16
1 files changed, 8 insertions, 8 deletions
diff --git a/media-video/obs-studio/obs-studio-9999.ebuild b/media-video/obs-studio/obs-studio-9999.ebuild
index 9cd8bdd75172..abb6a6df16e0 100644
--- a/media-video/obs-studio/obs-studio-9999.ebuild
+++ b/media-video/obs-studio/obs-studio-9999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
PYTHON_COMPAT=( python{3_4,3_5,3_6,3_7} )
@@ -24,7 +24,11 @@ SLOT="0"
IUSE="+alsa fdk imagemagick jack luajit nvenc pulseaudio python speex truetype v4l"
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-COMMON_DEPEND="
+BDEPEND="
+ luajit? ( dev-lang/swig )
+ python? ( dev-lang/swig )
+"
+DEPEND="
>=dev-libs/jansson-2.5
dev-qt/qtcore:5
dev-qt/qtdeclarative:5
@@ -61,11 +65,7 @@ COMMON_DEPEND="
)
v4l? ( media-libs/libv4l )
"
-DEPEND="${COMMON_DEPEND}
- luajit? ( dev-lang/swig )
- python? ( dev-lang/swig )
-"
-RDEPEND="${COMMON_DEPEND}"
+RDEPEND="${DEPEND}"
CMAKE_REMOVE_MODULES_LIST=( FindFreetype )