summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/arp-scan')
-rw-r--r--net-analyzer/arp-scan/Manifest1
-rw-r--r--net-analyzer/arp-scan/arp-scan-1.9.7.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/net-analyzer/arp-scan/Manifest b/net-analyzer/arp-scan/Manifest
index c107c73a3cee..54ac63d77097 100644
--- a/net-analyzer/arp-scan/Manifest
+++ b/net-analyzer/arp-scan/Manifest
@@ -1 +1,2 @@
DIST arp-scan-1.9.6.tar.gz 462479 BLAKE2B 21383167d83ba1cd9792f0a8d569c51ff196186fb59a2161c00d6963bcedecb706a419b08aeef2956bad72563f56a9a58b4231715b472a8ab083229b333d2e8f SHA512 c2d56ab8c6e1a046919892f6c2750593d6fbb3a539c3e1736184bd37ff7ae6033f84b62a3d2b4f56c0f2cdc1752002cb010ce77f701ee2f87b6f14b2e1753fe6
+DIST arp-scan-1.9.7.tar.gz 459544 BLAKE2B bd70b2dd9e005096ce80fca07b8f2d8482b1073d25a2a9f82e8f5c1206148dbeab095046292cb46b5823aa18b56c208a5e86d0b7252d8566ddee5cd714b78cc6 SHA512 2aa808521a64cd3e2a6a270c6725f2cffa4cfce5c251e5483053c8ea9f56fb1368dd9aae2afcf8fffe1030fe2fc37723f0701c9eafa7cd1d52df459c07a80870
diff --git a/net-analyzer/arp-scan/arp-scan-1.9.7.ebuild b/net-analyzer/arp-scan/arp-scan-1.9.7.ebuild
new file mode 100644
index 000000000000..b98d876c237a
--- /dev/null
+++ b/net-analyzer/arp-scan/arp-scan-1.9.7.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools
+
+DESCRIPTION="ARP scanning and fingerprinting tool"
+HOMEPAGE="https://github.com/royhills/arp-scan"
+SRC_URI="${HOMEPAGE}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="
+ net-libs/libpcap
+"
+RDEPEND="
+ ${DEPEND}
+ dev-lang/perl
+"
+
+src_prepare() {
+ default
+ eautoreconf
+}