summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/goaccess/goaccess-0.5-r1.ebuild')
-rw-r--r--net-analyzer/goaccess/goaccess-0.5-r1.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/net-analyzer/goaccess/goaccess-0.5-r1.ebuild b/net-analyzer/goaccess/goaccess-0.5-r1.ebuild
new file mode 100644
index 000000000000..c650fbc52896
--- /dev/null
+++ b/net-analyzer/goaccess/goaccess-0.5-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=1
+inherit autotools-utils
+
+DESCRIPTION="A real-time Apache log analyzer and interactive viewer that runs in a terminal"
+HOMEPAGE="http://goaccess.prosoftcorp.com"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux"
+IUSE="geoip unicode"
+
+RDEPEND="
+ dev-libs/glib:2
+ sys-libs/ncurses[unicode?]
+ geoip? ( dev-libs/geoip )
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ # respect CFLAGS, bug #451806
+ sed -i -e '/AM_CFLAGS/s/-g//' Makefile.am || die 'sed failed'
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ # configure does not properly recognise '--disable-something'
+ local myeconfargs=(
+ $(usex geoip '--enable-geoip' '' '' '')
+ $(usex unicode '--enable-utf8' '' '' '')
+ )
+ autotools-utils_src_configure
+}
+
+src_compile() {
+ autotools-utils_src_compile CFLAGS="${CFLAGS}"
+}