summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/nmap/files')
-rw-r--r--net-analyzer/nmap/files/nmap-4.75-nolua.patch9
-rw-r--r--net-analyzer/nmap/files/nmap-6.47-no-libnl.patch70
-rw-r--r--net-analyzer/nmap/files/nmap-6.49-no-FORTIFY_SOURCE.patch71
3 files changed, 0 insertions, 150 deletions
diff --git a/net-analyzer/nmap/files/nmap-4.75-nolua.patch b/net-analyzer/nmap/files/nmap-4.75-nolua.patch
deleted file mode 100644
index 21f0e1fa49dd..000000000000
--- a/net-analyzer/nmap/files/nmap-4.75-nolua.patch
+++ /dev/null
@@ -1,9 +0,0 @@
---- a/Makefile.in
-+++ b/Makefile.in
-@@ -258,5 +258,5 @@
- ./config.status --recheck
-
- makefile.dep:
-- $(CXX) -MM $(CPPFLAGS) $(SRCS) > $@
-+ $(CXX) -MM $(CPPFLAGS) $(CXXFLAGS) $(SRCS) > $@
- include makefile.dep
diff --git a/net-analyzer/nmap/files/nmap-6.47-no-libnl.patch b/net-analyzer/nmap/files/nmap-6.47-no-libnl.patch
deleted file mode 100644
index 0e0c6b70beff..000000000000
--- a/net-analyzer/nmap/files/nmap-6.47-no-libnl.patch
+++ /dev/null
@@ -1,70 +0,0 @@
-nping does not call anything nl_* related so it should not link against libnl (bug #529244)
-Patching configure.ac would be best but eautoreconf does not handle the subdirs very well.
-
---- a/nping/configure
-+++ b/nping/configure
-@@ -4865,64 +4865,6 @@
- fi
-
-
--# libpcap can require libnl
--{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for library containing nl_handle_alloc" >&5
--$as_echo_n "checking for library containing nl_handle_alloc... " >&6; }
--if ${ac_cv_search_nl_handle_alloc+:} false; then :
-- $as_echo_n "(cached) " >&6
--else
-- ac_func_search_save_LIBS=$LIBS
--cat confdefs.h - <<_ACEOF >conftest.$ac_ext
--/* end confdefs.h. */
--
--/* Override any GCC internal prototype to avoid an error.
-- Use char because int might match the return type of a GCC
-- builtin and then its argument prototype would still apply. */
--#ifdef __cplusplus
--extern "C"
--#endif
--char nl_handle_alloc ();
--int
--main ()
--{
--return nl_handle_alloc ();
-- ;
-- return 0;
--}
--_ACEOF
--for ac_lib in '' nl; do
-- if test -z "$ac_lib"; then
-- ac_res="none required"
-- else
-- ac_res=-l$ac_lib
-- LIBS="-l$ac_lib $ac_func_search_save_LIBS"
-- fi
-- if ac_fn_c_try_link "$LINENO"; then :
-- ac_cv_search_nl_handle_alloc=$ac_res
--fi
--rm -f core conftest.err conftest.$ac_objext \
-- conftest$ac_exeext
-- if ${ac_cv_search_nl_handle_alloc+:} false; then :
-- break
--fi
--done
--if ${ac_cv_search_nl_handle_alloc+:} false; then :
--
--else
-- ac_cv_search_nl_handle_alloc=no
--fi
--rm conftest.$ac_ext
--LIBS=$ac_func_search_save_LIBS
--fi
--{ $as_echo "$as_me:${as_lineno-$LINENO}: result: $ac_cv_search_nl_handle_alloc" >&5
--$as_echo "$ac_cv_search_nl_handle_alloc" >&6; }
--ac_res=$ac_cv_search_nl_handle_alloc
--if test "$ac_res" != no; then :
-- test "$ac_res" = "none required" || LIBS="$ac_res $LIBS"
--
--fi
--
--
- # We test whether they specified openssl desires explicitly
- use_openssl="yes"
- specialssldir=""
diff --git a/net-analyzer/nmap/files/nmap-6.49-no-FORTIFY_SOURCE.patch b/net-analyzer/nmap/files/nmap-6.49-no-FORTIFY_SOURCE.patch
deleted file mode 100644
index 383975493be9..000000000000
--- a/net-analyzer/nmap/files/nmap-6.49-no-FORTIFY_SOURCE.patch
+++ /dev/null
@@ -1,71 +0,0 @@
---- a/Makefile.in
-+++ b/Makefile.in
-@@ -41,7 +41,6 @@
- # http://gcc.gnu.org/ml/gcc-patches/2004-09/msg02055.html
- # Level 1 only makes changes that don't affect "conforming" programs,
- # while level 2 enforces additional restrictions.
--DEFS += -D_FORTIFY_SOURCE=2
- # For mtrace debugging -- see MTRACE define in main.cc for instructions
- # Should only be enabled during debugging and not in any real release.
- # DEFS += -DMTRACE=1
---- a/nsock/src/Makefile.in
-+++ b/nsock/src/Makefile.in
-@@ -13,7 +13,6 @@
- CCOPT =
- DEFS = @DEFS@ -DNSOCK_VERSION=\"$(NSOCK_VERSION)\"
- # With GCC, add extra security checks to source code.
--DEFS += -D_FORTIFY_SOURCE=2
- INCLS = -I../include
- CFLAGS = @CFLAGS@ $(CCOPT)
- # CFLAGS = -g -Wall $(DEFS) $(INCLS)
---- a/nping/Makefile.in
-+++ b/nping/Makefile.in
-@@ -38,7 +38,6 @@
- # http://gcc.gnu.org/ml/gcc-patches/2004-09/msg02055.html
- # Level 1 only makes changes that don't affect "conforming" programs,
- # while level 2 enforces additional restrictions.
--DEFS += -D_FORTIFY_SOURCE=2
- # For mtrace debugging -- see MTRACE define in main.cc for instructions
- # Should only be enabled during debugging and not in any real release.
- # DEFS += -DMTRACE=1
---- a/libnetutil/Makefile.in
-+++ b/libnetutil/Makefile.in
-@@ -5,7 +5,6 @@
- CXXFLAGS = @CXXFLAGS@
- CPPFLAGS = @CPPFLAGS@ $(DEFS)
- DEFS = @DEFS@
--DEFS += -D_FORTIFY_SOURCE=2
- AR = ar
- RANLIB = @RANLIB@
-
---- a/ncat/Makefile.in
-+++ b/ncat/Makefile.in
-@@ -53,7 +53,6 @@
- LIBS = @LIBS@
- DEFS = @DEFS@ -DNCAT_DATADIR="\"$(pkgdatadir)\""
- # With GCC, add extra security checks to source code.
--DEFS += -D_FORTIFY_SOURCE=2
- INCLS = -I. -I.. -I../nsock/include/ -I$(NBASEDIR)
- RM = rm -f
- STRIP = @STRIP@
---- a/nbase/Makefile.in
-+++ b/nbase/Makefile.in
-@@ -12,7 +12,6 @@
- CCOPT =
- DEFS = @DEFS@
- # With GCC, add extra security checks to source code.
--DEFS += -D_FORTIFY_SOURCE=2
- CPPFLAGS = @CPPFLAGS@
- CFLAGS = @CFLAGS@ $(CCOPT) $(GLIB_CFLAGS) $(DEFS) $(INCLS)
- STATIC =
---- a/nmap-update/Makefile.in
-+++ b/nmap-update/Makefile.in
-@@ -11,7 +11,7 @@
- CPPFLAGS = @CPPFLAGS@ $(DEFS) -I$(NBASEDIR)
- LDFLAGS = @LDFLAGS@
- LIBS = @LIBS@ $(NBASELIB)
--DEFS = @DEFS@ -D_FORTIFY_SOURCE=2
-+DEFS = @DEFS@
- APR_LIBS = @APR_LIBS@
- SVN_LIBS = @SVN_LIBS@
-