summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/scapy/scapy-2.3.1.ebuild')
-rw-r--r--net-analyzer/scapy/scapy-2.3.1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/net-analyzer/scapy/scapy-2.3.1.ebuild b/net-analyzer/scapy/scapy-2.3.1.ebuild
new file mode 100644
index 000000000000..8230665fdc71
--- /dev/null
+++ b/net-analyzer/scapy/scapy-2.3.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+PYTHON_COMPAT=( python2_7 )
+DISTUTILS_SINGLE_IMPL=true
+
+inherit eutils distutils-r1
+
+DESCRIPTION="A Python interactive packet manipulation program for mastering the network"
+HOMEPAGE="http://www.secdev.org/projects/scapy/"
+SRC_URI="http://bb.secdev.org/${PN}/downloads/${P}.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gnuplot pyx crypt graphviz imagemagick visual tcpreplay"
+
+RDEPEND="
+ net-analyzer/tcpdump
+ gnuplot? ( dev-python/gnuplot-py[${PYTHON_USEDEP}] )
+ pyx? ( dev-python/pyx[${PYTHON_USEDEP}] )
+ crypt? ( dev-python/pycrypto[${PYTHON_USEDEP}] )
+ graphviz? ( media-gfx/graphviz )
+ imagemagick? (
+ || (
+ media-gfx/imagemagick
+ media-gfx/graphicsmagick[imagemagick]
+ )
+ )
+ visual? ( dev-python/visual )
+ tcpreplay? ( net-analyzer/tcpreplay )
+"