summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/greenbone-security-assistant/greenbone-security-assistant-8.0.1-r1.ebuild18
-rw-r--r--net-analyzer/gvm-libs/gvm-libs-10.0.1.ebuild18
-rw-r--r--net-analyzer/gvmd/gvmd-8.0.1.ebuild18
-rw-r--r--net-analyzer/openvas-scanner/openvas-scanner-6.0.1.ebuild18
4 files changed, 36 insertions, 36 deletions
diff --git a/net-analyzer/greenbone-security-assistant/greenbone-security-assistant-8.0.1-r1.ebuild b/net-analyzer/greenbone-security-assistant/greenbone-security-assistant-8.0.1-r1.ebuild
index 417273d6d456..ed0bcabf18ff 100644
--- a/net-analyzer/greenbone-security-assistant/greenbone-security-assistant-8.0.1-r1.ebuild
+++ b/net-analyzer/greenbone-security-assistant/greenbone-security-assistant-8.0.1-r1.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CMAKE_MAKEFILE_GENERATOR="emake"
-inherit cmake-utils flag-o-matic systemd toolchain-funcs
+inherit cmake flag-o-matic systemd toolchain-funcs
MY_PN="gsa"
MY_DN="gsad"
@@ -63,7 +63,7 @@ PATCHES=(
)
src_prepare() {
- cmake-utils_src_prepare
+ cmake_src_prepare
# We will use pre-generated npm stuff.
mv "${WORKDIR}/${MY_NODE_N}" "${MY_NODE_DIR}" || die "couldn't move node_modules"
# Update .yarnrc accordingly.
@@ -92,21 +92,21 @@ src_configure() {
# Add release hardening flags for 8.0.1
append-cflags -D_FORTIFY_SOURCE=2 -fstack-protector
append-ldflags -Wl,-z,relro -Wl,-z,now
- cmake-utils_src_configure
+ cmake_src_configure
}
src_compile() {
- cmake-utils_src_compile
+ cmake_src_compile
if use extras; then
- cmake-utils_src_make -C "${BUILD_DIR}" doc
- cmake-utils_src_make doc-full -C "${BUILD_DIR}" doc
+ cmake_build -C "${BUILD_DIR}" doc
+ cmake_build doc-full -C "${BUILD_DIR}" doc
HTML_DOCS=( "${BUILD_DIR}/${MY_DN}/doc/generated/html/." )
fi
- cmake-utils_src_make rebuild_cache
+ cmake_build rebuild_cache
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
insinto /etc/gvm/sysconfig
doins "${FILESDIR}/${MY_DN}-daemon.conf"
diff --git a/net-analyzer/gvm-libs/gvm-libs-10.0.1.ebuild b/net-analyzer/gvm-libs/gvm-libs-10.0.1.ebuild
index ba028e634f03..aa6cf0725a7c 100644
--- a/net-analyzer/gvm-libs/gvm-libs-10.0.1.ebuild
+++ b/net-analyzer/gvm-libs/gvm-libs-10.0.1.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CMAKE_MAKEFILE_GENERATOR="emake"
-inherit cmake-utils flag-o-matic toolchain-funcs user
+inherit cmake flag-o-matic toolchain-funcs user
DESCRIPTION="Greenbone vulnerability management libraries, previously named openvas-libraries"
HOMEPAGE="https://www.greenbone.net/en/"
@@ -52,7 +52,7 @@ pkg_setup() {
}
src_prepare() {
- cmake-utils_src_prepare
+ cmake_src_prepare
# QA-Fix | Remove doxygen warnings for !CLANG
if use extras; then
if ! tc-is-clang; then
@@ -79,21 +79,21 @@ src_configure() {
# Add release hardening flags for 10.0.1
append-cflags -Wformat -Wformat-security -D_FORTIFY_SOURCE=2 -fstack-protector
append-ldflags -Wl,-z,relro -Wl,-z,now
- cmake-utils_src_configure
+ cmake_src_configure
}
src_compile() {
- cmake-utils_src_compile
+ cmake_src_compile
if use extras; then
- cmake-utils_src_make -C "${BUILD_DIR}" doc
- cmake-utils_src_make doc-full -C "${BUILD_DIR}" doc
+ cmake_build -C "${BUILD_DIR}" doc
+ cmake_build doc-full -C "${BUILD_DIR}" doc
HTML_DOCS=( "${BUILD_DIR}"/doc/generated/html/. )
fi
- cmake-utils_src_make rebuild_cache
+ cmake_build rebuild_cache
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
# Set proper permissions on required files/directories
keepdir /var/lib/gvm
diff --git a/net-analyzer/gvmd/gvmd-8.0.1.ebuild b/net-analyzer/gvmd/gvmd-8.0.1.ebuild
index 6d6b5c3f3eb2..adb7ef65163d 100644
--- a/net-analyzer/gvmd/gvmd-8.0.1.ebuild
+++ b/net-analyzer/gvmd/gvmd-8.0.1.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CMAKE_MAKEFILE_GENERATOR="emake"
-inherit cmake-utils flag-o-matic systemd toolchain-funcs
+inherit cmake flag-o-matic systemd toolchain-funcs
DESCRIPTION="Greenbone vulnerability manager, previously named openvas-manager"
HOMEPAGE="https://www.greenbone.net/en/"
@@ -48,7 +48,7 @@ PATCHES=(
)
src_prepare() {
- cmake-utils_src_prepare
+ cmake_src_prepare
# QA-Fix | Use correct FHS/Gentoo policy paths for 8.0.1
sed -i -e "s*share/doc/gvm/html/*share/doc/gvmd-${PV}/html/*g" "$S"/doc/CMakeLists.txt || die
sed -i -e "s*/doc/gvm/*/doc/gvmd-${PV}/*g" "$S"/CMakeLists.txt || die
@@ -76,21 +76,21 @@ src_configure() {
# Add release hardening flags for 8.0.1
append-cflags -Wno-nonnull -Wformat -Wformat-security -D_FORTIFY_SOURCE=2 -fstack-protector
append-ldflags -Wl,-z,relro -Wl,-z,now
- cmake-utils_src_configure
+ cmake_src_configure
}
src_compile() {
- cmake-utils_src_compile
+ cmake_src_compile
if use extras; then
- cmake-utils_src_make -C "${BUILD_DIR}" doc
- cmake-utils_src_make doc-full -C "${BUILD_DIR}" doc
+ cmake_build -C "${BUILD_DIR}" doc
+ cmake_build doc-full -C "${BUILD_DIR}" doc
HTML_DOCS=( "${BUILD_DIR}"/doc/generated/html/. )
fi
- cmake-utils_src_make rebuild_cache
+ cmake_build rebuild_cache
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
dodir /etc/gvm
insinto /etc/gvm
diff --git a/net-analyzer/openvas-scanner/openvas-scanner-6.0.1.ebuild b/net-analyzer/openvas-scanner/openvas-scanner-6.0.1.ebuild
index b1ba0ec555db..aeedaa6e04f9 100644
--- a/net-analyzer/openvas-scanner/openvas-scanner-6.0.1.ebuild
+++ b/net-analyzer/openvas-scanner/openvas-scanner-6.0.1.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CMAKE_MAKEFILE_GENERATOR="emake"
-inherit cmake-utils flag-o-matic systemd toolchain-funcs
+inherit cmake flag-o-matic systemd toolchain-funcs
MY_PN="openvas"
MY_DN="openvassd"
@@ -53,7 +53,7 @@ PATCHES=(
)
src_prepare() {
- cmake-utils_src_prepare
+ cmake_src_prepare
# QA-Fix | Correct FHS/Gentoo policy paths for 6.0.1
sed -i -e "s*/doc/openvas-scanner/*/doc/openvas-scanner-${PV}/*g" "$S"/src/CMakeLists.txt || die
# QA-Fix | Remove !CLANG doxygen warnings for 6.0.1
@@ -80,21 +80,21 @@ src_configure() {
# Add release hardening flags for 6.0.1
append-cflags -Wno-format-truncation -Wformat -Wformat-security -D_FORTIFY_SOURCE=2 -fstack-protector
append-ldflags -Wl,-z,relro -Wl,-z,now
- cmake-utils_src_configure
+ cmake_src_configure
}
src_compile() {
- cmake-utils_src_compile
+ cmake_src_compile
if use extras; then
- cmake-utils_src_make -C "${BUILD_DIR}" doc
- cmake-utils_src_make doc-full -C "${BUILD_DIR}" doc
+ cmake_build -C "${BUILD_DIR}" doc
+ cmake_build doc-full -C "${BUILD_DIR}" doc
HTML_DOCS=( "${BUILD_DIR}"/doc/generated/html/. )
fi
- cmake-utils_src_make rebuild_cache
+ cmake_build rebuild_cache
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
dodir /etc/openvas
insinto /etc/openvas