summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/prometheus/Manifest2
-rw-r--r--net-analyzer/prometheus/prometheus-1.5.0.ebuild56
-rw-r--r--net-analyzer/prometheus/prometheus-1.5.1.ebuild56
3 files changed, 0 insertions, 114 deletions
diff --git a/net-analyzer/prometheus/Manifest b/net-analyzer/prometheus/Manifest
index d849d2c74b60..8583e2d5c006 100644
--- a/net-analyzer/prometheus/Manifest
+++ b/net-analyzer/prometheus/Manifest
@@ -1,4 +1,2 @@
-DIST prometheus-1.5.0.tar.gz 5182830 SHA256 f8eae5f4c51fdd73ceec08fc4895e695b6b02b581aa95e742e0f48f5aefc5537 SHA512 e90ae333c15335d449332487f6bf3d6a64d356208604850ece7ea8568e7e78f500dfc92219e11d57a01231671586de8c76173254b97fcb92fc14787c8c2a2ed7 WHIRLPOOL 42f2f93bdb04c2fa788c17bc4cd2be9b1c3a1de274c01cbba05b2623d902ef236a78092a1e45eb510fe9fdb20f68ab9b82fe1a958b7cc85e240efa0f1e387b06
-DIST prometheus-1.5.1.tar.gz 5181576 SHA256 5b8e61edc6b192a5b036fb1e76edcfc8948dbb1bfb05669fab49fdbb37349991 SHA512 3db32bcf0a0d0b0ee010b990167571547ffa90f69a94fe41fa91ac9762e66ce167866a53c54d7aeb46e2f9bd03466a287d9476458c18267d3c45d1a3a358ec5e WHIRLPOOL cd98b4cf587634fc011a78b722012e770d5e5104f54725441f23ea1ed1eb861534780943f6bb9a5277f629f7663a926e1c2ae103014925fe9b34d43581cfc0d7
DIST prometheus-1.5.2.tar.gz 5183537 SHA256 c4881cc305263cc8da434be69a20aa039386d4feab5e58f8b89a60bfe8b556ac SHA512 5a08b26228b111c65431c0afce082962109f80435a5201ca0dd8883ba300da1f28865231c4182235df7ce4e2baa5b01d6a41cbb7ce29d9cb9f2e2853a2de81d4 WHIRLPOOL a8c2cb3ebd6a210316433a4ff63d18ac13ed196e297384d49e39da2ef88f49a01341af8c17ee5fa3090a3870a5b854c51fded90783afc2b08ebba83466ead856
DIST prometheus-1.6.1.tar.gz 5220870 SHA256 ecc9ce94fce45994c23b76eb0c5acbb1b942513be601872c8cd74d0821450c5e SHA512 c4d4604e23fcd6cecb408c5688a28f96a96145b9be7799ca64a1b31b6993a014450bb009f5eea342728aa099c70eeef8bcec65cc7ccf326cd5f71e9edcb22052 WHIRLPOOL 74ec10d2fa8c833dbde370a399f0b7bda07bd4b9b4fc19958246eb81cfd8e17fb90d1e283791d200cbe3c4b6dfcd5a8ed9d705a5b7c4112a152f385d7d5b5a44
diff --git a/net-analyzer/prometheus/prometheus-1.5.0.ebuild b/net-analyzer/prometheus/prometheus-1.5.0.ebuild
deleted file mode 100644
index a4622a9ae7bf..000000000000
--- a/net-analyzer/prometheus/prometheus-1.5.0.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit user golang-build golang-vcs-snapshot
-
-EGO_PN="github.com/prometheus/prometheus/..."
-EGIT_COMMIT="v${PV}"
-PROMETHEUS_COMMIT="d840f2c"
-ARCHIVE_URI="https://${EGO_PN%/*}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
-KEYWORDS="~amd64"
-
-DESCRIPTION="Prometheus monitoring system and time series database"
-HOMEPAGE="https://github.com/prometheus/prometheus"
-SRC_URI="${ARCHIVE_URI}"
-LICENSE="Apache-2.0"
-SLOT="0"
-IUSE=""
-
-DEPEND="dev-util/promu"
-
-PROMETHEUS_HOME="/var/lib/prometheus"
-
-pkg_setup() {
- enewgroup prometheus
- enewuser prometheus -1 -1 "${PROMETHEUS_HOME}" prometheus
-}
-
-src_prepare() {
- default
- sed -i -e "s/{{.Revision}}/${PROMETHEUS_COMMIT}/" src/${EGO_PN%/*}/.promu.yml || die
-}
-
-src_compile() {
- pushd src/${EGO_PN%/*} || die
- GOPATH="${S}" promu build -v || die
- popd || die
-}
-
-src_install() {
- pushd src/${EGO_PN%/*} || die
- dobin promtool prometheus
- dodoc -r {documentation,{README,CHANGELOG,CONTRIBUTING}.md}
- insinto /etc/prometheus
- doins documentation/examples/prometheus.yml
- insinto /usr/share/prometheus
- doins -r console_libraries consoles
- dosym ../../usr/share/prometheus/console_libraries /etc/prometheus/console_libraries
- dosym ../../usr/share/prometheus/consoles /etc/prometheus/consoles
- popd || die
-
- newinitd "${FILESDIR}"/prometheus.initd prometheus
- newconfd "${FILESDIR}"/prometheus.confd prometheus
- keepdir /var/log/prometheus /var/lib/prometheus
- fowners prometheus:prometheus /var/log/prometheus /var/lib/prometheus
-}
diff --git a/net-analyzer/prometheus/prometheus-1.5.1.ebuild b/net-analyzer/prometheus/prometheus-1.5.1.ebuild
deleted file mode 100644
index 0311191a6fc7..000000000000
--- a/net-analyzer/prometheus/prometheus-1.5.1.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit user golang-build golang-vcs-snapshot
-
-EGO_PN="github.com/prometheus/prometheus/..."
-EGIT_COMMIT="v${PV}"
-PROMETHEUS_COMMIT="c4686f7"
-ARCHIVE_URI="https://${EGO_PN%/*}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
-KEYWORDS="~amd64"
-
-DESCRIPTION="Prometheus monitoring system and time series database"
-HOMEPAGE="https://github.com/prometheus/prometheus"
-SRC_URI="${ARCHIVE_URI}"
-LICENSE="Apache-2.0"
-SLOT="0"
-IUSE=""
-
-DEPEND="dev-util/promu"
-
-PROMETHEUS_HOME="/var/lib/prometheus"
-
-pkg_setup() {
- enewgroup prometheus
- enewuser prometheus -1 -1 "${PROMETHEUS_HOME}" prometheus
-}
-
-src_prepare() {
- default
- sed -i -e "s/{{.Revision}}/${PROMETHEUS_COMMIT}/" src/${EGO_PN%/*}/.promu.yml || die
-}
-
-src_compile() {
- pushd src/${EGO_PN%/*} || die
- GOPATH="${S}" promu build -v || die
- popd || die
-}
-
-src_install() {
- pushd src/${EGO_PN%/*} || die
- dobin promtool prometheus
- dodoc -r {documentation,{README,CHANGELOG,CONTRIBUTING}.md}
- insinto /etc/prometheus
- doins documentation/examples/prometheus.yml
- insinto /usr/share/prometheus
- doins -r console_libraries consoles
- dosym ../../usr/share/prometheus/console_libraries /etc/prometheus/console_libraries
- dosym ../../usr/share/prometheus/consoles /etc/prometheus/consoles
- popd || die
-
- newinitd "${FILESDIR}"/prometheus.initd prometheus
- newconfd "${FILESDIR}"/prometheus.confd prometheus
- keepdir /var/log/prometheus /var/lib/prometheus
- fowners prometheus:prometheus /var/log/prometheus /var/lib/prometheus
-}