summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-dialup')
-rw-r--r--net-dialup/hcfpcimodem/Manifest3
-rw-r--r--net-dialup/hcfpcimodem/files/hcfpcimodem-1.20-gentoo.patch29
-rw-r--r--net-dialup/hcfpcimodem/hcfpcimodem-1.20.ebuild91
-rw-r--r--net-dialup/hcfpcimodem/hcfpcimodem-1.21.ebuild90
-rw-r--r--net-dialup/hcfpcimodem/metadata.xml5
5 files changed, 0 insertions, 218 deletions
diff --git a/net-dialup/hcfpcimodem/Manifest b/net-dialup/hcfpcimodem/Manifest
deleted file mode 100644
index e5491051babb..000000000000
--- a/net-dialup/hcfpcimodem/Manifest
+++ /dev/null
@@ -1,3 +0,0 @@
-DIST 100498D_RM_HxF_Released.pdf 718949 BLAKE2B bb6320c0d76a6a78d8ca596575985202ea4023afa6c66a6046f07239e8ac637a5e94e8e7e74e44511600fbef1b9c0de00b82c5e5ec49c951105d56d06070a3a4 SHA512 3a2b79bcf63f9f6cb6e846ba41cad810ebe3622273e7df749efa6a24ea1c1ca0fd627ca3455feafa77d7f54a3aba2ed2b3ba01c37286a750929f9b7685bcf40f
-DIST hcfpcimodem-1.20full.tar.gz 692131 BLAKE2B f50b0ee5e210052cd0fa5ffd8c39210fd654f454d6dc7faeada4bfb954daf06e2d67bc14b3ff68146574603f59c01b09b7ed7b69bd25ede6c5f704e9958de7bb SHA512 bacb05fd6f35a6d795c7e5497a5cc3ca330e4f47a75f3a5d3322e1f018de89cd59485db064e1ca9b095472ec20998b51af0d099df978df4a7326bca9188786e7
-DIST hcfpcimodem-1.21full.tar.gz 692291 BLAKE2B 5017a789e064c7df3de8417e07809b7b81997aaafe4e5f7a9a686a7e7183a4b68a6f5a753bc70eb7248aba56a6ae63261da171c2ea561539ea23b75491c0aed5 SHA512 eddcff4222c9a3642c590673249966bce59c0afb30536dbcce80df5bd9d7c47a30281f80b8f9a20853424181123369088203141dd9dd1e73e7b1aa6a9ed695c3
diff --git a/net-dialup/hcfpcimodem/files/hcfpcimodem-1.20-gentoo.patch b/net-dialup/hcfpcimodem/files/hcfpcimodem-1.20-gentoo.patch
deleted file mode 100644
index 11ce09abfbbc..000000000000
--- a/net-dialup/hcfpcimodem/files/hcfpcimodem-1.20-gentoo.patch
+++ /dev/null
@@ -1,29 +0,0 @@
-diff -Nru hcfpcimodem-1.20full.orig/diag/makefile hcfpcimodem-1.20full/diag/makefile
---- hcfpcimodem-1.20full.orig/diag/makefile 2004-12-14 08:50:41.000000000 +0100
-+++ hcfpcimodem-1.20full/diag/makefile 2009-11-29 10:35:05.000000000 +0100
-@@ -10,7 +10,7 @@
- include $(TOP)/config.mak
- -include $(TOP)/modules/imported/makeflags.mak
-
--CFLAGS = -I$(TOP)/modules/imported/include -I$(TOP)/modules/include
-+CFLAGS += -I$(TOP)/modules/imported/include -I$(TOP)/modules/include
- CFLAGS += $(IMPORTED_FRAMEWORK_DEFS) $(IMPORTED_GENERAL_DEFS)
- CFLAGS += -DCNXTTARGET="\"$(CNXTTARGET)\""
-
-@@ -41,13 +41,13 @@
- $(MKDIR) -p $@
-
- $(CNXTTARGET)diag: diag.o modemexpert.o
-- $(CC) -o $@ $^
-+ $(CC) ${LDFLAGS} -o $@ $^
-
- $(CNXTTARGET)scr: scr.o
-- $(CC) -o $@ $^
-+ $(CC) ${CFLAGS} ${LDFLAGS} -o $@ $^
-
- $(CNXTTARGET)dmp: dmp.o
-- $(CC) -o $@ $^
-+ $(CC) ${CFLAGS} ${LDFLAGS} -o $@ $^
-
- clean:
- rm -f *.o $(ALL)
diff --git a/net-dialup/hcfpcimodem/hcfpcimodem-1.20.ebuild b/net-dialup/hcfpcimodem/hcfpcimodem-1.20.ebuild
deleted file mode 100644
index 0d16f721ac06..000000000000
--- a/net-dialup/hcfpcimodem/hcfpcimodem-1.20.ebuild
+++ /dev/null
@@ -1,91 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-inherit eutils linux-info
-
-#The document is the same as in hsfmodem, even if it has a different URL
-MY_DOC="100498D_RM_HxF_Released.pdf"
-
-DESCRIPTION="Linuxant's modem driver for Connexant HCF chipset"
-HOMEPAGE="http://www.linuxant.com/drivers/hcf/index.php"
-SRC_URI="http://www.linuxant.com/drivers/hcf/full/archive/${P}full/${P}full.tar.gz
- doc? ( http://www.linuxant.com/drivers/hcf/full/archive/${P}full/${MY_DOC} )"
-
-LICENSE="Conexant"
-SLOT="0"
-KEYWORDS="-* x86"
-IUSE="doc"
-
-DEPEND="dev-lang/perl
- app-arch/cpio"
-RDEPEND="${DEPEND}"
-
-S="${WORKDIR}/${P}full"
-
-QA_EXECSTACK="usr/lib/hcfpcimodem/modules/imported/hcfblam-i386.O usr/lib/hcfpcimodem/modules/imported/hcfengine-i386.O"
-
-pkg_setup() {
- linux-info_pkg_setup
-
- MOD_N="hcfpci"
- # Check to see if module is inserted into kernel, otherwise, build fails
- if [ "`lsmod | sed '/^'$MOD_N'serial/!d'`" ]; then
- eerror
- eerror "Module is in use by the kernel!!!"
- eerror "Attempting to unload..."
- eerror
-
- # Unloading module...
- ${MOD_N}stop
- if [ "`lsmod | sed '/^'$MOD_N'serial/!d'`" ]; then
- eerror "Failed to unload modules from kernel!!!"
- eerror "Please manualy remove the module from the kernel and emerge again."
- eerror
- die
- fi
- einfo "Successfuly removed module from memory. Resuming emerge."
- einfo
- fi
-}
-
-src_unpack() {
- unpack ${A}
-
- cd "${S}"
- epatch "${FILESDIR}"/${P}-gentoo.patch
-}
-
-src_compile() {
- emake all || die "make failed"
-}
-
-pkg_preinst() {
- local NVMDIR="${ROOT}/etc/${PN}/nvm"
- if [ -d "${NVMDIR}" ]; then
- einfo "Cleaning ${NVMDIR}..."
- rm -rf "${NVMDIR}"
- eend
- fi
-}
-
-src_install () {
- make PREFIX="${D}/usr/" ROOT="${D}" install || die "make install failed"
-
- # in some cases, kernelcompiler.sh does not have x permission (#173414)
- fperms a+rx /usr/lib/hcfpcimodem/modules/kernelcompiler.sh
-
- use doc && dodoc "${DISTDIR}/${MY_DOC}"
-}
-
-pkg_postinst() {
- if [ "${ROOT}" = / ]; then
- elog "To complete the installation and configuration of your HCF modem,"
- elog "please run hcfpciconfig."
- fi
-}
-
-pkg_prerm() {
- if [ "${ROOT}" = / -a -f /etc/init.d/hcfpci ] ; then
- hcfpciconfig --remove || die "hcfpciconfig --remove failed"
- fi
-}
diff --git a/net-dialup/hcfpcimodem/hcfpcimodem-1.21.ebuild b/net-dialup/hcfpcimodem/hcfpcimodem-1.21.ebuild
deleted file mode 100644
index 2af11b5cec43..000000000000
--- a/net-dialup/hcfpcimodem/hcfpcimodem-1.21.ebuild
+++ /dev/null
@@ -1,90 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=2
-
-inherit eutils linux-info toolchain-funcs
-
-#The document is the same as in hsfmodem, even if it has a different URL
-MY_DOC="100498D_RM_HxF_Released.pdf"
-
-DESCRIPTION="Linuxant's modem driver for Connexant HCF chipset"
-HOMEPAGE="http://www.linuxant.com/drivers/hcf/index.php"
-SRC_URI="http://www.linuxant.com/drivers/hcf/full/archive/${P}full/${P}full.tar.gz
- doc? ( http://www.linuxant.com/drivers/hcf/full/archive/${P}full/${MY_DOC} )"
-
-LICENSE="Conexant"
-SLOT="0"
-KEYWORDS="-* ~x86"
-IUSE="doc"
-
-DEPEND="dev-lang/perl
- app-arch/cpio"
-RDEPEND="${DEPEND}"
-
-S="${WORKDIR}/${P}full"
-
-QA_EXECSTACK="usr/lib/hcfpcimodem/modules/imported/hcfblam-i386.O usr/lib/hcfpcimodem/modules/imported/hcfengine-i386.O"
-
-pkg_setup() {
- linux-info_pkg_setup
-
- local MOD_N="hcfpci"
- # Check to see if module is inserted into kernel, otherwise, build fails
- if [ "`lsmod | sed '/^'$MOD_N'serial/!d'`" ]; then
- eerror
- eerror "Module is in use by the kernel!!!"
- eerror "Attempting to unload..."
- eerror
-
- # Unloading module...
- ${MOD_N}stop
- if [ "`lsmod | sed '/^'$MOD_N'serial/!d'`" ]; then
- eerror "Failed to unload modules from kernel!!!"
- eerror "Please manualy remove the module from the kernel and emerge again."
- eerror
- die
- fi
- einfo "Successfuly removed module from memory. Resuming emerge."
- einfo
- fi
-}
-
-src_prepare() {
- epatch "${FILESDIR}"/${PN}-1.20-gentoo.patch
-}
-
-src_compile() {
- emake CC="$(tc-getCC)" all || die "make failed"
-}
-
-pkg_preinst() {
- local NVMDIR="${ROOT}/etc/${PN}/nvm"
- if [ -d "${NVMDIR}" ]; then
- einfo "Cleaning ${NVMDIR}..."
- rm -rf "${NVMDIR}" || die
- eend
- fi
-}
-
-src_install () {
- make PREFIX="${D}/usr/" ROOT="${D}" install || die "make install failed"
-
- # in some cases, kernelcompiler.sh does not have x permission (#173414)
- fperms a+rx /usr/lib/hcfpcimodem/modules/kernelcompiler.sh
-
- use doc && dodoc "${DISTDIR}/${MY_DOC}"
-}
-
-pkg_postinst() {
- if [ "${ROOT}" = / ]; then
- elog "To complete the installation and configuration of your HCF modem,"
- elog "please run hcfpciconfig."
- fi
-}
-
-pkg_prerm() {
- if [ "${ROOT}" = / -a -f /etc/init.d/hcfpci ] ; then
- hcfpciconfig --remove || die "hcfpciconfig --remove failed"
- fi
-}
diff --git a/net-dialup/hcfpcimodem/metadata.xml b/net-dialup/hcfpcimodem/metadata.xml
deleted file mode 100644
index 6f49eba8f496..000000000000
--- a/net-dialup/hcfpcimodem/metadata.xml
+++ /dev/null
@@ -1,5 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-<!-- maintainer-needed -->
-</pkgmetadata>