summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-dns/c-ares/c-ares-1.9.1.ebuild')
-rw-r--r--net-dns/c-ares/c-ares-1.9.1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/net-dns/c-ares/c-ares-1.9.1.ebuild b/net-dns/c-ares/c-ares-1.9.1.ebuild
new file mode 100644
index 000000000000..1c9d1e07ffcd
--- /dev/null
+++ b/net-dns/c-ares/c-ares-1.9.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+DESCRIPTION="C library that resolves names asynchronously"
+HOMEPAGE="http://c-ares.haxx.se/"
+SRC_URI="http://${PN}.haxx.se/download/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~mips ppc ppc64 s390 sh ~sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc64-solaris"
+IUSE="static-libs"
+
+DOCS=( AUTHORS CHANGES NEWS README RELEASE-NOTES TODO )
+
+src_configure() {
+ econf \
+ --enable-nonblocking \
+ --enable-symbol-hiding \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ find "${ED}" -name "*.la" -exec rm {} + || die
+}