summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-dns/pdns')
-rw-r--r--net-dns/pdns/pdns-4.2.0_rc2.ebuild15
1 files changed, 15 insertions, 0 deletions
diff --git a/net-dns/pdns/pdns-4.2.0_rc2.ebuild b/net-dns/pdns/pdns-4.2.0_rc2.ebuild
index 839351637f06..d811e77d5c51 100644
--- a/net-dns/pdns/pdns-4.2.0_rc2.ebuild
+++ b/net-dns/pdns/pdns-4.2.0_rc2.ebuild
@@ -155,4 +155,19 @@ pkg_postinst() {
break
done
+
+ if use postgres; then
+ for old in ${REPLACING_VERSIONS}; do
+ ver_test ${old} -lt 4.1.11-r1 || continue
+
+ echo
+ ewarn "PowerDNS 4.1.11 contains a security fix for the PostgreSQL backend."
+ ewarn "This security fix needs to be applied manually to the database schema."
+ ewarn "Please refer to the official security advisory for more information:"
+ ewarn
+ ewarn " https://doc.powerdns.com/authoritative/security-advisories/powerdns-advisory-2019-06.html"
+
+ break
+ done
+ fi
}