summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-im/bitlbee-steam/bitlbee-steam-9999.ebuild')
-rw-r--r--net-im/bitlbee-steam/bitlbee-steam-9999.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/net-im/bitlbee-steam/bitlbee-steam-9999.ebuild b/net-im/bitlbee-steam/bitlbee-steam-9999.ebuild
new file mode 100644
index 000000000000..07c5297786c7
--- /dev/null
+++ b/net-im/bitlbee-steam/bitlbee-steam-9999.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils autotools git-2
+
+DESCRIPTION="Steam protocol plugin for BitlBee"
+HOMEPAGE="https://github.com/jgeboski/bitlbee-steam"
+EGIT_REPO_URI="https://github.com/jgeboski/bitlbee-steam.git"
+
+LICENSE="GPL-2 LGPL-2.1 BSD-2"
+SLOT="0"
+KEYWORDS=""
+IUSE="debug"
+
+RDEPEND="
+ dev-libs/glib:2
+ dev-libs/libgpg-error
+ >=net-im/bitlbee-3.2.1[plugins]"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable debug) \
+ --enable-minimal-flags
+}
+
+src_install() {
+ default
+ prune_libtool_files
+}