summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-im/bitlbee')
-rw-r--r--net-im/bitlbee/Manifest1
-rw-r--r--net-im/bitlbee/bitlbee-3.4.2.ebuild187
-rw-r--r--net-im/bitlbee/bitlbee-9999.ebuild17
3 files changed, 202 insertions, 3 deletions
diff --git a/net-im/bitlbee/Manifest b/net-im/bitlbee/Manifest
index de17c3e49ad7..2153c6cd20e3 100644
--- a/net-im/bitlbee/Manifest
+++ b/net-im/bitlbee/Manifest
@@ -1,2 +1,3 @@
DIST bitlbee-3.2.2.tar.gz 661757 SHA256 ba38939281f23e8a0e71022c7be0cb68f6544248404362c5e20245fa7a67558e SHA512 5826a9d64e2de42c5560d85c3e7c96a72930afae005143323b6a301b588328b156b50cde571c7f396ca00952d950d22db1ea11cc42256935d3d72ec90215e7d2 WHIRLPOOL cbc3552289949e5e10281d65f617f38075016c813bf2cbb13e09af913ea8545c46a69225bf4f523e1a73f955d7309b8c7b94e23affdedf5dce2760eee55203ae
DIST bitlbee-3.4.1.tar.gz 688072 SHA256 500a0b19943040d67458eb3beb0a63d004abb2aa54a777addeb2a895d4f5c0e1 SHA512 fad297c7a792c932ba74daf7dc894883037842ae5d39a4c831c6615100580073001806c1af60555aa1c775399e8a484d99a4e601e96c6a075e12546e5d153532 WHIRLPOOL 431faa8f065233ee7345d4950d147fea9fc627ba4b78ca0f25bed9627804d3dd4d512a12c9f98bd29a01ebfb680c8cf7e756bb53b38a484b304a0e973c657993
+DIST bitlbee-3.4.2.tar.gz 719456 SHA256 69c85554def74f314e3b6e390389a30b0e748f23ef37883e9d7545ee2c45ea57 SHA512 2b839c014cfad037d815aa0e0867dda1b4628ff076d8de6fec1e80ab1499bca565d9afbe104929d492ff68c86b745cc3f76acbeba102766d656f2d359b70302e WHIRLPOOL 43803ba2bbe6297e05e465912d22b0547bb0f9c3cd184a6c0c924dc023b9d505e3666aa732de83c79249e59aa0e2d6f621ee15c508ccc17eed1898b755f0112e
diff --git a/net-im/bitlbee/bitlbee-3.4.2.ebuild b/net-im/bitlbee/bitlbee-3.4.2.ebuild
new file mode 100644
index 000000000000..dceb0c289806
--- /dev/null
+++ b/net-im/bitlbee/bitlbee-3.4.2.ebuild
@@ -0,0 +1,187 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit eutils multilib user python-single-r1 systemd
+
+if [[ ${PV} == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/bitlbee/bitlbee.git"
+ inherit git-r3
+else
+ SRC_URI="http://get.bitlbee.org/src/${P}.tar.gz"
+ KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-fbsd"
+fi
+
+DESCRIPTION="irc to IM gateway that support multiple IM protocols"
+HOMEPAGE="http://www.bitlbee.org/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="debug gnutls ipv6 +xmpp libevent msn nss +oscar otr +plugins purple selinux
+ skype ssl test twitter +yahoo xinetd libressl"
+
+COMMON_DEPEND="
+ >=dev-libs/glib-2.16
+ purple? ( net-im/pidgin )
+ libevent? ( dev-libs/libevent:= )
+ otr? ( >=net-libs/libotr-4 )
+ gnutls? ( net-libs/gnutls:= )
+ !gnutls? (
+ nss? ( dev-libs/nss )
+ !nss? ( ssl? ( !libressl? ( dev-libs/openssl:0= ) libressl? ( dev-libs/libressl:= ) ) )
+ )
+ "
+DEPEND="${COMMON_DEPEND}
+ dev-lang/python
+ virtual/pkgconfig
+ selinux? ( sec-policy/selinux-bitlbee )
+ test? ( dev-libs/check )"
+
+RDEPEND="${COMMON_DEPEND}
+ virtual/logger
+ skype? (
+ dev-python/skype4py[${PYTHON_USEDEP}]
+ net-im/skype
+ )
+ xinetd? ( sys-apps/xinetd )"
+
+REQUIRED_USE="|| ( purple xmpp msn oscar yahoo )
+ msn? ( || ( gnutls nss ssl ) )
+ xmpp? ( !nss )"
+
+pkg_setup() {
+ if use xmpp && ! use gnutls && ! use ssl ; then
+ einfo
+ elog "You have enabled support for Jabber but do not have SSL"
+ elog "support enabled. This *will* prevent bitlbee from being"
+ elog "able to connect to SSL enabled Jabber servers. If you need to"
+ elog "connect to Jabber over SSL, enable ONE of the following use"
+ elog "flags: gnutls or ssl"
+ einfo
+ fi
+
+ use skype && python-single-r1_pkg_setup
+
+ enewgroup bitlbee
+ enewuser bitlbee -1 -1 /var/lib/bitlbee bitlbee
+}
+
+src_prepare() {
+ sed -i \
+ -e "s@/usr/local/sbin/bitlbee@/usr/sbin/bitlbee@" \
+ -e "s/nobody/bitlbee/" \
+ -e "s/}/ disable = yes\n}/" \
+ doc/bitlbee.xinetd || die "sed failed in xinetd"
+
+ sed -i \
+ -e "s@mozilla-nss@nss@g" \
+ configure || die "sed failed in configure"
+
+ use skype && python_fix_shebang protocols/skype/skyped.py
+
+ [[ ${PV} != "9999" ]] && epatch "${FILESDIR}"/${PN}-3.2.1-configure.patch
+ epatch_user
+}
+
+src_configure() {
+ # setup plugins, protocol, ipv6 and debug
+ use xmpp && myconf="${myconf} --jabber=1"
+ for flag in debug ipv6 msn oscar plugins purple skype twitter yahoo ; do
+ if use ${flag} ; then
+ myconf="${myconf} --${flag}=1"
+ else
+ myconf="${myconf} --${flag}=0"
+ fi
+ done
+
+ # set otr
+ if use otr && use plugins ; then
+ myconf="${myconf} --otr=plugin"
+ else
+ if use otr ; then
+ ewarn "OTR support has been disabled automatically because it"
+ ewarn "requires the plugins USE flag."
+ fi
+ myconf="${myconf} --otr=0"
+ fi
+
+ # setup ssl use flags
+ if use gnutls ; then
+ myconf="${myconf} --ssl=gnutls"
+ einfo "Using gnutls for SSL support"
+ elif use ssl ; then
+ myconf="${myconf} --ssl=openssl"
+ einfo "Using openssl for SSL support"
+ elif use nss ; then
+ myconf="${myconf} --ssl=nss"
+ einfo "Using nss for SSL support"
+ else
+ myconf="${myconf} --ssl=bogus"
+ einfo "You will not have any encryption support enabled."
+ fi
+
+ # set event handler
+ if use libevent ; then
+ myconf="${myconf} --events=libevent"
+ else
+ myconf="${myconf} --events=glib"
+ fi
+
+ # NOTE: bitlbee's configure script is not an autotool creation,
+ # so that is why we don't use econf.
+ ./configure \
+ --prefix=/usr --datadir=/usr/share/bitlbee \
+ --etcdir=/etc/bitlbee --plugindir=/usr/$(get_libdir)/bitlbee \
+ --systemdsystemunitdir=$(systemd_get_unitdir) \
+ --doc=1 --strip=0 ${myconf} || die "econf failed"
+
+ sed -i \
+ -e "/^EFLAGS/s:=:&${LDFLAGS} :" \
+ Makefile.settings || die "sed failed"
+}
+
+src_install() {
+ emake install install-etc install-doc install-dev install-systemd DESTDIR="${D}"
+
+ keepdir /var/lib/bitlbee
+ fperms 700 /var/lib/bitlbee
+ fowners bitlbee:bitlbee /var/lib/bitlbee
+
+ dodoc doc/{AUTHORS,CHANGES,CREDITS,FAQ,README}
+
+ if use skype ; then
+ newdoc protocols/skype/NEWS NEWS-skype
+ newdoc protocols/skype/README README-skype
+ fi
+
+ if use xinetd ; then
+ insinto /etc/xinetd.d
+ newins doc/bitlbee.xinetd bitlbee
+ fi
+
+ newinitd "${FILESDIR}"/bitlbee.initd-r1 bitlbee
+ newconfd "${FILESDIR}"/bitlbee.confd-r1 bitlbee
+
+ exeinto /usr/share/bitlbee
+ doexe utils/{convert_purple.py,bitlbee-ctl.pl}
+}
+
+pkg_postinst() {
+ chown -R bitlbee:bitlbee "${ROOT}"/var/lib/bitlbee
+ [[ -d "${ROOT}"/var/run/bitlbee ]] &&
+ chown -R bitlbee:bitlbee "${ROOT}"/var/run/bitlbee
+
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ einfo
+ elog "The bitlbee init script will now attempt to stop all processes owned by the"
+ elog "bitlbee user, including per-client forks."
+ elog
+ elog "Tell the init script not to touch anything besides the main bitlbee process"
+ elog "by changing the BITLBEE_STOP_ALL variable in"
+ elog " /etc/conf.d/bitlbee"
+ einfo
+ fi
+}
diff --git a/net-im/bitlbee/bitlbee-9999.ebuild b/net-im/bitlbee/bitlbee-9999.ebuild
index 181f31968bcf..dceb0c289806 100644
--- a/net-im/bitlbee/bitlbee-9999.ebuild
+++ b/net-im/bitlbee/bitlbee-9999.ebuild
@@ -26,12 +26,12 @@ IUSE="debug gnutls ipv6 +xmpp libevent msn nss +oscar otr +plugins purple selinu
COMMON_DEPEND="
>=dev-libs/glib-2.16
purple? ( net-im/pidgin )
- libevent? ( dev-libs/libevent )
+ libevent? ( dev-libs/libevent:= )
otr? ( >=net-libs/libotr-4 )
- gnutls? ( net-libs/gnutls )
+ gnutls? ( net-libs/gnutls:= )
!gnutls? (
nss? ( dev-libs/nss )
- !nss? ( ssl? ( !libressl? ( dev-libs/openssl:0 ) libressl? ( dev-libs/libressl:= ) ) )
+ !nss? ( ssl? ( !libressl? ( dev-libs/openssl:0= ) libressl? ( dev-libs/libressl:= ) ) )
)
"
DEPEND="${COMMON_DEPEND}
@@ -173,4 +173,15 @@ pkg_postinst() {
chown -R bitlbee:bitlbee "${ROOT}"/var/lib/bitlbee
[[ -d "${ROOT}"/var/run/bitlbee ]] &&
chown -R bitlbee:bitlbee "${ROOT}"/var/run/bitlbee
+
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ einfo
+ elog "The bitlbee init script will now attempt to stop all processes owned by the"
+ elog "bitlbee user, including per-client forks."
+ elog
+ elog "Tell the init script not to touch anything besides the main bitlbee process"
+ elog "by changing the BITLBEE_STOP_ALL variable in"
+ elog " /etc/conf.d/bitlbee"
+ einfo
+ fi
}