summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-im/openmittsu')
-rw-r--r--net-im/openmittsu/Manifest1
-rw-r--r--net-im/openmittsu/files/openmittsu-0.9.2_p78-fmt.patch49
-rw-r--r--net-im/openmittsu/openmittsu-0.9.2_p78.ebuild54
3 files changed, 0 insertions, 104 deletions
diff --git a/net-im/openmittsu/Manifest b/net-im/openmittsu/Manifest
index c847b403d4da..a9665a163c40 100644
--- a/net-im/openmittsu/Manifest
+++ b/net-im/openmittsu/Manifest
@@ -1,2 +1 @@
-DIST openMittsu-0.9.2_p78.tar.xz 1304908 SHA256 9be2d1e35a5995786f0c02383e0aaccd67f8848743417020f70d814f464ecc85 SHA512 4969667bd7430dc5b7d0d756ae5f8f8f64ebd717645a6288a46f49f9b03930d6aceac3a9b3d507e12d0a35b69226e19ec65792af23e5e402cf6c7f693bae145c WHIRLPOOL 4903f37a7ea9addc1739940138d50a6caf716810016900edc107b0f02538f10322040ef734e6159cd099347ac2a988bafc778c3c8a0accd26d3bace4a0930a2c
DIST openMittsu-0.9.2_p82.tar.xz 1313600 SHA256 3fefd9c9a67cede57e9f310c39d7547cd622a859511d5e7af12261d2fd4b337b SHA512 c50e5618a282833d472c1d176d928dc2902d2d0a5e65bf4524af48ae17ba45e002fac5d3bceefaf8a4007eee3749976c680fd168c865c4b5e2e2e2c532d5f600 WHIRLPOOL f3290289aa0f8a59c391f127561418a0103c00a664fff27db67c73125ba772f675e71db17fa7a3fa8a25c127527f66339e2d0cd4fa095d2746a13b9b905a6908
diff --git a/net-im/openmittsu/files/openmittsu-0.9.2_p78-fmt.patch b/net-im/openmittsu/files/openmittsu-0.9.2_p78-fmt.patch
deleted file mode 100644
index 19b55701e83d..000000000000
--- a/net-im/openmittsu/files/openmittsu-0.9.2_p78-fmt.patch
+++ /dev/null
@@ -1,49 +0,0 @@
-https://bugs.gentoo.org/609366
-Backported from https://github.com/fmtlib/fmt.git:
-
-commit abbefd71666055daac9e14e78262620f9e845850
-Author: Victor Zverovich <victor.zverovich@gmail.com>
-Date: Wed Oct 19 06:52:55 2016 -0700
-
- CHAR_WIDTH -> CHAR_SIZE to avoid collision with ISO/IEC TS 18661-1:2014 macro
-
---- openMittsu-0.9.2_p78-orig/3rdparty/spdlog/include/spdlog/details/format.h
-+++ openMittsu-0.9.2_p78/3rdparty/spdlog/include/spdlog/details/format.h
-@@ -2163,29 +2163,29 @@
- typedef typename BasicWriter<Char>::CharPtr CharPtr;
- Char fill = internal::CharTraits<Char>::cast(spec_.fill());
- CharPtr out = CharPtr();
-- const unsigned CHAR_WIDTH = 1;
-- if (spec_.width_ > CHAR_WIDTH)
-+ const unsigned CHAR_SIZE = 1;
-+ if (spec_.width_ > CHAR_SIZE)
- {
- out = writer_.grow_buffer(spec_.width_);
- if (spec_.align_ == ALIGN_RIGHT)
- {
-- std::uninitialized_fill_n(out, spec_.width_ - CHAR_WIDTH, fill);
-- out += spec_.width_ - CHAR_WIDTH;
-+ std::uninitialized_fill_n(out, spec_.width_ - CHAR_SIZE, fill);
-+ out += spec_.width_ - CHAR_SIZE;
- }
- else if (spec_.align_ == ALIGN_CENTER)
- {
- out = writer_.fill_padding(out, spec_.width_,
-- internal::check(CHAR_WIDTH), fill);
-+ internal::check(CHAR_SIZE), fill);
- }
- else
- {
-- std::uninitialized_fill_n(out + CHAR_WIDTH,
-- spec_.width_ - CHAR_WIDTH, fill);
-+ std::uninitialized_fill_n(out + CHAR_SIZE,
-+ spec_.width_ - CHAR_SIZE, fill);
- }
- }
- else
- {
-- out = writer_.grow_buffer(CHAR_WIDTH);
-+ out = writer_.grow_buffer(CHAR_SIZE);
- }
- *out = internal::CharTraits<Char>::cast(value);
- }
diff --git a/net-im/openmittsu/openmittsu-0.9.2_p78.ebuild b/net-im/openmittsu/openmittsu-0.9.2_p78.ebuild
deleted file mode 100644
index 3cbd7a1482bd..000000000000
--- a/net-im/openmittsu/openmittsu-0.9.2_p78.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=6
-
-inherit cmake-utils eutils
-
-MY_PN="openMittsu"
-DESCRIPTION="An open source chat client for Threema-style end-to-end encrypted chat networks"
-HOMEPAGE="https://www.openmittsu.de/"
-# git-archive-all.sh snapshot of https://github.com/blizzard4591/${MY_PN}.git
-SRC_URI="https://dev.gentoo.org/~ulm/distfiles/${MY_PN}-${PV}.tar.xz"
-
-LICENSE="GPL-2+ BitstreamVera OFL-1.1 Apache-2.0 CC0-1.0 MIT BSD-2 Boost-1.0"
-SLOT="0"
-KEYWORDS="~amd64"
-
-DEPEND=">=dev-libs/libsodium-1.0.11:=
- >=dev-qt/qtcore-5.7.1:5=
- >=dev-qt/qtgui-5.7.1:5=
- >=dev-qt/qtmultimedia-5.7.1:5=
- >=dev-qt/qtnetwork-5.7.1:5=
- >=dev-qt/qtwidgets-5.7.1:5=
- >=media-gfx/qrencode-3.4.4-r1"
-RDEPEND="${DEPEND}"
-
-S="${WORKDIR}/${MY_PN}-${PV}"
-
-DOCS=(
- README.md
- Example-client-configuration-file.ini
- Example-contacts-file.txt
-)
-
-src_prepare() {
- # set version manually, since autodetection works only with git
- sed -i "/git_describe_checkout/\
- s/.*/set(OPENMITTSU_GIT_VERSION_STRING \"${PV/_p/-}-00000000\")/" \
- CMakeLists.txt || die
- eapply "${FILESDIR}"/${P}-fmt.patch
- cmake-utils_src_prepare
-}
-
-src_configure() {
- local mycmakeargs=("-DOPENMITTSU_DISABLE_VERSION_UPDATE_CHECK=ON")
- cmake-utils_src_configure
-}
-
-src_install() {
- cmake-utils_src_install
- newicon resources/icon.png ${MY_PN}.png
- make_desktop_entry ${MY_PN} ${MY_PN} ${MY_PN}
-}