summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-im/telepathy-mission-control')
-rw-r--r--net-im/telepathy-mission-control/Manifest2
-rw-r--r--net-im/telepathy-mission-control/metadata.xml14
-rw-r--r--net-im/telepathy-mission-control/telepathy-mission-control-5.16.2.ebuild50
-rw-r--r--net-im/telepathy-mission-control/telepathy-mission-control-5.16.3.ebuild50
4 files changed, 116 insertions, 0 deletions
diff --git a/net-im/telepathy-mission-control/Manifest b/net-im/telepathy-mission-control/Manifest
new file mode 100644
index 000000000000..08ddd7f0aac7
--- /dev/null
+++ b/net-im/telepathy-mission-control/Manifest
@@ -0,0 +1,2 @@
+DIST telepathy-mission-control-5.16.2.tar.gz 1095760 SHA256 3dcbf8d26cd19e77ef9296c9ae501f8af6cd59aeb058f0a3d5eb75e5647268ea SHA512 6016e877db02a719846543323b3ee1336bbb0f345f9b08120c211cae3308e67adb5b0131c04c518b6a44c9ead3b996429d70c5266ced2dad5f4e5a69544d86f8 WHIRLPOOL 09ac8e351f0d550a953b30bb3c0d2e4f76f3b187159d69b6a465935d6b46d31613a644cbe590f8c6428b7dde52c04087860992b95a9c6a3f1c6972c1073bd622
+DIST telepathy-mission-control-5.16.3.tar.gz 1096019 SHA256 71575d2ff8aa7337aca355e3d921eba5cd2ff050fabc01e51577343093e98b7d SHA512 4cf8b387e74aa11536dfcc607a2bef4b1b594fb027753fc8bb702c27251ccbb611b80724f4f5b95c6cd347c53df4f0474fcc0dd4ee42313f8b655c2a745231ad WHIRLPOOL 4a905ee2b8bc92803735cdd837bd921e01236136433314e64b0c14689d7784d69495673a587134f650932769aafaabc6990f52f4a2c9ccc35427c02511bc1b8e
diff --git a/net-im/telepathy-mission-control/metadata.xml b/net-im/telepathy-mission-control/metadata.xml
new file mode 100644
index 000000000000..5265d716d02c
--- /dev/null
+++ b/net-im/telepathy-mission-control/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>gnome</herd>
+<herd>net-im</herd>
+<longdescription>Mission Control, or MC, is a telepathy component providing a
+way for "end-user" applications to abstract some of the details of connection
+managers, to provide a simple way to manipulate a bunch of connection managers
+at once, and to remove the need to have in each program the account
+definitions and credentials.</longdescription>
+<use>
+ <flag name="systemd">Rely on systemd's logind to detect suspend and resume</flag>
+</use>
+</pkgmetadata>
diff --git a/net-im/telepathy-mission-control/telepathy-mission-control-5.16.2.ebuild b/net-im/telepathy-mission-control/telepathy-mission-control-5.16.2.ebuild
new file mode 100644
index 000000000000..75a9acba1256
--- /dev/null
+++ b/net-im/telepathy-mission-control/telepathy-mission-control-5.16.2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+# Needed for tests and build #489466
+PYTHON_COMPAT=( python2_7 )
+
+inherit gnome2 python-any-r1
+
+DESCRIPTION="An account manager and channel dispatcher for the Telepathy framework"
+HOMEPAGE="http://cgit.freedesktop.org/telepathy/telepathy-mission-control/"
+SRC_URI="http://telepathy.freedesktop.org/releases/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ia64 ppc ppc64 sparc x86 ~amd64-linux ~arm-linux ~x86-linux"
+IUSE="debug networkmanager systemd upower" # test
+
+RDEPEND="
+ >=dev-libs/dbus-glib-0.82
+ >=dev-libs/glib-2.32:2
+ >=sys-apps/dbus-0.95
+ >=net-libs/telepathy-glib-0.20
+ networkmanager? ( >=net-misc/networkmanager-0.7 )
+ !systemd? ( upower? ( >=sys-power/upower-pm-utils-0.9.23 ) )
+"
+DEPEND="${RDEPEND}
+ ${PYTHON_DEPS}
+ dev-libs/libxslt
+ >=dev-util/gtk-doc-am-1.17
+ virtual/pkgconfig
+"
+# test? ( dev-python/twisted-words )"
+
+# Tests are broken, see upstream bug #29334 and #64212
+# upstream doesn't want it enabled everywhere (#29334#c12)
+RESTRICT="test"
+
+src_configure() {
+ # creds is not available
+ gnome2_src_configure \
+ --disable-static \
+ $(use_enable debug) \
+ $(use_with networkmanager connectivity nm) \
+ $(use_enable upower) \
+ $(use systemd && echo "--disable-upower")
+}
diff --git a/net-im/telepathy-mission-control/telepathy-mission-control-5.16.3.ebuild b/net-im/telepathy-mission-control/telepathy-mission-control-5.16.3.ebuild
new file mode 100644
index 000000000000..75a9acba1256
--- /dev/null
+++ b/net-im/telepathy-mission-control/telepathy-mission-control-5.16.3.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+# Needed for tests and build #489466
+PYTHON_COMPAT=( python2_7 )
+
+inherit gnome2 python-any-r1
+
+DESCRIPTION="An account manager and channel dispatcher for the Telepathy framework"
+HOMEPAGE="http://cgit.freedesktop.org/telepathy/telepathy-mission-control/"
+SRC_URI="http://telepathy.freedesktop.org/releases/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ia64 ppc ppc64 sparc x86 ~amd64-linux ~arm-linux ~x86-linux"
+IUSE="debug networkmanager systemd upower" # test
+
+RDEPEND="
+ >=dev-libs/dbus-glib-0.82
+ >=dev-libs/glib-2.32:2
+ >=sys-apps/dbus-0.95
+ >=net-libs/telepathy-glib-0.20
+ networkmanager? ( >=net-misc/networkmanager-0.7 )
+ !systemd? ( upower? ( >=sys-power/upower-pm-utils-0.9.23 ) )
+"
+DEPEND="${RDEPEND}
+ ${PYTHON_DEPS}
+ dev-libs/libxslt
+ >=dev-util/gtk-doc-am-1.17
+ virtual/pkgconfig
+"
+# test? ( dev-python/twisted-words )"
+
+# Tests are broken, see upstream bug #29334 and #64212
+# upstream doesn't want it enabled everywhere (#29334#c12)
+RESTRICT="test"
+
+src_configure() {
+ # creds is not available
+ gnome2_src_configure \
+ --disable-static \
+ $(use_enable debug) \
+ $(use_with networkmanager connectivity nm) \
+ $(use_enable upower) \
+ $(use systemd && echo "--disable-upower")
+}