summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-im/telepathy-mission-control')
-rw-r--r--net-im/telepathy-mission-control/Manifest1
-rw-r--r--net-im/telepathy-mission-control/telepathy-mission-control-5.16.4.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/net-im/telepathy-mission-control/Manifest b/net-im/telepathy-mission-control/Manifest
index 7828d8e7e773..c3606ce81c08 100644
--- a/net-im/telepathy-mission-control/Manifest
+++ b/net-im/telepathy-mission-control/Manifest
@@ -1 +1,2 @@
DIST telepathy-mission-control-5.16.3.tar.gz 1096019 SHA256 71575d2ff8aa7337aca355e3d921eba5cd2ff050fabc01e51577343093e98b7d SHA512 4cf8b387e74aa11536dfcc607a2bef4b1b594fb027753fc8bb702c27251ccbb611b80724f4f5b95c6cd347c53df4f0474fcc0dd4ee42313f8b655c2a745231ad WHIRLPOOL 4a905ee2b8bc92803735cdd837bd921e01236136433314e64b0c14689d7784d69495673a587134f650932769aafaabc6990f52f4a2c9ccc35427c02511bc1b8e
+DIST telepathy-mission-control-5.16.4.tar.gz 1102177 SHA256 9769ddac7ad8aad21f6db854016792162b57e6fa0b0aed8d823d76a71fe7e6cb SHA512 5ed624df2d041554af074c22a18db2405fa5bd41bec40edc574382eb9d8b9f93ff6f4be3042d27f950694a353f4192670e200f5f8865419701ca520a973959ed WHIRLPOOL 7672345d3ac76c879c22c2a5cb0180a5fe4bc03403f1e5d934a3b3944ec75eb6c0c6f17610f9619acc6a35892d16dd2c642fc85d2dbf3659f058da9c49aa717e
diff --git a/net-im/telepathy-mission-control/telepathy-mission-control-5.16.4.ebuild b/net-im/telepathy-mission-control/telepathy-mission-control-5.16.4.ebuild
new file mode 100644
index 000000000000..09546c37922f
--- /dev/null
+++ b/net-im/telepathy-mission-control/telepathy-mission-control-5.16.4.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+GNOME2_LA_PUNT="yes"
+# Needed for tests and build #489466
+PYTHON_COMPAT=( python2_7 )
+
+inherit gnome2 python-any-r1
+
+DESCRIPTION="An account manager and channel dispatcher for the Telepathy framework"
+HOMEPAGE="https://cgit.freedesktop.org/telepathy/telepathy-mission-control/"
+SRC_URI="https://telepathy.freedesktop.org/releases/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~arm-linux ~x86-linux"
+IUSE="debug networkmanager" # test
+
+RDEPEND="
+ >=dev-libs/dbus-glib-0.82
+ >=dev-libs/glib-2.46:2
+ >=sys-apps/dbus-0.95
+ >=net-libs/telepathy-glib-0.20
+ networkmanager? ( >=net-misc/networkmanager-1:= )
+"
+DEPEND="${RDEPEND}
+ ${PYTHON_DEPS}
+ dev-libs/libxslt
+ >=dev-util/gtk-doc-am-1.17
+ virtual/pkgconfig
+"
+# test? ( dev-python/twisted-words )"
+
+# Tests are broken, see upstream bug #29334 and #64212
+# upstream doesn't want it enabled everywhere (#29334#c12)
+RESTRICT="test"
+
+src_configure() {
+ # creds is not available
+ gnome2_src_configure \
+ --disable-static \
+ --disable-upower \
+ $(use_enable debug) \
+ $(use_with networkmanager connectivity nm)
+}