summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
Diffstat (limited to 'net-im')
-rw-r--r--net-im/skypeforlinux/Manifest1
-rw-r--r--net-im/skypeforlinux/skypeforlinux-8.51.0.92.ebuild102
2 files changed, 103 insertions, 0 deletions
diff --git a/net-im/skypeforlinux/Manifest b/net-im/skypeforlinux/Manifest
index fddec433ed94..c4a91acc489a 100644
--- a/net-im/skypeforlinux/Manifest
+++ b/net-im/skypeforlinux/Manifest
@@ -1,2 +1,3 @@
DIST skypeforlinux_8.51.0.72-1.x86_64.rpm 106489177 BLAKE2B 18a84af205dfdca719d15e37c2cf19a039dfb521e7458c02271dae5eb9dd6433d14ec5fcb1501c74fbcf90103745e3ae49e5d290c699866d94430b2662eac7cf SHA512 18c98a040d453be83cafeca39009e07db2319dab5f2738dc98e2b7c6966dd2d59e83d0c8a943bfa3dd19b7cd435b7dcfa097f9725850148cb493cdc992a6550e
DIST skypeforlinux_8.51.0.86-1.x86_64.rpm 106489312 BLAKE2B b0baf0f55808bcda30a5cc568a47e9514e8f9188659e6a7eb1b58722851edb7cab4c48d31889b6d3a2e16ffd89c563c92f0753fd0a2224b340d6f2239b45eec5 SHA512 a58b7b5a03d1ab665322d1af6ac2f65d452789192a8497e3638823e3a29e9e253193ad6fffbd8497f50253084c3c3a73e1cfe7a8384209fd7d33e45975584b20
+DIST skypeforlinux_8.51.0.92-1.x86_64.rpm 106489251 BLAKE2B 1846623eb9ab78bf143b9a45bf2001fb3ae4b78ac1690041b984f96f309f57ac427f1313722de02d3305cab4413f40470a9452f1d87a47b3e3af1d0878eecabb SHA512 58c86e19900badec28e0bc58ed23459aea8e94e6f0d36fd8d8412d99d96eec15945a9b4920278788e5edccc6cc26ec7da9159d7105ff4499f9c6e44d3e4615ac
diff --git a/net-im/skypeforlinux/skypeforlinux-8.51.0.92.ebuild b/net-im/skypeforlinux/skypeforlinux-8.51.0.92.ebuild
new file mode 100644
index 000000000000..df398450e030
--- /dev/null
+++ b/net-im/skypeforlinux/skypeforlinux-8.51.0.92.ebuild
@@ -0,0 +1,102 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MULTILIB_COMPAT=( abi_x86_64 )
+
+inherit desktop pax-utils rpm multilib-build xdg
+
+DESCRIPTION="Instant messaging client, with support for audio and video"
+HOMEPAGE="https://www.skype.com/"
+SRC_URI="https://repo.skype.com/rpm/stable/${PN}_${PV}-1.x86_64.rpm"
+
+LICENSE="Skype-TOS MIT MIT-with-advertising BSD-1 BSD-2 BSD Apache-2.0 Boost-1.0 ISC CC-BY-SA-3.0 CC0-1.0 openssl ZLIB APSL-2 icu Artistic-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="-* ~amd64"
+IUSE="pax_kernel"
+
+S="${WORKDIR}"
+QA_PREBUILT="*"
+RESTRICT="mirror bindist strip" #299368
+
+RDEPEND="
+ || (
+ sys-auth/elogind
+ sys-apps/systemd
+ )
+ app-crypt/libsecret[${MULTILIB_USEDEP}]
+ dev-libs/atk[${MULTILIB_USEDEP}]
+ dev-libs/expat[${MULTILIB_USEDEP}]
+ dev-libs/glib:2[${MULTILIB_USEDEP}]
+ dev-libs/nspr[${MULTILIB_USEDEP}]
+ dev-libs/nss[${MULTILIB_USEDEP}]
+ media-libs/alsa-lib[${MULTILIB_USEDEP}]
+ media-libs/fontconfig:1.0[${MULTILIB_USEDEP}]
+ media-libs/freetype:2[${MULTILIB_USEDEP}]
+ media-libs/libv4l[${MULTILIB_USEDEP}]
+ net-print/cups[${MULTILIB_USEDEP}]
+ sys-apps/dbus[${MULTILIB_USEDEP}]
+ sys-devel/gcc[cxx]
+ virtual/ttf-fonts
+ x11-libs/cairo[${MULTILIB_USEDEP}]
+ x11-libs/gdk-pixbuf:2[${MULTILIB_USEDEP}]
+ x11-libs/gtk+:3[${MULTILIB_USEDEP}]
+ x11-libs/libX11[${MULTILIB_USEDEP}]
+ x11-libs/libXScrnSaver[${MULTILIB_USEDEP}]
+ x11-libs/libXcomposite[${MULTILIB_USEDEP}]
+ x11-libs/libXcursor[${MULTILIB_USEDEP}]
+ x11-libs/libXdamage[${MULTILIB_USEDEP}]
+ x11-libs/libXext[${MULTILIB_USEDEP}]
+ x11-libs/libXfixes[${MULTILIB_USEDEP}]
+ x11-libs/libXi[${MULTILIB_USEDEP}]
+ x11-libs/libXrandr[${MULTILIB_USEDEP}]
+ x11-libs/libXrender[${MULTILIB_USEDEP}]
+ x11-libs/libXtst[${MULTILIB_USEDEP}]
+ x11-libs/libxcb[${MULTILIB_USEDEP}]
+ x11-libs/libxkbfile[${MULTILIB_USEDEP}]
+ x11-libs/pango[${MULTILIB_USEDEP}]"
+
+src_unpack() {
+ rpm_src_unpack ${A}
+}
+
+src_prepare() {
+ default
+ sed -e "s!^SKYPE_PATH=.*!SKYPE_PATH=${EPREFIX}/opt/skypeforlinux/skypeforlinux!" \
+ -i usr/bin/skypeforlinux || die
+ sed -e "s!^Categories=.*!Categories=Network;InstantMessaging;Telephony;!" \
+ -e "/^OnlyShowIn=/d" \
+ -i usr/share/applications/skypeforlinux.desktop || die
+}
+
+src_install() {
+ dodir /opt
+ cp -a usr/share/skypeforlinux "${D}"/opt || die
+
+ dobin usr/bin/skypeforlinux
+
+ dodoc usr/share/skypeforlinux/*.html
+ dodoc -r usr/share/doc/skypeforlinux/.
+ # symlink required for the "Help->3rd Party Notes" menu entry (otherwise frozen skype -> xdg-open)
+ dosym ${PF} usr/share/doc/skypeforlinux
+
+ doicon usr/share/pixmaps/skypeforlinux.png
+
+ local res
+ for res in 16 32 256 512; do
+ newicon -s ${res} usr/share/icons/hicolor/${res}x${res}/apps/skypeforlinux.png skypeforlinux.png
+ done
+
+ domenu usr/share/applications/skypeforlinux.desktop
+
+ if use pax_kernel; then
+ pax-mark -m "${ED}"/opt/skypeforlinux/skypeforlinux
+ pax-mark -m "${ED}"/opt/skypeforlinux/resources/app.asar.unpacked/node_modules/slimcore/bin/slimcore.node
+ ewarn "You have set USE=pax_kernel meaning that you intend to run"
+ ewarn "${PN} under a PaX enabled kernel. To do so, we must modify"
+ ewarn "the ${PN} binary itself and this *may* lead to breakage! If"
+ ewarn "you suspect that ${PN} is being broken by this modification,"
+ ewarn "please open a bug."
+ fi
+}