summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/gnome-online-accounts')
-rw-r--r--net-libs/gnome-online-accounts/Manifest1
-rw-r--r--net-libs/gnome-online-accounts/gnome-online-accounts-3.26.2.ebuild94
2 files changed, 95 insertions, 0 deletions
diff --git a/net-libs/gnome-online-accounts/Manifest b/net-libs/gnome-online-accounts/Manifest
index 38f48640409b..979a4feb1f06 100644
--- a/net-libs/gnome-online-accounts/Manifest
+++ b/net-libs/gnome-online-accounts/Manifest
@@ -1,2 +1,3 @@
DIST gnome-online-accounts-3.24.4.tar.xz 1412004 BLAKE2B 96e92eefeedb94563af755367b4932469d8a55bd545324bb1ebffb4798bd0a499aafe9523abc7c707342b1c78f912c499335708dfb3f9a149567b64877f0bbd9 SHA512 6e12f03d3ff9b9c831705f0310923b2c3e0daeee1304bb3dfa52fd17d6df49656f3380a1ffd9f30f75890340fb7ee23f53789e4df357a0aeba4e31667fd9c45a
DIST gnome-online-accounts-3.24.5.tar.xz 1391332 BLAKE2B 9085cbb0c92bfcd338d5feca7ebdd3e3b15483e47fe29faffb8f9fb474663adeaf8d5cc81673c552652c9444e742f2782fd727c93bf488f5c976bde72d00ddce SHA512 8db35d21f0639e7452ec5cb34455b6d48a77fe0755c525f22e5235abe758f09ad5a4685e5e4912a53def298c76a13b558704a83803b5aabecc13a0f9bc3ae0e4
+DIST gnome-online-accounts-3.26.2.tar.xz 1405424 BLAKE2B 99b6bae527809e3c37248b35c0783e8f884577d93d1de04537f19cc2776f6204242469e78b51198c062272736c676bc67e1a3ef1cc4325eea94bb505e060ff0b SHA512 be1a9f4e1944f19937c2718db64c6968fb1f7538cdb6f7ecfa0b48136d37b1aa0c8054ff7a91cf037fac72f1e8ac7b59b69af3db39c585674113538dccf19114
diff --git a/net-libs/gnome-online-accounts/gnome-online-accounts-3.26.2.ebuild b/net-libs/gnome-online-accounts/gnome-online-accounts-3.26.2.ebuild
new file mode 100644
index 000000000000..cb8b8feecd49
--- /dev/null
+++ b/net-libs/gnome-online-accounts/gnome-online-accounts-3.26.2.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+GNOME2_LA_PUNT="yes"
+VALA_USE_DEPEND="vapigen"
+
+inherit gnome2 vala
+
+DESCRIPTION="GNOME framework for accessing online accounts"
+HOMEPAGE="https://wiki.gnome.org/Projects/GnomeOnlineAccounts"
+
+LICENSE="LGPL-2+"
+SLOT="0/1"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+IUSE="debug gnome +introspection kerberos vala" # telepathy"
+REQUIRED_USE="vala? ( introspection )"
+
+# pango used in goaeditablelabel
+# libsoup used in goaoauthprovider
+# goa kerberos provider is incompatible with app-crypt/heimdal, see
+# https://bugzilla.gnome.org/show_bug.cgi?id=692250
+# json-glib-0.16 needed for bug #485092
+RDEPEND="
+ >=dev-libs/glib-2.52:2
+ >=app-crypt/libsecret-0.5
+ >=dev-libs/json-glib-0.16
+ dev-libs/libxml2:2
+ >=net-libs/libsoup-2.42:2.4
+ net-libs/rest:0.7
+ net-libs/telepathy-glib
+ >=net-libs/webkit-gtk-2.7.2:4
+ >=x11-libs/gtk+-3.19.12:3
+ x11-libs/pango
+
+ introspection? ( >=dev-libs/gobject-introspection-0.6.2:= )
+ kerberos? (
+ app-crypt/gcr:0=[gtk]
+ app-crypt/mit-krb5 )
+"
+# telepathy? ( net-libs/telepathy-glib )
+# goa-daemon can launch gnome-control-center
+PDEPEND="gnome? ( >=gnome-base/gnome-control-center-3.2[gnome-online-accounts(+)] )"
+
+DEPEND="${RDEPEND}
+ vala? ( $(vala_depend) )
+ dev-libs/libxslt
+ >=dev-util/gtk-doc-am-1.3
+ >=dev-util/gdbus-codegen-2.30.0
+ >=dev-util/intltool-0.50.1
+ sys-devel/gettext
+ virtual/pkgconfig
+
+ dev-libs/gobject-introspection-common
+ gnome-base/gnome-common
+"
+# eautoreconf needs gobject-introspection-common, gnome-common
+
+# Due to sub-configure
+QA_CONFIGURE_OPTIONS=".*"
+
+src_prepare() {
+ use vala && vala_src_prepare
+ gnome2_src_prepare
+}
+
+src_configure() {
+ # TODO: Give users a way to set the G/FB/Windows Live secrets
+ # telepathy optional support is really a badly one, bug #494456 - now default disabled upstream - revisit soon
+ gnome2_src_configure \
+ --disable-static \
+ --enable-backend \
+ --enable-documentation \
+ --enable-exchange \
+ --enable-facebook \
+ --enable-flickr \
+ --enable-foursquare \
+ --enable-imap-smtp \
+ --enable-lastfm \
+ --enable-media-server \
+ --enable-owncloud \
+ --enable-pocket \
+ --enable-telepathy \
+ --enable-todoist \
+ --enable-windows-live \
+ $(usex debug --enable-debug=yes ' ') \
+ $(use_enable kerberos) \
+ $(use_enable introspection) \
+ $(use_enable vala)
+ #$(use_enable telepathy)
+ # gudev & cheese from sub-configure is overriden
+ # by top level configure, and disabled so leave it like that
+}