summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/libprotoident')
-rw-r--r--net-libs/libprotoident/Manifest1
-rw-r--r--net-libs/libprotoident/libprotoident-2.0.11.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/net-libs/libprotoident/Manifest b/net-libs/libprotoident/Manifest
index 0636f1c9ca1e..6cf11dfc27b4 100644
--- a/net-libs/libprotoident/Manifest
+++ b/net-libs/libprotoident/Manifest
@@ -1 +1,2 @@
DIST libprotoident-2.0.10.tar.gz 534718 SHA256 a5ef504967c34fa07ed967b3a629a9df2768eb9da799858ceecd8026ca1efceb SHA512 88f2088cc4662fc02ee3d70c86e55ced716ff62a2fb7479ee04f55f78a34bea7346d81cc01663ef61f2fe29cffc4c1bc6ddca34c45abb93c9929d9422df0db22 WHIRLPOOL 9689d7ce90643d4b4d5173596c0c448af46c7b1e7f311b9296372c569bce7a6d57fd5aec34c286ee5ea4815202d56317836cbef6d9571aff54e2fe6fda492ef3
+DIST libprotoident-2.0.11.tar.gz 561267 SHA256 796d59ec0a48ee88d386d4f0a393a80df01184a92bbbb8c2aa2e2fc10741840a SHA512 9f3dbc44dd41ed66c18d187b543d9b0da7e778a127b1191cf851a3c6d79f14d07a40fccf79377a3e17ee7c707c17b1049f4afb9f4d041b66c0b3170fa721fc8b WHIRLPOOL 71f48966b8af7a1ed36eaa6028d7e9224338b6fb35f79b0b246bbf97dd0ac267dd5c66116c89c54d672080fc420ff78a9c62998a4561c38e01a2ff3abf929a95
diff --git a/net-libs/libprotoident/libprotoident-2.0.11.ebuild b/net-libs/libprotoident/libprotoident-2.0.11.ebuild
new file mode 100644
index 000000000000..0eb230f26ce9
--- /dev/null
+++ b/net-libs/libprotoident/libprotoident-2.0.11.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit eutils
+
+DESCRIPTION="A library that performs application layer protocol identification for flows"
+HOMEPAGE="http://research.wand.net.nz/software/libprotoident.php"
+SRC_URI="http://research.wand.net.nz/software/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-3+"
+SLOT="0/2"
+KEYWORDS="~amd64 ~x86"
+IUSE="static-libs tools"
+
+DEPEND="
+ >=net-libs/libtrace-4.0.1
+ >=net-libs/libflowmanager-3.0.0
+"
+RDEPEND="
+ ${DEPEND}
+"
+
+src_prepare() {
+ default
+
+ sed -i \
+ -e '/-Werror/d' \
+ lib/Makefile{.am,.in} || die
+}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ $(use_with tools)
+}
+
+src_install() {
+ default
+ prune_libtool_files
+}